NRenoiseTools Namespace

[image]

.NET Framework Class Library
NRenoiseTools Namespace
Send Feedback

Classes

Class Description
AudioPluginDevice
AudioPluginDeviceDeviceSlotRunTimePreset
AudioPluginDeviceRunTimePreset
AutoAmp
Automations
BusCompressorDevice
BusCompressorDeviceAttack
BusCompressorDeviceAttackRunTimePreset
BusCompressorDeviceDeviceSlotRunTimePreset
BusCompressorDeviceKnee
BusCompressorDeviceKneeRunTimePreset
BusCompressorDeviceMakeUp
BusCompressorDeviceMakeUpRunTimePreset
BusCompressorDeviceRatio
BusCompressorDeviceRatioRunTimePreset
BusCompressorDeviceRelease
BusCompressorDeviceReleaseRunTimePreset
BusCompressorDeviceRunTimePreset
BusCompressorDeviceThreshold
BusCompressorDeviceThresholdRunTimePreset
ChorusDevice
ChorusDeviceDelay
ChorusDeviceDelayRunTimePreset
ChorusDeviceDeviceSlotRunTimePreset
ChorusDeviceDryWetMix
ChorusDeviceDryWetMixRunTimePreset
ChorusDeviceFeedback
ChorusDeviceFeedbackRunTimePreset
ChorusDeviceFilterFreq
ChorusDeviceFilterFreqRunTimePreset
ChorusDeviceFilterResonance
ChorusDeviceFilterResonanceRunTimePreset
ChorusDeviceFilterType
ChorusDeviceFilterTypeRunTimePreset
ChorusDeviceLfoDepth
ChorusDeviceLfoDepthRunTimePreset
ChorusDeviceLfoRate
ChorusDeviceLfoRateRunTimePreset
ChorusDevicePhase
ChorusDevicePhaseRunTimePreset
ChorusDeviceRunTimePreset
CompressorDevice
CompressorDeviceAttack
CompressorDeviceAttackRunTimePreset
CompressorDeviceDeviceSlotRunTimePreset
CompressorDeviceGain
CompressorDeviceGainRunTimePreset
CompressorDeviceLogThreshold
CompressorDeviceLogThresholdRunTimePreset
CompressorDeviceRatio
CompressorDeviceRatioRunTimePreset
CompressorDeviceRelease
CompressorDeviceReleaseRunTimePreset
CompressorDeviceRunTimePreset
CustomEnvelope
CutoffNodes
DcOffsetDevice
DcOffsetDeviceAutoDC
DcOffsetDeviceAutoDCRunTimePreset
DcOffsetDeviceDCOffset
DcOffsetDeviceDCOffsetRunTimePreset
DcOffsetDeviceDeviceSlotRunTimePreset
DcOffsetDeviceRunTimePreset
DelayDevice
DelayDeviceDeviceSlotRunTimePreset
DelayDeviceLDelay
DelayDeviceLDelayRunTimePreset
DelayDeviceLFeedback
DelayDeviceLFeedbackRunTimePreset
DelayDeviceLineSync
DelayDeviceLineSyncRunTimePreset
DelayDeviceLSyncOffset
DelayDeviceLSyncOffsetRunTimePreset
DelayDeviceLSyncTime
DelayDeviceLSyncTimeRunTimePreset
DelayDeviceLTapPan
DelayDeviceLTapPanRunTimePreset
DelayDeviceMuteDrySignal
DelayDeviceMuteDrySignalRunTimePreset
DelayDeviceRDelay
DelayDeviceRDelayRunTimePreset
DelayDeviceRFeedback
DelayDeviceRFeedbackRunTimePreset
DelayDeviceRSyncOffset
DelayDeviceRSyncOffsetRunTimePreset
DelayDeviceRSyncTime
DelayDeviceRSyncTimeRunTimePreset
DelayDeviceRTapPan
DelayDeviceRTapPanRunTimePreset
DelayDeviceRunTimePreset
DelayDeviceTrackSend
DelayDeviceTrackSendRunTimePreset
DestEffect
DestParameter
DeviceSlotRunTimePreset
Distortion2DeviceDeviceSlotRunTimePreset
Distortion2DeviceDistortionDevice
Distortion2DeviceDrive
Distortion2DeviceDriveRunTimePreset
Distortion2DeviceDryOut
Distortion2DeviceDryOutRunTimePreset
Distortion2DeviceRunTimePreset
Distortion2DeviceTone
Distortion2DeviceToneRunTimePreset
Distortion2DeviceType
Distortion2DeviceTypeRunTimePreset
Distortion2DeviceWetOut
Distortion2DeviceWetOutRunTimePreset
DistortionDeviceDeviceSlotRunTimePreset
DistortionDeviceDistortionDevice
DistortionDeviceDryOut
DistortionDeviceDryOutRunTimePreset
DistortionDeviceGateOrFilter
DistortionDeviceGateOrFilterRunTimePreset
DistortionDeviceLpOrClamp
DistortionDeviceLpOrClampRunTimePreset
DistortionDeviceRunTimePreset
DistortionDeviceThreshold
DistortionDeviceThresholdRunTimePreset
DistortionDeviceType
DistortionDeviceTypeRunTimePreset
DistortionDeviceWetOut
DistortionDeviceWetOutRunTimePreset
EffectColumn
EnvelopeData
EnvelopeItem
Envelopes
EnvelopesCutoff
EnvelopesPan
EnvelopesResonance
EnvelopesVolume
Eq10DeviceDeviceSlotRunTimePreset
Eq10DeviceEqDevice
Eq10DeviceGain
Eq10DeviceGainRunTimePreset
Eq10DeviceRunTimePreset
Eq5DeviceDeviceSlotRunTimePreset
Eq5DeviceEqDevice
Eq5DeviceGain
Eq5DeviceGainRunTimePreset
Eq5DeviceRunTimePreset
Filter1DeviceCutoff
Filter1DeviceCutoffRunTimePreset
Filter1DeviceDeviceSlotRunTimePreset
Filter1DeviceFilterDevice
Filter1DeviceInnertia
Filter1DeviceInnertiaRunTimePreset
Filter1DeviceResonance
Filter1DeviceResonanceRunTimePreset
Filter1DeviceRunTimePreset
Filter1DeviceType
Filter1DeviceTypeRunTimePreset
Filter2DeviceCutoff
Filter2DeviceCutoffRunTimePreset
Filter2DeviceDeviceSlotRunTimePreset
Filter2DeviceFilterDevice
Filter2DeviceInnertia
Filter2DeviceInnertiaRunTimePreset
Filter2DeviceResonance
Filter2DeviceResonanceRunTimePreset
Filter2DeviceRunTimePreset
Filter2DeviceType
Filter2DeviceTypeRunTimePreset
Filter3DeviceDeviceSlotRunTimePreset
Filter3DeviceFilterDevice
Filter3DeviceFrequency
Filter3DeviceFrequencyRunTimePreset
Filter3DeviceGain
Filter3DeviceGainRunTimePreset
Filter3DeviceInertia
Filter3DeviceInertiaRunTimePreset
Filter3DeviceQ
Filter3DeviceQRunTimePreset
Filter3DeviceRunTimePreset
Filter3DeviceType
Filter3DeviceTypeRunTimePreset
FilterDistortionDevice
FilterDistortionDeviceCutoff
FilterDistortionDeviceCutoffRunTimePreset
FilterDistortionDeviceDeviceSlotRunTimePreset
FilterDistortionDeviceDrive
FilterDistortionDeviceDriveRunTimePreset
FilterDistortionDeviceFilterType
FilterDistortionDeviceFilterTypeRunTimePreset
FilterDistortionDeviceInertia
FilterDistortionDeviceInertiaRunTimePreset
FilterDistortionDeviceResonance
FilterDistortionDeviceResonanceRunTimePreset
FilterDistortionDeviceRunTimePreset
FlangerDevice
FlangerDeviceAmount
FlangerDeviceAmountRunTimePreset
FlangerDeviceAmplitude
FlangerDeviceAmplitudeRunTimePreset
FlangerDeviceDelay
FlangerDeviceDelayRunTimePreset
FlangerDeviceDephase
FlangerDeviceDephaseRunTimePreset
FlangerDeviceDeviceSlotRunTimePreset
FlangerDeviceFeedBack
FlangerDeviceFeedBackRunTimePreset
FlangerDeviceFilterFreq
FlangerDeviceFilterFreqRunTimePreset
FlangerDeviceFilterResonance
FlangerDeviceFilterResonanceRunTimePreset
FlangerDeviceFilterType
FlangerDeviceFilterTypeRunTimePreset
FlangerDeviceRate
FlangerDeviceRateRunTimePreset
FlangerDeviceRunTimePreset
GainerDevice
GainerDeviceDeviceSlotRunTimePreset
GainerDevicePanning
GainerDevicePanningRunTimePreset
GainerDeviceRunTimePreset
GainerDeviceVolume
GainerDeviceVolumeRunTimePreset
Gate2DeviceAttack
Gate2DeviceAttackRunTimePreset
Gate2DeviceDeviceSlotRunTimePreset
Gate2DeviceFloor
Gate2DeviceFloorRunTimePreset
Gate2DeviceGateDevice
Gate2DeviceHold
Gate2DeviceHoldRunTimePreset
Gate2DeviceRelease
Gate2DeviceReleaseRunTimePreset
Gate2DeviceRunTimePreset
Gate2DeviceSideChainHpFreq
Gate2DeviceSideChainHpFreqRunTimePreset
Gate2DeviceSideChainLpFreq
Gate2DeviceSideChainLpFreqRunTimePreset
Gate2DeviceThreshold
Gate2DeviceThresholdRunTimePreset
Gate2DeviceType
Gate2DeviceTypeRunTimePreset
GateDeviceAttackInMs
GateDeviceAttackInMsRunTimePreset
GateDeviceDeviceSlotRunTimePreset
GateDeviceGateDevice
GateDeviceGatedVolume
GateDeviceGatedVolumeRunTimePreset
GateDeviceHoldInMs
GateDeviceHoldInMsRunTimePreset
GateDeviceReleaseInMs
GateDeviceReleaseInMsRunTimePreset
GateDeviceRunTimePreset
GateDeviceThreshold
GateDeviceThresholdRunTimePreset
GlobalSongData
Instrument
Main Renoise Instrument class. Use this class to create and manipulate Renoise Instrument.
InstrumentAutomationDevice
InstrumentAutomationDeviceDeviceSlotRunTimePreset
InstrumentAutomationDeviceRunTimePreset
Lfo
LfoDevice
LfoDeviceAmplitude
LfoDeviceAmplitudeRunTimePreset
LfoDeviceDeviceSlotRunTimePreset
LfoDeviceFrequency
LfoDeviceFrequencyRunTimePreset
LfoDeviceOffset
LfoDeviceOffsetRunTimePreset
LfoDeviceRunTimePreset
LfoDeviceType
LfoDeviceTypeRunTimePreset
Line
LineInDevice
LineInDeviceDeviceSlotRunTimePreset
LineInDevicePanning
LineInDevicePanningRunTimePreset
LineInDeviceRunTimePreset
LineInDeviceVolume
LineInDeviceVolumeRunTimePreset
Lofi2DeviceBits
Lofi2DeviceBitsRunTimePreset
Lofi2DeviceDeviceSlotRunTimePreset
Lofi2DeviceDryOut
Lofi2DeviceDryOutRunTimePreset
Lofi2DeviceInterpolate
Lofi2DeviceInterpolateRunTimePreset
Lofi2DeviceLofiDevice
Lofi2DeviceNoise
Lofi2DeviceNoiseRunTimePreset
Lofi2DeviceRate
Lofi2DeviceRateRunTimePreset
Lofi2DeviceRunTimePreset
Lofi2DeviceWetOut
Lofi2DeviceWetOutRunTimePreset
LofiDeviceBitCrunsh
LofiDeviceBitCrunshRunTimePreset
LofiDeviceDeviceSlotRunTimePreset
LofiDeviceDryOut
LofiDeviceDryOutRunTimePreset
LofiDeviceInterpolate
LofiDeviceInterpolateRunTimePreset
LofiDeviceLofiDevice
LofiDeviceNoise
LofiDeviceNoiseRunTimePreset
LofiDeviceQuality
LofiDeviceQualityRunTimePreset
LofiDeviceRunTimePreset
LofiDeviceWetOut
LofiDeviceWetOutRunTimePreset
LoopSelection
MaximizerDevice
MaximizerDeviceCeiling
MaximizerDeviceCeilingRunTimePreset
MaximizerDeviceDeviceSlotRunTimePreset
MaximizerDeviceInputGain
MaximizerDeviceInputGainRunTimePreset
MaximizerDeviceLongTermRelease
MaximizerDeviceLongTermReleaseRunTimePreset
MaximizerDeviceRunTimePreset
MaximizerDeviceThreshold
MaximizerDeviceThresholdRunTimePreset
MaximizerDeviceTransientRelease
MaximizerDeviceTransientReleaseRunTimePreset
MidiCCDevice
MidiCCDeviceControllerValue
MidiCCDeviceControllerValueRunTimePreset
MidiCCDeviceDeviceSlotRunTimePreset
MidiCCDeviceRunTimePreset
MidiMapping
MidiProperties
MixerEqDevice
MixerEqDeviceDeviceSlotRunTimePreset
MixerEqDeviceHiGain
MixerEqDeviceHiGainRunTimePreset
MixerEqDeviceLowGain
MixerEqDeviceLowGainRunTimePreset
MixerEqDeviceMidFreq
MixerEqDeviceMidFreqRunTimePreset
MixerEqDeviceMidGain
MixerEqDeviceMidGainRunTimePreset
MixerEqDeviceMidQ
MixerEqDeviceMidQRunTimePreset
MixerEqDeviceRunTimePreset
NoteColumn
NoteHelper
OutputRouting
PanNodes
Parameter
ParameterValue
Pattern
PatternMasterTrack
PatternPool
PatternSendTrack
PatternSequenceData
PatternTrack
PatternTracks
PdcTestDelayDevice
PdcTestDelayDeviceDelayInMs
PdcTestDelayDeviceDelayInMsRunTimePreset
PdcTestDelayDeviceDeviceSlotRunTimePreset
PdcTestDelayDeviceReportLatency
PdcTestDelayDeviceReportLatencyRunTimePreset
PdcTestDelayDeviceRunTimePreset
PhaserDevice
PhaserDeviceCeilling
PhaserDeviceCeillingRunTimePreset
PhaserDeviceDepth
PhaserDeviceDepthRunTimePreset
PhaserDeviceDeviceSlotRunTimePreset
PhaserDeviceFeedback
PhaserDeviceFeedbackRunTimePreset
PhaserDeviceFloor
PhaserDeviceFloorRunTimePreset
PhaserDeviceLFORate
PhaserDeviceLFORateRunTimePreset
PhaserDevicePhase
PhaserDevicePhaseRunTimePreset
PhaserDeviceRunTimePreset
PhaserDeviceStages
PhaserDeviceStagesRunTimePreset
Pitch
PitchNodes
PluginDevice
PluginDeviceRunTimePreset
PluginProperties
RecordManager
RenoiseDeviceChain
RenoiseDeviceChainDevices
RenoiseInstrument
RenoiseSong
ResonanceNodes
Reverb2DeviceDeviceSlotRunTimePreset
Reverb2DeviceDryMix
Reverb2DeviceDryMixRunTimePreset
Reverb2DeviceLPFilter
Reverb2DeviceLPFilterRunTimePreset
Reverb2DevicePreDelay
Reverb2DevicePreDelayRunTimePreset
Reverb2DeviceReverbDevice
Reverb2DeviceReverbTime
Reverb2DeviceReverbTimeRunTimePreset
Reverb2DeviceRunTimePreset
Reverb2DeviceSend
Reverb2DeviceSendRunTimePreset
Reverb3DeviceColor
Reverb3DeviceColorRunTimePreset
Reverb3DeviceDeviceSlotRunTimePreset
Reverb3DeviceDryMix
Reverb3DeviceDryMixRunTimePreset
Reverb3DeviceLPFilter
Reverb3DeviceLPFilterRunTimePreset
Reverb3DeviceLPGain
Reverb3DeviceLPGainRunTimePreset
Reverb3DevicePan
Reverb3DevicePanRunTimePreset
Reverb3DevicePreDelay
Reverb3DevicePreDelayRunTimePreset
Reverb3DeviceReverbDevice
Reverb3DeviceReverbTime
Reverb3DeviceReverbTimeRunTimePreset
Reverb3DeviceRunTimePreset
Reverb3DeviceWetMix
Reverb3DeviceWetMixRunTimePreset
Reverb3DeviceWidth
Reverb3DeviceWidthRunTimePreset
ReverbDeviceDamp
ReverbDeviceDampRunTimePreset
ReverbDeviceDeviceSlotRunTimePreset
ReverbDeviceDryMix
ReverbDeviceDryMixRunTimePreset
ReverbDeviceReverbDevice
ReverbDeviceRoomSize
ReverbDeviceRoomSizeRunTimePreset
ReverbDeviceRunTimePreset
ReverbDeviceSend
ReverbDeviceSendRunTimePreset
ReverbDeviceWidth
ReverbDeviceWidthRunTimePreset
RingModDevice
RingModDeviceAmount
RingModDeviceAmountRunTimePreset
RingModDeviceDeviceSlotRunTimePreset
RingModDeviceFrequency
RingModDeviceFrequencyRunTimePreset
RingModDeviceInertia
RingModDeviceInertiaRunTimePreset
RingModDeviceOscillatorType
RingModDeviceOscillatorTypeRunTimePreset
RingModDevicePhase
RingModDevicePhaseRunTimePreset
RingModDeviceRunTimePreset
Sample
Sample class. This class to create and manipulate Renoise Song.
SendDevice
SendDeviceDestSendTrack
SendDeviceDestSendTrackRunTimePreset
SendDeviceDeviceSlotRunTimePreset
SendDeviceRunTimePreset
SendDeviceSendAmount
SendDeviceSendAmountRunTimePreset
SequencerMasterTrack
SequencerMasterTrackDevice
SequencerMasterTrackDeviceDeviceSlotRunTimePreset
SequencerMasterTrackDevicePanning
SequencerMasterTrackDevicePanningRunTimePreset
SequencerMasterTrackDevicePostPanning
SequencerMasterTrackDevicePostPanningRunTimePreset
SequencerMasterTrackDevicePostVolume
SequencerMasterTrackDevicePostVolumeRunTimePreset
SequencerMasterTrackDeviceRunTimePreset
SequencerMasterTrackDeviceSurround
SequencerMasterTrackDeviceSurroundRunTimePreset
SequencerMasterTrackDeviceVolume
SequencerMasterTrackDeviceVolumeRunTimePreset
SequencerMasterTrackFilterDevices
SequencerMasterTrackFilterDevicesDevices
SequencerSendTrack
SequencerSendTrackDevice
SequencerSendTrackDeviceDeviceSlotRunTimePreset
SequencerSendTrackDevicePanning
SequencerSendTrackDevicePanningRunTimePreset
SequencerSendTrackDevicePostPanning
SequencerSendTrackDevicePostPanningRunTimePreset
SequencerSendTrackDevicePostVolume
SequencerSendTrackDevicePostVolumeRunTimePreset
SequencerSendTrackDeviceRunTimePreset
SequencerSendTrackDeviceSurround
SequencerSendTrackDeviceSurroundRunTimePreset
SequencerSendTrackDeviceVolume
SequencerSendTrackDeviceVolumeRunTimePreset
SequencerSendTrackFilterDevices
SequencerSendTrackFilterDevicesDevices
SequencerTrack
SequencerTrackDevice
SequencerTrackDeviceDeviceSlotRunTimePreset
SequencerTrackDevicePanning
SequencerTrackDevicePanningRunTimePreset
SequencerTrackDevicePostPanning
SequencerTrackDevicePostPanningRunTimePreset
SequencerTrackDevicePostVolume
SequencerTrackDevicePostVolumeRunTimePreset
SequencerTrackDeviceRunTimePreset
SequencerTrackDeviceSurround
SequencerTrackDeviceSurroundRunTimePreset
SequencerTrackDeviceVolume
SequencerTrackDeviceVolumeRunTimePreset
SequencerTrackFilterDevices
SequencerTrackFilterDevicesDevices
ShaperDevice
ShaperDeviceAttack
ShaperDeviceAttackRunTimePreset
ShaperDeviceDeviceSlotRunTimePreset
ShaperDeviceGain
ShaperDeviceGainRunTimePreset
ShaperDeviceRatio
ShaperDeviceRatioRunTimePreset
ShaperDeviceRelease
ShaperDeviceReleaseRunTimePreset
ShaperDeviceRunTimePreset
ShaperDeviceThreshold
ShaperDeviceThresholdRunTimePreset
Song
Main Renoise Song class. Use this class to create and manipulate Renoise Song.
SongBase
SongBaseTracks
SongIterator
Convenient class helper to iterate on a Renoise song. Subclass this class and use Iterate with delegates to catch events.
Copy Code
            public class MyRenoiseIterator : SongIterator {
                public MyRenoiseIterator(Song song) : base(song) {}

                public void DoMyConvertion() {
                    Iterate(new RenoiseSongEvent()
                    {
                        OnNote = delegate
                        {
                            // do whatever you want to do here.
                            // Look at Pattern, Track, Line, NoteColumn properties... to get the current pattern, track, line...etc
                        },
                        OnBeginPattern = delegate { Console.WriteLine("New pattern {0}", Pattern.Name); }
                    });
                }
SongTempo
SongTempoMarker
Tempo marker inside the song with the absolute position (in line and time) in the song.
StereoExpanderDevice
StereoExpanderDeviceDeviceSlotRunTimePreset
StereoExpanderDeviceRunTimePreset
StereoExpanderDeviceStereoWidth
StereoExpanderDeviceStereoWidthRunTimePreset
StereoExpanderDeviceSurroundWidth
StereoExpanderDeviceSurroundWidthRunTimePreset
TextBoxWriter
Track
Util
Misc utility methods.
VelocityDevice
VelocityDeviceDestMax
VelocityDeviceDestMaxRunTimePreset
VelocityDeviceDestMin
VelocityDeviceDestMinRunTimePreset
VelocityDeviceDeviceSlotRunTimePreset
VelocityDeviceRunTimePreset
VolumeNodes

Structures

Structure | Description
SongIteratorEvent | Structures used by Iterate(SongIteratorEvent) and IteratePattern(Int32, SongIteratorEvent). This structure provides callbacks through delegates.

Delegates

Delegate | Description
SongIteratorEvent..::.OnIteratorEvent |

Enumerations

Enumeration | Description
AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType |
AudioPluginDeviceDeviceSlotRunTimePresetPluginType |
AudioPluginDeviceParameterChunkType |
AudioPluginDevicePluginType |
BusCompressorDeviceAttackVisualization |
BusCompressorDeviceKneeVisualization |
BusCompressorDeviceMakeUpVisualization |
BusCompressorDeviceRatioVisualization |
BusCompressorDeviceReleaseVisualization |
BusCompressorDeviceThresholdVisualization |
ChorusDeviceDelayVisualization |
ChorusDeviceDryWetMixVisualization |
ChorusDeviceFeedbackVisualization |
ChorusDeviceFilterFreqVisualization |
ChorusDeviceFilterResonanceVisualization |
ChorusDeviceFilterTypeVisualization |
ChorusDeviceLfoDepthVisualization |
ChorusDeviceLfoRateVisualization |
ChorusDevicePhaseVisualization |
CompressorDeviceAttackVisualization |
CompressorDeviceGainVisualization |
CompressorDeviceLogThresholdVisualization |
CompressorDeviceRatioVisualization |
CompressorDeviceReleaseVisualization |
CustomEnvelopePlayMode |
CutoffNodesPlayMode |
DcOffsetDeviceAutoDCVisualization |
DcOffsetDeviceDCOffsetVisualization |
DelayDeviceLDelayVisualization |
DelayDeviceLFeedbackVisualization |
DelayDeviceLineSyncVisualization |
DelayDeviceLSyncOffsetVisualization |
DelayDeviceLSyncTimeVisualization |
DelayDeviceLTapPanVisualization |
DelayDeviceMuteDrySignalVisualization |
DelayDeviceRDelayVisualization |
DelayDeviceRFeedbackVisualization |
DelayDeviceRSyncOffsetVisualization |
DelayDeviceRSyncTimeVisualization |
DelayDeviceRTapPanVisualization |
DelayDeviceTrackSendVisualization |
DestEffectVisualization |
DestParameterVisualization |
DeviceSlotRunTimePresetParameterChunkType |
DeviceSlotRunTimePresetPluginType |
Distortion2DeviceDriveVisualization |
Distortion2DeviceDryOutVisualization |
Distortion2DeviceToneVisualization |
Distortion2DeviceTypeVisualization |
Distortion2DeviceWetOutVisualization |
DistortionDeviceDryOutVisualization |
DistortionDeviceGateOrFilterVisualization |
DistortionDeviceLpOrClampVisualization |
DistortionDeviceThresholdVisualization |
DistortionDeviceTypeVisualization |
DistortionDeviceWetOutVisualization |
EnvelopeDataPlayMode |
EnvelopesCutoffInterpolationMode |
EnvelopesCutoffLoopMode |
EnvelopesPanInterpolationMode |
EnvelopesPanLoopMode |
EnvelopesResonanceInterpolationMode |
EnvelopesResonanceLoopMode |
EnvelopesVolumeInterpolationMode |
EnvelopesVolumeLoopMode |
Eq10DeviceDeviceSlotRunTimePresetInputMode |
Eq10DeviceEqDeviceInputMode |
Eq10DeviceGainVisualization |
Eq5DeviceDeviceSlotRunTimePresetInputMode |
Eq5DeviceEqDeviceInputMode |
Eq5DeviceGainVisualization |
Filter1DeviceCutoffVisualization |
Filter1DeviceInnertiaVisualization |
Filter1DeviceResonanceVisualization |
Filter1DeviceTypeVisualization |
Filter2DeviceCutoffVisualization |
Filter2DeviceInnertiaVisualization |
Filter2DeviceResonanceVisualization |
Filter2DeviceTypeVisualization |
Filter3DeviceDeviceSlotRunTimePresetModel |
Filter3DeviceFilterDeviceModel |
Filter3DeviceFrequencyVisualization |
Filter3DeviceGainVisualization |
Filter3DeviceInertiaVisualization |
Filter3DeviceQVisualization |
Filter3DeviceTypeVisualization |
FilterDistortionDeviceCutoffVisualization |
FilterDistortionDeviceDriveVisualization |
FilterDistortionDeviceFilterTypeVisualization |
FilterDistortionDeviceInertiaVisualization |
FilterDistortionDeviceResonanceVisualization |
FlangerDeviceAmountVisualization |
FlangerDeviceAmplitudeVisualization |
FlangerDeviceDelayVisualization |
FlangerDeviceDephaseVisualization |
FlangerDeviceFeedBackVisualization |
FlangerDeviceFilterFreqVisualization |
FlangerDeviceFilterResonanceVisualization |
FlangerDeviceFilterTypeVisualization |
FlangerDeviceRateVisualization |
GainerDevicePanningVisualization |
GainerDeviceVolumeVisualization |
Gate2DeviceAttackVisualization |
Gate2DeviceFloorVisualization |
Gate2DeviceHoldVisualization |
Gate2DeviceReleaseVisualization |
Gate2DeviceSideChainHpFreqVisualization |
Gate2DeviceSideChainLpFreqVisualization |
Gate2DeviceThresholdVisualization |
Gate2DeviceTypeVisualization |
GateDeviceAttackInMsVisualization |
GateDeviceGatedVolumeVisualization |
GateDeviceHoldInMsVisualization |
GateDeviceReleaseInMsVisualization |
GateDeviceThresholdVisualization |
LfoDeviceAmplitudeVisualization |
LfoDeviceFrequencyVisualization |
LfoDeviceOffsetVisualization |
LfoDeviceTypeVisualization |
LfoMode |
LineInDeviceDeviceSlotRunTimePresetInputChannelMode |
LineInDeviceDeviceSlotRunTimePresetInputLatencyMode |
LineInDeviceInputChannelMode |
LineInDeviceInputLatencyMode |
LineInDevicePanningVisualization |
LineInDeviceVolumeVisualization |
Lofi2DeviceBitsVisualization |
Lofi2DeviceDryOutVisualization |
Lofi2DeviceInterpolateVisualization |
Lofi2DeviceNoiseVisualization |
Lofi2DeviceRateVisualization |
Lofi2DeviceWetOutVisualization |
LofiDeviceBitCrunshVisualization |
LofiDeviceDryOutVisualization |
LofiDeviceInterpolateVisualization |
LofiDeviceNoiseVisualization |
LofiDeviceQualityVisualization |
LofiDeviceWetOutVisualization |
MaximizerDeviceCeilingVisualization |
MaximizerDeviceInputGainVisualization |
MaximizerDeviceLongTermReleaseVisualization |
MaximizerDeviceThresholdVisualization |
MaximizerDeviceTransientReleaseVisualization |
MidiCCDeviceControllerValueVisualization |
MidiPropertiesInstrumentType |
MixerEqDeviceDeviceSlotRunTimePresetInputMode |
MixerEqDeviceHiGainVisualization |
MixerEqDeviceInputMode |
MixerEqDeviceLowGainVisualization |
MixerEqDeviceMidFreqVisualization |
MixerEqDeviceMidGainVisualization |
MixerEqDeviceMidQVisualization |
OutputRoutingMixMode |
PanNodesPlayMode |
ParameterValueVisualization |
ParameterVisualization |
PdcTestDelayDeviceDelayInMsVisualization |
PdcTestDelayDeviceReportLatencyVisualization |
PhaserDeviceCeillingVisualization |
PhaserDeviceDepthVisualization |
PhaserDeviceFeedbackVisualization |
PhaserDeviceFloorVisualization |
PhaserDeviceLFORateVisualization |
PhaserDevicePhaseVisualization |
PhaserDeviceStagesVisualization |
PitchInterpolationMode |
PitchLoopMode |
PitchNodesPlayMode |
PluginDeviceParameterChunkType |
PluginDevicePluginType |
ResonanceNodesPlayMode |
Reverb2DeviceDryMixVisualization |
Reverb2DeviceLPFilterVisualization |
Reverb2DevicePreDelayVisualization |
Reverb2DeviceReverbTimeVisualization |
Reverb2DeviceSendVisualization |
Reverb3DeviceColorVisualization |
Reverb3DeviceDryMixVisualization |
Reverb3DeviceLPFilterVisualization |
Reverb3DeviceLPGainVisualization |
Reverb3DevicePanVisualization |
Reverb3DevicePreDelayVisualization |
Reverb3DeviceReverbTimeVisualization |
Reverb3DeviceWetMixVisualization |
Reverb3DeviceWidthVisualization |
ReverbDeviceDampVisualization |
ReverbDeviceDryMixVisualization |
ReverbDeviceRoomSizeVisualization |
ReverbDeviceSendVisualization |
ReverbDeviceWidthVisualization |
RingModDeviceAmountVisualization |
RingModDeviceFrequencyVisualization |
RingModDeviceInertiaVisualization |
RingModDeviceOscillatorTypeVisualization |
RingModDevicePhaseVisualization |
SampleInterpolationMode |
SampleLoopMode |
SampleNewNoteAction |
SendDeviceDestSendTrackVisualization |
SendDeviceSendAmountVisualization |
SequencerMasterTrackDevicePanningVisualization |
SequencerMasterTrackDevicePostPanningVisualization |
SequencerMasterTrackDevicePostVolumeVisualization |
SequencerMasterTrackDeviceSurroundVisualization |
SequencerMasterTrackDeviceVolumeVisualization |
SequencerMasterTrackNoteColumnState |
SequencerMasterTrackState |
SequencerSendTrackDevicePanningVisualization |
SequencerSendTrackDevicePostPanningVisualization |
SequencerSendTrackDevicePostVolumeVisualization |
SequencerSendTrackDeviceSurroundVisualization |
SequencerSendTrackDeviceVolumeVisualization |
SequencerSendTrackNoteColumnState |
SequencerSendTrackState |
SequencerTrackDevicePanningVisualization |
SequencerTrackDevicePostPanningVisualization |
SequencerTrackDevicePostVolumeVisualization |
SequencerTrackDeviceSurroundVisualization |
SequencerTrackDeviceVolumeVisualization |
SequencerTrackNoteColumnState |
SequencerTrackState |
ShaperDeviceAttackVisualization |
ShaperDeviceGainVisualization |
ShaperDeviceRatioVisualization |
ShaperDeviceReleaseVisualization |
ShaperDeviceThresholdVisualization |
StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode |
StereoExpanderDeviceMonoMixMode |
StereoExpanderDeviceStereoWidthVisualization |
StereoExpanderDeviceSurroundWidthVisualization |
VelocityDeviceDestMaxVisualization |
VelocityDeviceDestMinVisualization |
VelocityDeviceDeviceSlotRunTimePresetVelocityScaling |
VelocityDeviceVelocityScaling |
VolumeNodesPlayMode |
Send feedback on this topic to Microsoft.


AudioPluginDevice Class

[image]

.NET Framework Class Library
AudioPluginDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class AudioPluginDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class AudioPluginDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class AudioPluginDevice
JavaScript
NRenoiseTools.AudioPluginDevice = function();

Type.createClass(
    'NRenoiseTools.AudioPluginDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.AudioPluginDevice

See Also

AudioPluginDevice Members
NRenoiseTools Namespace


AudioPluginDevice Members

[image] [image]

.NET Framework Class Library
AudioPluginDevice Members
AudioPluginDevice Class Constructors Methods Properties See Also Send Feedback

The AudioPluginDevice type exposes the following members.

Constructors

Name | Description
AudioPluginDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveProgram |
IsActive |
IsSelected |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

AudioPluginDevice Class


AudioPluginDevice Constructor

[image]

.NET Framework Class Library
AudioPluginDevice Constructor
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AudioPluginDevice()
Visual C++
public:
AudioPluginDevice()
JavaScript
NRenoiseTools.AudioPluginDevice = function();

See Also

AudioPluginDevice Class


AudioPluginDevice Methods

[image] [image]

.NET Framework Class Library
AudioPluginDevice Methods
AudioPluginDevice Class See Also Send Feedback

The AudioPluginDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AudioPluginDevice Class


AudioPluginDevice Properties

[image] [image]

.NET Framework Class Library
AudioPluginDevice Properties
AudioPluginDevice Class See Also Send Feedback

The AudioPluginDevice type exposes the following members.

Properties

Name | Description
ActiveProgram |
IsActive |
IsSelected |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

AudioPluginDevice Class


ActiveProgram Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.ActiveProgram Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveProgram As Integer
C#
public int ActiveProgram { get; set; }
Visual C++
public:
property int ActiveProgram {
    int get ();
    void set (int value);
}
JavaScript
function get_activeProgram();
function set_activeProgram(value);

Remarks

See Also

AudioPluginDevice Class


IsActive Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.IsActive Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

AudioPluginDevice Class


IsSelected Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.IsSelected Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

AudioPluginDevice Class


ParameterChunk Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.ParameterChunk Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunk As String
C#
public string ParameterChunk { get; set; }
Visual C++
public:
property String^ ParameterChunk {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameterChunk();
function set_parameterChunk(value);

Remarks

See Also

AudioPluginDevice Class


ParameterChunkType Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.ParameterChunkType Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunkType As AudioPluginDeviceParameterChunkType
C#
public AudioPluginDeviceParameterChunkType ParameterChunkType { get; set; }
Visual C++
public:
property AudioPluginDeviceParameterChunkType ParameterChunkType {
    AudioPluginDeviceParameterChunkType get ();
    void set (AudioPluginDeviceParameterChunkType value);
}
JavaScript
function get_parameterChunkType();
function set_parameterChunkType(value);

Remarks

See Also

AudioPluginDevice Class


Parameters Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.Parameters Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameter()
C#
public Parameter[] Parameters { get; set; }
Visual C++
public:
property array<Parameter^>^ Parameters {
    array<Parameter^>^ get ();
    void set (array<Parameter^>^ value);
}
JavaScript
function get_parameters();
function set_parameters(value);

Remarks

See Also

AudioPluginDevice Class


PluginDisplayName Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginDisplayName Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginDisplayName As String
C#
public string PluginDisplayName { get; set; }
Visual C++
public:
property String^ PluginDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginDisplayName();
function set_pluginDisplayName(value);

Remarks

See Also

AudioPluginDevice Class


PluginEditorWindowPosition Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginEditorWindowPosition Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginEditorWindowPosition As String
C#
public string PluginEditorWindowPosition { get; set; }
Visual C++
public:
property String^ PluginEditorWindowPosition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginEditorWindowPosition();
function set_pluginEditorWindowPosition(value);

Remarks

See Also

AudioPluginDevice Class


PluginIdentifier Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginIdentifier Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginIdentifier As String
C#
public string PluginIdentifier { get; set; }
Visual C++
public:
property String^ PluginIdentifier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginIdentifier();
function set_pluginIdentifier(value);

Remarks

See Also

AudioPluginDevice Class


PluginShortDisplayName Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginShortDisplayName Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginShortDisplayName As String
C#
public string PluginShortDisplayName { get; set; }
Visual C++
public:
property String^ PluginShortDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginShortDisplayName();
function set_pluginShortDisplayName(value);

Remarks

See Also

AudioPluginDevice Class


PluginType Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginType Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginType As AudioPluginDevicePluginType
C#
public AudioPluginDevicePluginType PluginType { get; set; }
Visual C++
public:
property AudioPluginDevicePluginType PluginType {
    AudioPluginDevicePluginType get ();
    void set (AudioPluginDevicePluginType value);
}
JavaScript
function get_pluginType();
function set_pluginType(value);

Remarks

See Also

AudioPluginDevice Class


PluginTypeSpecified Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.PluginTypeSpecified Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginTypeSpecified As Boolean
C#
public bool PluginTypeSpecified { get; set; }
Visual C++
public:
property bool PluginTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pluginTypeSpecified();
function set_pluginTypeSpecified(value);

Remarks

See Also

AudioPluginDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.RunTimePresetA Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As AudioPluginDeviceRunTimePreset
C#
public AudioPluginDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property AudioPluginDeviceRunTimePreset^ RunTimePresetA {
    AudioPluginDeviceRunTimePreset^ get ();
    void set (AudioPluginDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

AudioPluginDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.RunTimePresetB Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As AudioPluginDeviceRunTimePreset
C#
public AudioPluginDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property AudioPluginDeviceRunTimePreset^ RunTimePresetB {
    AudioPluginDeviceRunTimePreset^ get ();
    void set (AudioPluginDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

AudioPluginDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.SelectedPresetIsModified Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

AudioPluginDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.SelectedPresetName Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

AudioPluginDevice Class


type Property

[image]

.NET Framework Class Library
AudioPluginDevice..::.type Property
AudioPluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

AudioPluginDevice Class


AudioPluginDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class AudioPluginDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class AudioPluginDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class AudioPluginDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.AudioPluginDeviceDeviceSlotRunTimePreset

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Members


AudioPluginDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset Members
AudioPluginDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The AudioPluginDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
AudioPluginDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveProgram |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
type |

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


AudioPluginDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset Constructor
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AudioPluginDeviceDeviceSlotRunTimePreset()
Visual C++
public:
AudioPluginDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePreset = function();

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


AudioPluginDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset Methods
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The AudioPluginDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


AudioPluginDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset Properties
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The AudioPluginDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
ActiveProgram |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
type |

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


ActiveProgram Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.ActiveProgram Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveProgram As Integer
C#
public int ActiveProgram { get; set; }
Visual C++
public:
property int ActiveProgram {
    int get ();
    void set (int value);
}
JavaScript
function get_activeProgram();
function set_activeProgram(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


ParameterChunk Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.ParameterChunk Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunk As String
C#
public string ParameterChunk { get; set; }
Visual C++
public:
property String^ ParameterChunk {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameterChunk();
function set_parameterChunk(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


ParameterChunkType Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.ParameterChunkType Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunkType As AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType
C#
public AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType ParameterChunkType { get; set; }
Visual C++
public:
property AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType ParameterChunkType {
    AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType get ();
    void set (AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType value);
}
JavaScript
function get_parameterChunkType();
function set_parameterChunkType(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


Parameters Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.Parameters Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameter()
C#
public Parameter[] Parameters { get; set; }
Visual C++
public:
property array<Parameter^>^ Parameters {
    array<Parameter^>^ get ();
    void set (array<Parameter^>^ value);
}
JavaScript
function get_parameters();
function set_parameters(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginDisplayName Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginDisplayName Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginDisplayName As String
C#
public string PluginDisplayName { get; set; }
Visual C++
public:
property String^ PluginDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginDisplayName();
function set_pluginDisplayName(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginEditorWindowPosition Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginEditorWindowPosition Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginEditorWindowPosition As String
C#
public string PluginEditorWindowPosition { get; set; }
Visual C++
public:
property String^ PluginEditorWindowPosition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginEditorWindowPosition();
function set_pluginEditorWindowPosition(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginIdentifier Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginIdentifier Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginIdentifier As String
C#
public string PluginIdentifier { get; set; }
Visual C++
public:
property String^ PluginIdentifier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginIdentifier();
function set_pluginIdentifier(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginShortDisplayName Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginShortDisplayName Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginShortDisplayName As String
C#
public string PluginShortDisplayName { get; set; }
Visual C++
public:
property String^ PluginShortDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginShortDisplayName();
function set_pluginShortDisplayName(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginType Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginType Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginType As AudioPluginDeviceDeviceSlotRunTimePresetPluginType
C#
public AudioPluginDeviceDeviceSlotRunTimePresetPluginType PluginType { get; set; }
Visual C++
public:
property AudioPluginDeviceDeviceSlotRunTimePresetPluginType PluginType {
    AudioPluginDeviceDeviceSlotRunTimePresetPluginType get ();
    void set (AudioPluginDeviceDeviceSlotRunTimePresetPluginType value);
}
JavaScript
function get_pluginType();
function set_pluginType(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


PluginTypeSpecified Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.PluginTypeSpecified Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginTypeSpecified As Boolean
C#
public bool PluginTypeSpecified { get; set; }
Visual C++
public:
property bool PluginTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pluginTypeSpecified();
function set_pluginTypeSpecified(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePreset..::.type Property
AudioPluginDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

AudioPluginDeviceDeviceSlotRunTimePreset Class


AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType Enumeration

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType
JavaScript
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType = function();
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType.createEnum('NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetParameterChunkType', false);

Members

Member name | Description
Chunk |
ParameterBag |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


AudioPluginDeviceDeviceSlotRunTimePresetPluginType Enumeration

[image]

.NET Framework Class Library
AudioPluginDeviceDeviceSlotRunTimePresetPluginType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration AudioPluginDeviceDeviceSlotRunTimePresetPluginType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum AudioPluginDeviceDeviceSlotRunTimePresetPluginType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class AudioPluginDeviceDeviceSlotRunTimePresetPluginType
JavaScript
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetPluginType = function();
NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetPluginType.createEnum('NRenoiseTools.AudioPluginDeviceDeviceSlotRunTimePresetPluginType', false);

Members

Member name | Description
AU |
VST |
LADSAP |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


AudioPluginDeviceParameterChunkType Enumeration

[image]

.NET Framework Class Library
AudioPluginDeviceParameterChunkType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration AudioPluginDeviceParameterChunkType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum AudioPluginDeviceParameterChunkType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class AudioPluginDeviceParameterChunkType
JavaScript
NRenoiseTools.AudioPluginDeviceParameterChunkType = function();
NRenoiseTools.AudioPluginDeviceParameterChunkType.createEnum('NRenoiseTools.AudioPluginDeviceParameterChunkType', false);

Members

Member name | Description
Chunk |
ParameterBag |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


AudioPluginDevicePluginType Enumeration

[image]

.NET Framework Class Library
AudioPluginDevicePluginType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration AudioPluginDevicePluginType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum AudioPluginDevicePluginType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class AudioPluginDevicePluginType
JavaScript
NRenoiseTools.AudioPluginDevicePluginType = function();
NRenoiseTools.AudioPluginDevicePluginType.createEnum('NRenoiseTools.AudioPluginDevicePluginType', false);

Members

Member name | Description
AU |
VST |
LADSAP |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


AudioPluginDeviceRunTimePreset Class

[image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class AudioPluginDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class AudioPluginDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class AudioPluginDeviceRunTimePreset
JavaScript
NRenoiseTools.AudioPluginDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.AudioPluginDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.AudioPluginDeviceRunTimePreset

See Also

AudioPluginDeviceRunTimePreset Members


AudioPluginDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset Members
AudioPluginDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The AudioPluginDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
AudioPluginDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

AudioPluginDeviceRunTimePreset Class


AudioPluginDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset Constructor
AudioPluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AudioPluginDeviceRunTimePreset()
Visual C++
public:
AudioPluginDeviceRunTimePreset()
JavaScript
NRenoiseTools.AudioPluginDeviceRunTimePreset = function();

See Also

AudioPluginDeviceRunTimePreset Class


AudioPluginDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset Methods
AudioPluginDeviceRunTimePreset Class See Also Send Feedback

The AudioPluginDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AudioPluginDeviceRunTimePreset Class


AudioPluginDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset Properties
AudioPluginDeviceRunTimePreset Class See Also Send Feedback

The AudioPluginDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

AudioPluginDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset..::.DeviceSlot Property
AudioPluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As AudioPluginDeviceDeviceSlotRunTimePreset
C#
public AudioPluginDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property AudioPluginDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    AudioPluginDeviceDeviceSlotRunTimePreset^ get ();
    void set (AudioPluginDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

AudioPluginDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
AudioPluginDeviceRunTimePreset..::.type Property
AudioPluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

AudioPluginDeviceRunTimePreset Class


AutoAmp Class

[image]

.NET Framework Class Library
AutoAmp Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class AutoAmp
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class AutoAmp
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class AutoAmp
JavaScript
NRenoiseTools.AutoAmp = function();

Type.createClass(
    'NRenoiseTools.AutoAmp');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.AutoAmp

See Also

AutoAmp Members


AutoAmp Members

[image] [image]

.NET Framework Class Library
AutoAmp Members
AutoAmp Class Constructors Methods Properties See Also Send Feedback

The AutoAmp type exposes the following members.

Constructors

Name | Description
AutoAmp |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Attack |
IsActive |
Release |

See Also

AutoAmp Class


AutoAmp Constructor

[image]

.NET Framework Class Library
AutoAmp Constructor
AutoAmp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AutoAmp()
Visual C++
public:
AutoAmp()
JavaScript
NRenoiseTools.AutoAmp = function();

See Also

AutoAmp Class


AutoAmp Methods

[image] [image]

.NET Framework Class Library
AutoAmp Methods
AutoAmp Class See Also Send Feedback

The AutoAmp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutoAmp Class


AutoAmp Properties

[image] [image]

.NET Framework Class Library
AutoAmp Properties
AutoAmp Class See Also Send Feedback

The AutoAmp type exposes the following members.

Properties

Name | Description
Amount |
Attack |
IsActive |
Release |

See Also

AutoAmp Class


Amount Property

[image]

.NET Framework Class Library
AutoAmp..::.Amount Property
AutoAmp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Integer
C#
public int Amount { get; set; }
Visual C++
public:
property int Amount {
    int get ();
    void set (int value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

AutoAmp Class


Attack Property

[image]

.NET Framework Class Library
AutoAmp..::.Attack Property
AutoAmp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As Integer
C#
public int Attack { get; set; }
Visual C++
public:
property int Attack {
    int get ();
    void set (int value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

AutoAmp Class


IsActive Property

[image]

.NET Framework Class Library
AutoAmp..::.IsActive Property
AutoAmp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

AutoAmp Class


Release Property

[image]

.NET Framework Class Library
AutoAmp..::.Release Property
AutoAmp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As Integer
C#
public int Release { get; set; }
Visual C++
public:
property int Release {
    int get ();
    void set (int value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

AutoAmp Class


Automations Class

[image]

.NET Framework Class Library
Automations Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Automations
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Automations
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Automations
JavaScript
NRenoiseTools.Automations = function();

Type.createClass(
    'NRenoiseTools.Automations');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Automations

See Also

Automations Members


Automations Members

[image] [image]

.NET Framework Class Library
Automations Members
Automations Class Constructors Methods Properties See Also Send Feedback

The Automations type exposes the following members.

Constructors

Name | Description
Automations |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Envelopes |

See Also

Automations Class


Automations Constructor

[image]

.NET Framework Class Library
Automations Constructor
Automations Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Automations()
Visual C++
public:
Automations()
JavaScript
NRenoiseTools.Automations = function();

See Also

Automations Class


Automations Methods

[image] [image]

.NET Framework Class Library
Automations Methods
Automations Class See Also Send Feedback

The Automations type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Automations Class


Automations Properties

[image] [image]

.NET Framework Class Library
Automations Properties
Automations Class See Also Send Feedback

The Automations type exposes the following members.

Properties

Name | Description
Envelopes |

See Also

Automations Class


Envelopes Property

[image]

.NET Framework Class Library
Automations..::.Envelopes Property
Automations Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Envelopes As EnvelopeItem()
C#
public EnvelopeItem[] Envelopes { get; set; }
Visual C++
public:
property array<EnvelopeItem^>^ Envelopes {
    array<EnvelopeItem^>^ get ();
    void set (array<EnvelopeItem^>^ value);
}
JavaScript
function get_envelopes();
function set_envelopes(value);

Remarks

See Also

Automations Class


BusCompressorDevice Class

[image]

.NET Framework Class Library
BusCompressorDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDevice
JavaScript
NRenoiseTools.BusCompressorDevice = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDevice

See Also

BusCompressorDevice Members


BusCompressorDevice Members

[image] [image]

.NET Framework Class Library
BusCompressorDevice Members
BusCompressorDevice Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDevice type exposes the following members.

Constructors

Name | Description
BusCompressorDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
IsActive |
IsSelected |
Knee |
MakeUp |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

BusCompressorDevice Class


BusCompressorDevice Constructor

[image]

.NET Framework Class Library
BusCompressorDevice Constructor
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDevice()
Visual C++
public:
BusCompressorDevice()
JavaScript
NRenoiseTools.BusCompressorDevice = function();

See Also

BusCompressorDevice Class


BusCompressorDevice Methods

[image] [image]

.NET Framework Class Library
BusCompressorDevice Methods
BusCompressorDevice Class See Also Send Feedback

The BusCompressorDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDevice Class


BusCompressorDevice Properties

[image] [image]

.NET Framework Class Library
BusCompressorDevice Properties
BusCompressorDevice Class See Also Send Feedback

The BusCompressorDevice type exposes the following members.

Properties

Name | Description
Attack |
IsActive |
IsSelected |
Knee |
MakeUp |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

BusCompressorDevice Class


Attack Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.Attack Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As BusCompressorDeviceAttack
C#
public BusCompressorDeviceAttack Attack { get; set; }
Visual C++
public:
property BusCompressorDeviceAttack^ Attack {
    BusCompressorDeviceAttack^ get ();
    void set (BusCompressorDeviceAttack^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

BusCompressorDevice Class


IsActive Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.IsActive Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

BusCompressorDevice Class


IsSelected Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.IsSelected Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

BusCompressorDevice Class


Knee Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.Knee Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Knee As BusCompressorDeviceKnee
C#
public BusCompressorDeviceKnee Knee { get; set; }
Visual C++
public:
property BusCompressorDeviceKnee^ Knee {
    BusCompressorDeviceKnee^ get ();
    void set (BusCompressorDeviceKnee^ value);
}
JavaScript
function get_knee();
function set_knee(value);

Remarks

See Also

BusCompressorDevice Class


MakeUp Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.MakeUp Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MakeUp As BusCompressorDeviceMakeUp
C#
public BusCompressorDeviceMakeUp MakeUp { get; set; }
Visual C++
public:
property BusCompressorDeviceMakeUp^ MakeUp {
    BusCompressorDeviceMakeUp^ get ();
    void set (BusCompressorDeviceMakeUp^ value);
}
JavaScript
function get_makeUp();
function set_makeUp(value);

Remarks

See Also

BusCompressorDevice Class


Ratio Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.Ratio Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As BusCompressorDeviceRatio
C#
public BusCompressorDeviceRatio Ratio { get; set; }
Visual C++
public:
property BusCompressorDeviceRatio^ Ratio {
    BusCompressorDeviceRatio^ get ();
    void set (BusCompressorDeviceRatio^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

BusCompressorDevice Class


Release Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.Release Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As BusCompressorDeviceRelease
C#
public BusCompressorDeviceRelease Release { get; set; }
Visual C++
public:
property BusCompressorDeviceRelease^ Release {
    BusCompressorDeviceRelease^ get ();
    void set (BusCompressorDeviceRelease^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

BusCompressorDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.RunTimePresetA Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As BusCompressorDeviceRunTimePreset
C#
public BusCompressorDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property BusCompressorDeviceRunTimePreset^ RunTimePresetA {
    BusCompressorDeviceRunTimePreset^ get ();
    void set (BusCompressorDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

BusCompressorDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.RunTimePresetB Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As BusCompressorDeviceRunTimePreset
C#
public BusCompressorDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property BusCompressorDeviceRunTimePreset^ RunTimePresetB {
    BusCompressorDeviceRunTimePreset^ get ();
    void set (BusCompressorDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

BusCompressorDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.SelectedPresetIsModified Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

BusCompressorDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.SelectedPresetName Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

BusCompressorDevice Class


Threshold Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.Threshold Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As BusCompressorDeviceThreshold
C#
public BusCompressorDeviceThreshold Threshold { get; set; }
Visual C++
public:
property BusCompressorDeviceThreshold^ Threshold {
    BusCompressorDeviceThreshold^ get ();
    void set (BusCompressorDeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

BusCompressorDevice Class


type Property

[image]

.NET Framework Class Library
BusCompressorDevice..::.type Property
BusCompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

BusCompressorDevice Class


BusCompressorDeviceAttack Class

[image]

.NET Framework Class Library
BusCompressorDeviceAttack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceAttack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceAttack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceAttack
JavaScript
NRenoiseTools.BusCompressorDeviceAttack = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceAttack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceAttack

See Also

BusCompressorDeviceAttack Members


BusCompressorDeviceAttack Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttack Members
BusCompressorDeviceAttack Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceAttack type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceAttack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceAttack Class


BusCompressorDeviceAttack Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceAttack Constructor
BusCompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceAttack()
Visual C++
public:
BusCompressorDeviceAttack()
JavaScript
NRenoiseTools.BusCompressorDeviceAttack = function();

See Also

BusCompressorDeviceAttack Class


BusCompressorDeviceAttack Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttack Methods
BusCompressorDeviceAttack Class See Also Send Feedback

The BusCompressorDeviceAttack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceAttack Class


BusCompressorDeviceAttack Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttack Properties
BusCompressorDeviceAttack Class See Also Send Feedback

The BusCompressorDeviceAttack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceAttack Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceAttack..::.MidiMappings Property
BusCompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceAttack Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceAttack..::.Value Property
BusCompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceAttack Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceAttack..::.Visualization Property
BusCompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceAttackVisualization
C#
public BusCompressorDeviceAttackVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceAttackVisualization Visualization {
    BusCompressorDeviceAttackVisualization get ();
    void set (BusCompressorDeviceAttackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceAttack Class


BusCompressorDeviceAttackRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceAttackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceAttackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceAttackRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceAttackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceAttackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceAttackRunTimePreset

See Also

BusCompressorDeviceAttackRunTimePreset Members


BusCompressorDeviceAttackRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset Members
BusCompressorDeviceAttackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceAttackRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceAttackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceAttackRunTimePreset Class


BusCompressorDeviceAttackRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset Constructor
BusCompressorDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceAttackRunTimePreset()
Visual C++
public:
BusCompressorDeviceAttackRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceAttackRunTimePreset = function();

See Also

BusCompressorDeviceAttackRunTimePreset Class


BusCompressorDeviceAttackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset Methods
BusCompressorDeviceAttackRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceAttackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceAttackRunTimePreset Class


BusCompressorDeviceAttackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset Properties
BusCompressorDeviceAttackRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceAttackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceAttackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceAttackRunTimePreset..::.Value Property
BusCompressorDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceAttackRunTimePreset Class


BusCompressorDeviceAttackVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceAttackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceAttackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceAttackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceAttackVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceAttackVisualization = function();
NRenoiseTools.BusCompressorDeviceAttackVisualization.createEnum('NRenoiseTools.BusCompressorDeviceAttackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


BusCompressorDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceDeviceSlotRunTimePreset

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Members


BusCompressorDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset Members
BusCompressorDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Knee |
MakeUp |
Ratio |
Release |
Threshold |
type |

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


BusCompressorDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset Constructor
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceDeviceSlotRunTimePreset()
Visual C++
public:
BusCompressorDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceDeviceSlotRunTimePreset = function();

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


BusCompressorDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset Methods
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


BusCompressorDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset Properties
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Attack |
Knee |
MakeUp |
Ratio |
Release |
Threshold |
type |

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


Attack Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.Attack Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As BusCompressorDeviceAttackRunTimePreset
C#
public BusCompressorDeviceAttackRunTimePreset Attack { get; set; }
Visual C++
public:
property BusCompressorDeviceAttackRunTimePreset^ Attack {
    BusCompressorDeviceAttackRunTimePreset^ get ();
    void set (BusCompressorDeviceAttackRunTimePreset^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


Knee Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.Knee Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Knee As BusCompressorDeviceKneeRunTimePreset
C#
public BusCompressorDeviceKneeRunTimePreset Knee { get; set; }
Visual C++
public:
property BusCompressorDeviceKneeRunTimePreset^ Knee {
    BusCompressorDeviceKneeRunTimePreset^ get ();
    void set (BusCompressorDeviceKneeRunTimePreset^ value);
}
JavaScript
function get_knee();
function set_knee(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


MakeUp Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.MakeUp Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MakeUp As BusCompressorDeviceMakeUpRunTimePreset
C#
public BusCompressorDeviceMakeUpRunTimePreset MakeUp { get; set; }
Visual C++
public:
property BusCompressorDeviceMakeUpRunTimePreset^ MakeUp {
    BusCompressorDeviceMakeUpRunTimePreset^ get ();
    void set (BusCompressorDeviceMakeUpRunTimePreset^ value);
}
JavaScript
function get_makeUp();
function set_makeUp(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


Ratio Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.Ratio Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As BusCompressorDeviceRatioRunTimePreset
C#
public BusCompressorDeviceRatioRunTimePreset Ratio { get; set; }
Visual C++
public:
property BusCompressorDeviceRatioRunTimePreset^ Ratio {
    BusCompressorDeviceRatioRunTimePreset^ get ();
    void set (BusCompressorDeviceRatioRunTimePreset^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


Release Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.Release Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As BusCompressorDeviceReleaseRunTimePreset
C#
public BusCompressorDeviceReleaseRunTimePreset Release { get; set; }
Visual C++
public:
property BusCompressorDeviceReleaseRunTimePreset^ Release {
    BusCompressorDeviceReleaseRunTimePreset^ get ();
    void set (BusCompressorDeviceReleaseRunTimePreset^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.Threshold Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As BusCompressorDeviceThresholdRunTimePreset
C#
public BusCompressorDeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property BusCompressorDeviceThresholdRunTimePreset^ Threshold {
    BusCompressorDeviceThresholdRunTimePreset^ get ();
    void set (BusCompressorDeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
BusCompressorDeviceDeviceSlotRunTimePreset..::.type Property
BusCompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

BusCompressorDeviceDeviceSlotRunTimePreset Class


BusCompressorDeviceKnee Class

[image]

.NET Framework Class Library
BusCompressorDeviceKnee Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceKnee
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceKnee
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceKnee
JavaScript
NRenoiseTools.BusCompressorDeviceKnee = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceKnee');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceKnee

See Also

BusCompressorDeviceKnee Members


BusCompressorDeviceKnee Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKnee Members
BusCompressorDeviceKnee Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceKnee type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceKnee |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceKnee Class


BusCompressorDeviceKnee Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceKnee Constructor
BusCompressorDeviceKnee Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceKnee()
Visual C++
public:
BusCompressorDeviceKnee()
JavaScript
NRenoiseTools.BusCompressorDeviceKnee = function();

See Also

BusCompressorDeviceKnee Class


BusCompressorDeviceKnee Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKnee Methods
BusCompressorDeviceKnee Class See Also Send Feedback

The BusCompressorDeviceKnee type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceKnee Class


BusCompressorDeviceKnee Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKnee Properties
BusCompressorDeviceKnee Class See Also Send Feedback

The BusCompressorDeviceKnee type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceKnee Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceKnee..::.MidiMappings Property
BusCompressorDeviceKnee Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceKnee Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceKnee..::.Value Property
BusCompressorDeviceKnee Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceKnee Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceKnee..::.Visualization Property
BusCompressorDeviceKnee Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceKneeVisualization
C#
public BusCompressorDeviceKneeVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceKneeVisualization Visualization {
    BusCompressorDeviceKneeVisualization get ();
    void set (BusCompressorDeviceKneeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceKnee Class


BusCompressorDeviceKneeRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceKneeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceKneeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceKneeRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceKneeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceKneeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceKneeRunTimePreset

See Also

BusCompressorDeviceKneeRunTimePreset Members


BusCompressorDeviceKneeRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset Members
BusCompressorDeviceKneeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceKneeRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceKneeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceKneeRunTimePreset Class


BusCompressorDeviceKneeRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset Constructor
BusCompressorDeviceKneeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceKneeRunTimePreset()
Visual C++
public:
BusCompressorDeviceKneeRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceKneeRunTimePreset = function();

See Also

BusCompressorDeviceKneeRunTimePreset Class


BusCompressorDeviceKneeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset Methods
BusCompressorDeviceKneeRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceKneeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceKneeRunTimePreset Class


BusCompressorDeviceKneeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset Properties
BusCompressorDeviceKneeRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceKneeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceKneeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceKneeRunTimePreset..::.Value Property
BusCompressorDeviceKneeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceKneeRunTimePreset Class


BusCompressorDeviceKneeVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceKneeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceKneeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceKneeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceKneeVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceKneeVisualization = function();
NRenoiseTools.BusCompressorDeviceKneeVisualization.createEnum('NRenoiseTools.BusCompressorDeviceKneeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


BusCompressorDeviceMakeUp Class

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUp Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceMakeUp
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceMakeUp
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceMakeUp
JavaScript
NRenoiseTools.BusCompressorDeviceMakeUp = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceMakeUp');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceMakeUp

See Also

BusCompressorDeviceMakeUp Members


BusCompressorDeviceMakeUp Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUp Members
BusCompressorDeviceMakeUp Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceMakeUp type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceMakeUp |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceMakeUp Class


BusCompressorDeviceMakeUp Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUp Constructor
BusCompressorDeviceMakeUp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceMakeUp()
Visual C++
public:
BusCompressorDeviceMakeUp()
JavaScript
NRenoiseTools.BusCompressorDeviceMakeUp = function();

See Also

BusCompressorDeviceMakeUp Class


BusCompressorDeviceMakeUp Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUp Methods
BusCompressorDeviceMakeUp Class See Also Send Feedback

The BusCompressorDeviceMakeUp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceMakeUp Class


BusCompressorDeviceMakeUp Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUp Properties
BusCompressorDeviceMakeUp Class See Also Send Feedback

The BusCompressorDeviceMakeUp type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceMakeUp Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUp..::.MidiMappings Property
BusCompressorDeviceMakeUp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceMakeUp Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUp..::.Value Property
BusCompressorDeviceMakeUp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceMakeUp Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUp..::.Visualization Property
BusCompressorDeviceMakeUp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceMakeUpVisualization
C#
public BusCompressorDeviceMakeUpVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceMakeUpVisualization Visualization {
    BusCompressorDeviceMakeUpVisualization get ();
    void set (BusCompressorDeviceMakeUpVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceMakeUp Class


BusCompressorDeviceMakeUpRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceMakeUpRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceMakeUpRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceMakeUpRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceMakeUpRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceMakeUpRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceMakeUpRunTimePreset

See Also

BusCompressorDeviceMakeUpRunTimePreset Members


BusCompressorDeviceMakeUpRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset Members
BusCompressorDeviceMakeUpRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceMakeUpRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceMakeUpRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceMakeUpRunTimePreset Class


BusCompressorDeviceMakeUpRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset Constructor
BusCompressorDeviceMakeUpRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceMakeUpRunTimePreset()
Visual C++
public:
BusCompressorDeviceMakeUpRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceMakeUpRunTimePreset = function();

See Also

BusCompressorDeviceMakeUpRunTimePreset Class


BusCompressorDeviceMakeUpRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset Methods
BusCompressorDeviceMakeUpRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceMakeUpRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceMakeUpRunTimePreset Class


BusCompressorDeviceMakeUpRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset Properties
BusCompressorDeviceMakeUpRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceMakeUpRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceMakeUpRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUpRunTimePreset..::.Value Property
BusCompressorDeviceMakeUpRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceMakeUpRunTimePreset Class


BusCompressorDeviceMakeUpVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceMakeUpVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceMakeUpVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceMakeUpVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceMakeUpVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceMakeUpVisualization = function();
NRenoiseTools.BusCompressorDeviceMakeUpVisualization.createEnum('NRenoiseTools.BusCompressorDeviceMakeUpVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


BusCompressorDeviceRatio Class

[image]

.NET Framework Class Library
BusCompressorDeviceRatio Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceRatio
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceRatio
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceRatio
JavaScript
NRenoiseTools.BusCompressorDeviceRatio = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceRatio');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceRatio

See Also

BusCompressorDeviceRatio Members


BusCompressorDeviceRatio Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatio Members
BusCompressorDeviceRatio Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceRatio type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceRatio |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceRatio Class


BusCompressorDeviceRatio Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceRatio Constructor
BusCompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceRatio()
Visual C++
public:
BusCompressorDeviceRatio()
JavaScript
NRenoiseTools.BusCompressorDeviceRatio = function();

See Also

BusCompressorDeviceRatio Class


BusCompressorDeviceRatio Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatio Methods
BusCompressorDeviceRatio Class See Also Send Feedback

The BusCompressorDeviceRatio type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceRatio Class


BusCompressorDeviceRatio Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatio Properties
BusCompressorDeviceRatio Class See Also Send Feedback

The BusCompressorDeviceRatio type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceRatio Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceRatio..::.MidiMappings Property
BusCompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceRatio Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceRatio..::.Value Property
BusCompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceRatio Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceRatio..::.Visualization Property
BusCompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceRatioVisualization
C#
public BusCompressorDeviceRatioVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceRatioVisualization Visualization {
    BusCompressorDeviceRatioVisualization get ();
    void set (BusCompressorDeviceRatioVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceRatio Class


BusCompressorDeviceRatioRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceRatioRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceRatioRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceRatioRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceRatioRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceRatioRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceRatioRunTimePreset

See Also

BusCompressorDeviceRatioRunTimePreset Members


BusCompressorDeviceRatioRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset Members
BusCompressorDeviceRatioRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceRatioRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceRatioRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceRatioRunTimePreset Class


BusCompressorDeviceRatioRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset Constructor
BusCompressorDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceRatioRunTimePreset()
Visual C++
public:
BusCompressorDeviceRatioRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceRatioRunTimePreset = function();

See Also

BusCompressorDeviceRatioRunTimePreset Class


BusCompressorDeviceRatioRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset Methods
BusCompressorDeviceRatioRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceRatioRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceRatioRunTimePreset Class


BusCompressorDeviceRatioRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset Properties
BusCompressorDeviceRatioRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceRatioRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceRatioRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceRatioRunTimePreset..::.Value Property
BusCompressorDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceRatioRunTimePreset Class


BusCompressorDeviceRatioVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceRatioVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceRatioVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceRatioVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceRatioVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceRatioVisualization = function();
NRenoiseTools.BusCompressorDeviceRatioVisualization.createEnum('NRenoiseTools.BusCompressorDeviceRatioVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


BusCompressorDeviceRelease Class

[image]

.NET Framework Class Library
BusCompressorDeviceRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceRelease
JavaScript
NRenoiseTools.BusCompressorDeviceRelease = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceRelease

See Also

BusCompressorDeviceRelease Members


BusCompressorDeviceRelease Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRelease Members
BusCompressorDeviceRelease Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceRelease type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceRelease Class


BusCompressorDeviceRelease Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceRelease Constructor
BusCompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceRelease()
Visual C++
public:
BusCompressorDeviceRelease()
JavaScript
NRenoiseTools.BusCompressorDeviceRelease = function();

See Also

BusCompressorDeviceRelease Class


BusCompressorDeviceRelease Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRelease Methods
BusCompressorDeviceRelease Class See Also Send Feedback

The BusCompressorDeviceRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceRelease Class


BusCompressorDeviceRelease Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRelease Properties
BusCompressorDeviceRelease Class See Also Send Feedback

The BusCompressorDeviceRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceRelease..::.MidiMappings Property
BusCompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceRelease Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceRelease..::.Value Property
BusCompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceRelease Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceRelease..::.Visualization Property
BusCompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceReleaseVisualization
C#
public BusCompressorDeviceReleaseVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceReleaseVisualization Visualization {
    BusCompressorDeviceReleaseVisualization get ();
    void set (BusCompressorDeviceReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceRelease Class


BusCompressorDeviceReleaseRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceReleaseRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceReleaseRunTimePreset

See Also

BusCompressorDeviceReleaseRunTimePreset Members


BusCompressorDeviceReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset Members
BusCompressorDeviceReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceReleaseRunTimePreset Class


BusCompressorDeviceReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset Constructor
BusCompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceReleaseRunTimePreset()
Visual C++
public:
BusCompressorDeviceReleaseRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceReleaseRunTimePreset = function();

See Also

BusCompressorDeviceReleaseRunTimePreset Class


BusCompressorDeviceReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset Methods
BusCompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceReleaseRunTimePreset Class


BusCompressorDeviceReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset Properties
BusCompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceReleaseRunTimePreset..::.Value Property
BusCompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceReleaseRunTimePreset Class


BusCompressorDeviceReleaseVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceReleaseVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceReleaseVisualization = function();
NRenoiseTools.BusCompressorDeviceReleaseVisualization.createEnum('NRenoiseTools.BusCompressorDeviceReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


BusCompressorDeviceRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceRunTimePreset

See Also

BusCompressorDeviceRunTimePreset Members


BusCompressorDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset Members
BusCompressorDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

BusCompressorDeviceRunTimePreset Class


BusCompressorDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset Constructor
BusCompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceRunTimePreset()
Visual C++
public:
BusCompressorDeviceRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceRunTimePreset = function();

See Also

BusCompressorDeviceRunTimePreset Class


BusCompressorDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset Methods
BusCompressorDeviceRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceRunTimePreset Class


BusCompressorDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset Properties
BusCompressorDeviceRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

BusCompressorDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset..::.DeviceSlot Property
BusCompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As BusCompressorDeviceDeviceSlotRunTimePreset
C#
public BusCompressorDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property BusCompressorDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    BusCompressorDeviceDeviceSlotRunTimePreset^ get ();
    void set (BusCompressorDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

BusCompressorDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
BusCompressorDeviceRunTimePreset..::.type Property
BusCompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

BusCompressorDeviceRunTimePreset Class


BusCompressorDeviceThreshold Class

[image]

.NET Framework Class Library
BusCompressorDeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceThreshold
JavaScript
NRenoiseTools.BusCompressorDeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceThreshold

See Also

BusCompressorDeviceThreshold Members


BusCompressorDeviceThreshold Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThreshold Members
BusCompressorDeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceThreshold type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceThreshold Class


BusCompressorDeviceThreshold Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceThreshold Constructor
BusCompressorDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceThreshold()
Visual C++
public:
BusCompressorDeviceThreshold()
JavaScript
NRenoiseTools.BusCompressorDeviceThreshold = function();

See Also

BusCompressorDeviceThreshold Class


BusCompressorDeviceThreshold Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThreshold Methods
BusCompressorDeviceThreshold Class See Also Send Feedback

The BusCompressorDeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceThreshold Class


BusCompressorDeviceThreshold Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThreshold Properties
BusCompressorDeviceThreshold Class See Also Send Feedback

The BusCompressorDeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

BusCompressorDeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
BusCompressorDeviceThreshold..::.MidiMappings Property
BusCompressorDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

BusCompressorDeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceThreshold..::.Value Property
BusCompressorDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
BusCompressorDeviceThreshold..::.Visualization Property
BusCompressorDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As BusCompressorDeviceThresholdVisualization
C#
public BusCompressorDeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property BusCompressorDeviceThresholdVisualization Visualization {
    BusCompressorDeviceThresholdVisualization get ();
    void set (BusCompressorDeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

BusCompressorDeviceThreshold Class


BusCompressorDeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class BusCompressorDeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class BusCompressorDeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class BusCompressorDeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.BusCompressorDeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.BusCompressorDeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.BusCompressorDeviceThresholdRunTimePreset

See Also

BusCompressorDeviceThresholdRunTimePreset Members


BusCompressorDeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset Members
BusCompressorDeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The BusCompressorDeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
BusCompressorDeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

BusCompressorDeviceThresholdRunTimePreset Class


BusCompressorDeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset Constructor
BusCompressorDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusCompressorDeviceThresholdRunTimePreset()
Visual C++
public:
BusCompressorDeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.BusCompressorDeviceThresholdRunTimePreset = function();

See Also

BusCompressorDeviceThresholdRunTimePreset Class


BusCompressorDeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset Methods
BusCompressorDeviceThresholdRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusCompressorDeviceThresholdRunTimePreset Class


BusCompressorDeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset Properties
BusCompressorDeviceThresholdRunTimePreset Class See Also Send Feedback

The BusCompressorDeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

BusCompressorDeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
BusCompressorDeviceThresholdRunTimePreset..::.Value Property
BusCompressorDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

BusCompressorDeviceThresholdRunTimePreset Class


BusCompressorDeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
BusCompressorDeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration BusCompressorDeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum BusCompressorDeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class BusCompressorDeviceThresholdVisualization
JavaScript
NRenoiseTools.BusCompressorDeviceThresholdVisualization = function();
NRenoiseTools.BusCompressorDeviceThresholdVisualization.createEnum('NRenoiseTools.BusCompressorDeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDevice Class

[image]

.NET Framework Class Library
ChorusDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDevice
JavaScript
NRenoiseTools.ChorusDevice = function();

Type.createClass(
    'NRenoiseTools.ChorusDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDevice

See Also

ChorusDevice Members


ChorusDevice Members

[image] [image]

.NET Framework Class Library
ChorusDevice Members
ChorusDevice Class Constructors Methods Properties See Also Send Feedback

The ChorusDevice type exposes the following members.

Constructors

Name | Description
ChorusDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delay |
DryWetMix |
Feedback |
FilterFreq |
FilterResonance |
FilterType |
IsActive |
IsSelected |
LfoDepth |
LfoRate |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

ChorusDevice Class


ChorusDevice Constructor

[image]

.NET Framework Class Library
ChorusDevice Constructor
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDevice()
Visual C++
public:
ChorusDevice()
JavaScript
NRenoiseTools.ChorusDevice = function();

See Also

ChorusDevice Class


ChorusDevice Methods

[image] [image]

.NET Framework Class Library
ChorusDevice Methods
ChorusDevice Class See Also Send Feedback

The ChorusDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDevice Class


ChorusDevice Properties

[image] [image]

.NET Framework Class Library
ChorusDevice Properties
ChorusDevice Class See Also Send Feedback

The ChorusDevice type exposes the following members.

Properties

Name | Description
Delay |
DryWetMix |
Feedback |
FilterFreq |
FilterResonance |
FilterType |
IsActive |
IsSelected |
LfoDepth |
LfoRate |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

ChorusDevice Class


Delay Property

[image]

.NET Framework Class Library
ChorusDevice..::.Delay Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As ChorusDeviceDelay
C#
public ChorusDeviceDelay Delay { get; set; }
Visual C++
public:
property ChorusDeviceDelay^ Delay {
    ChorusDeviceDelay^ get ();
    void set (ChorusDeviceDelay^ value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

ChorusDevice Class


DryWetMix Property

[image]

.NET Framework Class Library
ChorusDevice..::.DryWetMix Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryWetMix As ChorusDeviceDryWetMix
C#
public ChorusDeviceDryWetMix DryWetMix { get; set; }
Visual C++
public:
property ChorusDeviceDryWetMix^ DryWetMix {
    ChorusDeviceDryWetMix^ get ();
    void set (ChorusDeviceDryWetMix^ value);
}
JavaScript
function get_dryWetMix();
function set_dryWetMix(value);

Remarks

See Also

ChorusDevice Class


Feedback Property

[image]

.NET Framework Class Library
ChorusDevice..::.Feedback Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Feedback As ChorusDeviceFeedback
C#
public ChorusDeviceFeedback Feedback { get; set; }
Visual C++
public:
property ChorusDeviceFeedback^ Feedback {
    ChorusDeviceFeedback^ get ();
    void set (ChorusDeviceFeedback^ value);
}
JavaScript
function get_feedback();
function set_feedback(value);

Remarks

See Also

ChorusDevice Class


FilterFreq Property

[image]

.NET Framework Class Library
ChorusDevice..::.FilterFreq Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterFreq As ChorusDeviceFilterFreq
C#
public ChorusDeviceFilterFreq FilterFreq { get; set; }
Visual C++
public:
property ChorusDeviceFilterFreq^ FilterFreq {
    ChorusDeviceFilterFreq^ get ();
    void set (ChorusDeviceFilterFreq^ value);
}
JavaScript
function get_filterFreq();
function set_filterFreq(value);

Remarks

See Also

ChorusDevice Class


FilterResonance Property

[image]

.NET Framework Class Library
ChorusDevice..::.FilterResonance Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterResonance As ChorusDeviceFilterResonance
C#
public ChorusDeviceFilterResonance FilterResonance { get; set; }
Visual C++
public:
property ChorusDeviceFilterResonance^ FilterResonance {
    ChorusDeviceFilterResonance^ get ();
    void set (ChorusDeviceFilterResonance^ value);
}
JavaScript
function get_filterResonance();
function set_filterResonance(value);

Remarks

See Also

ChorusDevice Class


FilterType Property

[image]

.NET Framework Class Library
ChorusDevice..::.FilterType Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As ChorusDeviceFilterType
C#
public ChorusDeviceFilterType FilterType { get; set; }
Visual C++
public:
property ChorusDeviceFilterType^ FilterType {
    ChorusDeviceFilterType^ get ();
    void set (ChorusDeviceFilterType^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

ChorusDevice Class


IsActive Property

[image]

.NET Framework Class Library
ChorusDevice..::.IsActive Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

ChorusDevice Class


IsSelected Property

[image]

.NET Framework Class Library
ChorusDevice..::.IsSelected Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

ChorusDevice Class


LfoDepth Property

[image]

.NET Framework Class Library
ChorusDevice..::.LfoDepth Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDepth As ChorusDeviceLfoDepth
C#
public ChorusDeviceLfoDepth LfoDepth { get; set; }
Visual C++
public:
property ChorusDeviceLfoDepth^ LfoDepth {
    ChorusDeviceLfoDepth^ get ();
    void set (ChorusDeviceLfoDepth^ value);
}
JavaScript
function get_lfoDepth();
function set_lfoDepth(value);

Remarks

See Also

ChorusDevice Class


LfoRate Property

[image]

.NET Framework Class Library
ChorusDevice..::.LfoRate Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoRate As ChorusDeviceLfoRate
C#
public ChorusDeviceLfoRate LfoRate { get; set; }
Visual C++
public:
property ChorusDeviceLfoRate^ LfoRate {
    ChorusDeviceLfoRate^ get ();
    void set (ChorusDeviceLfoRate^ value);
}
JavaScript
function get_lfoRate();
function set_lfoRate(value);

Remarks

See Also

ChorusDevice Class


Phase Property

[image]

.NET Framework Class Library
ChorusDevice..::.Phase Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As ChorusDevicePhase
C#
public ChorusDevicePhase Phase { get; set; }
Visual C++
public:
property ChorusDevicePhase^ Phase {
    ChorusDevicePhase^ get ();
    void set (ChorusDevicePhase^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

ChorusDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
ChorusDevice..::.RunTimePresetA Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As ChorusDeviceRunTimePreset
C#
public ChorusDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property ChorusDeviceRunTimePreset^ RunTimePresetA {
    ChorusDeviceRunTimePreset^ get ();
    void set (ChorusDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

ChorusDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
ChorusDevice..::.RunTimePresetB Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As ChorusDeviceRunTimePreset
C#
public ChorusDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property ChorusDeviceRunTimePreset^ RunTimePresetB {
    ChorusDeviceRunTimePreset^ get ();
    void set (ChorusDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

ChorusDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
ChorusDevice..::.SelectedPresetIsModified Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

ChorusDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
ChorusDevice..::.SelectedPresetName Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

ChorusDevice Class


type Property

[image]

.NET Framework Class Library
ChorusDevice..::.type Property
ChorusDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ChorusDevice Class


ChorusDeviceDelay Class

[image]

.NET Framework Class Library
ChorusDeviceDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceDelay
JavaScript
NRenoiseTools.ChorusDeviceDelay = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceDelay

See Also

ChorusDeviceDelay Members


ChorusDeviceDelay Members

[image] [image]

.NET Framework Class Library
ChorusDeviceDelay Members
ChorusDeviceDelay Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceDelay type exposes the following members.

Constructors

Name | Description
ChorusDeviceDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceDelay Class


ChorusDeviceDelay Constructor

[image]

.NET Framework Class Library
ChorusDeviceDelay Constructor
ChorusDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceDelay()
Visual C++
public:
ChorusDeviceDelay()
JavaScript
NRenoiseTools.ChorusDeviceDelay = function();

See Also

ChorusDeviceDelay Class


ChorusDeviceDelay Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceDelay Methods
ChorusDeviceDelay Class See Also Send Feedback

The ChorusDeviceDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceDelay Class


ChorusDeviceDelay Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceDelay Properties
ChorusDeviceDelay Class See Also Send Feedback

The ChorusDeviceDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceDelay..::.MidiMappings Property
ChorusDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceDelay Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceDelay..::.Value Property
ChorusDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceDelay Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceDelay..::.Visualization Property
ChorusDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceDelayVisualization
C#
public ChorusDeviceDelayVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceDelayVisualization Visualization {
    ChorusDeviceDelayVisualization get ();
    void set (ChorusDeviceDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceDelay Class


ChorusDeviceDelayRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceDelayRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceDelayRunTimePreset

See Also

ChorusDeviceDelayRunTimePreset Members


ChorusDeviceDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset Members
ChorusDeviceDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceDelayRunTimePreset Class


ChorusDeviceDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset Constructor
ChorusDeviceDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceDelayRunTimePreset()
Visual C++
public:
ChorusDeviceDelayRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceDelayRunTimePreset = function();

See Also

ChorusDeviceDelayRunTimePreset Class


ChorusDeviceDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset Methods
ChorusDeviceDelayRunTimePreset Class See Also Send Feedback

The ChorusDeviceDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceDelayRunTimePreset Class


ChorusDeviceDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset Properties
ChorusDeviceDelayRunTimePreset Class See Also Send Feedback

The ChorusDeviceDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceDelayRunTimePreset..::.Value Property
ChorusDeviceDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceDelayRunTimePreset Class


ChorusDeviceDelayVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceDelayVisualization
JavaScript
NRenoiseTools.ChorusDeviceDelayVisualization = function();
NRenoiseTools.ChorusDeviceDelayVisualization.createEnum('NRenoiseTools.ChorusDeviceDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceDeviceSlotRunTimePreset

See Also

ChorusDeviceDeviceSlotRunTimePreset Members


ChorusDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset Members
ChorusDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delay |
DryWetMix |
Feedback |
FilterFreq |
FilterResonance |
FilterType |
LfoDepth |
LfoRate |
Phase |
type |

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


ChorusDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset Constructor
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceDeviceSlotRunTimePreset()
Visual C++
public:
ChorusDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceDeviceSlotRunTimePreset = function();

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


ChorusDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset Methods
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ChorusDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


ChorusDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset Properties
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ChorusDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Delay |
DryWetMix |
Feedback |
FilterFreq |
FilterResonance |
FilterType |
LfoDepth |
LfoRate |
Phase |
type |

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


Delay Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.Delay Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As ChorusDeviceDelayRunTimePreset
C#
public ChorusDeviceDelayRunTimePreset Delay { get; set; }
Visual C++
public:
property ChorusDeviceDelayRunTimePreset^ Delay {
    ChorusDeviceDelayRunTimePreset^ get ();
    void set (ChorusDeviceDelayRunTimePreset^ value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


DryWetMix Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.DryWetMix Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryWetMix As ChorusDeviceDryWetMixRunTimePreset
C#
public ChorusDeviceDryWetMixRunTimePreset DryWetMix { get; set; }
Visual C++
public:
property ChorusDeviceDryWetMixRunTimePreset^ DryWetMix {
    ChorusDeviceDryWetMixRunTimePreset^ get ();
    void set (ChorusDeviceDryWetMixRunTimePreset^ value);
}
JavaScript
function get_dryWetMix();
function set_dryWetMix(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


Feedback Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.Feedback Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Feedback As ChorusDeviceFeedbackRunTimePreset
C#
public ChorusDeviceFeedbackRunTimePreset Feedback { get; set; }
Visual C++
public:
property ChorusDeviceFeedbackRunTimePreset^ Feedback {
    ChorusDeviceFeedbackRunTimePreset^ get ();
    void set (ChorusDeviceFeedbackRunTimePreset^ value);
}
JavaScript
function get_feedback();
function set_feedback(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


FilterFreq Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.FilterFreq Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterFreq As ChorusDeviceFilterFreqRunTimePreset
C#
public ChorusDeviceFilterFreqRunTimePreset FilterFreq { get; set; }
Visual C++
public:
property ChorusDeviceFilterFreqRunTimePreset^ FilterFreq {
    ChorusDeviceFilterFreqRunTimePreset^ get ();
    void set (ChorusDeviceFilterFreqRunTimePreset^ value);
}
JavaScript
function get_filterFreq();
function set_filterFreq(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


FilterResonance Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.FilterResonance Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterResonance As ChorusDeviceFilterResonanceRunTimePreset
C#
public ChorusDeviceFilterResonanceRunTimePreset FilterResonance { get; set; }
Visual C++
public:
property ChorusDeviceFilterResonanceRunTimePreset^ FilterResonance {
    ChorusDeviceFilterResonanceRunTimePreset^ get ();
    void set (ChorusDeviceFilterResonanceRunTimePreset^ value);
}
JavaScript
function get_filterResonance();
function set_filterResonance(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


FilterType Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.FilterType Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As ChorusDeviceFilterTypeRunTimePreset
C#
public ChorusDeviceFilterTypeRunTimePreset FilterType { get; set; }
Visual C++
public:
property ChorusDeviceFilterTypeRunTimePreset^ FilterType {
    ChorusDeviceFilterTypeRunTimePreset^ get ();
    void set (ChorusDeviceFilterTypeRunTimePreset^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


LfoDepth Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.LfoDepth Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDepth As ChorusDeviceLfoDepthRunTimePreset
C#
public ChorusDeviceLfoDepthRunTimePreset LfoDepth { get; set; }
Visual C++
public:
property ChorusDeviceLfoDepthRunTimePreset^ LfoDepth {
    ChorusDeviceLfoDepthRunTimePreset^ get ();
    void set (ChorusDeviceLfoDepthRunTimePreset^ value);
}
JavaScript
function get_lfoDepth();
function set_lfoDepth(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


LfoRate Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.LfoRate Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoRate As ChorusDeviceLfoRateRunTimePreset
C#
public ChorusDeviceLfoRateRunTimePreset LfoRate { get; set; }
Visual C++
public:
property ChorusDeviceLfoRateRunTimePreset^ LfoRate {
    ChorusDeviceLfoRateRunTimePreset^ get ();
    void set (ChorusDeviceLfoRateRunTimePreset^ value);
}
JavaScript
function get_lfoRate();
function set_lfoRate(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


Phase Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.Phase Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As ChorusDevicePhaseRunTimePreset
C#
public ChorusDevicePhaseRunTimePreset Phase { get; set; }
Visual C++
public:
property ChorusDevicePhaseRunTimePreset^ Phase {
    ChorusDevicePhaseRunTimePreset^ get ();
    void set (ChorusDevicePhaseRunTimePreset^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ChorusDeviceDeviceSlotRunTimePreset..::.type Property
ChorusDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ChorusDeviceDeviceSlotRunTimePreset Class


ChorusDeviceDryWetMix Class

[image]

.NET Framework Class Library
ChorusDeviceDryWetMix Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceDryWetMix
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceDryWetMix
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceDryWetMix
JavaScript
NRenoiseTools.ChorusDeviceDryWetMix = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceDryWetMix');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceDryWetMix

See Also

ChorusDeviceDryWetMix Members


ChorusDeviceDryWetMix Members

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMix Members
ChorusDeviceDryWetMix Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceDryWetMix type exposes the following members.

Constructors

Name | Description
ChorusDeviceDryWetMix |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceDryWetMix Class


ChorusDeviceDryWetMix Constructor

[image]

.NET Framework Class Library
ChorusDeviceDryWetMix Constructor
ChorusDeviceDryWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceDryWetMix()
Visual C++
public:
ChorusDeviceDryWetMix()
JavaScript
NRenoiseTools.ChorusDeviceDryWetMix = function();

See Also

ChorusDeviceDryWetMix Class


ChorusDeviceDryWetMix Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMix Methods
ChorusDeviceDryWetMix Class See Also Send Feedback

The ChorusDeviceDryWetMix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceDryWetMix Class


ChorusDeviceDryWetMix Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMix Properties
ChorusDeviceDryWetMix Class See Also Send Feedback

The ChorusDeviceDryWetMix type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceDryWetMix Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceDryWetMix..::.MidiMappings Property
ChorusDeviceDryWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceDryWetMix Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceDryWetMix..::.Value Property
ChorusDeviceDryWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceDryWetMix Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceDryWetMix..::.Visualization Property
ChorusDeviceDryWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceDryWetMixVisualization
C#
public ChorusDeviceDryWetMixVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceDryWetMixVisualization Visualization {
    ChorusDeviceDryWetMixVisualization get ();
    void set (ChorusDeviceDryWetMixVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceDryWetMix Class


ChorusDeviceDryWetMixRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceDryWetMixRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceDryWetMixRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceDryWetMixRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceDryWetMixRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceDryWetMixRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceDryWetMixRunTimePreset

See Also

ChorusDeviceDryWetMixRunTimePreset Members


ChorusDeviceDryWetMixRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset Members
ChorusDeviceDryWetMixRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceDryWetMixRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceDryWetMixRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceDryWetMixRunTimePreset Class


ChorusDeviceDryWetMixRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset Constructor
ChorusDeviceDryWetMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceDryWetMixRunTimePreset()
Visual C++
public:
ChorusDeviceDryWetMixRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceDryWetMixRunTimePreset = function();

See Also

ChorusDeviceDryWetMixRunTimePreset Class


ChorusDeviceDryWetMixRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset Methods
ChorusDeviceDryWetMixRunTimePreset Class See Also Send Feedback

The ChorusDeviceDryWetMixRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceDryWetMixRunTimePreset Class


ChorusDeviceDryWetMixRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset Properties
ChorusDeviceDryWetMixRunTimePreset Class See Also Send Feedback

The ChorusDeviceDryWetMixRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceDryWetMixRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceDryWetMixRunTimePreset..::.Value Property
ChorusDeviceDryWetMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceDryWetMixRunTimePreset Class


ChorusDeviceDryWetMixVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceDryWetMixVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceDryWetMixVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceDryWetMixVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceDryWetMixVisualization
JavaScript
NRenoiseTools.ChorusDeviceDryWetMixVisualization = function();
NRenoiseTools.ChorusDeviceDryWetMixVisualization.createEnum('NRenoiseTools.ChorusDeviceDryWetMixVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceFeedback Class

[image]

.NET Framework Class Library
ChorusDeviceFeedback Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFeedback
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFeedback
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFeedback
JavaScript
NRenoiseTools.ChorusDeviceFeedback = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFeedback');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFeedback

See Also

ChorusDeviceFeedback Members


ChorusDeviceFeedback Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedback Members
ChorusDeviceFeedback Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFeedback type exposes the following members.

Constructors

Name | Description
ChorusDeviceFeedback |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFeedback Class


ChorusDeviceFeedback Constructor

[image]

.NET Framework Class Library
ChorusDeviceFeedback Constructor
ChorusDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFeedback()
Visual C++
public:
ChorusDeviceFeedback()
JavaScript
NRenoiseTools.ChorusDeviceFeedback = function();

See Also

ChorusDeviceFeedback Class


ChorusDeviceFeedback Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedback Methods
ChorusDeviceFeedback Class See Also Send Feedback

The ChorusDeviceFeedback type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFeedback Class


ChorusDeviceFeedback Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedback Properties
ChorusDeviceFeedback Class See Also Send Feedback

The ChorusDeviceFeedback type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFeedback Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceFeedback..::.MidiMappings Property
ChorusDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceFeedback Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFeedback..::.Value Property
ChorusDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFeedback Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceFeedback..::.Visualization Property
ChorusDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceFeedbackVisualization
C#
public ChorusDeviceFeedbackVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceFeedbackVisualization Visualization {
    ChorusDeviceFeedbackVisualization get ();
    void set (ChorusDeviceFeedbackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceFeedback Class


ChorusDeviceFeedbackRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFeedbackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFeedbackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFeedbackRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceFeedbackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFeedbackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFeedbackRunTimePreset

See Also

ChorusDeviceFeedbackRunTimePreset Members


ChorusDeviceFeedbackRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset Members
ChorusDeviceFeedbackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFeedbackRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceFeedbackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceFeedbackRunTimePreset Class


ChorusDeviceFeedbackRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset Constructor
ChorusDeviceFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFeedbackRunTimePreset()
Visual C++
public:
ChorusDeviceFeedbackRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceFeedbackRunTimePreset = function();

See Also

ChorusDeviceFeedbackRunTimePreset Class


ChorusDeviceFeedbackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset Methods
ChorusDeviceFeedbackRunTimePreset Class See Also Send Feedback

The ChorusDeviceFeedbackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFeedbackRunTimePreset Class


ChorusDeviceFeedbackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset Properties
ChorusDeviceFeedbackRunTimePreset Class See Also Send Feedback

The ChorusDeviceFeedbackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceFeedbackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFeedbackRunTimePreset..::.Value Property
ChorusDeviceFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFeedbackRunTimePreset Class


ChorusDeviceFeedbackVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceFeedbackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceFeedbackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceFeedbackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceFeedbackVisualization
JavaScript
NRenoiseTools.ChorusDeviceFeedbackVisualization = function();
NRenoiseTools.ChorusDeviceFeedbackVisualization.createEnum('NRenoiseTools.ChorusDeviceFeedbackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceFilterFreq Class

[image]

.NET Framework Class Library
ChorusDeviceFilterFreq Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterFreq
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterFreq
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterFreq
JavaScript
NRenoiseTools.ChorusDeviceFilterFreq = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterFreq');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterFreq

See Also

ChorusDeviceFilterFreq Members


ChorusDeviceFilterFreq Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreq Members
ChorusDeviceFilterFreq Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterFreq type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterFreq |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterFreq Class


ChorusDeviceFilterFreq Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterFreq Constructor
ChorusDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterFreq()
Visual C++
public:
ChorusDeviceFilterFreq()
JavaScript
NRenoiseTools.ChorusDeviceFilterFreq = function();

See Also

ChorusDeviceFilterFreq Class


ChorusDeviceFilterFreq Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreq Methods
ChorusDeviceFilterFreq Class See Also Send Feedback

The ChorusDeviceFilterFreq type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterFreq Class


ChorusDeviceFilterFreq Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreq Properties
ChorusDeviceFilterFreq Class See Also Send Feedback

The ChorusDeviceFilterFreq type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterFreq Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceFilterFreq..::.MidiMappings Property
ChorusDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceFilterFreq Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterFreq..::.Value Property
ChorusDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterFreq Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceFilterFreq..::.Visualization Property
ChorusDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceFilterFreqVisualization
C#
public ChorusDeviceFilterFreqVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceFilterFreqVisualization Visualization {
    ChorusDeviceFilterFreqVisualization get ();
    void set (ChorusDeviceFilterFreqVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceFilterFreq Class


ChorusDeviceFilterFreqRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterFreqRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterFreqRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterFreqRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceFilterFreqRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterFreqRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterFreqRunTimePreset

See Also

ChorusDeviceFilterFreqRunTimePreset Members


ChorusDeviceFilterFreqRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset Members
ChorusDeviceFilterFreqRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterFreqRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterFreqRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterFreqRunTimePreset Class


ChorusDeviceFilterFreqRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset Constructor
ChorusDeviceFilterFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterFreqRunTimePreset()
Visual C++
public:
ChorusDeviceFilterFreqRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceFilterFreqRunTimePreset = function();

See Also

ChorusDeviceFilterFreqRunTimePreset Class


ChorusDeviceFilterFreqRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset Methods
ChorusDeviceFilterFreqRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterFreqRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterFreqRunTimePreset Class


ChorusDeviceFilterFreqRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset Properties
ChorusDeviceFilterFreqRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterFreqRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterFreqRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterFreqRunTimePreset..::.Value Property
ChorusDeviceFilterFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterFreqRunTimePreset Class


ChorusDeviceFilterFreqVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceFilterFreqVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceFilterFreqVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceFilterFreqVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceFilterFreqVisualization
JavaScript
NRenoiseTools.ChorusDeviceFilterFreqVisualization = function();
NRenoiseTools.ChorusDeviceFilterFreqVisualization.createEnum('NRenoiseTools.ChorusDeviceFilterFreqVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceFilterResonance Class

[image]

.NET Framework Class Library
ChorusDeviceFilterResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterResonance
JavaScript
NRenoiseTools.ChorusDeviceFilterResonance = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterResonance

See Also

ChorusDeviceFilterResonance Members


ChorusDeviceFilterResonance Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonance Members
ChorusDeviceFilterResonance Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterResonance type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterResonance Class


ChorusDeviceFilterResonance Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterResonance Constructor
ChorusDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterResonance()
Visual C++
public:
ChorusDeviceFilterResonance()
JavaScript
NRenoiseTools.ChorusDeviceFilterResonance = function();

See Also

ChorusDeviceFilterResonance Class


ChorusDeviceFilterResonance Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonance Methods
ChorusDeviceFilterResonance Class See Also Send Feedback

The ChorusDeviceFilterResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterResonance Class


ChorusDeviceFilterResonance Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonance Properties
ChorusDeviceFilterResonance Class See Also Send Feedback

The ChorusDeviceFilterResonance type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterResonance Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceFilterResonance..::.MidiMappings Property
ChorusDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceFilterResonance Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterResonance..::.Value Property
ChorusDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterResonance Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceFilterResonance..::.Visualization Property
ChorusDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceFilterResonanceVisualization
C#
public ChorusDeviceFilterResonanceVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceFilterResonanceVisualization Visualization {
    ChorusDeviceFilterResonanceVisualization get ();
    void set (ChorusDeviceFilterResonanceVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceFilterResonance Class


ChorusDeviceFilterResonanceRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterResonanceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterResonanceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterResonanceRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceFilterResonanceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterResonanceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterResonanceRunTimePreset

See Also

ChorusDeviceFilterResonanceRunTimePreset Members


ChorusDeviceFilterResonanceRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset Members
ChorusDeviceFilterResonanceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterResonanceRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterResonanceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterResonanceRunTimePreset Class


ChorusDeviceFilterResonanceRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset Constructor
ChorusDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterResonanceRunTimePreset()
Visual C++
public:
ChorusDeviceFilterResonanceRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceFilterResonanceRunTimePreset = function();

See Also

ChorusDeviceFilterResonanceRunTimePreset Class


ChorusDeviceFilterResonanceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset Methods
ChorusDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterResonanceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterResonanceRunTimePreset Class


ChorusDeviceFilterResonanceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset Properties
ChorusDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterResonanceRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterResonanceRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterResonanceRunTimePreset..::.Value Property
ChorusDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterResonanceRunTimePreset Class


ChorusDeviceFilterResonanceVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceFilterResonanceVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceFilterResonanceVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceFilterResonanceVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceFilterResonanceVisualization
JavaScript
NRenoiseTools.ChorusDeviceFilterResonanceVisualization = function();
NRenoiseTools.ChorusDeviceFilterResonanceVisualization.createEnum('NRenoiseTools.ChorusDeviceFilterResonanceVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceFilterType Class

[image]

.NET Framework Class Library
ChorusDeviceFilterType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterType
JavaScript
NRenoiseTools.ChorusDeviceFilterType = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterType

See Also

ChorusDeviceFilterType Members


ChorusDeviceFilterType Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterType Members
ChorusDeviceFilterType Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterType type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterType Class


ChorusDeviceFilterType Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterType Constructor
ChorusDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterType()
Visual C++
public:
ChorusDeviceFilterType()
JavaScript
NRenoiseTools.ChorusDeviceFilterType = function();

See Also

ChorusDeviceFilterType Class


ChorusDeviceFilterType Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterType Methods
ChorusDeviceFilterType Class See Also Send Feedback

The ChorusDeviceFilterType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterType Class


ChorusDeviceFilterType Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterType Properties
ChorusDeviceFilterType Class See Also Send Feedback

The ChorusDeviceFilterType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceFilterType Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceFilterType..::.MidiMappings Property
ChorusDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceFilterType Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterType..::.Value Property
ChorusDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterType Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceFilterType..::.Visualization Property
ChorusDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceFilterTypeVisualization
C#
public ChorusDeviceFilterTypeVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceFilterTypeVisualization Visualization {
    ChorusDeviceFilterTypeVisualization get ();
    void set (ChorusDeviceFilterTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceFilterType Class


ChorusDeviceFilterTypeRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceFilterTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceFilterTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceFilterTypeRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceFilterTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceFilterTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceFilterTypeRunTimePreset

See Also

ChorusDeviceFilterTypeRunTimePreset Members


ChorusDeviceFilterTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset Members
ChorusDeviceFilterTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceFilterTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceFilterTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterTypeRunTimePreset Class


ChorusDeviceFilterTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset Constructor
ChorusDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceFilterTypeRunTimePreset()
Visual C++
public:
ChorusDeviceFilterTypeRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceFilterTypeRunTimePreset = function();

See Also

ChorusDeviceFilterTypeRunTimePreset Class


ChorusDeviceFilterTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset Methods
ChorusDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceFilterTypeRunTimePreset Class


ChorusDeviceFilterTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset Properties
ChorusDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The ChorusDeviceFilterTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceFilterTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceFilterTypeRunTimePreset..::.Value Property
ChorusDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceFilterTypeRunTimePreset Class


ChorusDeviceFilterTypeVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceFilterTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceFilterTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceFilterTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceFilterTypeVisualization
JavaScript
NRenoiseTools.ChorusDeviceFilterTypeVisualization = function();
NRenoiseTools.ChorusDeviceFilterTypeVisualization.createEnum('NRenoiseTools.ChorusDeviceFilterTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceLfoDepth Class

[image]

.NET Framework Class Library
ChorusDeviceLfoDepth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceLfoDepth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceLfoDepth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceLfoDepth
JavaScript
NRenoiseTools.ChorusDeviceLfoDepth = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceLfoDepth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceLfoDepth

See Also

ChorusDeviceLfoDepth Members


ChorusDeviceLfoDepth Members

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepth Members
ChorusDeviceLfoDepth Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceLfoDepth type exposes the following members.

Constructors

Name | Description
ChorusDeviceLfoDepth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceLfoDepth Class


ChorusDeviceLfoDepth Constructor

[image]

.NET Framework Class Library
ChorusDeviceLfoDepth Constructor
ChorusDeviceLfoDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceLfoDepth()
Visual C++
public:
ChorusDeviceLfoDepth()
JavaScript
NRenoiseTools.ChorusDeviceLfoDepth = function();

See Also

ChorusDeviceLfoDepth Class


ChorusDeviceLfoDepth Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepth Methods
ChorusDeviceLfoDepth Class See Also Send Feedback

The ChorusDeviceLfoDepth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceLfoDepth Class


ChorusDeviceLfoDepth Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepth Properties
ChorusDeviceLfoDepth Class See Also Send Feedback

The ChorusDeviceLfoDepth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceLfoDepth Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceLfoDepth..::.MidiMappings Property
ChorusDeviceLfoDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceLfoDepth Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceLfoDepth..::.Value Property
ChorusDeviceLfoDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceLfoDepth Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceLfoDepth..::.Visualization Property
ChorusDeviceLfoDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceLfoDepthVisualization
C#
public ChorusDeviceLfoDepthVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceLfoDepthVisualization Visualization {
    ChorusDeviceLfoDepthVisualization get ();
    void set (ChorusDeviceLfoDepthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceLfoDepth Class


ChorusDeviceLfoDepthRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceLfoDepthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceLfoDepthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceLfoDepthRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceLfoDepthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceLfoDepthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceLfoDepthRunTimePreset

See Also

ChorusDeviceLfoDepthRunTimePreset Members


ChorusDeviceLfoDepthRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset Members
ChorusDeviceLfoDepthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceLfoDepthRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceLfoDepthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceLfoDepthRunTimePreset Class


ChorusDeviceLfoDepthRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset Constructor
ChorusDeviceLfoDepthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceLfoDepthRunTimePreset()
Visual C++
public:
ChorusDeviceLfoDepthRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceLfoDepthRunTimePreset = function();

See Also

ChorusDeviceLfoDepthRunTimePreset Class


ChorusDeviceLfoDepthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset Methods
ChorusDeviceLfoDepthRunTimePreset Class See Also Send Feedback

The ChorusDeviceLfoDepthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceLfoDepthRunTimePreset Class


ChorusDeviceLfoDepthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset Properties
ChorusDeviceLfoDepthRunTimePreset Class See Also Send Feedback

The ChorusDeviceLfoDepthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceLfoDepthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceLfoDepthRunTimePreset..::.Value Property
ChorusDeviceLfoDepthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceLfoDepthRunTimePreset Class


ChorusDeviceLfoDepthVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceLfoDepthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceLfoDepthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceLfoDepthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceLfoDepthVisualization
JavaScript
NRenoiseTools.ChorusDeviceLfoDepthVisualization = function();
NRenoiseTools.ChorusDeviceLfoDepthVisualization.createEnum('NRenoiseTools.ChorusDeviceLfoDepthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceLfoRate Class

[image]

.NET Framework Class Library
ChorusDeviceLfoRate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceLfoRate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceLfoRate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceLfoRate
JavaScript
NRenoiseTools.ChorusDeviceLfoRate = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceLfoRate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceLfoRate

See Also

ChorusDeviceLfoRate Members


ChorusDeviceLfoRate Members

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRate Members
ChorusDeviceLfoRate Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceLfoRate type exposes the following members.

Constructors

Name | Description
ChorusDeviceLfoRate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceLfoRate Class


ChorusDeviceLfoRate Constructor

[image]

.NET Framework Class Library
ChorusDeviceLfoRate Constructor
ChorusDeviceLfoRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceLfoRate()
Visual C++
public:
ChorusDeviceLfoRate()
JavaScript
NRenoiseTools.ChorusDeviceLfoRate = function();

See Also

ChorusDeviceLfoRate Class


ChorusDeviceLfoRate Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRate Methods
ChorusDeviceLfoRate Class See Also Send Feedback

The ChorusDeviceLfoRate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceLfoRate Class


ChorusDeviceLfoRate Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRate Properties
ChorusDeviceLfoRate Class See Also Send Feedback

The ChorusDeviceLfoRate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDeviceLfoRate Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDeviceLfoRate..::.MidiMappings Property
ChorusDeviceLfoRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDeviceLfoRate Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceLfoRate..::.Value Property
ChorusDeviceLfoRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceLfoRate Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDeviceLfoRate..::.Visualization Property
ChorusDeviceLfoRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDeviceLfoRateVisualization
C#
public ChorusDeviceLfoRateVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDeviceLfoRateVisualization Visualization {
    ChorusDeviceLfoRateVisualization get ();
    void set (ChorusDeviceLfoRateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDeviceLfoRate Class


ChorusDeviceLfoRateRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceLfoRateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceLfoRateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceLfoRateRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceLfoRateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceLfoRateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceLfoRateRunTimePreset

See Also

ChorusDeviceLfoRateRunTimePreset Members


ChorusDeviceLfoRateRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset Members
ChorusDeviceLfoRateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceLfoRateRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceLfoRateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDeviceLfoRateRunTimePreset Class


ChorusDeviceLfoRateRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset Constructor
ChorusDeviceLfoRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceLfoRateRunTimePreset()
Visual C++
public:
ChorusDeviceLfoRateRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceLfoRateRunTimePreset = function();

See Also

ChorusDeviceLfoRateRunTimePreset Class


ChorusDeviceLfoRateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset Methods
ChorusDeviceLfoRateRunTimePreset Class See Also Send Feedback

The ChorusDeviceLfoRateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceLfoRateRunTimePreset Class


ChorusDeviceLfoRateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset Properties
ChorusDeviceLfoRateRunTimePreset Class See Also Send Feedback

The ChorusDeviceLfoRateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDeviceLfoRateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDeviceLfoRateRunTimePreset..::.Value Property
ChorusDeviceLfoRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDeviceLfoRateRunTimePreset Class


ChorusDeviceLfoRateVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDeviceLfoRateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDeviceLfoRateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDeviceLfoRateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDeviceLfoRateVisualization
JavaScript
NRenoiseTools.ChorusDeviceLfoRateVisualization = function();
NRenoiseTools.ChorusDeviceLfoRateVisualization.createEnum('NRenoiseTools.ChorusDeviceLfoRateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDevicePhase Class

[image]

.NET Framework Class Library
ChorusDevicePhase Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDevicePhase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDevicePhase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDevicePhase
JavaScript
NRenoiseTools.ChorusDevicePhase = function();

Type.createClass(
    'NRenoiseTools.ChorusDevicePhase');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDevicePhase

See Also

ChorusDevicePhase Members


ChorusDevicePhase Members

[image] [image]

.NET Framework Class Library
ChorusDevicePhase Members
ChorusDevicePhase Class Constructors Methods Properties See Also Send Feedback

The ChorusDevicePhase type exposes the following members.

Constructors

Name | Description
ChorusDevicePhase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDevicePhase Class


ChorusDevicePhase Constructor

[image]

.NET Framework Class Library
ChorusDevicePhase Constructor
ChorusDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDevicePhase()
Visual C++
public:
ChorusDevicePhase()
JavaScript
NRenoiseTools.ChorusDevicePhase = function();

See Also

ChorusDevicePhase Class


ChorusDevicePhase Methods

[image] [image]

.NET Framework Class Library
ChorusDevicePhase Methods
ChorusDevicePhase Class See Also Send Feedback

The ChorusDevicePhase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDevicePhase Class


ChorusDevicePhase Properties

[image] [image]

.NET Framework Class Library
ChorusDevicePhase Properties
ChorusDevicePhase Class See Also Send Feedback

The ChorusDevicePhase type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ChorusDevicePhase Class


MidiMappings Property

[image]

.NET Framework Class Library
ChorusDevicePhase..::.MidiMappings Property
ChorusDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ChorusDevicePhase Class


Value Property

[image]

.NET Framework Class Library
ChorusDevicePhase..::.Value Property
ChorusDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDevicePhase Class


Visualization Property

[image]

.NET Framework Class Library
ChorusDevicePhase..::.Visualization Property
ChorusDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ChorusDevicePhaseVisualization
C#
public ChorusDevicePhaseVisualization Visualization { get; set; }
Visual C++
public:
property ChorusDevicePhaseVisualization Visualization {
    ChorusDevicePhaseVisualization get ();
    void set (ChorusDevicePhaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ChorusDevicePhase Class


ChorusDevicePhaseRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDevicePhaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDevicePhaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDevicePhaseRunTimePreset
JavaScript
NRenoiseTools.ChorusDevicePhaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDevicePhaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDevicePhaseRunTimePreset

See Also

ChorusDevicePhaseRunTimePreset Members


ChorusDevicePhaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset Members
ChorusDevicePhaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDevicePhaseRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDevicePhaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ChorusDevicePhaseRunTimePreset Class


ChorusDevicePhaseRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset Constructor
ChorusDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDevicePhaseRunTimePreset()
Visual C++
public:
ChorusDevicePhaseRunTimePreset()
JavaScript
NRenoiseTools.ChorusDevicePhaseRunTimePreset = function();

See Also

ChorusDevicePhaseRunTimePreset Class


ChorusDevicePhaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset Methods
ChorusDevicePhaseRunTimePreset Class See Also Send Feedback

The ChorusDevicePhaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDevicePhaseRunTimePreset Class


ChorusDevicePhaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset Properties
ChorusDevicePhaseRunTimePreset Class See Also Send Feedback

The ChorusDevicePhaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ChorusDevicePhaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ChorusDevicePhaseRunTimePreset..::.Value Property
ChorusDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ChorusDevicePhaseRunTimePreset Class


ChorusDevicePhaseVisualization Enumeration

[image]

.NET Framework Class Library
ChorusDevicePhaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ChorusDevicePhaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ChorusDevicePhaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ChorusDevicePhaseVisualization
JavaScript
NRenoiseTools.ChorusDevicePhaseVisualization = function();
NRenoiseTools.ChorusDevicePhaseVisualization.createEnum('NRenoiseTools.ChorusDevicePhaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ChorusDeviceRunTimePreset Class

[image]

.NET Framework Class Library
ChorusDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ChorusDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ChorusDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ChorusDeviceRunTimePreset
JavaScript
NRenoiseTools.ChorusDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ChorusDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ChorusDeviceRunTimePreset

See Also

ChorusDeviceRunTimePreset Members


ChorusDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
ChorusDeviceRunTimePreset Members
ChorusDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ChorusDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
ChorusDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

ChorusDeviceRunTimePreset Class


ChorusDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
ChorusDeviceRunTimePreset Constructor
ChorusDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChorusDeviceRunTimePreset()
Visual C++
public:
ChorusDeviceRunTimePreset()
JavaScript
NRenoiseTools.ChorusDeviceRunTimePreset = function();

See Also

ChorusDeviceRunTimePreset Class


ChorusDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ChorusDeviceRunTimePreset Methods
ChorusDeviceRunTimePreset Class See Also Send Feedback

The ChorusDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChorusDeviceRunTimePreset Class


ChorusDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ChorusDeviceRunTimePreset Properties
ChorusDeviceRunTimePreset Class See Also Send Feedback

The ChorusDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

ChorusDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
ChorusDeviceRunTimePreset..::.DeviceSlot Property
ChorusDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As ChorusDeviceDeviceSlotRunTimePreset
C#
public ChorusDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property ChorusDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    ChorusDeviceDeviceSlotRunTimePreset^ get ();
    void set (ChorusDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

ChorusDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ChorusDeviceRunTimePreset..::.type Property
ChorusDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ChorusDeviceRunTimePreset Class


CompressorDevice Class

[image]

.NET Framework Class Library
CompressorDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDevice
JavaScript
NRenoiseTools.CompressorDevice = function();

Type.createClass(
    'NRenoiseTools.CompressorDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDevice

See Also

CompressorDevice Members


CompressorDevice Members

[image] [image]

.NET Framework Class Library
CompressorDevice Members
CompressorDevice Class Constructors Methods Properties See Also Send Feedback

The CompressorDevice type exposes the following members.

Constructors

Name | Description
CompressorDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Gain |
IsActive |
IsSelected |
LogThreshold |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

CompressorDevice Class


CompressorDevice Constructor

[image]

.NET Framework Class Library
CompressorDevice Constructor
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDevice()
Visual C++
public:
CompressorDevice()
JavaScript
NRenoiseTools.CompressorDevice = function();

See Also

CompressorDevice Class


CompressorDevice Methods

[image] [image]

.NET Framework Class Library
CompressorDevice Methods
CompressorDevice Class See Also Send Feedback

The CompressorDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDevice Class


CompressorDevice Properties

[image] [image]

.NET Framework Class Library
CompressorDevice Properties
CompressorDevice Class See Also Send Feedback

The CompressorDevice type exposes the following members.

Properties

Name | Description
Attack |
Gain |
IsActive |
IsSelected |
LogThreshold |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

CompressorDevice Class


Attack Property

[image]

.NET Framework Class Library
CompressorDevice..::.Attack Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As CompressorDeviceAttack
C#
public CompressorDeviceAttack Attack { get; set; }
Visual C++
public:
property CompressorDeviceAttack^ Attack {
    CompressorDeviceAttack^ get ();
    void set (CompressorDeviceAttack^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

CompressorDevice Class


Gain Property

[image]

.NET Framework Class Library
CompressorDevice..::.Gain Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As CompressorDeviceGain
C#
public CompressorDeviceGain Gain { get; set; }
Visual C++
public:
property CompressorDeviceGain^ Gain {
    CompressorDeviceGain^ get ();
    void set (CompressorDeviceGain^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

CompressorDevice Class


IsActive Property

[image]

.NET Framework Class Library
CompressorDevice..::.IsActive Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

CompressorDevice Class


IsSelected Property

[image]

.NET Framework Class Library
CompressorDevice..::.IsSelected Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

CompressorDevice Class


LogThreshold Property

[image]

.NET Framework Class Library
CompressorDevice..::.LogThreshold Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LogThreshold As CompressorDeviceLogThreshold
C#
public CompressorDeviceLogThreshold LogThreshold { get; set; }
Visual C++
public:
property CompressorDeviceLogThreshold^ LogThreshold {
    CompressorDeviceLogThreshold^ get ();
    void set (CompressorDeviceLogThreshold^ value);
}
JavaScript
function get_logThreshold();
function set_logThreshold(value);

Remarks

See Also

CompressorDevice Class


Ratio Property

[image]

.NET Framework Class Library
CompressorDevice..::.Ratio Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As CompressorDeviceRatio
C#
public CompressorDeviceRatio Ratio { get; set; }
Visual C++
public:
property CompressorDeviceRatio^ Ratio {
    CompressorDeviceRatio^ get ();
    void set (CompressorDeviceRatio^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

CompressorDevice Class


Release Property

[image]

.NET Framework Class Library
CompressorDevice..::.Release Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As CompressorDeviceRelease
C#
public CompressorDeviceRelease Release { get; set; }
Visual C++
public:
property CompressorDeviceRelease^ Release {
    CompressorDeviceRelease^ get ();
    void set (CompressorDeviceRelease^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

CompressorDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
CompressorDevice..::.RunTimePresetA Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As CompressorDeviceRunTimePreset
C#
public CompressorDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property CompressorDeviceRunTimePreset^ RunTimePresetA {
    CompressorDeviceRunTimePreset^ get ();
    void set (CompressorDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

CompressorDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
CompressorDevice..::.RunTimePresetB Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As CompressorDeviceRunTimePreset
C#
public CompressorDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property CompressorDeviceRunTimePreset^ RunTimePresetB {
    CompressorDeviceRunTimePreset^ get ();
    void set (CompressorDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

CompressorDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
CompressorDevice..::.SelectedPresetIsModified Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

CompressorDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
CompressorDevice..::.SelectedPresetName Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

CompressorDevice Class


type Property

[image]

.NET Framework Class Library
CompressorDevice..::.type Property
CompressorDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

CompressorDevice Class


CompressorDeviceAttack Class

[image]

.NET Framework Class Library
CompressorDeviceAttack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceAttack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceAttack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceAttack
JavaScript
NRenoiseTools.CompressorDeviceAttack = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceAttack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceAttack

See Also

CompressorDeviceAttack Members


CompressorDeviceAttack Members

[image] [image]

.NET Framework Class Library
CompressorDeviceAttack Members
CompressorDeviceAttack Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceAttack type exposes the following members.

Constructors

Name | Description
CompressorDeviceAttack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceAttack Class


CompressorDeviceAttack Constructor

[image]

.NET Framework Class Library
CompressorDeviceAttack Constructor
CompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceAttack()
Visual C++
public:
CompressorDeviceAttack()
JavaScript
NRenoiseTools.CompressorDeviceAttack = function();

See Also

CompressorDeviceAttack Class


CompressorDeviceAttack Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceAttack Methods
CompressorDeviceAttack Class See Also Send Feedback

The CompressorDeviceAttack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceAttack Class


CompressorDeviceAttack Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceAttack Properties
CompressorDeviceAttack Class See Also Send Feedback

The CompressorDeviceAttack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceAttack Class


MidiMappings Property

[image]

.NET Framework Class Library
CompressorDeviceAttack..::.MidiMappings Property
CompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

CompressorDeviceAttack Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceAttack..::.Value Property
CompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceAttack Class


Visualization Property

[image]

.NET Framework Class Library
CompressorDeviceAttack..::.Visualization Property
CompressorDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As CompressorDeviceAttackVisualization
C#
public CompressorDeviceAttackVisualization Visualization { get; set; }
Visual C++
public:
property CompressorDeviceAttackVisualization Visualization {
    CompressorDeviceAttackVisualization get ();
    void set (CompressorDeviceAttackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

CompressorDeviceAttack Class


CompressorDeviceAttackRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceAttackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceAttackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceAttackRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceAttackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceAttackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceAttackRunTimePreset

See Also

CompressorDeviceAttackRunTimePreset Members


CompressorDeviceAttackRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset Members
CompressorDeviceAttackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceAttackRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceAttackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

CompressorDeviceAttackRunTimePreset Class


CompressorDeviceAttackRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset Constructor
CompressorDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceAttackRunTimePreset()
Visual C++
public:
CompressorDeviceAttackRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceAttackRunTimePreset = function();

See Also

CompressorDeviceAttackRunTimePreset Class


CompressorDeviceAttackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset Methods
CompressorDeviceAttackRunTimePreset Class See Also Send Feedback

The CompressorDeviceAttackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceAttackRunTimePreset Class


CompressorDeviceAttackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset Properties
CompressorDeviceAttackRunTimePreset Class See Also Send Feedback

The CompressorDeviceAttackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

CompressorDeviceAttackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceAttackRunTimePreset..::.Value Property
CompressorDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceAttackRunTimePreset Class


CompressorDeviceAttackVisualization Enumeration

[image]

.NET Framework Class Library
CompressorDeviceAttackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CompressorDeviceAttackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CompressorDeviceAttackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CompressorDeviceAttackVisualization
JavaScript
NRenoiseTools.CompressorDeviceAttackVisualization = function();
NRenoiseTools.CompressorDeviceAttackVisualization.createEnum('NRenoiseTools.CompressorDeviceAttackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CompressorDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceDeviceSlotRunTimePreset

See Also

CompressorDeviceDeviceSlotRunTimePreset Members


CompressorDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset Members
CompressorDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Gain |
LogThreshold |
Ratio |
Release |
type |

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


CompressorDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset Constructor
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceDeviceSlotRunTimePreset()
Visual C++
public:
CompressorDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceDeviceSlotRunTimePreset = function();

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


CompressorDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset Methods
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The CompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


CompressorDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset Properties
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The CompressorDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Attack |
Gain |
LogThreshold |
Ratio |
Release |
type |

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


Attack Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.Attack Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As CompressorDeviceAttackRunTimePreset
C#
public CompressorDeviceAttackRunTimePreset Attack { get; set; }
Visual C++
public:
property CompressorDeviceAttackRunTimePreset^ Attack {
    CompressorDeviceAttackRunTimePreset^ get ();
    void set (CompressorDeviceAttackRunTimePreset^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


Gain Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.Gain Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As CompressorDeviceGainRunTimePreset
C#
public CompressorDeviceGainRunTimePreset Gain { get; set; }
Visual C++
public:
property CompressorDeviceGainRunTimePreset^ Gain {
    CompressorDeviceGainRunTimePreset^ get ();
    void set (CompressorDeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


LogThreshold Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.LogThreshold Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LogThreshold As CompressorDeviceLogThresholdRunTimePreset
C#
public CompressorDeviceLogThresholdRunTimePreset LogThreshold { get; set; }
Visual C++
public:
property CompressorDeviceLogThresholdRunTimePreset^ LogThreshold {
    CompressorDeviceLogThresholdRunTimePreset^ get ();
    void set (CompressorDeviceLogThresholdRunTimePreset^ value);
}
JavaScript
function get_logThreshold();
function set_logThreshold(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


Ratio Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.Ratio Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As CompressorDeviceRatioRunTimePreset
C#
public CompressorDeviceRatioRunTimePreset Ratio { get; set; }
Visual C++
public:
property CompressorDeviceRatioRunTimePreset^ Ratio {
    CompressorDeviceRatioRunTimePreset^ get ();
    void set (CompressorDeviceRatioRunTimePreset^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


Release Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.Release Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As CompressorDeviceReleaseRunTimePreset
C#
public CompressorDeviceReleaseRunTimePreset Release { get; set; }
Visual C++
public:
property CompressorDeviceReleaseRunTimePreset^ Release {
    CompressorDeviceReleaseRunTimePreset^ get ();
    void set (CompressorDeviceReleaseRunTimePreset^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
CompressorDeviceDeviceSlotRunTimePreset..::.type Property
CompressorDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

CompressorDeviceDeviceSlotRunTimePreset Class


CompressorDeviceGain Class

[image]

.NET Framework Class Library
CompressorDeviceGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceGain
JavaScript
NRenoiseTools.CompressorDeviceGain = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceGain

See Also

CompressorDeviceGain Members


CompressorDeviceGain Members

[image] [image]

.NET Framework Class Library
CompressorDeviceGain Members
CompressorDeviceGain Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceGain type exposes the following members.

Constructors

Name | Description
CompressorDeviceGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceGain Class


CompressorDeviceGain Constructor

[image]

.NET Framework Class Library
CompressorDeviceGain Constructor
CompressorDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceGain()
Visual C++
public:
CompressorDeviceGain()
JavaScript
NRenoiseTools.CompressorDeviceGain = function();

See Also

CompressorDeviceGain Class


CompressorDeviceGain Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceGain Methods
CompressorDeviceGain Class See Also Send Feedback

The CompressorDeviceGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceGain Class


CompressorDeviceGain Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceGain Properties
CompressorDeviceGain Class See Also Send Feedback

The CompressorDeviceGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceGain Class


MidiMappings Property

[image]

.NET Framework Class Library
CompressorDeviceGain..::.MidiMappings Property
CompressorDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

CompressorDeviceGain Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceGain..::.Value Property
CompressorDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceGain Class


Visualization Property

[image]

.NET Framework Class Library
CompressorDeviceGain..::.Visualization Property
CompressorDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As CompressorDeviceGainVisualization
C#
public CompressorDeviceGainVisualization Visualization { get; set; }
Visual C++
public:
property CompressorDeviceGainVisualization Visualization {
    CompressorDeviceGainVisualization get ();
    void set (CompressorDeviceGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

CompressorDeviceGain Class


CompressorDeviceGainRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceGainRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceGainRunTimePreset

See Also

CompressorDeviceGainRunTimePreset Members


CompressorDeviceGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset Members
CompressorDeviceGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceGainRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

CompressorDeviceGainRunTimePreset Class


CompressorDeviceGainRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset Constructor
CompressorDeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceGainRunTimePreset()
Visual C++
public:
CompressorDeviceGainRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceGainRunTimePreset = function();

See Also

CompressorDeviceGainRunTimePreset Class


CompressorDeviceGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset Methods
CompressorDeviceGainRunTimePreset Class See Also Send Feedback

The CompressorDeviceGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceGainRunTimePreset Class


CompressorDeviceGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset Properties
CompressorDeviceGainRunTimePreset Class See Also Send Feedback

The CompressorDeviceGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

CompressorDeviceGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceGainRunTimePreset..::.Value Property
CompressorDeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceGainRunTimePreset Class


CompressorDeviceGainVisualization Enumeration

[image]

.NET Framework Class Library
CompressorDeviceGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CompressorDeviceGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CompressorDeviceGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CompressorDeviceGainVisualization
JavaScript
NRenoiseTools.CompressorDeviceGainVisualization = function();
NRenoiseTools.CompressorDeviceGainVisualization.createEnum('NRenoiseTools.CompressorDeviceGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CompressorDeviceLogThreshold Class

[image]

.NET Framework Class Library
CompressorDeviceLogThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceLogThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceLogThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceLogThreshold
JavaScript
NRenoiseTools.CompressorDeviceLogThreshold = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceLogThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceLogThreshold

See Also

CompressorDeviceLogThreshold Members


CompressorDeviceLogThreshold Members

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThreshold Members
CompressorDeviceLogThreshold Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceLogThreshold type exposes the following members.

Constructors

Name | Description
CompressorDeviceLogThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceLogThreshold Class


CompressorDeviceLogThreshold Constructor

[image]

.NET Framework Class Library
CompressorDeviceLogThreshold Constructor
CompressorDeviceLogThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceLogThreshold()
Visual C++
public:
CompressorDeviceLogThreshold()
JavaScript
NRenoiseTools.CompressorDeviceLogThreshold = function();

See Also

CompressorDeviceLogThreshold Class


CompressorDeviceLogThreshold Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThreshold Methods
CompressorDeviceLogThreshold Class See Also Send Feedback

The CompressorDeviceLogThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceLogThreshold Class


CompressorDeviceLogThreshold Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThreshold Properties
CompressorDeviceLogThreshold Class See Also Send Feedback

The CompressorDeviceLogThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceLogThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
CompressorDeviceLogThreshold..::.MidiMappings Property
CompressorDeviceLogThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

CompressorDeviceLogThreshold Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceLogThreshold..::.Value Property
CompressorDeviceLogThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceLogThreshold Class


Visualization Property

[image]

.NET Framework Class Library
CompressorDeviceLogThreshold..::.Visualization Property
CompressorDeviceLogThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As CompressorDeviceLogThresholdVisualization
C#
public CompressorDeviceLogThresholdVisualization Visualization { get; set; }
Visual C++
public:
property CompressorDeviceLogThresholdVisualization Visualization {
    CompressorDeviceLogThresholdVisualization get ();
    void set (CompressorDeviceLogThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

CompressorDeviceLogThreshold Class


CompressorDeviceLogThresholdRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceLogThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceLogThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceLogThresholdRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceLogThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceLogThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceLogThresholdRunTimePreset

See Also

CompressorDeviceLogThresholdRunTimePreset Members


CompressorDeviceLogThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset Members
CompressorDeviceLogThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceLogThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceLogThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

CompressorDeviceLogThresholdRunTimePreset Class


CompressorDeviceLogThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset Constructor
CompressorDeviceLogThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceLogThresholdRunTimePreset()
Visual C++
public:
CompressorDeviceLogThresholdRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceLogThresholdRunTimePreset = function();

See Also

CompressorDeviceLogThresholdRunTimePreset Class


CompressorDeviceLogThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset Methods
CompressorDeviceLogThresholdRunTimePreset Class See Also Send Feedback

The CompressorDeviceLogThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceLogThresholdRunTimePreset Class


CompressorDeviceLogThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset Properties
CompressorDeviceLogThresholdRunTimePreset Class See Also Send Feedback

The CompressorDeviceLogThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

CompressorDeviceLogThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceLogThresholdRunTimePreset..::.Value Property
CompressorDeviceLogThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceLogThresholdRunTimePreset Class


CompressorDeviceLogThresholdVisualization Enumeration

[image]

.NET Framework Class Library
CompressorDeviceLogThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CompressorDeviceLogThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CompressorDeviceLogThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CompressorDeviceLogThresholdVisualization
JavaScript
NRenoiseTools.CompressorDeviceLogThresholdVisualization = function();
NRenoiseTools.CompressorDeviceLogThresholdVisualization.createEnum('NRenoiseTools.CompressorDeviceLogThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CompressorDeviceRatio Class

[image]

.NET Framework Class Library
CompressorDeviceRatio Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceRatio
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceRatio
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceRatio
JavaScript
NRenoiseTools.CompressorDeviceRatio = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceRatio');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceRatio

See Also

CompressorDeviceRatio Members


CompressorDeviceRatio Members

[image] [image]

.NET Framework Class Library
CompressorDeviceRatio Members
CompressorDeviceRatio Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceRatio type exposes the following members.

Constructors

Name | Description
CompressorDeviceRatio |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceRatio Class


CompressorDeviceRatio Constructor

[image]

.NET Framework Class Library
CompressorDeviceRatio Constructor
CompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceRatio()
Visual C++
public:
CompressorDeviceRatio()
JavaScript
NRenoiseTools.CompressorDeviceRatio = function();

See Also

CompressorDeviceRatio Class


CompressorDeviceRatio Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceRatio Methods
CompressorDeviceRatio Class See Also Send Feedback

The CompressorDeviceRatio type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceRatio Class


CompressorDeviceRatio Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceRatio Properties
CompressorDeviceRatio Class See Also Send Feedback

The CompressorDeviceRatio type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceRatio Class


MidiMappings Property

[image]

.NET Framework Class Library
CompressorDeviceRatio..::.MidiMappings Property
CompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

CompressorDeviceRatio Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceRatio..::.Value Property
CompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceRatio Class


Visualization Property

[image]

.NET Framework Class Library
CompressorDeviceRatio..::.Visualization Property
CompressorDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As CompressorDeviceRatioVisualization
C#
public CompressorDeviceRatioVisualization Visualization { get; set; }
Visual C++
public:
property CompressorDeviceRatioVisualization Visualization {
    CompressorDeviceRatioVisualization get ();
    void set (CompressorDeviceRatioVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

CompressorDeviceRatio Class


CompressorDeviceRatioRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceRatioRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceRatioRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceRatioRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceRatioRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceRatioRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceRatioRunTimePreset

See Also

CompressorDeviceRatioRunTimePreset Members


CompressorDeviceRatioRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset Members
CompressorDeviceRatioRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceRatioRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceRatioRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

CompressorDeviceRatioRunTimePreset Class


CompressorDeviceRatioRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset Constructor
CompressorDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceRatioRunTimePreset()
Visual C++
public:
CompressorDeviceRatioRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceRatioRunTimePreset = function();

See Also

CompressorDeviceRatioRunTimePreset Class


CompressorDeviceRatioRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset Methods
CompressorDeviceRatioRunTimePreset Class See Also Send Feedback

The CompressorDeviceRatioRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceRatioRunTimePreset Class


CompressorDeviceRatioRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset Properties
CompressorDeviceRatioRunTimePreset Class See Also Send Feedback

The CompressorDeviceRatioRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

CompressorDeviceRatioRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceRatioRunTimePreset..::.Value Property
CompressorDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceRatioRunTimePreset Class


CompressorDeviceRatioVisualization Enumeration

[image]

.NET Framework Class Library
CompressorDeviceRatioVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CompressorDeviceRatioVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CompressorDeviceRatioVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CompressorDeviceRatioVisualization
JavaScript
NRenoiseTools.CompressorDeviceRatioVisualization = function();
NRenoiseTools.CompressorDeviceRatioVisualization.createEnum('NRenoiseTools.CompressorDeviceRatioVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CompressorDeviceRelease Class

[image]

.NET Framework Class Library
CompressorDeviceRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceRelease
JavaScript
NRenoiseTools.CompressorDeviceRelease = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceRelease

See Also

CompressorDeviceRelease Members


CompressorDeviceRelease Members

[image] [image]

.NET Framework Class Library
CompressorDeviceRelease Members
CompressorDeviceRelease Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceRelease type exposes the following members.

Constructors

Name | Description
CompressorDeviceRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceRelease Class


CompressorDeviceRelease Constructor

[image]

.NET Framework Class Library
CompressorDeviceRelease Constructor
CompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceRelease()
Visual C++
public:
CompressorDeviceRelease()
JavaScript
NRenoiseTools.CompressorDeviceRelease = function();

See Also

CompressorDeviceRelease Class


CompressorDeviceRelease Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceRelease Methods
CompressorDeviceRelease Class See Also Send Feedback

The CompressorDeviceRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceRelease Class


CompressorDeviceRelease Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceRelease Properties
CompressorDeviceRelease Class See Also Send Feedback

The CompressorDeviceRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

CompressorDeviceRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
CompressorDeviceRelease..::.MidiMappings Property
CompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

CompressorDeviceRelease Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceRelease..::.Value Property
CompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceRelease Class


Visualization Property

[image]

.NET Framework Class Library
CompressorDeviceRelease..::.Visualization Property
CompressorDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As CompressorDeviceReleaseVisualization
C#
public CompressorDeviceReleaseVisualization Visualization { get; set; }
Visual C++
public:
property CompressorDeviceReleaseVisualization Visualization {
    CompressorDeviceReleaseVisualization get ();
    void set (CompressorDeviceReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

CompressorDeviceRelease Class


CompressorDeviceReleaseRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceReleaseRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceReleaseRunTimePreset

See Also

CompressorDeviceReleaseRunTimePreset Members


CompressorDeviceReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset Members
CompressorDeviceReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

CompressorDeviceReleaseRunTimePreset Class


CompressorDeviceReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset Constructor
CompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceReleaseRunTimePreset()
Visual C++
public:
CompressorDeviceReleaseRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceReleaseRunTimePreset = function();

See Also

CompressorDeviceReleaseRunTimePreset Class


CompressorDeviceReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset Methods
CompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

The CompressorDeviceReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceReleaseRunTimePreset Class


CompressorDeviceReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset Properties
CompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

The CompressorDeviceReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

CompressorDeviceReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
CompressorDeviceReleaseRunTimePreset..::.Value Property
CompressorDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CompressorDeviceReleaseRunTimePreset Class


CompressorDeviceReleaseVisualization Enumeration

[image]

.NET Framework Class Library
CompressorDeviceReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CompressorDeviceReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CompressorDeviceReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CompressorDeviceReleaseVisualization
JavaScript
NRenoiseTools.CompressorDeviceReleaseVisualization = function();
NRenoiseTools.CompressorDeviceReleaseVisualization.createEnum('NRenoiseTools.CompressorDeviceReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CompressorDeviceRunTimePreset Class

[image]

.NET Framework Class Library
CompressorDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CompressorDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CompressorDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CompressorDeviceRunTimePreset
JavaScript
NRenoiseTools.CompressorDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.CompressorDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CompressorDeviceRunTimePreset

See Also

CompressorDeviceRunTimePreset Members


CompressorDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
CompressorDeviceRunTimePreset Members
CompressorDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The CompressorDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
CompressorDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

CompressorDeviceRunTimePreset Class


CompressorDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
CompressorDeviceRunTimePreset Constructor
CompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CompressorDeviceRunTimePreset()
Visual C++
public:
CompressorDeviceRunTimePreset()
JavaScript
NRenoiseTools.CompressorDeviceRunTimePreset = function();

See Also

CompressorDeviceRunTimePreset Class


CompressorDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
CompressorDeviceRunTimePreset Methods
CompressorDeviceRunTimePreset Class See Also Send Feedback

The CompressorDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompressorDeviceRunTimePreset Class


CompressorDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
CompressorDeviceRunTimePreset Properties
CompressorDeviceRunTimePreset Class See Also Send Feedback

The CompressorDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

CompressorDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
CompressorDeviceRunTimePreset..::.DeviceSlot Property
CompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As CompressorDeviceDeviceSlotRunTimePreset
C#
public CompressorDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property CompressorDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    CompressorDeviceDeviceSlotRunTimePreset^ get ();
    void set (CompressorDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

CompressorDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
CompressorDeviceRunTimePreset..::.type Property
CompressorDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

CompressorDeviceRunTimePreset Class


CustomEnvelope Class

[image]

.NET Framework Class Library
CustomEnvelope Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CustomEnvelope
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CustomEnvelope
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CustomEnvelope
JavaScript
NRenoiseTools.CustomEnvelope = function();

Type.createClass(
    'NRenoiseTools.CustomEnvelope');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CustomEnvelope

See Also

CustomEnvelope Members


CustomEnvelope Members

[image] [image]

.NET Framework Class Library
CustomEnvelope Members
CustomEnvelope Class Constructors Methods Properties See Also Send Feedback

The CustomEnvelope type exposes the following members.

Constructors

Name | Description
CustomEnvelope |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

CustomEnvelope Class


CustomEnvelope Constructor

[image]

.NET Framework Class Library
CustomEnvelope Constructor
CustomEnvelope Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomEnvelope()
Visual C++
public:
CustomEnvelope()
JavaScript
NRenoiseTools.CustomEnvelope = function();

See Also

CustomEnvelope Class


CustomEnvelope Methods

[image] [image]

.NET Framework Class Library
CustomEnvelope Methods
CustomEnvelope Class See Also Send Feedback

The CustomEnvelope type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomEnvelope Class


CustomEnvelope Properties

[image] [image]

.NET Framework Class Library
CustomEnvelope Properties
CustomEnvelope Class See Also Send Feedback

The CustomEnvelope type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

CustomEnvelope Class


Length Property

[image]

.NET Framework Class Library
CustomEnvelope..::.Length Property
CustomEnvelope Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

CustomEnvelope Class


PlayMode Property

[image]

.NET Framework Class Library
CustomEnvelope..::.PlayMode Property
CustomEnvelope Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As CustomEnvelopePlayMode
C#
public CustomEnvelopePlayMode PlayMode { get; set; }
Visual C++
public:
property CustomEnvelopePlayMode PlayMode {
    CustomEnvelopePlayMode get ();
    void set (CustomEnvelopePlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

CustomEnvelope Class


Points Property

[image]

.NET Framework Class Library
CustomEnvelope..::.Points Property
CustomEnvelope Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

CustomEnvelope Class


ValueQuantum Property

[image]

.NET Framework Class Library
CustomEnvelope..::.ValueQuantum Property
CustomEnvelope Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

CustomEnvelope Class


CustomEnvelopePlayMode Enumeration

[image]

.NET Framework Class Library
CustomEnvelopePlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CustomEnvelopePlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CustomEnvelopePlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CustomEnvelopePlayMode
JavaScript
NRenoiseTools.CustomEnvelopePlayMode = function();
NRenoiseTools.CustomEnvelopePlayMode.createEnum('NRenoiseTools.CustomEnvelopePlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


CutoffNodes Class

[image]

.NET Framework Class Library
CutoffNodes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class CutoffNodes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class CutoffNodes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class CutoffNodes
JavaScript
NRenoiseTools.CutoffNodes = function();

Type.createClass(
    'NRenoiseTools.CutoffNodes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.CutoffNodes

See Also

CutoffNodes Members


CutoffNodes Members

[image] [image]

.NET Framework Class Library
CutoffNodes Members
CutoffNodes Class Constructors Methods Properties See Also Send Feedback

The CutoffNodes type exposes the following members.

Constructors

Name | Description
CutoffNodes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

CutoffNodes Class


CutoffNodes Constructor

[image]

.NET Framework Class Library
CutoffNodes Constructor
CutoffNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CutoffNodes()
Visual C++
public:
CutoffNodes()
JavaScript
NRenoiseTools.CutoffNodes = function();

See Also

CutoffNodes Class


CutoffNodes Methods

[image] [image]

.NET Framework Class Library
CutoffNodes Methods
CutoffNodes Class See Also Send Feedback

The CutoffNodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CutoffNodes Class


CutoffNodes Properties

[image] [image]

.NET Framework Class Library
CutoffNodes Properties
CutoffNodes Class See Also Send Feedback

The CutoffNodes type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

CutoffNodes Class


Length Property

[image]

.NET Framework Class Library
CutoffNodes..::.Length Property
CutoffNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

CutoffNodes Class


PlayMode Property

[image]

.NET Framework Class Library
CutoffNodes..::.PlayMode Property
CutoffNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As CutoffNodesPlayMode
C#
public CutoffNodesPlayMode PlayMode { get; set; }
Visual C++
public:
property CutoffNodesPlayMode PlayMode {
    CutoffNodesPlayMode get ();
    void set (CutoffNodesPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

CutoffNodes Class


Points Property

[image]

.NET Framework Class Library
CutoffNodes..::.Points Property
CutoffNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

CutoffNodes Class


ValueQuantum Property

[image]

.NET Framework Class Library
CutoffNodes..::.ValueQuantum Property
CutoffNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

CutoffNodes Class


CutoffNodesPlayMode Enumeration

[image]

.NET Framework Class Library
CutoffNodesPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration CutoffNodesPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum CutoffNodesPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class CutoffNodesPlayMode
JavaScript
NRenoiseTools.CutoffNodesPlayMode = function();
NRenoiseTools.CutoffNodesPlayMode.createEnum('NRenoiseTools.CutoffNodesPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DcOffsetDevice Class

[image]

.NET Framework Class Library
DcOffsetDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDevice
JavaScript
NRenoiseTools.DcOffsetDevice = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDevice

See Also

DcOffsetDevice Members


DcOffsetDevice Members

[image] [image]

.NET Framework Class Library
DcOffsetDevice Members
DcOffsetDevice Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDevice type exposes the following members.

Constructors

Name | Description
DcOffsetDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoDC |
DCOffset |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

DcOffsetDevice Class


DcOffsetDevice Constructor

[image]

.NET Framework Class Library
DcOffsetDevice Constructor
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDevice()
Visual C++
public:
DcOffsetDevice()
JavaScript
NRenoiseTools.DcOffsetDevice = function();

See Also

DcOffsetDevice Class


DcOffsetDevice Methods

[image] [image]

.NET Framework Class Library
DcOffsetDevice Methods
DcOffsetDevice Class See Also Send Feedback

The DcOffsetDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDevice Class


DcOffsetDevice Properties

[image] [image]

.NET Framework Class Library
DcOffsetDevice Properties
DcOffsetDevice Class See Also Send Feedback

The DcOffsetDevice type exposes the following members.

Properties

Name | Description
AutoDC |
DCOffset |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

DcOffsetDevice Class


AutoDC Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.AutoDC Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoDC As DcOffsetDeviceAutoDC
C#
public DcOffsetDeviceAutoDC AutoDC { get; set; }
Visual C++
public:
property DcOffsetDeviceAutoDC^ AutoDC {
    DcOffsetDeviceAutoDC^ get ();
    void set (DcOffsetDeviceAutoDC^ value);
}
JavaScript
function get_autoDC();
function set_autoDC(value);

Remarks

See Also

DcOffsetDevice Class


DCOffset Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.DCOffset Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DCOffset As DcOffsetDeviceDCOffset
C#
public DcOffsetDeviceDCOffset DCOffset { get; set; }
Visual C++
public:
property DcOffsetDeviceDCOffset^ DCOffset {
    DcOffsetDeviceDCOffset^ get ();
    void set (DcOffsetDeviceDCOffset^ value);
}
JavaScript
function get_dcOffset();
function set_dcOffset(value);

Remarks

See Also

DcOffsetDevice Class


IsActive Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.IsActive Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

DcOffsetDevice Class


IsSelected Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.IsSelected Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

DcOffsetDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.RunTimePresetA Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As DcOffsetDeviceRunTimePreset
C#
public DcOffsetDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property DcOffsetDeviceRunTimePreset^ RunTimePresetA {
    DcOffsetDeviceRunTimePreset^ get ();
    void set (DcOffsetDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

DcOffsetDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.RunTimePresetB Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As DcOffsetDeviceRunTimePreset
C#
public DcOffsetDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property DcOffsetDeviceRunTimePreset^ RunTimePresetB {
    DcOffsetDeviceRunTimePreset^ get ();
    void set (DcOffsetDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

DcOffsetDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.SelectedPresetIsModified Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

DcOffsetDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.SelectedPresetName Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

DcOffsetDevice Class


type Property

[image]

.NET Framework Class Library
DcOffsetDevice..::.type Property
DcOffsetDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DcOffsetDevice Class


DcOffsetDeviceAutoDC Class

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDC Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceAutoDC
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceAutoDC
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceAutoDC
JavaScript
NRenoiseTools.DcOffsetDeviceAutoDC = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceAutoDC');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceAutoDC

See Also

DcOffsetDeviceAutoDC Members


DcOffsetDeviceAutoDC Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDC Members
DcOffsetDeviceAutoDC Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceAutoDC type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceAutoDC |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DcOffsetDeviceAutoDC Class


DcOffsetDeviceAutoDC Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDC Constructor
DcOffsetDeviceAutoDC Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceAutoDC()
Visual C++
public:
DcOffsetDeviceAutoDC()
JavaScript
NRenoiseTools.DcOffsetDeviceAutoDC = function();

See Also

DcOffsetDeviceAutoDC Class


DcOffsetDeviceAutoDC Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDC Methods
DcOffsetDeviceAutoDC Class See Also Send Feedback

The DcOffsetDeviceAutoDC type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceAutoDC Class


DcOffsetDeviceAutoDC Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDC Properties
DcOffsetDeviceAutoDC Class See Also Send Feedback

The DcOffsetDeviceAutoDC type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DcOffsetDeviceAutoDC Class


MidiMappings Property

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDC..::.MidiMappings Property
DcOffsetDeviceAutoDC Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DcOffsetDeviceAutoDC Class


Value Property

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDC..::.Value Property
DcOffsetDeviceAutoDC Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DcOffsetDeviceAutoDC Class


Visualization Property

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDC..::.Visualization Property
DcOffsetDeviceAutoDC Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DcOffsetDeviceAutoDCVisualization
C#
public DcOffsetDeviceAutoDCVisualization Visualization { get; set; }
Visual C++
public:
property DcOffsetDeviceAutoDCVisualization Visualization {
    DcOffsetDeviceAutoDCVisualization get ();
    void set (DcOffsetDeviceAutoDCVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DcOffsetDeviceAutoDC Class


DcOffsetDeviceAutoDCRunTimePreset Class

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceAutoDCRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceAutoDCRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceAutoDCRunTimePreset
JavaScript
NRenoiseTools.DcOffsetDeviceAutoDCRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceAutoDCRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceAutoDCRunTimePreset

See Also

DcOffsetDeviceAutoDCRunTimePreset Members


DcOffsetDeviceAutoDCRunTimePreset Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset Members
DcOffsetDeviceAutoDCRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceAutoDCRunTimePreset type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceAutoDCRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DcOffsetDeviceAutoDCRunTimePreset Class


DcOffsetDeviceAutoDCRunTimePreset Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset Constructor
DcOffsetDeviceAutoDCRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceAutoDCRunTimePreset()
Visual C++
public:
DcOffsetDeviceAutoDCRunTimePreset()
JavaScript
NRenoiseTools.DcOffsetDeviceAutoDCRunTimePreset = function();

See Also

DcOffsetDeviceAutoDCRunTimePreset Class


DcOffsetDeviceAutoDCRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset Methods
DcOffsetDeviceAutoDCRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceAutoDCRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceAutoDCRunTimePreset Class


DcOffsetDeviceAutoDCRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset Properties
DcOffsetDeviceAutoDCRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceAutoDCRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DcOffsetDeviceAutoDCRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDCRunTimePreset..::.Value Property
DcOffsetDeviceAutoDCRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DcOffsetDeviceAutoDCRunTimePreset Class


DcOffsetDeviceAutoDCVisualization Enumeration

[image]

.NET Framework Class Library
DcOffsetDeviceAutoDCVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DcOffsetDeviceAutoDCVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DcOffsetDeviceAutoDCVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DcOffsetDeviceAutoDCVisualization
JavaScript
NRenoiseTools.DcOffsetDeviceAutoDCVisualization = function();
NRenoiseTools.DcOffsetDeviceAutoDCVisualization.createEnum('NRenoiseTools.DcOffsetDeviceAutoDCVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DcOffsetDeviceDCOffset Class

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceDCOffset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceDCOffset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceDCOffset
JavaScript
NRenoiseTools.DcOffsetDeviceDCOffset = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceDCOffset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceDCOffset

See Also

DcOffsetDeviceDCOffset Members


DcOffsetDeviceDCOffset Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffset Members
DcOffsetDeviceDCOffset Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceDCOffset type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceDCOffset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DcOffsetDeviceDCOffset Class


DcOffsetDeviceDCOffset Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffset Constructor
DcOffsetDeviceDCOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceDCOffset()
Visual C++
public:
DcOffsetDeviceDCOffset()
JavaScript
NRenoiseTools.DcOffsetDeviceDCOffset = function();

See Also

DcOffsetDeviceDCOffset Class


DcOffsetDeviceDCOffset Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffset Methods
DcOffsetDeviceDCOffset Class See Also Send Feedback

The DcOffsetDeviceDCOffset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceDCOffset Class


DcOffsetDeviceDCOffset Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffset Properties
DcOffsetDeviceDCOffset Class See Also Send Feedback

The DcOffsetDeviceDCOffset type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DcOffsetDeviceDCOffset Class


MidiMappings Property

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffset..::.MidiMappings Property
DcOffsetDeviceDCOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DcOffsetDeviceDCOffset Class


Value Property

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffset..::.Value Property
DcOffsetDeviceDCOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DcOffsetDeviceDCOffset Class


Visualization Property

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffset..::.Visualization Property
DcOffsetDeviceDCOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DcOffsetDeviceDCOffsetVisualization
C#
public DcOffsetDeviceDCOffsetVisualization Visualization { get; set; }
Visual C++
public:
property DcOffsetDeviceDCOffsetVisualization Visualization {
    DcOffsetDeviceDCOffsetVisualization get ();
    void set (DcOffsetDeviceDCOffsetVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DcOffsetDeviceDCOffset Class


DcOffsetDeviceDCOffsetRunTimePreset Class

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceDCOffsetRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceDCOffsetRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceDCOffsetRunTimePreset
JavaScript
NRenoiseTools.DcOffsetDeviceDCOffsetRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceDCOffsetRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceDCOffsetRunTimePreset

See Also

DcOffsetDeviceDCOffsetRunTimePreset Members


DcOffsetDeviceDCOffsetRunTimePreset Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset Members
DcOffsetDeviceDCOffsetRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceDCOffsetRunTimePreset type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceDCOffsetRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DcOffsetDeviceDCOffsetRunTimePreset Class


DcOffsetDeviceDCOffsetRunTimePreset Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset Constructor
DcOffsetDeviceDCOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceDCOffsetRunTimePreset()
Visual C++
public:
DcOffsetDeviceDCOffsetRunTimePreset()
JavaScript
NRenoiseTools.DcOffsetDeviceDCOffsetRunTimePreset = function();

See Also

DcOffsetDeviceDCOffsetRunTimePreset Class


DcOffsetDeviceDCOffsetRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset Methods
DcOffsetDeviceDCOffsetRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceDCOffsetRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceDCOffsetRunTimePreset Class


DcOffsetDeviceDCOffsetRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset Properties
DcOffsetDeviceDCOffsetRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceDCOffsetRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DcOffsetDeviceDCOffsetRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetRunTimePreset..::.Value Property
DcOffsetDeviceDCOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DcOffsetDeviceDCOffsetRunTimePreset Class


DcOffsetDeviceDCOffsetVisualization Enumeration

[image]

.NET Framework Class Library
DcOffsetDeviceDCOffsetVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DcOffsetDeviceDCOffsetVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DcOffsetDeviceDCOffsetVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DcOffsetDeviceDCOffsetVisualization
JavaScript
NRenoiseTools.DcOffsetDeviceDCOffsetVisualization = function();
NRenoiseTools.DcOffsetDeviceDCOffsetVisualization.createEnum('NRenoiseTools.DcOffsetDeviceDCOffsetVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DcOffsetDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.DcOffsetDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceDeviceSlotRunTimePreset

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Members


DcOffsetDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset Members
DcOffsetDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoDC |
DCOffset |
type |

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


DcOffsetDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset Constructor
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceDeviceSlotRunTimePreset()
Visual C++
public:
DcOffsetDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.DcOffsetDeviceDeviceSlotRunTimePreset = function();

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


DcOffsetDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset Methods
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


DcOffsetDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset Properties
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
AutoDC |
DCOffset |
type |

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


AutoDC Property

[image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset..::.AutoDC Property
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoDC As DcOffsetDeviceAutoDCRunTimePreset
C#
public DcOffsetDeviceAutoDCRunTimePreset AutoDC { get; set; }
Visual C++
public:
property DcOffsetDeviceAutoDCRunTimePreset^ AutoDC {
    DcOffsetDeviceAutoDCRunTimePreset^ get ();
    void set (DcOffsetDeviceAutoDCRunTimePreset^ value);
}
JavaScript
function get_autoDC();
function set_autoDC(value);

Remarks

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


DCOffset Property

[image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset..::.DCOffset Property
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DCOffset As DcOffsetDeviceDCOffsetRunTimePreset
C#
public DcOffsetDeviceDCOffsetRunTimePreset DCOffset { get; set; }
Visual C++
public:
property DcOffsetDeviceDCOffsetRunTimePreset^ DCOffset {
    DcOffsetDeviceDCOffsetRunTimePreset^ get ();
    void set (DcOffsetDeviceDCOffsetRunTimePreset^ value);
}
JavaScript
function get_dcOffset();
function set_dcOffset(value);

Remarks

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DcOffsetDeviceDeviceSlotRunTimePreset..::.type Property
DcOffsetDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DcOffsetDeviceDeviceSlotRunTimePreset Class


DcOffsetDeviceRunTimePreset Class

[image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DcOffsetDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DcOffsetDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DcOffsetDeviceRunTimePreset
JavaScript
NRenoiseTools.DcOffsetDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DcOffsetDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DcOffsetDeviceRunTimePreset

See Also

DcOffsetDeviceRunTimePreset Members


DcOffsetDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset Members
DcOffsetDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DcOffsetDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
DcOffsetDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

DcOffsetDeviceRunTimePreset Class


DcOffsetDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset Constructor
DcOffsetDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DcOffsetDeviceRunTimePreset()
Visual C++
public:
DcOffsetDeviceRunTimePreset()
JavaScript
NRenoiseTools.DcOffsetDeviceRunTimePreset = function();

See Also

DcOffsetDeviceRunTimePreset Class


DcOffsetDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset Methods
DcOffsetDeviceRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DcOffsetDeviceRunTimePreset Class


DcOffsetDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset Properties
DcOffsetDeviceRunTimePreset Class See Also Send Feedback

The DcOffsetDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

DcOffsetDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset..::.DeviceSlot Property
DcOffsetDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As DcOffsetDeviceDeviceSlotRunTimePreset
C#
public DcOffsetDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property DcOffsetDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    DcOffsetDeviceDeviceSlotRunTimePreset^ get ();
    void set (DcOffsetDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

DcOffsetDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DcOffsetDeviceRunTimePreset..::.type Property
DcOffsetDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DcOffsetDeviceRunTimePreset Class


DelayDevice Class

[image]

.NET Framework Class Library
DelayDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDevice
JavaScript
NRenoiseTools.DelayDevice = function();

Type.createClass(
    'NRenoiseTools.DelayDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDevice

See Also

DelayDevice Members


DelayDevice Members

[image] [image]

.NET Framework Class Library
DelayDevice Members
DelayDevice Class Constructors Methods Properties See Also Send Feedback

The DelayDevice type exposes the following members.

Constructors

Name | Description
DelayDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
LDelay |
LFeedback |
LineSync |
LSyncOffset |
LSyncTime |
LTapPan |
MuteDrySignal |
RDelay |
RFeedback |
RSyncOffset |
RSyncTime |
RTapPan |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
TrackSend |
type |

See Also

DelayDevice Class


DelayDevice Constructor

[image]

.NET Framework Class Library
DelayDevice Constructor
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDevice()
Visual C++
public:
DelayDevice()
JavaScript
NRenoiseTools.DelayDevice = function();

See Also

DelayDevice Class


DelayDevice Methods

[image] [image]

.NET Framework Class Library
DelayDevice Methods
DelayDevice Class See Also Send Feedback

The DelayDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDevice Class


DelayDevice Properties

[image] [image]

.NET Framework Class Library
DelayDevice Properties
DelayDevice Class See Also Send Feedback

The DelayDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
LDelay |
LFeedback |
LineSync |
LSyncOffset |
LSyncTime |
LTapPan |
MuteDrySignal |
RDelay |
RFeedback |
RSyncOffset |
RSyncTime |
RTapPan |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
TrackSend |
type |

See Also

DelayDevice Class


IsActive Property

[image]

.NET Framework Class Library
DelayDevice..::.IsActive Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

DelayDevice Class


IsSelected Property

[image]

.NET Framework Class Library
DelayDevice..::.IsSelected Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

DelayDevice Class


LDelay Property

[image]

.NET Framework Class Library
DelayDevice..::.LDelay Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LDelay As DelayDeviceLDelay
C#
public DelayDeviceLDelay LDelay { get; set; }
Visual C++
public:
property DelayDeviceLDelay^ LDelay {
    DelayDeviceLDelay^ get ();
    void set (DelayDeviceLDelay^ value);
}
JavaScript
function get_lDelay();
function set_lDelay(value);

Remarks

See Also

DelayDevice Class


LFeedback Property

[image]

.NET Framework Class Library
DelayDevice..::.LFeedback Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LFeedback As DelayDeviceLFeedback
C#
public DelayDeviceLFeedback LFeedback { get; set; }
Visual C++
public:
property DelayDeviceLFeedback^ LFeedback {
    DelayDeviceLFeedback^ get ();
    void set (DelayDeviceLFeedback^ value);
}
JavaScript
function get_lFeedback();
function set_lFeedback(value);

Remarks

See Also

DelayDevice Class


LineSync Property

[image]

.NET Framework Class Library
DelayDevice..::.LineSync Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LineSync As DelayDeviceLineSync
C#
public DelayDeviceLineSync LineSync { get; set; }
Visual C++
public:
property DelayDeviceLineSync^ LineSync {
    DelayDeviceLineSync^ get ();
    void set (DelayDeviceLineSync^ value);
}
JavaScript
function get_lineSync();
function set_lineSync(value);

Remarks

See Also

DelayDevice Class


LSyncOffset Property

[image]

.NET Framework Class Library
DelayDevice..::.LSyncOffset Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LSyncOffset As DelayDeviceLSyncOffset
C#
public DelayDeviceLSyncOffset LSyncOffset { get; set; }
Visual C++
public:
property DelayDeviceLSyncOffset^ LSyncOffset {
    DelayDeviceLSyncOffset^ get ();
    void set (DelayDeviceLSyncOffset^ value);
}
JavaScript
function get_lSyncOffset();
function set_lSyncOffset(value);

Remarks

See Also

DelayDevice Class


LSyncTime Property

[image]

.NET Framework Class Library
DelayDevice..::.LSyncTime Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LSyncTime As DelayDeviceLSyncTime
C#
public DelayDeviceLSyncTime LSyncTime { get; set; }
Visual C++
public:
property DelayDeviceLSyncTime^ LSyncTime {
    DelayDeviceLSyncTime^ get ();
    void set (DelayDeviceLSyncTime^ value);
}
JavaScript
function get_lSyncTime();
function set_lSyncTime(value);

Remarks

See Also

DelayDevice Class


LTapPan Property

[image]

.NET Framework Class Library
DelayDevice..::.LTapPan Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LTapPan As DelayDeviceLTapPan
C#
public DelayDeviceLTapPan LTapPan { get; set; }
Visual C++
public:
property DelayDeviceLTapPan^ LTapPan {
    DelayDeviceLTapPan^ get ();
    void set (DelayDeviceLTapPan^ value);
}
JavaScript
function get_lTapPan();
function set_lTapPan(value);

Remarks

See Also

DelayDevice Class


MuteDrySignal Property

[image]

.NET Framework Class Library
DelayDevice..::.MuteDrySignal Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MuteDrySignal As DelayDeviceMuteDrySignal
C#
public DelayDeviceMuteDrySignal MuteDrySignal { get; set; }
Visual C++
public:
property DelayDeviceMuteDrySignal^ MuteDrySignal {
    DelayDeviceMuteDrySignal^ get ();
    void set (DelayDeviceMuteDrySignal^ value);
}
JavaScript
function get_muteDrySignal();
function set_muteDrySignal(value);

Remarks

See Also

DelayDevice Class


RDelay Property

[image]

.NET Framework Class Library
DelayDevice..::.RDelay Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RDelay As DelayDeviceRDelay
C#
public DelayDeviceRDelay RDelay { get; set; }
Visual C++
public:
property DelayDeviceRDelay^ RDelay {
    DelayDeviceRDelay^ get ();
    void set (DelayDeviceRDelay^ value);
}
JavaScript
function get_rDelay();
function set_rDelay(value);

Remarks

See Also

DelayDevice Class


RFeedback Property

[image]

.NET Framework Class Library
DelayDevice..::.RFeedback Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RFeedback As DelayDeviceRFeedback
C#
public DelayDeviceRFeedback RFeedback { get; set; }
Visual C++
public:
property DelayDeviceRFeedback^ RFeedback {
    DelayDeviceRFeedback^ get ();
    void set (DelayDeviceRFeedback^ value);
}
JavaScript
function get_rFeedback();
function set_rFeedback(value);

Remarks

See Also

DelayDevice Class


RSyncOffset Property

[image]

.NET Framework Class Library
DelayDevice..::.RSyncOffset Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RSyncOffset As DelayDeviceRSyncOffset
C#
public DelayDeviceRSyncOffset RSyncOffset { get; set; }
Visual C++
public:
property DelayDeviceRSyncOffset^ RSyncOffset {
    DelayDeviceRSyncOffset^ get ();
    void set (DelayDeviceRSyncOffset^ value);
}
JavaScript
function get_rSyncOffset();
function set_rSyncOffset(value);

Remarks

See Also

DelayDevice Class


RSyncTime Property

[image]

.NET Framework Class Library
DelayDevice..::.RSyncTime Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RSyncTime As DelayDeviceRSyncTime
C#
public DelayDeviceRSyncTime RSyncTime { get; set; }
Visual C++
public:
property DelayDeviceRSyncTime^ RSyncTime {
    DelayDeviceRSyncTime^ get ();
    void set (DelayDeviceRSyncTime^ value);
}
JavaScript
function get_rSyncTime();
function set_rSyncTime(value);

Remarks

See Also

DelayDevice Class


RTapPan Property

[image]

.NET Framework Class Library
DelayDevice..::.RTapPan Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RTapPan As DelayDeviceRTapPan
C#
public DelayDeviceRTapPan RTapPan { get; set; }
Visual C++
public:
property DelayDeviceRTapPan^ RTapPan {
    DelayDeviceRTapPan^ get ();
    void set (DelayDeviceRTapPan^ value);
}
JavaScript
function get_rTapPan();
function set_rTapPan(value);

Remarks

See Also

DelayDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
DelayDevice..::.RunTimePresetA Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As DelayDeviceRunTimePreset
C#
public DelayDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property DelayDeviceRunTimePreset^ RunTimePresetA {
    DelayDeviceRunTimePreset^ get ();
    void set (DelayDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

DelayDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
DelayDevice..::.RunTimePresetB Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As DelayDeviceRunTimePreset
C#
public DelayDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property DelayDeviceRunTimePreset^ RunTimePresetB {
    DelayDeviceRunTimePreset^ get ();
    void set (DelayDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

DelayDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
DelayDevice..::.SelectedPresetIsModified Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

DelayDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
DelayDevice..::.SelectedPresetName Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

DelayDevice Class


TrackSend Property

[image]

.NET Framework Class Library
DelayDevice..::.TrackSend Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackSend As DelayDeviceTrackSend
C#
public DelayDeviceTrackSend TrackSend { get; set; }
Visual C++
public:
property DelayDeviceTrackSend^ TrackSend {
    DelayDeviceTrackSend^ get ();
    void set (DelayDeviceTrackSend^ value);
}
JavaScript
function get_trackSend();
function set_trackSend(value);

Remarks

See Also

DelayDevice Class


type Property

[image]

.NET Framework Class Library
DelayDevice..::.type Property
DelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DelayDevice Class


DelayDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceDeviceSlotRunTimePreset

See Also

DelayDeviceDeviceSlotRunTimePreset Members


DelayDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset Members
DelayDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LDelay |
LFeedback |
LineSync |
LSyncOffset |
LSyncTime |
LTapPan |
MuteDrySignal |
RDelay |
RFeedback |
RSyncOffset |
RSyncTime |
RTapPan |
TrackSend |
type |

See Also

DelayDeviceDeviceSlotRunTimePreset Class


DelayDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset Constructor
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceDeviceSlotRunTimePreset()
Visual C++
public:
DelayDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceDeviceSlotRunTimePreset = function();

See Also

DelayDeviceDeviceSlotRunTimePreset Class


DelayDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset Methods
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceDeviceSlotRunTimePreset Class


DelayDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset Properties
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
LDelay |
LFeedback |
LineSync |
LSyncOffset |
LSyncTime |
LTapPan |
MuteDrySignal |
RDelay |
RFeedback |
RSyncOffset |
RSyncTime |
RTapPan |
TrackSend |
type |

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LDelay Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LDelay Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LDelay As DelayDeviceLDelayRunTimePreset
C#
public DelayDeviceLDelayRunTimePreset LDelay { get; set; }
Visual C++
public:
property DelayDeviceLDelayRunTimePreset^ LDelay {
    DelayDeviceLDelayRunTimePreset^ get ();
    void set (DelayDeviceLDelayRunTimePreset^ value);
}
JavaScript
function get_lDelay();
function set_lDelay(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LFeedback Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LFeedback Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LFeedback As DelayDeviceLFeedbackRunTimePreset
C#
public DelayDeviceLFeedbackRunTimePreset LFeedback { get; set; }
Visual C++
public:
property DelayDeviceLFeedbackRunTimePreset^ LFeedback {
    DelayDeviceLFeedbackRunTimePreset^ get ();
    void set (DelayDeviceLFeedbackRunTimePreset^ value);
}
JavaScript
function get_lFeedback();
function set_lFeedback(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LineSync Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LineSync Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LineSync As DelayDeviceLineSyncRunTimePreset
C#
public DelayDeviceLineSyncRunTimePreset LineSync { get; set; }
Visual C++
public:
property DelayDeviceLineSyncRunTimePreset^ LineSync {
    DelayDeviceLineSyncRunTimePreset^ get ();
    void set (DelayDeviceLineSyncRunTimePreset^ value);
}
JavaScript
function get_lineSync();
function set_lineSync(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LSyncOffset Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LSyncOffset Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LSyncOffset As DelayDeviceLSyncOffsetRunTimePreset
C#
public DelayDeviceLSyncOffsetRunTimePreset LSyncOffset { get; set; }
Visual C++
public:
property DelayDeviceLSyncOffsetRunTimePreset^ LSyncOffset {
    DelayDeviceLSyncOffsetRunTimePreset^ get ();
    void set (DelayDeviceLSyncOffsetRunTimePreset^ value);
}
JavaScript
function get_lSyncOffset();
function set_lSyncOffset(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LSyncTime Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LSyncTime Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LSyncTime As DelayDeviceLSyncTimeRunTimePreset
C#
public DelayDeviceLSyncTimeRunTimePreset LSyncTime { get; set; }
Visual C++
public:
property DelayDeviceLSyncTimeRunTimePreset^ LSyncTime {
    DelayDeviceLSyncTimeRunTimePreset^ get ();
    void set (DelayDeviceLSyncTimeRunTimePreset^ value);
}
JavaScript
function get_lSyncTime();
function set_lSyncTime(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


LTapPan Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.LTapPan Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LTapPan As DelayDeviceLTapPanRunTimePreset
C#
public DelayDeviceLTapPanRunTimePreset LTapPan { get; set; }
Visual C++
public:
property DelayDeviceLTapPanRunTimePreset^ LTapPan {
    DelayDeviceLTapPanRunTimePreset^ get ();
    void set (DelayDeviceLTapPanRunTimePreset^ value);
}
JavaScript
function get_lTapPan();
function set_lTapPan(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


MuteDrySignal Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.MuteDrySignal Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MuteDrySignal As DelayDeviceMuteDrySignalRunTimePreset
C#
public DelayDeviceMuteDrySignalRunTimePreset MuteDrySignal { get; set; }
Visual C++
public:
property DelayDeviceMuteDrySignalRunTimePreset^ MuteDrySignal {
    DelayDeviceMuteDrySignalRunTimePreset^ get ();
    void set (DelayDeviceMuteDrySignalRunTimePreset^ value);
}
JavaScript
function get_muteDrySignal();
function set_muteDrySignal(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


RDelay Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.RDelay Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RDelay As DelayDeviceRDelayRunTimePreset
C#
public DelayDeviceRDelayRunTimePreset RDelay { get; set; }
Visual C++
public:
property DelayDeviceRDelayRunTimePreset^ RDelay {
    DelayDeviceRDelayRunTimePreset^ get ();
    void set (DelayDeviceRDelayRunTimePreset^ value);
}
JavaScript
function get_rDelay();
function set_rDelay(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


RFeedback Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.RFeedback Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RFeedback As DelayDeviceRFeedbackRunTimePreset
C#
public DelayDeviceRFeedbackRunTimePreset RFeedback { get; set; }
Visual C++
public:
property DelayDeviceRFeedbackRunTimePreset^ RFeedback {
    DelayDeviceRFeedbackRunTimePreset^ get ();
    void set (DelayDeviceRFeedbackRunTimePreset^ value);
}
JavaScript
function get_rFeedback();
function set_rFeedback(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


RSyncOffset Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.RSyncOffset Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RSyncOffset As DelayDeviceRSyncOffsetRunTimePreset
C#
public DelayDeviceRSyncOffsetRunTimePreset RSyncOffset { get; set; }
Visual C++
public:
property DelayDeviceRSyncOffsetRunTimePreset^ RSyncOffset {
    DelayDeviceRSyncOffsetRunTimePreset^ get ();
    void set (DelayDeviceRSyncOffsetRunTimePreset^ value);
}
JavaScript
function get_rSyncOffset();
function set_rSyncOffset(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


RSyncTime Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.RSyncTime Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RSyncTime As DelayDeviceRSyncTimeRunTimePreset
C#
public DelayDeviceRSyncTimeRunTimePreset RSyncTime { get; set; }
Visual C++
public:
property DelayDeviceRSyncTimeRunTimePreset^ RSyncTime {
    DelayDeviceRSyncTimeRunTimePreset^ get ();
    void set (DelayDeviceRSyncTimeRunTimePreset^ value);
}
JavaScript
function get_rSyncTime();
function set_rSyncTime(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


RTapPan Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.RTapPan Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RTapPan As DelayDeviceRTapPanRunTimePreset
C#
public DelayDeviceRTapPanRunTimePreset RTapPan { get; set; }
Visual C++
public:
property DelayDeviceRTapPanRunTimePreset^ RTapPan {
    DelayDeviceRTapPanRunTimePreset^ get ();
    void set (DelayDeviceRTapPanRunTimePreset^ value);
}
JavaScript
function get_rTapPan();
function set_rTapPan(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


TrackSend Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.TrackSend Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackSend As DelayDeviceTrackSendRunTimePreset
C#
public DelayDeviceTrackSendRunTimePreset TrackSend { get; set; }
Visual C++
public:
property DelayDeviceTrackSendRunTimePreset^ TrackSend {
    DelayDeviceTrackSendRunTimePreset^ get ();
    void set (DelayDeviceTrackSendRunTimePreset^ value);
}
JavaScript
function get_trackSend();
function set_trackSend(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DelayDeviceDeviceSlotRunTimePreset..::.type Property
DelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DelayDeviceDeviceSlotRunTimePreset Class


DelayDeviceLDelay Class

[image]

.NET Framework Class Library
DelayDeviceLDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLDelay
JavaScript
NRenoiseTools.DelayDeviceLDelay = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLDelay

See Also

DelayDeviceLDelay Members


DelayDeviceLDelay Members

[image] [image]

.NET Framework Class Library
DelayDeviceLDelay Members
DelayDeviceLDelay Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLDelay type exposes the following members.

Constructors

Name | Description
DelayDeviceLDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLDelay Class


DelayDeviceLDelay Constructor

[image]

.NET Framework Class Library
DelayDeviceLDelay Constructor
DelayDeviceLDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLDelay()
Visual C++
public:
DelayDeviceLDelay()
JavaScript
NRenoiseTools.DelayDeviceLDelay = function();

See Also

DelayDeviceLDelay Class


DelayDeviceLDelay Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLDelay Methods
DelayDeviceLDelay Class See Also Send Feedback

The DelayDeviceLDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLDelay Class


DelayDeviceLDelay Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLDelay Properties
DelayDeviceLDelay Class See Also Send Feedback

The DelayDeviceLDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLDelay..::.MidiMappings Property
DelayDeviceLDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLDelay Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLDelay..::.Value Property
DelayDeviceLDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLDelay Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLDelay..::.Visualization Property
DelayDeviceLDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLDelayVisualization
C#
public DelayDeviceLDelayVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLDelayVisualization Visualization {
    DelayDeviceLDelayVisualization get ();
    void set (DelayDeviceLDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLDelay Class


DelayDeviceLDelayRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLDelayRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLDelayRunTimePreset

See Also

DelayDeviceLDelayRunTimePreset Members


DelayDeviceLDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset Members
DelayDeviceLDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLDelayRunTimePreset Class


DelayDeviceLDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset Constructor
DelayDeviceLDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLDelayRunTimePreset()
Visual C++
public:
DelayDeviceLDelayRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLDelayRunTimePreset = function();

See Also

DelayDeviceLDelayRunTimePreset Class


DelayDeviceLDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset Methods
DelayDeviceLDelayRunTimePreset Class See Also Send Feedback

The DelayDeviceLDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLDelayRunTimePreset Class


DelayDeviceLDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset Properties
DelayDeviceLDelayRunTimePreset Class See Also Send Feedback

The DelayDeviceLDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLDelayRunTimePreset..::.Value Property
DelayDeviceLDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLDelayRunTimePreset Class


DelayDeviceLDelayVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLDelayVisualization
JavaScript
NRenoiseTools.DelayDeviceLDelayVisualization = function();
NRenoiseTools.DelayDeviceLDelayVisualization.createEnum('NRenoiseTools.DelayDeviceLDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceLFeedback Class

[image]

.NET Framework Class Library
DelayDeviceLFeedback Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLFeedback
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLFeedback
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLFeedback
JavaScript
NRenoiseTools.DelayDeviceLFeedback = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLFeedback');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLFeedback

See Also

DelayDeviceLFeedback Members


DelayDeviceLFeedback Members

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedback Members
DelayDeviceLFeedback Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLFeedback type exposes the following members.

Constructors

Name | Description
DelayDeviceLFeedback |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLFeedback Class


DelayDeviceLFeedback Constructor

[image]

.NET Framework Class Library
DelayDeviceLFeedback Constructor
DelayDeviceLFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLFeedback()
Visual C++
public:
DelayDeviceLFeedback()
JavaScript
NRenoiseTools.DelayDeviceLFeedback = function();

See Also

DelayDeviceLFeedback Class


DelayDeviceLFeedback Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedback Methods
DelayDeviceLFeedback Class See Also Send Feedback

The DelayDeviceLFeedback type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLFeedback Class


DelayDeviceLFeedback Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedback Properties
DelayDeviceLFeedback Class See Also Send Feedback

The DelayDeviceLFeedback type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLFeedback Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLFeedback..::.MidiMappings Property
DelayDeviceLFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLFeedback Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLFeedback..::.Value Property
DelayDeviceLFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLFeedback Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLFeedback..::.Visualization Property
DelayDeviceLFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLFeedbackVisualization
C#
public DelayDeviceLFeedbackVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLFeedbackVisualization Visualization {
    DelayDeviceLFeedbackVisualization get ();
    void set (DelayDeviceLFeedbackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLFeedback Class


DelayDeviceLFeedbackRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLFeedbackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLFeedbackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLFeedbackRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLFeedbackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLFeedbackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLFeedbackRunTimePreset

See Also

DelayDeviceLFeedbackRunTimePreset Members


DelayDeviceLFeedbackRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset Members
DelayDeviceLFeedbackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLFeedbackRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLFeedbackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLFeedbackRunTimePreset Class


DelayDeviceLFeedbackRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset Constructor
DelayDeviceLFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLFeedbackRunTimePreset()
Visual C++
public:
DelayDeviceLFeedbackRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLFeedbackRunTimePreset = function();

See Also

DelayDeviceLFeedbackRunTimePreset Class


DelayDeviceLFeedbackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset Methods
DelayDeviceLFeedbackRunTimePreset Class See Also Send Feedback

The DelayDeviceLFeedbackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLFeedbackRunTimePreset Class


DelayDeviceLFeedbackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset Properties
DelayDeviceLFeedbackRunTimePreset Class See Also Send Feedback

The DelayDeviceLFeedbackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLFeedbackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLFeedbackRunTimePreset..::.Value Property
DelayDeviceLFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLFeedbackRunTimePreset Class


DelayDeviceLFeedbackVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLFeedbackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLFeedbackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLFeedbackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLFeedbackVisualization
JavaScript
NRenoiseTools.DelayDeviceLFeedbackVisualization = function();
NRenoiseTools.DelayDeviceLFeedbackVisualization.createEnum('NRenoiseTools.DelayDeviceLFeedbackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceLineSync Class

[image]

.NET Framework Class Library
DelayDeviceLineSync Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLineSync
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLineSync
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLineSync
JavaScript
NRenoiseTools.DelayDeviceLineSync = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLineSync');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLineSync

See Also

DelayDeviceLineSync Members


DelayDeviceLineSync Members

[image] [image]

.NET Framework Class Library
DelayDeviceLineSync Members
DelayDeviceLineSync Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLineSync type exposes the following members.

Constructors

Name | Description
DelayDeviceLineSync |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLineSync Class


DelayDeviceLineSync Constructor

[image]

.NET Framework Class Library
DelayDeviceLineSync Constructor
DelayDeviceLineSync Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLineSync()
Visual C++
public:
DelayDeviceLineSync()
JavaScript
NRenoiseTools.DelayDeviceLineSync = function();

See Also

DelayDeviceLineSync Class


DelayDeviceLineSync Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLineSync Methods
DelayDeviceLineSync Class See Also Send Feedback

The DelayDeviceLineSync type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLineSync Class


DelayDeviceLineSync Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLineSync Properties
DelayDeviceLineSync Class See Also Send Feedback

The DelayDeviceLineSync type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLineSync Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLineSync..::.MidiMappings Property
DelayDeviceLineSync Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLineSync Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLineSync..::.Value Property
DelayDeviceLineSync Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLineSync Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLineSync..::.Visualization Property
DelayDeviceLineSync Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLineSyncVisualization
C#
public DelayDeviceLineSyncVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLineSyncVisualization Visualization {
    DelayDeviceLineSyncVisualization get ();
    void set (DelayDeviceLineSyncVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLineSync Class


DelayDeviceLineSyncRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLineSyncRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLineSyncRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLineSyncRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLineSyncRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLineSyncRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLineSyncRunTimePreset

See Also

DelayDeviceLineSyncRunTimePreset Members


DelayDeviceLineSyncRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset Members
DelayDeviceLineSyncRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLineSyncRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLineSyncRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLineSyncRunTimePreset Class


DelayDeviceLineSyncRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset Constructor
DelayDeviceLineSyncRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLineSyncRunTimePreset()
Visual C++
public:
DelayDeviceLineSyncRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLineSyncRunTimePreset = function();

See Also

DelayDeviceLineSyncRunTimePreset Class


DelayDeviceLineSyncRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset Methods
DelayDeviceLineSyncRunTimePreset Class See Also Send Feedback

The DelayDeviceLineSyncRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLineSyncRunTimePreset Class


DelayDeviceLineSyncRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset Properties
DelayDeviceLineSyncRunTimePreset Class See Also Send Feedback

The DelayDeviceLineSyncRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLineSyncRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLineSyncRunTimePreset..::.Value Property
DelayDeviceLineSyncRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLineSyncRunTimePreset Class


DelayDeviceLineSyncVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLineSyncVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLineSyncVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLineSyncVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLineSyncVisualization
JavaScript
NRenoiseTools.DelayDeviceLineSyncVisualization = function();
NRenoiseTools.DelayDeviceLineSyncVisualization.createEnum('NRenoiseTools.DelayDeviceLineSyncVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceLSyncOffset Class

[image]

.NET Framework Class Library
DelayDeviceLSyncOffset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLSyncOffset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLSyncOffset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLSyncOffset
JavaScript
NRenoiseTools.DelayDeviceLSyncOffset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLSyncOffset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLSyncOffset

See Also

DelayDeviceLSyncOffset Members


DelayDeviceLSyncOffset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffset Members
DelayDeviceLSyncOffset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLSyncOffset type exposes the following members.

Constructors

Name | Description
DelayDeviceLSyncOffset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLSyncOffset Class


DelayDeviceLSyncOffset Constructor

[image]

.NET Framework Class Library
DelayDeviceLSyncOffset Constructor
DelayDeviceLSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLSyncOffset()
Visual C++
public:
DelayDeviceLSyncOffset()
JavaScript
NRenoiseTools.DelayDeviceLSyncOffset = function();

See Also

DelayDeviceLSyncOffset Class


DelayDeviceLSyncOffset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffset Methods
DelayDeviceLSyncOffset Class See Also Send Feedback

The DelayDeviceLSyncOffset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLSyncOffset Class


DelayDeviceLSyncOffset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffset Properties
DelayDeviceLSyncOffset Class See Also Send Feedback

The DelayDeviceLSyncOffset type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLSyncOffset Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLSyncOffset..::.MidiMappings Property
DelayDeviceLSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLSyncOffset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLSyncOffset..::.Value Property
DelayDeviceLSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLSyncOffset Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLSyncOffset..::.Visualization Property
DelayDeviceLSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLSyncOffsetVisualization
C#
public DelayDeviceLSyncOffsetVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLSyncOffsetVisualization Visualization {
    DelayDeviceLSyncOffsetVisualization get ();
    void set (DelayDeviceLSyncOffsetVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLSyncOffset Class


DelayDeviceLSyncOffsetRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLSyncOffsetRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLSyncOffsetRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLSyncOffsetRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLSyncOffsetRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLSyncOffsetRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLSyncOffsetRunTimePreset

See Also

DelayDeviceLSyncOffsetRunTimePreset Members


DelayDeviceLSyncOffsetRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset Members
DelayDeviceLSyncOffsetRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLSyncOffsetRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLSyncOffsetRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLSyncOffsetRunTimePreset Class


DelayDeviceLSyncOffsetRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset Constructor
DelayDeviceLSyncOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLSyncOffsetRunTimePreset()
Visual C++
public:
DelayDeviceLSyncOffsetRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLSyncOffsetRunTimePreset = function();

See Also

DelayDeviceLSyncOffsetRunTimePreset Class


DelayDeviceLSyncOffsetRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset Methods
DelayDeviceLSyncOffsetRunTimePreset Class See Also Send Feedback

The DelayDeviceLSyncOffsetRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLSyncOffsetRunTimePreset Class


DelayDeviceLSyncOffsetRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset Properties
DelayDeviceLSyncOffsetRunTimePreset Class See Also Send Feedback

The DelayDeviceLSyncOffsetRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLSyncOffsetRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLSyncOffsetRunTimePreset..::.Value Property
DelayDeviceLSyncOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLSyncOffsetRunTimePreset Class


DelayDeviceLSyncOffsetVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLSyncOffsetVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLSyncOffsetVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLSyncOffsetVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLSyncOffsetVisualization
JavaScript
NRenoiseTools.DelayDeviceLSyncOffsetVisualization = function();
NRenoiseTools.DelayDeviceLSyncOffsetVisualization.createEnum('NRenoiseTools.DelayDeviceLSyncOffsetVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceLSyncTime Class

[image]

.NET Framework Class Library
DelayDeviceLSyncTime Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLSyncTime
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLSyncTime
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLSyncTime
JavaScript
NRenoiseTools.DelayDeviceLSyncTime = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLSyncTime');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLSyncTime

See Also

DelayDeviceLSyncTime Members


DelayDeviceLSyncTime Members

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTime Members
DelayDeviceLSyncTime Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLSyncTime type exposes the following members.

Constructors

Name | Description
DelayDeviceLSyncTime |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLSyncTime Class


DelayDeviceLSyncTime Constructor

[image]

.NET Framework Class Library
DelayDeviceLSyncTime Constructor
DelayDeviceLSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLSyncTime()
Visual C++
public:
DelayDeviceLSyncTime()
JavaScript
NRenoiseTools.DelayDeviceLSyncTime = function();

See Also

DelayDeviceLSyncTime Class


DelayDeviceLSyncTime Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTime Methods
DelayDeviceLSyncTime Class See Also Send Feedback

The DelayDeviceLSyncTime type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLSyncTime Class


DelayDeviceLSyncTime Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTime Properties
DelayDeviceLSyncTime Class See Also Send Feedback

The DelayDeviceLSyncTime type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLSyncTime Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLSyncTime..::.MidiMappings Property
DelayDeviceLSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLSyncTime Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLSyncTime..::.Value Property
DelayDeviceLSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLSyncTime Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLSyncTime..::.Visualization Property
DelayDeviceLSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLSyncTimeVisualization
C#
public DelayDeviceLSyncTimeVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLSyncTimeVisualization Visualization {
    DelayDeviceLSyncTimeVisualization get ();
    void set (DelayDeviceLSyncTimeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLSyncTime Class


DelayDeviceLSyncTimeRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLSyncTimeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLSyncTimeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLSyncTimeRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLSyncTimeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLSyncTimeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLSyncTimeRunTimePreset

See Also

DelayDeviceLSyncTimeRunTimePreset Members


DelayDeviceLSyncTimeRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset Members
DelayDeviceLSyncTimeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLSyncTimeRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLSyncTimeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLSyncTimeRunTimePreset Class


DelayDeviceLSyncTimeRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset Constructor
DelayDeviceLSyncTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLSyncTimeRunTimePreset()
Visual C++
public:
DelayDeviceLSyncTimeRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLSyncTimeRunTimePreset = function();

See Also

DelayDeviceLSyncTimeRunTimePreset Class


DelayDeviceLSyncTimeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset Methods
DelayDeviceLSyncTimeRunTimePreset Class See Also Send Feedback

The DelayDeviceLSyncTimeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLSyncTimeRunTimePreset Class


DelayDeviceLSyncTimeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset Properties
DelayDeviceLSyncTimeRunTimePreset Class See Also Send Feedback

The DelayDeviceLSyncTimeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLSyncTimeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLSyncTimeRunTimePreset..::.Value Property
DelayDeviceLSyncTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLSyncTimeRunTimePreset Class


DelayDeviceLSyncTimeVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLSyncTimeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLSyncTimeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLSyncTimeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLSyncTimeVisualization
JavaScript
NRenoiseTools.DelayDeviceLSyncTimeVisualization = function();
NRenoiseTools.DelayDeviceLSyncTimeVisualization.createEnum('NRenoiseTools.DelayDeviceLSyncTimeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceLTapPan Class

[image]

.NET Framework Class Library
DelayDeviceLTapPan Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLTapPan
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLTapPan
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLTapPan
JavaScript
NRenoiseTools.DelayDeviceLTapPan = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLTapPan');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLTapPan

See Also

DelayDeviceLTapPan Members


DelayDeviceLTapPan Members

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPan Members
DelayDeviceLTapPan Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLTapPan type exposes the following members.

Constructors

Name | Description
DelayDeviceLTapPan |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLTapPan Class


DelayDeviceLTapPan Constructor

[image]

.NET Framework Class Library
DelayDeviceLTapPan Constructor
DelayDeviceLTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLTapPan()
Visual C++
public:
DelayDeviceLTapPan()
JavaScript
NRenoiseTools.DelayDeviceLTapPan = function();

See Also

DelayDeviceLTapPan Class


DelayDeviceLTapPan Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPan Methods
DelayDeviceLTapPan Class See Also Send Feedback

The DelayDeviceLTapPan type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLTapPan Class


DelayDeviceLTapPan Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPan Properties
DelayDeviceLTapPan Class See Also Send Feedback

The DelayDeviceLTapPan type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceLTapPan Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceLTapPan..::.MidiMappings Property
DelayDeviceLTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceLTapPan Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLTapPan..::.Value Property
DelayDeviceLTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLTapPan Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceLTapPan..::.Visualization Property
DelayDeviceLTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceLTapPanVisualization
C#
public DelayDeviceLTapPanVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceLTapPanVisualization Visualization {
    DelayDeviceLTapPanVisualization get ();
    void set (DelayDeviceLTapPanVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceLTapPan Class


DelayDeviceLTapPanRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceLTapPanRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceLTapPanRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceLTapPanRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceLTapPanRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceLTapPanRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceLTapPanRunTimePreset

See Also

DelayDeviceLTapPanRunTimePreset Members


DelayDeviceLTapPanRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset Members
DelayDeviceLTapPanRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceLTapPanRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceLTapPanRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceLTapPanRunTimePreset Class


DelayDeviceLTapPanRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset Constructor
DelayDeviceLTapPanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceLTapPanRunTimePreset()
Visual C++
public:
DelayDeviceLTapPanRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceLTapPanRunTimePreset = function();

See Also

DelayDeviceLTapPanRunTimePreset Class


DelayDeviceLTapPanRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset Methods
DelayDeviceLTapPanRunTimePreset Class See Also Send Feedback

The DelayDeviceLTapPanRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceLTapPanRunTimePreset Class


DelayDeviceLTapPanRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset Properties
DelayDeviceLTapPanRunTimePreset Class See Also Send Feedback

The DelayDeviceLTapPanRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceLTapPanRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceLTapPanRunTimePreset..::.Value Property
DelayDeviceLTapPanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceLTapPanRunTimePreset Class


DelayDeviceLTapPanVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceLTapPanVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceLTapPanVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceLTapPanVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceLTapPanVisualization
JavaScript
NRenoiseTools.DelayDeviceLTapPanVisualization = function();
NRenoiseTools.DelayDeviceLTapPanVisualization.createEnum('NRenoiseTools.DelayDeviceLTapPanVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceMuteDrySignal Class

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignal Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceMuteDrySignal
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceMuteDrySignal
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceMuteDrySignal
JavaScript
NRenoiseTools.DelayDeviceMuteDrySignal = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceMuteDrySignal');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceMuteDrySignal

See Also

DelayDeviceMuteDrySignal Members


DelayDeviceMuteDrySignal Members

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignal Members
DelayDeviceMuteDrySignal Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceMuteDrySignal type exposes the following members.

Constructors

Name | Description
DelayDeviceMuteDrySignal |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceMuteDrySignal Class


DelayDeviceMuteDrySignal Constructor

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignal Constructor
DelayDeviceMuteDrySignal Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceMuteDrySignal()
Visual C++
public:
DelayDeviceMuteDrySignal()
JavaScript
NRenoiseTools.DelayDeviceMuteDrySignal = function();

See Also

DelayDeviceMuteDrySignal Class


DelayDeviceMuteDrySignal Methods

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignal Methods
DelayDeviceMuteDrySignal Class See Also Send Feedback

The DelayDeviceMuteDrySignal type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceMuteDrySignal Class


DelayDeviceMuteDrySignal Properties

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignal Properties
DelayDeviceMuteDrySignal Class See Also Send Feedback

The DelayDeviceMuteDrySignal type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceMuteDrySignal Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignal..::.MidiMappings Property
DelayDeviceMuteDrySignal Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceMuteDrySignal Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignal..::.Value Property
DelayDeviceMuteDrySignal Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceMuteDrySignal Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignal..::.Visualization Property
DelayDeviceMuteDrySignal Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceMuteDrySignalVisualization
C#
public DelayDeviceMuteDrySignalVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceMuteDrySignalVisualization Visualization {
    DelayDeviceMuteDrySignalVisualization get ();
    void set (DelayDeviceMuteDrySignalVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceMuteDrySignal Class


DelayDeviceMuteDrySignalRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceMuteDrySignalRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceMuteDrySignalRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceMuteDrySignalRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceMuteDrySignalRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceMuteDrySignalRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceMuteDrySignalRunTimePreset

See Also

DelayDeviceMuteDrySignalRunTimePreset Members


DelayDeviceMuteDrySignalRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset Members
DelayDeviceMuteDrySignalRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceMuteDrySignalRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceMuteDrySignalRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceMuteDrySignalRunTimePreset Class


DelayDeviceMuteDrySignalRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset Constructor
DelayDeviceMuteDrySignalRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceMuteDrySignalRunTimePreset()
Visual C++
public:
DelayDeviceMuteDrySignalRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceMuteDrySignalRunTimePreset = function();

See Also

DelayDeviceMuteDrySignalRunTimePreset Class


DelayDeviceMuteDrySignalRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset Methods
DelayDeviceMuteDrySignalRunTimePreset Class See Also Send Feedback

The DelayDeviceMuteDrySignalRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceMuteDrySignalRunTimePreset Class


DelayDeviceMuteDrySignalRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset Properties
DelayDeviceMuteDrySignalRunTimePreset Class See Also Send Feedback

The DelayDeviceMuteDrySignalRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceMuteDrySignalRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignalRunTimePreset..::.Value Property
DelayDeviceMuteDrySignalRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceMuteDrySignalRunTimePreset Class


DelayDeviceMuteDrySignalVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceMuteDrySignalVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceMuteDrySignalVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceMuteDrySignalVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceMuteDrySignalVisualization
JavaScript
NRenoiseTools.DelayDeviceMuteDrySignalVisualization = function();
NRenoiseTools.DelayDeviceMuteDrySignalVisualization.createEnum('NRenoiseTools.DelayDeviceMuteDrySignalVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRDelay Class

[image]

.NET Framework Class Library
DelayDeviceRDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRDelay
JavaScript
NRenoiseTools.DelayDeviceRDelay = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRDelay

See Also

DelayDeviceRDelay Members


DelayDeviceRDelay Members

[image] [image]

.NET Framework Class Library
DelayDeviceRDelay Members
DelayDeviceRDelay Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRDelay type exposes the following members.

Constructors

Name | Description
DelayDeviceRDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRDelay Class


DelayDeviceRDelay Constructor

[image]

.NET Framework Class Library
DelayDeviceRDelay Constructor
DelayDeviceRDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRDelay()
Visual C++
public:
DelayDeviceRDelay()
JavaScript
NRenoiseTools.DelayDeviceRDelay = function();

See Also

DelayDeviceRDelay Class


DelayDeviceRDelay Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRDelay Methods
DelayDeviceRDelay Class See Also Send Feedback

The DelayDeviceRDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRDelay Class


DelayDeviceRDelay Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRDelay Properties
DelayDeviceRDelay Class See Also Send Feedback

The DelayDeviceRDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceRDelay..::.MidiMappings Property
DelayDeviceRDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceRDelay Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRDelay..::.Value Property
DelayDeviceRDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRDelay Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceRDelay..::.Visualization Property
DelayDeviceRDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceRDelayVisualization
C#
public DelayDeviceRDelayVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceRDelayVisualization Visualization {
    DelayDeviceRDelayVisualization get ();
    void set (DelayDeviceRDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceRDelay Class


DelayDeviceRDelayRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRDelayRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRDelayRunTimePreset

See Also

DelayDeviceRDelayRunTimePreset Members


DelayDeviceRDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset Members
DelayDeviceRDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceRDelayRunTimePreset Class


DelayDeviceRDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset Constructor
DelayDeviceRDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRDelayRunTimePreset()
Visual C++
public:
DelayDeviceRDelayRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRDelayRunTimePreset = function();

See Also

DelayDeviceRDelayRunTimePreset Class


DelayDeviceRDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset Methods
DelayDeviceRDelayRunTimePreset Class See Also Send Feedback

The DelayDeviceRDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRDelayRunTimePreset Class


DelayDeviceRDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset Properties
DelayDeviceRDelayRunTimePreset Class See Also Send Feedback

The DelayDeviceRDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceRDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRDelayRunTimePreset..::.Value Property
DelayDeviceRDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRDelayRunTimePreset Class


DelayDeviceRDelayVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceRDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceRDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceRDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceRDelayVisualization
JavaScript
NRenoiseTools.DelayDeviceRDelayVisualization = function();
NRenoiseTools.DelayDeviceRDelayVisualization.createEnum('NRenoiseTools.DelayDeviceRDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRFeedback Class

[image]

.NET Framework Class Library
DelayDeviceRFeedback Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRFeedback
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRFeedback
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRFeedback
JavaScript
NRenoiseTools.DelayDeviceRFeedback = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRFeedback');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRFeedback

See Also

DelayDeviceRFeedback Members


DelayDeviceRFeedback Members

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedback Members
DelayDeviceRFeedback Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRFeedback type exposes the following members.

Constructors

Name | Description
DelayDeviceRFeedback |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRFeedback Class


DelayDeviceRFeedback Constructor

[image]

.NET Framework Class Library
DelayDeviceRFeedback Constructor
DelayDeviceRFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRFeedback()
Visual C++
public:
DelayDeviceRFeedback()
JavaScript
NRenoiseTools.DelayDeviceRFeedback = function();

See Also

DelayDeviceRFeedback Class


DelayDeviceRFeedback Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedback Methods
DelayDeviceRFeedback Class See Also Send Feedback

The DelayDeviceRFeedback type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRFeedback Class


DelayDeviceRFeedback Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedback Properties
DelayDeviceRFeedback Class See Also Send Feedback

The DelayDeviceRFeedback type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRFeedback Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceRFeedback..::.MidiMappings Property
DelayDeviceRFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceRFeedback Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRFeedback..::.Value Property
DelayDeviceRFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRFeedback Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceRFeedback..::.Visualization Property
DelayDeviceRFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceRFeedbackVisualization
C#
public DelayDeviceRFeedbackVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceRFeedbackVisualization Visualization {
    DelayDeviceRFeedbackVisualization get ();
    void set (DelayDeviceRFeedbackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceRFeedback Class


DelayDeviceRFeedbackRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRFeedbackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRFeedbackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRFeedbackRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRFeedbackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRFeedbackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRFeedbackRunTimePreset

See Also

DelayDeviceRFeedbackRunTimePreset Members


DelayDeviceRFeedbackRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset Members
DelayDeviceRFeedbackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRFeedbackRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRFeedbackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceRFeedbackRunTimePreset Class


DelayDeviceRFeedbackRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset Constructor
DelayDeviceRFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRFeedbackRunTimePreset()
Visual C++
public:
DelayDeviceRFeedbackRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRFeedbackRunTimePreset = function();

See Also

DelayDeviceRFeedbackRunTimePreset Class


DelayDeviceRFeedbackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset Methods
DelayDeviceRFeedbackRunTimePreset Class See Also Send Feedback

The DelayDeviceRFeedbackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRFeedbackRunTimePreset Class


DelayDeviceRFeedbackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset Properties
DelayDeviceRFeedbackRunTimePreset Class See Also Send Feedback

The DelayDeviceRFeedbackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceRFeedbackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRFeedbackRunTimePreset..::.Value Property
DelayDeviceRFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRFeedbackRunTimePreset Class


DelayDeviceRFeedbackVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceRFeedbackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceRFeedbackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceRFeedbackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceRFeedbackVisualization
JavaScript
NRenoiseTools.DelayDeviceRFeedbackVisualization = function();
NRenoiseTools.DelayDeviceRFeedbackVisualization.createEnum('NRenoiseTools.DelayDeviceRFeedbackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRSyncOffset Class

[image]

.NET Framework Class Library
DelayDeviceRSyncOffset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRSyncOffset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRSyncOffset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRSyncOffset
JavaScript
NRenoiseTools.DelayDeviceRSyncOffset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRSyncOffset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRSyncOffset

See Also

DelayDeviceRSyncOffset Members


DelayDeviceRSyncOffset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffset Members
DelayDeviceRSyncOffset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRSyncOffset type exposes the following members.

Constructors

Name | Description
DelayDeviceRSyncOffset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRSyncOffset Class


DelayDeviceRSyncOffset Constructor

[image]

.NET Framework Class Library
DelayDeviceRSyncOffset Constructor
DelayDeviceRSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRSyncOffset()
Visual C++
public:
DelayDeviceRSyncOffset()
JavaScript
NRenoiseTools.DelayDeviceRSyncOffset = function();

See Also

DelayDeviceRSyncOffset Class


DelayDeviceRSyncOffset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffset Methods
DelayDeviceRSyncOffset Class See Also Send Feedback

The DelayDeviceRSyncOffset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRSyncOffset Class


DelayDeviceRSyncOffset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffset Properties
DelayDeviceRSyncOffset Class See Also Send Feedback

The DelayDeviceRSyncOffset type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRSyncOffset Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceRSyncOffset..::.MidiMappings Property
DelayDeviceRSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceRSyncOffset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRSyncOffset..::.Value Property
DelayDeviceRSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRSyncOffset Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceRSyncOffset..::.Visualization Property
DelayDeviceRSyncOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceRSyncOffsetVisualization
C#
public DelayDeviceRSyncOffsetVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceRSyncOffsetVisualization Visualization {
    DelayDeviceRSyncOffsetVisualization get ();
    void set (DelayDeviceRSyncOffsetVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceRSyncOffset Class


DelayDeviceRSyncOffsetRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRSyncOffsetRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRSyncOffsetRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRSyncOffsetRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRSyncOffsetRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRSyncOffsetRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRSyncOffsetRunTimePreset

See Also

DelayDeviceRSyncOffsetRunTimePreset Members


DelayDeviceRSyncOffsetRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset Members
DelayDeviceRSyncOffsetRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRSyncOffsetRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRSyncOffsetRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceRSyncOffsetRunTimePreset Class


DelayDeviceRSyncOffsetRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset Constructor
DelayDeviceRSyncOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRSyncOffsetRunTimePreset()
Visual C++
public:
DelayDeviceRSyncOffsetRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRSyncOffsetRunTimePreset = function();

See Also

DelayDeviceRSyncOffsetRunTimePreset Class


DelayDeviceRSyncOffsetRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset Methods
DelayDeviceRSyncOffsetRunTimePreset Class See Also Send Feedback

The DelayDeviceRSyncOffsetRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRSyncOffsetRunTimePreset Class


DelayDeviceRSyncOffsetRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset Properties
DelayDeviceRSyncOffsetRunTimePreset Class See Also Send Feedback

The DelayDeviceRSyncOffsetRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceRSyncOffsetRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRSyncOffsetRunTimePreset..::.Value Property
DelayDeviceRSyncOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRSyncOffsetRunTimePreset Class


DelayDeviceRSyncOffsetVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceRSyncOffsetVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceRSyncOffsetVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceRSyncOffsetVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceRSyncOffsetVisualization
JavaScript
NRenoiseTools.DelayDeviceRSyncOffsetVisualization = function();
NRenoiseTools.DelayDeviceRSyncOffsetVisualization.createEnum('NRenoiseTools.DelayDeviceRSyncOffsetVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRSyncTime Class

[image]

.NET Framework Class Library
DelayDeviceRSyncTime Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRSyncTime
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRSyncTime
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRSyncTime
JavaScript
NRenoiseTools.DelayDeviceRSyncTime = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRSyncTime');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRSyncTime

See Also

DelayDeviceRSyncTime Members


DelayDeviceRSyncTime Members

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTime Members
DelayDeviceRSyncTime Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRSyncTime type exposes the following members.

Constructors

Name | Description
DelayDeviceRSyncTime |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRSyncTime Class


DelayDeviceRSyncTime Constructor

[image]

.NET Framework Class Library
DelayDeviceRSyncTime Constructor
DelayDeviceRSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRSyncTime()
Visual C++
public:
DelayDeviceRSyncTime()
JavaScript
NRenoiseTools.DelayDeviceRSyncTime = function();

See Also

DelayDeviceRSyncTime Class


DelayDeviceRSyncTime Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTime Methods
DelayDeviceRSyncTime Class See Also Send Feedback

The DelayDeviceRSyncTime type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRSyncTime Class


DelayDeviceRSyncTime Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTime Properties
DelayDeviceRSyncTime Class See Also Send Feedback

The DelayDeviceRSyncTime type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRSyncTime Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceRSyncTime..::.MidiMappings Property
DelayDeviceRSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceRSyncTime Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRSyncTime..::.Value Property
DelayDeviceRSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRSyncTime Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceRSyncTime..::.Visualization Property
DelayDeviceRSyncTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceRSyncTimeVisualization
C#
public DelayDeviceRSyncTimeVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceRSyncTimeVisualization Visualization {
    DelayDeviceRSyncTimeVisualization get ();
    void set (DelayDeviceRSyncTimeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceRSyncTime Class


DelayDeviceRSyncTimeRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRSyncTimeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRSyncTimeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRSyncTimeRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRSyncTimeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRSyncTimeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRSyncTimeRunTimePreset

See Also

DelayDeviceRSyncTimeRunTimePreset Members


DelayDeviceRSyncTimeRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset Members
DelayDeviceRSyncTimeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRSyncTimeRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRSyncTimeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceRSyncTimeRunTimePreset Class


DelayDeviceRSyncTimeRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset Constructor
DelayDeviceRSyncTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRSyncTimeRunTimePreset()
Visual C++
public:
DelayDeviceRSyncTimeRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRSyncTimeRunTimePreset = function();

See Also

DelayDeviceRSyncTimeRunTimePreset Class


DelayDeviceRSyncTimeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset Methods
DelayDeviceRSyncTimeRunTimePreset Class See Also Send Feedback

The DelayDeviceRSyncTimeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRSyncTimeRunTimePreset Class


DelayDeviceRSyncTimeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset Properties
DelayDeviceRSyncTimeRunTimePreset Class See Also Send Feedback

The DelayDeviceRSyncTimeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceRSyncTimeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRSyncTimeRunTimePreset..::.Value Property
DelayDeviceRSyncTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRSyncTimeRunTimePreset Class


DelayDeviceRSyncTimeVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceRSyncTimeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceRSyncTimeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceRSyncTimeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceRSyncTimeVisualization
JavaScript
NRenoiseTools.DelayDeviceRSyncTimeVisualization = function();
NRenoiseTools.DelayDeviceRSyncTimeVisualization.createEnum('NRenoiseTools.DelayDeviceRSyncTimeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRTapPan Class

[image]

.NET Framework Class Library
DelayDeviceRTapPan Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRTapPan
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRTapPan
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRTapPan
JavaScript
NRenoiseTools.DelayDeviceRTapPan = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRTapPan');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRTapPan

See Also

DelayDeviceRTapPan Members


DelayDeviceRTapPan Members

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPan Members
DelayDeviceRTapPan Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRTapPan type exposes the following members.

Constructors

Name | Description
DelayDeviceRTapPan |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRTapPan Class


DelayDeviceRTapPan Constructor

[image]

.NET Framework Class Library
DelayDeviceRTapPan Constructor
DelayDeviceRTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRTapPan()
Visual C++
public:
DelayDeviceRTapPan()
JavaScript
NRenoiseTools.DelayDeviceRTapPan = function();

See Also

DelayDeviceRTapPan Class


DelayDeviceRTapPan Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPan Methods
DelayDeviceRTapPan Class See Also Send Feedback

The DelayDeviceRTapPan type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRTapPan Class


DelayDeviceRTapPan Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPan Properties
DelayDeviceRTapPan Class See Also Send Feedback

The DelayDeviceRTapPan type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceRTapPan Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceRTapPan..::.MidiMappings Property
DelayDeviceRTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceRTapPan Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRTapPan..::.Value Property
DelayDeviceRTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRTapPan Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceRTapPan..::.Visualization Property
DelayDeviceRTapPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceRTapPanVisualization
C#
public DelayDeviceRTapPanVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceRTapPanVisualization Visualization {
    DelayDeviceRTapPanVisualization get ();
    void set (DelayDeviceRTapPanVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceRTapPan Class


DelayDeviceRTapPanRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRTapPanRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRTapPanRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRTapPanRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRTapPanRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRTapPanRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRTapPanRunTimePreset

See Also

DelayDeviceRTapPanRunTimePreset Members


DelayDeviceRTapPanRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset Members
DelayDeviceRTapPanRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRTapPanRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRTapPanRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceRTapPanRunTimePreset Class


DelayDeviceRTapPanRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset Constructor
DelayDeviceRTapPanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRTapPanRunTimePreset()
Visual C++
public:
DelayDeviceRTapPanRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRTapPanRunTimePreset = function();

See Also

DelayDeviceRTapPanRunTimePreset Class


DelayDeviceRTapPanRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset Methods
DelayDeviceRTapPanRunTimePreset Class See Also Send Feedback

The DelayDeviceRTapPanRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRTapPanRunTimePreset Class


DelayDeviceRTapPanRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset Properties
DelayDeviceRTapPanRunTimePreset Class See Also Send Feedback

The DelayDeviceRTapPanRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceRTapPanRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceRTapPanRunTimePreset..::.Value Property
DelayDeviceRTapPanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceRTapPanRunTimePreset Class


DelayDeviceRTapPanVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceRTapPanVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceRTapPanVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceRTapPanVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceRTapPanVisualization
JavaScript
NRenoiseTools.DelayDeviceRTapPanVisualization = function();
NRenoiseTools.DelayDeviceRTapPanVisualization.createEnum('NRenoiseTools.DelayDeviceRTapPanVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DelayDeviceRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceRunTimePreset

See Also

DelayDeviceRunTimePreset Members


DelayDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceRunTimePreset Members
DelayDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

DelayDeviceRunTimePreset Class


DelayDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceRunTimePreset Constructor
DelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceRunTimePreset()
Visual C++
public:
DelayDeviceRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceRunTimePreset = function();

See Also

DelayDeviceRunTimePreset Class


DelayDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceRunTimePreset Methods
DelayDeviceRunTimePreset Class See Also Send Feedback

The DelayDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceRunTimePreset Class


DelayDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceRunTimePreset Properties
DelayDeviceRunTimePreset Class See Also Send Feedback

The DelayDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

DelayDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
DelayDeviceRunTimePreset..::.DeviceSlot Property
DelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As DelayDeviceDeviceSlotRunTimePreset
C#
public DelayDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property DelayDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    DelayDeviceDeviceSlotRunTimePreset^ get ();
    void set (DelayDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

DelayDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DelayDeviceRunTimePreset..::.type Property
DelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DelayDeviceRunTimePreset Class


DelayDeviceTrackSend Class

[image]

.NET Framework Class Library
DelayDeviceTrackSend Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceTrackSend
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceTrackSend
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceTrackSend
JavaScript
NRenoiseTools.DelayDeviceTrackSend = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceTrackSend');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceTrackSend

See Also

DelayDeviceTrackSend Members


DelayDeviceTrackSend Members

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSend Members
DelayDeviceTrackSend Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceTrackSend type exposes the following members.

Constructors

Name | Description
DelayDeviceTrackSend |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceTrackSend Class


DelayDeviceTrackSend Constructor

[image]

.NET Framework Class Library
DelayDeviceTrackSend Constructor
DelayDeviceTrackSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceTrackSend()
Visual C++
public:
DelayDeviceTrackSend()
JavaScript
NRenoiseTools.DelayDeviceTrackSend = function();

See Also

DelayDeviceTrackSend Class


DelayDeviceTrackSend Methods

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSend Methods
DelayDeviceTrackSend Class See Also Send Feedback

The DelayDeviceTrackSend type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceTrackSend Class


DelayDeviceTrackSend Properties

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSend Properties
DelayDeviceTrackSend Class See Also Send Feedback

The DelayDeviceTrackSend type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DelayDeviceTrackSend Class


MidiMappings Property

[image]

.NET Framework Class Library
DelayDeviceTrackSend..::.MidiMappings Property
DelayDeviceTrackSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DelayDeviceTrackSend Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceTrackSend..::.Value Property
DelayDeviceTrackSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceTrackSend Class


Visualization Property

[image]

.NET Framework Class Library
DelayDeviceTrackSend..::.Visualization Property
DelayDeviceTrackSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DelayDeviceTrackSendVisualization
C#
public DelayDeviceTrackSendVisualization Visualization { get; set; }
Visual C++
public:
property DelayDeviceTrackSendVisualization Visualization {
    DelayDeviceTrackSendVisualization get ();
    void set (DelayDeviceTrackSendVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DelayDeviceTrackSend Class


DelayDeviceTrackSendRunTimePreset Class

[image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DelayDeviceTrackSendRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DelayDeviceTrackSendRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DelayDeviceTrackSendRunTimePreset
JavaScript
NRenoiseTools.DelayDeviceTrackSendRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DelayDeviceTrackSendRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DelayDeviceTrackSendRunTimePreset

See Also

DelayDeviceTrackSendRunTimePreset Members


DelayDeviceTrackSendRunTimePreset Members

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset Members
DelayDeviceTrackSendRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DelayDeviceTrackSendRunTimePreset type exposes the following members.

Constructors

Name | Description
DelayDeviceTrackSendRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DelayDeviceTrackSendRunTimePreset Class


DelayDeviceTrackSendRunTimePreset Constructor

[image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset Constructor
DelayDeviceTrackSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDeviceTrackSendRunTimePreset()
Visual C++
public:
DelayDeviceTrackSendRunTimePreset()
JavaScript
NRenoiseTools.DelayDeviceTrackSendRunTimePreset = function();

See Also

DelayDeviceTrackSendRunTimePreset Class


DelayDeviceTrackSendRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset Methods
DelayDeviceTrackSendRunTimePreset Class See Also Send Feedback

The DelayDeviceTrackSendRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDeviceTrackSendRunTimePreset Class


DelayDeviceTrackSendRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset Properties
DelayDeviceTrackSendRunTimePreset Class See Also Send Feedback

The DelayDeviceTrackSendRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DelayDeviceTrackSendRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DelayDeviceTrackSendRunTimePreset..::.Value Property
DelayDeviceTrackSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DelayDeviceTrackSendRunTimePreset Class


DelayDeviceTrackSendVisualization Enumeration

[image]

.NET Framework Class Library
DelayDeviceTrackSendVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DelayDeviceTrackSendVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DelayDeviceTrackSendVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DelayDeviceTrackSendVisualization
JavaScript
NRenoiseTools.DelayDeviceTrackSendVisualization = function();
NRenoiseTools.DelayDeviceTrackSendVisualization.createEnum('NRenoiseTools.DelayDeviceTrackSendVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DestEffect Class

[image]

.NET Framework Class Library
DestEffect Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DestEffect
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DestEffect
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DestEffect
JavaScript
NRenoiseTools.DestEffect = function();

Type.createClass(
    'NRenoiseTools.DestEffect');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DestEffect

See Also

DestEffect Members


DestEffect Members

[image] [image]

.NET Framework Class Library
DestEffect Members
DestEffect Class Constructors Methods Properties See Also Send Feedback

The DestEffect type exposes the following members.

Constructors

Name | Description
DestEffect |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DestEffect Class


DestEffect Constructor

[image]

.NET Framework Class Library
DestEffect Constructor
DestEffect Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DestEffect()
Visual C++
public:
DestEffect()
JavaScript
NRenoiseTools.DestEffect = function();

See Also

DestEffect Class


DestEffect Methods

[image] [image]

.NET Framework Class Library
DestEffect Methods
DestEffect Class See Also Send Feedback

The DestEffect type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DestEffect Class


DestEffect Properties

[image] [image]

.NET Framework Class Library
DestEffect Properties
DestEffect Class See Also Send Feedback

The DestEffect type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DestEffect Class


MidiMappings Property

[image]

.NET Framework Class Library
DestEffect..::.MidiMappings Property
DestEffect Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DestEffect Class


Value Property

[image]

.NET Framework Class Library
DestEffect..::.Value Property
DestEffect Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DestEffect Class


Visualization Property

[image]

.NET Framework Class Library
DestEffect..::.Visualization Property
DestEffect Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DestEffectVisualization
C#
public DestEffectVisualization Visualization { get; set; }
Visual C++
public:
property DestEffectVisualization Visualization {
    DestEffectVisualization get ();
    void set (DestEffectVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DestEffect Class


DestEffectVisualization Enumeration

[image]

.NET Framework Class Library
DestEffectVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DestEffectVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DestEffectVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DestEffectVisualization
JavaScript
NRenoiseTools.DestEffectVisualization = function();
NRenoiseTools.DestEffectVisualization.createEnum('NRenoiseTools.DestEffectVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DestParameter Class

[image]

.NET Framework Class Library
DestParameter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DestParameter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DestParameter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DestParameter
JavaScript
NRenoiseTools.DestParameter = function();

Type.createClass(
    'NRenoiseTools.DestParameter');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DestParameter

See Also

DestParameter Members


DestParameter Members

[image] [image]

.NET Framework Class Library
DestParameter Members
DestParameter Class Constructors Methods Properties See Also Send Feedback

The DestParameter type exposes the following members.

Constructors

Name | Description
DestParameter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DestParameter Class


DestParameter Constructor

[image]

.NET Framework Class Library
DestParameter Constructor
DestParameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DestParameter()
Visual C++
public:
DestParameter()
JavaScript
NRenoiseTools.DestParameter = function();

See Also

DestParameter Class


DestParameter Methods

[image] [image]

.NET Framework Class Library
DestParameter Methods
DestParameter Class See Also Send Feedback

The DestParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DestParameter Class


DestParameter Properties

[image] [image]

.NET Framework Class Library
DestParameter Properties
DestParameter Class See Also Send Feedback

The DestParameter type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DestParameter Class


MidiMappings Property

[image]

.NET Framework Class Library
DestParameter..::.MidiMappings Property
DestParameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DestParameter Class


Value Property

[image]

.NET Framework Class Library
DestParameter..::.Value Property
DestParameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DestParameter Class


Visualization Property

[image]

.NET Framework Class Library
DestParameter..::.Visualization Property
DestParameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DestParameterVisualization
C#
public DestParameterVisualization Visualization { get; set; }
Visual C++
public:
property DestParameterVisualization Visualization {
    DestParameterVisualization get ();
    void set (DestParameterVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DestParameter Class


DestParameterVisualization Enumeration

[image]

.NET Framework Class Library
DestParameterVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DestParameterVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DestParameterVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DestParameterVisualization
JavaScript
NRenoiseTools.DestParameterVisualization = function();
NRenoiseTools.DestParameterVisualization.createEnum('NRenoiseTools.DestParameterVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DeviceSlotRunTimePreset
JavaScript
NRenoiseTools.DeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DeviceSlotRunTimePreset

See Also

DeviceSlotRunTimePreset Members


DeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
DeviceSlotRunTimePreset Members
DeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
DeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveProgram |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
type |

See Also

DeviceSlotRunTimePreset Class


DeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset Constructor
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeviceSlotRunTimePreset()
Visual C++
public:
DeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.DeviceSlotRunTimePreset = function();

See Also

DeviceSlotRunTimePreset Class


DeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DeviceSlotRunTimePreset Methods
DeviceSlotRunTimePreset Class See Also Send Feedback

The DeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceSlotRunTimePreset Class


DeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DeviceSlotRunTimePreset Properties
DeviceSlotRunTimePreset Class See Also Send Feedback

The DeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
ActiveProgram |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
type |

See Also

DeviceSlotRunTimePreset Class


ActiveProgram Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.ActiveProgram Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveProgram As Integer
C#
public int ActiveProgram { get; set; }
Visual C++
public:
property int ActiveProgram {
    int get ();
    void set (int value);
}
JavaScript
function get_activeProgram();
function set_activeProgram(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


ParameterChunk Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.ParameterChunk Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunk As String
C#
public string ParameterChunk { get; set; }
Visual C++
public:
property String^ ParameterChunk {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameterChunk();
function set_parameterChunk(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


ParameterChunkType Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.ParameterChunkType Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunkType As DeviceSlotRunTimePresetParameterChunkType
C#
public DeviceSlotRunTimePresetParameterChunkType ParameterChunkType { get; set; }
Visual C++
public:
property DeviceSlotRunTimePresetParameterChunkType ParameterChunkType {
    DeviceSlotRunTimePresetParameterChunkType get ();
    void set (DeviceSlotRunTimePresetParameterChunkType value);
}
JavaScript
function get_parameterChunkType();
function set_parameterChunkType(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


Parameters Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.Parameters Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameter()
C#
public Parameter[] Parameters { get; set; }
Visual C++
public:
property array<Parameter^>^ Parameters {
    array<Parameter^>^ get ();
    void set (array<Parameter^>^ value);
}
JavaScript
function get_parameters();
function set_parameters(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginDisplayName Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginDisplayName Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginDisplayName As String
C#
public string PluginDisplayName { get; set; }
Visual C++
public:
property String^ PluginDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginDisplayName();
function set_pluginDisplayName(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginEditorWindowPosition Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginEditorWindowPosition Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginEditorWindowPosition As String
C#
public string PluginEditorWindowPosition { get; set; }
Visual C++
public:
property String^ PluginEditorWindowPosition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginEditorWindowPosition();
function set_pluginEditorWindowPosition(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginIdentifier Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginIdentifier Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginIdentifier As String
C#
public string PluginIdentifier { get; set; }
Visual C++
public:
property String^ PluginIdentifier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginIdentifier();
function set_pluginIdentifier(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginShortDisplayName Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginShortDisplayName Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginShortDisplayName As String
C#
public string PluginShortDisplayName { get; set; }
Visual C++
public:
property String^ PluginShortDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginShortDisplayName();
function set_pluginShortDisplayName(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginType Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginType Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginType As DeviceSlotRunTimePresetPluginType
C#
public DeviceSlotRunTimePresetPluginType PluginType { get; set; }
Visual C++
public:
property DeviceSlotRunTimePresetPluginType PluginType {
    DeviceSlotRunTimePresetPluginType get ();
    void set (DeviceSlotRunTimePresetPluginType value);
}
JavaScript
function get_pluginType();
function set_pluginType(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


PluginTypeSpecified Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.PluginTypeSpecified Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginTypeSpecified As Boolean
C#
public bool PluginTypeSpecified { get; set; }
Visual C++
public:
property bool PluginTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pluginTypeSpecified();
function set_pluginTypeSpecified(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DeviceSlotRunTimePreset..::.type Property
DeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DeviceSlotRunTimePreset Class


DeviceSlotRunTimePresetParameterChunkType Enumeration

[image]

.NET Framework Class Library
DeviceSlotRunTimePresetParameterChunkType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DeviceSlotRunTimePresetParameterChunkType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DeviceSlotRunTimePresetParameterChunkType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DeviceSlotRunTimePresetParameterChunkType
JavaScript
NRenoiseTools.DeviceSlotRunTimePresetParameterChunkType = function();
NRenoiseTools.DeviceSlotRunTimePresetParameterChunkType.createEnum('NRenoiseTools.DeviceSlotRunTimePresetParameterChunkType', false);

Members

Member name | Description
Chunk |
ParameterBag |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DeviceSlotRunTimePresetPluginType Enumeration

[image]

.NET Framework Class Library
DeviceSlotRunTimePresetPluginType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DeviceSlotRunTimePresetPluginType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DeviceSlotRunTimePresetPluginType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DeviceSlotRunTimePresetPluginType
JavaScript
NRenoiseTools.DeviceSlotRunTimePresetPluginType = function();
NRenoiseTools.DeviceSlotRunTimePresetPluginType.createEnum('NRenoiseTools.DeviceSlotRunTimePresetPluginType', false);

Members

Member name | Description
AU |
VST |
LADSAP |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Distortion2DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDeviceSlotRunTimePreset

See Also

Distortion2DeviceDeviceSlotRunTimePreset Members


Distortion2DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset Members
Distortion2DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Drive |
DryOut |
Tone |
type |
Type |
WetOut |

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Distortion2DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset Constructor
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Distortion2DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceDeviceSlotRunTimePreset = function();

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Distortion2DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset Methods
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Distortion2DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset Properties
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Drive |
DryOut |
Tone |
type |
Type |
WetOut |

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Drive Property

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset..::.Drive Property
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Drive As Distortion2DeviceDriveRunTimePreset
C#
public Distortion2DeviceDriveRunTimePreset Drive { get; set; }
Visual C++
public:
property Distortion2DeviceDriveRunTimePreset^ Drive {
    Distortion2DeviceDriveRunTimePreset^ get ();
    void set (Distortion2DeviceDriveRunTimePreset^ value);
}
JavaScript
function get_drive();
function set_drive(value);

Remarks

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


DryOut Property

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset..::.DryOut Property
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As Distortion2DeviceDryOutRunTimePreset
C#
public Distortion2DeviceDryOutRunTimePreset DryOut { get; set; }
Visual C++
public:
property Distortion2DeviceDryOutRunTimePreset^ DryOut {
    Distortion2DeviceDryOutRunTimePreset^ get ();
    void set (Distortion2DeviceDryOutRunTimePreset^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Tone Property

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset..::.Tone Property
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Tone As Distortion2DeviceToneRunTimePreset
C#
public Distortion2DeviceToneRunTimePreset Tone { get; set; }
Visual C++
public:
property Distortion2DeviceToneRunTimePreset^ Tone {
    Distortion2DeviceToneRunTimePreset^ get ();
    void set (Distortion2DeviceToneRunTimePreset^ value);
}
JavaScript
function get_tone();
function set_tone(value);

Remarks

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset..::.Type Property
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Distortion2DeviceTypeRunTimePreset
C#
public Distortion2DeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property Distortion2DeviceTypeRunTimePreset^ Type {
    Distortion2DeviceTypeRunTimePreset^ get ();
    void set (Distortion2DeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


WetOut Property

[image]

.NET Framework Class Library
Distortion2DeviceDeviceSlotRunTimePreset..::.WetOut Property
Distortion2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As Distortion2DeviceWetOutRunTimePreset
C#
public Distortion2DeviceWetOutRunTimePreset WetOut { get; set; }
Visual C++
public:
property Distortion2DeviceWetOutRunTimePreset^ WetOut {
    Distortion2DeviceWetOutRunTimePreset^ get ();
    void set (Distortion2DeviceWetOutRunTimePreset^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

Distortion2DeviceDeviceSlotRunTimePreset Class


Distortion2DeviceDistortionDevice Class

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDistortionDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDistortionDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDistortionDevice
JavaScript
NRenoiseTools.Distortion2DeviceDistortionDevice = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDistortionDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDistortionDevice

See Also

Distortion2DeviceDistortionDevice Members


Distortion2DeviceDistortionDevice Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice Members
Distortion2DeviceDistortionDevice Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDistortionDevice type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDistortionDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Drive |
DryOut |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Tone |
type |
Type |
WetOut |

See Also

Distortion2DeviceDistortionDevice Class


Distortion2DeviceDistortionDevice Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice Constructor
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDistortionDevice()
Visual C++
public:
Distortion2DeviceDistortionDevice()
JavaScript
NRenoiseTools.Distortion2DeviceDistortionDevice = function();

See Also

Distortion2DeviceDistortionDevice Class


Distortion2DeviceDistortionDevice Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice Methods
Distortion2DeviceDistortionDevice Class See Also Send Feedback

The Distortion2DeviceDistortionDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDistortionDevice Class


Distortion2DeviceDistortionDevice Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice Properties
Distortion2DeviceDistortionDevice Class See Also Send Feedback

The Distortion2DeviceDistortionDevice type exposes the following members.

Properties

Name | Description
Drive |
DryOut |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Tone |
type |
Type |
WetOut |

See Also

Distortion2DeviceDistortionDevice Class


Drive Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.Drive Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Drive As Distortion2DeviceDrive
C#
public Distortion2DeviceDrive Drive { get; set; }
Visual C++
public:
property Distortion2DeviceDrive^ Drive {
    Distortion2DeviceDrive^ get ();
    void set (Distortion2DeviceDrive^ value);
}
JavaScript
function get_drive();
function set_drive(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


DryOut Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.DryOut Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As Distortion2DeviceDryOut
C#
public Distortion2DeviceDryOut DryOut { get; set; }
Visual C++
public:
property Distortion2DeviceDryOut^ DryOut {
    Distortion2DeviceDryOut^ get ();
    void set (Distortion2DeviceDryOut^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


IsActive Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.IsActive Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.IsSelected Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.RunTimePresetA Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Distortion2DeviceRunTimePreset
C#
public Distortion2DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Distortion2DeviceRunTimePreset^ RunTimePresetA {
    Distortion2DeviceRunTimePreset^ get ();
    void set (Distortion2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.RunTimePresetB Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Distortion2DeviceRunTimePreset
C#
public Distortion2DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Distortion2DeviceRunTimePreset^ RunTimePresetB {
    Distortion2DeviceRunTimePreset^ get ();
    void set (Distortion2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.SelectedPresetIsModified Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.SelectedPresetName Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


Tone Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.Tone Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Tone As Distortion2DeviceTone
C#
public Distortion2DeviceTone Tone { get; set; }
Visual C++
public:
property Distortion2DeviceTone^ Tone {
    Distortion2DeviceTone^ get ();
    void set (Distortion2DeviceTone^ value);
}
JavaScript
function get_tone();
function set_tone(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


Type Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.Type Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Distortion2DeviceType
C#
public Distortion2DeviceType Type { get; set; }
Visual C++
public:
property Distortion2DeviceType^ Type {
    Distortion2DeviceType^ get ();
    void set (Distortion2DeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


WetOut Property

[image]

.NET Framework Class Library
Distortion2DeviceDistortionDevice..::.WetOut Property
Distortion2DeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As Distortion2DeviceWetOut
C#
public Distortion2DeviceWetOut WetOut { get; set; }
Visual C++
public:
property Distortion2DeviceWetOut^ WetOut {
    Distortion2DeviceWetOut^ get ();
    void set (Distortion2DeviceWetOut^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

Distortion2DeviceDistortionDevice Class


Distortion2DeviceDrive Class

[image]

.NET Framework Class Library
Distortion2DeviceDrive Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDrive
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDrive
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDrive
JavaScript
NRenoiseTools.Distortion2DeviceDrive = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDrive');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDrive

See Also

Distortion2DeviceDrive Members


Distortion2DeviceDrive Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDrive Members
Distortion2DeviceDrive Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDrive type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDrive |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceDrive Class


Distortion2DeviceDrive Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDrive Constructor
Distortion2DeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDrive()
Visual C++
public:
Distortion2DeviceDrive()
JavaScript
NRenoiseTools.Distortion2DeviceDrive = function();

See Also

Distortion2DeviceDrive Class


Distortion2DeviceDrive Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDrive Methods
Distortion2DeviceDrive Class See Also Send Feedback

The Distortion2DeviceDrive type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDrive Class


Distortion2DeviceDrive Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDrive Properties
Distortion2DeviceDrive Class See Also Send Feedback

The Distortion2DeviceDrive type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceDrive Class


MidiMappings Property

[image]

.NET Framework Class Library
Distortion2DeviceDrive..::.MidiMappings Property
Distortion2DeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Distortion2DeviceDrive Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceDrive..::.Value Property
Distortion2DeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceDrive Class


Visualization Property

[image]

.NET Framework Class Library
Distortion2DeviceDrive..::.Visualization Property
Distortion2DeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Distortion2DeviceDriveVisualization
C#
public Distortion2DeviceDriveVisualization Visualization { get; set; }
Visual C++
public:
property Distortion2DeviceDriveVisualization Visualization {
    Distortion2DeviceDriveVisualization get ();
    void set (Distortion2DeviceDriveVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Distortion2DeviceDrive Class


Distortion2DeviceDriveRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDriveRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDriveRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDriveRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceDriveRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDriveRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDriveRunTimePreset

See Also

Distortion2DeviceDriveRunTimePreset Members


Distortion2DeviceDriveRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset Members
Distortion2DeviceDriveRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDriveRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDriveRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Distortion2DeviceDriveRunTimePreset Class


Distortion2DeviceDriveRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset Constructor
Distortion2DeviceDriveRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDriveRunTimePreset()
Visual C++
public:
Distortion2DeviceDriveRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceDriveRunTimePreset = function();

See Also

Distortion2DeviceDriveRunTimePreset Class


Distortion2DeviceDriveRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset Methods
Distortion2DeviceDriveRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDriveRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDriveRunTimePreset Class


Distortion2DeviceDriveRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset Properties
Distortion2DeviceDriveRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDriveRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Distortion2DeviceDriveRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceDriveRunTimePreset..::.Value Property
Distortion2DeviceDriveRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceDriveRunTimePreset Class


Distortion2DeviceDriveVisualization Enumeration

[image]

.NET Framework Class Library
Distortion2DeviceDriveVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Distortion2DeviceDriveVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Distortion2DeviceDriveVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Distortion2DeviceDriveVisualization
JavaScript
NRenoiseTools.Distortion2DeviceDriveVisualization = function();
NRenoiseTools.Distortion2DeviceDriveVisualization.createEnum('NRenoiseTools.Distortion2DeviceDriveVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Distortion2DeviceDryOut Class

[image]

.NET Framework Class Library
Distortion2DeviceDryOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDryOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDryOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDryOut
JavaScript
NRenoiseTools.Distortion2DeviceDryOut = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDryOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDryOut

See Also

Distortion2DeviceDryOut Members


Distortion2DeviceDryOut Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOut Members
Distortion2DeviceDryOut Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDryOut type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDryOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceDryOut Class


Distortion2DeviceDryOut Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDryOut Constructor
Distortion2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDryOut()
Visual C++
public:
Distortion2DeviceDryOut()
JavaScript
NRenoiseTools.Distortion2DeviceDryOut = function();

See Also

Distortion2DeviceDryOut Class


Distortion2DeviceDryOut Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOut Methods
Distortion2DeviceDryOut Class See Also Send Feedback

The Distortion2DeviceDryOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDryOut Class


Distortion2DeviceDryOut Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOut Properties
Distortion2DeviceDryOut Class See Also Send Feedback

The Distortion2DeviceDryOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceDryOut Class


MidiMappings Property

[image]

.NET Framework Class Library
Distortion2DeviceDryOut..::.MidiMappings Property
Distortion2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Distortion2DeviceDryOut Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceDryOut..::.Value Property
Distortion2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceDryOut Class


Visualization Property

[image]

.NET Framework Class Library
Distortion2DeviceDryOut..::.Visualization Property
Distortion2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Distortion2DeviceDryOutVisualization
C#
public Distortion2DeviceDryOutVisualization Visualization { get; set; }
Visual C++
public:
property Distortion2DeviceDryOutVisualization Visualization {
    Distortion2DeviceDryOutVisualization get ();
    void set (Distortion2DeviceDryOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Distortion2DeviceDryOut Class


Distortion2DeviceDryOutRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceDryOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceDryOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceDryOutRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceDryOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceDryOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceDryOutRunTimePreset

See Also

Distortion2DeviceDryOutRunTimePreset Members


Distortion2DeviceDryOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset Members
Distortion2DeviceDryOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceDryOutRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceDryOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Distortion2DeviceDryOutRunTimePreset Class


Distortion2DeviceDryOutRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset Constructor
Distortion2DeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceDryOutRunTimePreset()
Visual C++
public:
Distortion2DeviceDryOutRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceDryOutRunTimePreset = function();

See Also

Distortion2DeviceDryOutRunTimePreset Class


Distortion2DeviceDryOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset Methods
Distortion2DeviceDryOutRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDryOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceDryOutRunTimePreset Class


Distortion2DeviceDryOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset Properties
Distortion2DeviceDryOutRunTimePreset Class See Also Send Feedback

The Distortion2DeviceDryOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Distortion2DeviceDryOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceDryOutRunTimePreset..::.Value Property
Distortion2DeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceDryOutRunTimePreset Class


Distortion2DeviceDryOutVisualization Enumeration

[image]

.NET Framework Class Library
Distortion2DeviceDryOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Distortion2DeviceDryOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Distortion2DeviceDryOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Distortion2DeviceDryOutVisualization
JavaScript
NRenoiseTools.Distortion2DeviceDryOutVisualization = function();
NRenoiseTools.Distortion2DeviceDryOutVisualization.createEnum('NRenoiseTools.Distortion2DeviceDryOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Distortion2DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceRunTimePreset

See Also

Distortion2DeviceRunTimePreset Members


Distortion2DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset Members
Distortion2DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Distortion2DeviceRunTimePreset Class


Distortion2DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset Constructor
Distortion2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceRunTimePreset()
Visual C++
public:
Distortion2DeviceRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceRunTimePreset = function();

See Also

Distortion2DeviceRunTimePreset Class


Distortion2DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset Methods
Distortion2DeviceRunTimePreset Class See Also Send Feedback

The Distortion2DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceRunTimePreset Class


Distortion2DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset Properties
Distortion2DeviceRunTimePreset Class See Also Send Feedback

The Distortion2DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Distortion2DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset..::.DeviceSlot Property
Distortion2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Distortion2DeviceDeviceSlotRunTimePreset
C#
public Distortion2DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Distortion2DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Distortion2DeviceDeviceSlotRunTimePreset^ get ();
    void set (Distortion2DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Distortion2DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Distortion2DeviceRunTimePreset..::.type Property
Distortion2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Distortion2DeviceRunTimePreset Class


Distortion2DeviceTone Class

[image]

.NET Framework Class Library
Distortion2DeviceTone Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceTone
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceTone
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceTone
JavaScript
NRenoiseTools.Distortion2DeviceTone = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceTone');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceTone

See Also

Distortion2DeviceTone Members


Distortion2DeviceTone Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceTone Members
Distortion2DeviceTone Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceTone type exposes the following members.

Constructors

Name | Description
Distortion2DeviceTone |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceTone Class


Distortion2DeviceTone Constructor

[image]

.NET Framework Class Library
Distortion2DeviceTone Constructor
Distortion2DeviceTone Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceTone()
Visual C++
public:
Distortion2DeviceTone()
JavaScript
NRenoiseTools.Distortion2DeviceTone = function();

See Also

Distortion2DeviceTone Class


Distortion2DeviceTone Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceTone Methods
Distortion2DeviceTone Class See Also Send Feedback

The Distortion2DeviceTone type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceTone Class


Distortion2DeviceTone Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceTone Properties
Distortion2DeviceTone Class See Also Send Feedback

The Distortion2DeviceTone type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceTone Class


MidiMappings Property

[image]

.NET Framework Class Library
Distortion2DeviceTone..::.MidiMappings Property
Distortion2DeviceTone Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Distortion2DeviceTone Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceTone..::.Value Property
Distortion2DeviceTone Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceTone Class


Visualization Property

[image]

.NET Framework Class Library
Distortion2DeviceTone..::.Visualization Property
Distortion2DeviceTone Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Distortion2DeviceToneVisualization
C#
public Distortion2DeviceToneVisualization Visualization { get; set; }
Visual C++
public:
property Distortion2DeviceToneVisualization Visualization {
    Distortion2DeviceToneVisualization get ();
    void set (Distortion2DeviceToneVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Distortion2DeviceTone Class


Distortion2DeviceToneRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceToneRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceToneRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceToneRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceToneRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceToneRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceToneRunTimePreset

See Also

Distortion2DeviceToneRunTimePreset Members


Distortion2DeviceToneRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset Members
Distortion2DeviceToneRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceToneRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceToneRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Distortion2DeviceToneRunTimePreset Class


Distortion2DeviceToneRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset Constructor
Distortion2DeviceToneRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceToneRunTimePreset()
Visual C++
public:
Distortion2DeviceToneRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceToneRunTimePreset = function();

See Also

Distortion2DeviceToneRunTimePreset Class


Distortion2DeviceToneRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset Methods
Distortion2DeviceToneRunTimePreset Class See Also Send Feedback

The Distortion2DeviceToneRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceToneRunTimePreset Class


Distortion2DeviceToneRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset Properties
Distortion2DeviceToneRunTimePreset Class See Also Send Feedback

The Distortion2DeviceToneRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Distortion2DeviceToneRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceToneRunTimePreset..::.Value Property
Distortion2DeviceToneRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceToneRunTimePreset Class


Distortion2DeviceToneVisualization Enumeration

[image]

.NET Framework Class Library
Distortion2DeviceToneVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Distortion2DeviceToneVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Distortion2DeviceToneVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Distortion2DeviceToneVisualization
JavaScript
NRenoiseTools.Distortion2DeviceToneVisualization = function();
NRenoiseTools.Distortion2DeviceToneVisualization.createEnum('NRenoiseTools.Distortion2DeviceToneVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Distortion2DeviceType Class

[image]

.NET Framework Class Library
Distortion2DeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceType
JavaScript
NRenoiseTools.Distortion2DeviceType = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceType

See Also

Distortion2DeviceType Members


Distortion2DeviceType Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceType Members
Distortion2DeviceType Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceType type exposes the following members.

Constructors

Name | Description
Distortion2DeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceType Class


Distortion2DeviceType Constructor

[image]

.NET Framework Class Library
Distortion2DeviceType Constructor
Distortion2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceType()
Visual C++
public:
Distortion2DeviceType()
JavaScript
NRenoiseTools.Distortion2DeviceType = function();

See Also

Distortion2DeviceType Class


Distortion2DeviceType Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceType Methods
Distortion2DeviceType Class See Also Send Feedback

The Distortion2DeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceType Class


Distortion2DeviceType Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceType Properties
Distortion2DeviceType Class See Also Send Feedback

The Distortion2DeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
Distortion2DeviceType..::.MidiMappings Property
Distortion2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Distortion2DeviceType Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceType..::.Value Property
Distortion2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceType Class


Visualization Property

[image]

.NET Framework Class Library
Distortion2DeviceType..::.Visualization Property
Distortion2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Distortion2DeviceTypeVisualization
C#
public Distortion2DeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property Distortion2DeviceTypeVisualization Visualization {
    Distortion2DeviceTypeVisualization get ();
    void set (Distortion2DeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Distortion2DeviceType Class


Distortion2DeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceTypeRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceTypeRunTimePreset

See Also

Distortion2DeviceTypeRunTimePreset Members


Distortion2DeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset Members
Distortion2DeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Distortion2DeviceTypeRunTimePreset Class


Distortion2DeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset Constructor
Distortion2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceTypeRunTimePreset()
Visual C++
public:
Distortion2DeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceTypeRunTimePreset = function();

See Also

Distortion2DeviceTypeRunTimePreset Class


Distortion2DeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset Methods
Distortion2DeviceTypeRunTimePreset Class See Also Send Feedback

The Distortion2DeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceTypeRunTimePreset Class


Distortion2DeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset Properties
Distortion2DeviceTypeRunTimePreset Class See Also Send Feedback

The Distortion2DeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Distortion2DeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceTypeRunTimePreset..::.Value Property
Distortion2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceTypeRunTimePreset Class


Distortion2DeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
Distortion2DeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Distortion2DeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Distortion2DeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Distortion2DeviceTypeVisualization
JavaScript
NRenoiseTools.Distortion2DeviceTypeVisualization = function();
NRenoiseTools.Distortion2DeviceTypeVisualization.createEnum('NRenoiseTools.Distortion2DeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Distortion2DeviceWetOut Class

[image]

.NET Framework Class Library
Distortion2DeviceWetOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceWetOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceWetOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceWetOut
JavaScript
NRenoiseTools.Distortion2DeviceWetOut = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceWetOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceWetOut

See Also

Distortion2DeviceWetOut Members


Distortion2DeviceWetOut Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOut Members
Distortion2DeviceWetOut Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceWetOut type exposes the following members.

Constructors

Name | Description
Distortion2DeviceWetOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceWetOut Class


Distortion2DeviceWetOut Constructor

[image]

.NET Framework Class Library
Distortion2DeviceWetOut Constructor
Distortion2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceWetOut()
Visual C++
public:
Distortion2DeviceWetOut()
JavaScript
NRenoiseTools.Distortion2DeviceWetOut = function();

See Also

Distortion2DeviceWetOut Class


Distortion2DeviceWetOut Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOut Methods
Distortion2DeviceWetOut Class See Also Send Feedback

The Distortion2DeviceWetOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceWetOut Class


Distortion2DeviceWetOut Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOut Properties
Distortion2DeviceWetOut Class See Also Send Feedback

The Distortion2DeviceWetOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Distortion2DeviceWetOut Class


MidiMappings Property

[image]

.NET Framework Class Library
Distortion2DeviceWetOut..::.MidiMappings Property
Distortion2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Distortion2DeviceWetOut Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceWetOut..::.Value Property
Distortion2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceWetOut Class


Visualization Property

[image]

.NET Framework Class Library
Distortion2DeviceWetOut..::.Visualization Property
Distortion2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Distortion2DeviceWetOutVisualization
C#
public Distortion2DeviceWetOutVisualization Visualization { get; set; }
Visual C++
public:
property Distortion2DeviceWetOutVisualization Visualization {
    Distortion2DeviceWetOutVisualization get ();
    void set (Distortion2DeviceWetOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Distortion2DeviceWetOut Class


Distortion2DeviceWetOutRunTimePreset Class

[image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Distortion2DeviceWetOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Distortion2DeviceWetOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Distortion2DeviceWetOutRunTimePreset
JavaScript
NRenoiseTools.Distortion2DeviceWetOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Distortion2DeviceWetOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Distortion2DeviceWetOutRunTimePreset

See Also

Distortion2DeviceWetOutRunTimePreset Members


Distortion2DeviceWetOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset Members
Distortion2DeviceWetOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Distortion2DeviceWetOutRunTimePreset type exposes the following members.

Constructors

Name | Description
Distortion2DeviceWetOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Distortion2DeviceWetOutRunTimePreset Class


Distortion2DeviceWetOutRunTimePreset Constructor

[image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset Constructor
Distortion2DeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distortion2DeviceWetOutRunTimePreset()
Visual C++
public:
Distortion2DeviceWetOutRunTimePreset()
JavaScript
NRenoiseTools.Distortion2DeviceWetOutRunTimePreset = function();

See Also

Distortion2DeviceWetOutRunTimePreset Class


Distortion2DeviceWetOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset Methods
Distortion2DeviceWetOutRunTimePreset Class See Also Send Feedback

The Distortion2DeviceWetOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distortion2DeviceWetOutRunTimePreset Class


Distortion2DeviceWetOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset Properties
Distortion2DeviceWetOutRunTimePreset Class See Also Send Feedback

The Distortion2DeviceWetOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Distortion2DeviceWetOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Distortion2DeviceWetOutRunTimePreset..::.Value Property
Distortion2DeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distortion2DeviceWetOutRunTimePreset Class


Distortion2DeviceWetOutVisualization Enumeration

[image]

.NET Framework Class Library
Distortion2DeviceWetOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Distortion2DeviceWetOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Distortion2DeviceWetOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Distortion2DeviceWetOutVisualization
JavaScript
NRenoiseTools.Distortion2DeviceWetOutVisualization = function();
NRenoiseTools.Distortion2DeviceWetOutVisualization.createEnum('NRenoiseTools.Distortion2DeviceWetOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceDeviceSlotRunTimePreset

See Also

DistortionDeviceDeviceSlotRunTimePreset Members


DistortionDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset Members
DistortionDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DryOut |
GateOrFilter |
LpOrClamp |
Threshold |
type |
Type |
WetOut |

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


DistortionDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset Constructor
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceDeviceSlotRunTimePreset()
Visual C++
public:
DistortionDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceDeviceSlotRunTimePreset = function();

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


DistortionDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset Methods
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


DistortionDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset Properties
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The DistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
DryOut |
GateOrFilter |
LpOrClamp |
Threshold |
type |
Type |
WetOut |

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


DryOut Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.DryOut Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As DistortionDeviceDryOutRunTimePreset
C#
public DistortionDeviceDryOutRunTimePreset DryOut { get; set; }
Visual C++
public:
property DistortionDeviceDryOutRunTimePreset^ DryOut {
    DistortionDeviceDryOutRunTimePreset^ get ();
    void set (DistortionDeviceDryOutRunTimePreset^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


GateOrFilter Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.GateOrFilter Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateOrFilter As DistortionDeviceGateOrFilterRunTimePreset
C#
public DistortionDeviceGateOrFilterRunTimePreset GateOrFilter { get; set; }
Visual C++
public:
property DistortionDeviceGateOrFilterRunTimePreset^ GateOrFilter {
    DistortionDeviceGateOrFilterRunTimePreset^ get ();
    void set (DistortionDeviceGateOrFilterRunTimePreset^ value);
}
JavaScript
function get_gateOrFilter();
function set_gateOrFilter(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


LpOrClamp Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.LpOrClamp Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LpOrClamp As DistortionDeviceLpOrClampRunTimePreset
C#
public DistortionDeviceLpOrClampRunTimePreset LpOrClamp { get; set; }
Visual C++
public:
property DistortionDeviceLpOrClampRunTimePreset^ LpOrClamp {
    DistortionDeviceLpOrClampRunTimePreset^ get ();
    void set (DistortionDeviceLpOrClampRunTimePreset^ value);
}
JavaScript
function get_lpOrClamp();
function set_lpOrClamp(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.Threshold Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As DistortionDeviceThresholdRunTimePreset
C#
public DistortionDeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property DistortionDeviceThresholdRunTimePreset^ Threshold {
    DistortionDeviceThresholdRunTimePreset^ get ();
    void set (DistortionDeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.Type Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DistortionDeviceTypeRunTimePreset
C#
public DistortionDeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property DistortionDeviceTypeRunTimePreset^ Type {
    DistortionDeviceTypeRunTimePreset^ get ();
    void set (DistortionDeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


WetOut Property

[image]

.NET Framework Class Library
DistortionDeviceDeviceSlotRunTimePreset..::.WetOut Property
DistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As DistortionDeviceWetOutRunTimePreset
C#
public DistortionDeviceWetOutRunTimePreset WetOut { get; set; }
Visual C++
public:
property DistortionDeviceWetOutRunTimePreset^ WetOut {
    DistortionDeviceWetOutRunTimePreset^ get ();
    void set (DistortionDeviceWetOutRunTimePreset^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

DistortionDeviceDeviceSlotRunTimePreset Class


DistortionDeviceDistortionDevice Class

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceDistortionDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceDistortionDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceDistortionDevice
JavaScript
NRenoiseTools.DistortionDeviceDistortionDevice = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceDistortionDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceDistortionDevice

See Also

DistortionDeviceDistortionDevice Members


DistortionDeviceDistortionDevice Members

[image] [image]

.NET Framework Class Library
DistortionDeviceDistortionDevice Members
DistortionDeviceDistortionDevice Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceDistortionDevice type exposes the following members.

Constructors

Name | Description
DistortionDeviceDistortionDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DryOut |
GateOrFilter |
IsActive |
IsSelected |
LpOrClamp |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |
Type |
WetOut |

See Also

DistortionDeviceDistortionDevice Class


DistortionDeviceDistortionDevice Constructor

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice Constructor
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceDistortionDevice()
Visual C++
public:
DistortionDeviceDistortionDevice()
JavaScript
NRenoiseTools.DistortionDeviceDistortionDevice = function();

See Also

DistortionDeviceDistortionDevice Class


DistortionDeviceDistortionDevice Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceDistortionDevice Methods
DistortionDeviceDistortionDevice Class See Also Send Feedback

The DistortionDeviceDistortionDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceDistortionDevice Class


DistortionDeviceDistortionDevice Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceDistortionDevice Properties
DistortionDeviceDistortionDevice Class See Also Send Feedback

The DistortionDeviceDistortionDevice type exposes the following members.

Properties

Name | Description
DryOut |
GateOrFilter |
IsActive |
IsSelected |
LpOrClamp |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |
Type |
WetOut |

See Also

DistortionDeviceDistortionDevice Class


DryOut Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.DryOut Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As DistortionDeviceDryOut
C#
public DistortionDeviceDryOut DryOut { get; set; }
Visual C++
public:
property DistortionDeviceDryOut^ DryOut {
    DistortionDeviceDryOut^ get ();
    void set (DistortionDeviceDryOut^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


GateOrFilter Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.GateOrFilter Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateOrFilter As DistortionDeviceGateOrFilter
C#
public DistortionDeviceGateOrFilter GateOrFilter { get; set; }
Visual C++
public:
property DistortionDeviceGateOrFilter^ GateOrFilter {
    DistortionDeviceGateOrFilter^ get ();
    void set (DistortionDeviceGateOrFilter^ value);
}
JavaScript
function get_gateOrFilter();
function set_gateOrFilter(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


IsActive Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.IsActive Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


IsSelected Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.IsSelected Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


LpOrClamp Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.LpOrClamp Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LpOrClamp As DistortionDeviceLpOrClamp
C#
public DistortionDeviceLpOrClamp LpOrClamp { get; set; }
Visual C++
public:
property DistortionDeviceLpOrClamp^ LpOrClamp {
    DistortionDeviceLpOrClamp^ get ();
    void set (DistortionDeviceLpOrClamp^ value);
}
JavaScript
function get_lpOrClamp();
function set_lpOrClamp(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.RunTimePresetA Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As DistortionDeviceRunTimePreset
C#
public DistortionDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property DistortionDeviceRunTimePreset^ RunTimePresetA {
    DistortionDeviceRunTimePreset^ get ();
    void set (DistortionDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.RunTimePresetB Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As DistortionDeviceRunTimePreset
C#
public DistortionDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property DistortionDeviceRunTimePreset^ RunTimePresetB {
    DistortionDeviceRunTimePreset^ get ();
    void set (DistortionDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.SelectedPresetIsModified Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.SelectedPresetName Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


Threshold Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.Threshold Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As DistortionDeviceThreshold
C#
public DistortionDeviceThreshold Threshold { get; set; }
Visual C++
public:
property DistortionDeviceThreshold^ Threshold {
    DistortionDeviceThreshold^ get ();
    void set (DistortionDeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


Type Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.Type Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DistortionDeviceType
C#
public DistortionDeviceType Type { get; set; }
Visual C++
public:
property DistortionDeviceType^ Type {
    DistortionDeviceType^ get ();
    void set (DistortionDeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


WetOut Property

[image]

.NET Framework Class Library
DistortionDeviceDistortionDevice..::.WetOut Property
DistortionDeviceDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As DistortionDeviceWetOut
C#
public DistortionDeviceWetOut WetOut { get; set; }
Visual C++
public:
property DistortionDeviceWetOut^ WetOut {
    DistortionDeviceWetOut^ get ();
    void set (DistortionDeviceWetOut^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

DistortionDeviceDistortionDevice Class


DistortionDeviceDryOut Class

[image]

.NET Framework Class Library
DistortionDeviceDryOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceDryOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceDryOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceDryOut
JavaScript
NRenoiseTools.DistortionDeviceDryOut = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceDryOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceDryOut

See Also

DistortionDeviceDryOut Members


DistortionDeviceDryOut Members

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOut Members
DistortionDeviceDryOut Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceDryOut type exposes the following members.

Constructors

Name | Description
DistortionDeviceDryOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceDryOut Class


DistortionDeviceDryOut Constructor

[image]

.NET Framework Class Library
DistortionDeviceDryOut Constructor
DistortionDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceDryOut()
Visual C++
public:
DistortionDeviceDryOut()
JavaScript
NRenoiseTools.DistortionDeviceDryOut = function();

See Also

DistortionDeviceDryOut Class


DistortionDeviceDryOut Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOut Methods
DistortionDeviceDryOut Class See Also Send Feedback

The DistortionDeviceDryOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceDryOut Class


DistortionDeviceDryOut Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOut Properties
DistortionDeviceDryOut Class See Also Send Feedback

The DistortionDeviceDryOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceDryOut Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceDryOut..::.MidiMappings Property
DistortionDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceDryOut Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceDryOut..::.Value Property
DistortionDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceDryOut Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceDryOut..::.Visualization Property
DistortionDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceDryOutVisualization
C#
public DistortionDeviceDryOutVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceDryOutVisualization Visualization {
    DistortionDeviceDryOutVisualization get ();
    void set (DistortionDeviceDryOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceDryOut Class


DistortionDeviceDryOutRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceDryOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceDryOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceDryOutRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceDryOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceDryOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceDryOutRunTimePreset

See Also

DistortionDeviceDryOutRunTimePreset Members


DistortionDeviceDryOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset Members
DistortionDeviceDryOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceDryOutRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceDryOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceDryOutRunTimePreset Class


DistortionDeviceDryOutRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset Constructor
DistortionDeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceDryOutRunTimePreset()
Visual C++
public:
DistortionDeviceDryOutRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceDryOutRunTimePreset = function();

See Also

DistortionDeviceDryOutRunTimePreset Class


DistortionDeviceDryOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset Methods
DistortionDeviceDryOutRunTimePreset Class See Also Send Feedback

The DistortionDeviceDryOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceDryOutRunTimePreset Class


DistortionDeviceDryOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset Properties
DistortionDeviceDryOutRunTimePreset Class See Also Send Feedback

The DistortionDeviceDryOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceDryOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceDryOutRunTimePreset..::.Value Property
DistortionDeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceDryOutRunTimePreset Class


DistortionDeviceDryOutVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceDryOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceDryOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceDryOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceDryOutVisualization
JavaScript
NRenoiseTools.DistortionDeviceDryOutVisualization = function();
NRenoiseTools.DistortionDeviceDryOutVisualization.createEnum('NRenoiseTools.DistortionDeviceDryOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceGateOrFilter Class

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceGateOrFilter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceGateOrFilter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceGateOrFilter
JavaScript
NRenoiseTools.DistortionDeviceGateOrFilter = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceGateOrFilter');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceGateOrFilter

See Also

DistortionDeviceGateOrFilter Members


DistortionDeviceGateOrFilter Members

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilter Members
DistortionDeviceGateOrFilter Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceGateOrFilter type exposes the following members.

Constructors

Name | Description
DistortionDeviceGateOrFilter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceGateOrFilter Class


DistortionDeviceGateOrFilter Constructor

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilter Constructor
DistortionDeviceGateOrFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceGateOrFilter()
Visual C++
public:
DistortionDeviceGateOrFilter()
JavaScript
NRenoiseTools.DistortionDeviceGateOrFilter = function();

See Also

DistortionDeviceGateOrFilter Class


DistortionDeviceGateOrFilter Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilter Methods
DistortionDeviceGateOrFilter Class See Also Send Feedback

The DistortionDeviceGateOrFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceGateOrFilter Class


DistortionDeviceGateOrFilter Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilter Properties
DistortionDeviceGateOrFilter Class See Also Send Feedback

The DistortionDeviceGateOrFilter type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceGateOrFilter Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilter..::.MidiMappings Property
DistortionDeviceGateOrFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceGateOrFilter Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilter..::.Value Property
DistortionDeviceGateOrFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceGateOrFilter Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilter..::.Visualization Property
DistortionDeviceGateOrFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceGateOrFilterVisualization
C#
public DistortionDeviceGateOrFilterVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceGateOrFilterVisualization Visualization {
    DistortionDeviceGateOrFilterVisualization get ();
    void set (DistortionDeviceGateOrFilterVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceGateOrFilter Class


DistortionDeviceGateOrFilterRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceGateOrFilterRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceGateOrFilterRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceGateOrFilterRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceGateOrFilterRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceGateOrFilterRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceGateOrFilterRunTimePreset

See Also

DistortionDeviceGateOrFilterRunTimePreset Members


DistortionDeviceGateOrFilterRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset Members
DistortionDeviceGateOrFilterRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceGateOrFilterRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceGateOrFilterRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceGateOrFilterRunTimePreset Class


DistortionDeviceGateOrFilterRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset Constructor
DistortionDeviceGateOrFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceGateOrFilterRunTimePreset()
Visual C++
public:
DistortionDeviceGateOrFilterRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceGateOrFilterRunTimePreset = function();

See Also

DistortionDeviceGateOrFilterRunTimePreset Class


DistortionDeviceGateOrFilterRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset Methods
DistortionDeviceGateOrFilterRunTimePreset Class See Also Send Feedback

The DistortionDeviceGateOrFilterRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceGateOrFilterRunTimePreset Class


DistortionDeviceGateOrFilterRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset Properties
DistortionDeviceGateOrFilterRunTimePreset Class See Also Send Feedback

The DistortionDeviceGateOrFilterRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceGateOrFilterRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilterRunTimePreset..::.Value Property
DistortionDeviceGateOrFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceGateOrFilterRunTimePreset Class


DistortionDeviceGateOrFilterVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceGateOrFilterVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceGateOrFilterVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceGateOrFilterVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceGateOrFilterVisualization
JavaScript
NRenoiseTools.DistortionDeviceGateOrFilterVisualization = function();
NRenoiseTools.DistortionDeviceGateOrFilterVisualization.createEnum('NRenoiseTools.DistortionDeviceGateOrFilterVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceLpOrClamp Class

[image]

.NET Framework Class Library
DistortionDeviceLpOrClamp Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceLpOrClamp
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceLpOrClamp
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceLpOrClamp
JavaScript
NRenoiseTools.DistortionDeviceLpOrClamp = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceLpOrClamp');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceLpOrClamp

See Also

DistortionDeviceLpOrClamp Members


DistortionDeviceLpOrClamp Members

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClamp Members
DistortionDeviceLpOrClamp Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceLpOrClamp type exposes the following members.

Constructors

Name | Description
DistortionDeviceLpOrClamp |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceLpOrClamp Class


DistortionDeviceLpOrClamp Constructor

[image]

.NET Framework Class Library
DistortionDeviceLpOrClamp Constructor
DistortionDeviceLpOrClamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceLpOrClamp()
Visual C++
public:
DistortionDeviceLpOrClamp()
JavaScript
NRenoiseTools.DistortionDeviceLpOrClamp = function();

See Also

DistortionDeviceLpOrClamp Class


DistortionDeviceLpOrClamp Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClamp Methods
DistortionDeviceLpOrClamp Class See Also Send Feedback

The DistortionDeviceLpOrClamp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceLpOrClamp Class


DistortionDeviceLpOrClamp Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClamp Properties
DistortionDeviceLpOrClamp Class See Also Send Feedback

The DistortionDeviceLpOrClamp type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceLpOrClamp Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceLpOrClamp..::.MidiMappings Property
DistortionDeviceLpOrClamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceLpOrClamp Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceLpOrClamp..::.Value Property
DistortionDeviceLpOrClamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceLpOrClamp Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceLpOrClamp..::.Visualization Property
DistortionDeviceLpOrClamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceLpOrClampVisualization
C#
public DistortionDeviceLpOrClampVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceLpOrClampVisualization Visualization {
    DistortionDeviceLpOrClampVisualization get ();
    void set (DistortionDeviceLpOrClampVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceLpOrClamp Class


DistortionDeviceLpOrClampRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceLpOrClampRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceLpOrClampRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceLpOrClampRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceLpOrClampRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceLpOrClampRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceLpOrClampRunTimePreset

See Also

DistortionDeviceLpOrClampRunTimePreset Members


DistortionDeviceLpOrClampRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset Members
DistortionDeviceLpOrClampRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceLpOrClampRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceLpOrClampRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceLpOrClampRunTimePreset Class


DistortionDeviceLpOrClampRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset Constructor
DistortionDeviceLpOrClampRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceLpOrClampRunTimePreset()
Visual C++
public:
DistortionDeviceLpOrClampRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceLpOrClampRunTimePreset = function();

See Also

DistortionDeviceLpOrClampRunTimePreset Class


DistortionDeviceLpOrClampRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset Methods
DistortionDeviceLpOrClampRunTimePreset Class See Also Send Feedback

The DistortionDeviceLpOrClampRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceLpOrClampRunTimePreset Class


DistortionDeviceLpOrClampRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset Properties
DistortionDeviceLpOrClampRunTimePreset Class See Also Send Feedback

The DistortionDeviceLpOrClampRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceLpOrClampRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceLpOrClampRunTimePreset..::.Value Property
DistortionDeviceLpOrClampRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceLpOrClampRunTimePreset Class


DistortionDeviceLpOrClampVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceLpOrClampVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceLpOrClampVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceLpOrClampVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceLpOrClampVisualization
JavaScript
NRenoiseTools.DistortionDeviceLpOrClampVisualization = function();
NRenoiseTools.DistortionDeviceLpOrClampVisualization.createEnum('NRenoiseTools.DistortionDeviceLpOrClampVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceRunTimePreset

See Also

DistortionDeviceRunTimePreset Members


DistortionDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceRunTimePreset Members
DistortionDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

DistortionDeviceRunTimePreset Class


DistortionDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceRunTimePreset Constructor
DistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceRunTimePreset()
Visual C++
public:
DistortionDeviceRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceRunTimePreset = function();

See Also

DistortionDeviceRunTimePreset Class


DistortionDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceRunTimePreset Methods
DistortionDeviceRunTimePreset Class See Also Send Feedback

The DistortionDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceRunTimePreset Class


DistortionDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceRunTimePreset Properties
DistortionDeviceRunTimePreset Class See Also Send Feedback

The DistortionDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

DistortionDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
DistortionDeviceRunTimePreset..::.DeviceSlot Property
DistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As DistortionDeviceDeviceSlotRunTimePreset
C#
public DistortionDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property DistortionDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    DistortionDeviceDeviceSlotRunTimePreset^ get ();
    void set (DistortionDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

DistortionDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
DistortionDeviceRunTimePreset..::.type Property
DistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DistortionDeviceRunTimePreset Class


DistortionDeviceThreshold Class

[image]

.NET Framework Class Library
DistortionDeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceThreshold
JavaScript
NRenoiseTools.DistortionDeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceThreshold

See Also

DistortionDeviceThreshold Members


DistortionDeviceThreshold Members

[image] [image]

.NET Framework Class Library
DistortionDeviceThreshold Members
DistortionDeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceThreshold type exposes the following members.

Constructors

Name | Description
DistortionDeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceThreshold Class


DistortionDeviceThreshold Constructor

[image]

.NET Framework Class Library
DistortionDeviceThreshold Constructor
DistortionDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceThreshold()
Visual C++
public:
DistortionDeviceThreshold()
JavaScript
NRenoiseTools.DistortionDeviceThreshold = function();

See Also

DistortionDeviceThreshold Class


DistortionDeviceThreshold Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceThreshold Methods
DistortionDeviceThreshold Class See Also Send Feedback

The DistortionDeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceThreshold Class


DistortionDeviceThreshold Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceThreshold Properties
DistortionDeviceThreshold Class See Also Send Feedback

The DistortionDeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceThreshold..::.MidiMappings Property
DistortionDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceThreshold..::.Value Property
DistortionDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceThreshold..::.Visualization Property
DistortionDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceThresholdVisualization
C#
public DistortionDeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceThresholdVisualization Visualization {
    DistortionDeviceThresholdVisualization get ();
    void set (DistortionDeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceThreshold Class


DistortionDeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceThresholdRunTimePreset

See Also

DistortionDeviceThresholdRunTimePreset Members


DistortionDeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset Members
DistortionDeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceThresholdRunTimePreset Class


DistortionDeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset Constructor
DistortionDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceThresholdRunTimePreset()
Visual C++
public:
DistortionDeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceThresholdRunTimePreset = function();

See Also

DistortionDeviceThresholdRunTimePreset Class


DistortionDeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset Methods
DistortionDeviceThresholdRunTimePreset Class See Also Send Feedback

The DistortionDeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceThresholdRunTimePreset Class


DistortionDeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset Properties
DistortionDeviceThresholdRunTimePreset Class See Also Send Feedback

The DistortionDeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceThresholdRunTimePreset..::.Value Property
DistortionDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceThresholdRunTimePreset Class


DistortionDeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceThresholdVisualization
JavaScript
NRenoiseTools.DistortionDeviceThresholdVisualization = function();
NRenoiseTools.DistortionDeviceThresholdVisualization.createEnum('NRenoiseTools.DistortionDeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceType Class

[image]

.NET Framework Class Library
DistortionDeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceType
JavaScript
NRenoiseTools.DistortionDeviceType = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceType

See Also

DistortionDeviceType Members


DistortionDeviceType Members

[image] [image]

.NET Framework Class Library
DistortionDeviceType Members
DistortionDeviceType Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceType type exposes the following members.

Constructors

Name | Description
DistortionDeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceType Class


DistortionDeviceType Constructor

[image]

.NET Framework Class Library
DistortionDeviceType Constructor
DistortionDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceType()
Visual C++
public:
DistortionDeviceType()
JavaScript
NRenoiseTools.DistortionDeviceType = function();

See Also

DistortionDeviceType Class


DistortionDeviceType Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceType Methods
DistortionDeviceType Class See Also Send Feedback

The DistortionDeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceType Class


DistortionDeviceType Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceType Properties
DistortionDeviceType Class See Also Send Feedback

The DistortionDeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceType..::.MidiMappings Property
DistortionDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceType Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceType..::.Value Property
DistortionDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceType Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceType..::.Visualization Property
DistortionDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceTypeVisualization
C#
public DistortionDeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceTypeVisualization Visualization {
    DistortionDeviceTypeVisualization get ();
    void set (DistortionDeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceType Class


DistortionDeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceTypeRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceTypeRunTimePreset

See Also

DistortionDeviceTypeRunTimePreset Members


DistortionDeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset Members
DistortionDeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceTypeRunTimePreset Class


DistortionDeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset Constructor
DistortionDeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceTypeRunTimePreset()
Visual C++
public:
DistortionDeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceTypeRunTimePreset = function();

See Also

DistortionDeviceTypeRunTimePreset Class


DistortionDeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset Methods
DistortionDeviceTypeRunTimePreset Class See Also Send Feedback

The DistortionDeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceTypeRunTimePreset Class


DistortionDeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset Properties
DistortionDeviceTypeRunTimePreset Class See Also Send Feedback

The DistortionDeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceTypeRunTimePreset..::.Value Property
DistortionDeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceTypeRunTimePreset Class


DistortionDeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceTypeVisualization
JavaScript
NRenoiseTools.DistortionDeviceTypeVisualization = function();
NRenoiseTools.DistortionDeviceTypeVisualization.createEnum('NRenoiseTools.DistortionDeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


DistortionDeviceWetOut Class

[image]

.NET Framework Class Library
DistortionDeviceWetOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceWetOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceWetOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceWetOut
JavaScript
NRenoiseTools.DistortionDeviceWetOut = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceWetOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceWetOut

See Also

DistortionDeviceWetOut Members


DistortionDeviceWetOut Members

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOut Members
DistortionDeviceWetOut Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceWetOut type exposes the following members.

Constructors

Name | Description
DistortionDeviceWetOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceWetOut Class


DistortionDeviceWetOut Constructor

[image]

.NET Framework Class Library
DistortionDeviceWetOut Constructor
DistortionDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceWetOut()
Visual C++
public:
DistortionDeviceWetOut()
JavaScript
NRenoiseTools.DistortionDeviceWetOut = function();

See Also

DistortionDeviceWetOut Class


DistortionDeviceWetOut Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOut Methods
DistortionDeviceWetOut Class See Also Send Feedback

The DistortionDeviceWetOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceWetOut Class


DistortionDeviceWetOut Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOut Properties
DistortionDeviceWetOut Class See Also Send Feedback

The DistortionDeviceWetOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

DistortionDeviceWetOut Class


MidiMappings Property

[image]

.NET Framework Class Library
DistortionDeviceWetOut..::.MidiMappings Property
DistortionDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

DistortionDeviceWetOut Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceWetOut..::.Value Property
DistortionDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceWetOut Class


Visualization Property

[image]

.NET Framework Class Library
DistortionDeviceWetOut..::.Visualization Property
DistortionDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As DistortionDeviceWetOutVisualization
C#
public DistortionDeviceWetOutVisualization Visualization { get; set; }
Visual C++
public:
property DistortionDeviceWetOutVisualization Visualization {
    DistortionDeviceWetOutVisualization get ();
    void set (DistortionDeviceWetOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

DistortionDeviceWetOut Class


DistortionDeviceWetOutRunTimePreset Class

[image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class DistortionDeviceWetOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class DistortionDeviceWetOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class DistortionDeviceWetOutRunTimePreset
JavaScript
NRenoiseTools.DistortionDeviceWetOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.DistortionDeviceWetOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.DistortionDeviceWetOutRunTimePreset

See Also

DistortionDeviceWetOutRunTimePreset Members


DistortionDeviceWetOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset Members
DistortionDeviceWetOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The DistortionDeviceWetOutRunTimePreset type exposes the following members.

Constructors

Name | Description
DistortionDeviceWetOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

DistortionDeviceWetOutRunTimePreset Class


DistortionDeviceWetOutRunTimePreset Constructor

[image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset Constructor
DistortionDeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DistortionDeviceWetOutRunTimePreset()
Visual C++
public:
DistortionDeviceWetOutRunTimePreset()
JavaScript
NRenoiseTools.DistortionDeviceWetOutRunTimePreset = function();

See Also

DistortionDeviceWetOutRunTimePreset Class


DistortionDeviceWetOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset Methods
DistortionDeviceWetOutRunTimePreset Class See Also Send Feedback

The DistortionDeviceWetOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortionDeviceWetOutRunTimePreset Class


DistortionDeviceWetOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset Properties
DistortionDeviceWetOutRunTimePreset Class See Also Send Feedback

The DistortionDeviceWetOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

DistortionDeviceWetOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
DistortionDeviceWetOutRunTimePreset..::.Value Property
DistortionDeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

DistortionDeviceWetOutRunTimePreset Class


DistortionDeviceWetOutVisualization Enumeration

[image]

.NET Framework Class Library
DistortionDeviceWetOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration DistortionDeviceWetOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum DistortionDeviceWetOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class DistortionDeviceWetOutVisualization
JavaScript
NRenoiseTools.DistortionDeviceWetOutVisualization = function();
NRenoiseTools.DistortionDeviceWetOutVisualization.createEnum('NRenoiseTools.DistortionDeviceWetOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EffectColumn Class

[image]

.NET Framework Class Library
EffectColumn Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EffectColumn
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EffectColumn
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EffectColumn
JavaScript
NRenoiseTools.EffectColumn = function();

Type.createClass(
    'NRenoiseTools.EffectColumn');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EffectColumn

See Also

EffectColumn Members


EffectColumn Members

[image] [image]

.NET Framework Class Library
EffectColumn Members
EffectColumn Class Constructors Methods Properties See Also Send Feedback

The EffectColumn type exposes the following members.

Constructors

Name | Description
EffectColumn |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Number |
Value |

See Also

EffectColumn Class


EffectColumn Constructor

[image]

.NET Framework Class Library
EffectColumn Constructor
EffectColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EffectColumn()
Visual C++
public:
EffectColumn()
JavaScript
NRenoiseTools.EffectColumn = function();

See Also

EffectColumn Class


EffectColumn Methods

[image] [image]

.NET Framework Class Library
EffectColumn Methods
EffectColumn Class See Also Send Feedback

The EffectColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EffectColumn Class


EffectColumn Properties

[image] [image]

.NET Framework Class Library
EffectColumn Properties
EffectColumn Class See Also Send Feedback

The EffectColumn type exposes the following members.

Properties

Name | Description
Number |
Value |

See Also

EffectColumn Class


Number Property

[image]

.NET Framework Class Library
EffectColumn..::.Number Property
EffectColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Number As String
C#
public string Number { get; set; }
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

EffectColumn Class


Value Property

[image]

.NET Framework Class Library
EffectColumn..::.Value Property
EffectColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

EffectColumn Class


EnvelopeData Class

[image]

.NET Framework Class Library
EnvelopeData Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopeData
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopeData
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopeData
JavaScript
NRenoiseTools.EnvelopeData = function();

Type.createClass(
    'NRenoiseTools.EnvelopeData');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopeData

See Also

EnvelopeData Members


EnvelopeData Members

[image] [image]

.NET Framework Class Library
EnvelopeData Members
EnvelopeData Class Constructors Methods Properties See Also Send Feedback

The EnvelopeData type exposes the following members.

Constructors

Name | Description
EnvelopeData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

EnvelopeData Class


EnvelopeData Constructor

[image]

.NET Framework Class Library
EnvelopeData Constructor
EnvelopeData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopeData()
Visual C++
public:
EnvelopeData()
JavaScript
NRenoiseTools.EnvelopeData = function();

See Also

EnvelopeData Class


EnvelopeData Methods

[image] [image]

.NET Framework Class Library
EnvelopeData Methods
EnvelopeData Class See Also Send Feedback

The EnvelopeData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopeData Class


EnvelopeData Properties

[image] [image]

.NET Framework Class Library
EnvelopeData Properties
EnvelopeData Class See Also Send Feedback

The EnvelopeData type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

EnvelopeData Class


Length Property

[image]

.NET Framework Class Library
EnvelopeData..::.Length Property
EnvelopeData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

EnvelopeData Class


PlayMode Property

[image]

.NET Framework Class Library
EnvelopeData..::.PlayMode Property
EnvelopeData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As EnvelopeDataPlayMode
C#
public EnvelopeDataPlayMode PlayMode { get; set; }
Visual C++
public:
property EnvelopeDataPlayMode PlayMode {
    EnvelopeDataPlayMode get ();
    void set (EnvelopeDataPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

EnvelopeData Class


Points Property

[image]

.NET Framework Class Library
EnvelopeData..::.Points Property
EnvelopeData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

EnvelopeData Class


ValueQuantum Property

[image]

.NET Framework Class Library
EnvelopeData..::.ValueQuantum Property
EnvelopeData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

EnvelopeData Class


EnvelopeDataPlayMode Enumeration

[image]

.NET Framework Class Library
EnvelopeDataPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopeDataPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopeDataPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopeDataPlayMode
JavaScript
NRenoiseTools.EnvelopeDataPlayMode = function();
NRenoiseTools.EnvelopeDataPlayMode.createEnum('NRenoiseTools.EnvelopeDataPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopeItem Class

[image]

.NET Framework Class Library
EnvelopeItem Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopeItem
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopeItem
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopeItem
JavaScript
NRenoiseTools.EnvelopeItem = function();

Type.createClass(
    'NRenoiseTools.EnvelopeItem');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopeItem

See Also

EnvelopeItem Members


EnvelopeItem Members

[image] [image]

.NET Framework Class Library
EnvelopeItem Members
EnvelopeItem Class Constructors Methods Properties See Also Send Feedback

The EnvelopeItem type exposes the following members.

Constructors

Name | Description
EnvelopeItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceIndex |
Envelope |
ParameterIndex |

See Also

EnvelopeItem Class


EnvelopeItem Constructor

[image]

.NET Framework Class Library
EnvelopeItem Constructor
EnvelopeItem Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopeItem()
Visual C++
public:
EnvelopeItem()
JavaScript
NRenoiseTools.EnvelopeItem = function();

See Also

EnvelopeItem Class


EnvelopeItem Methods

[image] [image]

.NET Framework Class Library
EnvelopeItem Methods
EnvelopeItem Class See Also Send Feedback

The EnvelopeItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopeItem Class


EnvelopeItem Properties

[image] [image]

.NET Framework Class Library
EnvelopeItem Properties
EnvelopeItem Class See Also Send Feedback

The EnvelopeItem type exposes the following members.

Properties

Name | Description
DeviceIndex |
Envelope |
ParameterIndex |

See Also

EnvelopeItem Class


DeviceIndex Property

[image]

.NET Framework Class Library
EnvelopeItem..::.DeviceIndex Property
EnvelopeItem Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceIndex As Integer
C#
public int DeviceIndex { get; set; }
Visual C++
public:
property int DeviceIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_deviceIndex();
function set_deviceIndex(value);

Remarks

See Also

EnvelopeItem Class


Envelope Property

[image]

.NET Framework Class Library
EnvelopeItem..::.Envelope Property
EnvelopeItem Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Envelope As EnvelopeData
C#
public EnvelopeData Envelope { get; set; }
Visual C++
public:
property EnvelopeData^ Envelope {
    EnvelopeData^ get ();
    void set (EnvelopeData^ value);
}
JavaScript
function get_envelope();
function set_envelope(value);

Remarks

See Also

EnvelopeItem Class


ParameterIndex Property

[image]

.NET Framework Class Library
EnvelopeItem..::.ParameterIndex Property
EnvelopeItem Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterIndex As Integer
C#
public int ParameterIndex { get; set; }
Visual C++
public:
property int ParameterIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterIndex();
function set_parameterIndex(value);

Remarks

See Also

EnvelopeItem Class


Envelopes Class

[image]

.NET Framework Class Library
Envelopes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Envelopes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Envelopes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Envelopes
JavaScript
NRenoiseTools.Envelopes = function();

Type.createClass(
    'NRenoiseTools.Envelopes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Envelopes

See Also

Envelopes Members


Envelopes Members

[image] [image]

.NET Framework Class Library
Envelopes Members
Envelopes Class Constructors Methods Properties See Also Send Feedback

The Envelopes type exposes the following members.

Constructors

Name | Description
Envelopes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
FilterType |
Pan |
Pitch |
Resonance |
Volume |

See Also

Envelopes Class


Envelopes Constructor

[image]

.NET Framework Class Library
Envelopes Constructor
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Envelopes()
Visual C++
public:
Envelopes()
JavaScript
NRenoiseTools.Envelopes = function();

See Also

Envelopes Class


Envelopes Methods

[image] [image]

.NET Framework Class Library
Envelopes Methods
Envelopes Class See Also Send Feedback

The Envelopes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Envelopes Class


Envelopes Properties

[image] [image]

.NET Framework Class Library
Envelopes Properties
Envelopes Class See Also Send Feedback

The Envelopes type exposes the following members.

Properties

Name | Description
Cutoff |
FilterType |
Pan |
Pitch |
Resonance |
Volume |

See Also

Envelopes Class


Cutoff Property

[image]

.NET Framework Class Library
Envelopes..::.Cutoff Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As EnvelopesCutoff
C#
public EnvelopesCutoff Cutoff { get; set; }
Visual C++
public:
property EnvelopesCutoff^ Cutoff {
    EnvelopesCutoff^ get ();
    void set (EnvelopesCutoff^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

Envelopes Class


FilterType Property

[image]

.NET Framework Class Library
Envelopes..::.FilterType Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As Integer
C#
public int FilterType { get; set; }
Visual C++
public:
property int FilterType {
    int get ();
    void set (int value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

Envelopes Class


Pan Property

[image]

.NET Framework Class Library
Envelopes..::.Pan Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Pan As EnvelopesPan
C#
public EnvelopesPan Pan { get; set; }
Visual C++
public:
property EnvelopesPan^ Pan {
    EnvelopesPan^ get ();
    void set (EnvelopesPan^ value);
}
JavaScript
function get_pan();
function set_pan(value);

Remarks

See Also

Envelopes Class


Pitch Property

[image]

.NET Framework Class Library
Envelopes..::.Pitch Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Pitch As Pitch
C#
public Pitch Pitch { get; set; }
Visual C++
public:
property Pitch^ Pitch {
    Pitch^ get ();
    void set (Pitch^ value);
}
JavaScript
function get_pitch();
function set_pitch(value);

Remarks

See Also

Envelopes Class


Resonance Property

[image]

.NET Framework Class Library
Envelopes..::.Resonance Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As EnvelopesResonance
C#
public EnvelopesResonance Resonance { get; set; }
Visual C++
public:
property EnvelopesResonance^ Resonance {
    EnvelopesResonance^ get ();
    void set (EnvelopesResonance^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

Envelopes Class


Volume Property

[image]

.NET Framework Class Library
Envelopes..::.Volume Property
Envelopes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As EnvelopesVolume
C#
public EnvelopesVolume Volume { get; set; }
Visual C++
public:
property EnvelopesVolume^ Volume {
    EnvelopesVolume^ get ();
    void set (EnvelopesVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

Envelopes Class


EnvelopesCutoff Class

[image]

.NET Framework Class Library
EnvelopesCutoff Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopesCutoff
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopesCutoff
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopesCutoff
JavaScript
NRenoiseTools.EnvelopesCutoff = function();

Type.createClass(
    'NRenoiseTools.EnvelopesCutoff');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopesCutoff

See Also

EnvelopesCutoff Members


EnvelopesCutoff Members

[image] [image]

.NET Framework Class Library
EnvelopesCutoff Members
EnvelopesCutoff Class Constructors Methods Properties See Also Send Feedback

The EnvelopesCutoff type exposes the following members.

Constructors

Name | Description
EnvelopesCutoff |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoAmp |
Decay |
InterpolationMode |
IsActive |
Lfo |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesCutoff Class


EnvelopesCutoff Constructor

[image]

.NET Framework Class Library
EnvelopesCutoff Constructor
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopesCutoff()
Visual C++
public:
EnvelopesCutoff()
JavaScript
NRenoiseTools.EnvelopesCutoff = function();

See Also

EnvelopesCutoff Class


EnvelopesCutoff Methods

[image] [image]

.NET Framework Class Library
EnvelopesCutoff Methods
EnvelopesCutoff Class See Also Send Feedback

The EnvelopesCutoff type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopesCutoff Class


EnvelopesCutoff Properties

[image] [image]

.NET Framework Class Library
EnvelopesCutoff Properties
EnvelopesCutoff Class See Also Send Feedback

The EnvelopesCutoff type exposes the following members.

Properties

Name | Description
AutoAmp |
Decay |
InterpolationMode |
IsActive |
Lfo |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesCutoff Class


AutoAmp Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.AutoAmp Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoAmp As AutoAmp
C#
public AutoAmp AutoAmp { get; set; }
Visual C++
public:
property AutoAmp^ AutoAmp {
    AutoAmp^ get ();
    void set (AutoAmp^ value);
}
JavaScript
function get_autoAmp();
function set_autoAmp(value);

Remarks

See Also

EnvelopesCutoff Class


Decay Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.Decay Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Decay As Integer
C#
public int Decay { get; set; }
Visual C++
public:
property int Decay {
    int get ();
    void set (int value);
}
JavaScript
function get_decay();
function set_decay(value);

Remarks

See Also

EnvelopesCutoff Class


InterpolationMode Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.InterpolationMode Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As EnvelopesCutoffInterpolationMode
C#
public EnvelopesCutoffInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property EnvelopesCutoffInterpolationMode InterpolationMode {
    EnvelopesCutoffInterpolationMode get ();
    void set (EnvelopesCutoffInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

EnvelopesCutoff Class


IsActive Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.IsActive Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

EnvelopesCutoff Class


Lfo Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.Lfo Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo As Lfo
C#
public Lfo Lfo { get; set; }
Visual C++
public:
property Lfo^ Lfo {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo();
function set_lfo(value);

Remarks

See Also

EnvelopesCutoff Class


LoopEnd Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.LoopEnd Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As Integer
C#
public int LoopEnd { get; set; }
Visual C++
public:
property int LoopEnd {
    int get ();
    void set (int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

EnvelopesCutoff Class


LoopMode Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.LoopMode Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As EnvelopesCutoffLoopMode
C#
public EnvelopesCutoffLoopMode LoopMode { get; set; }
Visual C++
public:
property EnvelopesCutoffLoopMode LoopMode {
    EnvelopesCutoffLoopMode get ();
    void set (EnvelopesCutoffLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

EnvelopesCutoff Class


LoopStart Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.LoopStart Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

EnvelopesCutoff Class


Nodes Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.Nodes Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Nodes As CutoffNodes
C#
public CutoffNodes Nodes { get; set; }
Visual C++
public:
property CutoffNodes^ Nodes {
    CutoffNodes^ get ();
    void set (CutoffNodes^ value);
}
JavaScript
function get_nodes();
function set_nodes(value);

Remarks

See Also

EnvelopesCutoff Class


SustainIsActive Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.SustainIsActive Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainIsActive As Boolean
C#
public bool SustainIsActive { get; set; }
Visual C++
public:
property bool SustainIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sustainIsActive();
function set_sustainIsActive(value);

Remarks

See Also

EnvelopesCutoff Class


SustainPos Property

[image]

.NET Framework Class Library
EnvelopesCutoff..::.SustainPos Property
EnvelopesCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainPos As Integer
C#
public int SustainPos { get; set; }
Visual C++
public:
property int SustainPos {
    int get ();
    void set (int value);
}
JavaScript
function get_sustainPos();
function set_sustainPos(value);

Remarks

See Also

EnvelopesCutoff Class


EnvelopesCutoffInterpolationMode Enumeration

[image]

.NET Framework Class Library
EnvelopesCutoffInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesCutoffInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesCutoffInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesCutoffInterpolationMode
JavaScript
NRenoiseTools.EnvelopesCutoffInterpolationMode = function();
NRenoiseTools.EnvelopesCutoffInterpolationMode.createEnum('NRenoiseTools.EnvelopesCutoffInterpolationMode', false);

Members

Member name | Description
Linear |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesCutoffLoopMode Enumeration

[image]

.NET Framework Class Library
EnvelopesCutoffLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesCutoffLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesCutoffLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesCutoffLoopMode
JavaScript
NRenoiseTools.EnvelopesCutoffLoopMode = function();
NRenoiseTools.EnvelopesCutoffLoopMode.createEnum('NRenoiseTools.EnvelopesCutoffLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesPan Class

[image]

.NET Framework Class Library
EnvelopesPan Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopesPan
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopesPan
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopesPan
JavaScript
NRenoiseTools.EnvelopesPan = function();

Type.createClass(
    'NRenoiseTools.EnvelopesPan');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopesPan

See Also

EnvelopesPan Members


EnvelopesPan Members

[image] [image]

.NET Framework Class Library
EnvelopesPan Members
EnvelopesPan Class Constructors Methods Properties See Also Send Feedback

The EnvelopesPan type exposes the following members.

Constructors

Name | Description
EnvelopesPan |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesPan Class


EnvelopesPan Constructor

[image]

.NET Framework Class Library
EnvelopesPan Constructor
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopesPan()
Visual C++
public:
EnvelopesPan()
JavaScript
NRenoiseTools.EnvelopesPan = function();

See Also

EnvelopesPan Class


EnvelopesPan Methods

[image] [image]

.NET Framework Class Library
EnvelopesPan Methods
EnvelopesPan Class See Also Send Feedback

The EnvelopesPan type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopesPan Class


EnvelopesPan Properties

[image] [image]

.NET Framework Class Library
EnvelopesPan Properties
EnvelopesPan Class See Also Send Feedback

The EnvelopesPan type exposes the following members.

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesPan Class


Decay Property

[image]

.NET Framework Class Library
EnvelopesPan..::.Decay Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Decay As Integer
C#
public int Decay { get; set; }
Visual C++
public:
property int Decay {
    int get ();
    void set (int value);
}
JavaScript
function get_decay();
function set_decay(value);

Remarks

See Also

EnvelopesPan Class


InterpolationMode Property

[image]

.NET Framework Class Library
EnvelopesPan..::.InterpolationMode Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As EnvelopesPanInterpolationMode
C#
public EnvelopesPanInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property EnvelopesPanInterpolationMode InterpolationMode {
    EnvelopesPanInterpolationMode get ();
    void set (EnvelopesPanInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

EnvelopesPan Class


IsActive Property

[image]

.NET Framework Class Library
EnvelopesPan..::.IsActive Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

EnvelopesPan Class


Lfo1 Property

[image]

.NET Framework Class Library
EnvelopesPan..::.Lfo1 Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo1 As Lfo
C#
public Lfo Lfo1 { get; set; }
Visual C++
public:
property Lfo^ Lfo1 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo1();
function set_lfo1(value);

Remarks

See Also

EnvelopesPan Class


Lfo2 Property

[image]

.NET Framework Class Library
EnvelopesPan..::.Lfo2 Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo2 As Lfo
C#
public Lfo Lfo2 { get; set; }
Visual C++
public:
property Lfo^ Lfo2 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo2();
function set_lfo2(value);

Remarks

See Also

EnvelopesPan Class


LoopEnd Property

[image]

.NET Framework Class Library
EnvelopesPan..::.LoopEnd Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As Integer
C#
public int LoopEnd { get; set; }
Visual C++
public:
property int LoopEnd {
    int get ();
    void set (int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

EnvelopesPan Class


LoopMode Property

[image]

.NET Framework Class Library
EnvelopesPan..::.LoopMode Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As EnvelopesPanLoopMode
C#
public EnvelopesPanLoopMode LoopMode { get; set; }
Visual C++
public:
property EnvelopesPanLoopMode LoopMode {
    EnvelopesPanLoopMode get ();
    void set (EnvelopesPanLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

EnvelopesPan Class


LoopStart Property

[image]

.NET Framework Class Library
EnvelopesPan..::.LoopStart Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

EnvelopesPan Class


Nodes Property

[image]

.NET Framework Class Library
EnvelopesPan..::.Nodes Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Nodes As PanNodes
C#
public PanNodes Nodes { get; set; }
Visual C++
public:
property PanNodes^ Nodes {
    PanNodes^ get ();
    void set (PanNodes^ value);
}
JavaScript
function get_nodes();
function set_nodes(value);

Remarks

See Also

EnvelopesPan Class


SustainIsActive Property

[image]

.NET Framework Class Library
EnvelopesPan..::.SustainIsActive Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainIsActive As Boolean
C#
public bool SustainIsActive { get; set; }
Visual C++
public:
property bool SustainIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sustainIsActive();
function set_sustainIsActive(value);

Remarks

See Also

EnvelopesPan Class


SustainPos Property

[image]

.NET Framework Class Library
EnvelopesPan..::.SustainPos Property
EnvelopesPan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainPos As Integer
C#
public int SustainPos { get; set; }
Visual C++
public:
property int SustainPos {
    int get ();
    void set (int value);
}
JavaScript
function get_sustainPos();
function set_sustainPos(value);

Remarks

See Also

EnvelopesPan Class


EnvelopesPanInterpolationMode Enumeration

[image]

.NET Framework Class Library
EnvelopesPanInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesPanInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesPanInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesPanInterpolationMode
JavaScript
NRenoiseTools.EnvelopesPanInterpolationMode = function();
NRenoiseTools.EnvelopesPanInterpolationMode.createEnum('NRenoiseTools.EnvelopesPanInterpolationMode', false);

Members

Member name | Description
Linear |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesPanLoopMode Enumeration

[image]

.NET Framework Class Library
EnvelopesPanLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesPanLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesPanLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesPanLoopMode
JavaScript
NRenoiseTools.EnvelopesPanLoopMode = function();
NRenoiseTools.EnvelopesPanLoopMode.createEnum('NRenoiseTools.EnvelopesPanLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesResonance Class

[image]

.NET Framework Class Library
EnvelopesResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopesResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopesResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopesResonance
JavaScript
NRenoiseTools.EnvelopesResonance = function();

Type.createClass(
    'NRenoiseTools.EnvelopesResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopesResonance

See Also

EnvelopesResonance Members


EnvelopesResonance Members

[image] [image]

.NET Framework Class Library
EnvelopesResonance Members
EnvelopesResonance Class Constructors Methods Properties See Also Send Feedback

The EnvelopesResonance type exposes the following members.

Constructors

Name | Description
EnvelopesResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoAmp |
Decay |
InterpolationMode |
IsActive |
Lfo |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesResonance Class


EnvelopesResonance Constructor

[image]

.NET Framework Class Library
EnvelopesResonance Constructor
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopesResonance()
Visual C++
public:
EnvelopesResonance()
JavaScript
NRenoiseTools.EnvelopesResonance = function();

See Also

EnvelopesResonance Class


EnvelopesResonance Methods

[image] [image]

.NET Framework Class Library
EnvelopesResonance Methods
EnvelopesResonance Class See Also Send Feedback

The EnvelopesResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopesResonance Class


EnvelopesResonance Properties

[image] [image]

.NET Framework Class Library
EnvelopesResonance Properties
EnvelopesResonance Class See Also Send Feedback

The EnvelopesResonance type exposes the following members.

Properties

Name | Description
AutoAmp |
Decay |
InterpolationMode |
IsActive |
Lfo |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesResonance Class


AutoAmp Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.AutoAmp Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoAmp As AutoAmp
C#
public AutoAmp AutoAmp { get; set; }
Visual C++
public:
property AutoAmp^ AutoAmp {
    AutoAmp^ get ();
    void set (AutoAmp^ value);
}
JavaScript
function get_autoAmp();
function set_autoAmp(value);

Remarks

See Also

EnvelopesResonance Class


Decay Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.Decay Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Decay As Integer
C#
public int Decay { get; set; }
Visual C++
public:
property int Decay {
    int get ();
    void set (int value);
}
JavaScript
function get_decay();
function set_decay(value);

Remarks

See Also

EnvelopesResonance Class


InterpolationMode Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.InterpolationMode Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As EnvelopesResonanceInterpolationMode
C#
public EnvelopesResonanceInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property EnvelopesResonanceInterpolationMode InterpolationMode {
    EnvelopesResonanceInterpolationMode get ();
    void set (EnvelopesResonanceInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

EnvelopesResonance Class


IsActive Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.IsActive Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

EnvelopesResonance Class


Lfo Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.Lfo Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo As Lfo
C#
public Lfo Lfo { get; set; }
Visual C++
public:
property Lfo^ Lfo {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo();
function set_lfo(value);

Remarks

See Also

EnvelopesResonance Class


LoopEnd Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.LoopEnd Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As Integer
C#
public int LoopEnd { get; set; }
Visual C++
public:
property int LoopEnd {
    int get ();
    void set (int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

EnvelopesResonance Class


LoopMode Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.LoopMode Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As EnvelopesResonanceLoopMode
C#
public EnvelopesResonanceLoopMode LoopMode { get; set; }
Visual C++
public:
property EnvelopesResonanceLoopMode LoopMode {
    EnvelopesResonanceLoopMode get ();
    void set (EnvelopesResonanceLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

EnvelopesResonance Class


LoopStart Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.LoopStart Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

EnvelopesResonance Class


Nodes Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.Nodes Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Nodes As ResonanceNodes
C#
public ResonanceNodes Nodes { get; set; }
Visual C++
public:
property ResonanceNodes^ Nodes {
    ResonanceNodes^ get ();
    void set (ResonanceNodes^ value);
}
JavaScript
function get_nodes();
function set_nodes(value);

Remarks

See Also

EnvelopesResonance Class


SustainIsActive Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.SustainIsActive Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainIsActive As Boolean
C#
public bool SustainIsActive { get; set; }
Visual C++
public:
property bool SustainIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sustainIsActive();
function set_sustainIsActive(value);

Remarks

See Also

EnvelopesResonance Class


SustainPos Property

[image]

.NET Framework Class Library
EnvelopesResonance..::.SustainPos Property
EnvelopesResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainPos As Integer
C#
public int SustainPos { get; set; }
Visual C++
public:
property int SustainPos {
    int get ();
    void set (int value);
}
JavaScript
function get_sustainPos();
function set_sustainPos(value);

Remarks

See Also

EnvelopesResonance Class


EnvelopesResonanceInterpolationMode Enumeration

[image]

.NET Framework Class Library
EnvelopesResonanceInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesResonanceInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesResonanceInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesResonanceInterpolationMode
JavaScript
NRenoiseTools.EnvelopesResonanceInterpolationMode = function();
NRenoiseTools.EnvelopesResonanceInterpolationMode.createEnum('NRenoiseTools.EnvelopesResonanceInterpolationMode', false);

Members

Member name | Description
Linear |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesResonanceLoopMode Enumeration

[image]

.NET Framework Class Library
EnvelopesResonanceLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesResonanceLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesResonanceLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesResonanceLoopMode
JavaScript
NRenoiseTools.EnvelopesResonanceLoopMode = function();
NRenoiseTools.EnvelopesResonanceLoopMode.createEnum('NRenoiseTools.EnvelopesResonanceLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesVolume Class

[image]

.NET Framework Class Library
EnvelopesVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class EnvelopesVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class EnvelopesVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class EnvelopesVolume
JavaScript
NRenoiseTools.EnvelopesVolume = function();

Type.createClass(
    'NRenoiseTools.EnvelopesVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.EnvelopesVolume

See Also

EnvelopesVolume Members


EnvelopesVolume Members

[image] [image]

.NET Framework Class Library
EnvelopesVolume Members
EnvelopesVolume Class Constructors Methods Properties See Also Send Feedback

The EnvelopesVolume type exposes the following members.

Constructors

Name | Description
EnvelopesVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesVolume Class


EnvelopesVolume Constructor

[image]

.NET Framework Class Library
EnvelopesVolume Constructor
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EnvelopesVolume()
Visual C++
public:
EnvelopesVolume()
JavaScript
NRenoiseTools.EnvelopesVolume = function();

See Also

EnvelopesVolume Class


EnvelopesVolume Methods

[image] [image]

.NET Framework Class Library
EnvelopesVolume Methods
EnvelopesVolume Class See Also Send Feedback

The EnvelopesVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnvelopesVolume Class


EnvelopesVolume Properties

[image] [image]

.NET Framework Class Library
EnvelopesVolume Properties
EnvelopesVolume Class See Also Send Feedback

The EnvelopesVolume type exposes the following members.

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

EnvelopesVolume Class


Decay Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.Decay Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Decay As Integer
C#
public int Decay { get; set; }
Visual C++
public:
property int Decay {
    int get ();
    void set (int value);
}
JavaScript
function get_decay();
function set_decay(value);

Remarks

See Also

EnvelopesVolume Class


InterpolationMode Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.InterpolationMode Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As EnvelopesVolumeInterpolationMode
C#
public EnvelopesVolumeInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property EnvelopesVolumeInterpolationMode InterpolationMode {
    EnvelopesVolumeInterpolationMode get ();
    void set (EnvelopesVolumeInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

EnvelopesVolume Class


IsActive Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.IsActive Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

EnvelopesVolume Class


Lfo1 Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.Lfo1 Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo1 As Lfo
C#
public Lfo Lfo1 { get; set; }
Visual C++
public:
property Lfo^ Lfo1 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo1();
function set_lfo1(value);

Remarks

See Also

EnvelopesVolume Class


Lfo2 Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.Lfo2 Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo2 As Lfo
C#
public Lfo Lfo2 { get; set; }
Visual C++
public:
property Lfo^ Lfo2 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo2();
function set_lfo2(value);

Remarks

See Also

EnvelopesVolume Class


LoopEnd Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.LoopEnd Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As Integer
C#
public int LoopEnd { get; set; }
Visual C++
public:
property int LoopEnd {
    int get ();
    void set (int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

EnvelopesVolume Class


LoopMode Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.LoopMode Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As EnvelopesVolumeLoopMode
C#
public EnvelopesVolumeLoopMode LoopMode { get; set; }
Visual C++
public:
property EnvelopesVolumeLoopMode LoopMode {
    EnvelopesVolumeLoopMode get ();
    void set (EnvelopesVolumeLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

EnvelopesVolume Class


LoopStart Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.LoopStart Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

EnvelopesVolume Class


Nodes Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.Nodes Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Nodes As VolumeNodes
C#
public VolumeNodes Nodes { get; set; }
Visual C++
public:
property VolumeNodes^ Nodes {
    VolumeNodes^ get ();
    void set (VolumeNodes^ value);
}
JavaScript
function get_nodes();
function set_nodes(value);

Remarks

See Also

EnvelopesVolume Class


SustainIsActive Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.SustainIsActive Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainIsActive As Boolean
C#
public bool SustainIsActive { get; set; }
Visual C++
public:
property bool SustainIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sustainIsActive();
function set_sustainIsActive(value);

Remarks

See Also

EnvelopesVolume Class


SustainPos Property

[image]

.NET Framework Class Library
EnvelopesVolume..::.SustainPos Property
EnvelopesVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainPos As Integer
C#
public int SustainPos { get; set; }
Visual C++
public:
property int SustainPos {
    int get ();
    void set (int value);
}
JavaScript
function get_sustainPos();
function set_sustainPos(value);

Remarks

See Also

EnvelopesVolume Class


EnvelopesVolumeInterpolationMode Enumeration

[image]

.NET Framework Class Library
EnvelopesVolumeInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesVolumeInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesVolumeInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesVolumeInterpolationMode
JavaScript
NRenoiseTools.EnvelopesVolumeInterpolationMode = function();
NRenoiseTools.EnvelopesVolumeInterpolationMode.createEnum('NRenoiseTools.EnvelopesVolumeInterpolationMode', false);

Members

Member name | Description
Linear |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


EnvelopesVolumeLoopMode Enumeration

[image]

.NET Framework Class Library
EnvelopesVolumeLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration EnvelopesVolumeLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum EnvelopesVolumeLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class EnvelopesVolumeLoopMode
JavaScript
NRenoiseTools.EnvelopesVolumeLoopMode = function();
NRenoiseTools.EnvelopesVolumeLoopMode.createEnum('NRenoiseTools.EnvelopesVolumeLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq10DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq10DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq10DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq10DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Eq10DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq10DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq10DeviceDeviceSlotRunTimePreset

See Also

Eq10DeviceDeviceSlotRunTimePreset Members


Eq10DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset Members
Eq10DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq10DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq10DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
BandWidth5 |
BandWidth6 |
BandWidth7 |
BandWidth8 |
BandWidth9 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Frequency5 |
Frequency6 |
Frequency7 |
Frequency8 |
Frequency9 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
Gain5 |
Gain6 |
Gain7 |
Gain8 |
Gain9 |
InputMode |
MaxVisualizedGain |
type |

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Eq10DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset Constructor
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq10DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Eq10DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Eq10DeviceDeviceSlotRunTimePreset = function();

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Eq10DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset Methods
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Eq10DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Eq10DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset Properties
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Eq10DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
BandWidth5 |
BandWidth6 |
BandWidth7 |
BandWidth8 |
BandWidth9 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Frequency5 |
Frequency6 |
Frequency7 |
Frequency8 |
Frequency9 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
Gain5 |
Gain6 |
Gain7 |
Gain8 |
Gain9 |
InputMode |
MaxVisualizedGain |
type |

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth0 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth0 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth0 As Single
C#
public float BandWidth0 { get; set; }
Visual C++
public:
property float BandWidth0 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth0();
function set_bandWidth0(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth1 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth1 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth1 As Single
C#
public float BandWidth1 { get; set; }
Visual C++
public:
property float BandWidth1 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth1();
function set_bandWidth1(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth2 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth2 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth2 As Single
C#
public float BandWidth2 { get; set; }
Visual C++
public:
property float BandWidth2 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth2();
function set_bandWidth2(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth3 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth3 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth3 As Single
C#
public float BandWidth3 { get; set; }
Visual C++
public:
property float BandWidth3 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth3();
function set_bandWidth3(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth4 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth4 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth4 As Single
C#
public float BandWidth4 { get; set; }
Visual C++
public:
property float BandWidth4 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth4();
function set_bandWidth4(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth5 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth5 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth5 As Single
C#
public float BandWidth5 { get; set; }
Visual C++
public:
property float BandWidth5 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth5();
function set_bandWidth5(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth6 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth6 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth6 As Single
C#
public float BandWidth6 { get; set; }
Visual C++
public:
property float BandWidth6 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth6();
function set_bandWidth6(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth7 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth7 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth7 As Single
C#
public float BandWidth7 { get; set; }
Visual C++
public:
property float BandWidth7 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth7();
function set_bandWidth7(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth8 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth8 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth8 As Single
C#
public float BandWidth8 { get; set; }
Visual C++
public:
property float BandWidth8 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth8();
function set_bandWidth8(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


BandWidth9 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.BandWidth9 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth9 As Single
C#
public float BandWidth9 { get; set; }
Visual C++
public:
property float BandWidth9 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth9();
function set_bandWidth9(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency0 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency0 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency0 As Single
C#
public float Frequency0 { get; set; }
Visual C++
public:
property float Frequency0 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency0();
function set_frequency0(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency1 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency1 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency1 As Single
C#
public float Frequency1 { get; set; }
Visual C++
public:
property float Frequency1 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency1();
function set_frequency1(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency2 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency2 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency2 As Single
C#
public float Frequency2 { get; set; }
Visual C++
public:
property float Frequency2 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency2();
function set_frequency2(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency3 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency3 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency3 As Single
C#
public float Frequency3 { get; set; }
Visual C++
public:
property float Frequency3 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency3();
function set_frequency3(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency4 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency4 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency4 As Single
C#
public float Frequency4 { get; set; }
Visual C++
public:
property float Frequency4 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency4();
function set_frequency4(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency5 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency5 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency5 As Single
C#
public float Frequency5 { get; set; }
Visual C++
public:
property float Frequency5 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency5();
function set_frequency5(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency6 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency6 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency6 As Single
C#
public float Frequency6 { get; set; }
Visual C++
public:
property float Frequency6 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency6();
function set_frequency6(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency7 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency7 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency7 As Single
C#
public float Frequency7 { get; set; }
Visual C++
public:
property float Frequency7 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency7();
function set_frequency7(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency8 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency8 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency8 As Single
C#
public float Frequency8 { get; set; }
Visual C++
public:
property float Frequency8 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency8();
function set_frequency8(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Frequency9 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Frequency9 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency9 As Single
C#
public float Frequency9 { get; set; }
Visual C++
public:
property float Frequency9 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency9();
function set_frequency9(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain0 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain0 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain0 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain0 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain0 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain0();
function set_gain0(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain1 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain1 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain1 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain1 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain1 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain1();
function set_gain1(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain2 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain2 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain2 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain2 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain2 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain2();
function set_gain2(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain3 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain3 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain3 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain3 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain3 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain3();
function set_gain3(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain4 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain4 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain4 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain4 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain4 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain4();
function set_gain4(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain5 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain5 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain5 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain5 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain5 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain5();
function set_gain5(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain6 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain6 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain6 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain6 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain6 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain6();
function set_gain6(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain7 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain7 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain7 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain7 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain7 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain7();
function set_gain7(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain8 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain8 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain8 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain8 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain8 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain8();
function set_gain8(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Gain9 Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.Gain9 Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain9 As Eq10DeviceGainRunTimePreset
C#
public Eq10DeviceGainRunTimePreset Gain9 { get; set; }
Visual C++
public:
property Eq10DeviceGainRunTimePreset^ Gain9 {
    Eq10DeviceGainRunTimePreset^ get ();
    void set (Eq10DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain9();
function set_gain9(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


InputMode Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.InputMode Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As Eq10DeviceDeviceSlotRunTimePresetInputMode
C#
public Eq10DeviceDeviceSlotRunTimePresetInputMode InputMode { get; set; }
Visual C++
public:
property Eq10DeviceDeviceSlotRunTimePresetInputMode InputMode {
    Eq10DeviceDeviceSlotRunTimePresetInputMode get ();
    void set (Eq10DeviceDeviceSlotRunTimePresetInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.MaxVisualizedGain Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePreset..::.type Property
Eq10DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq10DeviceDeviceSlotRunTimePreset Class


Eq10DeviceDeviceSlotRunTimePresetInputMode Enumeration

[image]

.NET Framework Class Library
Eq10DeviceDeviceSlotRunTimePresetInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq10DeviceDeviceSlotRunTimePresetInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq10DeviceDeviceSlotRunTimePresetInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq10DeviceDeviceSlotRunTimePresetInputMode
JavaScript
NRenoiseTools.Eq10DeviceDeviceSlotRunTimePresetInputMode = function();
NRenoiseTools.Eq10DeviceDeviceSlotRunTimePresetInputMode.createEnum('NRenoiseTools.Eq10DeviceDeviceSlotRunTimePresetInputMode', false);

Members

Member name | Description
L |
R |
LR |
LR1 |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq10DeviceEqDevice Class

[image]

.NET Framework Class Library
Eq10DeviceEqDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq10DeviceEqDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq10DeviceEqDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq10DeviceEqDevice
JavaScript
NRenoiseTools.Eq10DeviceEqDevice = function();

Type.createClass(
    'NRenoiseTools.Eq10DeviceEqDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq10DeviceEqDevice

See Also

Eq10DeviceEqDevice Members


Eq10DeviceEqDevice Members

[image] [image]

.NET Framework Class Library
Eq10DeviceEqDevice Members
Eq10DeviceEqDevice Class Constructors Methods Properties See Also Send Feedback

The Eq10DeviceEqDevice type exposes the following members.

Constructors

Name | Description
Eq10DeviceEqDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
BandWidth5 |
BandWidth6 |
BandWidth7 |
BandWidth8 |
BandWidth9 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Frequency5 |
Frequency6 |
Frequency7 |
Frequency8 |
Frequency9 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
Gain5 |
Gain6 |
Gain7 |
Gain8 |
Gain9 |
InputMode |
IsActive |
IsSelected |
MaxVisualizedGain |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

Eq10DeviceEqDevice Class


Eq10DeviceEqDevice Constructor

[image]

.NET Framework Class Library
Eq10DeviceEqDevice Constructor
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq10DeviceEqDevice()
Visual C++
public:
Eq10DeviceEqDevice()
JavaScript
NRenoiseTools.Eq10DeviceEqDevice = function();

See Also

Eq10DeviceEqDevice Class


Eq10DeviceEqDevice Methods

[image] [image]

.NET Framework Class Library
Eq10DeviceEqDevice Methods
Eq10DeviceEqDevice Class See Also Send Feedback

The Eq10DeviceEqDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq10DeviceEqDevice Class


Eq10DeviceEqDevice Properties

[image] [image]

.NET Framework Class Library
Eq10DeviceEqDevice Properties
Eq10DeviceEqDevice Class See Also Send Feedback

The Eq10DeviceEqDevice type exposes the following members.

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
BandWidth5 |
BandWidth6 |
BandWidth7 |
BandWidth8 |
BandWidth9 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Frequency5 |
Frequency6 |
Frequency7 |
Frequency8 |
Frequency9 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
Gain5 |
Gain6 |
Gain7 |
Gain8 |
Gain9 |
InputMode |
IsActive |
IsSelected |
MaxVisualizedGain |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

Eq10DeviceEqDevice Class


BandWidth0 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth0 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth0 As Single
C#
public float BandWidth0 { get; set; }
Visual C++
public:
property float BandWidth0 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth0();
function set_bandWidth0(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth1 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth1 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth1 As Single
C#
public float BandWidth1 { get; set; }
Visual C++
public:
property float BandWidth1 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth1();
function set_bandWidth1(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth2 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth2 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth2 As Single
C#
public float BandWidth2 { get; set; }
Visual C++
public:
property float BandWidth2 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth2();
function set_bandWidth2(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth3 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth3 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth3 As Single
C#
public float BandWidth3 { get; set; }
Visual C++
public:
property float BandWidth3 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth3();
function set_bandWidth3(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth4 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth4 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth4 As Single
C#
public float BandWidth4 { get; set; }
Visual C++
public:
property float BandWidth4 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth4();
function set_bandWidth4(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth5 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth5 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth5 As Single
C#
public float BandWidth5 { get; set; }
Visual C++
public:
property float BandWidth5 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth5();
function set_bandWidth5(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth6 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth6 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth6 As Single
C#
public float BandWidth6 { get; set; }
Visual C++
public:
property float BandWidth6 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth6();
function set_bandWidth6(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth7 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth7 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth7 As Single
C#
public float BandWidth7 { get; set; }
Visual C++
public:
property float BandWidth7 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth7();
function set_bandWidth7(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth8 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth8 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth8 As Single
C#
public float BandWidth8 { get; set; }
Visual C++
public:
property float BandWidth8 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth8();
function set_bandWidth8(value);

Remarks

See Also

Eq10DeviceEqDevice Class


BandWidth9 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.BandWidth9 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth9 As Single
C#
public float BandWidth9 { get; set; }
Visual C++
public:
property float BandWidth9 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth9();
function set_bandWidth9(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency0 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency0 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency0 As Single
C#
public float Frequency0 { get; set; }
Visual C++
public:
property float Frequency0 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency0();
function set_frequency0(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency1 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency1 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency1 As Single
C#
public float Frequency1 { get; set; }
Visual C++
public:
property float Frequency1 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency1();
function set_frequency1(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency2 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency2 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency2 As Single
C#
public float Frequency2 { get; set; }
Visual C++
public:
property float Frequency2 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency2();
function set_frequency2(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency3 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency3 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency3 As Single
C#
public float Frequency3 { get; set; }
Visual C++
public:
property float Frequency3 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency3();
function set_frequency3(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency4 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency4 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency4 As Single
C#
public float Frequency4 { get; set; }
Visual C++
public:
property float Frequency4 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency4();
function set_frequency4(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency5 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency5 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency5 As Single
C#
public float Frequency5 { get; set; }
Visual C++
public:
property float Frequency5 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency5();
function set_frequency5(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency6 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency6 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency6 As Single
C#
public float Frequency6 { get; set; }
Visual C++
public:
property float Frequency6 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency6();
function set_frequency6(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency7 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency7 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency7 As Single
C#
public float Frequency7 { get; set; }
Visual C++
public:
property float Frequency7 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency7();
function set_frequency7(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency8 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency8 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency8 As Single
C#
public float Frequency8 { get; set; }
Visual C++
public:
property float Frequency8 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency8();
function set_frequency8(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Frequency9 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Frequency9 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency9 As Single
C#
public float Frequency9 { get; set; }
Visual C++
public:
property float Frequency9 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency9();
function set_frequency9(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain0 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain0 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain0 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain0 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain0 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain0();
function set_gain0(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain1 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain1 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain1 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain1 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain1 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain1();
function set_gain1(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain2 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain2 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain2 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain2 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain2 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain2();
function set_gain2(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain3 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain3 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain3 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain3 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain3 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain3();
function set_gain3(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain4 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain4 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain4 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain4 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain4 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain4();
function set_gain4(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain5 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain5 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain5 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain5 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain5 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain5();
function set_gain5(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain6 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain6 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain6 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain6 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain6 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain6();
function set_gain6(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain7 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain7 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain7 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain7 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain7 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain7();
function set_gain7(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain8 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain8 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain8 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain8 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain8 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain8();
function set_gain8(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Gain9 Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.Gain9 Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain9 As Eq10DeviceGain
C#
public Eq10DeviceGain Gain9 { get; set; }
Visual C++
public:
property Eq10DeviceGain^ Gain9 {
    Eq10DeviceGain^ get ();
    void set (Eq10DeviceGain^ value);
}
JavaScript
function get_gain9();
function set_gain9(value);

Remarks

See Also

Eq10DeviceEqDevice Class


InputMode Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.InputMode Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As Eq10DeviceEqDeviceInputMode
C#
public Eq10DeviceEqDeviceInputMode InputMode { get; set; }
Visual C++
public:
property Eq10DeviceEqDeviceInputMode InputMode {
    Eq10DeviceEqDeviceInputMode get ();
    void set (Eq10DeviceEqDeviceInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

Eq10DeviceEqDevice Class


IsActive Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.IsActive Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Eq10DeviceEqDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.IsSelected Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Eq10DeviceEqDevice Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.MaxVisualizedGain Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

Eq10DeviceEqDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.RunTimePresetA Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Eq10DeviceRunTimePreset
C#
public Eq10DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Eq10DeviceRunTimePreset^ RunTimePresetA {
    Eq10DeviceRunTimePreset^ get ();
    void set (Eq10DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Eq10DeviceEqDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.RunTimePresetB Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Eq10DeviceRunTimePreset
C#
public Eq10DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Eq10DeviceRunTimePreset^ RunTimePresetB {
    Eq10DeviceRunTimePreset^ get ();
    void set (Eq10DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Eq10DeviceEqDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.SelectedPresetIsModified Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Eq10DeviceEqDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.SelectedPresetName Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Eq10DeviceEqDevice Class


type Property

[image]

.NET Framework Class Library
Eq10DeviceEqDevice..::.type Property
Eq10DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq10DeviceEqDevice Class


Eq10DeviceEqDeviceInputMode Enumeration

[image]

.NET Framework Class Library
Eq10DeviceEqDeviceInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq10DeviceEqDeviceInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq10DeviceEqDeviceInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq10DeviceEqDeviceInputMode
JavaScript
NRenoiseTools.Eq10DeviceEqDeviceInputMode = function();
NRenoiseTools.Eq10DeviceEqDeviceInputMode.createEnum('NRenoiseTools.Eq10DeviceEqDeviceInputMode', false);

Members

Member name | Description
L |
R |
LR |
LR1 |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq10DeviceGain Class

[image]

.NET Framework Class Library
Eq10DeviceGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq10DeviceGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq10DeviceGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq10DeviceGain
JavaScript
NRenoiseTools.Eq10DeviceGain = function();

Type.createClass(
    'NRenoiseTools.Eq10DeviceGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq10DeviceGain

See Also

Eq10DeviceGain Members


Eq10DeviceGain Members

[image] [image]

.NET Framework Class Library
Eq10DeviceGain Members
Eq10DeviceGain Class Constructors Methods Properties See Also Send Feedback

The Eq10DeviceGain type exposes the following members.

Constructors

Name | Description
Eq10DeviceGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Eq10DeviceGain Class


Eq10DeviceGain Constructor

[image]

.NET Framework Class Library
Eq10DeviceGain Constructor
Eq10DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq10DeviceGain()
Visual C++
public:
Eq10DeviceGain()
JavaScript
NRenoiseTools.Eq10DeviceGain = function();

See Also

Eq10DeviceGain Class


Eq10DeviceGain Methods

[image] [image]

.NET Framework Class Library
Eq10DeviceGain Methods
Eq10DeviceGain Class See Also Send Feedback

The Eq10DeviceGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq10DeviceGain Class


Eq10DeviceGain Properties

[image] [image]

.NET Framework Class Library
Eq10DeviceGain Properties
Eq10DeviceGain Class See Also Send Feedback

The Eq10DeviceGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Eq10DeviceGain Class


MidiMappings Property

[image]

.NET Framework Class Library
Eq10DeviceGain..::.MidiMappings Property
Eq10DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Eq10DeviceGain Class


Value Property

[image]

.NET Framework Class Library
Eq10DeviceGain..::.Value Property
Eq10DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Eq10DeviceGain Class


Visualization Property

[image]

.NET Framework Class Library
Eq10DeviceGain..::.Visualization Property
Eq10DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Eq10DeviceGainVisualization
C#
public Eq10DeviceGainVisualization Visualization { get; set; }
Visual C++
public:
property Eq10DeviceGainVisualization Visualization {
    Eq10DeviceGainVisualization get ();
    void set (Eq10DeviceGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Eq10DeviceGain Class


Eq10DeviceGainRunTimePreset Class

[image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq10DeviceGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq10DeviceGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq10DeviceGainRunTimePreset
JavaScript
NRenoiseTools.Eq10DeviceGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq10DeviceGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq10DeviceGainRunTimePreset

See Also

Eq10DeviceGainRunTimePreset Members


Eq10DeviceGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset Members
Eq10DeviceGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq10DeviceGainRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq10DeviceGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Eq10DeviceGainRunTimePreset Class


Eq10DeviceGainRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset Constructor
Eq10DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq10DeviceGainRunTimePreset()
Visual C++
public:
Eq10DeviceGainRunTimePreset()
JavaScript
NRenoiseTools.Eq10DeviceGainRunTimePreset = function();

See Also

Eq10DeviceGainRunTimePreset Class


Eq10DeviceGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset Methods
Eq10DeviceGainRunTimePreset Class See Also Send Feedback

The Eq10DeviceGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq10DeviceGainRunTimePreset Class


Eq10DeviceGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset Properties
Eq10DeviceGainRunTimePreset Class See Also Send Feedback

The Eq10DeviceGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Eq10DeviceGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Eq10DeviceGainRunTimePreset..::.Value Property
Eq10DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Eq10DeviceGainRunTimePreset Class


Eq10DeviceGainVisualization Enumeration

[image]

.NET Framework Class Library
Eq10DeviceGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq10DeviceGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq10DeviceGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq10DeviceGainVisualization
JavaScript
NRenoiseTools.Eq10DeviceGainVisualization = function();
NRenoiseTools.Eq10DeviceGainVisualization.createEnum('NRenoiseTools.Eq10DeviceGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq10DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Eq10DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq10DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq10DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq10DeviceRunTimePreset
JavaScript
NRenoiseTools.Eq10DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq10DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq10DeviceRunTimePreset

See Also

Eq10DeviceRunTimePreset Members


Eq10DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq10DeviceRunTimePreset Members
Eq10DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq10DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq10DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Eq10DeviceRunTimePreset Class


Eq10DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq10DeviceRunTimePreset Constructor
Eq10DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq10DeviceRunTimePreset()
Visual C++
public:
Eq10DeviceRunTimePreset()
JavaScript
NRenoiseTools.Eq10DeviceRunTimePreset = function();

See Also

Eq10DeviceRunTimePreset Class


Eq10DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq10DeviceRunTimePreset Methods
Eq10DeviceRunTimePreset Class See Also Send Feedback

The Eq10DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq10DeviceRunTimePreset Class


Eq10DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq10DeviceRunTimePreset Properties
Eq10DeviceRunTimePreset Class See Also Send Feedback

The Eq10DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Eq10DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Eq10DeviceRunTimePreset..::.DeviceSlot Property
Eq10DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Eq10DeviceDeviceSlotRunTimePreset
C#
public Eq10DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Eq10DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Eq10DeviceDeviceSlotRunTimePreset^ get ();
    void set (Eq10DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Eq10DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Eq10DeviceRunTimePreset..::.type Property
Eq10DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq10DeviceRunTimePreset Class


Eq5DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq5DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq5DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq5DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Eq5DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq5DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq5DeviceDeviceSlotRunTimePreset

See Also

Eq5DeviceDeviceSlotRunTimePreset Members


Eq5DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset Members
Eq5DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq5DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq5DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
InputMode |
MaxVisualizedGain |
type |

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Eq5DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset Constructor
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq5DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Eq5DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Eq5DeviceDeviceSlotRunTimePreset = function();

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Eq5DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset Methods
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Eq5DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Eq5DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset Properties
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Eq5DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
InputMode |
MaxVisualizedGain |
type |

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


BandWidth0 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.BandWidth0 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth0 As Single
C#
public float BandWidth0 { get; set; }
Visual C++
public:
property float BandWidth0 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth0();
function set_bandWidth0(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


BandWidth1 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.BandWidth1 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth1 As Single
C#
public float BandWidth1 { get; set; }
Visual C++
public:
property float BandWidth1 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth1();
function set_bandWidth1(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


BandWidth2 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.BandWidth2 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth2 As Single
C#
public float BandWidth2 { get; set; }
Visual C++
public:
property float BandWidth2 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth2();
function set_bandWidth2(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


BandWidth3 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.BandWidth3 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth3 As Single
C#
public float BandWidth3 { get; set; }
Visual C++
public:
property float BandWidth3 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth3();
function set_bandWidth3(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


BandWidth4 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.BandWidth4 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth4 As Single
C#
public float BandWidth4 { get; set; }
Visual C++
public:
property float BandWidth4 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth4();
function set_bandWidth4(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Frequency0 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Frequency0 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency0 As Single
C#
public float Frequency0 { get; set; }
Visual C++
public:
property float Frequency0 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency0();
function set_frequency0(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Frequency1 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Frequency1 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency1 As Single
C#
public float Frequency1 { get; set; }
Visual C++
public:
property float Frequency1 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency1();
function set_frequency1(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Frequency2 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Frequency2 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency2 As Single
C#
public float Frequency2 { get; set; }
Visual C++
public:
property float Frequency2 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency2();
function set_frequency2(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Frequency3 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Frequency3 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency3 As Single
C#
public float Frequency3 { get; set; }
Visual C++
public:
property float Frequency3 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency3();
function set_frequency3(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Frequency4 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Frequency4 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency4 As Single
C#
public float Frequency4 { get; set; }
Visual C++
public:
property float Frequency4 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency4();
function set_frequency4(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Gain0 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Gain0 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain0 As Eq5DeviceGainRunTimePreset
C#
public Eq5DeviceGainRunTimePreset Gain0 { get; set; }
Visual C++
public:
property Eq5DeviceGainRunTimePreset^ Gain0 {
    Eq5DeviceGainRunTimePreset^ get ();
    void set (Eq5DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain0();
function set_gain0(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Gain1 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Gain1 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain1 As Eq5DeviceGainRunTimePreset
C#
public Eq5DeviceGainRunTimePreset Gain1 { get; set; }
Visual C++
public:
property Eq5DeviceGainRunTimePreset^ Gain1 {
    Eq5DeviceGainRunTimePreset^ get ();
    void set (Eq5DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain1();
function set_gain1(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Gain2 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Gain2 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain2 As Eq5DeviceGainRunTimePreset
C#
public Eq5DeviceGainRunTimePreset Gain2 { get; set; }
Visual C++
public:
property Eq5DeviceGainRunTimePreset^ Gain2 {
    Eq5DeviceGainRunTimePreset^ get ();
    void set (Eq5DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain2();
function set_gain2(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Gain3 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Gain3 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain3 As Eq5DeviceGainRunTimePreset
C#
public Eq5DeviceGainRunTimePreset Gain3 { get; set; }
Visual C++
public:
property Eq5DeviceGainRunTimePreset^ Gain3 {
    Eq5DeviceGainRunTimePreset^ get ();
    void set (Eq5DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain3();
function set_gain3(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Gain4 Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.Gain4 Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain4 As Eq5DeviceGainRunTimePreset
C#
public Eq5DeviceGainRunTimePreset Gain4 { get; set; }
Visual C++
public:
property Eq5DeviceGainRunTimePreset^ Gain4 {
    Eq5DeviceGainRunTimePreset^ get ();
    void set (Eq5DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain4();
function set_gain4(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


InputMode Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.InputMode Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As Eq5DeviceDeviceSlotRunTimePresetInputMode
C#
public Eq5DeviceDeviceSlotRunTimePresetInputMode InputMode { get; set; }
Visual C++
public:
property Eq5DeviceDeviceSlotRunTimePresetInputMode InputMode {
    Eq5DeviceDeviceSlotRunTimePresetInputMode get ();
    void set (Eq5DeviceDeviceSlotRunTimePresetInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.MaxVisualizedGain Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePreset..::.type Property
Eq5DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq5DeviceDeviceSlotRunTimePreset Class


Eq5DeviceDeviceSlotRunTimePresetInputMode Enumeration

[image]

.NET Framework Class Library
Eq5DeviceDeviceSlotRunTimePresetInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq5DeviceDeviceSlotRunTimePresetInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq5DeviceDeviceSlotRunTimePresetInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq5DeviceDeviceSlotRunTimePresetInputMode
JavaScript
NRenoiseTools.Eq5DeviceDeviceSlotRunTimePresetInputMode = function();
NRenoiseTools.Eq5DeviceDeviceSlotRunTimePresetInputMode.createEnum('NRenoiseTools.Eq5DeviceDeviceSlotRunTimePresetInputMode', false);

Members

Member name | Description
L |
R |
LR |
LR1 |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq5DeviceEqDevice Class

[image]

.NET Framework Class Library
Eq5DeviceEqDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq5DeviceEqDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq5DeviceEqDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq5DeviceEqDevice
JavaScript
NRenoiseTools.Eq5DeviceEqDevice = function();

Type.createClass(
    'NRenoiseTools.Eq5DeviceEqDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq5DeviceEqDevice

See Also

Eq5DeviceEqDevice Members


Eq5DeviceEqDevice Members

[image] [image]

.NET Framework Class Library
Eq5DeviceEqDevice Members
Eq5DeviceEqDevice Class Constructors Methods Properties See Also Send Feedback

The Eq5DeviceEqDevice type exposes the following members.

Constructors

Name | Description
Eq5DeviceEqDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
InputMode |
IsActive |
IsSelected |
MaxVisualizedGain |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

Eq5DeviceEqDevice Class


Eq5DeviceEqDevice Constructor

[image]

.NET Framework Class Library
Eq5DeviceEqDevice Constructor
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq5DeviceEqDevice()
Visual C++
public:
Eq5DeviceEqDevice()
JavaScript
NRenoiseTools.Eq5DeviceEqDevice = function();

See Also

Eq5DeviceEqDevice Class


Eq5DeviceEqDevice Methods

[image] [image]

.NET Framework Class Library
Eq5DeviceEqDevice Methods
Eq5DeviceEqDevice Class See Also Send Feedback

The Eq5DeviceEqDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq5DeviceEqDevice Class


Eq5DeviceEqDevice Properties

[image] [image]

.NET Framework Class Library
Eq5DeviceEqDevice Properties
Eq5DeviceEqDevice Class See Also Send Feedback

The Eq5DeviceEqDevice type exposes the following members.

Properties

Name | Description
BandWidth0 |
BandWidth1 |
BandWidth2 |
BandWidth3 |
BandWidth4 |
Frequency0 |
Frequency1 |
Frequency2 |
Frequency3 |
Frequency4 |
Gain0 |
Gain1 |
Gain2 |
Gain3 |
Gain4 |
InputMode |
IsActive |
IsSelected |
MaxVisualizedGain |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

Eq5DeviceEqDevice Class


BandWidth0 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.BandWidth0 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth0 As Single
C#
public float BandWidth0 { get; set; }
Visual C++
public:
property float BandWidth0 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth0();
function set_bandWidth0(value);

Remarks

See Also

Eq5DeviceEqDevice Class


BandWidth1 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.BandWidth1 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth1 As Single
C#
public float BandWidth1 { get; set; }
Visual C++
public:
property float BandWidth1 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth1();
function set_bandWidth1(value);

Remarks

See Also

Eq5DeviceEqDevice Class


BandWidth2 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.BandWidth2 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth2 As Single
C#
public float BandWidth2 { get; set; }
Visual C++
public:
property float BandWidth2 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth2();
function set_bandWidth2(value);

Remarks

See Also

Eq5DeviceEqDevice Class


BandWidth3 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.BandWidth3 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth3 As Single
C#
public float BandWidth3 { get; set; }
Visual C++
public:
property float BandWidth3 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth3();
function set_bandWidth3(value);

Remarks

See Also

Eq5DeviceEqDevice Class


BandWidth4 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.BandWidth4 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BandWidth4 As Single
C#
public float BandWidth4 { get; set; }
Visual C++
public:
property float BandWidth4 {
    float get ();
    void set (float value);
}
JavaScript
function get_bandWidth4();
function set_bandWidth4(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Frequency0 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Frequency0 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency0 As Single
C#
public float Frequency0 { get; set; }
Visual C++
public:
property float Frequency0 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency0();
function set_frequency0(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Frequency1 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Frequency1 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency1 As Single
C#
public float Frequency1 { get; set; }
Visual C++
public:
property float Frequency1 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency1();
function set_frequency1(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Frequency2 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Frequency2 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency2 As Single
C#
public float Frequency2 { get; set; }
Visual C++
public:
property float Frequency2 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency2();
function set_frequency2(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Frequency3 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Frequency3 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency3 As Single
C#
public float Frequency3 { get; set; }
Visual C++
public:
property float Frequency3 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency3();
function set_frequency3(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Frequency4 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Frequency4 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency4 As Single
C#
public float Frequency4 { get; set; }
Visual C++
public:
property float Frequency4 {
    float get ();
    void set (float value);
}
JavaScript
function get_frequency4();
function set_frequency4(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Gain0 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Gain0 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain0 As Eq5DeviceGain
C#
public Eq5DeviceGain Gain0 { get; set; }
Visual C++
public:
property Eq5DeviceGain^ Gain0 {
    Eq5DeviceGain^ get ();
    void set (Eq5DeviceGain^ value);
}
JavaScript
function get_gain0();
function set_gain0(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Gain1 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Gain1 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain1 As Eq5DeviceGain
C#
public Eq5DeviceGain Gain1 { get; set; }
Visual C++
public:
property Eq5DeviceGain^ Gain1 {
    Eq5DeviceGain^ get ();
    void set (Eq5DeviceGain^ value);
}
JavaScript
function get_gain1();
function set_gain1(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Gain2 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Gain2 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain2 As Eq5DeviceGain
C#
public Eq5DeviceGain Gain2 { get; set; }
Visual C++
public:
property Eq5DeviceGain^ Gain2 {
    Eq5DeviceGain^ get ();
    void set (Eq5DeviceGain^ value);
}
JavaScript
function get_gain2();
function set_gain2(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Gain3 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Gain3 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain3 As Eq5DeviceGain
C#
public Eq5DeviceGain Gain3 { get; set; }
Visual C++
public:
property Eq5DeviceGain^ Gain3 {
    Eq5DeviceGain^ get ();
    void set (Eq5DeviceGain^ value);
}
JavaScript
function get_gain3();
function set_gain3(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Gain4 Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.Gain4 Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain4 As Eq5DeviceGain
C#
public Eq5DeviceGain Gain4 { get; set; }
Visual C++
public:
property Eq5DeviceGain^ Gain4 {
    Eq5DeviceGain^ get ();
    void set (Eq5DeviceGain^ value);
}
JavaScript
function get_gain4();
function set_gain4(value);

Remarks

See Also

Eq5DeviceEqDevice Class


InputMode Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.InputMode Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As Eq5DeviceEqDeviceInputMode
C#
public Eq5DeviceEqDeviceInputMode InputMode { get; set; }
Visual C++
public:
property Eq5DeviceEqDeviceInputMode InputMode {
    Eq5DeviceEqDeviceInputMode get ();
    void set (Eq5DeviceEqDeviceInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

Eq5DeviceEqDevice Class


IsActive Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.IsActive Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Eq5DeviceEqDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.IsSelected Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Eq5DeviceEqDevice Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.MaxVisualizedGain Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

Eq5DeviceEqDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.RunTimePresetA Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Eq5DeviceRunTimePreset
C#
public Eq5DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Eq5DeviceRunTimePreset^ RunTimePresetA {
    Eq5DeviceRunTimePreset^ get ();
    void set (Eq5DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Eq5DeviceEqDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.RunTimePresetB Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Eq5DeviceRunTimePreset
C#
public Eq5DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Eq5DeviceRunTimePreset^ RunTimePresetB {
    Eq5DeviceRunTimePreset^ get ();
    void set (Eq5DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Eq5DeviceEqDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.SelectedPresetIsModified Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Eq5DeviceEqDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.SelectedPresetName Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Eq5DeviceEqDevice Class


type Property

[image]

.NET Framework Class Library
Eq5DeviceEqDevice..::.type Property
Eq5DeviceEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq5DeviceEqDevice Class


Eq5DeviceEqDeviceInputMode Enumeration

[image]

.NET Framework Class Library
Eq5DeviceEqDeviceInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq5DeviceEqDeviceInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq5DeviceEqDeviceInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq5DeviceEqDeviceInputMode
JavaScript
NRenoiseTools.Eq5DeviceEqDeviceInputMode = function();
NRenoiseTools.Eq5DeviceEqDeviceInputMode.createEnum('NRenoiseTools.Eq5DeviceEqDeviceInputMode', false);

Members

Member name | Description
L |
R |
LR |
LR1 |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq5DeviceGain Class

[image]

.NET Framework Class Library
Eq5DeviceGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq5DeviceGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq5DeviceGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq5DeviceGain
JavaScript
NRenoiseTools.Eq5DeviceGain = function();

Type.createClass(
    'NRenoiseTools.Eq5DeviceGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq5DeviceGain

See Also

Eq5DeviceGain Members


Eq5DeviceGain Members

[image] [image]

.NET Framework Class Library
Eq5DeviceGain Members
Eq5DeviceGain Class Constructors Methods Properties See Also Send Feedback

The Eq5DeviceGain type exposes the following members.

Constructors

Name | Description
Eq5DeviceGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Eq5DeviceGain Class


Eq5DeviceGain Constructor

[image]

.NET Framework Class Library
Eq5DeviceGain Constructor
Eq5DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq5DeviceGain()
Visual C++
public:
Eq5DeviceGain()
JavaScript
NRenoiseTools.Eq5DeviceGain = function();

See Also

Eq5DeviceGain Class


Eq5DeviceGain Methods

[image] [image]

.NET Framework Class Library
Eq5DeviceGain Methods
Eq5DeviceGain Class See Also Send Feedback

The Eq5DeviceGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq5DeviceGain Class


Eq5DeviceGain Properties

[image] [image]

.NET Framework Class Library
Eq5DeviceGain Properties
Eq5DeviceGain Class See Also Send Feedback

The Eq5DeviceGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Eq5DeviceGain Class


MidiMappings Property

[image]

.NET Framework Class Library
Eq5DeviceGain..::.MidiMappings Property
Eq5DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Eq5DeviceGain Class


Value Property

[image]

.NET Framework Class Library
Eq5DeviceGain..::.Value Property
Eq5DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Eq5DeviceGain Class


Visualization Property

[image]

.NET Framework Class Library
Eq5DeviceGain..::.Visualization Property
Eq5DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Eq5DeviceGainVisualization
C#
public Eq5DeviceGainVisualization Visualization { get; set; }
Visual C++
public:
property Eq5DeviceGainVisualization Visualization {
    Eq5DeviceGainVisualization get ();
    void set (Eq5DeviceGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Eq5DeviceGain Class


Eq5DeviceGainRunTimePreset Class

[image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq5DeviceGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq5DeviceGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq5DeviceGainRunTimePreset
JavaScript
NRenoiseTools.Eq5DeviceGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq5DeviceGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq5DeviceGainRunTimePreset

See Also

Eq5DeviceGainRunTimePreset Members


Eq5DeviceGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset Members
Eq5DeviceGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq5DeviceGainRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq5DeviceGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Eq5DeviceGainRunTimePreset Class


Eq5DeviceGainRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset Constructor
Eq5DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq5DeviceGainRunTimePreset()
Visual C++
public:
Eq5DeviceGainRunTimePreset()
JavaScript
NRenoiseTools.Eq5DeviceGainRunTimePreset = function();

See Also

Eq5DeviceGainRunTimePreset Class


Eq5DeviceGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset Methods
Eq5DeviceGainRunTimePreset Class See Also Send Feedback

The Eq5DeviceGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq5DeviceGainRunTimePreset Class


Eq5DeviceGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset Properties
Eq5DeviceGainRunTimePreset Class See Also Send Feedback

The Eq5DeviceGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Eq5DeviceGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Eq5DeviceGainRunTimePreset..::.Value Property
Eq5DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Eq5DeviceGainRunTimePreset Class


Eq5DeviceGainVisualization Enumeration

[image]

.NET Framework Class Library
Eq5DeviceGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Eq5DeviceGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Eq5DeviceGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Eq5DeviceGainVisualization
JavaScript
NRenoiseTools.Eq5DeviceGainVisualization = function();
NRenoiseTools.Eq5DeviceGainVisualization.createEnum('NRenoiseTools.Eq5DeviceGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Eq5DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Eq5DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Eq5DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Eq5DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Eq5DeviceRunTimePreset
JavaScript
NRenoiseTools.Eq5DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Eq5DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Eq5DeviceRunTimePreset

See Also

Eq5DeviceRunTimePreset Members


Eq5DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Eq5DeviceRunTimePreset Members
Eq5DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Eq5DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Eq5DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Eq5DeviceRunTimePreset Class


Eq5DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Eq5DeviceRunTimePreset Constructor
Eq5DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Eq5DeviceRunTimePreset()
Visual C++
public:
Eq5DeviceRunTimePreset()
JavaScript
NRenoiseTools.Eq5DeviceRunTimePreset = function();

See Also

Eq5DeviceRunTimePreset Class


Eq5DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Eq5DeviceRunTimePreset Methods
Eq5DeviceRunTimePreset Class See Also Send Feedback

The Eq5DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Eq5DeviceRunTimePreset Class


Eq5DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Eq5DeviceRunTimePreset Properties
Eq5DeviceRunTimePreset Class See Also Send Feedback

The Eq5DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Eq5DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Eq5DeviceRunTimePreset..::.DeviceSlot Property
Eq5DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Eq5DeviceDeviceSlotRunTimePreset
C#
public Eq5DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Eq5DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Eq5DeviceDeviceSlotRunTimePreset^ get ();
    void set (Eq5DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Eq5DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Eq5DeviceRunTimePreset..::.type Property
Eq5DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Eq5DeviceRunTimePreset Class


Filter1DeviceCutoff Class

[image]

.NET Framework Class Library
Filter1DeviceCutoff Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceCutoff
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceCutoff
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceCutoff
JavaScript
NRenoiseTools.Filter1DeviceCutoff = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceCutoff');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceCutoff

See Also

Filter1DeviceCutoff Members


Filter1DeviceCutoff Members

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoff Members
Filter1DeviceCutoff Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceCutoff type exposes the following members.

Constructors

Name | Description
Filter1DeviceCutoff |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceCutoff Class


Filter1DeviceCutoff Constructor

[image]

.NET Framework Class Library
Filter1DeviceCutoff Constructor
Filter1DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceCutoff()
Visual C++
public:
Filter1DeviceCutoff()
JavaScript
NRenoiseTools.Filter1DeviceCutoff = function();

See Also

Filter1DeviceCutoff Class


Filter1DeviceCutoff Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoff Methods
Filter1DeviceCutoff Class See Also Send Feedback

The Filter1DeviceCutoff type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceCutoff Class


Filter1DeviceCutoff Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoff Properties
Filter1DeviceCutoff Class See Also Send Feedback

The Filter1DeviceCutoff type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceCutoff Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter1DeviceCutoff..::.MidiMappings Property
Filter1DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter1DeviceCutoff Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceCutoff..::.Value Property
Filter1DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceCutoff Class


Visualization Property

[image]

.NET Framework Class Library
Filter1DeviceCutoff..::.Visualization Property
Filter1DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter1DeviceCutoffVisualization
C#
public Filter1DeviceCutoffVisualization Visualization { get; set; }
Visual C++
public:
property Filter1DeviceCutoffVisualization Visualization {
    Filter1DeviceCutoffVisualization get ();
    void set (Filter1DeviceCutoffVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter1DeviceCutoff Class


Filter1DeviceCutoffRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceCutoffRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceCutoffRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceCutoffRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceCutoffRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceCutoffRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceCutoffRunTimePreset

See Also

Filter1DeviceCutoffRunTimePreset Members


Filter1DeviceCutoffRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset Members
Filter1DeviceCutoffRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceCutoffRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceCutoffRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter1DeviceCutoffRunTimePreset Class


Filter1DeviceCutoffRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset Constructor
Filter1DeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceCutoffRunTimePreset()
Visual C++
public:
Filter1DeviceCutoffRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceCutoffRunTimePreset = function();

See Also

Filter1DeviceCutoffRunTimePreset Class


Filter1DeviceCutoffRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset Methods
Filter1DeviceCutoffRunTimePreset Class See Also Send Feedback

The Filter1DeviceCutoffRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceCutoffRunTimePreset Class


Filter1DeviceCutoffRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset Properties
Filter1DeviceCutoffRunTimePreset Class See Also Send Feedback

The Filter1DeviceCutoffRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter1DeviceCutoffRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceCutoffRunTimePreset..::.Value Property
Filter1DeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceCutoffRunTimePreset Class


Filter1DeviceCutoffVisualization Enumeration

[image]

.NET Framework Class Library
Filter1DeviceCutoffVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter1DeviceCutoffVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter1DeviceCutoffVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter1DeviceCutoffVisualization
JavaScript
NRenoiseTools.Filter1DeviceCutoffVisualization = function();
NRenoiseTools.Filter1DeviceCutoffVisualization.createEnum('NRenoiseTools.Filter1DeviceCutoffVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter1DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceDeviceSlotRunTimePreset

See Also

Filter1DeviceDeviceSlotRunTimePreset Members


Filter1DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset Members
Filter1DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Innertia |
Resonance |
type |
Type |

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Filter1DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset Constructor
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Filter1DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceDeviceSlotRunTimePreset = function();

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Filter1DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset Methods
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter1DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Filter1DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset Properties
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter1DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Cutoff |
Innertia |
Resonance |
type |
Type |

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Cutoff Property

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset..::.Cutoff Property
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As Filter1DeviceCutoffRunTimePreset
C#
public Filter1DeviceCutoffRunTimePreset Cutoff { get; set; }
Visual C++
public:
property Filter1DeviceCutoffRunTimePreset^ Cutoff {
    Filter1DeviceCutoffRunTimePreset^ get ();
    void set (Filter1DeviceCutoffRunTimePreset^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Innertia Property

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset..::.Innertia Property
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Innertia As Filter1DeviceInnertiaRunTimePreset
C#
public Filter1DeviceInnertiaRunTimePreset Innertia { get; set; }
Visual C++
public:
property Filter1DeviceInnertiaRunTimePreset^ Innertia {
    Filter1DeviceInnertiaRunTimePreset^ get ();
    void set (Filter1DeviceInnertiaRunTimePreset^ value);
}
JavaScript
function get_innertia();
function set_innertia(value);

Remarks

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Resonance Property

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset..::.Resonance Property
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As Filter1DeviceResonanceRunTimePreset
C#
public Filter1DeviceResonanceRunTimePreset Resonance { get; set; }
Visual C++
public:
property Filter1DeviceResonanceRunTimePreset^ Resonance {
    Filter1DeviceResonanceRunTimePreset^ get ();
    void set (Filter1DeviceResonanceRunTimePreset^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
Filter1DeviceDeviceSlotRunTimePreset..::.Type Property
Filter1DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter1DeviceTypeRunTimePreset
C#
public Filter1DeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property Filter1DeviceTypeRunTimePreset^ Type {
    Filter1DeviceTypeRunTimePreset^ get ();
    void set (Filter1DeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter1DeviceDeviceSlotRunTimePreset Class


Filter1DeviceFilterDevice Class

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceFilterDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceFilterDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceFilterDevice
JavaScript
NRenoiseTools.Filter1DeviceFilterDevice = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceFilterDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceFilterDevice

See Also

Filter1DeviceFilterDevice Members


Filter1DeviceFilterDevice Members

[image] [image]

.NET Framework Class Library
Filter1DeviceFilterDevice Members
Filter1DeviceFilterDevice Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceFilterDevice type exposes the following members.

Constructors

Name | Description
Filter1DeviceFilterDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Innertia |
IsActive |
IsSelected |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter1DeviceFilterDevice Class


Filter1DeviceFilterDevice Constructor

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice Constructor
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceFilterDevice()
Visual C++
public:
Filter1DeviceFilterDevice()
JavaScript
NRenoiseTools.Filter1DeviceFilterDevice = function();

See Also

Filter1DeviceFilterDevice Class


Filter1DeviceFilterDevice Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceFilterDevice Methods
Filter1DeviceFilterDevice Class See Also Send Feedback

The Filter1DeviceFilterDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceFilterDevice Class


Filter1DeviceFilterDevice Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceFilterDevice Properties
Filter1DeviceFilterDevice Class See Also Send Feedback

The Filter1DeviceFilterDevice type exposes the following members.

Properties

Name | Description
Cutoff |
Innertia |
IsActive |
IsSelected |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter1DeviceFilterDevice Class


Cutoff Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.Cutoff Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As Filter1DeviceCutoff
C#
public Filter1DeviceCutoff Cutoff { get; set; }
Visual C++
public:
property Filter1DeviceCutoff^ Cutoff {
    Filter1DeviceCutoff^ get ();
    void set (Filter1DeviceCutoff^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


Innertia Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.Innertia Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Innertia As Filter1DeviceInnertia
C#
public Filter1DeviceInnertia Innertia { get; set; }
Visual C++
public:
property Filter1DeviceInnertia^ Innertia {
    Filter1DeviceInnertia^ get ();
    void set (Filter1DeviceInnertia^ value);
}
JavaScript
function get_innertia();
function set_innertia(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


IsActive Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.IsActive Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.IsSelected Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


Resonance Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.Resonance Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As Filter1DeviceResonance
C#
public Filter1DeviceResonance Resonance { get; set; }
Visual C++
public:
property Filter1DeviceResonance^ Resonance {
    Filter1DeviceResonance^ get ();
    void set (Filter1DeviceResonance^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.RunTimePresetA Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Filter1DeviceRunTimePreset
C#
public Filter1DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Filter1DeviceRunTimePreset^ RunTimePresetA {
    Filter1DeviceRunTimePreset^ get ();
    void set (Filter1DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.RunTimePresetB Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Filter1DeviceRunTimePreset
C#
public Filter1DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Filter1DeviceRunTimePreset^ RunTimePresetB {
    Filter1DeviceRunTimePreset^ get ();
    void set (Filter1DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.SelectedPresetIsModified Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.SelectedPresetName Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


Type Property

[image]

.NET Framework Class Library
Filter1DeviceFilterDevice..::.Type Property
Filter1DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter1DeviceType
C#
public Filter1DeviceType Type { get; set; }
Visual C++
public:
property Filter1DeviceType^ Type {
    Filter1DeviceType^ get ();
    void set (Filter1DeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter1DeviceFilterDevice Class


Filter1DeviceInnertia Class

[image]

.NET Framework Class Library
Filter1DeviceInnertia Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceInnertia
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceInnertia
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceInnertia
JavaScript
NRenoiseTools.Filter1DeviceInnertia = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceInnertia');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceInnertia

See Also

Filter1DeviceInnertia Members


Filter1DeviceInnertia Members

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertia Members
Filter1DeviceInnertia Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceInnertia type exposes the following members.

Constructors

Name | Description
Filter1DeviceInnertia |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceInnertia Class


Filter1DeviceInnertia Constructor

[image]

.NET Framework Class Library
Filter1DeviceInnertia Constructor
Filter1DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceInnertia()
Visual C++
public:
Filter1DeviceInnertia()
JavaScript
NRenoiseTools.Filter1DeviceInnertia = function();

See Also

Filter1DeviceInnertia Class


Filter1DeviceInnertia Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertia Methods
Filter1DeviceInnertia Class See Also Send Feedback

The Filter1DeviceInnertia type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceInnertia Class


Filter1DeviceInnertia Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertia Properties
Filter1DeviceInnertia Class See Also Send Feedback

The Filter1DeviceInnertia type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceInnertia Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter1DeviceInnertia..::.MidiMappings Property
Filter1DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter1DeviceInnertia Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceInnertia..::.Value Property
Filter1DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceInnertia Class


Visualization Property

[image]

.NET Framework Class Library
Filter1DeviceInnertia..::.Visualization Property
Filter1DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter1DeviceInnertiaVisualization
C#
public Filter1DeviceInnertiaVisualization Visualization { get; set; }
Visual C++
public:
property Filter1DeviceInnertiaVisualization Visualization {
    Filter1DeviceInnertiaVisualization get ();
    void set (Filter1DeviceInnertiaVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter1DeviceInnertia Class


Filter1DeviceInnertiaRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceInnertiaRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceInnertiaRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceInnertiaRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceInnertiaRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceInnertiaRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceInnertiaRunTimePreset

See Also

Filter1DeviceInnertiaRunTimePreset Members


Filter1DeviceInnertiaRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset Members
Filter1DeviceInnertiaRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceInnertiaRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceInnertiaRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter1DeviceInnertiaRunTimePreset Class


Filter1DeviceInnertiaRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset Constructor
Filter1DeviceInnertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceInnertiaRunTimePreset()
Visual C++
public:
Filter1DeviceInnertiaRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceInnertiaRunTimePreset = function();

See Also

Filter1DeviceInnertiaRunTimePreset Class


Filter1DeviceInnertiaRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset Methods
Filter1DeviceInnertiaRunTimePreset Class See Also Send Feedback

The Filter1DeviceInnertiaRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceInnertiaRunTimePreset Class


Filter1DeviceInnertiaRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset Properties
Filter1DeviceInnertiaRunTimePreset Class See Also Send Feedback

The Filter1DeviceInnertiaRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter1DeviceInnertiaRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceInnertiaRunTimePreset..::.Value Property
Filter1DeviceInnertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceInnertiaRunTimePreset Class


Filter1DeviceInnertiaVisualization Enumeration

[image]

.NET Framework Class Library
Filter1DeviceInnertiaVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter1DeviceInnertiaVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter1DeviceInnertiaVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter1DeviceInnertiaVisualization
JavaScript
NRenoiseTools.Filter1DeviceInnertiaVisualization = function();
NRenoiseTools.Filter1DeviceInnertiaVisualization.createEnum('NRenoiseTools.Filter1DeviceInnertiaVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter1DeviceResonance Class

[image]

.NET Framework Class Library
Filter1DeviceResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceResonance
JavaScript
NRenoiseTools.Filter1DeviceResonance = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceResonance

See Also

Filter1DeviceResonance Members


Filter1DeviceResonance Members

[image] [image]

.NET Framework Class Library
Filter1DeviceResonance Members
Filter1DeviceResonance Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceResonance type exposes the following members.

Constructors

Name | Description
Filter1DeviceResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceResonance Class


Filter1DeviceResonance Constructor

[image]

.NET Framework Class Library
Filter1DeviceResonance Constructor
Filter1DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceResonance()
Visual C++
public:
Filter1DeviceResonance()
JavaScript
NRenoiseTools.Filter1DeviceResonance = function();

See Also

Filter1DeviceResonance Class


Filter1DeviceResonance Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceResonance Methods
Filter1DeviceResonance Class See Also Send Feedback

The Filter1DeviceResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceResonance Class


Filter1DeviceResonance Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceResonance Properties
Filter1DeviceResonance Class See Also Send Feedback

The Filter1DeviceResonance type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceResonance Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter1DeviceResonance..::.MidiMappings Property
Filter1DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter1DeviceResonance Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceResonance..::.Value Property
Filter1DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceResonance Class


Visualization Property

[image]

.NET Framework Class Library
Filter1DeviceResonance..::.Visualization Property
Filter1DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter1DeviceResonanceVisualization
C#
public Filter1DeviceResonanceVisualization Visualization { get; set; }
Visual C++
public:
property Filter1DeviceResonanceVisualization Visualization {
    Filter1DeviceResonanceVisualization get ();
    void set (Filter1DeviceResonanceVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter1DeviceResonance Class


Filter1DeviceResonanceRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceResonanceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceResonanceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceResonanceRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceResonanceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceResonanceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceResonanceRunTimePreset

See Also

Filter1DeviceResonanceRunTimePreset Members


Filter1DeviceResonanceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset Members
Filter1DeviceResonanceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceResonanceRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceResonanceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter1DeviceResonanceRunTimePreset Class


Filter1DeviceResonanceRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset Constructor
Filter1DeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceResonanceRunTimePreset()
Visual C++
public:
Filter1DeviceResonanceRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceResonanceRunTimePreset = function();

See Also

Filter1DeviceResonanceRunTimePreset Class


Filter1DeviceResonanceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset Methods
Filter1DeviceResonanceRunTimePreset Class See Also Send Feedback

The Filter1DeviceResonanceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceResonanceRunTimePreset Class


Filter1DeviceResonanceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset Properties
Filter1DeviceResonanceRunTimePreset Class See Also Send Feedback

The Filter1DeviceResonanceRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter1DeviceResonanceRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceResonanceRunTimePreset..::.Value Property
Filter1DeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceResonanceRunTimePreset Class


Filter1DeviceResonanceVisualization Enumeration

[image]

.NET Framework Class Library
Filter1DeviceResonanceVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter1DeviceResonanceVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter1DeviceResonanceVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter1DeviceResonanceVisualization
JavaScript
NRenoiseTools.Filter1DeviceResonanceVisualization = function();
NRenoiseTools.Filter1DeviceResonanceVisualization.createEnum('NRenoiseTools.Filter1DeviceResonanceVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter1DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceRunTimePreset

See Also

Filter1DeviceRunTimePreset Members


Filter1DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceRunTimePreset Members
Filter1DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter1DeviceRunTimePreset Class


Filter1DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceRunTimePreset Constructor
Filter1DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceRunTimePreset()
Visual C++
public:
Filter1DeviceRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceRunTimePreset = function();

See Also

Filter1DeviceRunTimePreset Class


Filter1DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceRunTimePreset Methods
Filter1DeviceRunTimePreset Class See Also Send Feedback

The Filter1DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceRunTimePreset Class


Filter1DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceRunTimePreset Properties
Filter1DeviceRunTimePreset Class See Also Send Feedback

The Filter1DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter1DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Filter1DeviceRunTimePreset..::.DeviceSlot Property
Filter1DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Filter1DeviceDeviceSlotRunTimePreset
C#
public Filter1DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Filter1DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Filter1DeviceDeviceSlotRunTimePreset^ get ();
    void set (Filter1DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Filter1DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Filter1DeviceRunTimePreset..::.type Property
Filter1DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter1DeviceRunTimePreset Class


Filter1DeviceType Class

[image]

.NET Framework Class Library
Filter1DeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceType
JavaScript
NRenoiseTools.Filter1DeviceType = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceType

See Also

Filter1DeviceType Members


Filter1DeviceType Members

[image] [image]

.NET Framework Class Library
Filter1DeviceType Members
Filter1DeviceType Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceType type exposes the following members.

Constructors

Name | Description
Filter1DeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceType Class


Filter1DeviceType Constructor

[image]

.NET Framework Class Library
Filter1DeviceType Constructor
Filter1DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceType()
Visual C++
public:
Filter1DeviceType()
JavaScript
NRenoiseTools.Filter1DeviceType = function();

See Also

Filter1DeviceType Class


Filter1DeviceType Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceType Methods
Filter1DeviceType Class See Also Send Feedback

The Filter1DeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceType Class


Filter1DeviceType Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceType Properties
Filter1DeviceType Class See Also Send Feedback

The Filter1DeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter1DeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter1DeviceType..::.MidiMappings Property
Filter1DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter1DeviceType Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceType..::.Value Property
Filter1DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceType Class


Visualization Property

[image]

.NET Framework Class Library
Filter1DeviceType..::.Visualization Property
Filter1DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter1DeviceTypeVisualization
C#
public Filter1DeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property Filter1DeviceTypeVisualization Visualization {
    Filter1DeviceTypeVisualization get ();
    void set (Filter1DeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter1DeviceType Class


Filter1DeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter1DeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter1DeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter1DeviceTypeRunTimePreset
JavaScript
NRenoiseTools.Filter1DeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter1DeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter1DeviceTypeRunTimePreset

See Also

Filter1DeviceTypeRunTimePreset Members


Filter1DeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset Members
Filter1DeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter1DeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter1DeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter1DeviceTypeRunTimePreset Class


Filter1DeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset Constructor
Filter1DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter1DeviceTypeRunTimePreset()
Visual C++
public:
Filter1DeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.Filter1DeviceTypeRunTimePreset = function();

See Also

Filter1DeviceTypeRunTimePreset Class


Filter1DeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset Methods
Filter1DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter1DeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter1DeviceTypeRunTimePreset Class


Filter1DeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset Properties
Filter1DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter1DeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter1DeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter1DeviceTypeRunTimePreset..::.Value Property
Filter1DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter1DeviceTypeRunTimePreset Class


Filter1DeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
Filter1DeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter1DeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter1DeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter1DeviceTypeVisualization
JavaScript
NRenoiseTools.Filter1DeviceTypeVisualization = function();
NRenoiseTools.Filter1DeviceTypeVisualization.createEnum('NRenoiseTools.Filter1DeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter2DeviceCutoff Class

[image]

.NET Framework Class Library
Filter2DeviceCutoff Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceCutoff
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceCutoff
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceCutoff
JavaScript
NRenoiseTools.Filter2DeviceCutoff = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceCutoff');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceCutoff

See Also

Filter2DeviceCutoff Members


Filter2DeviceCutoff Members

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoff Members
Filter2DeviceCutoff Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceCutoff type exposes the following members.

Constructors

Name | Description
Filter2DeviceCutoff |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceCutoff Class


Filter2DeviceCutoff Constructor

[image]

.NET Framework Class Library
Filter2DeviceCutoff Constructor
Filter2DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceCutoff()
Visual C++
public:
Filter2DeviceCutoff()
JavaScript
NRenoiseTools.Filter2DeviceCutoff = function();

See Also

Filter2DeviceCutoff Class


Filter2DeviceCutoff Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoff Methods
Filter2DeviceCutoff Class See Also Send Feedback

The Filter2DeviceCutoff type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceCutoff Class


Filter2DeviceCutoff Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoff Properties
Filter2DeviceCutoff Class See Also Send Feedback

The Filter2DeviceCutoff type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceCutoff Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter2DeviceCutoff..::.MidiMappings Property
Filter2DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter2DeviceCutoff Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceCutoff..::.Value Property
Filter2DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceCutoff Class


Visualization Property

[image]

.NET Framework Class Library
Filter2DeviceCutoff..::.Visualization Property
Filter2DeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter2DeviceCutoffVisualization
C#
public Filter2DeviceCutoffVisualization Visualization { get; set; }
Visual C++
public:
property Filter2DeviceCutoffVisualization Visualization {
    Filter2DeviceCutoffVisualization get ();
    void set (Filter2DeviceCutoffVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter2DeviceCutoff Class


Filter2DeviceCutoffRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceCutoffRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceCutoffRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceCutoffRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceCutoffRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceCutoffRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceCutoffRunTimePreset

See Also

Filter2DeviceCutoffRunTimePreset Members


Filter2DeviceCutoffRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset Members
Filter2DeviceCutoffRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceCutoffRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceCutoffRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter2DeviceCutoffRunTimePreset Class


Filter2DeviceCutoffRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset Constructor
Filter2DeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceCutoffRunTimePreset()
Visual C++
public:
Filter2DeviceCutoffRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceCutoffRunTimePreset = function();

See Also

Filter2DeviceCutoffRunTimePreset Class


Filter2DeviceCutoffRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset Methods
Filter2DeviceCutoffRunTimePreset Class See Also Send Feedback

The Filter2DeviceCutoffRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceCutoffRunTimePreset Class


Filter2DeviceCutoffRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset Properties
Filter2DeviceCutoffRunTimePreset Class See Also Send Feedback

The Filter2DeviceCutoffRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter2DeviceCutoffRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceCutoffRunTimePreset..::.Value Property
Filter2DeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceCutoffRunTimePreset Class


Filter2DeviceCutoffVisualization Enumeration

[image]

.NET Framework Class Library
Filter2DeviceCutoffVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter2DeviceCutoffVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter2DeviceCutoffVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter2DeviceCutoffVisualization
JavaScript
NRenoiseTools.Filter2DeviceCutoffVisualization = function();
NRenoiseTools.Filter2DeviceCutoffVisualization.createEnum('NRenoiseTools.Filter2DeviceCutoffVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter2DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceDeviceSlotRunTimePreset

See Also

Filter2DeviceDeviceSlotRunTimePreset Members


Filter2DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset Members
Filter2DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Innertia |
LimitMoogFilterOutput |
Resonance |
type |
Type |

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Filter2DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset Constructor
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Filter2DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceDeviceSlotRunTimePreset = function();

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Filter2DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset Methods
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter2DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Filter2DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset Properties
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter2DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Cutoff |
Innertia |
LimitMoogFilterOutput |
Resonance |
type |
Type |

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Cutoff Property

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset..::.Cutoff Property
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As Filter2DeviceCutoffRunTimePreset
C#
public Filter2DeviceCutoffRunTimePreset Cutoff { get; set; }
Visual C++
public:
property Filter2DeviceCutoffRunTimePreset^ Cutoff {
    Filter2DeviceCutoffRunTimePreset^ get ();
    void set (Filter2DeviceCutoffRunTimePreset^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Innertia Property

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset..::.Innertia Property
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Innertia As Filter2DeviceInnertiaRunTimePreset
C#
public Filter2DeviceInnertiaRunTimePreset Innertia { get; set; }
Visual C++
public:
property Filter2DeviceInnertiaRunTimePreset^ Innertia {
    Filter2DeviceInnertiaRunTimePreset^ get ();
    void set (Filter2DeviceInnertiaRunTimePreset^ value);
}
JavaScript
function get_innertia();
function set_innertia(value);

Remarks

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


LimitMoogFilterOutput Property

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset..::.LimitMoogFilterOutput Property
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LimitMoogFilterOutput As Boolean
C#
public bool LimitMoogFilterOutput { get; set; }
Visual C++
public:
property bool LimitMoogFilterOutput {
    bool get ();
    void set (bool value);
}
JavaScript
function get_limitMoogFilterOutput();
function set_limitMoogFilterOutput(value);

Remarks

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Resonance Property

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset..::.Resonance Property
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As Filter2DeviceResonanceRunTimePreset
C#
public Filter2DeviceResonanceRunTimePreset Resonance { get; set; }
Visual C++
public:
property Filter2DeviceResonanceRunTimePreset^ Resonance {
    Filter2DeviceResonanceRunTimePreset^ get ();
    void set (Filter2DeviceResonanceRunTimePreset^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
Filter2DeviceDeviceSlotRunTimePreset..::.Type Property
Filter2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter2DeviceTypeRunTimePreset
C#
public Filter2DeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property Filter2DeviceTypeRunTimePreset^ Type {
    Filter2DeviceTypeRunTimePreset^ get ();
    void set (Filter2DeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter2DeviceDeviceSlotRunTimePreset Class


Filter2DeviceFilterDevice Class

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceFilterDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceFilterDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceFilterDevice
JavaScript
NRenoiseTools.Filter2DeviceFilterDevice = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceFilterDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceFilterDevice

See Also

Filter2DeviceFilterDevice Members


Filter2DeviceFilterDevice Members

[image] [image]

.NET Framework Class Library
Filter2DeviceFilterDevice Members
Filter2DeviceFilterDevice Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceFilterDevice type exposes the following members.

Constructors

Name | Description
Filter2DeviceFilterDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Innertia |
IsActive |
IsSelected |
LimitMoogFilterOutput |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter2DeviceFilterDevice Class


Filter2DeviceFilterDevice Constructor

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice Constructor
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceFilterDevice()
Visual C++
public:
Filter2DeviceFilterDevice()
JavaScript
NRenoiseTools.Filter2DeviceFilterDevice = function();

See Also

Filter2DeviceFilterDevice Class


Filter2DeviceFilterDevice Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceFilterDevice Methods
Filter2DeviceFilterDevice Class See Also Send Feedback

The Filter2DeviceFilterDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceFilterDevice Class


Filter2DeviceFilterDevice Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceFilterDevice Properties
Filter2DeviceFilterDevice Class See Also Send Feedback

The Filter2DeviceFilterDevice type exposes the following members.

Properties

Name | Description
Cutoff |
Innertia |
IsActive |
IsSelected |
LimitMoogFilterOutput |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter2DeviceFilterDevice Class


Cutoff Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.Cutoff Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As Filter2DeviceCutoff
C#
public Filter2DeviceCutoff Cutoff { get; set; }
Visual C++
public:
property Filter2DeviceCutoff^ Cutoff {
    Filter2DeviceCutoff^ get ();
    void set (Filter2DeviceCutoff^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


Innertia Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.Innertia Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Innertia As Filter2DeviceInnertia
C#
public Filter2DeviceInnertia Innertia { get; set; }
Visual C++
public:
property Filter2DeviceInnertia^ Innertia {
    Filter2DeviceInnertia^ get ();
    void set (Filter2DeviceInnertia^ value);
}
JavaScript
function get_innertia();
function set_innertia(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


IsActive Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.IsActive Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.IsSelected Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


LimitMoogFilterOutput Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.LimitMoogFilterOutput Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LimitMoogFilterOutput As Boolean
C#
public bool LimitMoogFilterOutput { get; set; }
Visual C++
public:
property bool LimitMoogFilterOutput {
    bool get ();
    void set (bool value);
}
JavaScript
function get_limitMoogFilterOutput();
function set_limitMoogFilterOutput(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


Resonance Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.Resonance Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As Filter2DeviceResonance
C#
public Filter2DeviceResonance Resonance { get; set; }
Visual C++
public:
property Filter2DeviceResonance^ Resonance {
    Filter2DeviceResonance^ get ();
    void set (Filter2DeviceResonance^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.RunTimePresetA Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Filter2DeviceRunTimePreset
C#
public Filter2DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Filter2DeviceRunTimePreset^ RunTimePresetA {
    Filter2DeviceRunTimePreset^ get ();
    void set (Filter2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.RunTimePresetB Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Filter2DeviceRunTimePreset
C#
public Filter2DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Filter2DeviceRunTimePreset^ RunTimePresetB {
    Filter2DeviceRunTimePreset^ get ();
    void set (Filter2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.SelectedPresetIsModified Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.SelectedPresetName Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


Type Property

[image]

.NET Framework Class Library
Filter2DeviceFilterDevice..::.Type Property
Filter2DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter2DeviceType
C#
public Filter2DeviceType Type { get; set; }
Visual C++
public:
property Filter2DeviceType^ Type {
    Filter2DeviceType^ get ();
    void set (Filter2DeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter2DeviceFilterDevice Class


Filter2DeviceInnertia Class

[image]

.NET Framework Class Library
Filter2DeviceInnertia Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceInnertia
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceInnertia
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceInnertia
JavaScript
NRenoiseTools.Filter2DeviceInnertia = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceInnertia');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceInnertia

See Also

Filter2DeviceInnertia Members


Filter2DeviceInnertia Members

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertia Members
Filter2DeviceInnertia Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceInnertia type exposes the following members.

Constructors

Name | Description
Filter2DeviceInnertia |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceInnertia Class


Filter2DeviceInnertia Constructor

[image]

.NET Framework Class Library
Filter2DeviceInnertia Constructor
Filter2DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceInnertia()
Visual C++
public:
Filter2DeviceInnertia()
JavaScript
NRenoiseTools.Filter2DeviceInnertia = function();

See Also

Filter2DeviceInnertia Class


Filter2DeviceInnertia Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertia Methods
Filter2DeviceInnertia Class See Also Send Feedback

The Filter2DeviceInnertia type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceInnertia Class


Filter2DeviceInnertia Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertia Properties
Filter2DeviceInnertia Class See Also Send Feedback

The Filter2DeviceInnertia type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceInnertia Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter2DeviceInnertia..::.MidiMappings Property
Filter2DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter2DeviceInnertia Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceInnertia..::.Value Property
Filter2DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceInnertia Class


Visualization Property

[image]

.NET Framework Class Library
Filter2DeviceInnertia..::.Visualization Property
Filter2DeviceInnertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter2DeviceInnertiaVisualization
C#
public Filter2DeviceInnertiaVisualization Visualization { get; set; }
Visual C++
public:
property Filter2DeviceInnertiaVisualization Visualization {
    Filter2DeviceInnertiaVisualization get ();
    void set (Filter2DeviceInnertiaVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter2DeviceInnertia Class


Filter2DeviceInnertiaRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceInnertiaRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceInnertiaRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceInnertiaRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceInnertiaRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceInnertiaRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceInnertiaRunTimePreset

See Also

Filter2DeviceInnertiaRunTimePreset Members


Filter2DeviceInnertiaRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset Members
Filter2DeviceInnertiaRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceInnertiaRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceInnertiaRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter2DeviceInnertiaRunTimePreset Class


Filter2DeviceInnertiaRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset Constructor
Filter2DeviceInnertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceInnertiaRunTimePreset()
Visual C++
public:
Filter2DeviceInnertiaRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceInnertiaRunTimePreset = function();

See Also

Filter2DeviceInnertiaRunTimePreset Class


Filter2DeviceInnertiaRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset Methods
Filter2DeviceInnertiaRunTimePreset Class See Also Send Feedback

The Filter2DeviceInnertiaRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceInnertiaRunTimePreset Class


Filter2DeviceInnertiaRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset Properties
Filter2DeviceInnertiaRunTimePreset Class See Also Send Feedback

The Filter2DeviceInnertiaRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter2DeviceInnertiaRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceInnertiaRunTimePreset..::.Value Property
Filter2DeviceInnertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceInnertiaRunTimePreset Class


Filter2DeviceInnertiaVisualization Enumeration

[image]

.NET Framework Class Library
Filter2DeviceInnertiaVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter2DeviceInnertiaVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter2DeviceInnertiaVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter2DeviceInnertiaVisualization
JavaScript
NRenoiseTools.Filter2DeviceInnertiaVisualization = function();
NRenoiseTools.Filter2DeviceInnertiaVisualization.createEnum('NRenoiseTools.Filter2DeviceInnertiaVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter2DeviceResonance Class

[image]

.NET Framework Class Library
Filter2DeviceResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceResonance
JavaScript
NRenoiseTools.Filter2DeviceResonance = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceResonance

See Also

Filter2DeviceResonance Members


Filter2DeviceResonance Members

[image] [image]

.NET Framework Class Library
Filter2DeviceResonance Members
Filter2DeviceResonance Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceResonance type exposes the following members.

Constructors

Name | Description
Filter2DeviceResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceResonance Class


Filter2DeviceResonance Constructor

[image]

.NET Framework Class Library
Filter2DeviceResonance Constructor
Filter2DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceResonance()
Visual C++
public:
Filter2DeviceResonance()
JavaScript
NRenoiseTools.Filter2DeviceResonance = function();

See Also

Filter2DeviceResonance Class


Filter2DeviceResonance Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceResonance Methods
Filter2DeviceResonance Class See Also Send Feedback

The Filter2DeviceResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceResonance Class


Filter2DeviceResonance Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceResonance Properties
Filter2DeviceResonance Class See Also Send Feedback

The Filter2DeviceResonance type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceResonance Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter2DeviceResonance..::.MidiMappings Property
Filter2DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter2DeviceResonance Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceResonance..::.Value Property
Filter2DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceResonance Class


Visualization Property

[image]

.NET Framework Class Library
Filter2DeviceResonance..::.Visualization Property
Filter2DeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter2DeviceResonanceVisualization
C#
public Filter2DeviceResonanceVisualization Visualization { get; set; }
Visual C++
public:
property Filter2DeviceResonanceVisualization Visualization {
    Filter2DeviceResonanceVisualization get ();
    void set (Filter2DeviceResonanceVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter2DeviceResonance Class


Filter2DeviceResonanceRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceResonanceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceResonanceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceResonanceRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceResonanceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceResonanceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceResonanceRunTimePreset

See Also

Filter2DeviceResonanceRunTimePreset Members


Filter2DeviceResonanceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset Members
Filter2DeviceResonanceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceResonanceRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceResonanceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter2DeviceResonanceRunTimePreset Class


Filter2DeviceResonanceRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset Constructor
Filter2DeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceResonanceRunTimePreset()
Visual C++
public:
Filter2DeviceResonanceRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceResonanceRunTimePreset = function();

See Also

Filter2DeviceResonanceRunTimePreset Class


Filter2DeviceResonanceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset Methods
Filter2DeviceResonanceRunTimePreset Class See Also Send Feedback

The Filter2DeviceResonanceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceResonanceRunTimePreset Class


Filter2DeviceResonanceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset Properties
Filter2DeviceResonanceRunTimePreset Class See Also Send Feedback

The Filter2DeviceResonanceRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter2DeviceResonanceRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceResonanceRunTimePreset..::.Value Property
Filter2DeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceResonanceRunTimePreset Class


Filter2DeviceResonanceVisualization Enumeration

[image]

.NET Framework Class Library
Filter2DeviceResonanceVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter2DeviceResonanceVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter2DeviceResonanceVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter2DeviceResonanceVisualization
JavaScript
NRenoiseTools.Filter2DeviceResonanceVisualization = function();
NRenoiseTools.Filter2DeviceResonanceVisualization.createEnum('NRenoiseTools.Filter2DeviceResonanceVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter2DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceRunTimePreset

See Also

Filter2DeviceRunTimePreset Members


Filter2DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceRunTimePreset Members
Filter2DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter2DeviceRunTimePreset Class


Filter2DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceRunTimePreset Constructor
Filter2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceRunTimePreset()
Visual C++
public:
Filter2DeviceRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceRunTimePreset = function();

See Also

Filter2DeviceRunTimePreset Class


Filter2DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceRunTimePreset Methods
Filter2DeviceRunTimePreset Class See Also Send Feedback

The Filter2DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceRunTimePreset Class


Filter2DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceRunTimePreset Properties
Filter2DeviceRunTimePreset Class See Also Send Feedback

The Filter2DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter2DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Filter2DeviceRunTimePreset..::.DeviceSlot Property
Filter2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Filter2DeviceDeviceSlotRunTimePreset
C#
public Filter2DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Filter2DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Filter2DeviceDeviceSlotRunTimePreset^ get ();
    void set (Filter2DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Filter2DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Filter2DeviceRunTimePreset..::.type Property
Filter2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter2DeviceRunTimePreset Class


Filter2DeviceType Class

[image]

.NET Framework Class Library
Filter2DeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceType
JavaScript
NRenoiseTools.Filter2DeviceType = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceType

See Also

Filter2DeviceType Members


Filter2DeviceType Members

[image] [image]

.NET Framework Class Library
Filter2DeviceType Members
Filter2DeviceType Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceType type exposes the following members.

Constructors

Name | Description
Filter2DeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceType Class


Filter2DeviceType Constructor

[image]

.NET Framework Class Library
Filter2DeviceType Constructor
Filter2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceType()
Visual C++
public:
Filter2DeviceType()
JavaScript
NRenoiseTools.Filter2DeviceType = function();

See Also

Filter2DeviceType Class


Filter2DeviceType Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceType Methods
Filter2DeviceType Class See Also Send Feedback

The Filter2DeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceType Class


Filter2DeviceType Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceType Properties
Filter2DeviceType Class See Also Send Feedback

The Filter2DeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter2DeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter2DeviceType..::.MidiMappings Property
Filter2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter2DeviceType Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceType..::.Value Property
Filter2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceType Class


Visualization Property

[image]

.NET Framework Class Library
Filter2DeviceType..::.Visualization Property
Filter2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter2DeviceTypeVisualization
C#
public Filter2DeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property Filter2DeviceTypeVisualization Visualization {
    Filter2DeviceTypeVisualization get ();
    void set (Filter2DeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter2DeviceType Class


Filter2DeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter2DeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter2DeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter2DeviceTypeRunTimePreset
JavaScript
NRenoiseTools.Filter2DeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter2DeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter2DeviceTypeRunTimePreset

See Also

Filter2DeviceTypeRunTimePreset Members


Filter2DeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset Members
Filter2DeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter2DeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter2DeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter2DeviceTypeRunTimePreset Class


Filter2DeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset Constructor
Filter2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter2DeviceTypeRunTimePreset()
Visual C++
public:
Filter2DeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.Filter2DeviceTypeRunTimePreset = function();

See Also

Filter2DeviceTypeRunTimePreset Class


Filter2DeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset Methods
Filter2DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter2DeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter2DeviceTypeRunTimePreset Class


Filter2DeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset Properties
Filter2DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter2DeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter2DeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter2DeviceTypeRunTimePreset..::.Value Property
Filter2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter2DeviceTypeRunTimePreset Class


Filter2DeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
Filter2DeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter2DeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter2DeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter2DeviceTypeVisualization
JavaScript
NRenoiseTools.Filter2DeviceTypeVisualization = function();
NRenoiseTools.Filter2DeviceTypeVisualization.createEnum('NRenoiseTools.Filter2DeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceDeviceSlotRunTimePreset

See Also

Filter3DeviceDeviceSlotRunTimePreset Members


Filter3DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset Members
Filter3DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Frequency |
Gain |
Inertia |
Model |
Q |
type |
Type |

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Filter3DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset Constructor
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Filter3DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceDeviceSlotRunTimePreset = function();

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Filter3DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset Methods
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter3DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Filter3DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset Properties
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Filter3DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Frequency |
Gain |
Inertia |
Model |
Q |
type |
Type |

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Frequency Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Frequency Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As Filter3DeviceFrequencyRunTimePreset
C#
public Filter3DeviceFrequencyRunTimePreset Frequency { get; set; }
Visual C++
public:
property Filter3DeviceFrequencyRunTimePreset^ Frequency {
    Filter3DeviceFrequencyRunTimePreset^ get ();
    void set (Filter3DeviceFrequencyRunTimePreset^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Gain Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Gain Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As Filter3DeviceGainRunTimePreset
C#
public Filter3DeviceGainRunTimePreset Gain { get; set; }
Visual C++
public:
property Filter3DeviceGainRunTimePreset^ Gain {
    Filter3DeviceGainRunTimePreset^ get ();
    void set (Filter3DeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Inertia Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Inertia Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As Filter3DeviceInertiaRunTimePreset
C#
public Filter3DeviceInertiaRunTimePreset Inertia { get; set; }
Visual C++
public:
property Filter3DeviceInertiaRunTimePreset^ Inertia {
    Filter3DeviceInertiaRunTimePreset^ get ();
    void set (Filter3DeviceInertiaRunTimePreset^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Model Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Model Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Model As Filter3DeviceDeviceSlotRunTimePresetModel
C#
public Filter3DeviceDeviceSlotRunTimePresetModel Model { get; set; }
Visual C++
public:
property Filter3DeviceDeviceSlotRunTimePresetModel Model {
    Filter3DeviceDeviceSlotRunTimePresetModel get ();
    void set (Filter3DeviceDeviceSlotRunTimePresetModel value);
}
JavaScript
function get_model();
function set_model(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Q Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Q Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Q As Filter3DeviceQRunTimePreset
C#
public Filter3DeviceQRunTimePreset Q { get; set; }
Visual C++
public:
property Filter3DeviceQRunTimePreset^ Q {
    Filter3DeviceQRunTimePreset^ get ();
    void set (Filter3DeviceQRunTimePreset^ value);
}
JavaScript
function get_q();
function set_q(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePreset..::.Type Property
Filter3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter3DeviceTypeRunTimePreset
C#
public Filter3DeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property Filter3DeviceTypeRunTimePreset^ Type {
    Filter3DeviceTypeRunTimePreset^ get ();
    void set (Filter3DeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter3DeviceDeviceSlotRunTimePreset Class


Filter3DeviceDeviceSlotRunTimePresetModel Enumeration

[image]

.NET Framework Class Library
Filter3DeviceDeviceSlotRunTimePresetModel Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceDeviceSlotRunTimePresetModel
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceDeviceSlotRunTimePresetModel
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceDeviceSlotRunTimePresetModel
JavaScript
NRenoiseTools.Filter3DeviceDeviceSlotRunTimePresetModel = function();
NRenoiseTools.Filter3DeviceDeviceSlotRunTimePresetModel.createEnum('NRenoiseTools.Filter3DeviceDeviceSlotRunTimePresetModel', false);

Members

Member name | Description
Item24dB4Pole |
Item24dBMoog |
Butterworth4n |
Butterworth8n |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceFilterDevice Class

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceFilterDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceFilterDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceFilterDevice
JavaScript
NRenoiseTools.Filter3DeviceFilterDevice = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceFilterDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceFilterDevice

See Also

Filter3DeviceFilterDevice Members


Filter3DeviceFilterDevice Members

[image] [image]

.NET Framework Class Library
Filter3DeviceFilterDevice Members
Filter3DeviceFilterDevice Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceFilterDevice type exposes the following members.

Constructors

Name | Description
Filter3DeviceFilterDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Frequency |
Gain |
Inertia |
IsActive |
IsSelected |
Model |
Q |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter3DeviceFilterDevice Class


Filter3DeviceFilterDevice Constructor

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice Constructor
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceFilterDevice()
Visual C++
public:
Filter3DeviceFilterDevice()
JavaScript
NRenoiseTools.Filter3DeviceFilterDevice = function();

See Also

Filter3DeviceFilterDevice Class


Filter3DeviceFilterDevice Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceFilterDevice Methods
Filter3DeviceFilterDevice Class See Also Send Feedback

The Filter3DeviceFilterDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceFilterDevice Class


Filter3DeviceFilterDevice Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceFilterDevice Properties
Filter3DeviceFilterDevice Class See Also Send Feedback

The Filter3DeviceFilterDevice type exposes the following members.

Properties

Name | Description
Frequency |
Gain |
Inertia |
IsActive |
IsSelected |
Model |
Q |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

Filter3DeviceFilterDevice Class


Frequency Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Frequency Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As Filter3DeviceFrequency
C#
public Filter3DeviceFrequency Frequency { get; set; }
Visual C++
public:
property Filter3DeviceFrequency^ Frequency {
    Filter3DeviceFrequency^ get ();
    void set (Filter3DeviceFrequency^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Gain Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Gain Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As Filter3DeviceGain
C#
public Filter3DeviceGain Gain { get; set; }
Visual C++
public:
property Filter3DeviceGain^ Gain {
    Filter3DeviceGain^ get ();
    void set (Filter3DeviceGain^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Inertia Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Inertia Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As Filter3DeviceInertia
C#
public Filter3DeviceInertia Inertia { get; set; }
Visual C++
public:
property Filter3DeviceInertia^ Inertia {
    Filter3DeviceInertia^ get ();
    void set (Filter3DeviceInertia^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


IsActive Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.IsActive Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.IsSelected Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Model Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Model Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Model As Filter3DeviceFilterDeviceModel
C#
public Filter3DeviceFilterDeviceModel Model { get; set; }
Visual C++
public:
property Filter3DeviceFilterDeviceModel Model {
    Filter3DeviceFilterDeviceModel get ();
    void set (Filter3DeviceFilterDeviceModel value);
}
JavaScript
function get_model();
function set_model(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Q Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Q Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Q As Filter3DeviceQ
C#
public Filter3DeviceQ Q { get; set; }
Visual C++
public:
property Filter3DeviceQ^ Q {
    Filter3DeviceQ^ get ();
    void set (Filter3DeviceQ^ value);
}
JavaScript
function get_q();
function set_q(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.RunTimePresetA Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Filter3DeviceRunTimePreset
C#
public Filter3DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Filter3DeviceRunTimePreset^ RunTimePresetA {
    Filter3DeviceRunTimePreset^ get ();
    void set (Filter3DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.RunTimePresetB Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Filter3DeviceRunTimePreset
C#
public Filter3DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Filter3DeviceRunTimePreset^ RunTimePresetB {
    Filter3DeviceRunTimePreset^ get ();
    void set (Filter3DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.SelectedPresetIsModified Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.SelectedPresetName Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Type Property

[image]

.NET Framework Class Library
Filter3DeviceFilterDevice..::.Type Property
Filter3DeviceFilterDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Filter3DeviceType
C#
public Filter3DeviceType Type { get; set; }
Visual C++
public:
property Filter3DeviceType^ Type {
    Filter3DeviceType^ get ();
    void set (Filter3DeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter3DeviceFilterDevice Class


Filter3DeviceFilterDeviceModel Enumeration

[image]

.NET Framework Class Library
Filter3DeviceFilterDeviceModel Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceFilterDeviceModel
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceFilterDeviceModel
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceFilterDeviceModel
JavaScript
NRenoiseTools.Filter3DeviceFilterDeviceModel = function();
NRenoiseTools.Filter3DeviceFilterDeviceModel.createEnum('NRenoiseTools.Filter3DeviceFilterDeviceModel', false);

Members

Member name | Description
Item24dB4Pole |
Item24dBMoog |
Butterworth4n |
Butterworth8n |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceFrequency Class

[image]

.NET Framework Class Library
Filter3DeviceFrequency Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceFrequency
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceFrequency
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceFrequency
JavaScript
NRenoiseTools.Filter3DeviceFrequency = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceFrequency');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceFrequency

See Also

Filter3DeviceFrequency Members


Filter3DeviceFrequency Members

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequency Members
Filter3DeviceFrequency Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceFrequency type exposes the following members.

Constructors

Name | Description
Filter3DeviceFrequency |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceFrequency Class


Filter3DeviceFrequency Constructor

[image]

.NET Framework Class Library
Filter3DeviceFrequency Constructor
Filter3DeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceFrequency()
Visual C++
public:
Filter3DeviceFrequency()
JavaScript
NRenoiseTools.Filter3DeviceFrequency = function();

See Also

Filter3DeviceFrequency Class


Filter3DeviceFrequency Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequency Methods
Filter3DeviceFrequency Class See Also Send Feedback

The Filter3DeviceFrequency type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceFrequency Class


Filter3DeviceFrequency Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequency Properties
Filter3DeviceFrequency Class See Also Send Feedback

The Filter3DeviceFrequency type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceFrequency Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter3DeviceFrequency..::.MidiMappings Property
Filter3DeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter3DeviceFrequency Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceFrequency..::.Value Property
Filter3DeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceFrequency Class


Visualization Property

[image]

.NET Framework Class Library
Filter3DeviceFrequency..::.Visualization Property
Filter3DeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter3DeviceFrequencyVisualization
C#
public Filter3DeviceFrequencyVisualization Visualization { get; set; }
Visual C++
public:
property Filter3DeviceFrequencyVisualization Visualization {
    Filter3DeviceFrequencyVisualization get ();
    void set (Filter3DeviceFrequencyVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter3DeviceFrequency Class


Filter3DeviceFrequencyRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceFrequencyRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceFrequencyRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceFrequencyRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceFrequencyRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceFrequencyRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceFrequencyRunTimePreset

See Also

Filter3DeviceFrequencyRunTimePreset Members


Filter3DeviceFrequencyRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset Members
Filter3DeviceFrequencyRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceFrequencyRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceFrequencyRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter3DeviceFrequencyRunTimePreset Class


Filter3DeviceFrequencyRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset Constructor
Filter3DeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceFrequencyRunTimePreset()
Visual C++
public:
Filter3DeviceFrequencyRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceFrequencyRunTimePreset = function();

See Also

Filter3DeviceFrequencyRunTimePreset Class


Filter3DeviceFrequencyRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset Methods
Filter3DeviceFrequencyRunTimePreset Class See Also Send Feedback

The Filter3DeviceFrequencyRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceFrequencyRunTimePreset Class


Filter3DeviceFrequencyRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset Properties
Filter3DeviceFrequencyRunTimePreset Class See Also Send Feedback

The Filter3DeviceFrequencyRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter3DeviceFrequencyRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceFrequencyRunTimePreset..::.Value Property
Filter3DeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceFrequencyRunTimePreset Class


Filter3DeviceFrequencyVisualization Enumeration

[image]

.NET Framework Class Library
Filter3DeviceFrequencyVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceFrequencyVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceFrequencyVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceFrequencyVisualization
JavaScript
NRenoiseTools.Filter3DeviceFrequencyVisualization = function();
NRenoiseTools.Filter3DeviceFrequencyVisualization.createEnum('NRenoiseTools.Filter3DeviceFrequencyVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceGain Class

[image]

.NET Framework Class Library
Filter3DeviceGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceGain
JavaScript
NRenoiseTools.Filter3DeviceGain = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceGain

See Also

Filter3DeviceGain Members


Filter3DeviceGain Members

[image] [image]

.NET Framework Class Library
Filter3DeviceGain Members
Filter3DeviceGain Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceGain type exposes the following members.

Constructors

Name | Description
Filter3DeviceGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceGain Class


Filter3DeviceGain Constructor

[image]

.NET Framework Class Library
Filter3DeviceGain Constructor
Filter3DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceGain()
Visual C++
public:
Filter3DeviceGain()
JavaScript
NRenoiseTools.Filter3DeviceGain = function();

See Also

Filter3DeviceGain Class


Filter3DeviceGain Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceGain Methods
Filter3DeviceGain Class See Also Send Feedback

The Filter3DeviceGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceGain Class


Filter3DeviceGain Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceGain Properties
Filter3DeviceGain Class See Also Send Feedback

The Filter3DeviceGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceGain Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter3DeviceGain..::.MidiMappings Property
Filter3DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter3DeviceGain Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceGain..::.Value Property
Filter3DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceGain Class


Visualization Property

[image]

.NET Framework Class Library
Filter3DeviceGain..::.Visualization Property
Filter3DeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter3DeviceGainVisualization
C#
public Filter3DeviceGainVisualization Visualization { get; set; }
Visual C++
public:
property Filter3DeviceGainVisualization Visualization {
    Filter3DeviceGainVisualization get ();
    void set (Filter3DeviceGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter3DeviceGain Class


Filter3DeviceGainRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceGainRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceGainRunTimePreset

See Also

Filter3DeviceGainRunTimePreset Members


Filter3DeviceGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset Members
Filter3DeviceGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceGainRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter3DeviceGainRunTimePreset Class


Filter3DeviceGainRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset Constructor
Filter3DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceGainRunTimePreset()
Visual C++
public:
Filter3DeviceGainRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceGainRunTimePreset = function();

See Also

Filter3DeviceGainRunTimePreset Class


Filter3DeviceGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset Methods
Filter3DeviceGainRunTimePreset Class See Also Send Feedback

The Filter3DeviceGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceGainRunTimePreset Class


Filter3DeviceGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset Properties
Filter3DeviceGainRunTimePreset Class See Also Send Feedback

The Filter3DeviceGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter3DeviceGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceGainRunTimePreset..::.Value Property
Filter3DeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceGainRunTimePreset Class


Filter3DeviceGainVisualization Enumeration

[image]

.NET Framework Class Library
Filter3DeviceGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceGainVisualization
JavaScript
NRenoiseTools.Filter3DeviceGainVisualization = function();
NRenoiseTools.Filter3DeviceGainVisualization.createEnum('NRenoiseTools.Filter3DeviceGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceInertia Class

[image]

.NET Framework Class Library
Filter3DeviceInertia Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceInertia
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceInertia
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceInertia
JavaScript
NRenoiseTools.Filter3DeviceInertia = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceInertia');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceInertia

See Also

Filter3DeviceInertia Members


Filter3DeviceInertia Members

[image] [image]

.NET Framework Class Library
Filter3DeviceInertia Members
Filter3DeviceInertia Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceInertia type exposes the following members.

Constructors

Name | Description
Filter3DeviceInertia |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceInertia Class


Filter3DeviceInertia Constructor

[image]

.NET Framework Class Library
Filter3DeviceInertia Constructor
Filter3DeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceInertia()
Visual C++
public:
Filter3DeviceInertia()
JavaScript
NRenoiseTools.Filter3DeviceInertia = function();

See Also

Filter3DeviceInertia Class


Filter3DeviceInertia Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceInertia Methods
Filter3DeviceInertia Class See Also Send Feedback

The Filter3DeviceInertia type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceInertia Class


Filter3DeviceInertia Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceInertia Properties
Filter3DeviceInertia Class See Also Send Feedback

The Filter3DeviceInertia type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceInertia Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter3DeviceInertia..::.MidiMappings Property
Filter3DeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter3DeviceInertia Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceInertia..::.Value Property
Filter3DeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceInertia Class


Visualization Property

[image]

.NET Framework Class Library
Filter3DeviceInertia..::.Visualization Property
Filter3DeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter3DeviceInertiaVisualization
C#
public Filter3DeviceInertiaVisualization Visualization { get; set; }
Visual C++
public:
property Filter3DeviceInertiaVisualization Visualization {
    Filter3DeviceInertiaVisualization get ();
    void set (Filter3DeviceInertiaVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter3DeviceInertia Class


Filter3DeviceInertiaRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceInertiaRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceInertiaRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceInertiaRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceInertiaRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceInertiaRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceInertiaRunTimePreset

See Also

Filter3DeviceInertiaRunTimePreset Members


Filter3DeviceInertiaRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset Members
Filter3DeviceInertiaRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceInertiaRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceInertiaRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter3DeviceInertiaRunTimePreset Class


Filter3DeviceInertiaRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset Constructor
Filter3DeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceInertiaRunTimePreset()
Visual C++
public:
Filter3DeviceInertiaRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceInertiaRunTimePreset = function();

See Also

Filter3DeviceInertiaRunTimePreset Class


Filter3DeviceInertiaRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset Methods
Filter3DeviceInertiaRunTimePreset Class See Also Send Feedback

The Filter3DeviceInertiaRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceInertiaRunTimePreset Class


Filter3DeviceInertiaRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset Properties
Filter3DeviceInertiaRunTimePreset Class See Also Send Feedback

The Filter3DeviceInertiaRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter3DeviceInertiaRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceInertiaRunTimePreset..::.Value Property
Filter3DeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceInertiaRunTimePreset Class


Filter3DeviceInertiaVisualization Enumeration

[image]

.NET Framework Class Library
Filter3DeviceInertiaVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceInertiaVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceInertiaVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceInertiaVisualization
JavaScript
NRenoiseTools.Filter3DeviceInertiaVisualization = function();
NRenoiseTools.Filter3DeviceInertiaVisualization.createEnum('NRenoiseTools.Filter3DeviceInertiaVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceQ Class

[image]

.NET Framework Class Library
Filter3DeviceQ Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceQ
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceQ
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceQ
JavaScript
NRenoiseTools.Filter3DeviceQ = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceQ');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceQ

See Also

Filter3DeviceQ Members


Filter3DeviceQ Members

[image] [image]

.NET Framework Class Library
Filter3DeviceQ Members
Filter3DeviceQ Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceQ type exposes the following members.

Constructors

Name | Description
Filter3DeviceQ |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceQ Class


Filter3DeviceQ Constructor

[image]

.NET Framework Class Library
Filter3DeviceQ Constructor
Filter3DeviceQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceQ()
Visual C++
public:
Filter3DeviceQ()
JavaScript
NRenoiseTools.Filter3DeviceQ = function();

See Also

Filter3DeviceQ Class


Filter3DeviceQ Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceQ Methods
Filter3DeviceQ Class See Also Send Feedback

The Filter3DeviceQ type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceQ Class


Filter3DeviceQ Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceQ Properties
Filter3DeviceQ Class See Also Send Feedback

The Filter3DeviceQ type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceQ Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter3DeviceQ..::.MidiMappings Property
Filter3DeviceQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter3DeviceQ Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceQ..::.Value Property
Filter3DeviceQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceQ Class


Visualization Property

[image]

.NET Framework Class Library
Filter3DeviceQ..::.Visualization Property
Filter3DeviceQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter3DeviceQVisualization
C#
public Filter3DeviceQVisualization Visualization { get; set; }
Visual C++
public:
property Filter3DeviceQVisualization Visualization {
    Filter3DeviceQVisualization get ();
    void set (Filter3DeviceQVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter3DeviceQ Class


Filter3DeviceQRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceQRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceQRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceQRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceQRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceQRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceQRunTimePreset

See Also

Filter3DeviceQRunTimePreset Members


Filter3DeviceQRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset Members
Filter3DeviceQRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceQRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceQRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter3DeviceQRunTimePreset Class


Filter3DeviceQRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset Constructor
Filter3DeviceQRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceQRunTimePreset()
Visual C++
public:
Filter3DeviceQRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceQRunTimePreset = function();

See Also

Filter3DeviceQRunTimePreset Class


Filter3DeviceQRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset Methods
Filter3DeviceQRunTimePreset Class See Also Send Feedback

The Filter3DeviceQRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceQRunTimePreset Class


Filter3DeviceQRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset Properties
Filter3DeviceQRunTimePreset Class See Also Send Feedback

The Filter3DeviceQRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter3DeviceQRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceQRunTimePreset..::.Value Property
Filter3DeviceQRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceQRunTimePreset Class


Filter3DeviceQVisualization Enumeration

[image]

.NET Framework Class Library
Filter3DeviceQVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceQVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceQVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceQVisualization
JavaScript
NRenoiseTools.Filter3DeviceQVisualization = function();
NRenoiseTools.Filter3DeviceQVisualization.createEnum('NRenoiseTools.Filter3DeviceQVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Filter3DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceRunTimePreset

See Also

Filter3DeviceRunTimePreset Members


Filter3DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceRunTimePreset Members
Filter3DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter3DeviceRunTimePreset Class


Filter3DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceRunTimePreset Constructor
Filter3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceRunTimePreset()
Visual C++
public:
Filter3DeviceRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceRunTimePreset = function();

See Also

Filter3DeviceRunTimePreset Class


Filter3DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceRunTimePreset Methods
Filter3DeviceRunTimePreset Class See Also Send Feedback

The Filter3DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceRunTimePreset Class


Filter3DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceRunTimePreset Properties
Filter3DeviceRunTimePreset Class See Also Send Feedback

The Filter3DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Filter3DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Filter3DeviceRunTimePreset..::.DeviceSlot Property
Filter3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Filter3DeviceDeviceSlotRunTimePreset
C#
public Filter3DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Filter3DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Filter3DeviceDeviceSlotRunTimePreset^ get ();
    void set (Filter3DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Filter3DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Filter3DeviceRunTimePreset..::.type Property
Filter3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Filter3DeviceRunTimePreset Class


Filter3DeviceType Class

[image]

.NET Framework Class Library
Filter3DeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceType
JavaScript
NRenoiseTools.Filter3DeviceType = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceType

See Also

Filter3DeviceType Members


Filter3DeviceType Members

[image] [image]

.NET Framework Class Library
Filter3DeviceType Members
Filter3DeviceType Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceType type exposes the following members.

Constructors

Name | Description
Filter3DeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceType Class


Filter3DeviceType Constructor

[image]

.NET Framework Class Library
Filter3DeviceType Constructor
Filter3DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceType()
Visual C++
public:
Filter3DeviceType()
JavaScript
NRenoiseTools.Filter3DeviceType = function();

See Also

Filter3DeviceType Class


Filter3DeviceType Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceType Methods
Filter3DeviceType Class See Also Send Feedback

The Filter3DeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceType Class


Filter3DeviceType Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceType Properties
Filter3DeviceType Class See Also Send Feedback

The Filter3DeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Filter3DeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
Filter3DeviceType..::.MidiMappings Property
Filter3DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Filter3DeviceType Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceType..::.Value Property
Filter3DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceType Class


Visualization Property

[image]

.NET Framework Class Library
Filter3DeviceType..::.Visualization Property
Filter3DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Filter3DeviceTypeVisualization
C#
public Filter3DeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property Filter3DeviceTypeVisualization Visualization {
    Filter3DeviceTypeVisualization get ();
    void set (Filter3DeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Filter3DeviceType Class


Filter3DeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Filter3DeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Filter3DeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Filter3DeviceTypeRunTimePreset
JavaScript
NRenoiseTools.Filter3DeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Filter3DeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Filter3DeviceTypeRunTimePreset

See Also

Filter3DeviceTypeRunTimePreset Members


Filter3DeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset Members
Filter3DeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Filter3DeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
Filter3DeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Filter3DeviceTypeRunTimePreset Class


Filter3DeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset Constructor
Filter3DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Filter3DeviceTypeRunTimePreset()
Visual C++
public:
Filter3DeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.Filter3DeviceTypeRunTimePreset = function();

See Also

Filter3DeviceTypeRunTimePreset Class


Filter3DeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset Methods
Filter3DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter3DeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter3DeviceTypeRunTimePreset Class


Filter3DeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset Properties
Filter3DeviceTypeRunTimePreset Class See Also Send Feedback

The Filter3DeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Filter3DeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Filter3DeviceTypeRunTimePreset..::.Value Property
Filter3DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Filter3DeviceTypeRunTimePreset Class


Filter3DeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
Filter3DeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Filter3DeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Filter3DeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Filter3DeviceTypeVisualization
JavaScript
NRenoiseTools.Filter3DeviceTypeVisualization = function();
NRenoiseTools.Filter3DeviceTypeVisualization.createEnum('NRenoiseTools.Filter3DeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDevice Class

[image]

.NET Framework Class Library
FilterDistortionDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDevice
JavaScript
NRenoiseTools.FilterDistortionDevice = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDevice

See Also

FilterDistortionDevice Members


FilterDistortionDevice Members

[image] [image]

.NET Framework Class Library
FilterDistortionDevice Members
FilterDistortionDevice Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDevice type exposes the following members.

Constructors

Name | Description
FilterDistortionDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Drive |
FilterType |
Inertia |
IsActive |
IsSelected |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

FilterDistortionDevice Class


FilterDistortionDevice Constructor

[image]

.NET Framework Class Library
FilterDistortionDevice Constructor
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDevice()
Visual C++
public:
FilterDistortionDevice()
JavaScript
NRenoiseTools.FilterDistortionDevice = function();

See Also

FilterDistortionDevice Class


FilterDistortionDevice Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDevice Methods
FilterDistortionDevice Class See Also Send Feedback

The FilterDistortionDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDevice Class


FilterDistortionDevice Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDevice Properties
FilterDistortionDevice Class See Also Send Feedback

The FilterDistortionDevice type exposes the following members.

Properties

Name | Description
Cutoff |
Drive |
FilterType |
Inertia |
IsActive |
IsSelected |
Resonance |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

FilterDistortionDevice Class


Cutoff Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.Cutoff Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As FilterDistortionDeviceCutoff
C#
public FilterDistortionDeviceCutoff Cutoff { get; set; }
Visual C++
public:
property FilterDistortionDeviceCutoff^ Cutoff {
    FilterDistortionDeviceCutoff^ get ();
    void set (FilterDistortionDeviceCutoff^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

FilterDistortionDevice Class


Drive Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.Drive Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Drive As FilterDistortionDeviceDrive
C#
public FilterDistortionDeviceDrive Drive { get; set; }
Visual C++
public:
property FilterDistortionDeviceDrive^ Drive {
    FilterDistortionDeviceDrive^ get ();
    void set (FilterDistortionDeviceDrive^ value);
}
JavaScript
function get_drive();
function set_drive(value);

Remarks

See Also

FilterDistortionDevice Class


FilterType Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.FilterType Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As FilterDistortionDeviceFilterType
C#
public FilterDistortionDeviceFilterType FilterType { get; set; }
Visual C++
public:
property FilterDistortionDeviceFilterType^ FilterType {
    FilterDistortionDeviceFilterType^ get ();
    void set (FilterDistortionDeviceFilterType^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

FilterDistortionDevice Class


Inertia Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.Inertia Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As FilterDistortionDeviceInertia
C#
public FilterDistortionDeviceInertia Inertia { get; set; }
Visual C++
public:
property FilterDistortionDeviceInertia^ Inertia {
    FilterDistortionDeviceInertia^ get ();
    void set (FilterDistortionDeviceInertia^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

FilterDistortionDevice Class


IsActive Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.IsActive Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

FilterDistortionDevice Class


IsSelected Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.IsSelected Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

FilterDistortionDevice Class


Resonance Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.Resonance Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As FilterDistortionDeviceResonance
C#
public FilterDistortionDeviceResonance Resonance { get; set; }
Visual C++
public:
property FilterDistortionDeviceResonance^ Resonance {
    FilterDistortionDeviceResonance^ get ();
    void set (FilterDistortionDeviceResonance^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

FilterDistortionDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.RunTimePresetA Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As FilterDistortionDeviceRunTimePreset
C#
public FilterDistortionDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property FilterDistortionDeviceRunTimePreset^ RunTimePresetA {
    FilterDistortionDeviceRunTimePreset^ get ();
    void set (FilterDistortionDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

FilterDistortionDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.RunTimePresetB Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As FilterDistortionDeviceRunTimePreset
C#
public FilterDistortionDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property FilterDistortionDeviceRunTimePreset^ RunTimePresetB {
    FilterDistortionDeviceRunTimePreset^ get ();
    void set (FilterDistortionDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

FilterDistortionDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.SelectedPresetIsModified Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

FilterDistortionDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.SelectedPresetName Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

FilterDistortionDevice Class


type Property

[image]

.NET Framework Class Library
FilterDistortionDevice..::.type Property
FilterDistortionDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FilterDistortionDevice Class


FilterDistortionDeviceCutoff Class

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoff Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceCutoff
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceCutoff
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceCutoff
JavaScript
NRenoiseTools.FilterDistortionDeviceCutoff = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceCutoff');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceCutoff

See Also

FilterDistortionDeviceCutoff Members


FilterDistortionDeviceCutoff Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoff Members
FilterDistortionDeviceCutoff Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceCutoff type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceCutoff |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceCutoff Class


FilterDistortionDeviceCutoff Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoff Constructor
FilterDistortionDeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceCutoff()
Visual C++
public:
FilterDistortionDeviceCutoff()
JavaScript
NRenoiseTools.FilterDistortionDeviceCutoff = function();

See Also

FilterDistortionDeviceCutoff Class


FilterDistortionDeviceCutoff Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoff Methods
FilterDistortionDeviceCutoff Class See Also Send Feedback

The FilterDistortionDeviceCutoff type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceCutoff Class


FilterDistortionDeviceCutoff Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoff Properties
FilterDistortionDeviceCutoff Class See Also Send Feedback

The FilterDistortionDeviceCutoff type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceCutoff Class


MidiMappings Property

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoff..::.MidiMappings Property
FilterDistortionDeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FilterDistortionDeviceCutoff Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoff..::.Value Property
FilterDistortionDeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceCutoff Class


Visualization Property

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoff..::.Visualization Property
FilterDistortionDeviceCutoff Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FilterDistortionDeviceCutoffVisualization
C#
public FilterDistortionDeviceCutoffVisualization Visualization { get; set; }
Visual C++
public:
property FilterDistortionDeviceCutoffVisualization Visualization {
    FilterDistortionDeviceCutoffVisualization get ();
    void set (FilterDistortionDeviceCutoffVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FilterDistortionDeviceCutoff Class


FilterDistortionDeviceCutoffRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceCutoffRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceCutoffRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceCutoffRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceCutoffRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceCutoffRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceCutoffRunTimePreset

See Also

FilterDistortionDeviceCutoffRunTimePreset Members


FilterDistortionDeviceCutoffRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset Members
FilterDistortionDeviceCutoffRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceCutoffRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceCutoffRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceCutoffRunTimePreset Class


FilterDistortionDeviceCutoffRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset Constructor
FilterDistortionDeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceCutoffRunTimePreset()
Visual C++
public:
FilterDistortionDeviceCutoffRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceCutoffRunTimePreset = function();

See Also

FilterDistortionDeviceCutoffRunTimePreset Class


FilterDistortionDeviceCutoffRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset Methods
FilterDistortionDeviceCutoffRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceCutoffRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceCutoffRunTimePreset Class


FilterDistortionDeviceCutoffRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset Properties
FilterDistortionDeviceCutoffRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceCutoffRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceCutoffRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoffRunTimePreset..::.Value Property
FilterDistortionDeviceCutoffRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceCutoffRunTimePreset Class


FilterDistortionDeviceCutoffVisualization Enumeration

[image]

.NET Framework Class Library
FilterDistortionDeviceCutoffVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FilterDistortionDeviceCutoffVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FilterDistortionDeviceCutoffVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FilterDistortionDeviceCutoffVisualization
JavaScript
NRenoiseTools.FilterDistortionDeviceCutoffVisualization = function();
NRenoiseTools.FilterDistortionDeviceCutoffVisualization.createEnum('NRenoiseTools.FilterDistortionDeviceCutoffVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceDeviceSlotRunTimePreset

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Members


FilterDistortionDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset Members
FilterDistortionDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cutoff |
Drive |
FilterType |
Inertia |
Resonance |
type |

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


FilterDistortionDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset Constructor
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceDeviceSlotRunTimePreset()
Visual C++
public:
FilterDistortionDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceDeviceSlotRunTimePreset = function();

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


FilterDistortionDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset Methods
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


FilterDistortionDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset Properties
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Cutoff |
Drive |
FilterType |
Inertia |
Resonance |
type |

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


Cutoff Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.Cutoff Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Cutoff As FilterDistortionDeviceCutoffRunTimePreset
C#
public FilterDistortionDeviceCutoffRunTimePreset Cutoff { get; set; }
Visual C++
public:
property FilterDistortionDeviceCutoffRunTimePreset^ Cutoff {
    FilterDistortionDeviceCutoffRunTimePreset^ get ();
    void set (FilterDistortionDeviceCutoffRunTimePreset^ value);
}
JavaScript
function get_cutoff();
function set_cutoff(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


Drive Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.Drive Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Drive As FilterDistortionDeviceDriveRunTimePreset
C#
public FilterDistortionDeviceDriveRunTimePreset Drive { get; set; }
Visual C++
public:
property FilterDistortionDeviceDriveRunTimePreset^ Drive {
    FilterDistortionDeviceDriveRunTimePreset^ get ();
    void set (FilterDistortionDeviceDriveRunTimePreset^ value);
}
JavaScript
function get_drive();
function set_drive(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


FilterType Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.FilterType Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As FilterDistortionDeviceFilterTypeRunTimePreset
C#
public FilterDistortionDeviceFilterTypeRunTimePreset FilterType { get; set; }
Visual C++
public:
property FilterDistortionDeviceFilterTypeRunTimePreset^ FilterType {
    FilterDistortionDeviceFilterTypeRunTimePreset^ get ();
    void set (FilterDistortionDeviceFilterTypeRunTimePreset^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


Inertia Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.Inertia Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As FilterDistortionDeviceInertiaRunTimePreset
C#
public FilterDistortionDeviceInertiaRunTimePreset Inertia { get; set; }
Visual C++
public:
property FilterDistortionDeviceInertiaRunTimePreset^ Inertia {
    FilterDistortionDeviceInertiaRunTimePreset^ get ();
    void set (FilterDistortionDeviceInertiaRunTimePreset^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


Resonance Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.Resonance Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Resonance As FilterDistortionDeviceResonanceRunTimePreset
C#
public FilterDistortionDeviceResonanceRunTimePreset Resonance { get; set; }
Visual C++
public:
property FilterDistortionDeviceResonanceRunTimePreset^ Resonance {
    FilterDistortionDeviceResonanceRunTimePreset^ get ();
    void set (FilterDistortionDeviceResonanceRunTimePreset^ value);
}
JavaScript
function get_resonance();
function set_resonance(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDeviceSlotRunTimePreset..::.type Property
FilterDistortionDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FilterDistortionDeviceDeviceSlotRunTimePreset Class


FilterDistortionDeviceDrive Class

[image]

.NET Framework Class Library
FilterDistortionDeviceDrive Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceDrive
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceDrive
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceDrive
JavaScript
NRenoiseTools.FilterDistortionDeviceDrive = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceDrive');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceDrive

See Also

FilterDistortionDeviceDrive Members


FilterDistortionDeviceDrive Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDrive Members
FilterDistortionDeviceDrive Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceDrive type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceDrive |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceDrive Class


FilterDistortionDeviceDrive Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceDrive Constructor
FilterDistortionDeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceDrive()
Visual C++
public:
FilterDistortionDeviceDrive()
JavaScript
NRenoiseTools.FilterDistortionDeviceDrive = function();

See Also

FilterDistortionDeviceDrive Class


FilterDistortionDeviceDrive Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDrive Methods
FilterDistortionDeviceDrive Class See Also Send Feedback

The FilterDistortionDeviceDrive type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceDrive Class


FilterDistortionDeviceDrive Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDrive Properties
FilterDistortionDeviceDrive Class See Also Send Feedback

The FilterDistortionDeviceDrive type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceDrive Class


MidiMappings Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDrive..::.MidiMappings Property
FilterDistortionDeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FilterDistortionDeviceDrive Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDrive..::.Value Property
FilterDistortionDeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceDrive Class


Visualization Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDrive..::.Visualization Property
FilterDistortionDeviceDrive Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FilterDistortionDeviceDriveVisualization
C#
public FilterDistortionDeviceDriveVisualization Visualization { get; set; }
Visual C++
public:
property FilterDistortionDeviceDriveVisualization Visualization {
    FilterDistortionDeviceDriveVisualization get ();
    void set (FilterDistortionDeviceDriveVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FilterDistortionDeviceDrive Class


FilterDistortionDeviceDriveRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceDriveRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceDriveRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceDriveRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceDriveRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceDriveRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceDriveRunTimePreset

See Also

FilterDistortionDeviceDriveRunTimePreset Members


FilterDistortionDeviceDriveRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset Members
FilterDistortionDeviceDriveRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceDriveRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceDriveRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceDriveRunTimePreset Class


FilterDistortionDeviceDriveRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset Constructor
FilterDistortionDeviceDriveRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceDriveRunTimePreset()
Visual C++
public:
FilterDistortionDeviceDriveRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceDriveRunTimePreset = function();

See Also

FilterDistortionDeviceDriveRunTimePreset Class


FilterDistortionDeviceDriveRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset Methods
FilterDistortionDeviceDriveRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceDriveRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceDriveRunTimePreset Class


FilterDistortionDeviceDriveRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset Properties
FilterDistortionDeviceDriveRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceDriveRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceDriveRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceDriveRunTimePreset..::.Value Property
FilterDistortionDeviceDriveRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceDriveRunTimePreset Class


FilterDistortionDeviceDriveVisualization Enumeration

[image]

.NET Framework Class Library
FilterDistortionDeviceDriveVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FilterDistortionDeviceDriveVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FilterDistortionDeviceDriveVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FilterDistortionDeviceDriveVisualization
JavaScript
NRenoiseTools.FilterDistortionDeviceDriveVisualization = function();
NRenoiseTools.FilterDistortionDeviceDriveVisualization.createEnum('NRenoiseTools.FilterDistortionDeviceDriveVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDeviceFilterType Class

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceFilterType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceFilterType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceFilterType
JavaScript
NRenoiseTools.FilterDistortionDeviceFilterType = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceFilterType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceFilterType

See Also

FilterDistortionDeviceFilterType Members


FilterDistortionDeviceFilterType Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterType Members
FilterDistortionDeviceFilterType Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceFilterType type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceFilterType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceFilterType Class


FilterDistortionDeviceFilterType Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterType Constructor
FilterDistortionDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceFilterType()
Visual C++
public:
FilterDistortionDeviceFilterType()
JavaScript
NRenoiseTools.FilterDistortionDeviceFilterType = function();

See Also

FilterDistortionDeviceFilterType Class


FilterDistortionDeviceFilterType Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterType Methods
FilterDistortionDeviceFilterType Class See Also Send Feedback

The FilterDistortionDeviceFilterType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceFilterType Class


FilterDistortionDeviceFilterType Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterType Properties
FilterDistortionDeviceFilterType Class See Also Send Feedback

The FilterDistortionDeviceFilterType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceFilterType Class


MidiMappings Property

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterType..::.MidiMappings Property
FilterDistortionDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FilterDistortionDeviceFilterType Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterType..::.Value Property
FilterDistortionDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceFilterType Class


Visualization Property

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterType..::.Visualization Property
FilterDistortionDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FilterDistortionDeviceFilterTypeVisualization
C#
public FilterDistortionDeviceFilterTypeVisualization Visualization { get; set; }
Visual C++
public:
property FilterDistortionDeviceFilterTypeVisualization Visualization {
    FilterDistortionDeviceFilterTypeVisualization get ();
    void set (FilterDistortionDeviceFilterTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FilterDistortionDeviceFilterType Class


FilterDistortionDeviceFilterTypeRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceFilterTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceFilterTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceFilterTypeRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceFilterTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceFilterTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceFilterTypeRunTimePreset

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Members


FilterDistortionDeviceFilterTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset Members
FilterDistortionDeviceFilterTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceFilterTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceFilterTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Class


FilterDistortionDeviceFilterTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset Constructor
FilterDistortionDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceFilterTypeRunTimePreset()
Visual C++
public:
FilterDistortionDeviceFilterTypeRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceFilterTypeRunTimePreset = function();

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Class


FilterDistortionDeviceFilterTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset Methods
FilterDistortionDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceFilterTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Class


FilterDistortionDeviceFilterTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset Properties
FilterDistortionDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceFilterTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeRunTimePreset..::.Value Property
FilterDistortionDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceFilterTypeRunTimePreset Class


FilterDistortionDeviceFilterTypeVisualization Enumeration

[image]

.NET Framework Class Library
FilterDistortionDeviceFilterTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FilterDistortionDeviceFilterTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FilterDistortionDeviceFilterTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FilterDistortionDeviceFilterTypeVisualization
JavaScript
NRenoiseTools.FilterDistortionDeviceFilterTypeVisualization = function();
NRenoiseTools.FilterDistortionDeviceFilterTypeVisualization.createEnum('NRenoiseTools.FilterDistortionDeviceFilterTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDeviceInertia Class

[image]

.NET Framework Class Library
FilterDistortionDeviceInertia Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceInertia
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceInertia
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceInertia
JavaScript
NRenoiseTools.FilterDistortionDeviceInertia = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceInertia');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceInertia

See Also

FilterDistortionDeviceInertia Members


FilterDistortionDeviceInertia Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertia Members
FilterDistortionDeviceInertia Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceInertia type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceInertia |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceInertia Class


FilterDistortionDeviceInertia Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceInertia Constructor
FilterDistortionDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceInertia()
Visual C++
public:
FilterDistortionDeviceInertia()
JavaScript
NRenoiseTools.FilterDistortionDeviceInertia = function();

See Also

FilterDistortionDeviceInertia Class


FilterDistortionDeviceInertia Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertia Methods
FilterDistortionDeviceInertia Class See Also Send Feedback

The FilterDistortionDeviceInertia type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceInertia Class


FilterDistortionDeviceInertia Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertia Properties
FilterDistortionDeviceInertia Class See Also Send Feedback

The FilterDistortionDeviceInertia type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceInertia Class


MidiMappings Property

[image]

.NET Framework Class Library
FilterDistortionDeviceInertia..::.MidiMappings Property
FilterDistortionDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FilterDistortionDeviceInertia Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceInertia..::.Value Property
FilterDistortionDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceInertia Class


Visualization Property

[image]

.NET Framework Class Library
FilterDistortionDeviceInertia..::.Visualization Property
FilterDistortionDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FilterDistortionDeviceInertiaVisualization
C#
public FilterDistortionDeviceInertiaVisualization Visualization { get; set; }
Visual C++
public:
property FilterDistortionDeviceInertiaVisualization Visualization {
    FilterDistortionDeviceInertiaVisualization get ();
    void set (FilterDistortionDeviceInertiaVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FilterDistortionDeviceInertia Class


FilterDistortionDeviceInertiaRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceInertiaRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceInertiaRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceInertiaRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceInertiaRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceInertiaRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceInertiaRunTimePreset

See Also

FilterDistortionDeviceInertiaRunTimePreset Members


FilterDistortionDeviceInertiaRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset Members
FilterDistortionDeviceInertiaRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceInertiaRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceInertiaRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceInertiaRunTimePreset Class


FilterDistortionDeviceInertiaRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset Constructor
FilterDistortionDeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceInertiaRunTimePreset()
Visual C++
public:
FilterDistortionDeviceInertiaRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceInertiaRunTimePreset = function();

See Also

FilterDistortionDeviceInertiaRunTimePreset Class


FilterDistortionDeviceInertiaRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset Methods
FilterDistortionDeviceInertiaRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceInertiaRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceInertiaRunTimePreset Class


FilterDistortionDeviceInertiaRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset Properties
FilterDistortionDeviceInertiaRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceInertiaRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceInertiaRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceInertiaRunTimePreset..::.Value Property
FilterDistortionDeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceInertiaRunTimePreset Class


FilterDistortionDeviceInertiaVisualization Enumeration

[image]

.NET Framework Class Library
FilterDistortionDeviceInertiaVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FilterDistortionDeviceInertiaVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FilterDistortionDeviceInertiaVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FilterDistortionDeviceInertiaVisualization
JavaScript
NRenoiseTools.FilterDistortionDeviceInertiaVisualization = function();
NRenoiseTools.FilterDistortionDeviceInertiaVisualization.createEnum('NRenoiseTools.FilterDistortionDeviceInertiaVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDeviceResonance Class

[image]

.NET Framework Class Library
FilterDistortionDeviceResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceResonance
JavaScript
NRenoiseTools.FilterDistortionDeviceResonance = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceResonance

See Also

FilterDistortionDeviceResonance Members


FilterDistortionDeviceResonance Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonance Members
FilterDistortionDeviceResonance Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceResonance type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceResonance Class


FilterDistortionDeviceResonance Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceResonance Constructor
FilterDistortionDeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceResonance()
Visual C++
public:
FilterDistortionDeviceResonance()
JavaScript
NRenoiseTools.FilterDistortionDeviceResonance = function();

See Also

FilterDistortionDeviceResonance Class


FilterDistortionDeviceResonance Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonance Methods
FilterDistortionDeviceResonance Class See Also Send Feedback

The FilterDistortionDeviceResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceResonance Class


FilterDistortionDeviceResonance Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonance Properties
FilterDistortionDeviceResonance Class See Also Send Feedback

The FilterDistortionDeviceResonance type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FilterDistortionDeviceResonance Class


MidiMappings Property

[image]

.NET Framework Class Library
FilterDistortionDeviceResonance..::.MidiMappings Property
FilterDistortionDeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FilterDistortionDeviceResonance Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceResonance..::.Value Property
FilterDistortionDeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceResonance Class


Visualization Property

[image]

.NET Framework Class Library
FilterDistortionDeviceResonance..::.Visualization Property
FilterDistortionDeviceResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FilterDistortionDeviceResonanceVisualization
C#
public FilterDistortionDeviceResonanceVisualization Visualization { get; set; }
Visual C++
public:
property FilterDistortionDeviceResonanceVisualization Visualization {
    FilterDistortionDeviceResonanceVisualization get ();
    void set (FilterDistortionDeviceResonanceVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FilterDistortionDeviceResonance Class


FilterDistortionDeviceResonanceRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceResonanceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceResonanceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceResonanceRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceResonanceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceResonanceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceResonanceRunTimePreset

See Also

FilterDistortionDeviceResonanceRunTimePreset Members


FilterDistortionDeviceResonanceRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset Members
FilterDistortionDeviceResonanceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceResonanceRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceResonanceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceResonanceRunTimePreset Class


FilterDistortionDeviceResonanceRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset Constructor
FilterDistortionDeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceResonanceRunTimePreset()
Visual C++
public:
FilterDistortionDeviceResonanceRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceResonanceRunTimePreset = function();

See Also

FilterDistortionDeviceResonanceRunTimePreset Class


FilterDistortionDeviceResonanceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset Methods
FilterDistortionDeviceResonanceRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceResonanceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceResonanceRunTimePreset Class


FilterDistortionDeviceResonanceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset Properties
FilterDistortionDeviceResonanceRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceResonanceRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FilterDistortionDeviceResonanceRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FilterDistortionDeviceResonanceRunTimePreset..::.Value Property
FilterDistortionDeviceResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FilterDistortionDeviceResonanceRunTimePreset Class


FilterDistortionDeviceResonanceVisualization Enumeration

[image]

.NET Framework Class Library
FilterDistortionDeviceResonanceVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FilterDistortionDeviceResonanceVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FilterDistortionDeviceResonanceVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FilterDistortionDeviceResonanceVisualization
JavaScript
NRenoiseTools.FilterDistortionDeviceResonanceVisualization = function();
NRenoiseTools.FilterDistortionDeviceResonanceVisualization.createEnum('NRenoiseTools.FilterDistortionDeviceResonanceVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FilterDistortionDeviceRunTimePreset Class

[image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FilterDistortionDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FilterDistortionDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FilterDistortionDeviceRunTimePreset
JavaScript
NRenoiseTools.FilterDistortionDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FilterDistortionDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FilterDistortionDeviceRunTimePreset

See Also

FilterDistortionDeviceRunTimePreset Members


FilterDistortionDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset Members
FilterDistortionDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FilterDistortionDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
FilterDistortionDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

FilterDistortionDeviceRunTimePreset Class


FilterDistortionDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset Constructor
FilterDistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterDistortionDeviceRunTimePreset()
Visual C++
public:
FilterDistortionDeviceRunTimePreset()
JavaScript
NRenoiseTools.FilterDistortionDeviceRunTimePreset = function();

See Also

FilterDistortionDeviceRunTimePreset Class


FilterDistortionDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset Methods
FilterDistortionDeviceRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDistortionDeviceRunTimePreset Class


FilterDistortionDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset Properties
FilterDistortionDeviceRunTimePreset Class See Also Send Feedback

The FilterDistortionDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

FilterDistortionDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset..::.DeviceSlot Property
FilterDistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As FilterDistortionDeviceDeviceSlotRunTimePreset
C#
public FilterDistortionDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property FilterDistortionDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    FilterDistortionDeviceDeviceSlotRunTimePreset^ get ();
    void set (FilterDistortionDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

FilterDistortionDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
FilterDistortionDeviceRunTimePreset..::.type Property
FilterDistortionDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FilterDistortionDeviceRunTimePreset Class


FlangerDevice Class

[image]

.NET Framework Class Library
FlangerDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDevice
JavaScript
NRenoiseTools.FlangerDevice = function();

Type.createClass(
    'NRenoiseTools.FlangerDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDevice

See Also

FlangerDevice Members


FlangerDevice Members

[image] [image]

.NET Framework Class Library
FlangerDevice Members
FlangerDevice Class Constructors Methods Properties See Also Send Feedback

The FlangerDevice type exposes the following members.

Constructors

Name | Description
FlangerDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Amplitude |
Delay |
Dephase |
FeedBack |
FilterFreq |
FilterResonance |
FilterType |
IsActive |
IsSelected |
Rate |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

FlangerDevice Class


FlangerDevice Constructor

[image]

.NET Framework Class Library
FlangerDevice Constructor
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDevice()
Visual C++
public:
FlangerDevice()
JavaScript
NRenoiseTools.FlangerDevice = function();

See Also

FlangerDevice Class


FlangerDevice Methods

[image] [image]

.NET Framework Class Library
FlangerDevice Methods
FlangerDevice Class See Also Send Feedback

The FlangerDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDevice Class


FlangerDevice Properties

[image] [image]

.NET Framework Class Library
FlangerDevice Properties
FlangerDevice Class See Also Send Feedback

The FlangerDevice type exposes the following members.

Properties

Name | Description
Amount |
Amplitude |
Delay |
Dephase |
FeedBack |
FilterFreq |
FilterResonance |
FilterType |
IsActive |
IsSelected |
Rate |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

FlangerDevice Class


Amount Property

[image]

.NET Framework Class Library
FlangerDevice..::.Amount Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As FlangerDeviceAmount
C#
public FlangerDeviceAmount Amount { get; set; }
Visual C++
public:
property FlangerDeviceAmount^ Amount {
    FlangerDeviceAmount^ get ();
    void set (FlangerDeviceAmount^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

FlangerDevice Class


Amplitude Property

[image]

.NET Framework Class Library
FlangerDevice..::.Amplitude Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amplitude As FlangerDeviceAmplitude
C#
public FlangerDeviceAmplitude Amplitude { get; set; }
Visual C++
public:
property FlangerDeviceAmplitude^ Amplitude {
    FlangerDeviceAmplitude^ get ();
    void set (FlangerDeviceAmplitude^ value);
}
JavaScript
function get_amplitude();
function set_amplitude(value);

Remarks

See Also

FlangerDevice Class


Delay Property

[image]

.NET Framework Class Library
FlangerDevice..::.Delay Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As FlangerDeviceDelay
C#
public FlangerDeviceDelay Delay { get; set; }
Visual C++
public:
property FlangerDeviceDelay^ Delay {
    FlangerDeviceDelay^ get ();
    void set (FlangerDeviceDelay^ value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

FlangerDevice Class


Dephase Property

[image]

.NET Framework Class Library
FlangerDevice..::.Dephase Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Dephase As FlangerDeviceDephase
C#
public FlangerDeviceDephase Dephase { get; set; }
Visual C++
public:
property FlangerDeviceDephase^ Dephase {
    FlangerDeviceDephase^ get ();
    void set (FlangerDeviceDephase^ value);
}
JavaScript
function get_dephase();
function set_dephase(value);

Remarks

See Also

FlangerDevice Class


FeedBack Property

[image]

.NET Framework Class Library
FlangerDevice..::.FeedBack Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FeedBack As FlangerDeviceFeedBack
C#
public FlangerDeviceFeedBack FeedBack { get; set; }
Visual C++
public:
property FlangerDeviceFeedBack^ FeedBack {
    FlangerDeviceFeedBack^ get ();
    void set (FlangerDeviceFeedBack^ value);
}
JavaScript
function get_feedBack();
function set_feedBack(value);

Remarks

See Also

FlangerDevice Class


FilterFreq Property

[image]

.NET Framework Class Library
FlangerDevice..::.FilterFreq Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterFreq As FlangerDeviceFilterFreq
C#
public FlangerDeviceFilterFreq FilterFreq { get; set; }
Visual C++
public:
property FlangerDeviceFilterFreq^ FilterFreq {
    FlangerDeviceFilterFreq^ get ();
    void set (FlangerDeviceFilterFreq^ value);
}
JavaScript
function get_filterFreq();
function set_filterFreq(value);

Remarks

See Also

FlangerDevice Class


FilterResonance Property

[image]

.NET Framework Class Library
FlangerDevice..::.FilterResonance Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterResonance As FlangerDeviceFilterResonance
C#
public FlangerDeviceFilterResonance FilterResonance { get; set; }
Visual C++
public:
property FlangerDeviceFilterResonance^ FilterResonance {
    FlangerDeviceFilterResonance^ get ();
    void set (FlangerDeviceFilterResonance^ value);
}
JavaScript
function get_filterResonance();
function set_filterResonance(value);

Remarks

See Also

FlangerDevice Class


FilterType Property

[image]

.NET Framework Class Library
FlangerDevice..::.FilterType Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As FlangerDeviceFilterType
C#
public FlangerDeviceFilterType FilterType { get; set; }
Visual C++
public:
property FlangerDeviceFilterType^ FilterType {
    FlangerDeviceFilterType^ get ();
    void set (FlangerDeviceFilterType^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

FlangerDevice Class


IsActive Property

[image]

.NET Framework Class Library
FlangerDevice..::.IsActive Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

FlangerDevice Class


IsSelected Property

[image]

.NET Framework Class Library
FlangerDevice..::.IsSelected Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

FlangerDevice Class


Rate Property

[image]

.NET Framework Class Library
FlangerDevice..::.Rate Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Rate As FlangerDeviceRate
C#
public FlangerDeviceRate Rate { get; set; }
Visual C++
public:
property FlangerDeviceRate^ Rate {
    FlangerDeviceRate^ get ();
    void set (FlangerDeviceRate^ value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

FlangerDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
FlangerDevice..::.RunTimePresetA Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As FlangerDeviceRunTimePreset
C#
public FlangerDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property FlangerDeviceRunTimePreset^ RunTimePresetA {
    FlangerDeviceRunTimePreset^ get ();
    void set (FlangerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

FlangerDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
FlangerDevice..::.RunTimePresetB Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As FlangerDeviceRunTimePreset
C#
public FlangerDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property FlangerDeviceRunTimePreset^ RunTimePresetB {
    FlangerDeviceRunTimePreset^ get ();
    void set (FlangerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

FlangerDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
FlangerDevice..::.SelectedPresetIsModified Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

FlangerDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
FlangerDevice..::.SelectedPresetName Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

FlangerDevice Class


type Property

[image]

.NET Framework Class Library
FlangerDevice..::.type Property
FlangerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FlangerDevice Class


FlangerDeviceAmount Class

[image]

.NET Framework Class Library
FlangerDeviceAmount Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceAmount
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceAmount
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceAmount
JavaScript
NRenoiseTools.FlangerDeviceAmount = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceAmount');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceAmount

See Also

FlangerDeviceAmount Members


FlangerDeviceAmount Members

[image] [image]

.NET Framework Class Library
FlangerDeviceAmount Members
FlangerDeviceAmount Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceAmount type exposes the following members.

Constructors

Name | Description
FlangerDeviceAmount |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceAmount Class


FlangerDeviceAmount Constructor

[image]

.NET Framework Class Library
FlangerDeviceAmount Constructor
FlangerDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceAmount()
Visual C++
public:
FlangerDeviceAmount()
JavaScript
NRenoiseTools.FlangerDeviceAmount = function();

See Also

FlangerDeviceAmount Class


FlangerDeviceAmount Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceAmount Methods
FlangerDeviceAmount Class See Also Send Feedback

The FlangerDeviceAmount type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceAmount Class


FlangerDeviceAmount Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceAmount Properties
FlangerDeviceAmount Class See Also Send Feedback

The FlangerDeviceAmount type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceAmount Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceAmount..::.MidiMappings Property
FlangerDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceAmount Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceAmount..::.Value Property
FlangerDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceAmount Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceAmount..::.Visualization Property
FlangerDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceAmountVisualization
C#
public FlangerDeviceAmountVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceAmountVisualization Visualization {
    FlangerDeviceAmountVisualization get ();
    void set (FlangerDeviceAmountVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceAmount Class


FlangerDeviceAmountRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceAmountRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceAmountRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceAmountRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceAmountRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceAmountRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceAmountRunTimePreset

See Also

FlangerDeviceAmountRunTimePreset Members


FlangerDeviceAmountRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset Members
FlangerDeviceAmountRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceAmountRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceAmountRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceAmountRunTimePreset Class


FlangerDeviceAmountRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset Constructor
FlangerDeviceAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceAmountRunTimePreset()
Visual C++
public:
FlangerDeviceAmountRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceAmountRunTimePreset = function();

See Also

FlangerDeviceAmountRunTimePreset Class


FlangerDeviceAmountRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset Methods
FlangerDeviceAmountRunTimePreset Class See Also Send Feedback

The FlangerDeviceAmountRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceAmountRunTimePreset Class


FlangerDeviceAmountRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset Properties
FlangerDeviceAmountRunTimePreset Class See Also Send Feedback

The FlangerDeviceAmountRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceAmountRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceAmountRunTimePreset..::.Value Property
FlangerDeviceAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceAmountRunTimePreset Class


FlangerDeviceAmountVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceAmountVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceAmountVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceAmountVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceAmountVisualization
JavaScript
NRenoiseTools.FlangerDeviceAmountVisualization = function();
NRenoiseTools.FlangerDeviceAmountVisualization.createEnum('NRenoiseTools.FlangerDeviceAmountVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceAmplitude Class

[image]

.NET Framework Class Library
FlangerDeviceAmplitude Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceAmplitude
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceAmplitude
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceAmplitude
JavaScript
NRenoiseTools.FlangerDeviceAmplitude = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceAmplitude');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceAmplitude

See Also

FlangerDeviceAmplitude Members


FlangerDeviceAmplitude Members

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitude Members
FlangerDeviceAmplitude Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceAmplitude type exposes the following members.

Constructors

Name | Description
FlangerDeviceAmplitude |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceAmplitude Class


FlangerDeviceAmplitude Constructor

[image]

.NET Framework Class Library
FlangerDeviceAmplitude Constructor
FlangerDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceAmplitude()
Visual C++
public:
FlangerDeviceAmplitude()
JavaScript
NRenoiseTools.FlangerDeviceAmplitude = function();

See Also

FlangerDeviceAmplitude Class


FlangerDeviceAmplitude Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitude Methods
FlangerDeviceAmplitude Class See Also Send Feedback

The FlangerDeviceAmplitude type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceAmplitude Class


FlangerDeviceAmplitude Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitude Properties
FlangerDeviceAmplitude Class See Also Send Feedback

The FlangerDeviceAmplitude type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceAmplitude Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceAmplitude..::.MidiMappings Property
FlangerDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceAmplitude Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceAmplitude..::.Value Property
FlangerDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceAmplitude Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceAmplitude..::.Visualization Property
FlangerDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceAmplitudeVisualization
C#
public FlangerDeviceAmplitudeVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceAmplitudeVisualization Visualization {
    FlangerDeviceAmplitudeVisualization get ();
    void set (FlangerDeviceAmplitudeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceAmplitude Class


FlangerDeviceAmplitudeRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceAmplitudeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceAmplitudeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceAmplitudeRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceAmplitudeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceAmplitudeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceAmplitudeRunTimePreset

See Also

FlangerDeviceAmplitudeRunTimePreset Members


FlangerDeviceAmplitudeRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset Members
FlangerDeviceAmplitudeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceAmplitudeRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceAmplitudeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceAmplitudeRunTimePreset Class


FlangerDeviceAmplitudeRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset Constructor
FlangerDeviceAmplitudeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceAmplitudeRunTimePreset()
Visual C++
public:
FlangerDeviceAmplitudeRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceAmplitudeRunTimePreset = function();

See Also

FlangerDeviceAmplitudeRunTimePreset Class


FlangerDeviceAmplitudeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset Methods
FlangerDeviceAmplitudeRunTimePreset Class See Also Send Feedback

The FlangerDeviceAmplitudeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceAmplitudeRunTimePreset Class


FlangerDeviceAmplitudeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset Properties
FlangerDeviceAmplitudeRunTimePreset Class See Also Send Feedback

The FlangerDeviceAmplitudeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceAmplitudeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceAmplitudeRunTimePreset..::.Value Property
FlangerDeviceAmplitudeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceAmplitudeRunTimePreset Class


FlangerDeviceAmplitudeVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceAmplitudeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceAmplitudeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceAmplitudeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceAmplitudeVisualization
JavaScript
NRenoiseTools.FlangerDeviceAmplitudeVisualization = function();
NRenoiseTools.FlangerDeviceAmplitudeVisualization.createEnum('NRenoiseTools.FlangerDeviceAmplitudeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceDelay Class

[image]

.NET Framework Class Library
FlangerDeviceDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceDelay
JavaScript
NRenoiseTools.FlangerDeviceDelay = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceDelay

See Also

FlangerDeviceDelay Members


FlangerDeviceDelay Members

[image] [image]

.NET Framework Class Library
FlangerDeviceDelay Members
FlangerDeviceDelay Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceDelay type exposes the following members.

Constructors

Name | Description
FlangerDeviceDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceDelay Class


FlangerDeviceDelay Constructor

[image]

.NET Framework Class Library
FlangerDeviceDelay Constructor
FlangerDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceDelay()
Visual C++
public:
FlangerDeviceDelay()
JavaScript
NRenoiseTools.FlangerDeviceDelay = function();

See Also

FlangerDeviceDelay Class


FlangerDeviceDelay Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceDelay Methods
FlangerDeviceDelay Class See Also Send Feedback

The FlangerDeviceDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceDelay Class


FlangerDeviceDelay Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceDelay Properties
FlangerDeviceDelay Class See Also Send Feedback

The FlangerDeviceDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceDelay..::.MidiMappings Property
FlangerDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceDelay Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceDelay..::.Value Property
FlangerDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceDelay Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceDelay..::.Visualization Property
FlangerDeviceDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceDelayVisualization
C#
public FlangerDeviceDelayVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceDelayVisualization Visualization {
    FlangerDeviceDelayVisualization get ();
    void set (FlangerDeviceDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceDelay Class


FlangerDeviceDelayRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceDelayRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceDelayRunTimePreset

See Also

FlangerDeviceDelayRunTimePreset Members


FlangerDeviceDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset Members
FlangerDeviceDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceDelayRunTimePreset Class


FlangerDeviceDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset Constructor
FlangerDeviceDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceDelayRunTimePreset()
Visual C++
public:
FlangerDeviceDelayRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceDelayRunTimePreset = function();

See Also

FlangerDeviceDelayRunTimePreset Class


FlangerDeviceDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset Methods
FlangerDeviceDelayRunTimePreset Class See Also Send Feedback

The FlangerDeviceDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceDelayRunTimePreset Class


FlangerDeviceDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset Properties
FlangerDeviceDelayRunTimePreset Class See Also Send Feedback

The FlangerDeviceDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceDelayRunTimePreset..::.Value Property
FlangerDeviceDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceDelayRunTimePreset Class


FlangerDeviceDelayVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceDelayVisualization
JavaScript
NRenoiseTools.FlangerDeviceDelayVisualization = function();
NRenoiseTools.FlangerDeviceDelayVisualization.createEnum('NRenoiseTools.FlangerDeviceDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceDephase Class

[image]

.NET Framework Class Library
FlangerDeviceDephase Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceDephase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceDephase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceDephase
JavaScript
NRenoiseTools.FlangerDeviceDephase = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceDephase');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceDephase

See Also

FlangerDeviceDephase Members


FlangerDeviceDephase Members

[image] [image]

.NET Framework Class Library
FlangerDeviceDephase Members
FlangerDeviceDephase Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceDephase type exposes the following members.

Constructors

Name | Description
FlangerDeviceDephase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceDephase Class


FlangerDeviceDephase Constructor

[image]

.NET Framework Class Library
FlangerDeviceDephase Constructor
FlangerDeviceDephase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceDephase()
Visual C++
public:
FlangerDeviceDephase()
JavaScript
NRenoiseTools.FlangerDeviceDephase = function();

See Also

FlangerDeviceDephase Class


FlangerDeviceDephase Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceDephase Methods
FlangerDeviceDephase Class See Also Send Feedback

The FlangerDeviceDephase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceDephase Class


FlangerDeviceDephase Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceDephase Properties
FlangerDeviceDephase Class See Also Send Feedback

The FlangerDeviceDephase type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceDephase Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceDephase..::.MidiMappings Property
FlangerDeviceDephase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceDephase Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceDephase..::.Value Property
FlangerDeviceDephase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceDephase Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceDephase..::.Visualization Property
FlangerDeviceDephase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceDephaseVisualization
C#
public FlangerDeviceDephaseVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceDephaseVisualization Visualization {
    FlangerDeviceDephaseVisualization get ();
    void set (FlangerDeviceDephaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceDephase Class


FlangerDeviceDephaseRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceDephaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceDephaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceDephaseRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceDephaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceDephaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceDephaseRunTimePreset

See Also

FlangerDeviceDephaseRunTimePreset Members


FlangerDeviceDephaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset Members
FlangerDeviceDephaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceDephaseRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceDephaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceDephaseRunTimePreset Class


FlangerDeviceDephaseRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset Constructor
FlangerDeviceDephaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceDephaseRunTimePreset()
Visual C++
public:
FlangerDeviceDephaseRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceDephaseRunTimePreset = function();

See Also

FlangerDeviceDephaseRunTimePreset Class


FlangerDeviceDephaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset Methods
FlangerDeviceDephaseRunTimePreset Class See Also Send Feedback

The FlangerDeviceDephaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceDephaseRunTimePreset Class


FlangerDeviceDephaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset Properties
FlangerDeviceDephaseRunTimePreset Class See Also Send Feedback

The FlangerDeviceDephaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceDephaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceDephaseRunTimePreset..::.Value Property
FlangerDeviceDephaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceDephaseRunTimePreset Class


FlangerDeviceDephaseVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceDephaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceDephaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceDephaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceDephaseVisualization
JavaScript
NRenoiseTools.FlangerDeviceDephaseVisualization = function();
NRenoiseTools.FlangerDeviceDephaseVisualization.createEnum('NRenoiseTools.FlangerDeviceDephaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceDeviceSlotRunTimePreset

See Also

FlangerDeviceDeviceSlotRunTimePreset Members


FlangerDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset Members
FlangerDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Amplitude |
Delay |
Dephase |
FeedBack |
FilterFreq |
FilterResonance |
FilterType |
Rate |
type |

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FlangerDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset Constructor
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceDeviceSlotRunTimePreset()
Visual C++
public:
FlangerDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceDeviceSlotRunTimePreset = function();

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FlangerDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset Methods
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The FlangerDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FlangerDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset Properties
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The FlangerDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Amount |
Amplitude |
Delay |
Dephase |
FeedBack |
FilterFreq |
FilterResonance |
FilterType |
Rate |
type |

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


Amount Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.Amount Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As FlangerDeviceAmountRunTimePreset
C#
public FlangerDeviceAmountRunTimePreset Amount { get; set; }
Visual C++
public:
property FlangerDeviceAmountRunTimePreset^ Amount {
    FlangerDeviceAmountRunTimePreset^ get ();
    void set (FlangerDeviceAmountRunTimePreset^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


Amplitude Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.Amplitude Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amplitude As FlangerDeviceAmplitudeRunTimePreset
C#
public FlangerDeviceAmplitudeRunTimePreset Amplitude { get; set; }
Visual C++
public:
property FlangerDeviceAmplitudeRunTimePreset^ Amplitude {
    FlangerDeviceAmplitudeRunTimePreset^ get ();
    void set (FlangerDeviceAmplitudeRunTimePreset^ value);
}
JavaScript
function get_amplitude();
function set_amplitude(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


Delay Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.Delay Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As FlangerDeviceDelayRunTimePreset
C#
public FlangerDeviceDelayRunTimePreset Delay { get; set; }
Visual C++
public:
property FlangerDeviceDelayRunTimePreset^ Delay {
    FlangerDeviceDelayRunTimePreset^ get ();
    void set (FlangerDeviceDelayRunTimePreset^ value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


Dephase Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.Dephase Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Dephase As FlangerDeviceDephaseRunTimePreset
C#
public FlangerDeviceDephaseRunTimePreset Dephase { get; set; }
Visual C++
public:
property FlangerDeviceDephaseRunTimePreset^ Dephase {
    FlangerDeviceDephaseRunTimePreset^ get ();
    void set (FlangerDeviceDephaseRunTimePreset^ value);
}
JavaScript
function get_dephase();
function set_dephase(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FeedBack Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.FeedBack Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FeedBack As FlangerDeviceFeedBackRunTimePreset
C#
public FlangerDeviceFeedBackRunTimePreset FeedBack { get; set; }
Visual C++
public:
property FlangerDeviceFeedBackRunTimePreset^ FeedBack {
    FlangerDeviceFeedBackRunTimePreset^ get ();
    void set (FlangerDeviceFeedBackRunTimePreset^ value);
}
JavaScript
function get_feedBack();
function set_feedBack(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FilterFreq Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.FilterFreq Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterFreq As FlangerDeviceFilterFreqRunTimePreset
C#
public FlangerDeviceFilterFreqRunTimePreset FilterFreq { get; set; }
Visual C++
public:
property FlangerDeviceFilterFreqRunTimePreset^ FilterFreq {
    FlangerDeviceFilterFreqRunTimePreset^ get ();
    void set (FlangerDeviceFilterFreqRunTimePreset^ value);
}
JavaScript
function get_filterFreq();
function set_filterFreq(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FilterResonance Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.FilterResonance Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterResonance As FlangerDeviceFilterResonanceRunTimePreset
C#
public FlangerDeviceFilterResonanceRunTimePreset FilterResonance { get; set; }
Visual C++
public:
property FlangerDeviceFilterResonanceRunTimePreset^ FilterResonance {
    FlangerDeviceFilterResonanceRunTimePreset^ get ();
    void set (FlangerDeviceFilterResonanceRunTimePreset^ value);
}
JavaScript
function get_filterResonance();
function set_filterResonance(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FilterType Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.FilterType Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterType As FlangerDeviceFilterTypeRunTimePreset
C#
public FlangerDeviceFilterTypeRunTimePreset FilterType { get; set; }
Visual C++
public:
property FlangerDeviceFilterTypeRunTimePreset^ FilterType {
    FlangerDeviceFilterTypeRunTimePreset^ get ();
    void set (FlangerDeviceFilterTypeRunTimePreset^ value);
}
JavaScript
function get_filterType();
function set_filterType(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


Rate Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.Rate Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Rate As FlangerDeviceRateRunTimePreset
C#
public FlangerDeviceRateRunTimePreset Rate { get; set; }
Visual C++
public:
property FlangerDeviceRateRunTimePreset^ Rate {
    FlangerDeviceRateRunTimePreset^ get ();
    void set (FlangerDeviceRateRunTimePreset^ value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
FlangerDeviceDeviceSlotRunTimePreset..::.type Property
FlangerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FlangerDeviceDeviceSlotRunTimePreset Class


FlangerDeviceFeedBack Class

[image]

.NET Framework Class Library
FlangerDeviceFeedBack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFeedBack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFeedBack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFeedBack
JavaScript
NRenoiseTools.FlangerDeviceFeedBack = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFeedBack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFeedBack

See Also

FlangerDeviceFeedBack Members


FlangerDeviceFeedBack Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBack Members
FlangerDeviceFeedBack Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFeedBack type exposes the following members.

Constructors

Name | Description
FlangerDeviceFeedBack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFeedBack Class


FlangerDeviceFeedBack Constructor

[image]

.NET Framework Class Library
FlangerDeviceFeedBack Constructor
FlangerDeviceFeedBack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFeedBack()
Visual C++
public:
FlangerDeviceFeedBack()
JavaScript
NRenoiseTools.FlangerDeviceFeedBack = function();

See Also

FlangerDeviceFeedBack Class


FlangerDeviceFeedBack Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBack Methods
FlangerDeviceFeedBack Class See Also Send Feedback

The FlangerDeviceFeedBack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFeedBack Class


FlangerDeviceFeedBack Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBack Properties
FlangerDeviceFeedBack Class See Also Send Feedback

The FlangerDeviceFeedBack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFeedBack Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceFeedBack..::.MidiMappings Property
FlangerDeviceFeedBack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceFeedBack Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFeedBack..::.Value Property
FlangerDeviceFeedBack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFeedBack Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceFeedBack..::.Visualization Property
FlangerDeviceFeedBack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceFeedBackVisualization
C#
public FlangerDeviceFeedBackVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceFeedBackVisualization Visualization {
    FlangerDeviceFeedBackVisualization get ();
    void set (FlangerDeviceFeedBackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceFeedBack Class


FlangerDeviceFeedBackRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFeedBackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFeedBackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFeedBackRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceFeedBackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFeedBackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFeedBackRunTimePreset

See Also

FlangerDeviceFeedBackRunTimePreset Members


FlangerDeviceFeedBackRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset Members
FlangerDeviceFeedBackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFeedBackRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceFeedBackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceFeedBackRunTimePreset Class


FlangerDeviceFeedBackRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset Constructor
FlangerDeviceFeedBackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFeedBackRunTimePreset()
Visual C++
public:
FlangerDeviceFeedBackRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceFeedBackRunTimePreset = function();

See Also

FlangerDeviceFeedBackRunTimePreset Class


FlangerDeviceFeedBackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset Methods
FlangerDeviceFeedBackRunTimePreset Class See Also Send Feedback

The FlangerDeviceFeedBackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFeedBackRunTimePreset Class


FlangerDeviceFeedBackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset Properties
FlangerDeviceFeedBackRunTimePreset Class See Also Send Feedback

The FlangerDeviceFeedBackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceFeedBackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFeedBackRunTimePreset..::.Value Property
FlangerDeviceFeedBackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFeedBackRunTimePreset Class


FlangerDeviceFeedBackVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceFeedBackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceFeedBackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceFeedBackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceFeedBackVisualization
JavaScript
NRenoiseTools.FlangerDeviceFeedBackVisualization = function();
NRenoiseTools.FlangerDeviceFeedBackVisualization.createEnum('NRenoiseTools.FlangerDeviceFeedBackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceFilterFreq Class

[image]

.NET Framework Class Library
FlangerDeviceFilterFreq Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterFreq
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterFreq
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterFreq
JavaScript
NRenoiseTools.FlangerDeviceFilterFreq = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterFreq');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterFreq

See Also

FlangerDeviceFilterFreq Members


FlangerDeviceFilterFreq Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreq Members
FlangerDeviceFilterFreq Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterFreq type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterFreq |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterFreq Class


FlangerDeviceFilterFreq Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterFreq Constructor
FlangerDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterFreq()
Visual C++
public:
FlangerDeviceFilterFreq()
JavaScript
NRenoiseTools.FlangerDeviceFilterFreq = function();

See Also

FlangerDeviceFilterFreq Class


FlangerDeviceFilterFreq Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreq Methods
FlangerDeviceFilterFreq Class See Also Send Feedback

The FlangerDeviceFilterFreq type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterFreq Class


FlangerDeviceFilterFreq Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreq Properties
FlangerDeviceFilterFreq Class See Also Send Feedback

The FlangerDeviceFilterFreq type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterFreq Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceFilterFreq..::.MidiMappings Property
FlangerDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceFilterFreq Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterFreq..::.Value Property
FlangerDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterFreq Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceFilterFreq..::.Visualization Property
FlangerDeviceFilterFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceFilterFreqVisualization
C#
public FlangerDeviceFilterFreqVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceFilterFreqVisualization Visualization {
    FlangerDeviceFilterFreqVisualization get ();
    void set (FlangerDeviceFilterFreqVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceFilterFreq Class


FlangerDeviceFilterFreqRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterFreqRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterFreqRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterFreqRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceFilterFreqRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterFreqRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterFreqRunTimePreset

See Also

FlangerDeviceFilterFreqRunTimePreset Members


FlangerDeviceFilterFreqRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset Members
FlangerDeviceFilterFreqRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterFreqRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterFreqRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterFreqRunTimePreset Class


FlangerDeviceFilterFreqRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset Constructor
FlangerDeviceFilterFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterFreqRunTimePreset()
Visual C++
public:
FlangerDeviceFilterFreqRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceFilterFreqRunTimePreset = function();

See Also

FlangerDeviceFilterFreqRunTimePreset Class


FlangerDeviceFilterFreqRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset Methods
FlangerDeviceFilterFreqRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterFreqRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterFreqRunTimePreset Class


FlangerDeviceFilterFreqRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset Properties
FlangerDeviceFilterFreqRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterFreqRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterFreqRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterFreqRunTimePreset..::.Value Property
FlangerDeviceFilterFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterFreqRunTimePreset Class


FlangerDeviceFilterFreqVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceFilterFreqVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceFilterFreqVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceFilterFreqVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceFilterFreqVisualization
JavaScript
NRenoiseTools.FlangerDeviceFilterFreqVisualization = function();
NRenoiseTools.FlangerDeviceFilterFreqVisualization.createEnum('NRenoiseTools.FlangerDeviceFilterFreqVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceFilterResonance Class

[image]

.NET Framework Class Library
FlangerDeviceFilterResonance Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterResonance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterResonance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterResonance
JavaScript
NRenoiseTools.FlangerDeviceFilterResonance = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterResonance');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterResonance

See Also

FlangerDeviceFilterResonance Members


FlangerDeviceFilterResonance Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonance Members
FlangerDeviceFilterResonance Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterResonance type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterResonance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterResonance Class


FlangerDeviceFilterResonance Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterResonance Constructor
FlangerDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterResonance()
Visual C++
public:
FlangerDeviceFilterResonance()
JavaScript
NRenoiseTools.FlangerDeviceFilterResonance = function();

See Also

FlangerDeviceFilterResonance Class


FlangerDeviceFilterResonance Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonance Methods
FlangerDeviceFilterResonance Class See Also Send Feedback

The FlangerDeviceFilterResonance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterResonance Class


FlangerDeviceFilterResonance Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonance Properties
FlangerDeviceFilterResonance Class See Also Send Feedback

The FlangerDeviceFilterResonance type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterResonance Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceFilterResonance..::.MidiMappings Property
FlangerDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceFilterResonance Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterResonance..::.Value Property
FlangerDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterResonance Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceFilterResonance..::.Visualization Property
FlangerDeviceFilterResonance Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceFilterResonanceVisualization
C#
public FlangerDeviceFilterResonanceVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceFilterResonanceVisualization Visualization {
    FlangerDeviceFilterResonanceVisualization get ();
    void set (FlangerDeviceFilterResonanceVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceFilterResonance Class


FlangerDeviceFilterResonanceRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterResonanceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterResonanceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterResonanceRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceFilterResonanceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterResonanceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterResonanceRunTimePreset

See Also

FlangerDeviceFilterResonanceRunTimePreset Members


FlangerDeviceFilterResonanceRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset Members
FlangerDeviceFilterResonanceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterResonanceRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterResonanceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterResonanceRunTimePreset Class


FlangerDeviceFilterResonanceRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset Constructor
FlangerDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterResonanceRunTimePreset()
Visual C++
public:
FlangerDeviceFilterResonanceRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceFilterResonanceRunTimePreset = function();

See Also

FlangerDeviceFilterResonanceRunTimePreset Class


FlangerDeviceFilterResonanceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset Methods
FlangerDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterResonanceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterResonanceRunTimePreset Class


FlangerDeviceFilterResonanceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset Properties
FlangerDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterResonanceRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterResonanceRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterResonanceRunTimePreset..::.Value Property
FlangerDeviceFilterResonanceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterResonanceRunTimePreset Class


FlangerDeviceFilterResonanceVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceFilterResonanceVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceFilterResonanceVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceFilterResonanceVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceFilterResonanceVisualization
JavaScript
NRenoiseTools.FlangerDeviceFilterResonanceVisualization = function();
NRenoiseTools.FlangerDeviceFilterResonanceVisualization.createEnum('NRenoiseTools.FlangerDeviceFilterResonanceVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceFilterType Class

[image]

.NET Framework Class Library
FlangerDeviceFilterType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterType
JavaScript
NRenoiseTools.FlangerDeviceFilterType = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterType

See Also

FlangerDeviceFilterType Members


FlangerDeviceFilterType Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterType Members
FlangerDeviceFilterType Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterType type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterType Class


FlangerDeviceFilterType Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterType Constructor
FlangerDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterType()
Visual C++
public:
FlangerDeviceFilterType()
JavaScript
NRenoiseTools.FlangerDeviceFilterType = function();

See Also

FlangerDeviceFilterType Class


FlangerDeviceFilterType Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterType Methods
FlangerDeviceFilterType Class See Also Send Feedback

The FlangerDeviceFilterType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterType Class


FlangerDeviceFilterType Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterType Properties
FlangerDeviceFilterType Class See Also Send Feedback

The FlangerDeviceFilterType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceFilterType Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceFilterType..::.MidiMappings Property
FlangerDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceFilterType Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterType..::.Value Property
FlangerDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterType Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceFilterType..::.Visualization Property
FlangerDeviceFilterType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceFilterTypeVisualization
C#
public FlangerDeviceFilterTypeVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceFilterTypeVisualization Visualization {
    FlangerDeviceFilterTypeVisualization get ();
    void set (FlangerDeviceFilterTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceFilterType Class


FlangerDeviceFilterTypeRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceFilterTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceFilterTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceFilterTypeRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceFilterTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceFilterTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceFilterTypeRunTimePreset

See Also

FlangerDeviceFilterTypeRunTimePreset Members


FlangerDeviceFilterTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset Members
FlangerDeviceFilterTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceFilterTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceFilterTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterTypeRunTimePreset Class


FlangerDeviceFilterTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset Constructor
FlangerDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceFilterTypeRunTimePreset()
Visual C++
public:
FlangerDeviceFilterTypeRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceFilterTypeRunTimePreset = function();

See Also

FlangerDeviceFilterTypeRunTimePreset Class


FlangerDeviceFilterTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset Methods
FlangerDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceFilterTypeRunTimePreset Class


FlangerDeviceFilterTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset Properties
FlangerDeviceFilterTypeRunTimePreset Class See Also Send Feedback

The FlangerDeviceFilterTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceFilterTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceFilterTypeRunTimePreset..::.Value Property
FlangerDeviceFilterTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceFilterTypeRunTimePreset Class


FlangerDeviceFilterTypeVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceFilterTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceFilterTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceFilterTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceFilterTypeVisualization
JavaScript
NRenoiseTools.FlangerDeviceFilterTypeVisualization = function();
NRenoiseTools.FlangerDeviceFilterTypeVisualization.createEnum('NRenoiseTools.FlangerDeviceFilterTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceRate Class

[image]

.NET Framework Class Library
FlangerDeviceRate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceRate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceRate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceRate
JavaScript
NRenoiseTools.FlangerDeviceRate = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceRate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceRate

See Also

FlangerDeviceRate Members


FlangerDeviceRate Members

[image] [image]

.NET Framework Class Library
FlangerDeviceRate Members
FlangerDeviceRate Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceRate type exposes the following members.

Constructors

Name | Description
FlangerDeviceRate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceRate Class


FlangerDeviceRate Constructor

[image]

.NET Framework Class Library
FlangerDeviceRate Constructor
FlangerDeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceRate()
Visual C++
public:
FlangerDeviceRate()
JavaScript
NRenoiseTools.FlangerDeviceRate = function();

See Also

FlangerDeviceRate Class


FlangerDeviceRate Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceRate Methods
FlangerDeviceRate Class See Also Send Feedback

The FlangerDeviceRate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceRate Class


FlangerDeviceRate Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceRate Properties
FlangerDeviceRate Class See Also Send Feedback

The FlangerDeviceRate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

FlangerDeviceRate Class


MidiMappings Property

[image]

.NET Framework Class Library
FlangerDeviceRate..::.MidiMappings Property
FlangerDeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

FlangerDeviceRate Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceRate..::.Value Property
FlangerDeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceRate Class


Visualization Property

[image]

.NET Framework Class Library
FlangerDeviceRate..::.Visualization Property
FlangerDeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As FlangerDeviceRateVisualization
C#
public FlangerDeviceRateVisualization Visualization { get; set; }
Visual C++
public:
property FlangerDeviceRateVisualization Visualization {
    FlangerDeviceRateVisualization get ();
    void set (FlangerDeviceRateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

FlangerDeviceRate Class


FlangerDeviceRateRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceRateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceRateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceRateRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceRateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceRateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceRateRunTimePreset

See Also

FlangerDeviceRateRunTimePreset Members


FlangerDeviceRateRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset Members
FlangerDeviceRateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceRateRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceRateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

FlangerDeviceRateRunTimePreset Class


FlangerDeviceRateRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset Constructor
FlangerDeviceRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceRateRunTimePreset()
Visual C++
public:
FlangerDeviceRateRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceRateRunTimePreset = function();

See Also

FlangerDeviceRateRunTimePreset Class


FlangerDeviceRateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset Methods
FlangerDeviceRateRunTimePreset Class See Also Send Feedback

The FlangerDeviceRateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceRateRunTimePreset Class


FlangerDeviceRateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset Properties
FlangerDeviceRateRunTimePreset Class See Also Send Feedback

The FlangerDeviceRateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

FlangerDeviceRateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
FlangerDeviceRateRunTimePreset..::.Value Property
FlangerDeviceRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

FlangerDeviceRateRunTimePreset Class


FlangerDeviceRateVisualization Enumeration

[image]

.NET Framework Class Library
FlangerDeviceRateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration FlangerDeviceRateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum FlangerDeviceRateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class FlangerDeviceRateVisualization
JavaScript
NRenoiseTools.FlangerDeviceRateVisualization = function();
NRenoiseTools.FlangerDeviceRateVisualization.createEnum('NRenoiseTools.FlangerDeviceRateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


FlangerDeviceRunTimePreset Class

[image]

.NET Framework Class Library
FlangerDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class FlangerDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class FlangerDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class FlangerDeviceRunTimePreset
JavaScript
NRenoiseTools.FlangerDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.FlangerDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.FlangerDeviceRunTimePreset

See Also

FlangerDeviceRunTimePreset Members


FlangerDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
FlangerDeviceRunTimePreset Members
FlangerDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The FlangerDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
FlangerDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

FlangerDeviceRunTimePreset Class


FlangerDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
FlangerDeviceRunTimePreset Constructor
FlangerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlangerDeviceRunTimePreset()
Visual C++
public:
FlangerDeviceRunTimePreset()
JavaScript
NRenoiseTools.FlangerDeviceRunTimePreset = function();

See Also

FlangerDeviceRunTimePreset Class


FlangerDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
FlangerDeviceRunTimePreset Methods
FlangerDeviceRunTimePreset Class See Also Send Feedback

The FlangerDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlangerDeviceRunTimePreset Class


FlangerDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
FlangerDeviceRunTimePreset Properties
FlangerDeviceRunTimePreset Class See Also Send Feedback

The FlangerDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

FlangerDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
FlangerDeviceRunTimePreset..::.DeviceSlot Property
FlangerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As FlangerDeviceDeviceSlotRunTimePreset
C#
public FlangerDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property FlangerDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    FlangerDeviceDeviceSlotRunTimePreset^ get ();
    void set (FlangerDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

FlangerDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
FlangerDeviceRunTimePreset..::.type Property
FlangerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FlangerDeviceRunTimePreset Class


GainerDevice Class

[image]

.NET Framework Class Library
GainerDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDevice
JavaScript
NRenoiseTools.GainerDevice = function();

Type.createClass(
    'NRenoiseTools.GainerDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDevice

See Also

GainerDevice Members


GainerDevice Members

[image] [image]

.NET Framework Class Library
GainerDevice Members
GainerDevice Class Constructors Methods Properties See Also Send Feedback

The GainerDevice type exposes the following members.

Constructors

Name | Description
GainerDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
LPhaseInvert |
Panning |
RPhaseInvert |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Volume |

See Also

GainerDevice Class


GainerDevice Constructor

[image]

.NET Framework Class Library
GainerDevice Constructor
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDevice()
Visual C++
public:
GainerDevice()
JavaScript
NRenoiseTools.GainerDevice = function();

See Also

GainerDevice Class


GainerDevice Methods

[image] [image]

.NET Framework Class Library
GainerDevice Methods
GainerDevice Class See Also Send Feedback

The GainerDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDevice Class


GainerDevice Properties

[image] [image]

.NET Framework Class Library
GainerDevice Properties
GainerDevice Class See Also Send Feedback

The GainerDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
LPhaseInvert |
Panning |
RPhaseInvert |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Volume |

See Also

GainerDevice Class


IsActive Property

[image]

.NET Framework Class Library
GainerDevice..::.IsActive Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

GainerDevice Class


IsSelected Property

[image]

.NET Framework Class Library
GainerDevice..::.IsSelected Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

GainerDevice Class


LPhaseInvert Property

[image]

.NET Framework Class Library
GainerDevice..::.LPhaseInvert Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPhaseInvert As Boolean
C#
public bool LPhaseInvert { get; set; }
Visual C++
public:
property bool LPhaseInvert {
    bool get ();
    void set (bool value);
}
JavaScript
function get_lPhaseInvert();
function set_lPhaseInvert(value);

Remarks

See Also

GainerDevice Class


Panning Property

[image]

.NET Framework Class Library
GainerDevice..::.Panning Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As GainerDevicePanning
C#
public GainerDevicePanning Panning { get; set; }
Visual C++
public:
property GainerDevicePanning^ Panning {
    GainerDevicePanning^ get ();
    void set (GainerDevicePanning^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

GainerDevice Class


RPhaseInvert Property

[image]

.NET Framework Class Library
GainerDevice..::.RPhaseInvert Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RPhaseInvert As Boolean
C#
public bool RPhaseInvert { get; set; }
Visual C++
public:
property bool RPhaseInvert {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rPhaseInvert();
function set_rPhaseInvert(value);

Remarks

See Also

GainerDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
GainerDevice..::.RunTimePresetA Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As GainerDeviceRunTimePreset
C#
public GainerDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property GainerDeviceRunTimePreset^ RunTimePresetA {
    GainerDeviceRunTimePreset^ get ();
    void set (GainerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

GainerDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
GainerDevice..::.RunTimePresetB Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As GainerDeviceRunTimePreset
C#
public GainerDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property GainerDeviceRunTimePreset^ RunTimePresetB {
    GainerDeviceRunTimePreset^ get ();
    void set (GainerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

GainerDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
GainerDevice..::.SelectedPresetIsModified Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

GainerDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
GainerDevice..::.SelectedPresetName Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

GainerDevice Class


type Property

[image]

.NET Framework Class Library
GainerDevice..::.type Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GainerDevice Class


Volume Property

[image]

.NET Framework Class Library
GainerDevice..::.Volume Property
GainerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As GainerDeviceVolume
C#
public GainerDeviceVolume Volume { get; set; }
Visual C++
public:
property GainerDeviceVolume^ Volume {
    GainerDeviceVolume^ get ();
    void set (GainerDeviceVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

GainerDevice Class


GainerDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.GainerDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GainerDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDeviceDeviceSlotRunTimePreset

See Also

GainerDeviceDeviceSlotRunTimePreset Members


GainerDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset Members
GainerDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GainerDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
GainerDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LPhaseInvert |
Panning |
RPhaseInvert |
type |
Volume |

See Also

GainerDeviceDeviceSlotRunTimePreset Class


GainerDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset Constructor
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDeviceDeviceSlotRunTimePreset()
Visual C++
public:
GainerDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.GainerDeviceDeviceSlotRunTimePreset = function();

See Also

GainerDeviceDeviceSlotRunTimePreset Class


GainerDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset Methods
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The GainerDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDeviceDeviceSlotRunTimePreset Class


GainerDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset Properties
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The GainerDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
LPhaseInvert |
Panning |
RPhaseInvert |
type |
Volume |

See Also

GainerDeviceDeviceSlotRunTimePreset Class


LPhaseInvert Property

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset..::.LPhaseInvert Property
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPhaseInvert As Boolean
C#
public bool LPhaseInvert { get; set; }
Visual C++
public:
property bool LPhaseInvert {
    bool get ();
    void set (bool value);
}
JavaScript
function get_lPhaseInvert();
function set_lPhaseInvert(value);

Remarks

See Also

GainerDeviceDeviceSlotRunTimePreset Class


Panning Property

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset..::.Panning Property
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As GainerDevicePanningRunTimePreset
C#
public GainerDevicePanningRunTimePreset Panning { get; set; }
Visual C++
public:
property GainerDevicePanningRunTimePreset^ Panning {
    GainerDevicePanningRunTimePreset^ get ();
    void set (GainerDevicePanningRunTimePreset^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

GainerDeviceDeviceSlotRunTimePreset Class


RPhaseInvert Property

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset..::.RPhaseInvert Property
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RPhaseInvert As Boolean
C#
public bool RPhaseInvert { get; set; }
Visual C++
public:
property bool RPhaseInvert {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rPhaseInvert();
function set_rPhaseInvert(value);

Remarks

See Also

GainerDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset..::.type Property
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GainerDeviceDeviceSlotRunTimePreset Class


Volume Property

[image]

.NET Framework Class Library
GainerDeviceDeviceSlotRunTimePreset..::.Volume Property
GainerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As GainerDeviceVolumeRunTimePreset
C#
public GainerDeviceVolumeRunTimePreset Volume { get; set; }
Visual C++
public:
property GainerDeviceVolumeRunTimePreset^ Volume {
    GainerDeviceVolumeRunTimePreset^ get ();
    void set (GainerDeviceVolumeRunTimePreset^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

GainerDeviceDeviceSlotRunTimePreset Class


GainerDevicePanning Class

[image]

.NET Framework Class Library
GainerDevicePanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDevicePanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDevicePanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDevicePanning
JavaScript
NRenoiseTools.GainerDevicePanning = function();

Type.createClass(
    'NRenoiseTools.GainerDevicePanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDevicePanning

See Also

GainerDevicePanning Members


GainerDevicePanning Members

[image] [image]

.NET Framework Class Library
GainerDevicePanning Members
GainerDevicePanning Class Constructors Methods Properties See Also Send Feedback

The GainerDevicePanning type exposes the following members.

Constructors

Name | Description
GainerDevicePanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GainerDevicePanning Class


GainerDevicePanning Constructor

[image]

.NET Framework Class Library
GainerDevicePanning Constructor
GainerDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDevicePanning()
Visual C++
public:
GainerDevicePanning()
JavaScript
NRenoiseTools.GainerDevicePanning = function();

See Also

GainerDevicePanning Class


GainerDevicePanning Methods

[image] [image]

.NET Framework Class Library
GainerDevicePanning Methods
GainerDevicePanning Class See Also Send Feedback

The GainerDevicePanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDevicePanning Class


GainerDevicePanning Properties

[image] [image]

.NET Framework Class Library
GainerDevicePanning Properties
GainerDevicePanning Class See Also Send Feedback

The GainerDevicePanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GainerDevicePanning Class


MidiMappings Property

[image]

.NET Framework Class Library
GainerDevicePanning..::.MidiMappings Property
GainerDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GainerDevicePanning Class


Value Property

[image]

.NET Framework Class Library
GainerDevicePanning..::.Value Property
GainerDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GainerDevicePanning Class


Visualization Property

[image]

.NET Framework Class Library
GainerDevicePanning..::.Visualization Property
GainerDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GainerDevicePanningVisualization
C#
public GainerDevicePanningVisualization Visualization { get; set; }
Visual C++
public:
property GainerDevicePanningVisualization Visualization {
    GainerDevicePanningVisualization get ();
    void set (GainerDevicePanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GainerDevicePanning Class


GainerDevicePanningRunTimePreset Class

[image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDevicePanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDevicePanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDevicePanningRunTimePreset
JavaScript
NRenoiseTools.GainerDevicePanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GainerDevicePanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDevicePanningRunTimePreset

See Also

GainerDevicePanningRunTimePreset Members


GainerDevicePanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset Members
GainerDevicePanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GainerDevicePanningRunTimePreset type exposes the following members.

Constructors

Name | Description
GainerDevicePanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GainerDevicePanningRunTimePreset Class


GainerDevicePanningRunTimePreset Constructor

[image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset Constructor
GainerDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDevicePanningRunTimePreset()
Visual C++
public:
GainerDevicePanningRunTimePreset()
JavaScript
NRenoiseTools.GainerDevicePanningRunTimePreset = function();

See Also

GainerDevicePanningRunTimePreset Class


GainerDevicePanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset Methods
GainerDevicePanningRunTimePreset Class See Also Send Feedback

The GainerDevicePanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDevicePanningRunTimePreset Class


GainerDevicePanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset Properties
GainerDevicePanningRunTimePreset Class See Also Send Feedback

The GainerDevicePanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GainerDevicePanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GainerDevicePanningRunTimePreset..::.Value Property
GainerDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GainerDevicePanningRunTimePreset Class


GainerDevicePanningVisualization Enumeration

[image]

.NET Framework Class Library
GainerDevicePanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GainerDevicePanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GainerDevicePanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GainerDevicePanningVisualization
JavaScript
NRenoiseTools.GainerDevicePanningVisualization = function();
NRenoiseTools.GainerDevicePanningVisualization.createEnum('NRenoiseTools.GainerDevicePanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GainerDeviceRunTimePreset Class

[image]

.NET Framework Class Library
GainerDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDeviceRunTimePreset
JavaScript
NRenoiseTools.GainerDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GainerDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDeviceRunTimePreset

See Also

GainerDeviceRunTimePreset Members


GainerDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
GainerDeviceRunTimePreset Members
GainerDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GainerDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
GainerDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

GainerDeviceRunTimePreset Class


GainerDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
GainerDeviceRunTimePreset Constructor
GainerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDeviceRunTimePreset()
Visual C++
public:
GainerDeviceRunTimePreset()
JavaScript
NRenoiseTools.GainerDeviceRunTimePreset = function();

See Also

GainerDeviceRunTimePreset Class


GainerDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GainerDeviceRunTimePreset Methods
GainerDeviceRunTimePreset Class See Also Send Feedback

The GainerDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDeviceRunTimePreset Class


GainerDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GainerDeviceRunTimePreset Properties
GainerDeviceRunTimePreset Class See Also Send Feedback

The GainerDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

GainerDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
GainerDeviceRunTimePreset..::.DeviceSlot Property
GainerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As GainerDeviceDeviceSlotRunTimePreset
C#
public GainerDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property GainerDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    GainerDeviceDeviceSlotRunTimePreset^ get ();
    void set (GainerDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

GainerDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
GainerDeviceRunTimePreset..::.type Property
GainerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GainerDeviceRunTimePreset Class


GainerDeviceVolume Class

[image]

.NET Framework Class Library
GainerDeviceVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDeviceVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDeviceVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDeviceVolume
JavaScript
NRenoiseTools.GainerDeviceVolume = function();

Type.createClass(
    'NRenoiseTools.GainerDeviceVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDeviceVolume

See Also

GainerDeviceVolume Members


GainerDeviceVolume Members

[image] [image]

.NET Framework Class Library
GainerDeviceVolume Members
GainerDeviceVolume Class Constructors Methods Properties See Also Send Feedback

The GainerDeviceVolume type exposes the following members.

Constructors

Name | Description
GainerDeviceVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GainerDeviceVolume Class


GainerDeviceVolume Constructor

[image]

.NET Framework Class Library
GainerDeviceVolume Constructor
GainerDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDeviceVolume()
Visual C++
public:
GainerDeviceVolume()
JavaScript
NRenoiseTools.GainerDeviceVolume = function();

See Also

GainerDeviceVolume Class


GainerDeviceVolume Methods

[image] [image]

.NET Framework Class Library
GainerDeviceVolume Methods
GainerDeviceVolume Class See Also Send Feedback

The GainerDeviceVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDeviceVolume Class


GainerDeviceVolume Properties

[image] [image]

.NET Framework Class Library
GainerDeviceVolume Properties
GainerDeviceVolume Class See Also Send Feedback

The GainerDeviceVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GainerDeviceVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
GainerDeviceVolume..::.MidiMappings Property
GainerDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GainerDeviceVolume Class


Value Property

[image]

.NET Framework Class Library
GainerDeviceVolume..::.Value Property
GainerDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GainerDeviceVolume Class


Visualization Property

[image]

.NET Framework Class Library
GainerDeviceVolume..::.Visualization Property
GainerDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GainerDeviceVolumeVisualization
C#
public GainerDeviceVolumeVisualization Visualization { get; set; }
Visual C++
public:
property GainerDeviceVolumeVisualization Visualization {
    GainerDeviceVolumeVisualization get ();
    void set (GainerDeviceVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GainerDeviceVolume Class


GainerDeviceVolumeRunTimePreset Class

[image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GainerDeviceVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GainerDeviceVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GainerDeviceVolumeRunTimePreset
JavaScript
NRenoiseTools.GainerDeviceVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GainerDeviceVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GainerDeviceVolumeRunTimePreset

See Also

GainerDeviceVolumeRunTimePreset Members


GainerDeviceVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset Members
GainerDeviceVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GainerDeviceVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
GainerDeviceVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GainerDeviceVolumeRunTimePreset Class


GainerDeviceVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset Constructor
GainerDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GainerDeviceVolumeRunTimePreset()
Visual C++
public:
GainerDeviceVolumeRunTimePreset()
JavaScript
NRenoiseTools.GainerDeviceVolumeRunTimePreset = function();

See Also

GainerDeviceVolumeRunTimePreset Class


GainerDeviceVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset Methods
GainerDeviceVolumeRunTimePreset Class See Also Send Feedback

The GainerDeviceVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GainerDeviceVolumeRunTimePreset Class


GainerDeviceVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset Properties
GainerDeviceVolumeRunTimePreset Class See Also Send Feedback

The GainerDeviceVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GainerDeviceVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GainerDeviceVolumeRunTimePreset..::.Value Property
GainerDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GainerDeviceVolumeRunTimePreset Class


GainerDeviceVolumeVisualization Enumeration

[image]

.NET Framework Class Library
GainerDeviceVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GainerDeviceVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GainerDeviceVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GainerDeviceVolumeVisualization
JavaScript
NRenoiseTools.GainerDeviceVolumeVisualization = function();
NRenoiseTools.GainerDeviceVolumeVisualization.createEnum('NRenoiseTools.GainerDeviceVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceAttack Class

[image]

.NET Framework Class Library
Gate2DeviceAttack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceAttack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceAttack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceAttack
JavaScript
NRenoiseTools.Gate2DeviceAttack = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceAttack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceAttack

See Also

Gate2DeviceAttack Members


Gate2DeviceAttack Members

[image] [image]

.NET Framework Class Library
Gate2DeviceAttack Members
Gate2DeviceAttack Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceAttack type exposes the following members.

Constructors

Name | Description
Gate2DeviceAttack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceAttack Class


Gate2DeviceAttack Constructor

[image]

.NET Framework Class Library
Gate2DeviceAttack Constructor
Gate2DeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceAttack()
Visual C++
public:
Gate2DeviceAttack()
JavaScript
NRenoiseTools.Gate2DeviceAttack = function();

See Also

Gate2DeviceAttack Class


Gate2DeviceAttack Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceAttack Methods
Gate2DeviceAttack Class See Also Send Feedback

The Gate2DeviceAttack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceAttack Class


Gate2DeviceAttack Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceAttack Properties
Gate2DeviceAttack Class See Also Send Feedback

The Gate2DeviceAttack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceAttack Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceAttack..::.MidiMappings Property
Gate2DeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceAttack Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceAttack..::.Value Property
Gate2DeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceAttack Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceAttack..::.Visualization Property
Gate2DeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceAttackVisualization
C#
public Gate2DeviceAttackVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceAttackVisualization Visualization {
    Gate2DeviceAttackVisualization get ();
    void set (Gate2DeviceAttackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceAttack Class


Gate2DeviceAttackRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceAttackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceAttackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceAttackRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceAttackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceAttackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceAttackRunTimePreset

See Also

Gate2DeviceAttackRunTimePreset Members


Gate2DeviceAttackRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset Members
Gate2DeviceAttackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceAttackRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceAttackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceAttackRunTimePreset Class


Gate2DeviceAttackRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset Constructor
Gate2DeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceAttackRunTimePreset()
Visual C++
public:
Gate2DeviceAttackRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceAttackRunTimePreset = function();

See Also

Gate2DeviceAttackRunTimePreset Class


Gate2DeviceAttackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset Methods
Gate2DeviceAttackRunTimePreset Class See Also Send Feedback

The Gate2DeviceAttackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceAttackRunTimePreset Class


Gate2DeviceAttackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset Properties
Gate2DeviceAttackRunTimePreset Class See Also Send Feedback

The Gate2DeviceAttackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceAttackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceAttackRunTimePreset..::.Value Property
Gate2DeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceAttackRunTimePreset Class


Gate2DeviceAttackVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceAttackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceAttackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceAttackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceAttackVisualization
JavaScript
NRenoiseTools.Gate2DeviceAttackVisualization = function();
NRenoiseTools.Gate2DeviceAttackVisualization.createEnum('NRenoiseTools.Gate2DeviceAttackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceDeviceSlotRunTimePreset

See Also

Gate2DeviceDeviceSlotRunTimePreset Members


Gate2DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset Members
Gate2DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Floor |
Hold |
ListenToSideChain |
Release |
SideChainHpFreq |
SideChainLpFreq |
Threshold |
type |
Type |

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Gate2DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset Constructor
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Gate2DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceDeviceSlotRunTimePreset = function();

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Gate2DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset Methods
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Gate2DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Gate2DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset Properties
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Gate2DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Attack |
Floor |
Hold |
ListenToSideChain |
Release |
SideChainHpFreq |
SideChainLpFreq |
Threshold |
type |
Type |

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Attack Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Attack Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As Gate2DeviceAttackRunTimePreset
C#
public Gate2DeviceAttackRunTimePreset Attack { get; set; }
Visual C++
public:
property Gate2DeviceAttackRunTimePreset^ Attack {
    Gate2DeviceAttackRunTimePreset^ get ();
    void set (Gate2DeviceAttackRunTimePreset^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Floor Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Floor Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Floor As Gate2DeviceFloorRunTimePreset
C#
public Gate2DeviceFloorRunTimePreset Floor { get; set; }
Visual C++
public:
property Gate2DeviceFloorRunTimePreset^ Floor {
    Gate2DeviceFloorRunTimePreset^ get ();
    void set (Gate2DeviceFloorRunTimePreset^ value);
}
JavaScript
function get_floor();
function set_floor(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Hold Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Hold Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Hold As Gate2DeviceHoldRunTimePreset
C#
public Gate2DeviceHoldRunTimePreset Hold { get; set; }
Visual C++
public:
property Gate2DeviceHoldRunTimePreset^ Hold {
    Gate2DeviceHoldRunTimePreset^ get ();
    void set (Gate2DeviceHoldRunTimePreset^ value);
}
JavaScript
function get_hold();
function set_hold(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


ListenToSideChain Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.ListenToSideChain Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ListenToSideChain As Boolean
C#
public bool ListenToSideChain { get; set; }
Visual C++
public:
property bool ListenToSideChain {
    bool get ();
    void set (bool value);
}
JavaScript
function get_listenToSideChain();
function set_listenToSideChain(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Release Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Release Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As Gate2DeviceReleaseRunTimePreset
C#
public Gate2DeviceReleaseRunTimePreset Release { get; set; }
Visual C++
public:
property Gate2DeviceReleaseRunTimePreset^ Release {
    Gate2DeviceReleaseRunTimePreset^ get ();
    void set (Gate2DeviceReleaseRunTimePreset^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


SideChainHpFreq Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.SideChainHpFreq Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SideChainHpFreq As Gate2DeviceSideChainHpFreqRunTimePreset
C#
public Gate2DeviceSideChainHpFreqRunTimePreset SideChainHpFreq { get; set; }
Visual C++
public:
property Gate2DeviceSideChainHpFreqRunTimePreset^ SideChainHpFreq {
    Gate2DeviceSideChainHpFreqRunTimePreset^ get ();
    void set (Gate2DeviceSideChainHpFreqRunTimePreset^ value);
}
JavaScript
function get_sideChainHpFreq();
function set_sideChainHpFreq(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


SideChainLpFreq Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.SideChainLpFreq Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SideChainLpFreq As Gate2DeviceSideChainLpFreqRunTimePreset
C#
public Gate2DeviceSideChainLpFreqRunTimePreset SideChainLpFreq { get; set; }
Visual C++
public:
property Gate2DeviceSideChainLpFreqRunTimePreset^ SideChainLpFreq {
    Gate2DeviceSideChainLpFreqRunTimePreset^ get ();
    void set (Gate2DeviceSideChainLpFreqRunTimePreset^ value);
}
JavaScript
function get_sideChainLpFreq();
function set_sideChainLpFreq(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Threshold Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As Gate2DeviceThresholdRunTimePreset
C#
public Gate2DeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property Gate2DeviceThresholdRunTimePreset^ Threshold {
    Gate2DeviceThresholdRunTimePreset^ get ();
    void set (Gate2DeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
Gate2DeviceDeviceSlotRunTimePreset..::.Type Property
Gate2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Gate2DeviceTypeRunTimePreset
C#
public Gate2DeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property Gate2DeviceTypeRunTimePreset^ Type {
    Gate2DeviceTypeRunTimePreset^ get ();
    void set (Gate2DeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Gate2DeviceDeviceSlotRunTimePreset Class


Gate2DeviceFloor Class

[image]

.NET Framework Class Library
Gate2DeviceFloor Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceFloor
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceFloor
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceFloor
JavaScript
NRenoiseTools.Gate2DeviceFloor = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceFloor');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceFloor

See Also

Gate2DeviceFloor Members


Gate2DeviceFloor Members

[image] [image]

.NET Framework Class Library
Gate2DeviceFloor Members
Gate2DeviceFloor Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceFloor type exposes the following members.

Constructors

Name | Description
Gate2DeviceFloor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceFloor Class


Gate2DeviceFloor Constructor

[image]

.NET Framework Class Library
Gate2DeviceFloor Constructor
Gate2DeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceFloor()
Visual C++
public:
Gate2DeviceFloor()
JavaScript
NRenoiseTools.Gate2DeviceFloor = function();

See Also

Gate2DeviceFloor Class


Gate2DeviceFloor Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceFloor Methods
Gate2DeviceFloor Class See Also Send Feedback

The Gate2DeviceFloor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceFloor Class


Gate2DeviceFloor Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceFloor Properties
Gate2DeviceFloor Class See Also Send Feedback

The Gate2DeviceFloor type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceFloor Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceFloor..::.MidiMappings Property
Gate2DeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceFloor Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceFloor..::.Value Property
Gate2DeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceFloor Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceFloor..::.Visualization Property
Gate2DeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceFloorVisualization
C#
public Gate2DeviceFloorVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceFloorVisualization Visualization {
    Gate2DeviceFloorVisualization get ();
    void set (Gate2DeviceFloorVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceFloor Class


Gate2DeviceFloorRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceFloorRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceFloorRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceFloorRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceFloorRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceFloorRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceFloorRunTimePreset

See Also

Gate2DeviceFloorRunTimePreset Members


Gate2DeviceFloorRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset Members
Gate2DeviceFloorRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceFloorRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceFloorRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceFloorRunTimePreset Class


Gate2DeviceFloorRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset Constructor
Gate2DeviceFloorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceFloorRunTimePreset()
Visual C++
public:
Gate2DeviceFloorRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceFloorRunTimePreset = function();

See Also

Gate2DeviceFloorRunTimePreset Class


Gate2DeviceFloorRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset Methods
Gate2DeviceFloorRunTimePreset Class See Also Send Feedback

The Gate2DeviceFloorRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceFloorRunTimePreset Class


Gate2DeviceFloorRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset Properties
Gate2DeviceFloorRunTimePreset Class See Also Send Feedback

The Gate2DeviceFloorRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceFloorRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceFloorRunTimePreset..::.Value Property
Gate2DeviceFloorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceFloorRunTimePreset Class


Gate2DeviceFloorVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceFloorVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceFloorVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceFloorVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceFloorVisualization
JavaScript
NRenoiseTools.Gate2DeviceFloorVisualization = function();
NRenoiseTools.Gate2DeviceFloorVisualization.createEnum('NRenoiseTools.Gate2DeviceFloorVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceGateDevice Class

[image]

.NET Framework Class Library
Gate2DeviceGateDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceGateDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceGateDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceGateDevice
JavaScript
NRenoiseTools.Gate2DeviceGateDevice = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceGateDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceGateDevice

See Also

Gate2DeviceGateDevice Members


Gate2DeviceGateDevice Members

[image] [image]

.NET Framework Class Library
Gate2DeviceGateDevice Members
Gate2DeviceGateDevice Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceGateDevice type exposes the following members.

Constructors

Name | Description
Gate2DeviceGateDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Floor |
Hold |
IsActive |
IsSelected |
ListenToSideChain |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SideChainHpFreq |
SideChainLpFreq |
Threshold |
type |
Type |

See Also

Gate2DeviceGateDevice Class


Gate2DeviceGateDevice Constructor

[image]

.NET Framework Class Library
Gate2DeviceGateDevice Constructor
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceGateDevice()
Visual C++
public:
Gate2DeviceGateDevice()
JavaScript
NRenoiseTools.Gate2DeviceGateDevice = function();

See Also

Gate2DeviceGateDevice Class


Gate2DeviceGateDevice Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceGateDevice Methods
Gate2DeviceGateDevice Class See Also Send Feedback

The Gate2DeviceGateDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceGateDevice Class


Gate2DeviceGateDevice Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceGateDevice Properties
Gate2DeviceGateDevice Class See Also Send Feedback

The Gate2DeviceGateDevice type exposes the following members.

Properties

Name | Description
Attack |
Floor |
Hold |
IsActive |
IsSelected |
ListenToSideChain |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SideChainHpFreq |
SideChainLpFreq |
Threshold |
type |
Type |

See Also

Gate2DeviceGateDevice Class


Attack Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Attack Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As Gate2DeviceAttack
C#
public Gate2DeviceAttack Attack { get; set; }
Visual C++
public:
property Gate2DeviceAttack^ Attack {
    Gate2DeviceAttack^ get ();
    void set (Gate2DeviceAttack^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Floor Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Floor Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Floor As Gate2DeviceFloor
C#
public Gate2DeviceFloor Floor { get; set; }
Visual C++
public:
property Gate2DeviceFloor^ Floor {
    Gate2DeviceFloor^ get ();
    void set (Gate2DeviceFloor^ value);
}
JavaScript
function get_floor();
function set_floor(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Hold Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Hold Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Hold As Gate2DeviceHold
C#
public Gate2DeviceHold Hold { get; set; }
Visual C++
public:
property Gate2DeviceHold^ Hold {
    Gate2DeviceHold^ get ();
    void set (Gate2DeviceHold^ value);
}
JavaScript
function get_hold();
function set_hold(value);

Remarks

See Also

Gate2DeviceGateDevice Class


IsActive Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.IsActive Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Gate2DeviceGateDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.IsSelected Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Gate2DeviceGateDevice Class


ListenToSideChain Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.ListenToSideChain Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ListenToSideChain As Boolean
C#
public bool ListenToSideChain { get; set; }
Visual C++
public:
property bool ListenToSideChain {
    bool get ();
    void set (bool value);
}
JavaScript
function get_listenToSideChain();
function set_listenToSideChain(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Release Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Release Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As Gate2DeviceRelease
C#
public Gate2DeviceRelease Release { get; set; }
Visual C++
public:
property Gate2DeviceRelease^ Release {
    Gate2DeviceRelease^ get ();
    void set (Gate2DeviceRelease^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

Gate2DeviceGateDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.RunTimePresetA Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Gate2DeviceRunTimePreset
C#
public Gate2DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Gate2DeviceRunTimePreset^ RunTimePresetA {
    Gate2DeviceRunTimePreset^ get ();
    void set (Gate2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Gate2DeviceGateDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.RunTimePresetB Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Gate2DeviceRunTimePreset
C#
public Gate2DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Gate2DeviceRunTimePreset^ RunTimePresetB {
    Gate2DeviceRunTimePreset^ get ();
    void set (Gate2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Gate2DeviceGateDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.SelectedPresetIsModified Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Gate2DeviceGateDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.SelectedPresetName Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Gate2DeviceGateDevice Class


SideChainHpFreq Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.SideChainHpFreq Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SideChainHpFreq As Gate2DeviceSideChainHpFreq
C#
public Gate2DeviceSideChainHpFreq SideChainHpFreq { get; set; }
Visual C++
public:
property Gate2DeviceSideChainHpFreq^ SideChainHpFreq {
    Gate2DeviceSideChainHpFreq^ get ();
    void set (Gate2DeviceSideChainHpFreq^ value);
}
JavaScript
function get_sideChainHpFreq();
function set_sideChainHpFreq(value);

Remarks

See Also

Gate2DeviceGateDevice Class


SideChainLpFreq Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.SideChainLpFreq Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SideChainLpFreq As Gate2DeviceSideChainLpFreq
C#
public Gate2DeviceSideChainLpFreq SideChainLpFreq { get; set; }
Visual C++
public:
property Gate2DeviceSideChainLpFreq^ SideChainLpFreq {
    Gate2DeviceSideChainLpFreq^ get ();
    void set (Gate2DeviceSideChainLpFreq^ value);
}
JavaScript
function get_sideChainLpFreq();
function set_sideChainLpFreq(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Threshold Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Threshold Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As Gate2DeviceThreshold
C#
public Gate2DeviceThreshold Threshold { get; set; }
Visual C++
public:
property Gate2DeviceThreshold^ Threshold {
    Gate2DeviceThreshold^ get ();
    void set (Gate2DeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Type Property

[image]

.NET Framework Class Library
Gate2DeviceGateDevice..::.Type Property
Gate2DeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Gate2DeviceType
C#
public Gate2DeviceType Type { get; set; }
Visual C++
public:
property Gate2DeviceType^ Type {
    Gate2DeviceType^ get ();
    void set (Gate2DeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Gate2DeviceGateDevice Class


Gate2DeviceHold Class

[image]

.NET Framework Class Library
Gate2DeviceHold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceHold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceHold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceHold
JavaScript
NRenoiseTools.Gate2DeviceHold = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceHold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceHold

See Also

Gate2DeviceHold Members


Gate2DeviceHold Members

[image] [image]

.NET Framework Class Library
Gate2DeviceHold Members
Gate2DeviceHold Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceHold type exposes the following members.

Constructors

Name | Description
Gate2DeviceHold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceHold Class


Gate2DeviceHold Constructor

[image]

.NET Framework Class Library
Gate2DeviceHold Constructor
Gate2DeviceHold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceHold()
Visual C++
public:
Gate2DeviceHold()
JavaScript
NRenoiseTools.Gate2DeviceHold = function();

See Also

Gate2DeviceHold Class


Gate2DeviceHold Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceHold Methods
Gate2DeviceHold Class See Also Send Feedback

The Gate2DeviceHold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceHold Class


Gate2DeviceHold Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceHold Properties
Gate2DeviceHold Class See Also Send Feedback

The Gate2DeviceHold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceHold Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceHold..::.MidiMappings Property
Gate2DeviceHold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceHold Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceHold..::.Value Property
Gate2DeviceHold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceHold Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceHold..::.Visualization Property
Gate2DeviceHold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceHoldVisualization
C#
public Gate2DeviceHoldVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceHoldVisualization Visualization {
    Gate2DeviceHoldVisualization get ();
    void set (Gate2DeviceHoldVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceHold Class


Gate2DeviceHoldRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceHoldRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceHoldRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceHoldRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceHoldRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceHoldRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceHoldRunTimePreset

See Also

Gate2DeviceHoldRunTimePreset Members


Gate2DeviceHoldRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset Members
Gate2DeviceHoldRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceHoldRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceHoldRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceHoldRunTimePreset Class


Gate2DeviceHoldRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset Constructor
Gate2DeviceHoldRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceHoldRunTimePreset()
Visual C++
public:
Gate2DeviceHoldRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceHoldRunTimePreset = function();

See Also

Gate2DeviceHoldRunTimePreset Class


Gate2DeviceHoldRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset Methods
Gate2DeviceHoldRunTimePreset Class See Also Send Feedback

The Gate2DeviceHoldRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceHoldRunTimePreset Class


Gate2DeviceHoldRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset Properties
Gate2DeviceHoldRunTimePreset Class See Also Send Feedback

The Gate2DeviceHoldRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceHoldRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceHoldRunTimePreset..::.Value Property
Gate2DeviceHoldRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceHoldRunTimePreset Class


Gate2DeviceHoldVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceHoldVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceHoldVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceHoldVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceHoldVisualization
JavaScript
NRenoiseTools.Gate2DeviceHoldVisualization = function();
NRenoiseTools.Gate2DeviceHoldVisualization.createEnum('NRenoiseTools.Gate2DeviceHoldVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceRelease Class

[image]

.NET Framework Class Library
Gate2DeviceRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceRelease
JavaScript
NRenoiseTools.Gate2DeviceRelease = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceRelease

See Also

Gate2DeviceRelease Members


Gate2DeviceRelease Members

[image] [image]

.NET Framework Class Library
Gate2DeviceRelease Members
Gate2DeviceRelease Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceRelease type exposes the following members.

Constructors

Name | Description
Gate2DeviceRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceRelease Class


Gate2DeviceRelease Constructor

[image]

.NET Framework Class Library
Gate2DeviceRelease Constructor
Gate2DeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceRelease()
Visual C++
public:
Gate2DeviceRelease()
JavaScript
NRenoiseTools.Gate2DeviceRelease = function();

See Also

Gate2DeviceRelease Class


Gate2DeviceRelease Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceRelease Methods
Gate2DeviceRelease Class See Also Send Feedback

The Gate2DeviceRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceRelease Class


Gate2DeviceRelease Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceRelease Properties
Gate2DeviceRelease Class See Also Send Feedback

The Gate2DeviceRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceRelease..::.MidiMappings Property
Gate2DeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceRelease Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceRelease..::.Value Property
Gate2DeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceRelease Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceRelease..::.Visualization Property
Gate2DeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceReleaseVisualization
C#
public Gate2DeviceReleaseVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceReleaseVisualization Visualization {
    Gate2DeviceReleaseVisualization get ();
    void set (Gate2DeviceReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceRelease Class


Gate2DeviceReleaseRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceReleaseRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceReleaseRunTimePreset

See Also

Gate2DeviceReleaseRunTimePreset Members


Gate2DeviceReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset Members
Gate2DeviceReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceReleaseRunTimePreset Class


Gate2DeviceReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset Constructor
Gate2DeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceReleaseRunTimePreset()
Visual C++
public:
Gate2DeviceReleaseRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceReleaseRunTimePreset = function();

See Also

Gate2DeviceReleaseRunTimePreset Class


Gate2DeviceReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset Methods
Gate2DeviceReleaseRunTimePreset Class See Also Send Feedback

The Gate2DeviceReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceReleaseRunTimePreset Class


Gate2DeviceReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset Properties
Gate2DeviceReleaseRunTimePreset Class See Also Send Feedback

The Gate2DeviceReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceReleaseRunTimePreset..::.Value Property
Gate2DeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceReleaseRunTimePreset Class


Gate2DeviceReleaseVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceReleaseVisualization
JavaScript
NRenoiseTools.Gate2DeviceReleaseVisualization = function();
NRenoiseTools.Gate2DeviceReleaseVisualization.createEnum('NRenoiseTools.Gate2DeviceReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceRunTimePreset

See Also

Gate2DeviceRunTimePreset Members


Gate2DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceRunTimePreset Members
Gate2DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Gate2DeviceRunTimePreset Class


Gate2DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceRunTimePreset Constructor
Gate2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceRunTimePreset()
Visual C++
public:
Gate2DeviceRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceRunTimePreset = function();

See Also

Gate2DeviceRunTimePreset Class


Gate2DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceRunTimePreset Methods
Gate2DeviceRunTimePreset Class See Also Send Feedback

The Gate2DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceRunTimePreset Class


Gate2DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceRunTimePreset Properties
Gate2DeviceRunTimePreset Class See Also Send Feedback

The Gate2DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Gate2DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Gate2DeviceRunTimePreset..::.DeviceSlot Property
Gate2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Gate2DeviceDeviceSlotRunTimePreset
C#
public Gate2DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Gate2DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Gate2DeviceDeviceSlotRunTimePreset^ get ();
    void set (Gate2DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Gate2DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Gate2DeviceRunTimePreset..::.type Property
Gate2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Gate2DeviceRunTimePreset Class


Gate2DeviceSideChainHpFreq Class

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceSideChainHpFreq
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceSideChainHpFreq
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceSideChainHpFreq
JavaScript
NRenoiseTools.Gate2DeviceSideChainHpFreq = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceSideChainHpFreq');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceSideChainHpFreq

See Also

Gate2DeviceSideChainHpFreq Members


Gate2DeviceSideChainHpFreq Members

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq Members
Gate2DeviceSideChainHpFreq Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceSideChainHpFreq type exposes the following members.

Constructors

Name | Description
Gate2DeviceSideChainHpFreq |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceSideChainHpFreq Class


Gate2DeviceSideChainHpFreq Constructor

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq Constructor
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceSideChainHpFreq()
Visual C++
public:
Gate2DeviceSideChainHpFreq()
JavaScript
NRenoiseTools.Gate2DeviceSideChainHpFreq = function();

See Also

Gate2DeviceSideChainHpFreq Class


Gate2DeviceSideChainHpFreq Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq Methods
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

The Gate2DeviceSideChainHpFreq type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceSideChainHpFreq Class


Gate2DeviceSideChainHpFreq Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq Properties
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

The Gate2DeviceSideChainHpFreq type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceSideChainHpFreq Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq..::.MidiMappings Property
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceSideChainHpFreq Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq..::.Value Property
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceSideChainHpFreq Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreq..::.Visualization Property
Gate2DeviceSideChainHpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceSideChainHpFreqVisualization
C#
public Gate2DeviceSideChainHpFreqVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceSideChainHpFreqVisualization Visualization {
    Gate2DeviceSideChainHpFreqVisualization get ();
    void set (Gate2DeviceSideChainHpFreqVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceSideChainHpFreq Class


Gate2DeviceSideChainHpFreqRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceSideChainHpFreqRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceSideChainHpFreqRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceSideChainHpFreqRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceSideChainHpFreqRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceSideChainHpFreqRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceSideChainHpFreqRunTimePreset

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Members


Gate2DeviceSideChainHpFreqRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset Members
Gate2DeviceSideChainHpFreqRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceSideChainHpFreqRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceSideChainHpFreqRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Class


Gate2DeviceSideChainHpFreqRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset Constructor
Gate2DeviceSideChainHpFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceSideChainHpFreqRunTimePreset()
Visual C++
public:
Gate2DeviceSideChainHpFreqRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceSideChainHpFreqRunTimePreset = function();

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Class


Gate2DeviceSideChainHpFreqRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset Methods
Gate2DeviceSideChainHpFreqRunTimePreset Class See Also Send Feedback

The Gate2DeviceSideChainHpFreqRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Class


Gate2DeviceSideChainHpFreqRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset Properties
Gate2DeviceSideChainHpFreqRunTimePreset Class See Also Send Feedback

The Gate2DeviceSideChainHpFreqRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqRunTimePreset..::.Value Property
Gate2DeviceSideChainHpFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceSideChainHpFreqRunTimePreset Class


Gate2DeviceSideChainHpFreqVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceSideChainHpFreqVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceSideChainHpFreqVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceSideChainHpFreqVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceSideChainHpFreqVisualization
JavaScript
NRenoiseTools.Gate2DeviceSideChainHpFreqVisualization = function();
NRenoiseTools.Gate2DeviceSideChainHpFreqVisualization.createEnum('NRenoiseTools.Gate2DeviceSideChainHpFreqVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceSideChainLpFreq Class

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceSideChainLpFreq
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceSideChainLpFreq
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceSideChainLpFreq
JavaScript
NRenoiseTools.Gate2DeviceSideChainLpFreq = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceSideChainLpFreq');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceSideChainLpFreq

See Also

Gate2DeviceSideChainLpFreq Members


Gate2DeviceSideChainLpFreq Members

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq Members
Gate2DeviceSideChainLpFreq Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceSideChainLpFreq type exposes the following members.

Constructors

Name | Description
Gate2DeviceSideChainLpFreq |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceSideChainLpFreq Class


Gate2DeviceSideChainLpFreq Constructor

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq Constructor
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceSideChainLpFreq()
Visual C++
public:
Gate2DeviceSideChainLpFreq()
JavaScript
NRenoiseTools.Gate2DeviceSideChainLpFreq = function();

See Also

Gate2DeviceSideChainLpFreq Class


Gate2DeviceSideChainLpFreq Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq Methods
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

The Gate2DeviceSideChainLpFreq type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceSideChainLpFreq Class


Gate2DeviceSideChainLpFreq Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq Properties
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

The Gate2DeviceSideChainLpFreq type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceSideChainLpFreq Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq..::.MidiMappings Property
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceSideChainLpFreq Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq..::.Value Property
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceSideChainLpFreq Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreq..::.Visualization Property
Gate2DeviceSideChainLpFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceSideChainLpFreqVisualization
C#
public Gate2DeviceSideChainLpFreqVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceSideChainLpFreqVisualization Visualization {
    Gate2DeviceSideChainLpFreqVisualization get ();
    void set (Gate2DeviceSideChainLpFreqVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceSideChainLpFreq Class


Gate2DeviceSideChainLpFreqRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceSideChainLpFreqRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceSideChainLpFreqRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceSideChainLpFreqRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceSideChainLpFreqRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceSideChainLpFreqRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceSideChainLpFreqRunTimePreset

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Members


Gate2DeviceSideChainLpFreqRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset Members
Gate2DeviceSideChainLpFreqRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceSideChainLpFreqRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceSideChainLpFreqRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Class


Gate2DeviceSideChainLpFreqRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset Constructor
Gate2DeviceSideChainLpFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceSideChainLpFreqRunTimePreset()
Visual C++
public:
Gate2DeviceSideChainLpFreqRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceSideChainLpFreqRunTimePreset = function();

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Class


Gate2DeviceSideChainLpFreqRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset Methods
Gate2DeviceSideChainLpFreqRunTimePreset Class See Also Send Feedback

The Gate2DeviceSideChainLpFreqRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Class


Gate2DeviceSideChainLpFreqRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset Properties
Gate2DeviceSideChainLpFreqRunTimePreset Class See Also Send Feedback

The Gate2DeviceSideChainLpFreqRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqRunTimePreset..::.Value Property
Gate2DeviceSideChainLpFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceSideChainLpFreqRunTimePreset Class


Gate2DeviceSideChainLpFreqVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceSideChainLpFreqVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceSideChainLpFreqVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceSideChainLpFreqVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceSideChainLpFreqVisualization
JavaScript
NRenoiseTools.Gate2DeviceSideChainLpFreqVisualization = function();
NRenoiseTools.Gate2DeviceSideChainLpFreqVisualization.createEnum('NRenoiseTools.Gate2DeviceSideChainLpFreqVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceThreshold Class

[image]

.NET Framework Class Library
Gate2DeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceThreshold
JavaScript
NRenoiseTools.Gate2DeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceThreshold

See Also

Gate2DeviceThreshold Members


Gate2DeviceThreshold Members

[image] [image]

.NET Framework Class Library
Gate2DeviceThreshold Members
Gate2DeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceThreshold type exposes the following members.

Constructors

Name | Description
Gate2DeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceThreshold Class


Gate2DeviceThreshold Constructor

[image]

.NET Framework Class Library
Gate2DeviceThreshold Constructor
Gate2DeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceThreshold()
Visual C++
public:
Gate2DeviceThreshold()
JavaScript
NRenoiseTools.Gate2DeviceThreshold = function();

See Also

Gate2DeviceThreshold Class


Gate2DeviceThreshold Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceThreshold Methods
Gate2DeviceThreshold Class See Also Send Feedback

The Gate2DeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceThreshold Class


Gate2DeviceThreshold Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceThreshold Properties
Gate2DeviceThreshold Class See Also Send Feedback

The Gate2DeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceThreshold..::.MidiMappings Property
Gate2DeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceThreshold..::.Value Property
Gate2DeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceThreshold..::.Visualization Property
Gate2DeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceThresholdVisualization
C#
public Gate2DeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceThresholdVisualization Visualization {
    Gate2DeviceThresholdVisualization get ();
    void set (Gate2DeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceThreshold Class


Gate2DeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceThresholdRunTimePreset

See Also

Gate2DeviceThresholdRunTimePreset Members


Gate2DeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset Members
Gate2DeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceThresholdRunTimePreset Class


Gate2DeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset Constructor
Gate2DeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceThresholdRunTimePreset()
Visual C++
public:
Gate2DeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceThresholdRunTimePreset = function();

See Also

Gate2DeviceThresholdRunTimePreset Class


Gate2DeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset Methods
Gate2DeviceThresholdRunTimePreset Class See Also Send Feedback

The Gate2DeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceThresholdRunTimePreset Class


Gate2DeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset Properties
Gate2DeviceThresholdRunTimePreset Class See Also Send Feedback

The Gate2DeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceThresholdRunTimePreset..::.Value Property
Gate2DeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceThresholdRunTimePreset Class


Gate2DeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceThresholdVisualization
JavaScript
NRenoiseTools.Gate2DeviceThresholdVisualization = function();
NRenoiseTools.Gate2DeviceThresholdVisualization.createEnum('NRenoiseTools.Gate2DeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Gate2DeviceType Class

[image]

.NET Framework Class Library
Gate2DeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceType
JavaScript
NRenoiseTools.Gate2DeviceType = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceType

See Also

Gate2DeviceType Members


Gate2DeviceType Members

[image] [image]

.NET Framework Class Library
Gate2DeviceType Members
Gate2DeviceType Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceType type exposes the following members.

Constructors

Name | Description
Gate2DeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceType Class


Gate2DeviceType Constructor

[image]

.NET Framework Class Library
Gate2DeviceType Constructor
Gate2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceType()
Visual C++
public:
Gate2DeviceType()
JavaScript
NRenoiseTools.Gate2DeviceType = function();

See Also

Gate2DeviceType Class


Gate2DeviceType Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceType Methods
Gate2DeviceType Class See Also Send Feedback

The Gate2DeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceType Class


Gate2DeviceType Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceType Properties
Gate2DeviceType Class See Also Send Feedback

The Gate2DeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Gate2DeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
Gate2DeviceType..::.MidiMappings Property
Gate2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Gate2DeviceType Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceType..::.Value Property
Gate2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceType Class


Visualization Property

[image]

.NET Framework Class Library
Gate2DeviceType..::.Visualization Property
Gate2DeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Gate2DeviceTypeVisualization
C#
public Gate2DeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property Gate2DeviceTypeVisualization Visualization {
    Gate2DeviceTypeVisualization get ();
    void set (Gate2DeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Gate2DeviceType Class


Gate2DeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Gate2DeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Gate2DeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Gate2DeviceTypeRunTimePreset
JavaScript
NRenoiseTools.Gate2DeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Gate2DeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Gate2DeviceTypeRunTimePreset

See Also

Gate2DeviceTypeRunTimePreset Members


Gate2DeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset Members
Gate2DeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Gate2DeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
Gate2DeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Gate2DeviceTypeRunTimePreset Class


Gate2DeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset Constructor
Gate2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Gate2DeviceTypeRunTimePreset()
Visual C++
public:
Gate2DeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.Gate2DeviceTypeRunTimePreset = function();

See Also

Gate2DeviceTypeRunTimePreset Class


Gate2DeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset Methods
Gate2DeviceTypeRunTimePreset Class See Also Send Feedback

The Gate2DeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gate2DeviceTypeRunTimePreset Class


Gate2DeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset Properties
Gate2DeviceTypeRunTimePreset Class See Also Send Feedback

The Gate2DeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Gate2DeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Gate2DeviceTypeRunTimePreset..::.Value Property
Gate2DeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Gate2DeviceTypeRunTimePreset Class


Gate2DeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
Gate2DeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Gate2DeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Gate2DeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Gate2DeviceTypeVisualization
JavaScript
NRenoiseTools.Gate2DeviceTypeVisualization = function();
NRenoiseTools.Gate2DeviceTypeVisualization.createEnum('NRenoiseTools.Gate2DeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GateDeviceAttackInMs Class

[image]

.NET Framework Class Library
GateDeviceAttackInMs Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceAttackInMs
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceAttackInMs
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceAttackInMs
JavaScript
NRenoiseTools.GateDeviceAttackInMs = function();

Type.createClass(
    'NRenoiseTools.GateDeviceAttackInMs');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceAttackInMs

See Also

GateDeviceAttackInMs Members


GateDeviceAttackInMs Members

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMs Members
GateDeviceAttackInMs Class Constructors Methods Properties See Also Send Feedback

The GateDeviceAttackInMs type exposes the following members.

Constructors

Name | Description
GateDeviceAttackInMs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceAttackInMs Class


GateDeviceAttackInMs Constructor

[image]

.NET Framework Class Library
GateDeviceAttackInMs Constructor
GateDeviceAttackInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceAttackInMs()
Visual C++
public:
GateDeviceAttackInMs()
JavaScript
NRenoiseTools.GateDeviceAttackInMs = function();

See Also

GateDeviceAttackInMs Class


GateDeviceAttackInMs Methods

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMs Methods
GateDeviceAttackInMs Class See Also Send Feedback

The GateDeviceAttackInMs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceAttackInMs Class


GateDeviceAttackInMs Properties

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMs Properties
GateDeviceAttackInMs Class See Also Send Feedback

The GateDeviceAttackInMs type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceAttackInMs Class


MidiMappings Property

[image]

.NET Framework Class Library
GateDeviceAttackInMs..::.MidiMappings Property
GateDeviceAttackInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GateDeviceAttackInMs Class


Value Property

[image]

.NET Framework Class Library
GateDeviceAttackInMs..::.Value Property
GateDeviceAttackInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceAttackInMs Class


Visualization Property

[image]

.NET Framework Class Library
GateDeviceAttackInMs..::.Visualization Property
GateDeviceAttackInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GateDeviceAttackInMsVisualization
C#
public GateDeviceAttackInMsVisualization Visualization { get; set; }
Visual C++
public:
property GateDeviceAttackInMsVisualization Visualization {
    GateDeviceAttackInMsVisualization get ();
    void set (GateDeviceAttackInMsVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GateDeviceAttackInMs Class


GateDeviceAttackInMsRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceAttackInMsRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceAttackInMsRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceAttackInMsRunTimePreset
JavaScript
NRenoiseTools.GateDeviceAttackInMsRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceAttackInMsRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceAttackInMsRunTimePreset

See Also

GateDeviceAttackInMsRunTimePreset Members


GateDeviceAttackInMsRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset Members
GateDeviceAttackInMsRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceAttackInMsRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceAttackInMsRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GateDeviceAttackInMsRunTimePreset Class


GateDeviceAttackInMsRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset Constructor
GateDeviceAttackInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceAttackInMsRunTimePreset()
Visual C++
public:
GateDeviceAttackInMsRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceAttackInMsRunTimePreset = function();

See Also

GateDeviceAttackInMsRunTimePreset Class


GateDeviceAttackInMsRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset Methods
GateDeviceAttackInMsRunTimePreset Class See Also Send Feedback

The GateDeviceAttackInMsRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceAttackInMsRunTimePreset Class


GateDeviceAttackInMsRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset Properties
GateDeviceAttackInMsRunTimePreset Class See Also Send Feedback

The GateDeviceAttackInMsRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GateDeviceAttackInMsRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GateDeviceAttackInMsRunTimePreset..::.Value Property
GateDeviceAttackInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceAttackInMsRunTimePreset Class


GateDeviceAttackInMsVisualization Enumeration

[image]

.NET Framework Class Library
GateDeviceAttackInMsVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GateDeviceAttackInMsVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GateDeviceAttackInMsVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GateDeviceAttackInMsVisualization
JavaScript
NRenoiseTools.GateDeviceAttackInMsVisualization = function();
NRenoiseTools.GateDeviceAttackInMsVisualization.createEnum('NRenoiseTools.GateDeviceAttackInMsVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GateDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.GateDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceDeviceSlotRunTimePreset

See Also

GateDeviceDeviceSlotRunTimePreset Members


GateDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset Members
GateDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AttackInMs |
GatedVolume |
HoldInMs |
ReleaseInMs |
Threshold |
type |

See Also

GateDeviceDeviceSlotRunTimePreset Class


GateDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset Constructor
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceDeviceSlotRunTimePreset()
Visual C++
public:
GateDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceDeviceSlotRunTimePreset = function();

See Also

GateDeviceDeviceSlotRunTimePreset Class


GateDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset Methods
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The GateDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceDeviceSlotRunTimePreset Class


GateDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset Properties
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The GateDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
AttackInMs |
GatedVolume |
HoldInMs |
ReleaseInMs |
Threshold |
type |

See Also

GateDeviceDeviceSlotRunTimePreset Class


AttackInMs Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.AttackInMs Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AttackInMs As GateDeviceAttackInMsRunTimePreset
C#
public GateDeviceAttackInMsRunTimePreset AttackInMs { get; set; }
Visual C++
public:
property GateDeviceAttackInMsRunTimePreset^ AttackInMs {
    GateDeviceAttackInMsRunTimePreset^ get ();
    void set (GateDeviceAttackInMsRunTimePreset^ value);
}
JavaScript
function get_attackInMs();
function set_attackInMs(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


GatedVolume Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.GatedVolume Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GatedVolume As GateDeviceGatedVolumeRunTimePreset
C#
public GateDeviceGatedVolumeRunTimePreset GatedVolume { get; set; }
Visual C++
public:
property GateDeviceGatedVolumeRunTimePreset^ GatedVolume {
    GateDeviceGatedVolumeRunTimePreset^ get ();
    void set (GateDeviceGatedVolumeRunTimePreset^ value);
}
JavaScript
function get_gatedVolume();
function set_gatedVolume(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


HoldInMs Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.HoldInMs Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HoldInMs As GateDeviceHoldInMsRunTimePreset
C#
public GateDeviceHoldInMsRunTimePreset HoldInMs { get; set; }
Visual C++
public:
property GateDeviceHoldInMsRunTimePreset^ HoldInMs {
    GateDeviceHoldInMsRunTimePreset^ get ();
    void set (GateDeviceHoldInMsRunTimePreset^ value);
}
JavaScript
function get_holdInMs();
function set_holdInMs(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


ReleaseInMs Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.ReleaseInMs Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReleaseInMs As GateDeviceReleaseInMsRunTimePreset
C#
public GateDeviceReleaseInMsRunTimePreset ReleaseInMs { get; set; }
Visual C++
public:
property GateDeviceReleaseInMsRunTimePreset^ ReleaseInMs {
    GateDeviceReleaseInMsRunTimePreset^ get ();
    void set (GateDeviceReleaseInMsRunTimePreset^ value);
}
JavaScript
function get_releaseInMs();
function set_releaseInMs(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.Threshold Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As GateDeviceThresholdRunTimePreset
C#
public GateDeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property GateDeviceThresholdRunTimePreset^ Threshold {
    GateDeviceThresholdRunTimePreset^ get ();
    void set (GateDeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
GateDeviceDeviceSlotRunTimePreset..::.type Property
GateDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GateDeviceDeviceSlotRunTimePreset Class


GateDeviceGateDevice Class

[image]

.NET Framework Class Library
GateDeviceGateDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceGateDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceGateDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceGateDevice
JavaScript
NRenoiseTools.GateDeviceGateDevice = function();

Type.createClass(
    'NRenoiseTools.GateDeviceGateDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceGateDevice

See Also

GateDeviceGateDevice Members


GateDeviceGateDevice Members

[image] [image]

.NET Framework Class Library
GateDeviceGateDevice Members
GateDeviceGateDevice Class Constructors Methods Properties See Also Send Feedback

The GateDeviceGateDevice type exposes the following members.

Constructors

Name | Description
GateDeviceGateDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AttackInMs |
GatedVolume |
HoldInMs |
IsActive |
IsSelected |
ReleaseInMs |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

GateDeviceGateDevice Class


GateDeviceGateDevice Constructor

[image]

.NET Framework Class Library
GateDeviceGateDevice Constructor
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceGateDevice()
Visual C++
public:
GateDeviceGateDevice()
JavaScript
NRenoiseTools.GateDeviceGateDevice = function();

See Also

GateDeviceGateDevice Class


GateDeviceGateDevice Methods

[image] [image]

.NET Framework Class Library
GateDeviceGateDevice Methods
GateDeviceGateDevice Class See Also Send Feedback

The GateDeviceGateDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceGateDevice Class


GateDeviceGateDevice Properties

[image] [image]

.NET Framework Class Library
GateDeviceGateDevice Properties
GateDeviceGateDevice Class See Also Send Feedback

The GateDeviceGateDevice type exposes the following members.

Properties

Name | Description
AttackInMs |
GatedVolume |
HoldInMs |
IsActive |
IsSelected |
ReleaseInMs |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

GateDeviceGateDevice Class


AttackInMs Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.AttackInMs Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AttackInMs As GateDeviceAttackInMs
C#
public GateDeviceAttackInMs AttackInMs { get; set; }
Visual C++
public:
property GateDeviceAttackInMs^ AttackInMs {
    GateDeviceAttackInMs^ get ();
    void set (GateDeviceAttackInMs^ value);
}
JavaScript
function get_attackInMs();
function set_attackInMs(value);

Remarks

See Also

GateDeviceGateDevice Class


GatedVolume Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.GatedVolume Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GatedVolume As GateDeviceGatedVolume
C#
public GateDeviceGatedVolume GatedVolume { get; set; }
Visual C++
public:
property GateDeviceGatedVolume^ GatedVolume {
    GateDeviceGatedVolume^ get ();
    void set (GateDeviceGatedVolume^ value);
}
JavaScript
function get_gatedVolume();
function set_gatedVolume(value);

Remarks

See Also

GateDeviceGateDevice Class


HoldInMs Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.HoldInMs Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HoldInMs As GateDeviceHoldInMs
C#
public GateDeviceHoldInMs HoldInMs { get; set; }
Visual C++
public:
property GateDeviceHoldInMs^ HoldInMs {
    GateDeviceHoldInMs^ get ();
    void set (GateDeviceHoldInMs^ value);
}
JavaScript
function get_holdInMs();
function set_holdInMs(value);

Remarks

See Also

GateDeviceGateDevice Class


IsActive Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.IsActive Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

GateDeviceGateDevice Class


IsSelected Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.IsSelected Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

GateDeviceGateDevice Class


ReleaseInMs Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.ReleaseInMs Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReleaseInMs As GateDeviceReleaseInMs
C#
public GateDeviceReleaseInMs ReleaseInMs { get; set; }
Visual C++
public:
property GateDeviceReleaseInMs^ ReleaseInMs {
    GateDeviceReleaseInMs^ get ();
    void set (GateDeviceReleaseInMs^ value);
}
JavaScript
function get_releaseInMs();
function set_releaseInMs(value);

Remarks

See Also

GateDeviceGateDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.RunTimePresetA Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As GateDeviceRunTimePreset
C#
public GateDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property GateDeviceRunTimePreset^ RunTimePresetA {
    GateDeviceRunTimePreset^ get ();
    void set (GateDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

GateDeviceGateDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.RunTimePresetB Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As GateDeviceRunTimePreset
C#
public GateDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property GateDeviceRunTimePreset^ RunTimePresetB {
    GateDeviceRunTimePreset^ get ();
    void set (GateDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

GateDeviceGateDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.SelectedPresetIsModified Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

GateDeviceGateDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.SelectedPresetName Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

GateDeviceGateDevice Class


Threshold Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.Threshold Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As GateDeviceThreshold
C#
public GateDeviceThreshold Threshold { get; set; }
Visual C++
public:
property GateDeviceThreshold^ Threshold {
    GateDeviceThreshold^ get ();
    void set (GateDeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

GateDeviceGateDevice Class


type Property

[image]

.NET Framework Class Library
GateDeviceGateDevice..::.type Property
GateDeviceGateDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GateDeviceGateDevice Class


GateDeviceGatedVolume Class

[image]

.NET Framework Class Library
GateDeviceGatedVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceGatedVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceGatedVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceGatedVolume
JavaScript
NRenoiseTools.GateDeviceGatedVolume = function();

Type.createClass(
    'NRenoiseTools.GateDeviceGatedVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceGatedVolume

See Also

GateDeviceGatedVolume Members


GateDeviceGatedVolume Members

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolume Members
GateDeviceGatedVolume Class Constructors Methods Properties See Also Send Feedback

The GateDeviceGatedVolume type exposes the following members.

Constructors

Name | Description
GateDeviceGatedVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceGatedVolume Class


GateDeviceGatedVolume Constructor

[image]

.NET Framework Class Library
GateDeviceGatedVolume Constructor
GateDeviceGatedVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceGatedVolume()
Visual C++
public:
GateDeviceGatedVolume()
JavaScript
NRenoiseTools.GateDeviceGatedVolume = function();

See Also

GateDeviceGatedVolume Class


GateDeviceGatedVolume Methods

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolume Methods
GateDeviceGatedVolume Class See Also Send Feedback

The GateDeviceGatedVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceGatedVolume Class


GateDeviceGatedVolume Properties

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolume Properties
GateDeviceGatedVolume Class See Also Send Feedback

The GateDeviceGatedVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceGatedVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
GateDeviceGatedVolume..::.MidiMappings Property
GateDeviceGatedVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GateDeviceGatedVolume Class


Value Property

[image]

.NET Framework Class Library
GateDeviceGatedVolume..::.Value Property
GateDeviceGatedVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceGatedVolume Class


Visualization Property

[image]

.NET Framework Class Library
GateDeviceGatedVolume..::.Visualization Property
GateDeviceGatedVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GateDeviceGatedVolumeVisualization
C#
public GateDeviceGatedVolumeVisualization Visualization { get; set; }
Visual C++
public:
property GateDeviceGatedVolumeVisualization Visualization {
    GateDeviceGatedVolumeVisualization get ();
    void set (GateDeviceGatedVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GateDeviceGatedVolume Class


GateDeviceGatedVolumeRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceGatedVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceGatedVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceGatedVolumeRunTimePreset
JavaScript
NRenoiseTools.GateDeviceGatedVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceGatedVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceGatedVolumeRunTimePreset

See Also

GateDeviceGatedVolumeRunTimePreset Members


GateDeviceGatedVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset Members
GateDeviceGatedVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceGatedVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceGatedVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GateDeviceGatedVolumeRunTimePreset Class


GateDeviceGatedVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset Constructor
GateDeviceGatedVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceGatedVolumeRunTimePreset()
Visual C++
public:
GateDeviceGatedVolumeRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceGatedVolumeRunTimePreset = function();

See Also

GateDeviceGatedVolumeRunTimePreset Class


GateDeviceGatedVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset Methods
GateDeviceGatedVolumeRunTimePreset Class See Also Send Feedback

The GateDeviceGatedVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceGatedVolumeRunTimePreset Class


GateDeviceGatedVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset Properties
GateDeviceGatedVolumeRunTimePreset Class See Also Send Feedback

The GateDeviceGatedVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GateDeviceGatedVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GateDeviceGatedVolumeRunTimePreset..::.Value Property
GateDeviceGatedVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceGatedVolumeRunTimePreset Class


GateDeviceGatedVolumeVisualization Enumeration

[image]

.NET Framework Class Library
GateDeviceGatedVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GateDeviceGatedVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GateDeviceGatedVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GateDeviceGatedVolumeVisualization
JavaScript
NRenoiseTools.GateDeviceGatedVolumeVisualization = function();
NRenoiseTools.GateDeviceGatedVolumeVisualization.createEnum('NRenoiseTools.GateDeviceGatedVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GateDeviceHoldInMs Class

[image]

.NET Framework Class Library
GateDeviceHoldInMs Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceHoldInMs
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceHoldInMs
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceHoldInMs
JavaScript
NRenoiseTools.GateDeviceHoldInMs = function();

Type.createClass(
    'NRenoiseTools.GateDeviceHoldInMs');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceHoldInMs

See Also

GateDeviceHoldInMs Members


GateDeviceHoldInMs Members

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMs Members
GateDeviceHoldInMs Class Constructors Methods Properties See Also Send Feedback

The GateDeviceHoldInMs type exposes the following members.

Constructors

Name | Description
GateDeviceHoldInMs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceHoldInMs Class


GateDeviceHoldInMs Constructor

[image]

.NET Framework Class Library
GateDeviceHoldInMs Constructor
GateDeviceHoldInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceHoldInMs()
Visual C++
public:
GateDeviceHoldInMs()
JavaScript
NRenoiseTools.GateDeviceHoldInMs = function();

See Also

GateDeviceHoldInMs Class


GateDeviceHoldInMs Methods

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMs Methods
GateDeviceHoldInMs Class See Also Send Feedback

The GateDeviceHoldInMs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceHoldInMs Class


GateDeviceHoldInMs Properties

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMs Properties
GateDeviceHoldInMs Class See Also Send Feedback

The GateDeviceHoldInMs type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceHoldInMs Class


MidiMappings Property

[image]

.NET Framework Class Library
GateDeviceHoldInMs..::.MidiMappings Property
GateDeviceHoldInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GateDeviceHoldInMs Class


Value Property

[image]

.NET Framework Class Library
GateDeviceHoldInMs..::.Value Property
GateDeviceHoldInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceHoldInMs Class


Visualization Property

[image]

.NET Framework Class Library
GateDeviceHoldInMs..::.Visualization Property
GateDeviceHoldInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GateDeviceHoldInMsVisualization
C#
public GateDeviceHoldInMsVisualization Visualization { get; set; }
Visual C++
public:
property GateDeviceHoldInMsVisualization Visualization {
    GateDeviceHoldInMsVisualization get ();
    void set (GateDeviceHoldInMsVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GateDeviceHoldInMs Class


GateDeviceHoldInMsRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceHoldInMsRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceHoldInMsRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceHoldInMsRunTimePreset
JavaScript
NRenoiseTools.GateDeviceHoldInMsRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceHoldInMsRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceHoldInMsRunTimePreset

See Also

GateDeviceHoldInMsRunTimePreset Members


GateDeviceHoldInMsRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset Members
GateDeviceHoldInMsRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceHoldInMsRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceHoldInMsRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GateDeviceHoldInMsRunTimePreset Class


GateDeviceHoldInMsRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset Constructor
GateDeviceHoldInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceHoldInMsRunTimePreset()
Visual C++
public:
GateDeviceHoldInMsRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceHoldInMsRunTimePreset = function();

See Also

GateDeviceHoldInMsRunTimePreset Class


GateDeviceHoldInMsRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset Methods
GateDeviceHoldInMsRunTimePreset Class See Also Send Feedback

The GateDeviceHoldInMsRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceHoldInMsRunTimePreset Class


GateDeviceHoldInMsRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset Properties
GateDeviceHoldInMsRunTimePreset Class See Also Send Feedback

The GateDeviceHoldInMsRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GateDeviceHoldInMsRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GateDeviceHoldInMsRunTimePreset..::.Value Property
GateDeviceHoldInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceHoldInMsRunTimePreset Class


GateDeviceHoldInMsVisualization Enumeration

[image]

.NET Framework Class Library
GateDeviceHoldInMsVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GateDeviceHoldInMsVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GateDeviceHoldInMsVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GateDeviceHoldInMsVisualization
JavaScript
NRenoiseTools.GateDeviceHoldInMsVisualization = function();
NRenoiseTools.GateDeviceHoldInMsVisualization.createEnum('NRenoiseTools.GateDeviceHoldInMsVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GateDeviceReleaseInMs Class

[image]

.NET Framework Class Library
GateDeviceReleaseInMs Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceReleaseInMs
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceReleaseInMs
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceReleaseInMs
JavaScript
NRenoiseTools.GateDeviceReleaseInMs = function();

Type.createClass(
    'NRenoiseTools.GateDeviceReleaseInMs');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceReleaseInMs

See Also

GateDeviceReleaseInMs Members


GateDeviceReleaseInMs Members

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMs Members
GateDeviceReleaseInMs Class Constructors Methods Properties See Also Send Feedback

The GateDeviceReleaseInMs type exposes the following members.

Constructors

Name | Description
GateDeviceReleaseInMs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceReleaseInMs Class


GateDeviceReleaseInMs Constructor

[image]

.NET Framework Class Library
GateDeviceReleaseInMs Constructor
GateDeviceReleaseInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceReleaseInMs()
Visual C++
public:
GateDeviceReleaseInMs()
JavaScript
NRenoiseTools.GateDeviceReleaseInMs = function();

See Also

GateDeviceReleaseInMs Class


GateDeviceReleaseInMs Methods

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMs Methods
GateDeviceReleaseInMs Class See Also Send Feedback

The GateDeviceReleaseInMs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceReleaseInMs Class


GateDeviceReleaseInMs Properties

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMs Properties
GateDeviceReleaseInMs Class See Also Send Feedback

The GateDeviceReleaseInMs type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceReleaseInMs Class


MidiMappings Property

[image]

.NET Framework Class Library
GateDeviceReleaseInMs..::.MidiMappings Property
GateDeviceReleaseInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GateDeviceReleaseInMs Class


Value Property

[image]

.NET Framework Class Library
GateDeviceReleaseInMs..::.Value Property
GateDeviceReleaseInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceReleaseInMs Class


Visualization Property

[image]

.NET Framework Class Library
GateDeviceReleaseInMs..::.Visualization Property
GateDeviceReleaseInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GateDeviceReleaseInMsVisualization
C#
public GateDeviceReleaseInMsVisualization Visualization { get; set; }
Visual C++
public:
property GateDeviceReleaseInMsVisualization Visualization {
    GateDeviceReleaseInMsVisualization get ();
    void set (GateDeviceReleaseInMsVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GateDeviceReleaseInMs Class


GateDeviceReleaseInMsRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceReleaseInMsRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceReleaseInMsRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceReleaseInMsRunTimePreset
JavaScript
NRenoiseTools.GateDeviceReleaseInMsRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceReleaseInMsRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceReleaseInMsRunTimePreset

See Also

GateDeviceReleaseInMsRunTimePreset Members


GateDeviceReleaseInMsRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset Members
GateDeviceReleaseInMsRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceReleaseInMsRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceReleaseInMsRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GateDeviceReleaseInMsRunTimePreset Class


GateDeviceReleaseInMsRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset Constructor
GateDeviceReleaseInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceReleaseInMsRunTimePreset()
Visual C++
public:
GateDeviceReleaseInMsRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceReleaseInMsRunTimePreset = function();

See Also

GateDeviceReleaseInMsRunTimePreset Class


GateDeviceReleaseInMsRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset Methods
GateDeviceReleaseInMsRunTimePreset Class See Also Send Feedback

The GateDeviceReleaseInMsRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceReleaseInMsRunTimePreset Class


GateDeviceReleaseInMsRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset Properties
GateDeviceReleaseInMsRunTimePreset Class See Also Send Feedback

The GateDeviceReleaseInMsRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GateDeviceReleaseInMsRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GateDeviceReleaseInMsRunTimePreset..::.Value Property
GateDeviceReleaseInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceReleaseInMsRunTimePreset Class


GateDeviceReleaseInMsVisualization Enumeration

[image]

.NET Framework Class Library
GateDeviceReleaseInMsVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GateDeviceReleaseInMsVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GateDeviceReleaseInMsVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GateDeviceReleaseInMsVisualization
JavaScript
NRenoiseTools.GateDeviceReleaseInMsVisualization = function();
NRenoiseTools.GateDeviceReleaseInMsVisualization.createEnum('NRenoiseTools.GateDeviceReleaseInMsVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GateDeviceRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceRunTimePreset
JavaScript
NRenoiseTools.GateDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceRunTimePreset

See Also

GateDeviceRunTimePreset Members


GateDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceRunTimePreset Members
GateDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

GateDeviceRunTimePreset Class


GateDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceRunTimePreset Constructor
GateDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceRunTimePreset()
Visual C++
public:
GateDeviceRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceRunTimePreset = function();

See Also

GateDeviceRunTimePreset Class


GateDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceRunTimePreset Methods
GateDeviceRunTimePreset Class See Also Send Feedback

The GateDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceRunTimePreset Class


GateDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceRunTimePreset Properties
GateDeviceRunTimePreset Class See Also Send Feedback

The GateDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

GateDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
GateDeviceRunTimePreset..::.DeviceSlot Property
GateDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As GateDeviceDeviceSlotRunTimePreset
C#
public GateDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property GateDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    GateDeviceDeviceSlotRunTimePreset^ get ();
    void set (GateDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

GateDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
GateDeviceRunTimePreset..::.type Property
GateDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

GateDeviceRunTimePreset Class


GateDeviceThreshold Class

[image]

.NET Framework Class Library
GateDeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceThreshold
JavaScript
NRenoiseTools.GateDeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.GateDeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceThreshold

See Also

GateDeviceThreshold Members


GateDeviceThreshold Members

[image] [image]

.NET Framework Class Library
GateDeviceThreshold Members
GateDeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The GateDeviceThreshold type exposes the following members.

Constructors

Name | Description
GateDeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceThreshold Class


GateDeviceThreshold Constructor

[image]

.NET Framework Class Library
GateDeviceThreshold Constructor
GateDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceThreshold()
Visual C++
public:
GateDeviceThreshold()
JavaScript
NRenoiseTools.GateDeviceThreshold = function();

See Also

GateDeviceThreshold Class


GateDeviceThreshold Methods

[image] [image]

.NET Framework Class Library
GateDeviceThreshold Methods
GateDeviceThreshold Class See Also Send Feedback

The GateDeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceThreshold Class


GateDeviceThreshold Properties

[image] [image]

.NET Framework Class Library
GateDeviceThreshold Properties
GateDeviceThreshold Class See Also Send Feedback

The GateDeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

GateDeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
GateDeviceThreshold..::.MidiMappings Property
GateDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

GateDeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
GateDeviceThreshold..::.Value Property
GateDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
GateDeviceThreshold..::.Visualization Property
GateDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As GateDeviceThresholdVisualization
C#
public GateDeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property GateDeviceThresholdVisualization Visualization {
    GateDeviceThresholdVisualization get ();
    void set (GateDeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

GateDeviceThreshold Class


GateDeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GateDeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GateDeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GateDeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.GateDeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.GateDeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GateDeviceThresholdRunTimePreset

See Also

GateDeviceThresholdRunTimePreset Members


GateDeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset Members
GateDeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The GateDeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
GateDeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

GateDeviceThresholdRunTimePreset Class


GateDeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset Constructor
GateDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GateDeviceThresholdRunTimePreset()
Visual C++
public:
GateDeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.GateDeviceThresholdRunTimePreset = function();

See Also

GateDeviceThresholdRunTimePreset Class


GateDeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset Methods
GateDeviceThresholdRunTimePreset Class See Also Send Feedback

The GateDeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GateDeviceThresholdRunTimePreset Class


GateDeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset Properties
GateDeviceThresholdRunTimePreset Class See Also Send Feedback

The GateDeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

GateDeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
GateDeviceThresholdRunTimePreset..::.Value Property
GateDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

GateDeviceThresholdRunTimePreset Class


GateDeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
GateDeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration GateDeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum GateDeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class GateDeviceThresholdVisualization
JavaScript
NRenoiseTools.GateDeviceThresholdVisualization = function();
NRenoiseTools.GateDeviceThresholdVisualization.createEnum('NRenoiseTools.GateDeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


GlobalSongData Class

[image]

.NET Framework Class Library
GlobalSongData Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class GlobalSongData
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class GlobalSongData
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class GlobalSongData
JavaScript
NRenoiseTools.GlobalSongData = function();

Type.createClass(
    'NRenoiseTools.GlobalSongData');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.GlobalSongData

See Also

GlobalSongData Members


GlobalSongData Members

[image] [image]

.NET Framework Class Library
GlobalSongData Members
GlobalSongData Class Constructors Methods Properties See Also Send Feedback

The GlobalSongData type exposes the following members.

Constructors

Name | Description
GlobalSongData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Artist |
BeatsPerMin |
EditStep |
LinesPerBeat |
LoopCoeff |
LoopPlay |
LoopStart |
NewSampleNameCounter |
Octave |
PitchEffectsCompatibilityMode |
PlaybackEngineVersion |
RecordQuantizationAmount |
RecordQuantizationEnabled |
RecordSampleNameCounter |
RenderSelectionNameCounter |
SampleOffsetCompatibilityMode |
ShowSongCommentsAfterLoading |
ShowUsedAutomationsOnly |
ShuffleAmounts |
ShuffleIsActive |
SongComments |
SongName |
TicksPerLine |

See Also

GlobalSongData Class


GlobalSongData Constructor

[image]

.NET Framework Class Library
GlobalSongData Constructor
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GlobalSongData()
Visual C++
public:
GlobalSongData()
JavaScript
NRenoiseTools.GlobalSongData = function();

See Also

GlobalSongData Class


GlobalSongData Methods

[image] [image]

.NET Framework Class Library
GlobalSongData Methods
GlobalSongData Class See Also Send Feedback

The GlobalSongData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalSongData Class


GlobalSongData Properties

[image] [image]

.NET Framework Class Library
GlobalSongData Properties
GlobalSongData Class See Also Send Feedback

The GlobalSongData type exposes the following members.

Properties

Name | Description
Artist |
BeatsPerMin |
EditStep |
LinesPerBeat |
LoopCoeff |
LoopPlay |
LoopStart |
NewSampleNameCounter |
Octave |
PitchEffectsCompatibilityMode |
PlaybackEngineVersion |
RecordQuantizationAmount |
RecordQuantizationEnabled |
RecordSampleNameCounter |
RenderSelectionNameCounter |
SampleOffsetCompatibilityMode |
ShowSongCommentsAfterLoading |
ShowUsedAutomationsOnly |
ShuffleAmounts |
ShuffleIsActive |
SongComments |
SongName |
TicksPerLine |

See Also

GlobalSongData Class


Artist Property

[image]

.NET Framework Class Library
GlobalSongData..::.Artist Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Artist As String
C#
public string Artist { get; set; }
Visual C++
public:
property String^ Artist {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_artist();
function set_artist(value);

Remarks

See Also

GlobalSongData Class


BeatsPerMin Property

[image]

.NET Framework Class Library
GlobalSongData..::.BeatsPerMin Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BeatsPerMin As Single
C#
public float BeatsPerMin { get; set; }
Visual C++
public:
property float BeatsPerMin {
    float get ();
    void set (float value);
}
JavaScript
function get_beatsPerMin();
function set_beatsPerMin(value);

Remarks

See Also

GlobalSongData Class


EditStep Property

[image]

.NET Framework Class Library
GlobalSongData..::.EditStep Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property EditStep As Integer
C#
public int EditStep { get; set; }
Visual C++
public:
property int EditStep {
    int get ();
    void set (int value);
}
JavaScript
function get_editStep();
function set_editStep(value);

Remarks

See Also

GlobalSongData Class


LinesPerBeat Property

[image]

.NET Framework Class Library
GlobalSongData..::.LinesPerBeat Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LinesPerBeat As Integer
C#
public int LinesPerBeat { get; set; }
Visual C++
public:
property int LinesPerBeat {
    int get ();
    void set (int value);
}
JavaScript
function get_linesPerBeat();
function set_linesPerBeat(value);

Remarks

See Also

GlobalSongData Class


LoopCoeff Property

[image]

.NET Framework Class Library
GlobalSongData..::.LoopCoeff Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopCoeff As Integer
C#
public int LoopCoeff { get; set; }
Visual C++
public:
property int LoopCoeff {
    int get ();
    void set (int value);
}
JavaScript
function get_loopCoeff();
function set_loopCoeff(value);

Remarks

See Also

GlobalSongData Class


LoopPlay Property

[image]

.NET Framework Class Library
GlobalSongData..::.LoopPlay Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopPlay As Boolean
C#
public bool LoopPlay { get; set; }
Visual C++
public:
property bool LoopPlay {
    bool get ();
    void set (bool value);
}
JavaScript
function get_loopPlay();
function set_loopPlay(value);

Remarks

See Also

GlobalSongData Class


LoopStart Property

[image]

.NET Framework Class Library
GlobalSongData..::.LoopStart Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

GlobalSongData Class


NewSampleNameCounter Property

[image]

.NET Framework Class Library
GlobalSongData..::.NewSampleNameCounter Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NewSampleNameCounter As Integer
C#
public int NewSampleNameCounter { get; set; }
Visual C++
public:
property int NewSampleNameCounter {
    int get ();
    void set (int value);
}
JavaScript
function get_newSampleNameCounter();
function set_newSampleNameCounter(value);

Remarks

See Also

GlobalSongData Class


Octave Property

[image]

.NET Framework Class Library
GlobalSongData..::.Octave Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Octave As Integer
C#
public int Octave { get; set; }
Visual C++
public:
property int Octave {
    int get ();
    void set (int value);
}
JavaScript
function get_octave();
function set_octave(value);

Remarks

See Also

GlobalSongData Class


PitchEffectsCompatibilityMode Property

[image]

.NET Framework Class Library
GlobalSongData..::.PitchEffectsCompatibilityMode Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PitchEffectsCompatibilityMode As Boolean
C#
public bool PitchEffectsCompatibilityMode { get; set; }
Visual C++
public:
property bool PitchEffectsCompatibilityMode {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pitchEffectsCompatibilityMode();
function set_pitchEffectsCompatibilityMode(value);

Remarks

See Also

GlobalSongData Class


PlaybackEngineVersion Property

[image]

.NET Framework Class Library
GlobalSongData..::.PlaybackEngineVersion Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlaybackEngineVersion As Integer
C#
public int PlaybackEngineVersion { get; set; }
Visual C++
public:
property int PlaybackEngineVersion {
    int get ();
    void set (int value);
}
JavaScript
function get_playbackEngineVersion();
function set_playbackEngineVersion(value);

Remarks

See Also

GlobalSongData Class


RecordQuantizationAmount Property

[image]

.NET Framework Class Library
GlobalSongData..::.RecordQuantizationAmount Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RecordQuantizationAmount As Integer
C#
public int RecordQuantizationAmount { get; set; }
Visual C++
public:
property int RecordQuantizationAmount {
    int get ();
    void set (int value);
}
JavaScript
function get_recordQuantizationAmount();
function set_recordQuantizationAmount(value);

Remarks

See Also

GlobalSongData Class


RecordQuantizationEnabled Property

[image]

.NET Framework Class Library
GlobalSongData..::.RecordQuantizationEnabled Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RecordQuantizationEnabled As Boolean
C#
public bool RecordQuantizationEnabled { get; set; }
Visual C++
public:
property bool RecordQuantizationEnabled {
    bool get ();
    void set (bool value);
}
JavaScript
function get_recordQuantizationEnabled();
function set_recordQuantizationEnabled(value);

Remarks

See Also

GlobalSongData Class


RecordSampleNameCounter Property

[image]

.NET Framework Class Library
GlobalSongData..::.RecordSampleNameCounter Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RecordSampleNameCounter As Integer
C#
public int RecordSampleNameCounter { get; set; }
Visual C++
public:
property int RecordSampleNameCounter {
    int get ();
    void set (int value);
}
JavaScript
function get_recordSampleNameCounter();
function set_recordSampleNameCounter(value);

Remarks

See Also

GlobalSongData Class


RenderSelectionNameCounter Property

[image]

.NET Framework Class Library
GlobalSongData..::.RenderSelectionNameCounter Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RenderSelectionNameCounter As Integer
C#
public int RenderSelectionNameCounter { get; set; }
Visual C++
public:
property int RenderSelectionNameCounter {
    int get ();
    void set (int value);
}
JavaScript
function get_renderSelectionNameCounter();
function set_renderSelectionNameCounter(value);

Remarks

See Also

GlobalSongData Class


SampleOffsetCompatibilityMode Property

[image]

.NET Framework Class Library
GlobalSongData..::.SampleOffsetCompatibilityMode Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SampleOffsetCompatibilityMode As Boolean
C#
public bool SampleOffsetCompatibilityMode { get; set; }
Visual C++
public:
property bool SampleOffsetCompatibilityMode {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sampleOffsetCompatibilityMode();
function set_sampleOffsetCompatibilityMode(value);

Remarks

See Also

GlobalSongData Class


ShowSongCommentsAfterLoading Property

[image]

.NET Framework Class Library
GlobalSongData..::.ShowSongCommentsAfterLoading Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowSongCommentsAfterLoading As Boolean
C#
public bool ShowSongCommentsAfterLoading { get; set; }
Visual C++
public:
property bool ShowSongCommentsAfterLoading {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showSongCommentsAfterLoading();
function set_showSongCommentsAfterLoading(value);

Remarks

See Also

GlobalSongData Class


ShowUsedAutomationsOnly Property

[image]

.NET Framework Class Library
GlobalSongData..::.ShowUsedAutomationsOnly Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowUsedAutomationsOnly As Boolean
C#
public bool ShowUsedAutomationsOnly { get; set; }
Visual C++
public:
property bool ShowUsedAutomationsOnly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showUsedAutomationsOnly();
function set_showUsedAutomationsOnly(value);

Remarks

See Also

GlobalSongData Class


ShuffleAmounts Property

[image]

.NET Framework Class Library
GlobalSongData..::.ShuffleAmounts Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShuffleAmounts As Integer()
C#
public int[] ShuffleAmounts { get; set; }
Visual C++
public:
property array<int>^ ShuffleAmounts {
    array<int>^ get ();
    void set (array<int>^ value);
}
JavaScript
function get_shuffleAmounts();
function set_shuffleAmounts(value);

Remarks

See Also

GlobalSongData Class


ShuffleIsActive Property

[image]

.NET Framework Class Library
GlobalSongData..::.ShuffleIsActive Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShuffleIsActive As Boolean
C#
public bool ShuffleIsActive { get; set; }
Visual C++
public:
property bool ShuffleIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shuffleIsActive();
function set_shuffleIsActive(value);

Remarks

See Also

GlobalSongData Class


SongComments Property

[image]

.NET Framework Class Library
GlobalSongData..::.SongComments Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SongComments As String()
C#
public string[] SongComments { get; set; }
Visual C++
public:
property array<String^>^ SongComments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_songComments();
function set_songComments(value);

Remarks

See Also

GlobalSongData Class


SongName Property

[image]

.NET Framework Class Library
GlobalSongData..::.SongName Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SongName As String
C#
public string SongName { get; set; }
Visual C++
public:
property String^ SongName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_songName();
function set_songName(value);

Remarks

See Also

GlobalSongData Class


TicksPerLine Property

[image]

.NET Framework Class Library
GlobalSongData..::.TicksPerLine Property
GlobalSongData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TicksPerLine As Integer
C#
public int TicksPerLine { get; set; }
Visual C++
public:
property int TicksPerLine {
    int get ();
    void set (int value);
}
JavaScript
function get_ticksPerLine();
function set_ticksPerLine(value);

Remarks

See Also

GlobalSongData Class


Instrument Class

[image]

.NET Framework Class Library
Instrument Class
Members See Also Send Feedback

Main Renoise Instrument class. Use this class to create and manipulate Renoise Instrument.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Instrument
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Instrument
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Instrument
JavaScript
NRenoiseTools.Instrument = function();

Type.createClass(
    'NRenoiseTools.Instrument');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Instrument
NRenoiseTools..::.RenoiseInstrument

See Also

Instrument Members


Instrument Members

[image] [image]

.NET Framework Class Library
Instrument Members
Instrument Class Constructors Methods Properties See Also Send Feedback

The Instrument type exposes the following members.

Constructors

Name | Description
Instrument | Initializes a new instance of the Instrument class.

Methods

Name | Description
Copy | Copies this instrument to another instrument.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CopyIntoNewInstrumentNameCounter |
CopyIntoNewSampleNameCounter |
Envelopes |
FileName | Gets or sets the name of the file used to store the RenoiseInstrument. This property is set when loading song from a file Load(String).
MidiProperties |
Name |
PluginProperties |
Samples |
SplitMap |

See Also

Instrument Class


Instrument Constructor

[image]

.NET Framework Class Library
Instrument Constructor
Instrument Class See Also Send Feedback

Initializes a new instance of the Instrument class.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Instrument()
Visual C++
public:
Instrument()
JavaScript
NRenoiseTools.Instrument = function();

See Also

Instrument Class


Instrument Methods

[image] [image]

.NET Framework Class Library
Instrument Methods
Instrument Class See Also Send Feedback

The Instrument type exposes the following members.

Methods

Name | Description
Copy | Copies this instrument to another instrument.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Instrument Class


Copy Method

[image]

.NET Framework Class Library
Instrument..::.Copy Method
Instrument Class See Also Send Feedback

Copies this instrument to another instrument.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Copy ( _
    toInstrument As Instrument _
)
C#
public void Copy(
    Instrument toInstrument
)
Visual C++
public:
void Copy(
    Instrument^ toInstrument
)
JavaScript
function copy(toInstrument);

Parameters

toInstrument
Type: NRenoiseTools..::.Instrument
instrument to copy to.

See Also

Instrument Class


Load Method

[image] [image]

.NET Framework Class Library
Instrument..::.Load Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads a xrni Renoise instrument from a specified stream.
Load(String) | Loads a xrni Renoise instrument from a specified file name.

See Also

Instrument Class
Instrument Members


Load Method (Stream)

[image]

.NET Framework Class Library
Instrument..::.Load Method (Stream)
Instrument Class See Also Send Feedback

Loads a xrni Renoise instrument from a specified stream.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load ( _
    xrniInputStream As Stream _
)
C#
public void Load(
    Stream xrniInputStream
)
Visual C++
public:
void Load(
    Stream^ xrniInputStream
)
JavaScript
function load(xrniInputStream);

Parameters

xrniInputStream
Type: System.IO..::.Stream
The XRNI input stream.

See Also

Instrument Class
Load Overload


Load Method (String)

[image]

.NET Framework Class Library
Instrument..::.Load Method (String)
Instrument Class See Also Send Feedback

Loads a xrni Renoise instrument from a specified file name.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load ( _
    fileNameArg As String _
)
C#
public void Load(
    string fileNameArg
)
Visual C++
public:
void Load(
    String^ fileNameArg
)
JavaScript
function load(fileNameArg);

Parameters

fileNameArg
Type: System..::.String
Name of the xrni Renoise file.

See Also

Instrument Class
Load Overload


Save Method

[image] [image]

.NET Framework Class Library
Instrument..::.Save Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Save()()() | Writes this xrni Renoise instrument to the default filename file.
Save(Stream) | Writes this xrni Renoise instrument from a specified output stream.
Save(String) | Writes this xrni Renoise instrument to a specified output file.

See Also

Instrument Class
Instrument Members


Save Method

[image]

.NET Framework Class Library
Instrument..::.Save Method
Instrument Class See Also Send Feedback

Writes this xrni Renoise instrument to the default filename file.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save
C#
public void Save()
Visual C++
public:
void Save()
JavaScript
function save();

See Also

Instrument Class
Save Overload


Save Method (Stream)

[image]

.NET Framework Class Library
Instrument..::.Save Method (Stream)
Instrument Class See Also Send Feedback

Writes this xrni Renoise instrument from a specified output stream.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save ( _
    xrniOutputStream As Stream _
)
C#
public void Save(
    Stream xrniOutputStream
)
Visual C++
public:
void Save(
    Stream^ xrniOutputStream
)
JavaScript
function save(xrniOutputStream);

Parameters

xrniOutputStream
Type: System.IO..::.Stream
The XRNI output stream.

See Also

Instrument Class
Save Overload


Save Method (String)

[image]

.NET Framework Class Library
Instrument..::.Save Method (String)
Instrument Class See Also Send Feedback

Writes this xrni Renoise instrument to a specified output file.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save ( _
    fileNameArg As String _
)
C#
public void Save(
    string fileNameArg
)
Visual C++
public:
void Save(
    String^ fileNameArg
)
JavaScript
function save(fileNameArg);

Parameters

fileNameArg
Type: System..::.String
Name of the file.

See Also

Instrument Class
Save Overload


Instrument Properties

[image] [image]

.NET Framework Class Library
Instrument Properties
Instrument Class See Also Send Feedback

The Instrument type exposes the following members.

Properties

Name | Description
CopyIntoNewInstrumentNameCounter |
CopyIntoNewSampleNameCounter |
Envelopes |
FileName | Gets or sets the name of the file used to store the RenoiseInstrument. This property is set when loading song from a file Load(String).
MidiProperties |
Name |
PluginProperties |
Samples |
SplitMap |

See Also

Instrument Class


CopyIntoNewInstrumentNameCounter Property

[image]

.NET Framework Class Library
Instrument..::.CopyIntoNewInstrumentNameCounter Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyIntoNewInstrumentNameCounter As Integer
C#
public int CopyIntoNewInstrumentNameCounter { get; set; }
Visual C++
public:
property int CopyIntoNewInstrumentNameCounter {
    int get ();
    void set (int value);
}
JavaScript
function get_copyIntoNewInstrumentNameCounter();
function set_copyIntoNewInstrumentNameCounter(value);

Remarks

See Also

Instrument Class


CopyIntoNewSampleNameCounter Property

[image]

.NET Framework Class Library
Instrument..::.CopyIntoNewSampleNameCounter Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyIntoNewSampleNameCounter As Integer
C#
public int CopyIntoNewSampleNameCounter { get; set; }
Visual C++
public:
property int CopyIntoNewSampleNameCounter {
    int get ();
    void set (int value);
}
JavaScript
function get_copyIntoNewSampleNameCounter();
function set_copyIntoNewSampleNameCounter(value);

Remarks

See Also

Instrument Class


Envelopes Property

[image]

.NET Framework Class Library
Instrument..::.Envelopes Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Envelopes As Envelopes
C#
public Envelopes Envelopes { get; set; }
Visual C++
public:
property Envelopes^ Envelopes {
    Envelopes^ get ();
    void set (Envelopes^ value);
}
JavaScript
function get_envelopes();
function set_envelopes(value);

Remarks

See Also

Instrument Class


FileName Property

[image]

.NET Framework Class Library
Instrument..::.FileName Property
Instrument Class See Also Send Feedback

Gets or sets the name of the file used to store the RenoiseInstrument. This property is set when loading song from a file Load(String).

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

Field Value

The name of the file.

See Also

Instrument Class


MidiProperties Property

[image]

.NET Framework Class Library
Instrument..::.MidiProperties Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiProperties As MidiProperties
C#
public MidiProperties MidiProperties { get; set; }
Visual C++
public:
property MidiProperties^ MidiProperties {
    MidiProperties^ get ();
    void set (MidiProperties^ value);
}
JavaScript
function get_midiProperties();
function set_midiProperties(value);

Remarks

See Also

Instrument Class


Name Property

[image]

.NET Framework Class Library
Instrument..::.Name Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

Instrument Class


PluginProperties Property

[image]

.NET Framework Class Library
Instrument..::.PluginProperties Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginProperties As PluginProperties
C#
public PluginProperties PluginProperties { get; set; }
Visual C++
public:
property PluginProperties^ PluginProperties {
    PluginProperties^ get ();
    void set (PluginProperties^ value);
}
JavaScript
function get_pluginProperties();
function set_pluginProperties(value);

Remarks

See Also

Instrument Class


Samples Property

[image]

.NET Framework Class Library
Instrument..::.Samples Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Samples As Sample()
C#
public Sample[] Samples { get; set; }
Visual C++
public:
property array<Sample^>^ Samples {
    array<Sample^>^ get ();
    void set (array<Sample^>^ value);
}
JavaScript
function get_samples();
function set_samples(value);

Remarks

See Also

Instrument Class


SplitMap Property

[image]

.NET Framework Class Library
Instrument..::.SplitMap Property
Instrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SplitMap As Integer()
C#
public int[] SplitMap { get; set; }
Visual C++
public:
property array<int>^ SplitMap {
    array<int>^ get ();
    void set (array<int>^ value);
}
JavaScript
function get_splitMap();
function set_splitMap(value);

Remarks

See Also

Instrument Class


InstrumentAutomationDevice Class

[image]

.NET Framework Class Library
InstrumentAutomationDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class InstrumentAutomationDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class InstrumentAutomationDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class InstrumentAutomationDevice
JavaScript
NRenoiseTools.InstrumentAutomationDevice = function();

Type.createClass(
    'NRenoiseTools.InstrumentAutomationDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.InstrumentAutomationDevice

See Also

InstrumentAutomationDevice Members


InstrumentAutomationDevice Members

[image] [image]

.NET Framework Class Library
InstrumentAutomationDevice Members
InstrumentAutomationDevice Class Constructors Methods Properties See Also Send Feedback

The InstrumentAutomationDevice type exposes the following members.

Constructors

Name | Description
InstrumentAutomationDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
LinkedInstrument |
ParameterNumber0 |
ParameterNumber1 |
ParameterNumber10 |
ParameterNumber11 |
ParameterNumber12 |
ParameterNumber13 |
ParameterNumber2 |
ParameterNumber3 |
ParameterNumber4 |
ParameterNumber5 |
ParameterNumber6 |
ParameterNumber7 |
ParameterNumber8 |
ParameterNumber9 |
ParameterValue0 |
ParameterValue1 |
ParameterValue10 |
ParameterValue11 |
ParameterValue12 |
ParameterValue13 |
ParameterValue2 |
ParameterValue3 |
ParameterValue4 |
ParameterValue5 |
ParameterValue6 |
ParameterValue7 |
ParameterValue8 |
ParameterValue9 |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
VisiblePages |

See Also

InstrumentAutomationDevice Class


InstrumentAutomationDevice Constructor

[image]

.NET Framework Class Library
InstrumentAutomationDevice Constructor
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InstrumentAutomationDevice()
Visual C++
public:
InstrumentAutomationDevice()
JavaScript
NRenoiseTools.InstrumentAutomationDevice = function();

See Also

InstrumentAutomationDevice Class


InstrumentAutomationDevice Methods

[image] [image]

.NET Framework Class Library
InstrumentAutomationDevice Methods
InstrumentAutomationDevice Class See Also Send Feedback

The InstrumentAutomationDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstrumentAutomationDevice Class


InstrumentAutomationDevice Properties

[image] [image]

.NET Framework Class Library
InstrumentAutomationDevice Properties
InstrumentAutomationDevice Class See Also Send Feedback

The InstrumentAutomationDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
LinkedInstrument |
ParameterNumber0 |
ParameterNumber1 |
ParameterNumber10 |
ParameterNumber11 |
ParameterNumber12 |
ParameterNumber13 |
ParameterNumber2 |
ParameterNumber3 |
ParameterNumber4 |
ParameterNumber5 |
ParameterNumber6 |
ParameterNumber7 |
ParameterNumber8 |
ParameterNumber9 |
ParameterValue0 |
ParameterValue1 |
ParameterValue10 |
ParameterValue11 |
ParameterValue12 |
ParameterValue13 |
ParameterValue2 |
ParameterValue3 |
ParameterValue4 |
ParameterValue5 |
ParameterValue6 |
ParameterValue7 |
ParameterValue8 |
ParameterValue9 |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
VisiblePages |

See Also

InstrumentAutomationDevice Class


IsActive Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.IsActive Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

InstrumentAutomationDevice Class


IsSelected Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.IsSelected Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

InstrumentAutomationDevice Class


LinkedInstrument Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.LinkedInstrument Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LinkedInstrument As Integer
C#
public int LinkedInstrument { get; set; }
Visual C++
public:
property int LinkedInstrument {
    int get ();
    void set (int value);
}
JavaScript
function get_linkedInstrument();
function set_linkedInstrument(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber0 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber0 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber0 As Integer
C#
public int ParameterNumber0 { get; set; }
Visual C++
public:
property int ParameterNumber0 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber0();
function set_parameterNumber0(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber1 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber1 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber1 As Integer
C#
public int ParameterNumber1 { get; set; }
Visual C++
public:
property int ParameterNumber1 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber1();
function set_parameterNumber1(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber10 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber10 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber10 As Integer
C#
public int ParameterNumber10 { get; set; }
Visual C++
public:
property int ParameterNumber10 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber10();
function set_parameterNumber10(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber11 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber11 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber11 As Integer
C#
public int ParameterNumber11 { get; set; }
Visual C++
public:
property int ParameterNumber11 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber11();
function set_parameterNumber11(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber12 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber12 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber12 As Integer
C#
public int ParameterNumber12 { get; set; }
Visual C++
public:
property int ParameterNumber12 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber12();
function set_parameterNumber12(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber13 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber13 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber13 As Integer
C#
public int ParameterNumber13 { get; set; }
Visual C++
public:
property int ParameterNumber13 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber13();
function set_parameterNumber13(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber2 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber2 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber2 As Integer
C#
public int ParameterNumber2 { get; set; }
Visual C++
public:
property int ParameterNumber2 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber2();
function set_parameterNumber2(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber3 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber3 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber3 As Integer
C#
public int ParameterNumber3 { get; set; }
Visual C++
public:
property int ParameterNumber3 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber3();
function set_parameterNumber3(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber4 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber4 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber4 As Integer
C#
public int ParameterNumber4 { get; set; }
Visual C++
public:
property int ParameterNumber4 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber4();
function set_parameterNumber4(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber5 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber5 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber5 As Integer
C#
public int ParameterNumber5 { get; set; }
Visual C++
public:
property int ParameterNumber5 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber5();
function set_parameterNumber5(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber6 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber6 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber6 As Integer
C#
public int ParameterNumber6 { get; set; }
Visual C++
public:
property int ParameterNumber6 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber6();
function set_parameterNumber6(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber7 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber7 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber7 As Integer
C#
public int ParameterNumber7 { get; set; }
Visual C++
public:
property int ParameterNumber7 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber7();
function set_parameterNumber7(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber8 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber8 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber8 As Integer
C#
public int ParameterNumber8 { get; set; }
Visual C++
public:
property int ParameterNumber8 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber8();
function set_parameterNumber8(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterNumber9 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterNumber9 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber9 As Integer
C#
public int ParameterNumber9 { get; set; }
Visual C++
public:
property int ParameterNumber9 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber9();
function set_parameterNumber9(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue0 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue0 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue0 As ParameterValue
C#
public ParameterValue ParameterValue0 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue0 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue0();
function set_parameterValue0(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue1 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue1 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue1 As ParameterValue
C#
public ParameterValue ParameterValue1 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue1 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue1();
function set_parameterValue1(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue10 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue10 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue10 As ParameterValue
C#
public ParameterValue ParameterValue10 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue10 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue10();
function set_parameterValue10(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue11 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue11 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue11 As ParameterValue
C#
public ParameterValue ParameterValue11 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue11 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue11();
function set_parameterValue11(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue12 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue12 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue12 As ParameterValue
C#
public ParameterValue ParameterValue12 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue12 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue12();
function set_parameterValue12(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue13 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue13 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue13 As ParameterValue
C#
public ParameterValue ParameterValue13 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue13 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue13();
function set_parameterValue13(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue2 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue2 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue2 As ParameterValue
C#
public ParameterValue ParameterValue2 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue2 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue2();
function set_parameterValue2(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue3 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue3 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue3 As ParameterValue
C#
public ParameterValue ParameterValue3 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue3 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue3();
function set_parameterValue3(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue4 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue4 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue4 As ParameterValue
C#
public ParameterValue ParameterValue4 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue4 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue4();
function set_parameterValue4(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue5 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue5 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue5 As ParameterValue
C#
public ParameterValue ParameterValue5 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue5 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue5();
function set_parameterValue5(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue6 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue6 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue6 As ParameterValue
C#
public ParameterValue ParameterValue6 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue6 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue6();
function set_parameterValue6(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue7 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue7 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue7 As ParameterValue
C#
public ParameterValue ParameterValue7 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue7 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue7();
function set_parameterValue7(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue8 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue8 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue8 As ParameterValue
C#
public ParameterValue ParameterValue8 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue8 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue8();
function set_parameterValue8(value);

Remarks

See Also

InstrumentAutomationDevice Class


ParameterValue9 Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.ParameterValue9 Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue9 As ParameterValue
C#
public ParameterValue ParameterValue9 { get; set; }
Visual C++
public:
property ParameterValue^ ParameterValue9 {
    ParameterValue^ get ();
    void set (ParameterValue^ value);
}
JavaScript
function get_parameterValue9();
function set_parameterValue9(value);

Remarks

See Also

InstrumentAutomationDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.RunTimePresetA Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As InstrumentAutomationDeviceRunTimePreset
C#
public InstrumentAutomationDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property InstrumentAutomationDeviceRunTimePreset^ RunTimePresetA {
    InstrumentAutomationDeviceRunTimePreset^ get ();
    void set (InstrumentAutomationDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

InstrumentAutomationDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.RunTimePresetB Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As InstrumentAutomationDeviceRunTimePreset
C#
public InstrumentAutomationDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property InstrumentAutomationDeviceRunTimePreset^ RunTimePresetB {
    InstrumentAutomationDeviceRunTimePreset^ get ();
    void set (InstrumentAutomationDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

InstrumentAutomationDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.SelectedPresetIsModified Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

InstrumentAutomationDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.SelectedPresetName Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

InstrumentAutomationDevice Class


type Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.type Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

InstrumentAutomationDevice Class


VisiblePages Property

[image]

.NET Framework Class Library
InstrumentAutomationDevice..::.VisiblePages Property
InstrumentAutomationDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VisiblePages As Integer
C#
public int VisiblePages { get; set; }
Visual C++
public:
property int VisiblePages {
    int get ();
    void set (int value);
}
JavaScript
function get_visiblePages();
function set_visiblePages(value);

Remarks

See Also

InstrumentAutomationDevice Class


InstrumentAutomationDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class InstrumentAutomationDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class InstrumentAutomationDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class InstrumentAutomationDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.InstrumentAutomationDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.InstrumentAutomationDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.InstrumentAutomationDeviceDeviceSlotRunTimePreset

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Members


InstrumentAutomationDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset Members
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The InstrumentAutomationDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
InstrumentAutomationDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ParameterNumber0 |
ParameterNumber1 |
ParameterNumber10 |
ParameterNumber11 |
ParameterNumber12 |
ParameterNumber13 |
ParameterNumber2 |
ParameterNumber3 |
ParameterNumber4 |
ParameterNumber5 |
ParameterNumber6 |
ParameterNumber7 |
ParameterNumber8 |
ParameterNumber9 |
type |
VisiblePages |

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


InstrumentAutomationDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset Constructor
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InstrumentAutomationDeviceDeviceSlotRunTimePreset()
Visual C++
public:
InstrumentAutomationDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.InstrumentAutomationDeviceDeviceSlotRunTimePreset = function();

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


InstrumentAutomationDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset Methods
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The InstrumentAutomationDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


InstrumentAutomationDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset Properties
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The InstrumentAutomationDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
ParameterNumber0 |
ParameterNumber1 |
ParameterNumber10 |
ParameterNumber11 |
ParameterNumber12 |
ParameterNumber13 |
ParameterNumber2 |
ParameterNumber3 |
ParameterNumber4 |
ParameterNumber5 |
ParameterNumber6 |
ParameterNumber7 |
ParameterNumber8 |
ParameterNumber9 |
type |
VisiblePages |

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber0 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber0 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber0 As Integer
C#
public int ParameterNumber0 { get; set; }
Visual C++
public:
property int ParameterNumber0 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber0();
function set_parameterNumber0(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber1 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber1 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber1 As Integer
C#
public int ParameterNumber1 { get; set; }
Visual C++
public:
property int ParameterNumber1 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber1();
function set_parameterNumber1(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber10 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber10 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber10 As Integer
C#
public int ParameterNumber10 { get; set; }
Visual C++
public:
property int ParameterNumber10 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber10();
function set_parameterNumber10(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber11 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber11 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber11 As Integer
C#
public int ParameterNumber11 { get; set; }
Visual C++
public:
property int ParameterNumber11 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber11();
function set_parameterNumber11(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber12 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber12 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber12 As Integer
C#
public int ParameterNumber12 { get; set; }
Visual C++
public:
property int ParameterNumber12 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber12();
function set_parameterNumber12(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber13 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber13 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber13 As Integer
C#
public int ParameterNumber13 { get; set; }
Visual C++
public:
property int ParameterNumber13 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber13();
function set_parameterNumber13(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber2 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber2 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber2 As Integer
C#
public int ParameterNumber2 { get; set; }
Visual C++
public:
property int ParameterNumber2 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber2();
function set_parameterNumber2(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber3 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber3 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber3 As Integer
C#
public int ParameterNumber3 { get; set; }
Visual C++
public:
property int ParameterNumber3 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber3();
function set_parameterNumber3(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber4 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber4 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber4 As Integer
C#
public int ParameterNumber4 { get; set; }
Visual C++
public:
property int ParameterNumber4 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber4();
function set_parameterNumber4(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber5 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber5 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber5 As Integer
C#
public int ParameterNumber5 { get; set; }
Visual C++
public:
property int ParameterNumber5 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber5();
function set_parameterNumber5(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber6 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber6 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber6 As Integer
C#
public int ParameterNumber6 { get; set; }
Visual C++
public:
property int ParameterNumber6 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber6();
function set_parameterNumber6(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber7 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber7 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber7 As Integer
C#
public int ParameterNumber7 { get; set; }
Visual C++
public:
property int ParameterNumber7 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber7();
function set_parameterNumber7(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber8 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber8 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber8 As Integer
C#
public int ParameterNumber8 { get; set; }
Visual C++
public:
property int ParameterNumber8 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber8();
function set_parameterNumber8(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


ParameterNumber9 Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.ParameterNumber9 Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterNumber9 As Integer
C#
public int ParameterNumber9 { get; set; }
Visual C++
public:
property int ParameterNumber9 {
    int get ();
    void set (int value);
}
JavaScript
function get_parameterNumber9();
function set_parameterNumber9(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.type Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


VisiblePages Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceDeviceSlotRunTimePreset..::.VisiblePages Property
InstrumentAutomationDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VisiblePages As Integer
C#
public int VisiblePages { get; set; }
Visual C++
public:
property int VisiblePages {
    int get ();
    void set (int value);
}
JavaScript
function get_visiblePages();
function set_visiblePages(value);

Remarks

See Also

InstrumentAutomationDeviceDeviceSlotRunTimePreset Class


InstrumentAutomationDeviceRunTimePreset Class

[image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class InstrumentAutomationDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class InstrumentAutomationDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class InstrumentAutomationDeviceRunTimePreset
JavaScript
NRenoiseTools.InstrumentAutomationDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.InstrumentAutomationDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.InstrumentAutomationDeviceRunTimePreset

See Also

InstrumentAutomationDeviceRunTimePreset Members


InstrumentAutomationDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset Members
InstrumentAutomationDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The InstrumentAutomationDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
InstrumentAutomationDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

InstrumentAutomationDeviceRunTimePreset Class


InstrumentAutomationDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset Constructor
InstrumentAutomationDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InstrumentAutomationDeviceRunTimePreset()
Visual C++
public:
InstrumentAutomationDeviceRunTimePreset()
JavaScript
NRenoiseTools.InstrumentAutomationDeviceRunTimePreset = function();

See Also

InstrumentAutomationDeviceRunTimePreset Class


InstrumentAutomationDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset Methods
InstrumentAutomationDeviceRunTimePreset Class See Also Send Feedback

The InstrumentAutomationDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstrumentAutomationDeviceRunTimePreset Class


InstrumentAutomationDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset Properties
InstrumentAutomationDeviceRunTimePreset Class See Also Send Feedback

The InstrumentAutomationDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

InstrumentAutomationDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset..::.DeviceSlot Property
InstrumentAutomationDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As InstrumentAutomationDeviceDeviceSlotRunTimePreset
C#
public InstrumentAutomationDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property InstrumentAutomationDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    InstrumentAutomationDeviceDeviceSlotRunTimePreset^ get ();
    void set (InstrumentAutomationDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

InstrumentAutomationDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
InstrumentAutomationDeviceRunTimePreset..::.type Property
InstrumentAutomationDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

InstrumentAutomationDeviceRunTimePreset Class


Lfo Class

[image]

.NET Framework Class Library
Lfo Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lfo
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lfo
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lfo
JavaScript
NRenoiseTools.Lfo = function();

Type.createClass(
    'NRenoiseTools.Lfo');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lfo

See Also

Lfo Members


Lfo Members

[image] [image]

.NET Framework Class Library
Lfo Members
Lfo Class Constructors Methods Properties See Also Send Feedback

The Lfo type exposes the following members.

Constructors

Name | Description
Lfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amplitude |
Dephase |
Frequency |
Mode |

See Also

Lfo Class


Lfo Constructor

[image]

.NET Framework Class Library
Lfo Constructor
Lfo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lfo()
Visual C++
public:
Lfo()
JavaScript
NRenoiseTools.Lfo = function();

See Also

Lfo Class


Lfo Methods

[image] [image]

.NET Framework Class Library
Lfo Methods
Lfo Class See Also Send Feedback

The Lfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lfo Class


Lfo Properties

[image] [image]

.NET Framework Class Library
Lfo Properties
Lfo Class See Also Send Feedback

The Lfo type exposes the following members.

Properties

Name | Description
Amplitude |
Dephase |
Frequency |
Mode |

See Also

Lfo Class


Amplitude Property

[image]

.NET Framework Class Library
Lfo..::.Amplitude Property
Lfo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amplitude As Integer
C#
public int Amplitude { get; set; }
Visual C++
public:
property int Amplitude {
    int get ();
    void set (int value);
}
JavaScript
function get_amplitude();
function set_amplitude(value);

Remarks

See Also

Lfo Class


Dephase Property

[image]

.NET Framework Class Library
Lfo..::.Dephase Property
Lfo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Dephase As Integer
C#
public int Dephase { get; set; }
Visual C++
public:
property int Dephase {
    int get ();
    void set (int value);
}
JavaScript
function get_dephase();
function set_dephase(value);

Remarks

See Also

Lfo Class


Frequency Property

[image]

.NET Framework Class Library
Lfo..::.Frequency Property
Lfo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As Integer
C#
public int Frequency { get; set; }
Visual C++
public:
property int Frequency {
    int get ();
    void set (int value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

Lfo Class


Mode Property

[image]

.NET Framework Class Library
Lfo..::.Mode Property
Lfo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As LfoMode
C#
public LfoMode Mode { get; set; }
Visual C++
public:
property LfoMode Mode {
    LfoMode get ();
    void set (LfoMode value);
}
JavaScript
function get_mode();
function set_mode(value);

Remarks

See Also

Lfo Class


LfoDevice Class

[image]

.NET Framework Class Library
LfoDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDevice
JavaScript
NRenoiseTools.LfoDevice = function();

Type.createClass(
    'NRenoiseTools.LfoDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDevice

See Also

LfoDevice Members


LfoDevice Members

[image] [image]

.NET Framework Class Library
LfoDevice Members
LfoDevice Class Constructors Methods Properties See Also Send Feedback

The LfoDevice type exposes the following members.

Constructors

Name | Description
LfoDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amplitude |
CustomEnvelope |
CustomEnvelopeOneShot |
DestEffect |
DestParameter |
Frequency |
IsActive |
IsSelected |
Offset |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

LfoDevice Class


LfoDevice Constructor

[image]

.NET Framework Class Library
LfoDevice Constructor
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDevice()
Visual C++
public:
LfoDevice()
JavaScript
NRenoiseTools.LfoDevice = function();

See Also

LfoDevice Class


LfoDevice Methods

[image] [image]

.NET Framework Class Library
LfoDevice Methods
LfoDevice Class See Also Send Feedback

The LfoDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDevice Class


LfoDevice Properties

[image] [image]

.NET Framework Class Library
LfoDevice Properties
LfoDevice Class See Also Send Feedback

The LfoDevice type exposes the following members.

Properties

Name | Description
Amplitude |
CustomEnvelope |
CustomEnvelopeOneShot |
DestEffect |
DestParameter |
Frequency |
IsActive |
IsSelected |
Offset |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Type |

See Also

LfoDevice Class


Amplitude Property

[image]

.NET Framework Class Library
LfoDevice..::.Amplitude Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amplitude As LfoDeviceAmplitude
C#
public LfoDeviceAmplitude Amplitude { get; set; }
Visual C++
public:
property LfoDeviceAmplitude^ Amplitude {
    LfoDeviceAmplitude^ get ();
    void set (LfoDeviceAmplitude^ value);
}
JavaScript
function get_amplitude();
function set_amplitude(value);

Remarks

See Also

LfoDevice Class


CustomEnvelope Property

[image]

.NET Framework Class Library
LfoDevice..::.CustomEnvelope Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomEnvelope As CustomEnvelope
C#
public CustomEnvelope CustomEnvelope { get; set; }
Visual C++
public:
property CustomEnvelope^ CustomEnvelope {
    CustomEnvelope^ get ();
    void set (CustomEnvelope^ value);
}
JavaScript
function get_customEnvelope();
function set_customEnvelope(value);

Remarks

See Also

LfoDevice Class


CustomEnvelopeOneShot Property

[image]

.NET Framework Class Library
LfoDevice..::.CustomEnvelopeOneShot Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomEnvelopeOneShot As Boolean
C#
public bool CustomEnvelopeOneShot { get; set; }
Visual C++
public:
property bool CustomEnvelopeOneShot {
    bool get ();
    void set (bool value);
}
JavaScript
function get_customEnvelopeOneShot();
function set_customEnvelopeOneShot(value);

Remarks

See Also

LfoDevice Class


DestEffect Property

[image]

.NET Framework Class Library
LfoDevice..::.DestEffect Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestEffect As DestEffect
C#
public DestEffect DestEffect { get; set; }
Visual C++
public:
property DestEffect^ DestEffect {
    DestEffect^ get ();
    void set (DestEffect^ value);
}
JavaScript
function get_destEffect();
function set_destEffect(value);

Remarks

See Also

LfoDevice Class


DestParameter Property

[image]

.NET Framework Class Library
LfoDevice..::.DestParameter Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestParameter As DestParameter
C#
public DestParameter DestParameter { get; set; }
Visual C++
public:
property DestParameter^ DestParameter {
    DestParameter^ get ();
    void set (DestParameter^ value);
}
JavaScript
function get_destParameter();
function set_destParameter(value);

Remarks

See Also

LfoDevice Class


Frequency Property

[image]

.NET Framework Class Library
LfoDevice..::.Frequency Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As LfoDeviceFrequency
C#
public LfoDeviceFrequency Frequency { get; set; }
Visual C++
public:
property LfoDeviceFrequency^ Frequency {
    LfoDeviceFrequency^ get ();
    void set (LfoDeviceFrequency^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

LfoDevice Class


IsActive Property

[image]

.NET Framework Class Library
LfoDevice..::.IsActive Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

LfoDevice Class


IsSelected Property

[image]

.NET Framework Class Library
LfoDevice..::.IsSelected Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

LfoDevice Class


Offset Property

[image]

.NET Framework Class Library
LfoDevice..::.Offset Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Offset As LfoDeviceOffset
C#
public LfoDeviceOffset Offset { get; set; }
Visual C++
public:
property LfoDeviceOffset^ Offset {
    LfoDeviceOffset^ get ();
    void set (LfoDeviceOffset^ value);
}
JavaScript
function get_offset();
function set_offset(value);

Remarks

See Also

LfoDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
LfoDevice..::.RunTimePresetA Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As LfoDeviceRunTimePreset
C#
public LfoDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property LfoDeviceRunTimePreset^ RunTimePresetA {
    LfoDeviceRunTimePreset^ get ();
    void set (LfoDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

LfoDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
LfoDevice..::.RunTimePresetB Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As LfoDeviceRunTimePreset
C#
public LfoDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property LfoDeviceRunTimePreset^ RunTimePresetB {
    LfoDeviceRunTimePreset^ get ();
    void set (LfoDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

LfoDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
LfoDevice..::.SelectedPresetIsModified Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

LfoDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
LfoDevice..::.SelectedPresetName Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

LfoDevice Class


Type Property

[image]

.NET Framework Class Library
LfoDevice..::.Type Property
LfoDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As LfoDeviceType
C#
public LfoDeviceType Type { get; set; }
Visual C++
public:
property LfoDeviceType^ Type {
    LfoDeviceType^ get ();
    void set (LfoDeviceType^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LfoDevice Class


LfoDeviceAmplitude Class

[image]

.NET Framework Class Library
LfoDeviceAmplitude Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceAmplitude
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceAmplitude
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceAmplitude
JavaScript
NRenoiseTools.LfoDeviceAmplitude = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceAmplitude');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceAmplitude

See Also

LfoDeviceAmplitude Members


LfoDeviceAmplitude Members

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitude Members
LfoDeviceAmplitude Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceAmplitude type exposes the following members.

Constructors

Name | Description
LfoDeviceAmplitude |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceAmplitude Class


LfoDeviceAmplitude Constructor

[image]

.NET Framework Class Library
LfoDeviceAmplitude Constructor
LfoDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceAmplitude()
Visual C++
public:
LfoDeviceAmplitude()
JavaScript
NRenoiseTools.LfoDeviceAmplitude = function();

See Also

LfoDeviceAmplitude Class


LfoDeviceAmplitude Methods

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitude Methods
LfoDeviceAmplitude Class See Also Send Feedback

The LfoDeviceAmplitude type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceAmplitude Class


LfoDeviceAmplitude Properties

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitude Properties
LfoDeviceAmplitude Class See Also Send Feedback

The LfoDeviceAmplitude type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceAmplitude Class


MidiMappings Property

[image]

.NET Framework Class Library
LfoDeviceAmplitude..::.MidiMappings Property
LfoDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LfoDeviceAmplitude Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceAmplitude..::.Value Property
LfoDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceAmplitude Class


Visualization Property

[image]

.NET Framework Class Library
LfoDeviceAmplitude..::.Visualization Property
LfoDeviceAmplitude Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LfoDeviceAmplitudeVisualization
C#
public LfoDeviceAmplitudeVisualization Visualization { get; set; }
Visual C++
public:
property LfoDeviceAmplitudeVisualization Visualization {
    LfoDeviceAmplitudeVisualization get ();
    void set (LfoDeviceAmplitudeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LfoDeviceAmplitude Class


LfoDeviceAmplitudeRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceAmplitudeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceAmplitudeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceAmplitudeRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceAmplitudeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceAmplitudeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceAmplitudeRunTimePreset

See Also

LfoDeviceAmplitudeRunTimePreset Members


LfoDeviceAmplitudeRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset Members
LfoDeviceAmplitudeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceAmplitudeRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceAmplitudeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LfoDeviceAmplitudeRunTimePreset Class


LfoDeviceAmplitudeRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset Constructor
LfoDeviceAmplitudeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceAmplitudeRunTimePreset()
Visual C++
public:
LfoDeviceAmplitudeRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceAmplitudeRunTimePreset = function();

See Also

LfoDeviceAmplitudeRunTimePreset Class


LfoDeviceAmplitudeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset Methods
LfoDeviceAmplitudeRunTimePreset Class See Also Send Feedback

The LfoDeviceAmplitudeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceAmplitudeRunTimePreset Class


LfoDeviceAmplitudeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset Properties
LfoDeviceAmplitudeRunTimePreset Class See Also Send Feedback

The LfoDeviceAmplitudeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LfoDeviceAmplitudeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceAmplitudeRunTimePreset..::.Value Property
LfoDeviceAmplitudeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceAmplitudeRunTimePreset Class


LfoDeviceAmplitudeVisualization Enumeration

[image]

.NET Framework Class Library
LfoDeviceAmplitudeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LfoDeviceAmplitudeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LfoDeviceAmplitudeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LfoDeviceAmplitudeVisualization
JavaScript
NRenoiseTools.LfoDeviceAmplitudeVisualization = function();
NRenoiseTools.LfoDeviceAmplitudeVisualization.createEnum('NRenoiseTools.LfoDeviceAmplitudeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LfoDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceDeviceSlotRunTimePreset

See Also

LfoDeviceDeviceSlotRunTimePreset Members


LfoDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset Members
LfoDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amplitude |
CustomEnvelope |
CustomEnvelopeOneShot |
Frequency |
Offset |
type |
Type |

See Also

LfoDeviceDeviceSlotRunTimePreset Class


LfoDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset Constructor
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceDeviceSlotRunTimePreset()
Visual C++
public:
LfoDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceDeviceSlotRunTimePreset = function();

See Also

LfoDeviceDeviceSlotRunTimePreset Class


LfoDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset Methods
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LfoDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceDeviceSlotRunTimePreset Class


LfoDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset Properties
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LfoDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Amplitude |
CustomEnvelope |
CustomEnvelopeOneShot |
Frequency |
Offset |
type |
Type |

See Also

LfoDeviceDeviceSlotRunTimePreset Class


Amplitude Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.Amplitude Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amplitude As LfoDeviceAmplitudeRunTimePreset
C#
public LfoDeviceAmplitudeRunTimePreset Amplitude { get; set; }
Visual C++
public:
property LfoDeviceAmplitudeRunTimePreset^ Amplitude {
    LfoDeviceAmplitudeRunTimePreset^ get ();
    void set (LfoDeviceAmplitudeRunTimePreset^ value);
}
JavaScript
function get_amplitude();
function set_amplitude(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


CustomEnvelope Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.CustomEnvelope Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomEnvelope As CustomEnvelope
C#
public CustomEnvelope CustomEnvelope { get; set; }
Visual C++
public:
property CustomEnvelope^ CustomEnvelope {
    CustomEnvelope^ get ();
    void set (CustomEnvelope^ value);
}
JavaScript
function get_customEnvelope();
function set_customEnvelope(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


CustomEnvelopeOneShot Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.CustomEnvelopeOneShot Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomEnvelopeOneShot As Boolean
C#
public bool CustomEnvelopeOneShot { get; set; }
Visual C++
public:
property bool CustomEnvelopeOneShot {
    bool get ();
    void set (bool value);
}
JavaScript
function get_customEnvelopeOneShot();
function set_customEnvelopeOneShot(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


Frequency Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.Frequency Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As LfoDeviceFrequencyRunTimePreset
C#
public LfoDeviceFrequencyRunTimePreset Frequency { get; set; }
Visual C++
public:
property LfoDeviceFrequencyRunTimePreset^ Frequency {
    LfoDeviceFrequencyRunTimePreset^ get ();
    void set (LfoDeviceFrequencyRunTimePreset^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


Offset Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.Offset Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Offset As LfoDeviceOffsetRunTimePreset
C#
public LfoDeviceOffsetRunTimePreset Offset { get; set; }
Visual C++
public:
property LfoDeviceOffsetRunTimePreset^ Offset {
    LfoDeviceOffsetRunTimePreset^ get ();
    void set (LfoDeviceOffsetRunTimePreset^ value);
}
JavaScript
function get_offset();
function set_offset(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


Type Property

[image]

.NET Framework Class Library
LfoDeviceDeviceSlotRunTimePreset..::.Type Property
LfoDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As LfoDeviceTypeRunTimePreset
C#
public LfoDeviceTypeRunTimePreset Type { get; set; }
Visual C++
public:
property LfoDeviceTypeRunTimePreset^ Type {
    LfoDeviceTypeRunTimePreset^ get ();
    void set (LfoDeviceTypeRunTimePreset^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LfoDeviceDeviceSlotRunTimePreset Class


LfoDeviceFrequency Class

[image]

.NET Framework Class Library
LfoDeviceFrequency Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceFrequency
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceFrequency
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceFrequency
JavaScript
NRenoiseTools.LfoDeviceFrequency = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceFrequency');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceFrequency

See Also

LfoDeviceFrequency Members


LfoDeviceFrequency Members

[image] [image]

.NET Framework Class Library
LfoDeviceFrequency Members
LfoDeviceFrequency Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceFrequency type exposes the following members.

Constructors

Name | Description
LfoDeviceFrequency |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceFrequency Class


LfoDeviceFrequency Constructor

[image]

.NET Framework Class Library
LfoDeviceFrequency Constructor
LfoDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceFrequency()
Visual C++
public:
LfoDeviceFrequency()
JavaScript
NRenoiseTools.LfoDeviceFrequency = function();

See Also

LfoDeviceFrequency Class


LfoDeviceFrequency Methods

[image] [image]

.NET Framework Class Library
LfoDeviceFrequency Methods
LfoDeviceFrequency Class See Also Send Feedback

The LfoDeviceFrequency type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceFrequency Class


LfoDeviceFrequency Properties

[image] [image]

.NET Framework Class Library
LfoDeviceFrequency Properties
LfoDeviceFrequency Class See Also Send Feedback

The LfoDeviceFrequency type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceFrequency Class


MidiMappings Property

[image]

.NET Framework Class Library
LfoDeviceFrequency..::.MidiMappings Property
LfoDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LfoDeviceFrequency Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceFrequency..::.Value Property
LfoDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceFrequency Class


Visualization Property

[image]

.NET Framework Class Library
LfoDeviceFrequency..::.Visualization Property
LfoDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LfoDeviceFrequencyVisualization
C#
public LfoDeviceFrequencyVisualization Visualization { get; set; }
Visual C++
public:
property LfoDeviceFrequencyVisualization Visualization {
    LfoDeviceFrequencyVisualization get ();
    void set (LfoDeviceFrequencyVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LfoDeviceFrequency Class


LfoDeviceFrequencyRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceFrequencyRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceFrequencyRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceFrequencyRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceFrequencyRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceFrequencyRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceFrequencyRunTimePreset

See Also

LfoDeviceFrequencyRunTimePreset Members


LfoDeviceFrequencyRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset Members
LfoDeviceFrequencyRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceFrequencyRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceFrequencyRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LfoDeviceFrequencyRunTimePreset Class


LfoDeviceFrequencyRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset Constructor
LfoDeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceFrequencyRunTimePreset()
Visual C++
public:
LfoDeviceFrequencyRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceFrequencyRunTimePreset = function();

See Also

LfoDeviceFrequencyRunTimePreset Class


LfoDeviceFrequencyRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset Methods
LfoDeviceFrequencyRunTimePreset Class See Also Send Feedback

The LfoDeviceFrequencyRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceFrequencyRunTimePreset Class


LfoDeviceFrequencyRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset Properties
LfoDeviceFrequencyRunTimePreset Class See Also Send Feedback

The LfoDeviceFrequencyRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LfoDeviceFrequencyRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceFrequencyRunTimePreset..::.Value Property
LfoDeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceFrequencyRunTimePreset Class


LfoDeviceFrequencyVisualization Enumeration

[image]

.NET Framework Class Library
LfoDeviceFrequencyVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LfoDeviceFrequencyVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LfoDeviceFrequencyVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LfoDeviceFrequencyVisualization
JavaScript
NRenoiseTools.LfoDeviceFrequencyVisualization = function();
NRenoiseTools.LfoDeviceFrequencyVisualization.createEnum('NRenoiseTools.LfoDeviceFrequencyVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LfoDeviceOffset Class

[image]

.NET Framework Class Library
LfoDeviceOffset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceOffset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceOffset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceOffset
JavaScript
NRenoiseTools.LfoDeviceOffset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceOffset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceOffset

See Also

LfoDeviceOffset Members


LfoDeviceOffset Members

[image] [image]

.NET Framework Class Library
LfoDeviceOffset Members
LfoDeviceOffset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceOffset type exposes the following members.

Constructors

Name | Description
LfoDeviceOffset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceOffset Class


LfoDeviceOffset Constructor

[image]

.NET Framework Class Library
LfoDeviceOffset Constructor
LfoDeviceOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceOffset()
Visual C++
public:
LfoDeviceOffset()
JavaScript
NRenoiseTools.LfoDeviceOffset = function();

See Also

LfoDeviceOffset Class


LfoDeviceOffset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceOffset Methods
LfoDeviceOffset Class See Also Send Feedback

The LfoDeviceOffset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceOffset Class


LfoDeviceOffset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceOffset Properties
LfoDeviceOffset Class See Also Send Feedback

The LfoDeviceOffset type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceOffset Class


MidiMappings Property

[image]

.NET Framework Class Library
LfoDeviceOffset..::.MidiMappings Property
LfoDeviceOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LfoDeviceOffset Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceOffset..::.Value Property
LfoDeviceOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceOffset Class


Visualization Property

[image]

.NET Framework Class Library
LfoDeviceOffset..::.Visualization Property
LfoDeviceOffset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LfoDeviceOffsetVisualization
C#
public LfoDeviceOffsetVisualization Visualization { get; set; }
Visual C++
public:
property LfoDeviceOffsetVisualization Visualization {
    LfoDeviceOffsetVisualization get ();
    void set (LfoDeviceOffsetVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LfoDeviceOffset Class


LfoDeviceOffsetRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceOffsetRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceOffsetRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceOffsetRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceOffsetRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceOffsetRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceOffsetRunTimePreset

See Also

LfoDeviceOffsetRunTimePreset Members


LfoDeviceOffsetRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset Members
LfoDeviceOffsetRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceOffsetRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceOffsetRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LfoDeviceOffsetRunTimePreset Class


LfoDeviceOffsetRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset Constructor
LfoDeviceOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceOffsetRunTimePreset()
Visual C++
public:
LfoDeviceOffsetRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceOffsetRunTimePreset = function();

See Also

LfoDeviceOffsetRunTimePreset Class


LfoDeviceOffsetRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset Methods
LfoDeviceOffsetRunTimePreset Class See Also Send Feedback

The LfoDeviceOffsetRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceOffsetRunTimePreset Class


LfoDeviceOffsetRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset Properties
LfoDeviceOffsetRunTimePreset Class See Also Send Feedback

The LfoDeviceOffsetRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LfoDeviceOffsetRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceOffsetRunTimePreset..::.Value Property
LfoDeviceOffsetRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceOffsetRunTimePreset Class


LfoDeviceOffsetVisualization Enumeration

[image]

.NET Framework Class Library
LfoDeviceOffsetVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LfoDeviceOffsetVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LfoDeviceOffsetVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LfoDeviceOffsetVisualization
JavaScript
NRenoiseTools.LfoDeviceOffsetVisualization = function();
NRenoiseTools.LfoDeviceOffsetVisualization.createEnum('NRenoiseTools.LfoDeviceOffsetVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LfoDeviceRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceRunTimePreset

See Also

LfoDeviceRunTimePreset Members


LfoDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceRunTimePreset Members
LfoDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

LfoDeviceRunTimePreset Class


LfoDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceRunTimePreset Constructor
LfoDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceRunTimePreset()
Visual C++
public:
LfoDeviceRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceRunTimePreset = function();

See Also

LfoDeviceRunTimePreset Class


LfoDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceRunTimePreset Methods
LfoDeviceRunTimePreset Class See Also Send Feedback

The LfoDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceRunTimePreset Class


LfoDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceRunTimePreset Properties
LfoDeviceRunTimePreset Class See Also Send Feedback

The LfoDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

LfoDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
LfoDeviceRunTimePreset..::.DeviceSlot Property
LfoDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As LfoDeviceDeviceSlotRunTimePreset
C#
public LfoDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property LfoDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    LfoDeviceDeviceSlotRunTimePreset^ get ();
    void set (LfoDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

LfoDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
LfoDeviceRunTimePreset..::.type Property
LfoDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LfoDeviceRunTimePreset Class


LfoDeviceType Class

[image]

.NET Framework Class Library
LfoDeviceType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceType
JavaScript
NRenoiseTools.LfoDeviceType = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceType

See Also

LfoDeviceType Members


LfoDeviceType Members

[image] [image]

.NET Framework Class Library
LfoDeviceType Members
LfoDeviceType Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceType type exposes the following members.

Constructors

Name | Description
LfoDeviceType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceType Class


LfoDeviceType Constructor

[image]

.NET Framework Class Library
LfoDeviceType Constructor
LfoDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceType()
Visual C++
public:
LfoDeviceType()
JavaScript
NRenoiseTools.LfoDeviceType = function();

See Also

LfoDeviceType Class


LfoDeviceType Methods

[image] [image]

.NET Framework Class Library
LfoDeviceType Methods
LfoDeviceType Class See Also Send Feedback

The LfoDeviceType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceType Class


LfoDeviceType Properties

[image] [image]

.NET Framework Class Library
LfoDeviceType Properties
LfoDeviceType Class See Also Send Feedback

The LfoDeviceType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LfoDeviceType Class


MidiMappings Property

[image]

.NET Framework Class Library
LfoDeviceType..::.MidiMappings Property
LfoDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LfoDeviceType Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceType..::.Value Property
LfoDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceType Class


Visualization Property

[image]

.NET Framework Class Library
LfoDeviceType..::.Visualization Property
LfoDeviceType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LfoDeviceTypeVisualization
C#
public LfoDeviceTypeVisualization Visualization { get; set; }
Visual C++
public:
property LfoDeviceTypeVisualization Visualization {
    LfoDeviceTypeVisualization get ();
    void set (LfoDeviceTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LfoDeviceType Class


LfoDeviceTypeRunTimePreset Class

[image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LfoDeviceTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LfoDeviceTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LfoDeviceTypeRunTimePreset
JavaScript
NRenoiseTools.LfoDeviceTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LfoDeviceTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LfoDeviceTypeRunTimePreset

See Also

LfoDeviceTypeRunTimePreset Members


LfoDeviceTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset Members
LfoDeviceTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LfoDeviceTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
LfoDeviceTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LfoDeviceTypeRunTimePreset Class


LfoDeviceTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset Constructor
LfoDeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LfoDeviceTypeRunTimePreset()
Visual C++
public:
LfoDeviceTypeRunTimePreset()
JavaScript
NRenoiseTools.LfoDeviceTypeRunTimePreset = function();

See Also

LfoDeviceTypeRunTimePreset Class


LfoDeviceTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset Methods
LfoDeviceTypeRunTimePreset Class See Also Send Feedback

The LfoDeviceTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LfoDeviceTypeRunTimePreset Class


LfoDeviceTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset Properties
LfoDeviceTypeRunTimePreset Class See Also Send Feedback

The LfoDeviceTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LfoDeviceTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LfoDeviceTypeRunTimePreset..::.Value Property
LfoDeviceTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LfoDeviceTypeRunTimePreset Class


LfoDeviceTypeVisualization Enumeration

[image]

.NET Framework Class Library
LfoDeviceTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LfoDeviceTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LfoDeviceTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LfoDeviceTypeVisualization
JavaScript
NRenoiseTools.LfoDeviceTypeVisualization = function();
NRenoiseTools.LfoDeviceTypeVisualization.createEnum('NRenoiseTools.LfoDeviceTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LfoMode Enumeration

[image]

.NET Framework Class Library
LfoMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LfoMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LfoMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LfoMode
JavaScript
NRenoiseTools.LfoMode = function();
NRenoiseTools.LfoMode.createEnum('NRenoiseTools.LfoMode', false);

Members

Member name | Description
Off |
Sin |
Saw |
Pulse |
Random |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Line Class

[image]

.NET Framework Class Library
Line Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Line
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Line
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Line
JavaScript
NRenoiseTools.Line = function();

Type.createClass(
    'NRenoiseTools.Line');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Line

See Also

Line Members


Line Members

[image] [image]

.NET Framework Class Library
Line Members
Line Class Constructors Methods Properties See Also Send Feedback

The Line type exposes the following members.

Constructors

Name | Description
Line |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EffectColumns |
index |
NoteColumns |

See Also

Line Class


Line Constructor

[image]

.NET Framework Class Library
Line Constructor
Line Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Line()
Visual C++
public:
Line()
JavaScript
NRenoiseTools.Line = function();

See Also

Line Class


Line Methods

[image] [image]

.NET Framework Class Library
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class


Line Properties

[image] [image]

.NET Framework Class Library
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

Name | Description
EffectColumns |
index |
NoteColumns |

See Also

Line Class


EffectColumns Property

[image]

.NET Framework Class Library
Line..::.EffectColumns Property
Line Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property EffectColumns As EffectColumn()
C#
public EffectColumn[] EffectColumns { get; set; }
Visual C++
public:
property array<EffectColumn^>^ EffectColumns {
    array<EffectColumn^>^ get ();
    void set (array<EffectColumn^>^ value);
}
JavaScript
function get_effectColumns();
function set_effectColumns(value);

Remarks

See Also

Line Class


index Property

[image]

.NET Framework Class Library
Line..::.index Property
Line Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property index As Integer
C#
public int index { get; set; }
Visual C++
public:
property int index {
    int get ();
    void set (int value);
}
JavaScript
function get_index();
function set_index(value);

Remarks

See Also

Line Class


NoteColumns Property

[image]

.NET Framework Class Library
Line..::.NoteColumns Property
Line Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NoteColumns As NoteColumn()
C#
public NoteColumn[] NoteColumns { get; set; }
Visual C++
public:
property array<NoteColumn^>^ NoteColumns {
    array<NoteColumn^>^ get ();
    void set (array<NoteColumn^>^ value);
}
JavaScript
function get_noteColumns();
function set_noteColumns(value);

Remarks

See Also

Line Class


LineInDevice Class

[image]

.NET Framework Class Library
LineInDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDevice
JavaScript
NRenoiseTools.LineInDevice = function();

Type.createClass(
    'NRenoiseTools.LineInDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDevice

See Also

LineInDevice Members


LineInDevice Members

[image] [image]

.NET Framework Class Library
LineInDevice Members
LineInDevice Class Constructors Methods Properties See Also Send Feedback

The LineInDevice type exposes the following members.

Constructors

Name | Description
LineInDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InputChannel |
InputChannelMode |
InputLatencyMode |
IsActive |
IsSelected |
Panning |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Volume |

See Also

LineInDevice Class


LineInDevice Constructor

[image]

.NET Framework Class Library
LineInDevice Constructor
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDevice()
Visual C++
public:
LineInDevice()
JavaScript
NRenoiseTools.LineInDevice = function();

See Also

LineInDevice Class


LineInDevice Methods

[image] [image]

.NET Framework Class Library
LineInDevice Methods
LineInDevice Class See Also Send Feedback

The LineInDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDevice Class


LineInDevice Properties

[image] [image]

.NET Framework Class Library
LineInDevice Properties
LineInDevice Class See Also Send Feedback

The LineInDevice type exposes the following members.

Properties

Name | Description
InputChannel |
InputChannelMode |
InputLatencyMode |
IsActive |
IsSelected |
Panning |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
Volume |

See Also

LineInDevice Class


InputChannel Property

[image]

.NET Framework Class Library
LineInDevice..::.InputChannel Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputChannel As Integer
C#
public int InputChannel { get; set; }
Visual C++
public:
property int InputChannel {
    int get ();
    void set (int value);
}
JavaScript
function get_inputChannel();
function set_inputChannel(value);

Remarks

See Also

LineInDevice Class


InputChannelMode Property

[image]

.NET Framework Class Library
LineInDevice..::.InputChannelMode Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputChannelMode As LineInDeviceInputChannelMode
C#
public LineInDeviceInputChannelMode InputChannelMode { get; set; }
Visual C++
public:
property LineInDeviceInputChannelMode InputChannelMode {
    LineInDeviceInputChannelMode get ();
    void set (LineInDeviceInputChannelMode value);
}
JavaScript
function get_inputChannelMode();
function set_inputChannelMode(value);

Remarks

See Also

LineInDevice Class


InputLatencyMode Property

[image]

.NET Framework Class Library
LineInDevice..::.InputLatencyMode Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputLatencyMode As LineInDeviceInputLatencyMode
C#
public LineInDeviceInputLatencyMode InputLatencyMode { get; set; }
Visual C++
public:
property LineInDeviceInputLatencyMode InputLatencyMode {
    LineInDeviceInputLatencyMode get ();
    void set (LineInDeviceInputLatencyMode value);
}
JavaScript
function get_inputLatencyMode();
function set_inputLatencyMode(value);

Remarks

See Also

LineInDevice Class


IsActive Property

[image]

.NET Framework Class Library
LineInDevice..::.IsActive Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

LineInDevice Class


IsSelected Property

[image]

.NET Framework Class Library
LineInDevice..::.IsSelected Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

LineInDevice Class


Panning Property

[image]

.NET Framework Class Library
LineInDevice..::.Panning Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As LineInDevicePanning
C#
public LineInDevicePanning Panning { get; set; }
Visual C++
public:
property LineInDevicePanning^ Panning {
    LineInDevicePanning^ get ();
    void set (LineInDevicePanning^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

LineInDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
LineInDevice..::.RunTimePresetA Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As LineInDeviceRunTimePreset
C#
public LineInDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property LineInDeviceRunTimePreset^ RunTimePresetA {
    LineInDeviceRunTimePreset^ get ();
    void set (LineInDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

LineInDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
LineInDevice..::.RunTimePresetB Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As LineInDeviceRunTimePreset
C#
public LineInDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property LineInDeviceRunTimePreset^ RunTimePresetB {
    LineInDeviceRunTimePreset^ get ();
    void set (LineInDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

LineInDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
LineInDevice..::.SelectedPresetIsModified Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

LineInDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
LineInDevice..::.SelectedPresetName Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

LineInDevice Class


type Property

[image]

.NET Framework Class Library
LineInDevice..::.type Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LineInDevice Class


Volume Property

[image]

.NET Framework Class Library
LineInDevice..::.Volume Property
LineInDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As LineInDeviceVolume
C#
public LineInDeviceVolume Volume { get; set; }
Visual C++
public:
property LineInDeviceVolume^ Volume {
    LineInDeviceVolume^ get ();
    void set (LineInDeviceVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

LineInDevice Class


LineInDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.LineInDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LineInDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDeviceDeviceSlotRunTimePreset

See Also

LineInDeviceDeviceSlotRunTimePreset Members


LineInDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset Members
LineInDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LineInDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
LineInDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InputChannel |
InputChannelMode |
InputLatencyMode |
Panning |
type |
Volume |

See Also

LineInDeviceDeviceSlotRunTimePreset Class


LineInDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset Constructor
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDeviceDeviceSlotRunTimePreset()
Visual C++
public:
LineInDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.LineInDeviceDeviceSlotRunTimePreset = function();

See Also

LineInDeviceDeviceSlotRunTimePreset Class


LineInDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset Methods
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LineInDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDeviceDeviceSlotRunTimePreset Class


LineInDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset Properties
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LineInDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
InputChannel |
InputChannelMode |
InputLatencyMode |
Panning |
type |
Volume |

See Also

LineInDeviceDeviceSlotRunTimePreset Class


InputChannel Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.InputChannel Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputChannel As Integer
C#
public int InputChannel { get; set; }
Visual C++
public:
property int InputChannel {
    int get ();
    void set (int value);
}
JavaScript
function get_inputChannel();
function set_inputChannel(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


InputChannelMode Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.InputChannelMode Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputChannelMode As LineInDeviceDeviceSlotRunTimePresetInputChannelMode
C#
public LineInDeviceDeviceSlotRunTimePresetInputChannelMode InputChannelMode { get; set; }
Visual C++
public:
property LineInDeviceDeviceSlotRunTimePresetInputChannelMode InputChannelMode {
    LineInDeviceDeviceSlotRunTimePresetInputChannelMode get ();
    void set (LineInDeviceDeviceSlotRunTimePresetInputChannelMode value);
}
JavaScript
function get_inputChannelMode();
function set_inputChannelMode(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


InputLatencyMode Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.InputLatencyMode Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputLatencyMode As LineInDeviceDeviceSlotRunTimePresetInputLatencyMode
C#
public LineInDeviceDeviceSlotRunTimePresetInputLatencyMode InputLatencyMode { get; set; }
Visual C++
public:
property LineInDeviceDeviceSlotRunTimePresetInputLatencyMode InputLatencyMode {
    LineInDeviceDeviceSlotRunTimePresetInputLatencyMode get ();
    void set (LineInDeviceDeviceSlotRunTimePresetInputLatencyMode value);
}
JavaScript
function get_inputLatencyMode();
function set_inputLatencyMode(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


Panning Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.Panning Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As LineInDevicePanningRunTimePreset
C#
public LineInDevicePanningRunTimePreset Panning { get; set; }
Visual C++
public:
property LineInDevicePanningRunTimePreset^ Panning {
    LineInDevicePanningRunTimePreset^ get ();
    void set (LineInDevicePanningRunTimePreset^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.type Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


Volume Property

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePreset..::.Volume Property
LineInDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As LineInDeviceVolumeRunTimePreset
C#
public LineInDeviceVolumeRunTimePreset Volume { get; set; }
Visual C++
public:
property LineInDeviceVolumeRunTimePreset^ Volume {
    LineInDeviceVolumeRunTimePreset^ get ();
    void set (LineInDeviceVolumeRunTimePreset^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

LineInDeviceDeviceSlotRunTimePreset Class


LineInDeviceDeviceSlotRunTimePresetInputChannelMode Enumeration

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePresetInputChannelMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDeviceDeviceSlotRunTimePresetInputChannelMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDeviceDeviceSlotRunTimePresetInputChannelMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDeviceDeviceSlotRunTimePresetInputChannelMode
JavaScript
NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputChannelMode = function();
NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputChannelMode.createEnum('NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputChannelMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LineInDeviceDeviceSlotRunTimePresetInputLatencyMode Enumeration

[image]

.NET Framework Class Library
LineInDeviceDeviceSlotRunTimePresetInputLatencyMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDeviceDeviceSlotRunTimePresetInputLatencyMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDeviceDeviceSlotRunTimePresetInputLatencyMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDeviceDeviceSlotRunTimePresetInputLatencyMode
JavaScript
NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputLatencyMode = function();
NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputLatencyMode.createEnum('NRenoiseTools.LineInDeviceDeviceSlotRunTimePresetInputLatencyMode', false);

Members

Member name | Description
LiveRecordingMode |
MIDIReturnMode |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LineInDeviceInputChannelMode Enumeration

[image]

.NET Framework Class Library
LineInDeviceInputChannelMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDeviceInputChannelMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDeviceInputChannelMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDeviceInputChannelMode
JavaScript
NRenoiseTools.LineInDeviceInputChannelMode = function();
NRenoiseTools.LineInDeviceInputChannelMode.createEnum('NRenoiseTools.LineInDeviceInputChannelMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LineInDeviceInputLatencyMode Enumeration

[image]

.NET Framework Class Library
LineInDeviceInputLatencyMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDeviceInputLatencyMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDeviceInputLatencyMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDeviceInputLatencyMode
JavaScript
NRenoiseTools.LineInDeviceInputLatencyMode = function();
NRenoiseTools.LineInDeviceInputLatencyMode.createEnum('NRenoiseTools.LineInDeviceInputLatencyMode', false);

Members

Member name | Description
LiveRecordingMode |
MIDIReturnMode |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LineInDevicePanning Class

[image]

.NET Framework Class Library
LineInDevicePanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDevicePanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDevicePanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDevicePanning
JavaScript
NRenoiseTools.LineInDevicePanning = function();

Type.createClass(
    'NRenoiseTools.LineInDevicePanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDevicePanning

See Also

LineInDevicePanning Members


LineInDevicePanning Members

[image] [image]

.NET Framework Class Library
LineInDevicePanning Members
LineInDevicePanning Class Constructors Methods Properties See Also Send Feedback

The LineInDevicePanning type exposes the following members.

Constructors

Name | Description
LineInDevicePanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LineInDevicePanning Class


LineInDevicePanning Constructor

[image]

.NET Framework Class Library
LineInDevicePanning Constructor
LineInDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDevicePanning()
Visual C++
public:
LineInDevicePanning()
JavaScript
NRenoiseTools.LineInDevicePanning = function();

See Also

LineInDevicePanning Class


LineInDevicePanning Methods

[image] [image]

.NET Framework Class Library
LineInDevicePanning Methods
LineInDevicePanning Class See Also Send Feedback

The LineInDevicePanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDevicePanning Class


LineInDevicePanning Properties

[image] [image]

.NET Framework Class Library
LineInDevicePanning Properties
LineInDevicePanning Class See Also Send Feedback

The LineInDevicePanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LineInDevicePanning Class


MidiMappings Property

[image]

.NET Framework Class Library
LineInDevicePanning..::.MidiMappings Property
LineInDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LineInDevicePanning Class


Value Property

[image]

.NET Framework Class Library
LineInDevicePanning..::.Value Property
LineInDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LineInDevicePanning Class


Visualization Property

[image]

.NET Framework Class Library
LineInDevicePanning..::.Visualization Property
LineInDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LineInDevicePanningVisualization
C#
public LineInDevicePanningVisualization Visualization { get; set; }
Visual C++
public:
property LineInDevicePanningVisualization Visualization {
    LineInDevicePanningVisualization get ();
    void set (LineInDevicePanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LineInDevicePanning Class


LineInDevicePanningRunTimePreset Class

[image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDevicePanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDevicePanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDevicePanningRunTimePreset
JavaScript
NRenoiseTools.LineInDevicePanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LineInDevicePanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDevicePanningRunTimePreset

See Also

LineInDevicePanningRunTimePreset Members


LineInDevicePanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset Members
LineInDevicePanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LineInDevicePanningRunTimePreset type exposes the following members.

Constructors

Name | Description
LineInDevicePanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LineInDevicePanningRunTimePreset Class


LineInDevicePanningRunTimePreset Constructor

[image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset Constructor
LineInDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDevicePanningRunTimePreset()
Visual C++
public:
LineInDevicePanningRunTimePreset()
JavaScript
NRenoiseTools.LineInDevicePanningRunTimePreset = function();

See Also

LineInDevicePanningRunTimePreset Class


LineInDevicePanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset Methods
LineInDevicePanningRunTimePreset Class See Also Send Feedback

The LineInDevicePanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDevicePanningRunTimePreset Class


LineInDevicePanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset Properties
LineInDevicePanningRunTimePreset Class See Also Send Feedback

The LineInDevicePanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LineInDevicePanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LineInDevicePanningRunTimePreset..::.Value Property
LineInDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LineInDevicePanningRunTimePreset Class


LineInDevicePanningVisualization Enumeration

[image]

.NET Framework Class Library
LineInDevicePanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDevicePanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDevicePanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDevicePanningVisualization
JavaScript
NRenoiseTools.LineInDevicePanningVisualization = function();
NRenoiseTools.LineInDevicePanningVisualization.createEnum('NRenoiseTools.LineInDevicePanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LineInDeviceRunTimePreset Class

[image]

.NET Framework Class Library
LineInDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDeviceRunTimePreset
JavaScript
NRenoiseTools.LineInDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LineInDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDeviceRunTimePreset

See Also

LineInDeviceRunTimePreset Members


LineInDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
LineInDeviceRunTimePreset Members
LineInDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LineInDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
LineInDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

LineInDeviceRunTimePreset Class


LineInDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
LineInDeviceRunTimePreset Constructor
LineInDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDeviceRunTimePreset()
Visual C++
public:
LineInDeviceRunTimePreset()
JavaScript
NRenoiseTools.LineInDeviceRunTimePreset = function();

See Also

LineInDeviceRunTimePreset Class


LineInDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LineInDeviceRunTimePreset Methods
LineInDeviceRunTimePreset Class See Also Send Feedback

The LineInDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDeviceRunTimePreset Class


LineInDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LineInDeviceRunTimePreset Properties
LineInDeviceRunTimePreset Class See Also Send Feedback

The LineInDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

LineInDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
LineInDeviceRunTimePreset..::.DeviceSlot Property
LineInDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As LineInDeviceDeviceSlotRunTimePreset
C#
public LineInDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property LineInDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    LineInDeviceDeviceSlotRunTimePreset^ get ();
    void set (LineInDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

LineInDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
LineInDeviceRunTimePreset..::.type Property
LineInDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LineInDeviceRunTimePreset Class


LineInDeviceVolume Class

[image]

.NET Framework Class Library
LineInDeviceVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDeviceVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDeviceVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDeviceVolume
JavaScript
NRenoiseTools.LineInDeviceVolume = function();

Type.createClass(
    'NRenoiseTools.LineInDeviceVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDeviceVolume

See Also

LineInDeviceVolume Members


LineInDeviceVolume Members

[image] [image]

.NET Framework Class Library
LineInDeviceVolume Members
LineInDeviceVolume Class Constructors Methods Properties See Also Send Feedback

The LineInDeviceVolume type exposes the following members.

Constructors

Name | Description
LineInDeviceVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LineInDeviceVolume Class


LineInDeviceVolume Constructor

[image]

.NET Framework Class Library
LineInDeviceVolume Constructor
LineInDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDeviceVolume()
Visual C++
public:
LineInDeviceVolume()
JavaScript
NRenoiseTools.LineInDeviceVolume = function();

See Also

LineInDeviceVolume Class


LineInDeviceVolume Methods

[image] [image]

.NET Framework Class Library
LineInDeviceVolume Methods
LineInDeviceVolume Class See Also Send Feedback

The LineInDeviceVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDeviceVolume Class


LineInDeviceVolume Properties

[image] [image]

.NET Framework Class Library
LineInDeviceVolume Properties
LineInDeviceVolume Class See Also Send Feedback

The LineInDeviceVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LineInDeviceVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
LineInDeviceVolume..::.MidiMappings Property
LineInDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LineInDeviceVolume Class


Value Property

[image]

.NET Framework Class Library
LineInDeviceVolume..::.Value Property
LineInDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LineInDeviceVolume Class


Visualization Property

[image]

.NET Framework Class Library
LineInDeviceVolume..::.Visualization Property
LineInDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LineInDeviceVolumeVisualization
C#
public LineInDeviceVolumeVisualization Visualization { get; set; }
Visual C++
public:
property LineInDeviceVolumeVisualization Visualization {
    LineInDeviceVolumeVisualization get ();
    void set (LineInDeviceVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LineInDeviceVolume Class


LineInDeviceVolumeRunTimePreset Class

[image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LineInDeviceVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LineInDeviceVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LineInDeviceVolumeRunTimePreset
JavaScript
NRenoiseTools.LineInDeviceVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LineInDeviceVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LineInDeviceVolumeRunTimePreset

See Also

LineInDeviceVolumeRunTimePreset Members


LineInDeviceVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset Members
LineInDeviceVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LineInDeviceVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
LineInDeviceVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LineInDeviceVolumeRunTimePreset Class


LineInDeviceVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset Constructor
LineInDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineInDeviceVolumeRunTimePreset()
Visual C++
public:
LineInDeviceVolumeRunTimePreset()
JavaScript
NRenoiseTools.LineInDeviceVolumeRunTimePreset = function();

See Also

LineInDeviceVolumeRunTimePreset Class


LineInDeviceVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset Methods
LineInDeviceVolumeRunTimePreset Class See Also Send Feedback

The LineInDeviceVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineInDeviceVolumeRunTimePreset Class


LineInDeviceVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset Properties
LineInDeviceVolumeRunTimePreset Class See Also Send Feedback

The LineInDeviceVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LineInDeviceVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LineInDeviceVolumeRunTimePreset..::.Value Property
LineInDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LineInDeviceVolumeRunTimePreset Class


LineInDeviceVolumeVisualization Enumeration

[image]

.NET Framework Class Library
LineInDeviceVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LineInDeviceVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LineInDeviceVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LineInDeviceVolumeVisualization
JavaScript
NRenoiseTools.LineInDeviceVolumeVisualization = function();
NRenoiseTools.LineInDeviceVolumeVisualization.createEnum('NRenoiseTools.LineInDeviceVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceBits Class

[image]

.NET Framework Class Library
Lofi2DeviceBits Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceBits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceBits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceBits
JavaScript
NRenoiseTools.Lofi2DeviceBits = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceBits');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceBits

See Also

Lofi2DeviceBits Members


Lofi2DeviceBits Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceBits Members
Lofi2DeviceBits Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceBits type exposes the following members.

Constructors

Name | Description
Lofi2DeviceBits |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceBits Class


Lofi2DeviceBits Constructor

[image]

.NET Framework Class Library
Lofi2DeviceBits Constructor
Lofi2DeviceBits Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceBits()
Visual C++
public:
Lofi2DeviceBits()
JavaScript
NRenoiseTools.Lofi2DeviceBits = function();

See Also

Lofi2DeviceBits Class


Lofi2DeviceBits Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceBits Methods
Lofi2DeviceBits Class See Also Send Feedback

The Lofi2DeviceBits type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceBits Class


Lofi2DeviceBits Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceBits Properties
Lofi2DeviceBits Class See Also Send Feedback

The Lofi2DeviceBits type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceBits Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceBits..::.MidiMappings Property
Lofi2DeviceBits Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceBits Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceBits..::.Value Property
Lofi2DeviceBits Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceBits Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceBits..::.Visualization Property
Lofi2DeviceBits Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceBitsVisualization
C#
public Lofi2DeviceBitsVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceBitsVisualization Visualization {
    Lofi2DeviceBitsVisualization get ();
    void set (Lofi2DeviceBitsVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceBits Class


Lofi2DeviceBitsRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceBitsRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceBitsRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceBitsRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceBitsRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceBitsRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceBitsRunTimePreset

See Also

Lofi2DeviceBitsRunTimePreset Members


Lofi2DeviceBitsRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset Members
Lofi2DeviceBitsRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceBitsRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceBitsRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceBitsRunTimePreset Class


Lofi2DeviceBitsRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset Constructor
Lofi2DeviceBitsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceBitsRunTimePreset()
Visual C++
public:
Lofi2DeviceBitsRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceBitsRunTimePreset = function();

See Also

Lofi2DeviceBitsRunTimePreset Class


Lofi2DeviceBitsRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset Methods
Lofi2DeviceBitsRunTimePreset Class See Also Send Feedback

The Lofi2DeviceBitsRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceBitsRunTimePreset Class


Lofi2DeviceBitsRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset Properties
Lofi2DeviceBitsRunTimePreset Class See Also Send Feedback

The Lofi2DeviceBitsRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceBitsRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceBitsRunTimePreset..::.Value Property
Lofi2DeviceBitsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceBitsRunTimePreset Class


Lofi2DeviceBitsVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceBitsVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceBitsVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceBitsVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceBitsVisualization
JavaScript
NRenoiseTools.Lofi2DeviceBitsVisualization = function();
NRenoiseTools.Lofi2DeviceBitsVisualization.createEnum('NRenoiseTools.Lofi2DeviceBitsVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceDeviceSlotRunTimePreset

See Also

Lofi2DeviceDeviceSlotRunTimePreset Members


Lofi2DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset Members
Lofi2DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bits |
DryOut |
Interpolate |
Noise |
Rate |
type |
WetOut |

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Lofi2DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset Constructor
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Lofi2DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceDeviceSlotRunTimePreset = function();

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Lofi2DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset Methods
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Lofi2DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Lofi2DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset Properties
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Lofi2DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Bits |
DryOut |
Interpolate |
Noise |
Rate |
type |
WetOut |

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Bits Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.Bits Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Bits As Lofi2DeviceBitsRunTimePreset
C#
public Lofi2DeviceBitsRunTimePreset Bits { get; set; }
Visual C++
public:
property Lofi2DeviceBitsRunTimePreset^ Bits {
    Lofi2DeviceBitsRunTimePreset^ get ();
    void set (Lofi2DeviceBitsRunTimePreset^ value);
}
JavaScript
function get_bits();
function set_bits(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


DryOut Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.DryOut Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As Lofi2DeviceDryOutRunTimePreset
C#
public Lofi2DeviceDryOutRunTimePreset DryOut { get; set; }
Visual C++
public:
property Lofi2DeviceDryOutRunTimePreset^ DryOut {
    Lofi2DeviceDryOutRunTimePreset^ get ();
    void set (Lofi2DeviceDryOutRunTimePreset^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Interpolate Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.Interpolate Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Interpolate As Lofi2DeviceInterpolateRunTimePreset
C#
public Lofi2DeviceInterpolateRunTimePreset Interpolate { get; set; }
Visual C++
public:
property Lofi2DeviceInterpolateRunTimePreset^ Interpolate {
    Lofi2DeviceInterpolateRunTimePreset^ get ();
    void set (Lofi2DeviceInterpolateRunTimePreset^ value);
}
JavaScript
function get_interpolate();
function set_interpolate(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Noise Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.Noise Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Noise As Lofi2DeviceNoiseRunTimePreset
C#
public Lofi2DeviceNoiseRunTimePreset Noise { get; set; }
Visual C++
public:
property Lofi2DeviceNoiseRunTimePreset^ Noise {
    Lofi2DeviceNoiseRunTimePreset^ get ();
    void set (Lofi2DeviceNoiseRunTimePreset^ value);
}
JavaScript
function get_noise();
function set_noise(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Rate Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.Rate Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Rate As Lofi2DeviceRateRunTimePreset
C#
public Lofi2DeviceRateRunTimePreset Rate { get; set; }
Visual C++
public:
property Lofi2DeviceRateRunTimePreset^ Rate {
    Lofi2DeviceRateRunTimePreset^ get ();
    void set (Lofi2DeviceRateRunTimePreset^ value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.type Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


WetOut Property

[image]

.NET Framework Class Library
Lofi2DeviceDeviceSlotRunTimePreset..::.WetOut Property
Lofi2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As Lofi2DeviceWetOutRunTimePreset
C#
public Lofi2DeviceWetOutRunTimePreset WetOut { get; set; }
Visual C++
public:
property Lofi2DeviceWetOutRunTimePreset^ WetOut {
    Lofi2DeviceWetOutRunTimePreset^ get ();
    void set (Lofi2DeviceWetOutRunTimePreset^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

Lofi2DeviceDeviceSlotRunTimePreset Class


Lofi2DeviceDryOut Class

[image]

.NET Framework Class Library
Lofi2DeviceDryOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceDryOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceDryOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceDryOut
JavaScript
NRenoiseTools.Lofi2DeviceDryOut = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceDryOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceDryOut

See Also

Lofi2DeviceDryOut Members


Lofi2DeviceDryOut Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOut Members
Lofi2DeviceDryOut Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceDryOut type exposes the following members.

Constructors

Name | Description
Lofi2DeviceDryOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceDryOut Class


Lofi2DeviceDryOut Constructor

[image]

.NET Framework Class Library
Lofi2DeviceDryOut Constructor
Lofi2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceDryOut()
Visual C++
public:
Lofi2DeviceDryOut()
JavaScript
NRenoiseTools.Lofi2DeviceDryOut = function();

See Also

Lofi2DeviceDryOut Class


Lofi2DeviceDryOut Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOut Methods
Lofi2DeviceDryOut Class See Also Send Feedback

The Lofi2DeviceDryOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceDryOut Class


Lofi2DeviceDryOut Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOut Properties
Lofi2DeviceDryOut Class See Also Send Feedback

The Lofi2DeviceDryOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceDryOut Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceDryOut..::.MidiMappings Property
Lofi2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceDryOut Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceDryOut..::.Value Property
Lofi2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceDryOut Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceDryOut..::.Visualization Property
Lofi2DeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceDryOutVisualization
C#
public Lofi2DeviceDryOutVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceDryOutVisualization Visualization {
    Lofi2DeviceDryOutVisualization get ();
    void set (Lofi2DeviceDryOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceDryOut Class


Lofi2DeviceDryOutRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceDryOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceDryOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceDryOutRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceDryOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceDryOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceDryOutRunTimePreset

See Also

Lofi2DeviceDryOutRunTimePreset Members


Lofi2DeviceDryOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset Members
Lofi2DeviceDryOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceDryOutRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceDryOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceDryOutRunTimePreset Class


Lofi2DeviceDryOutRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset Constructor
Lofi2DeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceDryOutRunTimePreset()
Visual C++
public:
Lofi2DeviceDryOutRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceDryOutRunTimePreset = function();

See Also

Lofi2DeviceDryOutRunTimePreset Class


Lofi2DeviceDryOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset Methods
Lofi2DeviceDryOutRunTimePreset Class See Also Send Feedback

The Lofi2DeviceDryOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceDryOutRunTimePreset Class


Lofi2DeviceDryOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset Properties
Lofi2DeviceDryOutRunTimePreset Class See Also Send Feedback

The Lofi2DeviceDryOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceDryOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceDryOutRunTimePreset..::.Value Property
Lofi2DeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceDryOutRunTimePreset Class


Lofi2DeviceDryOutVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceDryOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceDryOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceDryOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceDryOutVisualization
JavaScript
NRenoiseTools.Lofi2DeviceDryOutVisualization = function();
NRenoiseTools.Lofi2DeviceDryOutVisualization.createEnum('NRenoiseTools.Lofi2DeviceDryOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceInterpolate Class

[image]

.NET Framework Class Library
Lofi2DeviceInterpolate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceInterpolate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceInterpolate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceInterpolate
JavaScript
NRenoiseTools.Lofi2DeviceInterpolate = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceInterpolate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceInterpolate

See Also

Lofi2DeviceInterpolate Members


Lofi2DeviceInterpolate Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolate Members
Lofi2DeviceInterpolate Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceInterpolate type exposes the following members.

Constructors

Name | Description
Lofi2DeviceInterpolate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceInterpolate Class


Lofi2DeviceInterpolate Constructor

[image]

.NET Framework Class Library
Lofi2DeviceInterpolate Constructor
Lofi2DeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceInterpolate()
Visual C++
public:
Lofi2DeviceInterpolate()
JavaScript
NRenoiseTools.Lofi2DeviceInterpolate = function();

See Also

Lofi2DeviceInterpolate Class


Lofi2DeviceInterpolate Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolate Methods
Lofi2DeviceInterpolate Class See Also Send Feedback

The Lofi2DeviceInterpolate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceInterpolate Class


Lofi2DeviceInterpolate Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolate Properties
Lofi2DeviceInterpolate Class See Also Send Feedback

The Lofi2DeviceInterpolate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceInterpolate Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceInterpolate..::.MidiMappings Property
Lofi2DeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceInterpolate Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceInterpolate..::.Value Property
Lofi2DeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceInterpolate Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceInterpolate..::.Visualization Property
Lofi2DeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceInterpolateVisualization
C#
public Lofi2DeviceInterpolateVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceInterpolateVisualization Visualization {
    Lofi2DeviceInterpolateVisualization get ();
    void set (Lofi2DeviceInterpolateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceInterpolate Class


Lofi2DeviceInterpolateRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceInterpolateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceInterpolateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceInterpolateRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceInterpolateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceInterpolateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceInterpolateRunTimePreset

See Also

Lofi2DeviceInterpolateRunTimePreset Members


Lofi2DeviceInterpolateRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset Members
Lofi2DeviceInterpolateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceInterpolateRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceInterpolateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceInterpolateRunTimePreset Class


Lofi2DeviceInterpolateRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset Constructor
Lofi2DeviceInterpolateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceInterpolateRunTimePreset()
Visual C++
public:
Lofi2DeviceInterpolateRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceInterpolateRunTimePreset = function();

See Also

Lofi2DeviceInterpolateRunTimePreset Class


Lofi2DeviceInterpolateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset Methods
Lofi2DeviceInterpolateRunTimePreset Class See Also Send Feedback

The Lofi2DeviceInterpolateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceInterpolateRunTimePreset Class


Lofi2DeviceInterpolateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset Properties
Lofi2DeviceInterpolateRunTimePreset Class See Also Send Feedback

The Lofi2DeviceInterpolateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceInterpolateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceInterpolateRunTimePreset..::.Value Property
Lofi2DeviceInterpolateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceInterpolateRunTimePreset Class


Lofi2DeviceInterpolateVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceInterpolateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceInterpolateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceInterpolateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceInterpolateVisualization
JavaScript
NRenoiseTools.Lofi2DeviceInterpolateVisualization = function();
NRenoiseTools.Lofi2DeviceInterpolateVisualization.createEnum('NRenoiseTools.Lofi2DeviceInterpolateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceLofiDevice Class

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceLofiDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceLofiDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceLofiDevice
JavaScript
NRenoiseTools.Lofi2DeviceLofiDevice = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceLofiDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceLofiDevice

See Also

Lofi2DeviceLofiDevice Members


Lofi2DeviceLofiDevice Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceLofiDevice Members
Lofi2DeviceLofiDevice Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceLofiDevice type exposes the following members.

Constructors

Name | Description
Lofi2DeviceLofiDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bits |
DryOut |
Interpolate |
IsActive |
IsSelected |
Noise |
Rate |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetOut |

See Also

Lofi2DeviceLofiDevice Class


Lofi2DeviceLofiDevice Constructor

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice Constructor
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceLofiDevice()
Visual C++
public:
Lofi2DeviceLofiDevice()
JavaScript
NRenoiseTools.Lofi2DeviceLofiDevice = function();

See Also

Lofi2DeviceLofiDevice Class


Lofi2DeviceLofiDevice Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceLofiDevice Methods
Lofi2DeviceLofiDevice Class See Also Send Feedback

The Lofi2DeviceLofiDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceLofiDevice Class


Lofi2DeviceLofiDevice Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceLofiDevice Properties
Lofi2DeviceLofiDevice Class See Also Send Feedback

The Lofi2DeviceLofiDevice type exposes the following members.

Properties

Name | Description
Bits |
DryOut |
Interpolate |
IsActive |
IsSelected |
Noise |
Rate |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetOut |

See Also

Lofi2DeviceLofiDevice Class


Bits Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.Bits Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Bits As Lofi2DeviceBits
C#
public Lofi2DeviceBits Bits { get; set; }
Visual C++
public:
property Lofi2DeviceBits^ Bits {
    Lofi2DeviceBits^ get ();
    void set (Lofi2DeviceBits^ value);
}
JavaScript
function get_bits();
function set_bits(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


DryOut Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.DryOut Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As Lofi2DeviceDryOut
C#
public Lofi2DeviceDryOut DryOut { get; set; }
Visual C++
public:
property Lofi2DeviceDryOut^ DryOut {
    Lofi2DeviceDryOut^ get ();
    void set (Lofi2DeviceDryOut^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


Interpolate Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.Interpolate Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Interpolate As Lofi2DeviceInterpolate
C#
public Lofi2DeviceInterpolate Interpolate { get; set; }
Visual C++
public:
property Lofi2DeviceInterpolate^ Interpolate {
    Lofi2DeviceInterpolate^ get ();
    void set (Lofi2DeviceInterpolate^ value);
}
JavaScript
function get_interpolate();
function set_interpolate(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


IsActive Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.IsActive Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.IsSelected Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


Noise Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.Noise Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Noise As Lofi2DeviceNoise
C#
public Lofi2DeviceNoise Noise { get; set; }
Visual C++
public:
property Lofi2DeviceNoise^ Noise {
    Lofi2DeviceNoise^ get ();
    void set (Lofi2DeviceNoise^ value);
}
JavaScript
function get_noise();
function set_noise(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


Rate Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.Rate Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Rate As Lofi2DeviceRate
C#
public Lofi2DeviceRate Rate { get; set; }
Visual C++
public:
property Lofi2DeviceRate^ Rate {
    Lofi2DeviceRate^ get ();
    void set (Lofi2DeviceRate^ value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.RunTimePresetA Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Lofi2DeviceRunTimePreset
C#
public Lofi2DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Lofi2DeviceRunTimePreset^ RunTimePresetA {
    Lofi2DeviceRunTimePreset^ get ();
    void set (Lofi2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.RunTimePresetB Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Lofi2DeviceRunTimePreset
C#
public Lofi2DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Lofi2DeviceRunTimePreset^ RunTimePresetB {
    Lofi2DeviceRunTimePreset^ get ();
    void set (Lofi2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.SelectedPresetIsModified Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.SelectedPresetName Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


type Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.type Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


WetOut Property

[image]

.NET Framework Class Library
Lofi2DeviceLofiDevice..::.WetOut Property
Lofi2DeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As Lofi2DeviceWetOut
C#
public Lofi2DeviceWetOut WetOut { get; set; }
Visual C++
public:
property Lofi2DeviceWetOut^ WetOut {
    Lofi2DeviceWetOut^ get ();
    void set (Lofi2DeviceWetOut^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

Lofi2DeviceLofiDevice Class


Lofi2DeviceNoise Class

[image]

.NET Framework Class Library
Lofi2DeviceNoise Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceNoise
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceNoise
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceNoise
JavaScript
NRenoiseTools.Lofi2DeviceNoise = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceNoise');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceNoise

See Also

Lofi2DeviceNoise Members


Lofi2DeviceNoise Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoise Members
Lofi2DeviceNoise Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceNoise type exposes the following members.

Constructors

Name | Description
Lofi2DeviceNoise |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceNoise Class


Lofi2DeviceNoise Constructor

[image]

.NET Framework Class Library
Lofi2DeviceNoise Constructor
Lofi2DeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceNoise()
Visual C++
public:
Lofi2DeviceNoise()
JavaScript
NRenoiseTools.Lofi2DeviceNoise = function();

See Also

Lofi2DeviceNoise Class


Lofi2DeviceNoise Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoise Methods
Lofi2DeviceNoise Class See Also Send Feedback

The Lofi2DeviceNoise type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceNoise Class


Lofi2DeviceNoise Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoise Properties
Lofi2DeviceNoise Class See Also Send Feedback

The Lofi2DeviceNoise type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceNoise Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceNoise..::.MidiMappings Property
Lofi2DeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceNoise Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceNoise..::.Value Property
Lofi2DeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceNoise Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceNoise..::.Visualization Property
Lofi2DeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceNoiseVisualization
C#
public Lofi2DeviceNoiseVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceNoiseVisualization Visualization {
    Lofi2DeviceNoiseVisualization get ();
    void set (Lofi2DeviceNoiseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceNoise Class


Lofi2DeviceNoiseRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceNoiseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceNoiseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceNoiseRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceNoiseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceNoiseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceNoiseRunTimePreset

See Also

Lofi2DeviceNoiseRunTimePreset Members


Lofi2DeviceNoiseRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset Members
Lofi2DeviceNoiseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceNoiseRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceNoiseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceNoiseRunTimePreset Class


Lofi2DeviceNoiseRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset Constructor
Lofi2DeviceNoiseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceNoiseRunTimePreset()
Visual C++
public:
Lofi2DeviceNoiseRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceNoiseRunTimePreset = function();

See Also

Lofi2DeviceNoiseRunTimePreset Class


Lofi2DeviceNoiseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset Methods
Lofi2DeviceNoiseRunTimePreset Class See Also Send Feedback

The Lofi2DeviceNoiseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceNoiseRunTimePreset Class


Lofi2DeviceNoiseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset Properties
Lofi2DeviceNoiseRunTimePreset Class See Also Send Feedback

The Lofi2DeviceNoiseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceNoiseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceNoiseRunTimePreset..::.Value Property
Lofi2DeviceNoiseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceNoiseRunTimePreset Class


Lofi2DeviceNoiseVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceNoiseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceNoiseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceNoiseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceNoiseVisualization
JavaScript
NRenoiseTools.Lofi2DeviceNoiseVisualization = function();
NRenoiseTools.Lofi2DeviceNoiseVisualization.createEnum('NRenoiseTools.Lofi2DeviceNoiseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceRate Class

[image]

.NET Framework Class Library
Lofi2DeviceRate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceRate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceRate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceRate
JavaScript
NRenoiseTools.Lofi2DeviceRate = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceRate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceRate

See Also

Lofi2DeviceRate Members


Lofi2DeviceRate Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceRate Members
Lofi2DeviceRate Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceRate type exposes the following members.

Constructors

Name | Description
Lofi2DeviceRate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceRate Class


Lofi2DeviceRate Constructor

[image]

.NET Framework Class Library
Lofi2DeviceRate Constructor
Lofi2DeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceRate()
Visual C++
public:
Lofi2DeviceRate()
JavaScript
NRenoiseTools.Lofi2DeviceRate = function();

See Also

Lofi2DeviceRate Class


Lofi2DeviceRate Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceRate Methods
Lofi2DeviceRate Class See Also Send Feedback

The Lofi2DeviceRate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceRate Class


Lofi2DeviceRate Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceRate Properties
Lofi2DeviceRate Class See Also Send Feedback

The Lofi2DeviceRate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceRate Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceRate..::.MidiMappings Property
Lofi2DeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceRate Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceRate..::.Value Property
Lofi2DeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceRate Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceRate..::.Visualization Property
Lofi2DeviceRate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceRateVisualization
C#
public Lofi2DeviceRateVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceRateVisualization Visualization {
    Lofi2DeviceRateVisualization get ();
    void set (Lofi2DeviceRateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceRate Class


Lofi2DeviceRateRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceRateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceRateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceRateRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceRateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceRateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceRateRunTimePreset

See Also

Lofi2DeviceRateRunTimePreset Members


Lofi2DeviceRateRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset Members
Lofi2DeviceRateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceRateRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceRateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceRateRunTimePreset Class


Lofi2DeviceRateRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset Constructor
Lofi2DeviceRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceRateRunTimePreset()
Visual C++
public:
Lofi2DeviceRateRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceRateRunTimePreset = function();

See Also

Lofi2DeviceRateRunTimePreset Class


Lofi2DeviceRateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset Methods
Lofi2DeviceRateRunTimePreset Class See Also Send Feedback

The Lofi2DeviceRateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceRateRunTimePreset Class


Lofi2DeviceRateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset Properties
Lofi2DeviceRateRunTimePreset Class See Also Send Feedback

The Lofi2DeviceRateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceRateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceRateRunTimePreset..::.Value Property
Lofi2DeviceRateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceRateRunTimePreset Class


Lofi2DeviceRateVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceRateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceRateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceRateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceRateVisualization
JavaScript
NRenoiseTools.Lofi2DeviceRateVisualization = function();
NRenoiseTools.Lofi2DeviceRateVisualization.createEnum('NRenoiseTools.Lofi2DeviceRateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Lofi2DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceRunTimePreset

See Also

Lofi2DeviceRunTimePreset Members


Lofi2DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset Members
Lofi2DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Lofi2DeviceRunTimePreset Class


Lofi2DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset Constructor
Lofi2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceRunTimePreset()
Visual C++
public:
Lofi2DeviceRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceRunTimePreset = function();

See Also

Lofi2DeviceRunTimePreset Class


Lofi2DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset Methods
Lofi2DeviceRunTimePreset Class See Also Send Feedback

The Lofi2DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceRunTimePreset Class


Lofi2DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset Properties
Lofi2DeviceRunTimePreset Class See Also Send Feedback

The Lofi2DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Lofi2DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset..::.DeviceSlot Property
Lofi2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Lofi2DeviceDeviceSlotRunTimePreset
C#
public Lofi2DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Lofi2DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Lofi2DeviceDeviceSlotRunTimePreset^ get ();
    void set (Lofi2DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Lofi2DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Lofi2DeviceRunTimePreset..::.type Property
Lofi2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Lofi2DeviceRunTimePreset Class


Lofi2DeviceWetOut Class

[image]

.NET Framework Class Library
Lofi2DeviceWetOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceWetOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceWetOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceWetOut
JavaScript
NRenoiseTools.Lofi2DeviceWetOut = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceWetOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceWetOut

See Also

Lofi2DeviceWetOut Members


Lofi2DeviceWetOut Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOut Members
Lofi2DeviceWetOut Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceWetOut type exposes the following members.

Constructors

Name | Description
Lofi2DeviceWetOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceWetOut Class


Lofi2DeviceWetOut Constructor

[image]

.NET Framework Class Library
Lofi2DeviceWetOut Constructor
Lofi2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceWetOut()
Visual C++
public:
Lofi2DeviceWetOut()
JavaScript
NRenoiseTools.Lofi2DeviceWetOut = function();

See Also

Lofi2DeviceWetOut Class


Lofi2DeviceWetOut Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOut Methods
Lofi2DeviceWetOut Class See Also Send Feedback

The Lofi2DeviceWetOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceWetOut Class


Lofi2DeviceWetOut Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOut Properties
Lofi2DeviceWetOut Class See Also Send Feedback

The Lofi2DeviceWetOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Lofi2DeviceWetOut Class


MidiMappings Property

[image]

.NET Framework Class Library
Lofi2DeviceWetOut..::.MidiMappings Property
Lofi2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Lofi2DeviceWetOut Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceWetOut..::.Value Property
Lofi2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceWetOut Class


Visualization Property

[image]

.NET Framework Class Library
Lofi2DeviceWetOut..::.Visualization Property
Lofi2DeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Lofi2DeviceWetOutVisualization
C#
public Lofi2DeviceWetOutVisualization Visualization { get; set; }
Visual C++
public:
property Lofi2DeviceWetOutVisualization Visualization {
    Lofi2DeviceWetOutVisualization get ();
    void set (Lofi2DeviceWetOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Lofi2DeviceWetOut Class


Lofi2DeviceWetOutRunTimePreset Class

[image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Lofi2DeviceWetOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Lofi2DeviceWetOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Lofi2DeviceWetOutRunTimePreset
JavaScript
NRenoiseTools.Lofi2DeviceWetOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Lofi2DeviceWetOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Lofi2DeviceWetOutRunTimePreset

See Also

Lofi2DeviceWetOutRunTimePreset Members


Lofi2DeviceWetOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset Members
Lofi2DeviceWetOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Lofi2DeviceWetOutRunTimePreset type exposes the following members.

Constructors

Name | Description
Lofi2DeviceWetOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Lofi2DeviceWetOutRunTimePreset Class


Lofi2DeviceWetOutRunTimePreset Constructor

[image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset Constructor
Lofi2DeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Lofi2DeviceWetOutRunTimePreset()
Visual C++
public:
Lofi2DeviceWetOutRunTimePreset()
JavaScript
NRenoiseTools.Lofi2DeviceWetOutRunTimePreset = function();

See Also

Lofi2DeviceWetOutRunTimePreset Class


Lofi2DeviceWetOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset Methods
Lofi2DeviceWetOutRunTimePreset Class See Also Send Feedback

The Lofi2DeviceWetOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lofi2DeviceWetOutRunTimePreset Class


Lofi2DeviceWetOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset Properties
Lofi2DeviceWetOutRunTimePreset Class See Also Send Feedback

The Lofi2DeviceWetOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Lofi2DeviceWetOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Lofi2DeviceWetOutRunTimePreset..::.Value Property
Lofi2DeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Lofi2DeviceWetOutRunTimePreset Class


Lofi2DeviceWetOutVisualization Enumeration

[image]

.NET Framework Class Library
Lofi2DeviceWetOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Lofi2DeviceWetOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Lofi2DeviceWetOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Lofi2DeviceWetOutVisualization
JavaScript
NRenoiseTools.Lofi2DeviceWetOutVisualization = function();
NRenoiseTools.Lofi2DeviceWetOutVisualization.createEnum('NRenoiseTools.Lofi2DeviceWetOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceBitCrunsh Class

[image]

.NET Framework Class Library
LofiDeviceBitCrunsh Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceBitCrunsh
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceBitCrunsh
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceBitCrunsh
JavaScript
NRenoiseTools.LofiDeviceBitCrunsh = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceBitCrunsh');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceBitCrunsh

See Also

LofiDeviceBitCrunsh Members


LofiDeviceBitCrunsh Members

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunsh Members
LofiDeviceBitCrunsh Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceBitCrunsh type exposes the following members.

Constructors

Name | Description
LofiDeviceBitCrunsh |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceBitCrunsh Class


LofiDeviceBitCrunsh Constructor

[image]

.NET Framework Class Library
LofiDeviceBitCrunsh Constructor
LofiDeviceBitCrunsh Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceBitCrunsh()
Visual C++
public:
LofiDeviceBitCrunsh()
JavaScript
NRenoiseTools.LofiDeviceBitCrunsh = function();

See Also

LofiDeviceBitCrunsh Class


LofiDeviceBitCrunsh Methods

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunsh Methods
LofiDeviceBitCrunsh Class See Also Send Feedback

The LofiDeviceBitCrunsh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceBitCrunsh Class


LofiDeviceBitCrunsh Properties

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunsh Properties
LofiDeviceBitCrunsh Class See Also Send Feedback

The LofiDeviceBitCrunsh type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceBitCrunsh Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceBitCrunsh..::.MidiMappings Property
LofiDeviceBitCrunsh Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceBitCrunsh Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceBitCrunsh..::.Value Property
LofiDeviceBitCrunsh Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceBitCrunsh Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceBitCrunsh..::.Visualization Property
LofiDeviceBitCrunsh Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceBitCrunshVisualization
C#
public LofiDeviceBitCrunshVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceBitCrunshVisualization Visualization {
    LofiDeviceBitCrunshVisualization get ();
    void set (LofiDeviceBitCrunshVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceBitCrunsh Class


LofiDeviceBitCrunshRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceBitCrunshRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceBitCrunshRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceBitCrunshRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceBitCrunshRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceBitCrunshRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceBitCrunshRunTimePreset

See Also

LofiDeviceBitCrunshRunTimePreset Members


LofiDeviceBitCrunshRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset Members
LofiDeviceBitCrunshRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceBitCrunshRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceBitCrunshRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceBitCrunshRunTimePreset Class


LofiDeviceBitCrunshRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset Constructor
LofiDeviceBitCrunshRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceBitCrunshRunTimePreset()
Visual C++
public:
LofiDeviceBitCrunshRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceBitCrunshRunTimePreset = function();

See Also

LofiDeviceBitCrunshRunTimePreset Class


LofiDeviceBitCrunshRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset Methods
LofiDeviceBitCrunshRunTimePreset Class See Also Send Feedback

The LofiDeviceBitCrunshRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceBitCrunshRunTimePreset Class


LofiDeviceBitCrunshRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset Properties
LofiDeviceBitCrunshRunTimePreset Class See Also Send Feedback

The LofiDeviceBitCrunshRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceBitCrunshRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceBitCrunshRunTimePreset..::.Value Property
LofiDeviceBitCrunshRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceBitCrunshRunTimePreset Class


LofiDeviceBitCrunshVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceBitCrunshVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceBitCrunshVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceBitCrunshVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceBitCrunshVisualization
JavaScript
NRenoiseTools.LofiDeviceBitCrunshVisualization = function();
NRenoiseTools.LofiDeviceBitCrunshVisualization.createEnum('NRenoiseTools.LofiDeviceBitCrunshVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceDeviceSlotRunTimePreset

See Also

LofiDeviceDeviceSlotRunTimePreset Members


LofiDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset Members
LofiDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BitCrunsh |
DryOut |
Interpolate |
Noise |
Quality |
type |
WetOut |

See Also

LofiDeviceDeviceSlotRunTimePreset Class


LofiDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset Constructor
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceDeviceSlotRunTimePreset()
Visual C++
public:
LofiDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceDeviceSlotRunTimePreset = function();

See Also

LofiDeviceDeviceSlotRunTimePreset Class


LofiDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset Methods
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LofiDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceDeviceSlotRunTimePreset Class


LofiDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset Properties
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The LofiDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
BitCrunsh |
DryOut |
Interpolate |
Noise |
Quality |
type |
WetOut |

See Also

LofiDeviceDeviceSlotRunTimePreset Class


BitCrunsh Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.BitCrunsh Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BitCrunsh As LofiDeviceBitCrunshRunTimePreset
C#
public LofiDeviceBitCrunshRunTimePreset BitCrunsh { get; set; }
Visual C++
public:
property LofiDeviceBitCrunshRunTimePreset^ BitCrunsh {
    LofiDeviceBitCrunshRunTimePreset^ get ();
    void set (LofiDeviceBitCrunshRunTimePreset^ value);
}
JavaScript
function get_bitCrunsh();
function set_bitCrunsh(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


DryOut Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.DryOut Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As LofiDeviceDryOutRunTimePreset
C#
public LofiDeviceDryOutRunTimePreset DryOut { get; set; }
Visual C++
public:
property LofiDeviceDryOutRunTimePreset^ DryOut {
    LofiDeviceDryOutRunTimePreset^ get ();
    void set (LofiDeviceDryOutRunTimePreset^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


Interpolate Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.Interpolate Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Interpolate As LofiDeviceInterpolateRunTimePreset
C#
public LofiDeviceInterpolateRunTimePreset Interpolate { get; set; }
Visual C++
public:
property LofiDeviceInterpolateRunTimePreset^ Interpolate {
    LofiDeviceInterpolateRunTimePreset^ get ();
    void set (LofiDeviceInterpolateRunTimePreset^ value);
}
JavaScript
function get_interpolate();
function set_interpolate(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


Noise Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.Noise Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Noise As LofiDeviceNoiseRunTimePreset
C#
public LofiDeviceNoiseRunTimePreset Noise { get; set; }
Visual C++
public:
property LofiDeviceNoiseRunTimePreset^ Noise {
    LofiDeviceNoiseRunTimePreset^ get ();
    void set (LofiDeviceNoiseRunTimePreset^ value);
}
JavaScript
function get_noise();
function set_noise(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


Quality Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.Quality Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Quality As LofiDeviceQualityRunTimePreset
C#
public LofiDeviceQualityRunTimePreset Quality { get; set; }
Visual C++
public:
property LofiDeviceQualityRunTimePreset^ Quality {
    LofiDeviceQualityRunTimePreset^ get ();
    void set (LofiDeviceQualityRunTimePreset^ value);
}
JavaScript
function get_quality();
function set_quality(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.type Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


WetOut Property

[image]

.NET Framework Class Library
LofiDeviceDeviceSlotRunTimePreset..::.WetOut Property
LofiDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As LofiDeviceWetOutRunTimePreset
C#
public LofiDeviceWetOutRunTimePreset WetOut { get; set; }
Visual C++
public:
property LofiDeviceWetOutRunTimePreset^ WetOut {
    LofiDeviceWetOutRunTimePreset^ get ();
    void set (LofiDeviceWetOutRunTimePreset^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

LofiDeviceDeviceSlotRunTimePreset Class


LofiDeviceDryOut Class

[image]

.NET Framework Class Library
LofiDeviceDryOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceDryOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceDryOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceDryOut
JavaScript
NRenoiseTools.LofiDeviceDryOut = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceDryOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceDryOut

See Also

LofiDeviceDryOut Members


LofiDeviceDryOut Members

[image] [image]

.NET Framework Class Library
LofiDeviceDryOut Members
LofiDeviceDryOut Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceDryOut type exposes the following members.

Constructors

Name | Description
LofiDeviceDryOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceDryOut Class


LofiDeviceDryOut Constructor

[image]

.NET Framework Class Library
LofiDeviceDryOut Constructor
LofiDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceDryOut()
Visual C++
public:
LofiDeviceDryOut()
JavaScript
NRenoiseTools.LofiDeviceDryOut = function();

See Also

LofiDeviceDryOut Class


LofiDeviceDryOut Methods

[image] [image]

.NET Framework Class Library
LofiDeviceDryOut Methods
LofiDeviceDryOut Class See Also Send Feedback

The LofiDeviceDryOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceDryOut Class


LofiDeviceDryOut Properties

[image] [image]

.NET Framework Class Library
LofiDeviceDryOut Properties
LofiDeviceDryOut Class See Also Send Feedback

The LofiDeviceDryOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceDryOut Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceDryOut..::.MidiMappings Property
LofiDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceDryOut Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceDryOut..::.Value Property
LofiDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceDryOut Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceDryOut..::.Visualization Property
LofiDeviceDryOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceDryOutVisualization
C#
public LofiDeviceDryOutVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceDryOutVisualization Visualization {
    LofiDeviceDryOutVisualization get ();
    void set (LofiDeviceDryOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceDryOut Class


LofiDeviceDryOutRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceDryOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceDryOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceDryOutRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceDryOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceDryOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceDryOutRunTimePreset

See Also

LofiDeviceDryOutRunTimePreset Members


LofiDeviceDryOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset Members
LofiDeviceDryOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceDryOutRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceDryOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceDryOutRunTimePreset Class


LofiDeviceDryOutRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset Constructor
LofiDeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceDryOutRunTimePreset()
Visual C++
public:
LofiDeviceDryOutRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceDryOutRunTimePreset = function();

See Also

LofiDeviceDryOutRunTimePreset Class


LofiDeviceDryOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset Methods
LofiDeviceDryOutRunTimePreset Class See Also Send Feedback

The LofiDeviceDryOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceDryOutRunTimePreset Class


LofiDeviceDryOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset Properties
LofiDeviceDryOutRunTimePreset Class See Also Send Feedback

The LofiDeviceDryOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceDryOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceDryOutRunTimePreset..::.Value Property
LofiDeviceDryOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceDryOutRunTimePreset Class


LofiDeviceDryOutVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceDryOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceDryOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceDryOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceDryOutVisualization
JavaScript
NRenoiseTools.LofiDeviceDryOutVisualization = function();
NRenoiseTools.LofiDeviceDryOutVisualization.createEnum('NRenoiseTools.LofiDeviceDryOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceInterpolate Class

[image]

.NET Framework Class Library
LofiDeviceInterpolate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceInterpolate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceInterpolate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceInterpolate
JavaScript
NRenoiseTools.LofiDeviceInterpolate = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceInterpolate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceInterpolate

See Also

LofiDeviceInterpolate Members


LofiDeviceInterpolate Members

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolate Members
LofiDeviceInterpolate Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceInterpolate type exposes the following members.

Constructors

Name | Description
LofiDeviceInterpolate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceInterpolate Class


LofiDeviceInterpolate Constructor

[image]

.NET Framework Class Library
LofiDeviceInterpolate Constructor
LofiDeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceInterpolate()
Visual C++
public:
LofiDeviceInterpolate()
JavaScript
NRenoiseTools.LofiDeviceInterpolate = function();

See Also

LofiDeviceInterpolate Class


LofiDeviceInterpolate Methods

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolate Methods
LofiDeviceInterpolate Class See Also Send Feedback

The LofiDeviceInterpolate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceInterpolate Class


LofiDeviceInterpolate Properties

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolate Properties
LofiDeviceInterpolate Class See Also Send Feedback

The LofiDeviceInterpolate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceInterpolate Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceInterpolate..::.MidiMappings Property
LofiDeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceInterpolate Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceInterpolate..::.Value Property
LofiDeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceInterpolate Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceInterpolate..::.Visualization Property
LofiDeviceInterpolate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceInterpolateVisualization
C#
public LofiDeviceInterpolateVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceInterpolateVisualization Visualization {
    LofiDeviceInterpolateVisualization get ();
    void set (LofiDeviceInterpolateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceInterpolate Class


LofiDeviceInterpolateRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceInterpolateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceInterpolateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceInterpolateRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceInterpolateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceInterpolateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceInterpolateRunTimePreset

See Also

LofiDeviceInterpolateRunTimePreset Members


LofiDeviceInterpolateRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset Members
LofiDeviceInterpolateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceInterpolateRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceInterpolateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceInterpolateRunTimePreset Class


LofiDeviceInterpolateRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset Constructor
LofiDeviceInterpolateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceInterpolateRunTimePreset()
Visual C++
public:
LofiDeviceInterpolateRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceInterpolateRunTimePreset = function();

See Also

LofiDeviceInterpolateRunTimePreset Class


LofiDeviceInterpolateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset Methods
LofiDeviceInterpolateRunTimePreset Class See Also Send Feedback

The LofiDeviceInterpolateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceInterpolateRunTimePreset Class


LofiDeviceInterpolateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset Properties
LofiDeviceInterpolateRunTimePreset Class See Also Send Feedback

The LofiDeviceInterpolateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceInterpolateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceInterpolateRunTimePreset..::.Value Property
LofiDeviceInterpolateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceInterpolateRunTimePreset Class


LofiDeviceInterpolateVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceInterpolateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceInterpolateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceInterpolateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceInterpolateVisualization
JavaScript
NRenoiseTools.LofiDeviceInterpolateVisualization = function();
NRenoiseTools.LofiDeviceInterpolateVisualization.createEnum('NRenoiseTools.LofiDeviceInterpolateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceLofiDevice Class

[image]

.NET Framework Class Library
LofiDeviceLofiDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceLofiDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceLofiDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceLofiDevice
JavaScript
NRenoiseTools.LofiDeviceLofiDevice = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceLofiDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceLofiDevice

See Also

LofiDeviceLofiDevice Members


LofiDeviceLofiDevice Members

[image] [image]

.NET Framework Class Library
LofiDeviceLofiDevice Members
LofiDeviceLofiDevice Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceLofiDevice type exposes the following members.

Constructors

Name | Description
LofiDeviceLofiDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BitCrunsh |
DryOut |
Interpolate |
IsActive |
IsSelected |
Noise |
Quality |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetOut |

See Also

LofiDeviceLofiDevice Class


LofiDeviceLofiDevice Constructor

[image]

.NET Framework Class Library
LofiDeviceLofiDevice Constructor
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceLofiDevice()
Visual C++
public:
LofiDeviceLofiDevice()
JavaScript
NRenoiseTools.LofiDeviceLofiDevice = function();

See Also

LofiDeviceLofiDevice Class


LofiDeviceLofiDevice Methods

[image] [image]

.NET Framework Class Library
LofiDeviceLofiDevice Methods
LofiDeviceLofiDevice Class See Also Send Feedback

The LofiDeviceLofiDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceLofiDevice Class


LofiDeviceLofiDevice Properties

[image] [image]

.NET Framework Class Library
LofiDeviceLofiDevice Properties
LofiDeviceLofiDevice Class See Also Send Feedback

The LofiDeviceLofiDevice type exposes the following members.

Properties

Name | Description
BitCrunsh |
DryOut |
Interpolate |
IsActive |
IsSelected |
Noise |
Quality |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetOut |

See Also

LofiDeviceLofiDevice Class


BitCrunsh Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.BitCrunsh Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BitCrunsh As LofiDeviceBitCrunsh
C#
public LofiDeviceBitCrunsh BitCrunsh { get; set; }
Visual C++
public:
property LofiDeviceBitCrunsh^ BitCrunsh {
    LofiDeviceBitCrunsh^ get ();
    void set (LofiDeviceBitCrunsh^ value);
}
JavaScript
function get_bitCrunsh();
function set_bitCrunsh(value);

Remarks

See Also

LofiDeviceLofiDevice Class


DryOut Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.DryOut Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryOut As LofiDeviceDryOut
C#
public LofiDeviceDryOut DryOut { get; set; }
Visual C++
public:
property LofiDeviceDryOut^ DryOut {
    LofiDeviceDryOut^ get ();
    void set (LofiDeviceDryOut^ value);
}
JavaScript
function get_dryOut();
function set_dryOut(value);

Remarks

See Also

LofiDeviceLofiDevice Class


Interpolate Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.Interpolate Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Interpolate As LofiDeviceInterpolate
C#
public LofiDeviceInterpolate Interpolate { get; set; }
Visual C++
public:
property LofiDeviceInterpolate^ Interpolate {
    LofiDeviceInterpolate^ get ();
    void set (LofiDeviceInterpolate^ value);
}
JavaScript
function get_interpolate();
function set_interpolate(value);

Remarks

See Also

LofiDeviceLofiDevice Class


IsActive Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.IsActive Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

LofiDeviceLofiDevice Class


IsSelected Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.IsSelected Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

LofiDeviceLofiDevice Class


Noise Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.Noise Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Noise As LofiDeviceNoise
C#
public LofiDeviceNoise Noise { get; set; }
Visual C++
public:
property LofiDeviceNoise^ Noise {
    LofiDeviceNoise^ get ();
    void set (LofiDeviceNoise^ value);
}
JavaScript
function get_noise();
function set_noise(value);

Remarks

See Also

LofiDeviceLofiDevice Class


Quality Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.Quality Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Quality As LofiDeviceQuality
C#
public LofiDeviceQuality Quality { get; set; }
Visual C++
public:
property LofiDeviceQuality^ Quality {
    LofiDeviceQuality^ get ();
    void set (LofiDeviceQuality^ value);
}
JavaScript
function get_quality();
function set_quality(value);

Remarks

See Also

LofiDeviceLofiDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.RunTimePresetA Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As LofiDeviceRunTimePreset
C#
public LofiDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property LofiDeviceRunTimePreset^ RunTimePresetA {
    LofiDeviceRunTimePreset^ get ();
    void set (LofiDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

LofiDeviceLofiDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.RunTimePresetB Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As LofiDeviceRunTimePreset
C#
public LofiDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property LofiDeviceRunTimePreset^ RunTimePresetB {
    LofiDeviceRunTimePreset^ get ();
    void set (LofiDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

LofiDeviceLofiDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.SelectedPresetIsModified Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

LofiDeviceLofiDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.SelectedPresetName Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

LofiDeviceLofiDevice Class


type Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.type Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LofiDeviceLofiDevice Class


WetOut Property

[image]

.NET Framework Class Library
LofiDeviceLofiDevice..::.WetOut Property
LofiDeviceLofiDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetOut As LofiDeviceWetOut
C#
public LofiDeviceWetOut WetOut { get; set; }
Visual C++
public:
property LofiDeviceWetOut^ WetOut {
    LofiDeviceWetOut^ get ();
    void set (LofiDeviceWetOut^ value);
}
JavaScript
function get_wetOut();
function set_wetOut(value);

Remarks

See Also

LofiDeviceLofiDevice Class


LofiDeviceNoise Class

[image]

.NET Framework Class Library
LofiDeviceNoise Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceNoise
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceNoise
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceNoise
JavaScript
NRenoiseTools.LofiDeviceNoise = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceNoise');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceNoise

See Also

LofiDeviceNoise Members


LofiDeviceNoise Members

[image] [image]

.NET Framework Class Library
LofiDeviceNoise Members
LofiDeviceNoise Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceNoise type exposes the following members.

Constructors

Name | Description
LofiDeviceNoise |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceNoise Class


LofiDeviceNoise Constructor

[image]

.NET Framework Class Library
LofiDeviceNoise Constructor
LofiDeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceNoise()
Visual C++
public:
LofiDeviceNoise()
JavaScript
NRenoiseTools.LofiDeviceNoise = function();

See Also

LofiDeviceNoise Class


LofiDeviceNoise Methods

[image] [image]

.NET Framework Class Library
LofiDeviceNoise Methods
LofiDeviceNoise Class See Also Send Feedback

The LofiDeviceNoise type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceNoise Class


LofiDeviceNoise Properties

[image] [image]

.NET Framework Class Library
LofiDeviceNoise Properties
LofiDeviceNoise Class See Also Send Feedback

The LofiDeviceNoise type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceNoise Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceNoise..::.MidiMappings Property
LofiDeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceNoise Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceNoise..::.Value Property
LofiDeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceNoise Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceNoise..::.Visualization Property
LofiDeviceNoise Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceNoiseVisualization
C#
public LofiDeviceNoiseVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceNoiseVisualization Visualization {
    LofiDeviceNoiseVisualization get ();
    void set (LofiDeviceNoiseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceNoise Class


LofiDeviceNoiseRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceNoiseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceNoiseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceNoiseRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceNoiseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceNoiseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceNoiseRunTimePreset

See Also

LofiDeviceNoiseRunTimePreset Members


LofiDeviceNoiseRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset Members
LofiDeviceNoiseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceNoiseRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceNoiseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceNoiseRunTimePreset Class


LofiDeviceNoiseRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset Constructor
LofiDeviceNoiseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceNoiseRunTimePreset()
Visual C++
public:
LofiDeviceNoiseRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceNoiseRunTimePreset = function();

See Also

LofiDeviceNoiseRunTimePreset Class


LofiDeviceNoiseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset Methods
LofiDeviceNoiseRunTimePreset Class See Also Send Feedback

The LofiDeviceNoiseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceNoiseRunTimePreset Class


LofiDeviceNoiseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset Properties
LofiDeviceNoiseRunTimePreset Class See Also Send Feedback

The LofiDeviceNoiseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceNoiseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceNoiseRunTimePreset..::.Value Property
LofiDeviceNoiseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceNoiseRunTimePreset Class


LofiDeviceNoiseVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceNoiseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceNoiseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceNoiseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceNoiseVisualization
JavaScript
NRenoiseTools.LofiDeviceNoiseVisualization = function();
NRenoiseTools.LofiDeviceNoiseVisualization.createEnum('NRenoiseTools.LofiDeviceNoiseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceQuality Class

[image]

.NET Framework Class Library
LofiDeviceQuality Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceQuality
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceQuality
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceQuality
JavaScript
NRenoiseTools.LofiDeviceQuality = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceQuality');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceQuality

See Also

LofiDeviceQuality Members


LofiDeviceQuality Members

[image] [image]

.NET Framework Class Library
LofiDeviceQuality Members
LofiDeviceQuality Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceQuality type exposes the following members.

Constructors

Name | Description
LofiDeviceQuality |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceQuality Class


LofiDeviceQuality Constructor

[image]

.NET Framework Class Library
LofiDeviceQuality Constructor
LofiDeviceQuality Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceQuality()
Visual C++
public:
LofiDeviceQuality()
JavaScript
NRenoiseTools.LofiDeviceQuality = function();

See Also

LofiDeviceQuality Class


LofiDeviceQuality Methods

[image] [image]

.NET Framework Class Library
LofiDeviceQuality Methods
LofiDeviceQuality Class See Also Send Feedback

The LofiDeviceQuality type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceQuality Class


LofiDeviceQuality Properties

[image] [image]

.NET Framework Class Library
LofiDeviceQuality Properties
LofiDeviceQuality Class See Also Send Feedback

The LofiDeviceQuality type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceQuality Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceQuality..::.MidiMappings Property
LofiDeviceQuality Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceQuality Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceQuality..::.Value Property
LofiDeviceQuality Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceQuality Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceQuality..::.Visualization Property
LofiDeviceQuality Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceQualityVisualization
C#
public LofiDeviceQualityVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceQualityVisualization Visualization {
    LofiDeviceQualityVisualization get ();
    void set (LofiDeviceQualityVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceQuality Class


LofiDeviceQualityRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceQualityRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceQualityRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceQualityRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceQualityRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceQualityRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceQualityRunTimePreset

See Also

LofiDeviceQualityRunTimePreset Members


LofiDeviceQualityRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset Members
LofiDeviceQualityRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceQualityRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceQualityRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceQualityRunTimePreset Class


LofiDeviceQualityRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset Constructor
LofiDeviceQualityRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceQualityRunTimePreset()
Visual C++
public:
LofiDeviceQualityRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceQualityRunTimePreset = function();

See Also

LofiDeviceQualityRunTimePreset Class


LofiDeviceQualityRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset Methods
LofiDeviceQualityRunTimePreset Class See Also Send Feedback

The LofiDeviceQualityRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceQualityRunTimePreset Class


LofiDeviceQualityRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset Properties
LofiDeviceQualityRunTimePreset Class See Also Send Feedback

The LofiDeviceQualityRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceQualityRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceQualityRunTimePreset..::.Value Property
LofiDeviceQualityRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceQualityRunTimePreset Class


LofiDeviceQualityVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceQualityVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceQualityVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceQualityVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceQualityVisualization
JavaScript
NRenoiseTools.LofiDeviceQualityVisualization = function();
NRenoiseTools.LofiDeviceQualityVisualization.createEnum('NRenoiseTools.LofiDeviceQualityVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LofiDeviceRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceRunTimePreset

See Also

LofiDeviceRunTimePreset Members


LofiDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceRunTimePreset Members
LofiDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

LofiDeviceRunTimePreset Class


LofiDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceRunTimePreset Constructor
LofiDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceRunTimePreset()
Visual C++
public:
LofiDeviceRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceRunTimePreset = function();

See Also

LofiDeviceRunTimePreset Class


LofiDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceRunTimePreset Methods
LofiDeviceRunTimePreset Class See Also Send Feedback

The LofiDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceRunTimePreset Class


LofiDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceRunTimePreset Properties
LofiDeviceRunTimePreset Class See Also Send Feedback

The LofiDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

LofiDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
LofiDeviceRunTimePreset..::.DeviceSlot Property
LofiDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As LofiDeviceDeviceSlotRunTimePreset
C#
public LofiDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property LofiDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    LofiDeviceDeviceSlotRunTimePreset^ get ();
    void set (LofiDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

LofiDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
LofiDeviceRunTimePreset..::.type Property
LofiDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

LofiDeviceRunTimePreset Class


LofiDeviceWetOut Class

[image]

.NET Framework Class Library
LofiDeviceWetOut Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceWetOut
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceWetOut
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceWetOut
JavaScript
NRenoiseTools.LofiDeviceWetOut = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceWetOut');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceWetOut

See Also

LofiDeviceWetOut Members


LofiDeviceWetOut Members

[image] [image]

.NET Framework Class Library
LofiDeviceWetOut Members
LofiDeviceWetOut Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceWetOut type exposes the following members.

Constructors

Name | Description
LofiDeviceWetOut |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceWetOut Class


LofiDeviceWetOut Constructor

[image]

.NET Framework Class Library
LofiDeviceWetOut Constructor
LofiDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceWetOut()
Visual C++
public:
LofiDeviceWetOut()
JavaScript
NRenoiseTools.LofiDeviceWetOut = function();

See Also

LofiDeviceWetOut Class


LofiDeviceWetOut Methods

[image] [image]

.NET Framework Class Library
LofiDeviceWetOut Methods
LofiDeviceWetOut Class See Also Send Feedback

The LofiDeviceWetOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceWetOut Class


LofiDeviceWetOut Properties

[image] [image]

.NET Framework Class Library
LofiDeviceWetOut Properties
LofiDeviceWetOut Class See Also Send Feedback

The LofiDeviceWetOut type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

LofiDeviceWetOut Class


MidiMappings Property

[image]

.NET Framework Class Library
LofiDeviceWetOut..::.MidiMappings Property
LofiDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

LofiDeviceWetOut Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceWetOut..::.Value Property
LofiDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceWetOut Class


Visualization Property

[image]

.NET Framework Class Library
LofiDeviceWetOut..::.Visualization Property
LofiDeviceWetOut Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As LofiDeviceWetOutVisualization
C#
public LofiDeviceWetOutVisualization Visualization { get; set; }
Visual C++
public:
property LofiDeviceWetOutVisualization Visualization {
    LofiDeviceWetOutVisualization get ();
    void set (LofiDeviceWetOutVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

LofiDeviceWetOut Class


LofiDeviceWetOutRunTimePreset Class

[image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LofiDeviceWetOutRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LofiDeviceWetOutRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LofiDeviceWetOutRunTimePreset
JavaScript
NRenoiseTools.LofiDeviceWetOutRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.LofiDeviceWetOutRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LofiDeviceWetOutRunTimePreset

See Also

LofiDeviceWetOutRunTimePreset Members


LofiDeviceWetOutRunTimePreset Members

[image] [image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset Members
LofiDeviceWetOutRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The LofiDeviceWetOutRunTimePreset type exposes the following members.

Constructors

Name | Description
LofiDeviceWetOutRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

LofiDeviceWetOutRunTimePreset Class


LofiDeviceWetOutRunTimePreset Constructor

[image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset Constructor
LofiDeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LofiDeviceWetOutRunTimePreset()
Visual C++
public:
LofiDeviceWetOutRunTimePreset()
JavaScript
NRenoiseTools.LofiDeviceWetOutRunTimePreset = function();

See Also

LofiDeviceWetOutRunTimePreset Class


LofiDeviceWetOutRunTimePreset Methods

[image] [image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset Methods
LofiDeviceWetOutRunTimePreset Class See Also Send Feedback

The LofiDeviceWetOutRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LofiDeviceWetOutRunTimePreset Class


LofiDeviceWetOutRunTimePreset Properties

[image] [image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset Properties
LofiDeviceWetOutRunTimePreset Class See Also Send Feedback

The LofiDeviceWetOutRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

LofiDeviceWetOutRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
LofiDeviceWetOutRunTimePreset..::.Value Property
LofiDeviceWetOutRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

LofiDeviceWetOutRunTimePreset Class


LofiDeviceWetOutVisualization Enumeration

[image]

.NET Framework Class Library
LofiDeviceWetOutVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration LofiDeviceWetOutVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum LofiDeviceWetOutVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class LofiDeviceWetOutVisualization
JavaScript
NRenoiseTools.LofiDeviceWetOutVisualization = function();
NRenoiseTools.LofiDeviceWetOutVisualization.createEnum('NRenoiseTools.LofiDeviceWetOutVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


LoopSelection Class

[image]

.NET Framework Class Library
LoopSelection Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class LoopSelection
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class LoopSelection
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class LoopSelection
JavaScript
NRenoiseTools.LoopSelection = function();

Type.createClass(
    'NRenoiseTools.LoopSelection');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.LoopSelection

See Also

LoopSelection Members


LoopSelection Members

[image] [image]

.NET Framework Class Library
LoopSelection Members
LoopSelection Class Constructors Methods Properties See Also Send Feedback

The LoopSelection type exposes the following members.

Constructors

Name | Description
LoopSelection |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CursorPos |
RangePos |

See Also

LoopSelection Class


LoopSelection Constructor

[image]

.NET Framework Class Library
LoopSelection Constructor
LoopSelection Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LoopSelection()
Visual C++
public:
LoopSelection()
JavaScript
NRenoiseTools.LoopSelection = function();

See Also

LoopSelection Class


LoopSelection Methods

[image] [image]

.NET Framework Class Library
LoopSelection Methods
LoopSelection Class See Also Send Feedback

The LoopSelection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoopSelection Class


LoopSelection Properties

[image] [image]

.NET Framework Class Library
LoopSelection Properties
LoopSelection Class See Also Send Feedback

The LoopSelection type exposes the following members.

Properties

Name | Description
CursorPos |
RangePos |

See Also

LoopSelection Class


CursorPos Property

[image]

.NET Framework Class Library
LoopSelection..::.CursorPos Property
LoopSelection Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CursorPos As Integer
C#
public int CursorPos { get; set; }
Visual C++
public:
property int CursorPos {
    int get ();
    void set (int value);
}
JavaScript
function get_cursorPos();
function set_cursorPos(value);

Remarks

See Also

LoopSelection Class


RangePos Property

[image]

.NET Framework Class Library
LoopSelection..::.RangePos Property
LoopSelection Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RangePos As Integer
C#
public int RangePos { get; set; }
Visual C++
public:
property int RangePos {
    int get ();
    void set (int value);
}
JavaScript
function get_rangePos();
function set_rangePos(value);

Remarks

See Also

LoopSelection Class


MaximizerDevice Class

[image]

.NET Framework Class Library
MaximizerDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDevice
JavaScript
NRenoiseTools.MaximizerDevice = function();

Type.createClass(
    'NRenoiseTools.MaximizerDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDevice

See Also

MaximizerDevice Members


MaximizerDevice Members

[image] [image]

.NET Framework Class Library
MaximizerDevice Members
MaximizerDevice Class Constructors Methods Properties See Also Send Feedback

The MaximizerDevice type exposes the following members.

Constructors

Name | Description
MaximizerDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ceiling |
InputGain |
IsActive |
IsSelected |
LongTermRelease |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
TransientRelease |
type |

See Also

MaximizerDevice Class


MaximizerDevice Constructor

[image]

.NET Framework Class Library
MaximizerDevice Constructor
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDevice()
Visual C++
public:
MaximizerDevice()
JavaScript
NRenoiseTools.MaximizerDevice = function();

See Also

MaximizerDevice Class


MaximizerDevice Methods

[image] [image]

.NET Framework Class Library
MaximizerDevice Methods
MaximizerDevice Class See Also Send Feedback

The MaximizerDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDevice Class


MaximizerDevice Properties

[image] [image]

.NET Framework Class Library
MaximizerDevice Properties
MaximizerDevice Class See Also Send Feedback

The MaximizerDevice type exposes the following members.

Properties

Name | Description
Ceiling |
InputGain |
IsActive |
IsSelected |
LongTermRelease |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
TransientRelease |
type |

See Also

MaximizerDevice Class


Ceiling Property

[image]

.NET Framework Class Library
MaximizerDevice..::.Ceiling Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ceiling As MaximizerDeviceCeiling
C#
public MaximizerDeviceCeiling Ceiling { get; set; }
Visual C++
public:
property MaximizerDeviceCeiling^ Ceiling {
    MaximizerDeviceCeiling^ get ();
    void set (MaximizerDeviceCeiling^ value);
}
JavaScript
function get_ceiling();
function set_ceiling(value);

Remarks

See Also

MaximizerDevice Class


InputGain Property

[image]

.NET Framework Class Library
MaximizerDevice..::.InputGain Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputGain As MaximizerDeviceInputGain
C#
public MaximizerDeviceInputGain InputGain { get; set; }
Visual C++
public:
property MaximizerDeviceInputGain^ InputGain {
    MaximizerDeviceInputGain^ get ();
    void set (MaximizerDeviceInputGain^ value);
}
JavaScript
function get_inputGain();
function set_inputGain(value);

Remarks

See Also

MaximizerDevice Class


IsActive Property

[image]

.NET Framework Class Library
MaximizerDevice..::.IsActive Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

MaximizerDevice Class


IsSelected Property

[image]

.NET Framework Class Library
MaximizerDevice..::.IsSelected Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

MaximizerDevice Class


LongTermRelease Property

[image]

.NET Framework Class Library
MaximizerDevice..::.LongTermRelease Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LongTermRelease As MaximizerDeviceLongTermRelease
C#
public MaximizerDeviceLongTermRelease LongTermRelease { get; set; }
Visual C++
public:
property MaximizerDeviceLongTermRelease^ LongTermRelease {
    MaximizerDeviceLongTermRelease^ get ();
    void set (MaximizerDeviceLongTermRelease^ value);
}
JavaScript
function get_longTermRelease();
function set_longTermRelease(value);

Remarks

See Also

MaximizerDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
MaximizerDevice..::.RunTimePresetA Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As MaximizerDeviceRunTimePreset
C#
public MaximizerDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property MaximizerDeviceRunTimePreset^ RunTimePresetA {
    MaximizerDeviceRunTimePreset^ get ();
    void set (MaximizerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

MaximizerDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
MaximizerDevice..::.RunTimePresetB Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As MaximizerDeviceRunTimePreset
C#
public MaximizerDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property MaximizerDeviceRunTimePreset^ RunTimePresetB {
    MaximizerDeviceRunTimePreset^ get ();
    void set (MaximizerDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

MaximizerDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
MaximizerDevice..::.SelectedPresetIsModified Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

MaximizerDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
MaximizerDevice..::.SelectedPresetName Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

MaximizerDevice Class


Threshold Property

[image]

.NET Framework Class Library
MaximizerDevice..::.Threshold Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As MaximizerDeviceThreshold
C#
public MaximizerDeviceThreshold Threshold { get; set; }
Visual C++
public:
property MaximizerDeviceThreshold^ Threshold {
    MaximizerDeviceThreshold^ get ();
    void set (MaximizerDeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

MaximizerDevice Class


TransientRelease Property

[image]

.NET Framework Class Library
MaximizerDevice..::.TransientRelease Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TransientRelease As MaximizerDeviceTransientRelease
C#
public MaximizerDeviceTransientRelease TransientRelease { get; set; }
Visual C++
public:
property MaximizerDeviceTransientRelease^ TransientRelease {
    MaximizerDeviceTransientRelease^ get ();
    void set (MaximizerDeviceTransientRelease^ value);
}
JavaScript
function get_transientRelease();
function set_transientRelease(value);

Remarks

See Also

MaximizerDevice Class


type Property

[image]

.NET Framework Class Library
MaximizerDevice..::.type Property
MaximizerDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MaximizerDevice Class


MaximizerDeviceCeiling Class

[image]

.NET Framework Class Library
MaximizerDeviceCeiling Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceCeiling
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceCeiling
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceCeiling
JavaScript
NRenoiseTools.MaximizerDeviceCeiling = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceCeiling');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceCeiling

See Also

MaximizerDeviceCeiling Members


MaximizerDeviceCeiling Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeiling Members
MaximizerDeviceCeiling Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceCeiling type exposes the following members.

Constructors

Name | Description
MaximizerDeviceCeiling |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceCeiling Class


MaximizerDeviceCeiling Constructor

[image]

.NET Framework Class Library
MaximizerDeviceCeiling Constructor
MaximizerDeviceCeiling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceCeiling()
Visual C++
public:
MaximizerDeviceCeiling()
JavaScript
NRenoiseTools.MaximizerDeviceCeiling = function();

See Also

MaximizerDeviceCeiling Class


MaximizerDeviceCeiling Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeiling Methods
MaximizerDeviceCeiling Class See Also Send Feedback

The MaximizerDeviceCeiling type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceCeiling Class


MaximizerDeviceCeiling Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeiling Properties
MaximizerDeviceCeiling Class See Also Send Feedback

The MaximizerDeviceCeiling type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceCeiling Class


MidiMappings Property

[image]

.NET Framework Class Library
MaximizerDeviceCeiling..::.MidiMappings Property
MaximizerDeviceCeiling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MaximizerDeviceCeiling Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceCeiling..::.Value Property
MaximizerDeviceCeiling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceCeiling Class


Visualization Property

[image]

.NET Framework Class Library
MaximizerDeviceCeiling..::.Visualization Property
MaximizerDeviceCeiling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MaximizerDeviceCeilingVisualization
C#
public MaximizerDeviceCeilingVisualization Visualization { get; set; }
Visual C++
public:
property MaximizerDeviceCeilingVisualization Visualization {
    MaximizerDeviceCeilingVisualization get ();
    void set (MaximizerDeviceCeilingVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MaximizerDeviceCeiling Class


MaximizerDeviceCeilingRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceCeilingRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceCeilingRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceCeilingRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceCeilingRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceCeilingRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceCeilingRunTimePreset

See Also

MaximizerDeviceCeilingRunTimePreset Members


MaximizerDeviceCeilingRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset Members
MaximizerDeviceCeilingRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceCeilingRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceCeilingRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MaximizerDeviceCeilingRunTimePreset Class


MaximizerDeviceCeilingRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset Constructor
MaximizerDeviceCeilingRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceCeilingRunTimePreset()
Visual C++
public:
MaximizerDeviceCeilingRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceCeilingRunTimePreset = function();

See Also

MaximizerDeviceCeilingRunTimePreset Class


MaximizerDeviceCeilingRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset Methods
MaximizerDeviceCeilingRunTimePreset Class See Also Send Feedback

The MaximizerDeviceCeilingRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceCeilingRunTimePreset Class


MaximizerDeviceCeilingRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset Properties
MaximizerDeviceCeilingRunTimePreset Class See Also Send Feedback

The MaximizerDeviceCeilingRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MaximizerDeviceCeilingRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceCeilingRunTimePreset..::.Value Property
MaximizerDeviceCeilingRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceCeilingRunTimePreset Class


MaximizerDeviceCeilingVisualization Enumeration

[image]

.NET Framework Class Library
MaximizerDeviceCeilingVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MaximizerDeviceCeilingVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MaximizerDeviceCeilingVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MaximizerDeviceCeilingVisualization
JavaScript
NRenoiseTools.MaximizerDeviceCeilingVisualization = function();
NRenoiseTools.MaximizerDeviceCeilingVisualization.createEnum('NRenoiseTools.MaximizerDeviceCeilingVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MaximizerDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceDeviceSlotRunTimePreset

See Also

MaximizerDeviceDeviceSlotRunTimePreset Members


MaximizerDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset Members
MaximizerDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ceiling |
InputGain |
LongTermRelease |
Threshold |
TransientRelease |
type |

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


MaximizerDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset Constructor
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceDeviceSlotRunTimePreset()
Visual C++
public:
MaximizerDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceDeviceSlotRunTimePreset = function();

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


MaximizerDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset Methods
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MaximizerDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


MaximizerDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset Properties
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MaximizerDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Ceiling |
InputGain |
LongTermRelease |
Threshold |
TransientRelease |
type |

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


Ceiling Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.Ceiling Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ceiling As MaximizerDeviceCeilingRunTimePreset
C#
public MaximizerDeviceCeilingRunTimePreset Ceiling { get; set; }
Visual C++
public:
property MaximizerDeviceCeilingRunTimePreset^ Ceiling {
    MaximizerDeviceCeilingRunTimePreset^ get ();
    void set (MaximizerDeviceCeilingRunTimePreset^ value);
}
JavaScript
function get_ceiling();
function set_ceiling(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


InputGain Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.InputGain Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputGain As MaximizerDeviceInputGainRunTimePreset
C#
public MaximizerDeviceInputGainRunTimePreset InputGain { get; set; }
Visual C++
public:
property MaximizerDeviceInputGainRunTimePreset^ InputGain {
    MaximizerDeviceInputGainRunTimePreset^ get ();
    void set (MaximizerDeviceInputGainRunTimePreset^ value);
}
JavaScript
function get_inputGain();
function set_inputGain(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


LongTermRelease Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.LongTermRelease Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LongTermRelease As MaximizerDeviceLongTermReleaseRunTimePreset
C#
public MaximizerDeviceLongTermReleaseRunTimePreset LongTermRelease { get; set; }
Visual C++
public:
property MaximizerDeviceLongTermReleaseRunTimePreset^ LongTermRelease {
    MaximizerDeviceLongTermReleaseRunTimePreset^ get ();
    void set (MaximizerDeviceLongTermReleaseRunTimePreset^ value);
}
JavaScript
function get_longTermRelease();
function set_longTermRelease(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.Threshold Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As MaximizerDeviceThresholdRunTimePreset
C#
public MaximizerDeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property MaximizerDeviceThresholdRunTimePreset^ Threshold {
    MaximizerDeviceThresholdRunTimePreset^ get ();
    void set (MaximizerDeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


TransientRelease Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.TransientRelease Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TransientRelease As MaximizerDeviceTransientReleaseRunTimePreset
C#
public MaximizerDeviceTransientReleaseRunTimePreset TransientRelease { get; set; }
Visual C++
public:
property MaximizerDeviceTransientReleaseRunTimePreset^ TransientRelease {
    MaximizerDeviceTransientReleaseRunTimePreset^ get ();
    void set (MaximizerDeviceTransientReleaseRunTimePreset^ value);
}
JavaScript
function get_transientRelease();
function set_transientRelease(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MaximizerDeviceDeviceSlotRunTimePreset..::.type Property
MaximizerDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MaximizerDeviceDeviceSlotRunTimePreset Class


MaximizerDeviceInputGain Class

[image]

.NET Framework Class Library
MaximizerDeviceInputGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceInputGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceInputGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceInputGain
JavaScript
NRenoiseTools.MaximizerDeviceInputGain = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceInputGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceInputGain

See Also

MaximizerDeviceInputGain Members


MaximizerDeviceInputGain Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGain Members
MaximizerDeviceInputGain Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceInputGain type exposes the following members.

Constructors

Name | Description
MaximizerDeviceInputGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceInputGain Class


MaximizerDeviceInputGain Constructor

[image]

.NET Framework Class Library
MaximizerDeviceInputGain Constructor
MaximizerDeviceInputGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceInputGain()
Visual C++
public:
MaximizerDeviceInputGain()
JavaScript
NRenoiseTools.MaximizerDeviceInputGain = function();

See Also

MaximizerDeviceInputGain Class


MaximizerDeviceInputGain Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGain Methods
MaximizerDeviceInputGain Class See Also Send Feedback

The MaximizerDeviceInputGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceInputGain Class


MaximizerDeviceInputGain Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGain Properties
MaximizerDeviceInputGain Class See Also Send Feedback

The MaximizerDeviceInputGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceInputGain Class


MidiMappings Property

[image]

.NET Framework Class Library
MaximizerDeviceInputGain..::.MidiMappings Property
MaximizerDeviceInputGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MaximizerDeviceInputGain Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceInputGain..::.Value Property
MaximizerDeviceInputGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceInputGain Class


Visualization Property

[image]

.NET Framework Class Library
MaximizerDeviceInputGain..::.Visualization Property
MaximizerDeviceInputGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MaximizerDeviceInputGainVisualization
C#
public MaximizerDeviceInputGainVisualization Visualization { get; set; }
Visual C++
public:
property MaximizerDeviceInputGainVisualization Visualization {
    MaximizerDeviceInputGainVisualization get ();
    void set (MaximizerDeviceInputGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MaximizerDeviceInputGain Class


MaximizerDeviceInputGainRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceInputGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceInputGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceInputGainRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceInputGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceInputGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceInputGainRunTimePreset

See Also

MaximizerDeviceInputGainRunTimePreset Members


MaximizerDeviceInputGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset Members
MaximizerDeviceInputGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceInputGainRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceInputGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MaximizerDeviceInputGainRunTimePreset Class


MaximizerDeviceInputGainRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset Constructor
MaximizerDeviceInputGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceInputGainRunTimePreset()
Visual C++
public:
MaximizerDeviceInputGainRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceInputGainRunTimePreset = function();

See Also

MaximizerDeviceInputGainRunTimePreset Class


MaximizerDeviceInputGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset Methods
MaximizerDeviceInputGainRunTimePreset Class See Also Send Feedback

The MaximizerDeviceInputGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceInputGainRunTimePreset Class


MaximizerDeviceInputGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset Properties
MaximizerDeviceInputGainRunTimePreset Class See Also Send Feedback

The MaximizerDeviceInputGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MaximizerDeviceInputGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceInputGainRunTimePreset..::.Value Property
MaximizerDeviceInputGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceInputGainRunTimePreset Class


MaximizerDeviceInputGainVisualization Enumeration

[image]

.NET Framework Class Library
MaximizerDeviceInputGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MaximizerDeviceInputGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MaximizerDeviceInputGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MaximizerDeviceInputGainVisualization
JavaScript
NRenoiseTools.MaximizerDeviceInputGainVisualization = function();
NRenoiseTools.MaximizerDeviceInputGainVisualization.createEnum('NRenoiseTools.MaximizerDeviceInputGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MaximizerDeviceLongTermRelease Class

[image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceLongTermRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceLongTermRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceLongTermRelease
JavaScript
NRenoiseTools.MaximizerDeviceLongTermRelease = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceLongTermRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceLongTermRelease

See Also

MaximizerDeviceLongTermRelease Members


MaximizerDeviceLongTermRelease Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease Members
MaximizerDeviceLongTermRelease Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceLongTermRelease type exposes the following members.

Constructors

Name | Description
MaximizerDeviceLongTermRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceLongTermRelease Class


MaximizerDeviceLongTermRelease Constructor

[image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease Constructor
MaximizerDeviceLongTermRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceLongTermRelease()
Visual C++
public:
MaximizerDeviceLongTermRelease()
JavaScript
NRenoiseTools.MaximizerDeviceLongTermRelease = function();

See Also

MaximizerDeviceLongTermRelease Class


MaximizerDeviceLongTermRelease Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease Methods
MaximizerDeviceLongTermRelease Class See Also Send Feedback

The MaximizerDeviceLongTermRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceLongTermRelease Class


MaximizerDeviceLongTermRelease Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease Properties
MaximizerDeviceLongTermRelease Class See Also Send Feedback

The MaximizerDeviceLongTermRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceLongTermRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease..::.MidiMappings Property
MaximizerDeviceLongTermRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MaximizerDeviceLongTermRelease Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease..::.Value Property
MaximizerDeviceLongTermRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceLongTermRelease Class


Visualization Property

[image]

.NET Framework Class Library
MaximizerDeviceLongTermRelease..::.Visualization Property
MaximizerDeviceLongTermRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MaximizerDeviceLongTermReleaseVisualization
C#
public MaximizerDeviceLongTermReleaseVisualization Visualization { get; set; }
Visual C++
public:
property MaximizerDeviceLongTermReleaseVisualization Visualization {
    MaximizerDeviceLongTermReleaseVisualization get ();
    void set (MaximizerDeviceLongTermReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MaximizerDeviceLongTermRelease Class


MaximizerDeviceLongTermReleaseRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceLongTermReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceLongTermReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceLongTermReleaseRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceLongTermReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceLongTermReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceLongTermReleaseRunTimePreset

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Members


MaximizerDeviceLongTermReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset Members
MaximizerDeviceLongTermReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceLongTermReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceLongTermReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Class


MaximizerDeviceLongTermReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset Constructor
MaximizerDeviceLongTermReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceLongTermReleaseRunTimePreset()
Visual C++
public:
MaximizerDeviceLongTermReleaseRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceLongTermReleaseRunTimePreset = function();

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Class


MaximizerDeviceLongTermReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset Methods
MaximizerDeviceLongTermReleaseRunTimePreset Class See Also Send Feedback

The MaximizerDeviceLongTermReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Class


MaximizerDeviceLongTermReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset Properties
MaximizerDeviceLongTermReleaseRunTimePreset Class See Also Send Feedback

The MaximizerDeviceLongTermReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseRunTimePreset..::.Value Property
MaximizerDeviceLongTermReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceLongTermReleaseRunTimePreset Class


MaximizerDeviceLongTermReleaseVisualization Enumeration

[image]

.NET Framework Class Library
MaximizerDeviceLongTermReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MaximizerDeviceLongTermReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MaximizerDeviceLongTermReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MaximizerDeviceLongTermReleaseVisualization
JavaScript
NRenoiseTools.MaximizerDeviceLongTermReleaseVisualization = function();
NRenoiseTools.MaximizerDeviceLongTermReleaseVisualization.createEnum('NRenoiseTools.MaximizerDeviceLongTermReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MaximizerDeviceRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceRunTimePreset

See Also

MaximizerDeviceRunTimePreset Members


MaximizerDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset Members
MaximizerDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

MaximizerDeviceRunTimePreset Class


MaximizerDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset Constructor
MaximizerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceRunTimePreset()
Visual C++
public:
MaximizerDeviceRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceRunTimePreset = function();

See Also

MaximizerDeviceRunTimePreset Class


MaximizerDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset Methods
MaximizerDeviceRunTimePreset Class See Also Send Feedback

The MaximizerDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceRunTimePreset Class


MaximizerDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset Properties
MaximizerDeviceRunTimePreset Class See Also Send Feedback

The MaximizerDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

MaximizerDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset..::.DeviceSlot Property
MaximizerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As MaximizerDeviceDeviceSlotRunTimePreset
C#
public MaximizerDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property MaximizerDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    MaximizerDeviceDeviceSlotRunTimePreset^ get ();
    void set (MaximizerDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

MaximizerDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MaximizerDeviceRunTimePreset..::.type Property
MaximizerDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MaximizerDeviceRunTimePreset Class


MaximizerDeviceThreshold Class

[image]

.NET Framework Class Library
MaximizerDeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceThreshold
JavaScript
NRenoiseTools.MaximizerDeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceThreshold

See Also

MaximizerDeviceThreshold Members


MaximizerDeviceThreshold Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceThreshold Members
MaximizerDeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceThreshold type exposes the following members.

Constructors

Name | Description
MaximizerDeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceThreshold Class


MaximizerDeviceThreshold Constructor

[image]

.NET Framework Class Library
MaximizerDeviceThreshold Constructor
MaximizerDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceThreshold()
Visual C++
public:
MaximizerDeviceThreshold()
JavaScript
NRenoiseTools.MaximizerDeviceThreshold = function();

See Also

MaximizerDeviceThreshold Class


MaximizerDeviceThreshold Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceThreshold Methods
MaximizerDeviceThreshold Class See Also Send Feedback

The MaximizerDeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceThreshold Class


MaximizerDeviceThreshold Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceThreshold Properties
MaximizerDeviceThreshold Class See Also Send Feedback

The MaximizerDeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
MaximizerDeviceThreshold..::.MidiMappings Property
MaximizerDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MaximizerDeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceThreshold..::.Value Property
MaximizerDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
MaximizerDeviceThreshold..::.Visualization Property
MaximizerDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MaximizerDeviceThresholdVisualization
C#
public MaximizerDeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property MaximizerDeviceThresholdVisualization Visualization {
    MaximizerDeviceThresholdVisualization get ();
    void set (MaximizerDeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MaximizerDeviceThreshold Class


MaximizerDeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceThresholdRunTimePreset

See Also

MaximizerDeviceThresholdRunTimePreset Members


MaximizerDeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset Members
MaximizerDeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MaximizerDeviceThresholdRunTimePreset Class


MaximizerDeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset Constructor
MaximizerDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceThresholdRunTimePreset()
Visual C++
public:
MaximizerDeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceThresholdRunTimePreset = function();

See Also

MaximizerDeviceThresholdRunTimePreset Class


MaximizerDeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset Methods
MaximizerDeviceThresholdRunTimePreset Class See Also Send Feedback

The MaximizerDeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceThresholdRunTimePreset Class


MaximizerDeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset Properties
MaximizerDeviceThresholdRunTimePreset Class See Also Send Feedback

The MaximizerDeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MaximizerDeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceThresholdRunTimePreset..::.Value Property
MaximizerDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceThresholdRunTimePreset Class


MaximizerDeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
MaximizerDeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MaximizerDeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MaximizerDeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MaximizerDeviceThresholdVisualization
JavaScript
NRenoiseTools.MaximizerDeviceThresholdVisualization = function();
NRenoiseTools.MaximizerDeviceThresholdVisualization.createEnum('NRenoiseTools.MaximizerDeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MaximizerDeviceTransientRelease Class

[image]

.NET Framework Class Library
MaximizerDeviceTransientRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceTransientRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceTransientRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceTransientRelease
JavaScript
NRenoiseTools.MaximizerDeviceTransientRelease = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceTransientRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceTransientRelease

See Also

MaximizerDeviceTransientRelease Members


MaximizerDeviceTransientRelease Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientRelease Members
MaximizerDeviceTransientRelease Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceTransientRelease type exposes the following members.

Constructors

Name | Description
MaximizerDeviceTransientRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceTransientRelease Class


MaximizerDeviceTransientRelease Constructor

[image]

.NET Framework Class Library
MaximizerDeviceTransientRelease Constructor
MaximizerDeviceTransientRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceTransientRelease()
Visual C++
public:
MaximizerDeviceTransientRelease()
JavaScript
NRenoiseTools.MaximizerDeviceTransientRelease = function();

See Also

MaximizerDeviceTransientRelease Class


MaximizerDeviceTransientRelease Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientRelease Methods
MaximizerDeviceTransientRelease Class See Also Send Feedback

The MaximizerDeviceTransientRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceTransientRelease Class


MaximizerDeviceTransientRelease Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientRelease Properties
MaximizerDeviceTransientRelease Class See Also Send Feedback

The MaximizerDeviceTransientRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MaximizerDeviceTransientRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
MaximizerDeviceTransientRelease..::.MidiMappings Property
MaximizerDeviceTransientRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MaximizerDeviceTransientRelease Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceTransientRelease..::.Value Property
MaximizerDeviceTransientRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceTransientRelease Class


Visualization Property

[image]

.NET Framework Class Library
MaximizerDeviceTransientRelease..::.Visualization Property
MaximizerDeviceTransientRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MaximizerDeviceTransientReleaseVisualization
C#
public MaximizerDeviceTransientReleaseVisualization Visualization { get; set; }
Visual C++
public:
property MaximizerDeviceTransientReleaseVisualization Visualization {
    MaximizerDeviceTransientReleaseVisualization get ();
    void set (MaximizerDeviceTransientReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MaximizerDeviceTransientRelease Class


MaximizerDeviceTransientReleaseRunTimePreset Class

[image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MaximizerDeviceTransientReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MaximizerDeviceTransientReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MaximizerDeviceTransientReleaseRunTimePreset
JavaScript
NRenoiseTools.MaximizerDeviceTransientReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MaximizerDeviceTransientReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MaximizerDeviceTransientReleaseRunTimePreset

See Also

MaximizerDeviceTransientReleaseRunTimePreset Members


MaximizerDeviceTransientReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset Members
MaximizerDeviceTransientReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MaximizerDeviceTransientReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
MaximizerDeviceTransientReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MaximizerDeviceTransientReleaseRunTimePreset Class


MaximizerDeviceTransientReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset Constructor
MaximizerDeviceTransientReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MaximizerDeviceTransientReleaseRunTimePreset()
Visual C++
public:
MaximizerDeviceTransientReleaseRunTimePreset()
JavaScript
NRenoiseTools.MaximizerDeviceTransientReleaseRunTimePreset = function();

See Also

MaximizerDeviceTransientReleaseRunTimePreset Class


MaximizerDeviceTransientReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset Methods
MaximizerDeviceTransientReleaseRunTimePreset Class See Also Send Feedback

The MaximizerDeviceTransientReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaximizerDeviceTransientReleaseRunTimePreset Class


MaximizerDeviceTransientReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset Properties
MaximizerDeviceTransientReleaseRunTimePreset Class See Also Send Feedback

The MaximizerDeviceTransientReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MaximizerDeviceTransientReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseRunTimePreset..::.Value Property
MaximizerDeviceTransientReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MaximizerDeviceTransientReleaseRunTimePreset Class


MaximizerDeviceTransientReleaseVisualization Enumeration

[image]

.NET Framework Class Library
MaximizerDeviceTransientReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MaximizerDeviceTransientReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MaximizerDeviceTransientReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MaximizerDeviceTransientReleaseVisualization
JavaScript
NRenoiseTools.MaximizerDeviceTransientReleaseVisualization = function();
NRenoiseTools.MaximizerDeviceTransientReleaseVisualization.createEnum('NRenoiseTools.MaximizerDeviceTransientReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MidiCCDevice Class

[image]

.NET Framework Class Library
MidiCCDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiCCDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiCCDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiCCDevice
JavaScript
NRenoiseTools.MidiCCDevice = function();

Type.createClass(
    'NRenoiseTools.MidiCCDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiCCDevice

See Also

MidiCCDevice Members


MidiCCDevice Members

[image] [image]

.NET Framework Class Library
MidiCCDevice Members
MidiCCDevice Class Constructors Methods Properties See Also Send Feedback

The MidiCCDevice type exposes the following members.

Constructors

Name | Description
MidiCCDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ControllerName0 |
ControllerName1 |
ControllerName10 |
ControllerName11 |
ControllerName12 |
ControllerName13 |
ControllerName2 |
ControllerName3 |
ControllerName4 |
ControllerName5 |
ControllerName6 |
ControllerName7 |
ControllerName8 |
ControllerName9 |
ControllerNumber0 |
ControllerNumber1 |
ControllerNumber10 |
ControllerNumber11 |
ControllerNumber12 |
ControllerNumber13 |
ControllerNumber2 |
ControllerNumber3 |
ControllerNumber4 |
ControllerNumber5 |
ControllerNumber6 |
ControllerNumber7 |
ControllerNumber8 |
ControllerNumber9 |
ControllerValue0 |
ControllerValue1 |
ControllerValue10 |
ControllerValue11 |
ControllerValue12 |
ControllerValue13 |
ControllerValue2 |
ControllerValue3 |
ControllerValue4 |
ControllerValue5 |
ControllerValue6 |
ControllerValue7 |
ControllerValue8 |
ControllerValue9 |
IsActive |
IsSelected |
LinkedInstrument |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
VisiblePages |

See Also

MidiCCDevice Class


MidiCCDevice Constructor

[image]

.NET Framework Class Library
MidiCCDevice Constructor
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiCCDevice()
Visual C++
public:
MidiCCDevice()
JavaScript
NRenoiseTools.MidiCCDevice = function();

See Also

MidiCCDevice Class


MidiCCDevice Methods

[image] [image]

.NET Framework Class Library
MidiCCDevice Methods
MidiCCDevice Class See Also Send Feedback

The MidiCCDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiCCDevice Class


MidiCCDevice Properties

[image] [image]

.NET Framework Class Library
MidiCCDevice Properties
MidiCCDevice Class See Also Send Feedback

The MidiCCDevice type exposes the following members.

Properties

Name | Description
ControllerName0 |
ControllerName1 |
ControllerName10 |
ControllerName11 |
ControllerName12 |
ControllerName13 |
ControllerName2 |
ControllerName3 |
ControllerName4 |
ControllerName5 |
ControllerName6 |
ControllerName7 |
ControllerName8 |
ControllerName9 |
ControllerNumber0 |
ControllerNumber1 |
ControllerNumber10 |
ControllerNumber11 |
ControllerNumber12 |
ControllerNumber13 |
ControllerNumber2 |
ControllerNumber3 |
ControllerNumber4 |
ControllerNumber5 |
ControllerNumber6 |
ControllerNumber7 |
ControllerNumber8 |
ControllerNumber9 |
ControllerValue0 |
ControllerValue1 |
ControllerValue10 |
ControllerValue11 |
ControllerValue12 |
ControllerValue13 |
ControllerValue2 |
ControllerValue3 |
ControllerValue4 |
ControllerValue5 |
ControllerValue6 |
ControllerValue7 |
ControllerValue8 |
ControllerValue9 |
IsActive |
IsSelected |
LinkedInstrument |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
VisiblePages |

See Also

MidiCCDevice Class


ControllerName0 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName0 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName0 As String
C#
public string ControllerName0 { get; set; }
Visual C++
public:
property String^ ControllerName0 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName0();
function set_controllerName0(value);

Remarks

See Also

MidiCCDevice Class


ControllerName1 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName1 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName1 As String
C#
public string ControllerName1 { get; set; }
Visual C++
public:
property String^ ControllerName1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName1();
function set_controllerName1(value);

Remarks

See Also

MidiCCDevice Class


ControllerName10 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName10 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName10 As String
C#
public string ControllerName10 { get; set; }
Visual C++
public:
property String^ ControllerName10 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName10();
function set_controllerName10(value);

Remarks

See Also

MidiCCDevice Class


ControllerName11 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName11 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName11 As String
C#
public string ControllerName11 { get; set; }
Visual C++
public:
property String^ ControllerName11 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName11();
function set_controllerName11(value);

Remarks

See Also

MidiCCDevice Class


ControllerName12 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName12 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName12 As String
C#
public string ControllerName12 { get; set; }
Visual C++
public:
property String^ ControllerName12 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName12();
function set_controllerName12(value);

Remarks

See Also

MidiCCDevice Class


ControllerName13 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName13 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName13 As String
C#
public string ControllerName13 { get; set; }
Visual C++
public:
property String^ ControllerName13 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName13();
function set_controllerName13(value);

Remarks

See Also

MidiCCDevice Class


ControllerName2 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName2 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName2 As String
C#
public string ControllerName2 { get; set; }
Visual C++
public:
property String^ ControllerName2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName2();
function set_controllerName2(value);

Remarks

See Also

MidiCCDevice Class


ControllerName3 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName3 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName3 As String
C#
public string ControllerName3 { get; set; }
Visual C++
public:
property String^ ControllerName3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName3();
function set_controllerName3(value);

Remarks

See Also

MidiCCDevice Class


ControllerName4 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName4 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName4 As String
C#
public string ControllerName4 { get; set; }
Visual C++
public:
property String^ ControllerName4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName4();
function set_controllerName4(value);

Remarks

See Also

MidiCCDevice Class


ControllerName5 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName5 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName5 As String
C#
public string ControllerName5 { get; set; }
Visual C++
public:
property String^ ControllerName5 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName5();
function set_controllerName5(value);

Remarks

See Also

MidiCCDevice Class


ControllerName6 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName6 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName6 As String
C#
public string ControllerName6 { get; set; }
Visual C++
public:
property String^ ControllerName6 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName6();
function set_controllerName6(value);

Remarks

See Also

MidiCCDevice Class


ControllerName7 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName7 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName7 As String
C#
public string ControllerName7 { get; set; }
Visual C++
public:
property String^ ControllerName7 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName7();
function set_controllerName7(value);

Remarks

See Also

MidiCCDevice Class


ControllerName8 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName8 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName8 As String
C#
public string ControllerName8 { get; set; }
Visual C++
public:
property String^ ControllerName8 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName8();
function set_controllerName8(value);

Remarks

See Also

MidiCCDevice Class


ControllerName9 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerName9 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName9 As String
C#
public string ControllerName9 { get; set; }
Visual C++
public:
property String^ ControllerName9 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName9();
function set_controllerName9(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber0 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber0 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber0 As Integer
C#
public int ControllerNumber0 { get; set; }
Visual C++
public:
property int ControllerNumber0 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber0();
function set_controllerNumber0(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber1 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber1 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber1 As Integer
C#
public int ControllerNumber1 { get; set; }
Visual C++
public:
property int ControllerNumber1 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber1();
function set_controllerNumber1(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber10 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber10 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber10 As Integer
C#
public int ControllerNumber10 { get; set; }
Visual C++
public:
property int ControllerNumber10 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber10();
function set_controllerNumber10(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber11 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber11 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber11 As Integer
C#
public int ControllerNumber11 { get; set; }
Visual C++
public:
property int ControllerNumber11 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber11();
function set_controllerNumber11(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber12 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber12 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber12 As Integer
C#
public int ControllerNumber12 { get; set; }
Visual C++
public:
property int ControllerNumber12 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber12();
function set_controllerNumber12(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber13 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber13 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber13 As Integer
C#
public int ControllerNumber13 { get; set; }
Visual C++
public:
property int ControllerNumber13 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber13();
function set_controllerNumber13(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber2 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber2 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber2 As Integer
C#
public int ControllerNumber2 { get; set; }
Visual C++
public:
property int ControllerNumber2 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber2();
function set_controllerNumber2(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber3 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber3 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber3 As Integer
C#
public int ControllerNumber3 { get; set; }
Visual C++
public:
property int ControllerNumber3 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber3();
function set_controllerNumber3(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber4 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber4 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber4 As Integer
C#
public int ControllerNumber4 { get; set; }
Visual C++
public:
property int ControllerNumber4 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber4();
function set_controllerNumber4(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber5 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber5 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber5 As Integer
C#
public int ControllerNumber5 { get; set; }
Visual C++
public:
property int ControllerNumber5 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber5();
function set_controllerNumber5(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber6 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber6 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber6 As Integer
C#
public int ControllerNumber6 { get; set; }
Visual C++
public:
property int ControllerNumber6 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber6();
function set_controllerNumber6(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber7 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber7 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber7 As Integer
C#
public int ControllerNumber7 { get; set; }
Visual C++
public:
property int ControllerNumber7 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber7();
function set_controllerNumber7(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber8 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber8 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber8 As Integer
C#
public int ControllerNumber8 { get; set; }
Visual C++
public:
property int ControllerNumber8 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber8();
function set_controllerNumber8(value);

Remarks

See Also

MidiCCDevice Class


ControllerNumber9 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerNumber9 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber9 As Integer
C#
public int ControllerNumber9 { get; set; }
Visual C++
public:
property int ControllerNumber9 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber9();
function set_controllerNumber9(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue0 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue0 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue0 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue0 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue0 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue0();
function set_controllerValue0(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue1 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue1 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue1 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue1 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue1 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue1();
function set_controllerValue1(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue10 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue10 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue10 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue10 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue10 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue10();
function set_controllerValue10(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue11 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue11 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue11 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue11 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue11 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue11();
function set_controllerValue11(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue12 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue12 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue12 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue12 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue12 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue12();
function set_controllerValue12(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue13 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue13 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue13 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue13 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue13 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue13();
function set_controllerValue13(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue2 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue2 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue2 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue2 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue2 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue2();
function set_controllerValue2(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue3 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue3 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue3 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue3 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue3 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue3();
function set_controllerValue3(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue4 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue4 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue4 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue4 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue4 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue4();
function set_controllerValue4(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue5 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue5 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue5 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue5 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue5 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue5();
function set_controllerValue5(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue6 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue6 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue6 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue6 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue6 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue6();
function set_controllerValue6(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue7 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue7 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue7 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue7 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue7 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue7();
function set_controllerValue7(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue8 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue8 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue8 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue8 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue8 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue8();
function set_controllerValue8(value);

Remarks

See Also

MidiCCDevice Class


ControllerValue9 Property

[image]

.NET Framework Class Library
MidiCCDevice..::.ControllerValue9 Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue9 As MidiCCDeviceControllerValue
C#
public MidiCCDeviceControllerValue ControllerValue9 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValue^ ControllerValue9 {
    MidiCCDeviceControllerValue^ get ();
    void set (MidiCCDeviceControllerValue^ value);
}
JavaScript
function get_controllerValue9();
function set_controllerValue9(value);

Remarks

See Also

MidiCCDevice Class


IsActive Property

[image]

.NET Framework Class Library
MidiCCDevice..::.IsActive Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

MidiCCDevice Class


IsSelected Property

[image]

.NET Framework Class Library
MidiCCDevice..::.IsSelected Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

MidiCCDevice Class


LinkedInstrument Property

[image]

.NET Framework Class Library
MidiCCDevice..::.LinkedInstrument Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LinkedInstrument As Integer
C#
public int LinkedInstrument { get; set; }
Visual C++
public:
property int LinkedInstrument {
    int get ();
    void set (int value);
}
JavaScript
function get_linkedInstrument();
function set_linkedInstrument(value);

Remarks

See Also

MidiCCDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
MidiCCDevice..::.RunTimePresetA Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As MidiCCDeviceRunTimePreset
C#
public MidiCCDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property MidiCCDeviceRunTimePreset^ RunTimePresetA {
    MidiCCDeviceRunTimePreset^ get ();
    void set (MidiCCDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

MidiCCDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
MidiCCDevice..::.RunTimePresetB Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As MidiCCDeviceRunTimePreset
C#
public MidiCCDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property MidiCCDeviceRunTimePreset^ RunTimePresetB {
    MidiCCDeviceRunTimePreset^ get ();
    void set (MidiCCDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

MidiCCDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
MidiCCDevice..::.SelectedPresetIsModified Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

MidiCCDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
MidiCCDevice..::.SelectedPresetName Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

MidiCCDevice Class


type Property

[image]

.NET Framework Class Library
MidiCCDevice..::.type Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MidiCCDevice Class


VisiblePages Property

[image]

.NET Framework Class Library
MidiCCDevice..::.VisiblePages Property
MidiCCDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VisiblePages As Integer
C#
public int VisiblePages { get; set; }
Visual C++
public:
property int VisiblePages {
    int get ();
    void set (int value);
}
JavaScript
function get_visiblePages();
function set_visiblePages(value);

Remarks

See Also

MidiCCDevice Class


MidiCCDeviceControllerValue Class

[image]

.NET Framework Class Library
MidiCCDeviceControllerValue Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiCCDeviceControllerValue
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiCCDeviceControllerValue
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiCCDeviceControllerValue
JavaScript
NRenoiseTools.MidiCCDeviceControllerValue = function();

Type.createClass(
    'NRenoiseTools.MidiCCDeviceControllerValue');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiCCDeviceControllerValue

See Also

MidiCCDeviceControllerValue Members


MidiCCDeviceControllerValue Members

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValue Members
MidiCCDeviceControllerValue Class Constructors Methods Properties See Also Send Feedback

The MidiCCDeviceControllerValue type exposes the following members.

Constructors

Name | Description
MidiCCDeviceControllerValue |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MidiCCDeviceControllerValue Class


MidiCCDeviceControllerValue Constructor

[image]

.NET Framework Class Library
MidiCCDeviceControllerValue Constructor
MidiCCDeviceControllerValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiCCDeviceControllerValue()
Visual C++
public:
MidiCCDeviceControllerValue()
JavaScript
NRenoiseTools.MidiCCDeviceControllerValue = function();

See Also

MidiCCDeviceControllerValue Class


MidiCCDeviceControllerValue Methods

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValue Methods
MidiCCDeviceControllerValue Class See Also Send Feedback

The MidiCCDeviceControllerValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiCCDeviceControllerValue Class


MidiCCDeviceControllerValue Properties

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValue Properties
MidiCCDeviceControllerValue Class See Also Send Feedback

The MidiCCDeviceControllerValue type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MidiCCDeviceControllerValue Class


MidiMappings Property

[image]

.NET Framework Class Library
MidiCCDeviceControllerValue..::.MidiMappings Property
MidiCCDeviceControllerValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MidiCCDeviceControllerValue Class


Value Property

[image]

.NET Framework Class Library
MidiCCDeviceControllerValue..::.Value Property
MidiCCDeviceControllerValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MidiCCDeviceControllerValue Class


Visualization Property

[image]

.NET Framework Class Library
MidiCCDeviceControllerValue..::.Visualization Property
MidiCCDeviceControllerValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MidiCCDeviceControllerValueVisualization
C#
public MidiCCDeviceControllerValueVisualization Visualization { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueVisualization Visualization {
    MidiCCDeviceControllerValueVisualization get ();
    void set (MidiCCDeviceControllerValueVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MidiCCDeviceControllerValue Class


MidiCCDeviceControllerValueRunTimePreset Class

[image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiCCDeviceControllerValueRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiCCDeviceControllerValueRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiCCDeviceControllerValueRunTimePreset
JavaScript
NRenoiseTools.MidiCCDeviceControllerValueRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MidiCCDeviceControllerValueRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiCCDeviceControllerValueRunTimePreset

See Also

MidiCCDeviceControllerValueRunTimePreset Members


MidiCCDeviceControllerValueRunTimePreset Members

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset Members
MidiCCDeviceControllerValueRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MidiCCDeviceControllerValueRunTimePreset type exposes the following members.

Constructors

Name | Description
MidiCCDeviceControllerValueRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MidiCCDeviceControllerValueRunTimePreset Class


MidiCCDeviceControllerValueRunTimePreset Constructor

[image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset Constructor
MidiCCDeviceControllerValueRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiCCDeviceControllerValueRunTimePreset()
Visual C++
public:
MidiCCDeviceControllerValueRunTimePreset()
JavaScript
NRenoiseTools.MidiCCDeviceControllerValueRunTimePreset = function();

See Also

MidiCCDeviceControllerValueRunTimePreset Class


MidiCCDeviceControllerValueRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset Methods
MidiCCDeviceControllerValueRunTimePreset Class See Also Send Feedback

The MidiCCDeviceControllerValueRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiCCDeviceControllerValueRunTimePreset Class


MidiCCDeviceControllerValueRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset Properties
MidiCCDeviceControllerValueRunTimePreset Class See Also Send Feedback

The MidiCCDeviceControllerValueRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MidiCCDeviceControllerValueRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MidiCCDeviceControllerValueRunTimePreset..::.Value Property
MidiCCDeviceControllerValueRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MidiCCDeviceControllerValueRunTimePreset Class


MidiCCDeviceControllerValueVisualization Enumeration

[image]

.NET Framework Class Library
MidiCCDeviceControllerValueVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MidiCCDeviceControllerValueVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MidiCCDeviceControllerValueVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MidiCCDeviceControllerValueVisualization
JavaScript
NRenoiseTools.MidiCCDeviceControllerValueVisualization = function();
NRenoiseTools.MidiCCDeviceControllerValueVisualization.createEnum('NRenoiseTools.MidiCCDeviceControllerValueVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MidiCCDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiCCDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiCCDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiCCDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.MidiCCDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MidiCCDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiCCDeviceDeviceSlotRunTimePreset

See Also

MidiCCDeviceDeviceSlotRunTimePreset Members


MidiCCDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset Members
MidiCCDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MidiCCDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
MidiCCDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ControllerName0 |
ControllerName1 |
ControllerName10 |
ControllerName11 |
ControllerName12 |
ControllerName13 |
ControllerName2 |
ControllerName3 |
ControllerName4 |
ControllerName5 |
ControllerName6 |
ControllerName7 |
ControllerName8 |
ControllerName9 |
ControllerNumber0 |
ControllerNumber1 |
ControllerNumber10 |
ControllerNumber11 |
ControllerNumber12 |
ControllerNumber13 |
ControllerNumber2 |
ControllerNumber3 |
ControllerNumber4 |
ControllerNumber5 |
ControllerNumber6 |
ControllerNumber7 |
ControllerNumber8 |
ControllerNumber9 |
ControllerValue0 |
ControllerValue1 |
ControllerValue10 |
ControllerValue11 |
ControllerValue12 |
ControllerValue13 |
ControllerValue2 |
ControllerValue3 |
ControllerValue4 |
ControllerValue5 |
ControllerValue6 |
ControllerValue7 |
ControllerValue8 |
ControllerValue9 |
type |
VisiblePages |

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


MidiCCDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset Constructor
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiCCDeviceDeviceSlotRunTimePreset()
Visual C++
public:
MidiCCDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.MidiCCDeviceDeviceSlotRunTimePreset = function();

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


MidiCCDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset Methods
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MidiCCDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


MidiCCDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset Properties
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MidiCCDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
ControllerName0 |
ControllerName1 |
ControllerName10 |
ControllerName11 |
ControllerName12 |
ControllerName13 |
ControllerName2 |
ControllerName3 |
ControllerName4 |
ControllerName5 |
ControllerName6 |
ControllerName7 |
ControllerName8 |
ControllerName9 |
ControllerNumber0 |
ControllerNumber1 |
ControllerNumber10 |
ControllerNumber11 |
ControllerNumber12 |
ControllerNumber13 |
ControllerNumber2 |
ControllerNumber3 |
ControllerNumber4 |
ControllerNumber5 |
ControllerNumber6 |
ControllerNumber7 |
ControllerNumber8 |
ControllerNumber9 |
ControllerValue0 |
ControllerValue1 |
ControllerValue10 |
ControllerValue11 |
ControllerValue12 |
ControllerValue13 |
ControllerValue2 |
ControllerValue3 |
ControllerValue4 |
ControllerValue5 |
ControllerValue6 |
ControllerValue7 |
ControllerValue8 |
ControllerValue9 |
type |
VisiblePages |

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName0 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName0 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName0 As String
C#
public string ControllerName0 { get; set; }
Visual C++
public:
property String^ ControllerName0 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName0();
function set_controllerName0(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName1 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName1 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName1 As String
C#
public string ControllerName1 { get; set; }
Visual C++
public:
property String^ ControllerName1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName1();
function set_controllerName1(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName10 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName10 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName10 As String
C#
public string ControllerName10 { get; set; }
Visual C++
public:
property String^ ControllerName10 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName10();
function set_controllerName10(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName11 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName11 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName11 As String
C#
public string ControllerName11 { get; set; }
Visual C++
public:
property String^ ControllerName11 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName11();
function set_controllerName11(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName12 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName12 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName12 As String
C#
public string ControllerName12 { get; set; }
Visual C++
public:
property String^ ControllerName12 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName12();
function set_controllerName12(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName13 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName13 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName13 As String
C#
public string ControllerName13 { get; set; }
Visual C++
public:
property String^ ControllerName13 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName13();
function set_controllerName13(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName2 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName2 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName2 As String
C#
public string ControllerName2 { get; set; }
Visual C++
public:
property String^ ControllerName2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName2();
function set_controllerName2(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName3 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName3 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName3 As String
C#
public string ControllerName3 { get; set; }
Visual C++
public:
property String^ ControllerName3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName3();
function set_controllerName3(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName4 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName4 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName4 As String
C#
public string ControllerName4 { get; set; }
Visual C++
public:
property String^ ControllerName4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName4();
function set_controllerName4(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName5 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName5 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName5 As String
C#
public string ControllerName5 { get; set; }
Visual C++
public:
property String^ ControllerName5 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName5();
function set_controllerName5(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName6 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName6 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName6 As String
C#
public string ControllerName6 { get; set; }
Visual C++
public:
property String^ ControllerName6 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName6();
function set_controllerName6(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName7 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName7 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName7 As String
C#
public string ControllerName7 { get; set; }
Visual C++
public:
property String^ ControllerName7 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName7();
function set_controllerName7(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName8 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName8 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName8 As String
C#
public string ControllerName8 { get; set; }
Visual C++
public:
property String^ ControllerName8 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName8();
function set_controllerName8(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerName9 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerName9 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerName9 As String
C#
public string ControllerName9 { get; set; }
Visual C++
public:
property String^ ControllerName9 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_controllerName9();
function set_controllerName9(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber0 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber0 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber0 As Integer
C#
public int ControllerNumber0 { get; set; }
Visual C++
public:
property int ControllerNumber0 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber0();
function set_controllerNumber0(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber1 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber1 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber1 As Integer
C#
public int ControllerNumber1 { get; set; }
Visual C++
public:
property int ControllerNumber1 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber1();
function set_controllerNumber1(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber10 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber10 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber10 As Integer
C#
public int ControllerNumber10 { get; set; }
Visual C++
public:
property int ControllerNumber10 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber10();
function set_controllerNumber10(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber11 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber11 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber11 As Integer
C#
public int ControllerNumber11 { get; set; }
Visual C++
public:
property int ControllerNumber11 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber11();
function set_controllerNumber11(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber12 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber12 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber12 As Integer
C#
public int ControllerNumber12 { get; set; }
Visual C++
public:
property int ControllerNumber12 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber12();
function set_controllerNumber12(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber13 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber13 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber13 As Integer
C#
public int ControllerNumber13 { get; set; }
Visual C++
public:
property int ControllerNumber13 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber13();
function set_controllerNumber13(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber2 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber2 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber2 As Integer
C#
public int ControllerNumber2 { get; set; }
Visual C++
public:
property int ControllerNumber2 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber2();
function set_controllerNumber2(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber3 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber3 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber3 As Integer
C#
public int ControllerNumber3 { get; set; }
Visual C++
public:
property int ControllerNumber3 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber3();
function set_controllerNumber3(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber4 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber4 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber4 As Integer
C#
public int ControllerNumber4 { get; set; }
Visual C++
public:
property int ControllerNumber4 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber4();
function set_controllerNumber4(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber5 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber5 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber5 As Integer
C#
public int ControllerNumber5 { get; set; }
Visual C++
public:
property int ControllerNumber5 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber5();
function set_controllerNumber5(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber6 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber6 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber6 As Integer
C#
public int ControllerNumber6 { get; set; }
Visual C++
public:
property int ControllerNumber6 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber6();
function set_controllerNumber6(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber7 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber7 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber7 As Integer
C#
public int ControllerNumber7 { get; set; }
Visual C++
public:
property int ControllerNumber7 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber7();
function set_controllerNumber7(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber8 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber8 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber8 As Integer
C#
public int ControllerNumber8 { get; set; }
Visual C++
public:
property int ControllerNumber8 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber8();
function set_controllerNumber8(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerNumber9 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerNumber9 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerNumber9 As Integer
C#
public int ControllerNumber9 { get; set; }
Visual C++
public:
property int ControllerNumber9 {
    int get ();
    void set (int value);
}
JavaScript
function get_controllerNumber9();
function set_controllerNumber9(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue0 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue0 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue0 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue0 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue0 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue0();
function set_controllerValue0(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue1 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue1 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue1 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue1 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue1 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue1();
function set_controllerValue1(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue10 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue10 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue10 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue10 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue10 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue10();
function set_controllerValue10(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue11 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue11 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue11 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue11 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue11 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue11();
function set_controllerValue11(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue12 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue12 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue12 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue12 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue12 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue12();
function set_controllerValue12(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue13 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue13 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue13 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue13 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue13 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue13();
function set_controllerValue13(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue2 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue2 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue2 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue2 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue2 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue2();
function set_controllerValue2(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue3 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue3 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue3 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue3 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue3 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue3();
function set_controllerValue3(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue4 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue4 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue4 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue4 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue4 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue4();
function set_controllerValue4(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue5 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue5 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue5 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue5 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue5 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue5();
function set_controllerValue5(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue6 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue6 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue6 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue6 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue6 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue6();
function set_controllerValue6(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue7 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue7 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue7 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue7 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue7 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue7();
function set_controllerValue7(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue8 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue8 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue8 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue8 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue8 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue8();
function set_controllerValue8(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


ControllerValue9 Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.ControllerValue9 Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ControllerValue9 As MidiCCDeviceControllerValueRunTimePreset
C#
public MidiCCDeviceControllerValueRunTimePreset ControllerValue9 { get; set; }
Visual C++
public:
property MidiCCDeviceControllerValueRunTimePreset^ ControllerValue9 {
    MidiCCDeviceControllerValueRunTimePreset^ get ();
    void set (MidiCCDeviceControllerValueRunTimePreset^ value);
}
JavaScript
function get_controllerValue9();
function set_controllerValue9(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.type Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


VisiblePages Property

[image]

.NET Framework Class Library
MidiCCDeviceDeviceSlotRunTimePreset..::.VisiblePages Property
MidiCCDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VisiblePages As Integer
C#
public int VisiblePages { get; set; }
Visual C++
public:
property int VisiblePages {
    int get ();
    void set (int value);
}
JavaScript
function get_visiblePages();
function set_visiblePages(value);

Remarks

See Also

MidiCCDeviceDeviceSlotRunTimePreset Class


MidiCCDeviceRunTimePreset Class

[image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiCCDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiCCDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiCCDeviceRunTimePreset
JavaScript
NRenoiseTools.MidiCCDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MidiCCDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiCCDeviceRunTimePreset

See Also

MidiCCDeviceRunTimePreset Members


MidiCCDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset Members
MidiCCDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MidiCCDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
MidiCCDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

MidiCCDeviceRunTimePreset Class


MidiCCDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset Constructor
MidiCCDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiCCDeviceRunTimePreset()
Visual C++
public:
MidiCCDeviceRunTimePreset()
JavaScript
NRenoiseTools.MidiCCDeviceRunTimePreset = function();

See Also

MidiCCDeviceRunTimePreset Class


MidiCCDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset Methods
MidiCCDeviceRunTimePreset Class See Also Send Feedback

The MidiCCDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiCCDeviceRunTimePreset Class


MidiCCDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset Properties
MidiCCDeviceRunTimePreset Class See Also Send Feedback

The MidiCCDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

MidiCCDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset..::.DeviceSlot Property
MidiCCDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As MidiCCDeviceDeviceSlotRunTimePreset
C#
public MidiCCDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property MidiCCDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    MidiCCDeviceDeviceSlotRunTimePreset^ get ();
    void set (MidiCCDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

MidiCCDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MidiCCDeviceRunTimePreset..::.type Property
MidiCCDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MidiCCDeviceRunTimePreset Class


MidiMapping Class

[image]

.NET Framework Class Library
MidiMapping Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiMapping
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiMapping
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiMapping
JavaScript
NRenoiseTools.MidiMapping = function();

Type.createClass(
    'NRenoiseTools.MidiMapping');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiMapping

See Also

MidiMapping Members


MidiMapping Members

[image] [image]

.NET Framework Class Library
MidiMapping Members
MidiMapping Class Constructors Methods Properties See Also Send Feedback

The MidiMapping type exposes the following members.

Constructors

Name | Description
MidiMapping |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CCNumber |
Channel |
Inverse |
Max |
Min |
Mode |

See Also

MidiMapping Class


MidiMapping Constructor

[image]

.NET Framework Class Library
MidiMapping Constructor
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiMapping()
Visual C++
public:
MidiMapping()
JavaScript
NRenoiseTools.MidiMapping = function();

See Also

MidiMapping Class


MidiMapping Methods

[image] [image]

.NET Framework Class Library
MidiMapping Methods
MidiMapping Class See Also Send Feedback

The MidiMapping type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiMapping Class


MidiMapping Properties

[image] [image]

.NET Framework Class Library
MidiMapping Properties
MidiMapping Class See Also Send Feedback

The MidiMapping type exposes the following members.

Properties

Name | Description
CCNumber |
Channel |
Inverse |
Max |
Min |
Mode |

See Also

MidiMapping Class


CCNumber Property

[image]

.NET Framework Class Library
MidiMapping..::.CCNumber Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CCNumber As Integer
C#
public int CCNumber { get; set; }
Visual C++
public:
property int CCNumber {
    int get ();
    void set (int value);
}
JavaScript
function get_ccNumber();
function set_ccNumber(value);

Remarks

See Also

MidiMapping Class


Channel Property

[image]

.NET Framework Class Library
MidiMapping..::.Channel Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Channel As Integer
C#
public int Channel { get; set; }
Visual C++
public:
property int Channel {
    int get ();
    void set (int value);
}
JavaScript
function get_channel();
function set_channel(value);

Remarks

See Also

MidiMapping Class


Inverse Property

[image]

.NET Framework Class Library
MidiMapping..::.Inverse Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inverse As Boolean
C#
public bool Inverse { get; set; }
Visual C++
public:
property bool Inverse {
    bool get ();
    void set (bool value);
}
JavaScript
function get_inverse();
function set_inverse(value);

Remarks

See Also

MidiMapping Class


Max Property

[image]

.NET Framework Class Library
MidiMapping..::.Max Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Max As Single
C#
public float Max { get; set; }
Visual C++
public:
property float Max {
    float get ();
    void set (float value);
}
JavaScript
function get_max();
function set_max(value);

Remarks

See Also

MidiMapping Class


Min Property

[image]

.NET Framework Class Library
MidiMapping..::.Min Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Min As Single
C#
public float Min { get; set; }
Visual C++
public:
property float Min {
    float get ();
    void set (float value);
}
JavaScript
function get_min();
function set_min(value);

Remarks

See Also

MidiMapping Class


Mode Property

[image]

.NET Framework Class Library
MidiMapping..::.Mode Property
MidiMapping Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As Integer
C#
public int Mode { get; set; }
Visual C++
public:
property int Mode {
    int get ();
    void set (int value);
}
JavaScript
function get_mode();
function set_mode(value);

Remarks

See Also

MidiMapping Class


MidiProperties Class

[image]

.NET Framework Class Library
MidiProperties Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MidiProperties
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MidiProperties
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MidiProperties
JavaScript
NRenoiseTools.MidiProperties = function();

Type.createClass(
    'NRenoiseTools.MidiProperties');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MidiProperties

See Also

MidiProperties Members


MidiProperties Members

[image] [image]

.NET Framework Class Library
MidiProperties Members
MidiProperties Class Constructors Methods Properties See Also Send Feedback

The MidiProperties type exposes the following members.

Constructors

Name | Description
MidiProperties |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bank |
BaseNote |
Channel |
Delay |
DeviceName |
InstrumentType |
IsActive |
Length |
Program |

See Also

MidiProperties Class


MidiProperties Constructor

[image]

.NET Framework Class Library
MidiProperties Constructor
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MidiProperties()
Visual C++
public:
MidiProperties()
JavaScript
NRenoiseTools.MidiProperties = function();

See Also

MidiProperties Class


MidiProperties Methods

[image] [image]

.NET Framework Class Library
MidiProperties Methods
MidiProperties Class See Also Send Feedback

The MidiProperties type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MidiProperties Class


MidiProperties Properties

[image] [image]

.NET Framework Class Library
MidiProperties Properties
MidiProperties Class See Also Send Feedback

The MidiProperties type exposes the following members.

Properties

Name | Description
Bank |
BaseNote |
Channel |
Delay |
DeviceName |
InstrumentType |
IsActive |
Length |
Program |

See Also

MidiProperties Class


Bank Property

[image]

.NET Framework Class Library
MidiProperties..::.Bank Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Bank As Integer
C#
public int Bank { get; set; }
Visual C++
public:
property int Bank {
    int get ();
    void set (int value);
}
JavaScript
function get_bank();
function set_bank(value);

Remarks

See Also

MidiProperties Class


BaseNote Property

[image]

.NET Framework Class Library
MidiProperties..::.BaseNote Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseNote As Integer
C#
public int BaseNote { get; set; }
Visual C++
public:
property int BaseNote {
    int get ();
    void set (int value);
}
JavaScript
function get_baseNote();
function set_baseNote(value);

Remarks

See Also

MidiProperties Class


Channel Property

[image]

.NET Framework Class Library
MidiProperties..::.Channel Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Channel As SByte
C#
public sbyte Channel { get; set; }
Visual C++
public:
property signed char Channel {
    signed char get ();
    void set (signed char value);
}
JavaScript
function get_channel();
function set_channel(value);

Remarks

See Also

MidiProperties Class


Delay Property

[image]

.NET Framework Class Library
MidiProperties..::.Delay Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As Integer
C#
public int Delay { get; set; }
Visual C++
public:
property int Delay {
    int get ();
    void set (int value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

MidiProperties Class


DeviceName Property

[image]

.NET Framework Class Library
MidiProperties..::.DeviceName Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceName As String
C#
public string DeviceName { get; set; }
Visual C++
public:
property String^ DeviceName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_deviceName();
function set_deviceName(value);

Remarks

See Also

MidiProperties Class


InstrumentType Property

[image]

.NET Framework Class Library
MidiProperties..::.InstrumentType Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InstrumentType As MidiPropertiesInstrumentType
C#
public MidiPropertiesInstrumentType InstrumentType { get; set; }
Visual C++
public:
property MidiPropertiesInstrumentType InstrumentType {
    MidiPropertiesInstrumentType get ();
    void set (MidiPropertiesInstrumentType value);
}
JavaScript
function get_instrumentType();
function set_instrumentType(value);

Remarks

See Also

MidiProperties Class


IsActive Property

[image]

.NET Framework Class Library
MidiProperties..::.IsActive Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

MidiProperties Class


Length Property

[image]

.NET Framework Class Library
MidiProperties..::.Length Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

MidiProperties Class


Program Property

[image]

.NET Framework Class Library
MidiProperties..::.Program Property
MidiProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Program As Integer
C#
public int Program { get; set; }
Visual C++
public:
property int Program {
    int get ();
    void set (int value);
}
JavaScript
function get_program();
function set_program(value);

Remarks

See Also

MidiProperties Class


MidiPropertiesInstrumentType Enumeration

[image]

.NET Framework Class Library
MidiPropertiesInstrumentType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MidiPropertiesInstrumentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MidiPropertiesInstrumentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MidiPropertiesInstrumentType
JavaScript
NRenoiseTools.MidiPropertiesInstrumentType = function();
NRenoiseTools.MidiPropertiesInstrumentType.createEnum('NRenoiseTools.MidiPropertiesInstrumentType', false);

Members

Member name | Description
extMIDI |
LineInRet |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDevice Class

[image]

.NET Framework Class Library
MixerEqDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDevice
JavaScript
NRenoiseTools.MixerEqDevice = function();

Type.createClass(
    'NRenoiseTools.MixerEqDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDevice

See Also

MixerEqDevice Members


MixerEqDevice Members

[image] [image]

.NET Framework Class Library
MixerEqDevice Members
MixerEqDevice Class Constructors Methods Properties See Also Send Feedback

The MixerEqDevice type exposes the following members.

Constructors

Name | Description
MixerEqDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HiGain |
InputMode |
IsActive |
IsSelected |
LowGain |
MaxVisualizedGain |
MidFreq |
MidGain |
MidQ |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

MixerEqDevice Class


MixerEqDevice Constructor

[image]

.NET Framework Class Library
MixerEqDevice Constructor
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDevice()
Visual C++
public:
MixerEqDevice()
JavaScript
NRenoiseTools.MixerEqDevice = function();

See Also

MixerEqDevice Class


MixerEqDevice Methods

[image] [image]

.NET Framework Class Library
MixerEqDevice Methods
MixerEqDevice Class See Also Send Feedback

The MixerEqDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDevice Class


MixerEqDevice Properties

[image] [image]

.NET Framework Class Library
MixerEqDevice Properties
MixerEqDevice Class See Also Send Feedback

The MixerEqDevice type exposes the following members.

Properties

Name | Description
HiGain |
InputMode |
IsActive |
IsSelected |
LowGain |
MaxVisualizedGain |
MidFreq |
MidGain |
MidQ |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

MixerEqDevice Class


HiGain Property

[image]

.NET Framework Class Library
MixerEqDevice..::.HiGain Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HiGain As MixerEqDeviceHiGain
C#
public MixerEqDeviceHiGain HiGain { get; set; }
Visual C++
public:
property MixerEqDeviceHiGain^ HiGain {
    MixerEqDeviceHiGain^ get ();
    void set (MixerEqDeviceHiGain^ value);
}
JavaScript
function get_hiGain();
function set_hiGain(value);

Remarks

See Also

MixerEqDevice Class


InputMode Property

[image]

.NET Framework Class Library
MixerEqDevice..::.InputMode Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As MixerEqDeviceInputMode
C#
public MixerEqDeviceInputMode InputMode { get; set; }
Visual C++
public:
property MixerEqDeviceInputMode InputMode {
    MixerEqDeviceInputMode get ();
    void set (MixerEqDeviceInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

MixerEqDevice Class


IsActive Property

[image]

.NET Framework Class Library
MixerEqDevice..::.IsActive Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

MixerEqDevice Class


IsSelected Property

[image]

.NET Framework Class Library
MixerEqDevice..::.IsSelected Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

MixerEqDevice Class


LowGain Property

[image]

.NET Framework Class Library
MixerEqDevice..::.LowGain Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LowGain As MixerEqDeviceLowGain
C#
public MixerEqDeviceLowGain LowGain { get; set; }
Visual C++
public:
property MixerEqDeviceLowGain^ LowGain {
    MixerEqDeviceLowGain^ get ();
    void set (MixerEqDeviceLowGain^ value);
}
JavaScript
function get_lowGain();
function set_lowGain(value);

Remarks

See Also

MixerEqDevice Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
MixerEqDevice..::.MaxVisualizedGain Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

MixerEqDevice Class


MidFreq Property

[image]

.NET Framework Class Library
MixerEqDevice..::.MidFreq Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidFreq As MixerEqDeviceMidFreq
C#
public MixerEqDeviceMidFreq MidFreq { get; set; }
Visual C++
public:
property MixerEqDeviceMidFreq^ MidFreq {
    MixerEqDeviceMidFreq^ get ();
    void set (MixerEqDeviceMidFreq^ value);
}
JavaScript
function get_midFreq();
function set_midFreq(value);

Remarks

See Also

MixerEqDevice Class


MidGain Property

[image]

.NET Framework Class Library
MixerEqDevice..::.MidGain Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidGain As MixerEqDeviceMidGain
C#
public MixerEqDeviceMidGain MidGain { get; set; }
Visual C++
public:
property MixerEqDeviceMidGain^ MidGain {
    MixerEqDeviceMidGain^ get ();
    void set (MixerEqDeviceMidGain^ value);
}
JavaScript
function get_midGain();
function set_midGain(value);

Remarks

See Also

MixerEqDevice Class


MidQ Property

[image]

.NET Framework Class Library
MixerEqDevice..::.MidQ Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidQ As MixerEqDeviceMidQ
C#
public MixerEqDeviceMidQ MidQ { get; set; }
Visual C++
public:
property MixerEqDeviceMidQ^ MidQ {
    MixerEqDeviceMidQ^ get ();
    void set (MixerEqDeviceMidQ^ value);
}
JavaScript
function get_midQ();
function set_midQ(value);

Remarks

See Also

MixerEqDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
MixerEqDevice..::.RunTimePresetA Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As MixerEqDeviceRunTimePreset
C#
public MixerEqDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property MixerEqDeviceRunTimePreset^ RunTimePresetA {
    MixerEqDeviceRunTimePreset^ get ();
    void set (MixerEqDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

MixerEqDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
MixerEqDevice..::.RunTimePresetB Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As MixerEqDeviceRunTimePreset
C#
public MixerEqDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property MixerEqDeviceRunTimePreset^ RunTimePresetB {
    MixerEqDeviceRunTimePreset^ get ();
    void set (MixerEqDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

MixerEqDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
MixerEqDevice..::.SelectedPresetIsModified Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

MixerEqDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
MixerEqDevice..::.SelectedPresetName Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

MixerEqDevice Class


type Property

[image]

.NET Framework Class Library
MixerEqDevice..::.type Property
MixerEqDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MixerEqDevice Class


MixerEqDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceDeviceSlotRunTimePreset

See Also

MixerEqDeviceDeviceSlotRunTimePreset Members


MixerEqDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset Members
MixerEqDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HiGain |
InputMode |
LowGain |
MaxVisualizedGain |
MidFreq |
MidGain |
MidQ |
type |

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MixerEqDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset Constructor
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceDeviceSlotRunTimePreset()
Visual C++
public:
MixerEqDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePreset = function();

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MixerEqDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset Methods
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MixerEqDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MixerEqDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset Properties
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The MixerEqDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
HiGain |
InputMode |
LowGain |
MaxVisualizedGain |
MidFreq |
MidGain |
MidQ |
type |

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


HiGain Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.HiGain Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HiGain As MixerEqDeviceHiGainRunTimePreset
C#
public MixerEqDeviceHiGainRunTimePreset HiGain { get; set; }
Visual C++
public:
property MixerEqDeviceHiGainRunTimePreset^ HiGain {
    MixerEqDeviceHiGainRunTimePreset^ get ();
    void set (MixerEqDeviceHiGainRunTimePreset^ value);
}
JavaScript
function get_hiGain();
function set_hiGain(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


InputMode Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.InputMode Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InputMode As MixerEqDeviceDeviceSlotRunTimePresetInputMode
C#
public MixerEqDeviceDeviceSlotRunTimePresetInputMode InputMode { get; set; }
Visual C++
public:
property MixerEqDeviceDeviceSlotRunTimePresetInputMode InputMode {
    MixerEqDeviceDeviceSlotRunTimePresetInputMode get ();
    void set (MixerEqDeviceDeviceSlotRunTimePresetInputMode value);
}
JavaScript
function get_inputMode();
function set_inputMode(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


LowGain Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.LowGain Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LowGain As MixerEqDeviceLowGainRunTimePreset
C#
public MixerEqDeviceLowGainRunTimePreset LowGain { get; set; }
Visual C++
public:
property MixerEqDeviceLowGainRunTimePreset^ LowGain {
    MixerEqDeviceLowGainRunTimePreset^ get ();
    void set (MixerEqDeviceLowGainRunTimePreset^ value);
}
JavaScript
function get_lowGain();
function set_lowGain(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MaxVisualizedGain Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.MaxVisualizedGain Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVisualizedGain As Single
C#
public float MaxVisualizedGain { get; set; }
Visual C++
public:
property float MaxVisualizedGain {
    float get ();
    void set (float value);
}
JavaScript
function get_maxVisualizedGain();
function set_maxVisualizedGain(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MidFreq Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.MidFreq Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidFreq As MixerEqDeviceMidFreqRunTimePreset
C#
public MixerEqDeviceMidFreqRunTimePreset MidFreq { get; set; }
Visual C++
public:
property MixerEqDeviceMidFreqRunTimePreset^ MidFreq {
    MixerEqDeviceMidFreqRunTimePreset^ get ();
    void set (MixerEqDeviceMidFreqRunTimePreset^ value);
}
JavaScript
function get_midFreq();
function set_midFreq(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MidGain Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.MidGain Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidGain As MixerEqDeviceMidGainRunTimePreset
C#
public MixerEqDeviceMidGainRunTimePreset MidGain { get; set; }
Visual C++
public:
property MixerEqDeviceMidGainRunTimePreset^ MidGain {
    MixerEqDeviceMidGainRunTimePreset^ get ();
    void set (MixerEqDeviceMidGainRunTimePreset^ value);
}
JavaScript
function get_midGain();
function set_midGain(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MidQ Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.MidQ Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidQ As MixerEqDeviceMidQRunTimePreset
C#
public MixerEqDeviceMidQRunTimePreset MidQ { get; set; }
Visual C++
public:
property MixerEqDeviceMidQRunTimePreset^ MidQ {
    MixerEqDeviceMidQRunTimePreset^ get ();
    void set (MixerEqDeviceMidQRunTimePreset^ value);
}
JavaScript
function get_midQ();
function set_midQ(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePreset..::.type Property
MixerEqDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MixerEqDeviceDeviceSlotRunTimePreset Class


MixerEqDeviceDeviceSlotRunTimePresetInputMode Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceDeviceSlotRunTimePresetInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceDeviceSlotRunTimePresetInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceDeviceSlotRunTimePresetInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceDeviceSlotRunTimePresetInputMode
JavaScript
NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePresetInputMode = function();
NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePresetInputMode.createEnum('NRenoiseTools.MixerEqDeviceDeviceSlotRunTimePresetInputMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceHiGain Class

[image]

.NET Framework Class Library
MixerEqDeviceHiGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceHiGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceHiGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceHiGain
JavaScript
NRenoiseTools.MixerEqDeviceHiGain = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceHiGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceHiGain

See Also

MixerEqDeviceHiGain Members


MixerEqDeviceHiGain Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGain Members
MixerEqDeviceHiGain Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceHiGain type exposes the following members.

Constructors

Name | Description
MixerEqDeviceHiGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceHiGain Class


MixerEqDeviceHiGain Constructor

[image]

.NET Framework Class Library
MixerEqDeviceHiGain Constructor
MixerEqDeviceHiGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceHiGain()
Visual C++
public:
MixerEqDeviceHiGain()
JavaScript
NRenoiseTools.MixerEqDeviceHiGain = function();

See Also

MixerEqDeviceHiGain Class


MixerEqDeviceHiGain Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGain Methods
MixerEqDeviceHiGain Class See Also Send Feedback

The MixerEqDeviceHiGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceHiGain Class


MixerEqDeviceHiGain Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGain Properties
MixerEqDeviceHiGain Class See Also Send Feedback

The MixerEqDeviceHiGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceHiGain Class


MidiMappings Property

[image]

.NET Framework Class Library
MixerEqDeviceHiGain..::.MidiMappings Property
MixerEqDeviceHiGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MixerEqDeviceHiGain Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceHiGain..::.Value Property
MixerEqDeviceHiGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceHiGain Class


Visualization Property

[image]

.NET Framework Class Library
MixerEqDeviceHiGain..::.Visualization Property
MixerEqDeviceHiGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MixerEqDeviceHiGainVisualization
C#
public MixerEqDeviceHiGainVisualization Visualization { get; set; }
Visual C++
public:
property MixerEqDeviceHiGainVisualization Visualization {
    MixerEqDeviceHiGainVisualization get ();
    void set (MixerEqDeviceHiGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MixerEqDeviceHiGain Class


MixerEqDeviceHiGainRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceHiGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceHiGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceHiGainRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceHiGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceHiGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceHiGainRunTimePreset

See Also

MixerEqDeviceHiGainRunTimePreset Members


MixerEqDeviceHiGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset Members
MixerEqDeviceHiGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceHiGainRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceHiGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MixerEqDeviceHiGainRunTimePreset Class


MixerEqDeviceHiGainRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset Constructor
MixerEqDeviceHiGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceHiGainRunTimePreset()
Visual C++
public:
MixerEqDeviceHiGainRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceHiGainRunTimePreset = function();

See Also

MixerEqDeviceHiGainRunTimePreset Class


MixerEqDeviceHiGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset Methods
MixerEqDeviceHiGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceHiGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceHiGainRunTimePreset Class


MixerEqDeviceHiGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset Properties
MixerEqDeviceHiGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceHiGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MixerEqDeviceHiGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceHiGainRunTimePreset..::.Value Property
MixerEqDeviceHiGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceHiGainRunTimePreset Class


MixerEqDeviceHiGainVisualization Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceHiGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceHiGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceHiGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceHiGainVisualization
JavaScript
NRenoiseTools.MixerEqDeviceHiGainVisualization = function();
NRenoiseTools.MixerEqDeviceHiGainVisualization.createEnum('NRenoiseTools.MixerEqDeviceHiGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceInputMode Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceInputMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceInputMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceInputMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceInputMode
JavaScript
NRenoiseTools.MixerEqDeviceInputMode = function();
NRenoiseTools.MixerEqDeviceInputMode.createEnum('NRenoiseTools.MixerEqDeviceInputMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceLowGain Class

[image]

.NET Framework Class Library
MixerEqDeviceLowGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceLowGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceLowGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceLowGain
JavaScript
NRenoiseTools.MixerEqDeviceLowGain = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceLowGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceLowGain

See Also

MixerEqDeviceLowGain Members


MixerEqDeviceLowGain Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGain Members
MixerEqDeviceLowGain Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceLowGain type exposes the following members.

Constructors

Name | Description
MixerEqDeviceLowGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceLowGain Class


MixerEqDeviceLowGain Constructor

[image]

.NET Framework Class Library
MixerEqDeviceLowGain Constructor
MixerEqDeviceLowGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceLowGain()
Visual C++
public:
MixerEqDeviceLowGain()
JavaScript
NRenoiseTools.MixerEqDeviceLowGain = function();

See Also

MixerEqDeviceLowGain Class


MixerEqDeviceLowGain Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGain Methods
MixerEqDeviceLowGain Class See Also Send Feedback

The MixerEqDeviceLowGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceLowGain Class


MixerEqDeviceLowGain Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGain Properties
MixerEqDeviceLowGain Class See Also Send Feedback

The MixerEqDeviceLowGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceLowGain Class


MidiMappings Property

[image]

.NET Framework Class Library
MixerEqDeviceLowGain..::.MidiMappings Property
MixerEqDeviceLowGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MixerEqDeviceLowGain Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceLowGain..::.Value Property
MixerEqDeviceLowGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceLowGain Class


Visualization Property

[image]

.NET Framework Class Library
MixerEqDeviceLowGain..::.Visualization Property
MixerEqDeviceLowGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MixerEqDeviceLowGainVisualization
C#
public MixerEqDeviceLowGainVisualization Visualization { get; set; }
Visual C++
public:
property MixerEqDeviceLowGainVisualization Visualization {
    MixerEqDeviceLowGainVisualization get ();
    void set (MixerEqDeviceLowGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MixerEqDeviceLowGain Class


MixerEqDeviceLowGainRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceLowGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceLowGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceLowGainRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceLowGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceLowGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceLowGainRunTimePreset

See Also

MixerEqDeviceLowGainRunTimePreset Members


MixerEqDeviceLowGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset Members
MixerEqDeviceLowGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceLowGainRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceLowGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MixerEqDeviceLowGainRunTimePreset Class


MixerEqDeviceLowGainRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset Constructor
MixerEqDeviceLowGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceLowGainRunTimePreset()
Visual C++
public:
MixerEqDeviceLowGainRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceLowGainRunTimePreset = function();

See Also

MixerEqDeviceLowGainRunTimePreset Class


MixerEqDeviceLowGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset Methods
MixerEqDeviceLowGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceLowGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceLowGainRunTimePreset Class


MixerEqDeviceLowGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset Properties
MixerEqDeviceLowGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceLowGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MixerEqDeviceLowGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceLowGainRunTimePreset..::.Value Property
MixerEqDeviceLowGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceLowGainRunTimePreset Class


MixerEqDeviceLowGainVisualization Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceLowGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceLowGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceLowGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceLowGainVisualization
JavaScript
NRenoiseTools.MixerEqDeviceLowGainVisualization = function();
NRenoiseTools.MixerEqDeviceLowGainVisualization.createEnum('NRenoiseTools.MixerEqDeviceLowGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceMidFreq Class

[image]

.NET Framework Class Library
MixerEqDeviceMidFreq Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidFreq
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidFreq
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidFreq
JavaScript
NRenoiseTools.MixerEqDeviceMidFreq = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidFreq');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidFreq

See Also

MixerEqDeviceMidFreq Members


MixerEqDeviceMidFreq Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreq Members
MixerEqDeviceMidFreq Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidFreq type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidFreq |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidFreq Class


MixerEqDeviceMidFreq Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidFreq Constructor
MixerEqDeviceMidFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidFreq()
Visual C++
public:
MixerEqDeviceMidFreq()
JavaScript
NRenoiseTools.MixerEqDeviceMidFreq = function();

See Also

MixerEqDeviceMidFreq Class


MixerEqDeviceMidFreq Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreq Methods
MixerEqDeviceMidFreq Class See Also Send Feedback

The MixerEqDeviceMidFreq type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidFreq Class


MixerEqDeviceMidFreq Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreq Properties
MixerEqDeviceMidFreq Class See Also Send Feedback

The MixerEqDeviceMidFreq type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidFreq Class


MidiMappings Property

[image]

.NET Framework Class Library
MixerEqDeviceMidFreq..::.MidiMappings Property
MixerEqDeviceMidFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MixerEqDeviceMidFreq Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidFreq..::.Value Property
MixerEqDeviceMidFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidFreq Class


Visualization Property

[image]

.NET Framework Class Library
MixerEqDeviceMidFreq..::.Visualization Property
MixerEqDeviceMidFreq Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MixerEqDeviceMidFreqVisualization
C#
public MixerEqDeviceMidFreqVisualization Visualization { get; set; }
Visual C++
public:
property MixerEqDeviceMidFreqVisualization Visualization {
    MixerEqDeviceMidFreqVisualization get ();
    void set (MixerEqDeviceMidFreqVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MixerEqDeviceMidFreq Class


MixerEqDeviceMidFreqRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidFreqRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidFreqRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidFreqRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceMidFreqRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidFreqRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidFreqRunTimePreset

See Also

MixerEqDeviceMidFreqRunTimePreset Members


MixerEqDeviceMidFreqRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset Members
MixerEqDeviceMidFreqRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidFreqRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidFreqRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidFreqRunTimePreset Class


MixerEqDeviceMidFreqRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset Constructor
MixerEqDeviceMidFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidFreqRunTimePreset()
Visual C++
public:
MixerEqDeviceMidFreqRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceMidFreqRunTimePreset = function();

See Also

MixerEqDeviceMidFreqRunTimePreset Class


MixerEqDeviceMidFreqRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset Methods
MixerEqDeviceMidFreqRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidFreqRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidFreqRunTimePreset Class


MixerEqDeviceMidFreqRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset Properties
MixerEqDeviceMidFreqRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidFreqRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidFreqRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidFreqRunTimePreset..::.Value Property
MixerEqDeviceMidFreqRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidFreqRunTimePreset Class


MixerEqDeviceMidFreqVisualization Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceMidFreqVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceMidFreqVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceMidFreqVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceMidFreqVisualization
JavaScript
NRenoiseTools.MixerEqDeviceMidFreqVisualization = function();
NRenoiseTools.MixerEqDeviceMidFreqVisualization.createEnum('NRenoiseTools.MixerEqDeviceMidFreqVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceMidGain Class

[image]

.NET Framework Class Library
MixerEqDeviceMidGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidGain
JavaScript
NRenoiseTools.MixerEqDeviceMidGain = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidGain

See Also

MixerEqDeviceMidGain Members


MixerEqDeviceMidGain Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGain Members
MixerEqDeviceMidGain Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidGain type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidGain Class


MixerEqDeviceMidGain Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidGain Constructor
MixerEqDeviceMidGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidGain()
Visual C++
public:
MixerEqDeviceMidGain()
JavaScript
NRenoiseTools.MixerEqDeviceMidGain = function();

See Also

MixerEqDeviceMidGain Class


MixerEqDeviceMidGain Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGain Methods
MixerEqDeviceMidGain Class See Also Send Feedback

The MixerEqDeviceMidGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidGain Class


MixerEqDeviceMidGain Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGain Properties
MixerEqDeviceMidGain Class See Also Send Feedback

The MixerEqDeviceMidGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidGain Class


MidiMappings Property

[image]

.NET Framework Class Library
MixerEqDeviceMidGain..::.MidiMappings Property
MixerEqDeviceMidGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MixerEqDeviceMidGain Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidGain..::.Value Property
MixerEqDeviceMidGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidGain Class


Visualization Property

[image]

.NET Framework Class Library
MixerEqDeviceMidGain..::.Visualization Property
MixerEqDeviceMidGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MixerEqDeviceMidGainVisualization
C#
public MixerEqDeviceMidGainVisualization Visualization { get; set; }
Visual C++
public:
property MixerEqDeviceMidGainVisualization Visualization {
    MixerEqDeviceMidGainVisualization get ();
    void set (MixerEqDeviceMidGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MixerEqDeviceMidGain Class


MixerEqDeviceMidGainRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidGainRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceMidGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidGainRunTimePreset

See Also

MixerEqDeviceMidGainRunTimePreset Members


MixerEqDeviceMidGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset Members
MixerEqDeviceMidGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidGainRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidGainRunTimePreset Class


MixerEqDeviceMidGainRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset Constructor
MixerEqDeviceMidGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidGainRunTimePreset()
Visual C++
public:
MixerEqDeviceMidGainRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceMidGainRunTimePreset = function();

See Also

MixerEqDeviceMidGainRunTimePreset Class


MixerEqDeviceMidGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset Methods
MixerEqDeviceMidGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidGainRunTimePreset Class


MixerEqDeviceMidGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset Properties
MixerEqDeviceMidGainRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidGainRunTimePreset..::.Value Property
MixerEqDeviceMidGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidGainRunTimePreset Class


MixerEqDeviceMidGainVisualization Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceMidGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceMidGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceMidGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceMidGainVisualization
JavaScript
NRenoiseTools.MixerEqDeviceMidGainVisualization = function();
NRenoiseTools.MixerEqDeviceMidGainVisualization.createEnum('NRenoiseTools.MixerEqDeviceMidGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceMidQ Class

[image]

.NET Framework Class Library
MixerEqDeviceMidQ Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidQ
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidQ
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidQ
JavaScript
NRenoiseTools.MixerEqDeviceMidQ = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidQ');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidQ

See Also

MixerEqDeviceMidQ Members


MixerEqDeviceMidQ Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQ Members
MixerEqDeviceMidQ Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidQ type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidQ |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidQ Class


MixerEqDeviceMidQ Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidQ Constructor
MixerEqDeviceMidQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidQ()
Visual C++
public:
MixerEqDeviceMidQ()
JavaScript
NRenoiseTools.MixerEqDeviceMidQ = function();

See Also

MixerEqDeviceMidQ Class


MixerEqDeviceMidQ Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQ Methods
MixerEqDeviceMidQ Class See Also Send Feedback

The MixerEqDeviceMidQ type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidQ Class


MixerEqDeviceMidQ Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQ Properties
MixerEqDeviceMidQ Class See Also Send Feedback

The MixerEqDeviceMidQ type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

MixerEqDeviceMidQ Class


MidiMappings Property

[image]

.NET Framework Class Library
MixerEqDeviceMidQ..::.MidiMappings Property
MixerEqDeviceMidQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

MixerEqDeviceMidQ Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidQ..::.Value Property
MixerEqDeviceMidQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidQ Class


Visualization Property

[image]

.NET Framework Class Library
MixerEqDeviceMidQ..::.Visualization Property
MixerEqDeviceMidQ Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As MixerEqDeviceMidQVisualization
C#
public MixerEqDeviceMidQVisualization Visualization { get; set; }
Visual C++
public:
property MixerEqDeviceMidQVisualization Visualization {
    MixerEqDeviceMidQVisualization get ();
    void set (MixerEqDeviceMidQVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

MixerEqDeviceMidQ Class


MixerEqDeviceMidQRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceMidQRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceMidQRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceMidQRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceMidQRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceMidQRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceMidQRunTimePreset

See Also

MixerEqDeviceMidQRunTimePreset Members


MixerEqDeviceMidQRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset Members
MixerEqDeviceMidQRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceMidQRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceMidQRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidQRunTimePreset Class


MixerEqDeviceMidQRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset Constructor
MixerEqDeviceMidQRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceMidQRunTimePreset()
Visual C++
public:
MixerEqDeviceMidQRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceMidQRunTimePreset = function();

See Also

MixerEqDeviceMidQRunTimePreset Class


MixerEqDeviceMidQRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset Methods
MixerEqDeviceMidQRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidQRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceMidQRunTimePreset Class


MixerEqDeviceMidQRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset Properties
MixerEqDeviceMidQRunTimePreset Class See Also Send Feedback

The MixerEqDeviceMidQRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

MixerEqDeviceMidQRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
MixerEqDeviceMidQRunTimePreset..::.Value Property
MixerEqDeviceMidQRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

MixerEqDeviceMidQRunTimePreset Class


MixerEqDeviceMidQVisualization Enumeration

[image]

.NET Framework Class Library
MixerEqDeviceMidQVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration MixerEqDeviceMidQVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum MixerEqDeviceMidQVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class MixerEqDeviceMidQVisualization
JavaScript
NRenoiseTools.MixerEqDeviceMidQVisualization = function();
NRenoiseTools.MixerEqDeviceMidQVisualization.createEnum('NRenoiseTools.MixerEqDeviceMidQVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


MixerEqDeviceRunTimePreset Class

[image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class MixerEqDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class MixerEqDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class MixerEqDeviceRunTimePreset
JavaScript
NRenoiseTools.MixerEqDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.MixerEqDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.MixerEqDeviceRunTimePreset

See Also

MixerEqDeviceRunTimePreset Members


MixerEqDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset Members
MixerEqDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The MixerEqDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
MixerEqDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

MixerEqDeviceRunTimePreset Class


MixerEqDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset Constructor
MixerEqDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MixerEqDeviceRunTimePreset()
Visual C++
public:
MixerEqDeviceRunTimePreset()
JavaScript
NRenoiseTools.MixerEqDeviceRunTimePreset = function();

See Also

MixerEqDeviceRunTimePreset Class


MixerEqDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset Methods
MixerEqDeviceRunTimePreset Class See Also Send Feedback

The MixerEqDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MixerEqDeviceRunTimePreset Class


MixerEqDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset Properties
MixerEqDeviceRunTimePreset Class See Also Send Feedback

The MixerEqDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

MixerEqDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset..::.DeviceSlot Property
MixerEqDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As MixerEqDeviceDeviceSlotRunTimePreset
C#
public MixerEqDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property MixerEqDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    MixerEqDeviceDeviceSlotRunTimePreset^ get ();
    void set (MixerEqDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

MixerEqDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
MixerEqDeviceRunTimePreset..::.type Property
MixerEqDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

MixerEqDeviceRunTimePreset Class


NoteColumn Class

[image]

.NET Framework Class Library
NoteColumn Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class NoteColumn
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class NoteColumn
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class NoteColumn
JavaScript
NRenoiseTools.NoteColumn = function();

Type.createClass(
    'NRenoiseTools.NoteColumn');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.NoteColumn

See Also

NoteColumn Members


NoteColumn Members

[image] [image]

.NET Framework Class Library
NoteColumn Members
NoteColumn Class Constructors Methods Properties See Also Send Feedback

The NoteColumn type exposes the following members.

Constructors

Name | Description
NoteColumn |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delay |
Instrument |
Note |
Panning |
Volume |

See Also

NoteColumn Class


NoteColumn Constructor

[image]

.NET Framework Class Library
NoteColumn Constructor
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NoteColumn()
Visual C++
public:
NoteColumn()
JavaScript
NRenoiseTools.NoteColumn = function();

See Also

NoteColumn Class


NoteColumn Methods

[image] [image]

.NET Framework Class Library
NoteColumn Methods
NoteColumn Class See Also Send Feedback

The NoteColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoteColumn Class


NoteColumn Properties

[image] [image]

.NET Framework Class Library
NoteColumn Properties
NoteColumn Class See Also Send Feedback

The NoteColumn type exposes the following members.

Properties

Name | Description
Delay |
Instrument |
Note |
Panning |
Volume |

See Also

NoteColumn Class


Delay Property

[image]

.NET Framework Class Library
NoteColumn..::.Delay Property
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Delay As String
C#
public string Delay { get; set; }
Visual C++
public:
property String^ Delay {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_delay();
function set_delay(value);

Remarks

See Also

NoteColumn Class


Instrument Property

[image]

.NET Framework Class Library
NoteColumn..::.Instrument Property
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Instrument As String
C#
public string Instrument { get; set; }
Visual C++
public:
property String^ Instrument {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_instrument();
function set_instrument(value);

Remarks

See Also

NoteColumn Class


Note Property

[image]

.NET Framework Class Library
NoteColumn..::.Note Property
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Note As String
C#
public string Note { get; set; }
Visual C++
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_note();
function set_note(value);

Remarks

See Also

NoteColumn Class


Panning Property

[image]

.NET Framework Class Library
NoteColumn..::.Panning Property
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As String
C#
public string Panning { get; set; }
Visual C++
public:
property String^ Panning {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

NoteColumn Class


Volume Property

[image]

.NET Framework Class Library
NoteColumn..::.Volume Property
NoteColumn Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As String
C#
public string Volume { get; set; }
Visual C++
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

NoteColumn Class


NoteHelper Class

[image]

.NET Framework Class Library
NoteHelper Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class NoteHelper
C#
public class NoteHelper
Visual C++
public ref class NoteHelper
JavaScript
NRenoiseTools.NoteHelper = function();

Type.createClass(
    'NRenoiseTools.NoteHelper');

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.NoteHelper

See Also

NoteHelper Members


NoteHelper Members

[image] [image]

.NET Framework Class Library
NoteHelper Members
NoteHelper Class Constructors Methods See Also Send Feedback

The NoteHelper type exposes the following members.

Constructors

Name | Description
NoteHelper |

Methods

Name | Description
ConvertToNumber | Converts the renoise note to a midi note number. C-0 == 0, C-1 == 12...etc.
ConvertToString | Converts a note number ranging from 0-119 to a renoise string representation ("C-0" == 0, "C-1" == 12...etc.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoteHelper Class


NoteHelper Constructor

[image]

.NET Framework Class Library
NoteHelper Constructor
NoteHelper Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NoteHelper()
Visual C++
public:
NoteHelper()
JavaScript
NRenoiseTools.NoteHelper = function();

See Also

NoteHelper Class


NoteHelper Methods

[image] [image]

.NET Framework Class Library
NoteHelper Methods
NoteHelper Class See Also Send Feedback

The NoteHelper type exposes the following members.

Methods

Name | Description
ConvertToNumber | Converts the renoise note to a midi note number. C-0 == 0, C-1 == 12...etc.
ConvertToString | Converts a note number ranging from 0-119 to a renoise string representation ("C-0" == 0, "C-1" == 12...etc.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoteHelper Class


ConvertToNumber Method

[image]

.NET Framework Class Library
NoteHelper..::.ConvertToNumber Method
NoteHelper Class See Also Send Feedback

Converts the renoise note to a midi note number. C-0 == 0, C-1 == 12...etc.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToNumber ( _
    note As String _
) As Integer
C#
public static int ConvertToNumber(
    string note
)
Visual C++
public:
static int ConvertToNumber(
    String^ note
)
JavaScript
NRenoiseTools.NoteHelper.convertToNumber = function(note);

Parameters

note
Type: System..::.String
The renoise note.

Return Value

a number ranging from 0-119

See Also

NoteHelper Class


ConvertToString Method

[image]

.NET Framework Class Library
NoteHelper..::.ConvertToString Method
NoteHelper Class See Also Send Feedback

Converts a note number ranging from 0-119 to a renoise string representation ("C-0" == 0, "C-1" == 12...etc.)

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToString ( _
    noteNumber As Integer _
) As String
C#
public static string ConvertToString(
    int noteNumber
)
Visual C++
public:
static String^ ConvertToString(
    int noteNumber
)
JavaScript
NRenoiseTools.NoteHelper.convertToString = function(noteNumber);

Parameters

noteNumber
Type: System..::.Int32
The renoise note number.

Return Value

a string C-0, C-1...etc.

See Also

NoteHelper Class


OutputRouting Class

[image]

.NET Framework Class Library
OutputRouting Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class OutputRouting
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class OutputRouting
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class OutputRouting
JavaScript
NRenoiseTools.OutputRouting = function();

Type.createClass(
    'NRenoiseTools.OutputRouting');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.OutputRouting

See Also

OutputRouting Members


OutputRouting Members

[image] [image]

.NET Framework Class Library
OutputRouting Members
OutputRouting Class Constructors Methods Properties See Also Send Feedback

The OutputRouting type exposes the following members.

Constructors

Name | Description
OutputRouting |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AssignedTrack |
AutoAssign |
Enabled |
MixMode |
Name |

See Also

OutputRouting Class


OutputRouting Constructor

[image]

.NET Framework Class Library
OutputRouting Constructor
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OutputRouting()
Visual C++
public:
OutputRouting()
JavaScript
NRenoiseTools.OutputRouting = function();

See Also

OutputRouting Class


OutputRouting Methods

[image] [image]

.NET Framework Class Library
OutputRouting Methods
OutputRouting Class See Also Send Feedback

The OutputRouting type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OutputRouting Class


OutputRouting Properties

[image] [image]

.NET Framework Class Library
OutputRouting Properties
OutputRouting Class See Also Send Feedback

The OutputRouting type exposes the following members.

Properties

Name | Description
AssignedTrack |
AutoAssign |
Enabled |
MixMode |
Name |

See Also

OutputRouting Class


AssignedTrack Property

[image]

.NET Framework Class Library
OutputRouting..::.AssignedTrack Property
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AssignedTrack As Integer
C#
public int AssignedTrack { get; set; }
Visual C++
public:
property int AssignedTrack {
    int get ();
    void set (int value);
}
JavaScript
function get_assignedTrack();
function set_assignedTrack(value);

Remarks

See Also

OutputRouting Class


AutoAssign Property

[image]

.NET Framework Class Library
OutputRouting..::.AutoAssign Property
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoAssign As Boolean
C#
public bool AutoAssign { get; set; }
Visual C++
public:
property bool AutoAssign {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoAssign();
function set_autoAssign(value);

Remarks

See Also

OutputRouting Class


Enabled Property

[image]

.NET Framework Class Library
OutputRouting..::.Enabled Property
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled { get; set; }
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enabled();
function set_enabled(value);

Remarks

See Also

OutputRouting Class


MixMode Property

[image]

.NET Framework Class Library
OutputRouting..::.MixMode Property
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MixMode As OutputRoutingMixMode
C#
public OutputRoutingMixMode MixMode { get; set; }
Visual C++
public:
property OutputRoutingMixMode MixMode {
    OutputRoutingMixMode get ();
    void set (OutputRoutingMixMode value);
}
JavaScript
function get_mixMode();
function set_mixMode(value);

Remarks

See Also

OutputRouting Class


Name Property

[image]

.NET Framework Class Library
OutputRouting..::.Name Property
OutputRouting Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

OutputRouting Class


OutputRoutingMixMode Enumeration

[image]

.NET Framework Class Library
OutputRoutingMixMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration OutputRoutingMixMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum OutputRoutingMixMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class OutputRoutingMixMode
JavaScript
NRenoiseTools.OutputRoutingMixMode = function();
NRenoiseTools.OutputRoutingMixMode.createEnum('NRenoiseTools.OutputRoutingMixMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PanNodes Class

[image]

.NET Framework Class Library
PanNodes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PanNodes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PanNodes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PanNodes
JavaScript
NRenoiseTools.PanNodes = function();

Type.createClass(
    'NRenoiseTools.PanNodes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PanNodes

See Also

PanNodes Members


PanNodes Members

[image] [image]

.NET Framework Class Library
PanNodes Members
PanNodes Class Constructors Methods Properties See Also Send Feedback

The PanNodes type exposes the following members.

Constructors

Name | Description
PanNodes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

PanNodes Class


PanNodes Constructor

[image]

.NET Framework Class Library
PanNodes Constructor
PanNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PanNodes()
Visual C++
public:
PanNodes()
JavaScript
NRenoiseTools.PanNodes = function();

See Also

PanNodes Class


PanNodes Methods

[image] [image]

.NET Framework Class Library
PanNodes Methods
PanNodes Class See Also Send Feedback

The PanNodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanNodes Class


PanNodes Properties

[image] [image]

.NET Framework Class Library
PanNodes Properties
PanNodes Class See Also Send Feedback

The PanNodes type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

PanNodes Class


Length Property

[image]

.NET Framework Class Library
PanNodes..::.Length Property
PanNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

PanNodes Class


PlayMode Property

[image]

.NET Framework Class Library
PanNodes..::.PlayMode Property
PanNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As PanNodesPlayMode
C#
public PanNodesPlayMode PlayMode { get; set; }
Visual C++
public:
property PanNodesPlayMode PlayMode {
    PanNodesPlayMode get ();
    void set (PanNodesPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

PanNodes Class


Points Property

[image]

.NET Framework Class Library
PanNodes..::.Points Property
PanNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

PanNodes Class


ValueQuantum Property

[image]

.NET Framework Class Library
PanNodes..::.ValueQuantum Property
PanNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

PanNodes Class


PanNodesPlayMode Enumeration

[image]

.NET Framework Class Library
PanNodesPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PanNodesPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PanNodesPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PanNodesPlayMode
JavaScript
NRenoiseTools.PanNodesPlayMode = function();
NRenoiseTools.PanNodesPlayMode.createEnum('NRenoiseTools.PanNodesPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Parameter Class

[image]

.NET Framework Class Library
Parameter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Parameter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Parameter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Parameter
JavaScript
NRenoiseTools.Parameter = function();

Type.createClass(
    'NRenoiseTools.Parameter');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Parameter

See Also

Parameter Members


Parameter Members

[image] [image]

.NET Framework Class Library
Parameter Members
Parameter Class Constructors Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Parameter Class


Parameter Constructor

[image]

.NET Framework Class Library
Parameter Constructor
Parameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Parameter()
Visual C++
public:
Parameter()
JavaScript
NRenoiseTools.Parameter = function();

See Also

Parameter Class


Parameter Methods

[image] [image]

.NET Framework Class Library
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class


Parameter Properties

[image] [image]

.NET Framework Class Library
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Parameter Class


MidiMappings Property

[image]

.NET Framework Class Library
Parameter..::.MidiMappings Property
Parameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Parameter Class


Value Property

[image]

.NET Framework Class Library
Parameter..::.Value Property
Parameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Parameter Class


Visualization Property

[image]

.NET Framework Class Library
Parameter..::.Visualization Property
Parameter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ParameterVisualization
C#
public ParameterVisualization Visualization { get; set; }
Visual C++
public:
property ParameterVisualization Visualization {
    ParameterVisualization get ();
    void set (ParameterVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Parameter Class


ParameterValue Class

[image]

.NET Framework Class Library
ParameterValue Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ParameterValue
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ParameterValue
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ParameterValue
JavaScript
NRenoiseTools.ParameterValue = function();

Type.createClass(
    'NRenoiseTools.ParameterValue');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ParameterValue

See Also

ParameterValue Members


ParameterValue Members

[image] [image]

.NET Framework Class Library
ParameterValue Members
ParameterValue Class Constructors Methods Properties See Also Send Feedback

The ParameterValue type exposes the following members.

Constructors

Name | Description
ParameterValue |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ParameterValue Class


ParameterValue Constructor

[image]

.NET Framework Class Library
ParameterValue Constructor
ParameterValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParameterValue()
Visual C++
public:
ParameterValue()
JavaScript
NRenoiseTools.ParameterValue = function();

See Also

ParameterValue Class


ParameterValue Methods

[image] [image]

.NET Framework Class Library
ParameterValue Methods
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValue Class


ParameterValue Properties

[image] [image]

.NET Framework Class Library
ParameterValue Properties
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ParameterValue Class


MidiMappings Property

[image]

.NET Framework Class Library
ParameterValue..::.MidiMappings Property
ParameterValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ParameterValue Class


Value Property

[image]

.NET Framework Class Library
ParameterValue..::.Value Property
ParameterValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ParameterValue Class


Visualization Property

[image]

.NET Framework Class Library
ParameterValue..::.Visualization Property
ParameterValue Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ParameterValueVisualization
C#
public ParameterValueVisualization Visualization { get; set; }
Visual C++
public:
property ParameterValueVisualization Visualization {
    ParameterValueVisualization get ();
    void set (ParameterValueVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ParameterValue Class


ParameterValueVisualization Enumeration

[image]

.NET Framework Class Library
ParameterValueVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ParameterValueVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ParameterValueVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ParameterValueVisualization
JavaScript
NRenoiseTools.ParameterValueVisualization = function();
NRenoiseTools.ParameterValueVisualization.createEnum('NRenoiseTools.ParameterValueVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ParameterVisualization Enumeration

[image]

.NET Framework Class Library
ParameterVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ParameterVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ParameterVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ParameterVisualization
JavaScript
NRenoiseTools.ParameterVisualization = function();
NRenoiseTools.ParameterVisualization.createEnum('NRenoiseTools.ParameterVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Pattern Class

[image]

.NET Framework Class Library
Pattern Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Pattern
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Pattern
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Pattern
JavaScript
NRenoiseTools.Pattern = function();

Type.createClass(
    'NRenoiseTools.Pattern');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Pattern

See Also

Pattern Members


Pattern Members

[image] [image]

.NET Framework Class Library
Pattern Members
Pattern Class Constructors Methods Properties See Also Send Feedback

The Pattern type exposes the following members.

Constructors

Name | Description
Pattern |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
NumberOfLines |
Tracks |

See Also

Pattern Class


Pattern Constructor

[image]

.NET Framework Class Library
Pattern Constructor
Pattern Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Pattern()
Visual C++
public:
Pattern()
JavaScript
NRenoiseTools.Pattern = function();

See Also

Pattern Class


Pattern Methods

[image] [image]

.NET Framework Class Library
Pattern Methods
Pattern Class See Also Send Feedback

The Pattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pattern Class


Pattern Properties

[image] [image]

.NET Framework Class Library
Pattern Properties
Pattern Class See Also Send Feedback

The Pattern type exposes the following members.

Properties

Name | Description
Name |
NumberOfLines |
Tracks |

See Also

Pattern Class


Name Property

[image]

.NET Framework Class Library
Pattern..::.Name Property
Pattern Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

Pattern Class


NumberOfLines Property

[image]

.NET Framework Class Library
Pattern..::.NumberOfLines Property
Pattern Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfLines As Integer
C#
public int NumberOfLines { get; set; }
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfLines();
function set_numberOfLines(value);

Remarks

See Also

Pattern Class


Tracks Property

[image]

.NET Framework Class Library
Pattern..::.Tracks Property
Pattern Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Tracks As PatternTracks
C#
public PatternTracks Tracks { get; set; }
Visual C++
public:
property PatternTracks^ Tracks {
    PatternTracks^ get ();
    void set (PatternTracks^ value);
}
JavaScript
function get_tracks();
function set_tracks(value);

Remarks

See Also

Pattern Class


PatternMasterTrack Class

[image]

.NET Framework Class Library
PatternMasterTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternMasterTrack _
    Inherits Track
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternMasterTrack : Track
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternMasterTrack : public Track
JavaScript
NRenoiseTools.PatternMasterTrack = function();

Type.createClass(
    'NRenoiseTools.PatternMasterTrack',
    NRenoiseTools.Track);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Track
NRenoiseTools..::.PatternMasterTrack

See Also

PatternMasterTrack Members


PatternMasterTrack Members

[image] [image]

.NET Framework Class Library
PatternMasterTrack Members
PatternMasterTrack Class Constructors Methods Properties See Also Send Feedback

The PatternMasterTrack type exposes the following members.

Constructors

Name | Description
PatternMasterTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternMasterTrack Class


PatternMasterTrack Constructor

[image]

.NET Framework Class Library
PatternMasterTrack Constructor
PatternMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternMasterTrack()
Visual C++
public:
PatternMasterTrack()
JavaScript
NRenoiseTools.PatternMasterTrack = function();

See Also

PatternMasterTrack Class


PatternMasterTrack Methods

[image] [image]

.NET Framework Class Library
PatternMasterTrack Methods
PatternMasterTrack Class See Also Send Feedback

The PatternMasterTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternMasterTrack Class


PatternMasterTrack Properties

[image] [image]

.NET Framework Class Library
PatternMasterTrack Properties
PatternMasterTrack Class See Also Send Feedback

The PatternMasterTrack type exposes the following members.

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternMasterTrack Class


type Property

[image]

.NET Framework Class Library
PatternMasterTrack..::.type Property
PatternMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PatternMasterTrack Class


PatternPool Class

[image]

.NET Framework Class Library
PatternPool Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternPool
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternPool
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternPool
JavaScript
NRenoiseTools.PatternPool = function();

Type.createClass(
    'NRenoiseTools.PatternPool');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PatternPool

See Also

PatternPool Members


PatternPool Members

[image] [image]

.NET Framework Class Library
PatternPool Members
PatternPool Class Constructors Methods Properties See Also Send Feedback

The PatternPool type exposes the following members.

Constructors

Name | Description
PatternPool |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultPatternLength |
HighliteStep |
Patterns |

See Also

PatternPool Class


PatternPool Constructor

[image]

.NET Framework Class Library
PatternPool Constructor
PatternPool Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternPool()
Visual C++
public:
PatternPool()
JavaScript
NRenoiseTools.PatternPool = function();

See Also

PatternPool Class


PatternPool Methods

[image] [image]

.NET Framework Class Library
PatternPool Methods
PatternPool Class See Also Send Feedback

The PatternPool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternPool Class


PatternPool Properties

[image] [image]

.NET Framework Class Library
PatternPool Properties
PatternPool Class See Also Send Feedback

The PatternPool type exposes the following members.

Properties

Name | Description
DefaultPatternLength |
HighliteStep |
Patterns |

See Also

PatternPool Class


DefaultPatternLength Property

[image]

.NET Framework Class Library
PatternPool..::.DefaultPatternLength Property
PatternPool Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultPatternLength As Integer
C#
public int DefaultPatternLength { get; set; }
Visual C++
public:
property int DefaultPatternLength {
    int get ();
    void set (int value);
}
JavaScript
function get_defaultPatternLength();
function set_defaultPatternLength(value);

Remarks

See Also

PatternPool Class


HighliteStep Property

[image]

.NET Framework Class Library
PatternPool..::.HighliteStep Property
PatternPool Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HighliteStep As Integer
C#
public int HighliteStep { get; set; }
Visual C++
public:
property int HighliteStep {
    int get ();
    void set (int value);
}
JavaScript
function get_highliteStep();
function set_highliteStep(value);

Remarks

See Also

PatternPool Class


Patterns Property

[image]

.NET Framework Class Library
PatternPool..::.Patterns Property
PatternPool Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Patterns As Pattern()
C#
public Pattern[] Patterns { get; set; }
Visual C++
public:
property array<Pattern^>^ Patterns {
    array<Pattern^>^ get ();
    void set (array<Pattern^>^ value);
}
JavaScript
function get_patterns();
function set_patterns(value);

Remarks

See Also

PatternPool Class


PatternSendTrack Class

[image]

.NET Framework Class Library
PatternSendTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternSendTrack _
    Inherits Track
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternSendTrack : Track
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternSendTrack : public Track
JavaScript
NRenoiseTools.PatternSendTrack = function();

Type.createClass(
    'NRenoiseTools.PatternSendTrack',
    NRenoiseTools.Track);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Track
NRenoiseTools..::.PatternSendTrack

See Also

PatternSendTrack Members


PatternSendTrack Members

[image] [image]

.NET Framework Class Library
PatternSendTrack Members
PatternSendTrack Class Constructors Methods Properties See Also Send Feedback

The PatternSendTrack type exposes the following members.

Constructors

Name | Description
PatternSendTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternSendTrack Class


PatternSendTrack Constructor

[image]

.NET Framework Class Library
PatternSendTrack Constructor
PatternSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternSendTrack()
Visual C++
public:
PatternSendTrack()
JavaScript
NRenoiseTools.PatternSendTrack = function();

See Also

PatternSendTrack Class


PatternSendTrack Methods

[image] [image]

.NET Framework Class Library
PatternSendTrack Methods
PatternSendTrack Class See Also Send Feedback

The PatternSendTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternSendTrack Class


PatternSendTrack Properties

[image] [image]

.NET Framework Class Library
PatternSendTrack Properties
PatternSendTrack Class See Also Send Feedback

The PatternSendTrack type exposes the following members.

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternSendTrack Class


type Property

[image]

.NET Framework Class Library
PatternSendTrack..::.type Property
PatternSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PatternSendTrack Class


PatternSequenceData Class

[image]

.NET Framework Class Library
PatternSequenceData Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternSequenceData
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternSequenceData
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternSequenceData
JavaScript
NRenoiseTools.PatternSequenceData = function();

Type.createClass(
    'NRenoiseTools.PatternSequenceData');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PatternSequenceData

See Also

PatternSequenceData Members


PatternSequenceData Members

[image] [image]

.NET Framework Class Library
PatternSequenceData Members
PatternSequenceData Class Constructors Methods Properties See Also Send Feedback

The PatternSequenceData type exposes the following members.

Constructors

Name | Description
PatternSequenceData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HighliteOffset |
HighliteStep |
LoopSelection |
PatternNameWidth |
PatternSequence |

See Also

PatternSequenceData Class


PatternSequenceData Constructor

[image]

.NET Framework Class Library
PatternSequenceData Constructor
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternSequenceData()
Visual C++
public:
PatternSequenceData()
JavaScript
NRenoiseTools.PatternSequenceData = function();

See Also

PatternSequenceData Class


PatternSequenceData Methods

[image] [image]

.NET Framework Class Library
PatternSequenceData Methods
PatternSequenceData Class See Also Send Feedback

The PatternSequenceData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternSequenceData Class


PatternSequenceData Properties

[image] [image]

.NET Framework Class Library
PatternSequenceData Properties
PatternSequenceData Class See Also Send Feedback

The PatternSequenceData type exposes the following members.

Properties

Name | Description
HighliteOffset |
HighliteStep |
LoopSelection |
PatternNameWidth |
PatternSequence |

See Also

PatternSequenceData Class


HighliteOffset Property

[image]

.NET Framework Class Library
PatternSequenceData..::.HighliteOffset Property
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HighliteOffset As Integer
C#
public int HighliteOffset { get; set; }
Visual C++
public:
property int HighliteOffset {
    int get ();
    void set (int value);
}
JavaScript
function get_highliteOffset();
function set_highliteOffset(value);

Remarks

See Also

PatternSequenceData Class


HighliteStep Property

[image]

.NET Framework Class Library
PatternSequenceData..::.HighliteStep Property
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property HighliteStep As Integer
C#
public int HighliteStep { get; set; }
Visual C++
public:
property int HighliteStep {
    int get ();
    void set (int value);
}
JavaScript
function get_highliteStep();
function set_highliteStep(value);

Remarks

See Also

PatternSequenceData Class


LoopSelection Property

[image]

.NET Framework Class Library
PatternSequenceData..::.LoopSelection Property
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopSelection As LoopSelection
C#
public LoopSelection LoopSelection { get; set; }
Visual C++
public:
property LoopSelection^ LoopSelection {
    LoopSelection^ get ();
    void set (LoopSelection^ value);
}
JavaScript
function get_loopSelection();
function set_loopSelection(value);

Remarks

See Also

PatternSequenceData Class


PatternNameWidth Property

[image]

.NET Framework Class Library
PatternSequenceData..::.PatternNameWidth Property
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternNameWidth As Integer
C#
public int PatternNameWidth { get; set; }
Visual C++
public:
property int PatternNameWidth {
    int get ();
    void set (int value);
}
JavaScript
function get_patternNameWidth();
function set_patternNameWidth(value);

Remarks

See Also

PatternSequenceData Class


PatternSequence Property

[image]

.NET Framework Class Library
PatternSequenceData..::.PatternSequence Property
PatternSequenceData Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternSequence As Integer()
C#
public int[] PatternSequence { get; set; }
Visual C++
public:
property array<int>^ PatternSequence {
    array<int>^ get ();
    void set (array<int>^ value);
}
JavaScript
function get_patternSequence();
function set_patternSequence(value);

Remarks

See Also

PatternSequenceData Class


PatternTrack Class

[image]

.NET Framework Class Library
PatternTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternTrack _
    Inherits Track
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternTrack : Track
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternTrack : public Track
JavaScript
NRenoiseTools.PatternTrack = function();

Type.createClass(
    'NRenoiseTools.PatternTrack',
    NRenoiseTools.Track);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Track
NRenoiseTools..::.PatternTrack

See Also

PatternTrack Members


PatternTrack Members

[image] [image]

.NET Framework Class Library
PatternTrack Members
PatternTrack Class Constructors Methods Properties See Also Send Feedback

The PatternTrack type exposes the following members.

Constructors

Name | Description
PatternTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternTrack Class


PatternTrack Constructor

[image]

.NET Framework Class Library
PatternTrack Constructor
PatternTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternTrack()
Visual C++
public:
PatternTrack()
JavaScript
NRenoiseTools.PatternTrack = function();

See Also

PatternTrack Class


PatternTrack Methods

[image] [image]

.NET Framework Class Library
PatternTrack Methods
PatternTrack Class See Also Send Feedback

The PatternTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternTrack Class


PatternTrack Properties

[image] [image]

.NET Framework Class Library
PatternTrack Properties
PatternTrack Class See Also Send Feedback

The PatternTrack type exposes the following members.

Properties

Name | Description
Automations | (Inherited from Track.)
Lines | (Inherited from Track.)
type |

See Also

PatternTrack Class


type Property

[image]

.NET Framework Class Library
PatternTrack..::.type Property
PatternTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PatternTrack Class


PatternTracks Class

[image]

.NET Framework Class Library
PatternTracks Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PatternTracks
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PatternTracks
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PatternTracks
JavaScript
NRenoiseTools.PatternTracks = function();

Type.createClass(
    'NRenoiseTools.PatternTracks');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PatternTracks

See Also

PatternTracks Members


PatternTracks Members

[image] [image]

.NET Framework Class Library
PatternTracks Members
PatternTracks Class Constructors Methods Properties See Also Send Feedback

The PatternTracks type exposes the following members.

Constructors

Name | Description
PatternTracks |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PatternMasterTrack |
PatternSendTrack |
PatternTrack |

See Also

PatternTracks Class


PatternTracks Constructor

[image]

.NET Framework Class Library
PatternTracks Constructor
PatternTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PatternTracks()
Visual C++
public:
PatternTracks()
JavaScript
NRenoiseTools.PatternTracks = function();

See Also

PatternTracks Class


PatternTracks Methods

[image] [image]

.NET Framework Class Library
PatternTracks Methods
PatternTracks Class See Also Send Feedback

The PatternTracks type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PatternTracks Class


PatternTracks Properties

[image] [image]

.NET Framework Class Library
PatternTracks Properties
PatternTracks Class See Also Send Feedback

The PatternTracks type exposes the following members.

Properties

Name | Description
PatternMasterTrack |
PatternSendTrack |
PatternTrack |

See Also

PatternTracks Class


PatternMasterTrack Property

[image]

.NET Framework Class Library
PatternTracks..::.PatternMasterTrack Property
PatternTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternMasterTrack As PatternMasterTrack()
C#
public PatternMasterTrack[] PatternMasterTrack { get; set; }
Visual C++
public:
property array<PatternMasterTrack^>^ PatternMasterTrack {
    array<PatternMasterTrack^>^ get ();
    void set (array<PatternMasterTrack^>^ value);
}
JavaScript
function get_patternMasterTrack();
function set_patternMasterTrack(value);

Remarks

See Also

PatternTracks Class


PatternSendTrack Property

[image]

.NET Framework Class Library
PatternTracks..::.PatternSendTrack Property
PatternTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternSendTrack As PatternSendTrack()
C#
public PatternSendTrack[] PatternSendTrack { get; set; }
Visual C++
public:
property array<PatternSendTrack^>^ PatternSendTrack {
    array<PatternSendTrack^>^ get ();
    void set (array<PatternSendTrack^>^ value);
}
JavaScript
function get_patternSendTrack();
function set_patternSendTrack(value);

Remarks

See Also

PatternTracks Class


PatternTrack Property

[image]

.NET Framework Class Library
PatternTracks..::.PatternTrack Property
PatternTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternTrack As PatternTrack()
C#
public PatternTrack[] PatternTrack { get; set; }
Visual C++
public:
property array<PatternTrack^>^ PatternTrack {
    array<PatternTrack^>^ get ();
    void set (array<PatternTrack^>^ value);
}
JavaScript
function get_patternTrack();
function set_patternTrack(value);

Remarks

See Also

PatternTracks Class


PdcTestDelayDevice Class

[image]

.NET Framework Class Library
PdcTestDelayDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDevice
JavaScript
NRenoiseTools.PdcTestDelayDevice = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDevice

See Also

PdcTestDelayDevice Members


PdcTestDelayDevice Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDevice Members
PdcTestDelayDevice Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDevice type exposes the following members.

Constructors

Name | Description
PdcTestDelayDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DelayInMs |
IsActive |
IsSelected |
ReportLatency |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

PdcTestDelayDevice Class


PdcTestDelayDevice Constructor

[image]

.NET Framework Class Library
PdcTestDelayDevice Constructor
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDevice()
Visual C++
public:
PdcTestDelayDevice()
JavaScript
NRenoiseTools.PdcTestDelayDevice = function();

See Also

PdcTestDelayDevice Class


PdcTestDelayDevice Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDevice Methods
PdcTestDelayDevice Class See Also Send Feedback

The PdcTestDelayDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDevice Class


PdcTestDelayDevice Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDevice Properties
PdcTestDelayDevice Class See Also Send Feedback

The PdcTestDelayDevice type exposes the following members.

Properties

Name | Description
DelayInMs |
IsActive |
IsSelected |
ReportLatency |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

PdcTestDelayDevice Class


DelayInMs Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.DelayInMs Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayInMs As PdcTestDelayDeviceDelayInMs
C#
public PdcTestDelayDeviceDelayInMs DelayInMs { get; set; }
Visual C++
public:
property PdcTestDelayDeviceDelayInMs^ DelayInMs {
    PdcTestDelayDeviceDelayInMs^ get ();
    void set (PdcTestDelayDeviceDelayInMs^ value);
}
JavaScript
function get_delayInMs();
function set_delayInMs(value);

Remarks

See Also

PdcTestDelayDevice Class


IsActive Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.IsActive Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

PdcTestDelayDevice Class


IsSelected Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.IsSelected Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

PdcTestDelayDevice Class


ReportLatency Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.ReportLatency Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportLatency As PdcTestDelayDeviceReportLatency
C#
public PdcTestDelayDeviceReportLatency ReportLatency { get; set; }
Visual C++
public:
property PdcTestDelayDeviceReportLatency^ ReportLatency {
    PdcTestDelayDeviceReportLatency^ get ();
    void set (PdcTestDelayDeviceReportLatency^ value);
}
JavaScript
function get_reportLatency();
function set_reportLatency(value);

Remarks

See Also

PdcTestDelayDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.RunTimePresetA Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As PdcTestDelayDeviceRunTimePreset
C#
public PdcTestDelayDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property PdcTestDelayDeviceRunTimePreset^ RunTimePresetA {
    PdcTestDelayDeviceRunTimePreset^ get ();
    void set (PdcTestDelayDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

PdcTestDelayDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.RunTimePresetB Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As PdcTestDelayDeviceRunTimePreset
C#
public PdcTestDelayDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property PdcTestDelayDeviceRunTimePreset^ RunTimePresetB {
    PdcTestDelayDeviceRunTimePreset^ get ();
    void set (PdcTestDelayDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

PdcTestDelayDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.SelectedPresetIsModified Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

PdcTestDelayDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.SelectedPresetName Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

PdcTestDelayDevice Class


type Property

[image]

.NET Framework Class Library
PdcTestDelayDevice..::.type Property
PdcTestDelayDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PdcTestDelayDevice Class


PdcTestDelayDeviceDelayInMs Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceDelayInMs
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceDelayInMs
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceDelayInMs
JavaScript
NRenoiseTools.PdcTestDelayDeviceDelayInMs = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceDelayInMs');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceDelayInMs

See Also

PdcTestDelayDeviceDelayInMs Members


PdcTestDelayDeviceDelayInMs Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs Members
PdcTestDelayDeviceDelayInMs Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceDelayInMs type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceDelayInMs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PdcTestDelayDeviceDelayInMs Class


PdcTestDelayDeviceDelayInMs Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs Constructor
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceDelayInMs()
Visual C++
public:
PdcTestDelayDeviceDelayInMs()
JavaScript
NRenoiseTools.PdcTestDelayDeviceDelayInMs = function();

See Also

PdcTestDelayDeviceDelayInMs Class


PdcTestDelayDeviceDelayInMs Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs Methods
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

The PdcTestDelayDeviceDelayInMs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceDelayInMs Class


PdcTestDelayDeviceDelayInMs Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs Properties
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

The PdcTestDelayDeviceDelayInMs type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PdcTestDelayDeviceDelayInMs Class


MidiMappings Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs..::.MidiMappings Property
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PdcTestDelayDeviceDelayInMs Class


Value Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs..::.Value Property
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PdcTestDelayDeviceDelayInMs Class


Visualization Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMs..::.Visualization Property
PdcTestDelayDeviceDelayInMs Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PdcTestDelayDeviceDelayInMsVisualization
C#
public PdcTestDelayDeviceDelayInMsVisualization Visualization { get; set; }
Visual C++
public:
property PdcTestDelayDeviceDelayInMsVisualization Visualization {
    PdcTestDelayDeviceDelayInMsVisualization get ();
    void set (PdcTestDelayDeviceDelayInMsVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PdcTestDelayDeviceDelayInMs Class


PdcTestDelayDeviceDelayInMsRunTimePreset Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceDelayInMsRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceDelayInMsRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceDelayInMsRunTimePreset
JavaScript
NRenoiseTools.PdcTestDelayDeviceDelayInMsRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceDelayInMsRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceDelayInMsRunTimePreset

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Members


PdcTestDelayDeviceDelayInMsRunTimePreset Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset Members
PdcTestDelayDeviceDelayInMsRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceDelayInMsRunTimePreset type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceDelayInMsRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Class


PdcTestDelayDeviceDelayInMsRunTimePreset Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset Constructor
PdcTestDelayDeviceDelayInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceDelayInMsRunTimePreset()
Visual C++
public:
PdcTestDelayDeviceDelayInMsRunTimePreset()
JavaScript
NRenoiseTools.PdcTestDelayDeviceDelayInMsRunTimePreset = function();

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Class


PdcTestDelayDeviceDelayInMsRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset Methods
PdcTestDelayDeviceDelayInMsRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceDelayInMsRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Class


PdcTestDelayDeviceDelayInMsRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset Properties
PdcTestDelayDeviceDelayInMsRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceDelayInMsRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsRunTimePreset..::.Value Property
PdcTestDelayDeviceDelayInMsRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PdcTestDelayDeviceDelayInMsRunTimePreset Class


PdcTestDelayDeviceDelayInMsVisualization Enumeration

[image]

.NET Framework Class Library
PdcTestDelayDeviceDelayInMsVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PdcTestDelayDeviceDelayInMsVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PdcTestDelayDeviceDelayInMsVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PdcTestDelayDeviceDelayInMsVisualization
JavaScript
NRenoiseTools.PdcTestDelayDeviceDelayInMsVisualization = function();
NRenoiseTools.PdcTestDelayDeviceDelayInMsVisualization.createEnum('NRenoiseTools.PdcTestDelayDeviceDelayInMsVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PdcTestDelayDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.PdcTestDelayDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceDeviceSlotRunTimePreset

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Members


PdcTestDelayDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset Members
PdcTestDelayDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DelayInMs |
ReportLatency |
type |

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


PdcTestDelayDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset Constructor
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceDeviceSlotRunTimePreset()
Visual C++
public:
PdcTestDelayDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.PdcTestDelayDeviceDeviceSlotRunTimePreset = function();

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


PdcTestDelayDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset Methods
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


PdcTestDelayDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset Properties
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
DelayInMs |
ReportLatency |
type |

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


DelayInMs Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset..::.DelayInMs Property
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayInMs As PdcTestDelayDeviceDelayInMsRunTimePreset
C#
public PdcTestDelayDeviceDelayInMsRunTimePreset DelayInMs { get; set; }
Visual C++
public:
property PdcTestDelayDeviceDelayInMsRunTimePreset^ DelayInMs {
    PdcTestDelayDeviceDelayInMsRunTimePreset^ get ();
    void set (PdcTestDelayDeviceDelayInMsRunTimePreset^ value);
}
JavaScript
function get_delayInMs();
function set_delayInMs(value);

Remarks

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


ReportLatency Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset..::.ReportLatency Property
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportLatency As PdcTestDelayDeviceReportLatencyRunTimePreset
C#
public PdcTestDelayDeviceReportLatencyRunTimePreset ReportLatency { get; set; }
Visual C++
public:
property PdcTestDelayDeviceReportLatencyRunTimePreset^ ReportLatency {
    PdcTestDelayDeviceReportLatencyRunTimePreset^ get ();
    void set (PdcTestDelayDeviceReportLatencyRunTimePreset^ value);
}
JavaScript
function get_reportLatency();
function set_reportLatency(value);

Remarks

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceDeviceSlotRunTimePreset..::.type Property
PdcTestDelayDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PdcTestDelayDeviceDeviceSlotRunTimePreset Class


PdcTestDelayDeviceReportLatency Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceReportLatency
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceReportLatency
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceReportLatency
JavaScript
NRenoiseTools.PdcTestDelayDeviceReportLatency = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceReportLatency');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceReportLatency

See Also

PdcTestDelayDeviceReportLatency Members


PdcTestDelayDeviceReportLatency Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency Members
PdcTestDelayDeviceReportLatency Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceReportLatency type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceReportLatency |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PdcTestDelayDeviceReportLatency Class


PdcTestDelayDeviceReportLatency Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency Constructor
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceReportLatency()
Visual C++
public:
PdcTestDelayDeviceReportLatency()
JavaScript
NRenoiseTools.PdcTestDelayDeviceReportLatency = function();

See Also

PdcTestDelayDeviceReportLatency Class


PdcTestDelayDeviceReportLatency Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency Methods
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

The PdcTestDelayDeviceReportLatency type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceReportLatency Class


PdcTestDelayDeviceReportLatency Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency Properties
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

The PdcTestDelayDeviceReportLatency type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PdcTestDelayDeviceReportLatency Class


MidiMappings Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency..::.MidiMappings Property
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PdcTestDelayDeviceReportLatency Class


Value Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency..::.Value Property
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PdcTestDelayDeviceReportLatency Class


Visualization Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatency..::.Visualization Property
PdcTestDelayDeviceReportLatency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PdcTestDelayDeviceReportLatencyVisualization
C#
public PdcTestDelayDeviceReportLatencyVisualization Visualization { get; set; }
Visual C++
public:
property PdcTestDelayDeviceReportLatencyVisualization Visualization {
    PdcTestDelayDeviceReportLatencyVisualization get ();
    void set (PdcTestDelayDeviceReportLatencyVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PdcTestDelayDeviceReportLatency Class


PdcTestDelayDeviceReportLatencyRunTimePreset Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceReportLatencyRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceReportLatencyRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceReportLatencyRunTimePreset
JavaScript
NRenoiseTools.PdcTestDelayDeviceReportLatencyRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceReportLatencyRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceReportLatencyRunTimePreset

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Members


PdcTestDelayDeviceReportLatencyRunTimePreset Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset Members
PdcTestDelayDeviceReportLatencyRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceReportLatencyRunTimePreset type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceReportLatencyRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Class


PdcTestDelayDeviceReportLatencyRunTimePreset Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset Constructor
PdcTestDelayDeviceReportLatencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceReportLatencyRunTimePreset()
Visual C++
public:
PdcTestDelayDeviceReportLatencyRunTimePreset()
JavaScript
NRenoiseTools.PdcTestDelayDeviceReportLatencyRunTimePreset = function();

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Class


PdcTestDelayDeviceReportLatencyRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset Methods
PdcTestDelayDeviceReportLatencyRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceReportLatencyRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Class


PdcTestDelayDeviceReportLatencyRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset Properties
PdcTestDelayDeviceReportLatencyRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceReportLatencyRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyRunTimePreset..::.Value Property
PdcTestDelayDeviceReportLatencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PdcTestDelayDeviceReportLatencyRunTimePreset Class


PdcTestDelayDeviceReportLatencyVisualization Enumeration

[image]

.NET Framework Class Library
PdcTestDelayDeviceReportLatencyVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PdcTestDelayDeviceReportLatencyVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PdcTestDelayDeviceReportLatencyVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PdcTestDelayDeviceReportLatencyVisualization
JavaScript
NRenoiseTools.PdcTestDelayDeviceReportLatencyVisualization = function();
NRenoiseTools.PdcTestDelayDeviceReportLatencyVisualization.createEnum('NRenoiseTools.PdcTestDelayDeviceReportLatencyVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PdcTestDelayDeviceRunTimePreset Class

[image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PdcTestDelayDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PdcTestDelayDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PdcTestDelayDeviceRunTimePreset
JavaScript
NRenoiseTools.PdcTestDelayDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PdcTestDelayDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PdcTestDelayDeviceRunTimePreset

See Also

PdcTestDelayDeviceRunTimePreset Members


PdcTestDelayDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset Members
PdcTestDelayDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PdcTestDelayDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
PdcTestDelayDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

PdcTestDelayDeviceRunTimePreset Class


PdcTestDelayDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset Constructor
PdcTestDelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdcTestDelayDeviceRunTimePreset()
Visual C++
public:
PdcTestDelayDeviceRunTimePreset()
JavaScript
NRenoiseTools.PdcTestDelayDeviceRunTimePreset = function();

See Also

PdcTestDelayDeviceRunTimePreset Class


PdcTestDelayDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset Methods
PdcTestDelayDeviceRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdcTestDelayDeviceRunTimePreset Class


PdcTestDelayDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset Properties
PdcTestDelayDeviceRunTimePreset Class See Also Send Feedback

The PdcTestDelayDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

PdcTestDelayDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset..::.DeviceSlot Property
PdcTestDelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As PdcTestDelayDeviceDeviceSlotRunTimePreset
C#
public PdcTestDelayDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property PdcTestDelayDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    PdcTestDelayDeviceDeviceSlotRunTimePreset^ get ();
    void set (PdcTestDelayDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

PdcTestDelayDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
PdcTestDelayDeviceRunTimePreset..::.type Property
PdcTestDelayDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PdcTestDelayDeviceRunTimePreset Class


PhaserDevice Class

[image]

.NET Framework Class Library
PhaserDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDevice
JavaScript
NRenoiseTools.PhaserDevice = function();

Type.createClass(
    'NRenoiseTools.PhaserDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDevice

See Also

PhaserDevice Members


PhaserDevice Members

[image] [image]

.NET Framework Class Library
PhaserDevice Members
PhaserDevice Class Constructors Methods Properties See Also Send Feedback

The PhaserDevice type exposes the following members.

Constructors

Name | Description
PhaserDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ceilling |
Depth |
Feedback |
Floor |
IsActive |
IsSelected |
LFORate |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Stages |
type |

See Also

PhaserDevice Class


PhaserDevice Constructor

[image]

.NET Framework Class Library
PhaserDevice Constructor
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDevice()
Visual C++
public:
PhaserDevice()
JavaScript
NRenoiseTools.PhaserDevice = function();

See Also

PhaserDevice Class


PhaserDevice Methods

[image] [image]

.NET Framework Class Library
PhaserDevice Methods
PhaserDevice Class See Also Send Feedback

The PhaserDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDevice Class


PhaserDevice Properties

[image] [image]

.NET Framework Class Library
PhaserDevice Properties
PhaserDevice Class See Also Send Feedback

The PhaserDevice type exposes the following members.

Properties

Name | Description
Ceilling |
Depth |
Feedback |
Floor |
IsActive |
IsSelected |
LFORate |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Stages |
type |

See Also

PhaserDevice Class


Ceilling Property

[image]

.NET Framework Class Library
PhaserDevice..::.Ceilling Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ceilling As PhaserDeviceCeilling
C#
public PhaserDeviceCeilling Ceilling { get; set; }
Visual C++
public:
property PhaserDeviceCeilling^ Ceilling {
    PhaserDeviceCeilling^ get ();
    void set (PhaserDeviceCeilling^ value);
}
JavaScript
function get_ceilling();
function set_ceilling(value);

Remarks

See Also

PhaserDevice Class


Depth Property

[image]

.NET Framework Class Library
PhaserDevice..::.Depth Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Depth As PhaserDeviceDepth
C#
public PhaserDeviceDepth Depth { get; set; }
Visual C++
public:
property PhaserDeviceDepth^ Depth {
    PhaserDeviceDepth^ get ();
    void set (PhaserDeviceDepth^ value);
}
JavaScript
function get_depth();
function set_depth(value);

Remarks

See Also

PhaserDevice Class


Feedback Property

[image]

.NET Framework Class Library
PhaserDevice..::.Feedback Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Feedback As PhaserDeviceFeedback
C#
public PhaserDeviceFeedback Feedback { get; set; }
Visual C++
public:
property PhaserDeviceFeedback^ Feedback {
    PhaserDeviceFeedback^ get ();
    void set (PhaserDeviceFeedback^ value);
}
JavaScript
function get_feedback();
function set_feedback(value);

Remarks

See Also

PhaserDevice Class


Floor Property

[image]

.NET Framework Class Library
PhaserDevice..::.Floor Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Floor As PhaserDeviceFloor
C#
public PhaserDeviceFloor Floor { get; set; }
Visual C++
public:
property PhaserDeviceFloor^ Floor {
    PhaserDeviceFloor^ get ();
    void set (PhaserDeviceFloor^ value);
}
JavaScript
function get_floor();
function set_floor(value);

Remarks

See Also

PhaserDevice Class


IsActive Property

[image]

.NET Framework Class Library
PhaserDevice..::.IsActive Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

PhaserDevice Class


IsSelected Property

[image]

.NET Framework Class Library
PhaserDevice..::.IsSelected Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

PhaserDevice Class


LFORate Property

[image]

.NET Framework Class Library
PhaserDevice..::.LFORate Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LFORate As PhaserDeviceLFORate
C#
public PhaserDeviceLFORate LFORate { get; set; }
Visual C++
public:
property PhaserDeviceLFORate^ LFORate {
    PhaserDeviceLFORate^ get ();
    void set (PhaserDeviceLFORate^ value);
}
JavaScript
function get_lfoRate();
function set_lfoRate(value);

Remarks

See Also

PhaserDevice Class


Phase Property

[image]

.NET Framework Class Library
PhaserDevice..::.Phase Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As PhaserDevicePhase
C#
public PhaserDevicePhase Phase { get; set; }
Visual C++
public:
property PhaserDevicePhase^ Phase {
    PhaserDevicePhase^ get ();
    void set (PhaserDevicePhase^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

PhaserDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
PhaserDevice..::.RunTimePresetA Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As PhaserDeviceRunTimePreset
C#
public PhaserDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property PhaserDeviceRunTimePreset^ RunTimePresetA {
    PhaserDeviceRunTimePreset^ get ();
    void set (PhaserDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

PhaserDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
PhaserDevice..::.RunTimePresetB Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As PhaserDeviceRunTimePreset
C#
public PhaserDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property PhaserDeviceRunTimePreset^ RunTimePresetB {
    PhaserDeviceRunTimePreset^ get ();
    void set (PhaserDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

PhaserDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
PhaserDevice..::.SelectedPresetIsModified Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

PhaserDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
PhaserDevice..::.SelectedPresetName Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

PhaserDevice Class


Stages Property

[image]

.NET Framework Class Library
PhaserDevice..::.Stages Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Stages As PhaserDeviceStages
C#
public PhaserDeviceStages Stages { get; set; }
Visual C++
public:
property PhaserDeviceStages^ Stages {
    PhaserDeviceStages^ get ();
    void set (PhaserDeviceStages^ value);
}
JavaScript
function get_stages();
function set_stages(value);

Remarks

See Also

PhaserDevice Class


type Property

[image]

.NET Framework Class Library
PhaserDevice..::.type Property
PhaserDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PhaserDevice Class


PhaserDeviceCeilling Class

[image]

.NET Framework Class Library
PhaserDeviceCeilling Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceCeilling
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceCeilling
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceCeilling
JavaScript
NRenoiseTools.PhaserDeviceCeilling = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceCeilling');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceCeilling

See Also

PhaserDeviceCeilling Members


PhaserDeviceCeilling Members

[image] [image]

.NET Framework Class Library
PhaserDeviceCeilling Members
PhaserDeviceCeilling Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceCeilling type exposes the following members.

Constructors

Name | Description
PhaserDeviceCeilling |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceCeilling Class


PhaserDeviceCeilling Constructor

[image]

.NET Framework Class Library
PhaserDeviceCeilling Constructor
PhaserDeviceCeilling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceCeilling()
Visual C++
public:
PhaserDeviceCeilling()
JavaScript
NRenoiseTools.PhaserDeviceCeilling = function();

See Also

PhaserDeviceCeilling Class


PhaserDeviceCeilling Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceCeilling Methods
PhaserDeviceCeilling Class See Also Send Feedback

The PhaserDeviceCeilling type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceCeilling Class


PhaserDeviceCeilling Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceCeilling Properties
PhaserDeviceCeilling Class See Also Send Feedback

The PhaserDeviceCeilling type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceCeilling Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceCeilling..::.MidiMappings Property
PhaserDeviceCeilling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceCeilling Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceCeilling..::.Value Property
PhaserDeviceCeilling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceCeilling Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceCeilling..::.Visualization Property
PhaserDeviceCeilling Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceCeillingVisualization
C#
public PhaserDeviceCeillingVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceCeillingVisualization Visualization {
    PhaserDeviceCeillingVisualization get ();
    void set (PhaserDeviceCeillingVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceCeilling Class


PhaserDeviceCeillingRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceCeillingRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceCeillingRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceCeillingRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceCeillingRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceCeillingRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceCeillingRunTimePreset

See Also

PhaserDeviceCeillingRunTimePreset Members


PhaserDeviceCeillingRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset Members
PhaserDeviceCeillingRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceCeillingRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceCeillingRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceCeillingRunTimePreset Class


PhaserDeviceCeillingRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset Constructor
PhaserDeviceCeillingRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceCeillingRunTimePreset()
Visual C++
public:
PhaserDeviceCeillingRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceCeillingRunTimePreset = function();

See Also

PhaserDeviceCeillingRunTimePreset Class


PhaserDeviceCeillingRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset Methods
PhaserDeviceCeillingRunTimePreset Class See Also Send Feedback

The PhaserDeviceCeillingRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceCeillingRunTimePreset Class


PhaserDeviceCeillingRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset Properties
PhaserDeviceCeillingRunTimePreset Class See Also Send Feedback

The PhaserDeviceCeillingRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceCeillingRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceCeillingRunTimePreset..::.Value Property
PhaserDeviceCeillingRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceCeillingRunTimePreset Class


PhaserDeviceCeillingVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceCeillingVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceCeillingVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceCeillingVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceCeillingVisualization
JavaScript
NRenoiseTools.PhaserDeviceCeillingVisualization = function();
NRenoiseTools.PhaserDeviceCeillingVisualization.createEnum('NRenoiseTools.PhaserDeviceCeillingVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDeviceDepth Class

[image]

.NET Framework Class Library
PhaserDeviceDepth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceDepth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceDepth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceDepth
JavaScript
NRenoiseTools.PhaserDeviceDepth = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceDepth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceDepth

See Also

PhaserDeviceDepth Members


PhaserDeviceDepth Members

[image] [image]

.NET Framework Class Library
PhaserDeviceDepth Members
PhaserDeviceDepth Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceDepth type exposes the following members.

Constructors

Name | Description
PhaserDeviceDepth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceDepth Class


PhaserDeviceDepth Constructor

[image]

.NET Framework Class Library
PhaserDeviceDepth Constructor
PhaserDeviceDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceDepth()
Visual C++
public:
PhaserDeviceDepth()
JavaScript
NRenoiseTools.PhaserDeviceDepth = function();

See Also

PhaserDeviceDepth Class


PhaserDeviceDepth Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceDepth Methods
PhaserDeviceDepth Class See Also Send Feedback

The PhaserDeviceDepth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceDepth Class


PhaserDeviceDepth Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceDepth Properties
PhaserDeviceDepth Class See Also Send Feedback

The PhaserDeviceDepth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceDepth Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceDepth..::.MidiMappings Property
PhaserDeviceDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceDepth Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceDepth..::.Value Property
PhaserDeviceDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceDepth Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceDepth..::.Visualization Property
PhaserDeviceDepth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceDepthVisualization
C#
public PhaserDeviceDepthVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceDepthVisualization Visualization {
    PhaserDeviceDepthVisualization get ();
    void set (PhaserDeviceDepthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceDepth Class


PhaserDeviceDepthRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceDepthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceDepthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceDepthRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceDepthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceDepthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceDepthRunTimePreset

See Also

PhaserDeviceDepthRunTimePreset Members


PhaserDeviceDepthRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset Members
PhaserDeviceDepthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceDepthRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceDepthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceDepthRunTimePreset Class


PhaserDeviceDepthRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset Constructor
PhaserDeviceDepthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceDepthRunTimePreset()
Visual C++
public:
PhaserDeviceDepthRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceDepthRunTimePreset = function();

See Also

PhaserDeviceDepthRunTimePreset Class


PhaserDeviceDepthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset Methods
PhaserDeviceDepthRunTimePreset Class See Also Send Feedback

The PhaserDeviceDepthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceDepthRunTimePreset Class


PhaserDeviceDepthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset Properties
PhaserDeviceDepthRunTimePreset Class See Also Send Feedback

The PhaserDeviceDepthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceDepthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceDepthRunTimePreset..::.Value Property
PhaserDeviceDepthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceDepthRunTimePreset Class


PhaserDeviceDepthVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceDepthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceDepthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceDepthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceDepthVisualization
JavaScript
NRenoiseTools.PhaserDeviceDepthVisualization = function();
NRenoiseTools.PhaserDeviceDepthVisualization.createEnum('NRenoiseTools.PhaserDeviceDepthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceDeviceSlotRunTimePreset

See Also

PhaserDeviceDeviceSlotRunTimePreset Members


PhaserDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset Members
PhaserDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Ceilling |
Depth |
Feedback |
Floor |
LFORate |
Phase |
Stages |
type |

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


PhaserDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset Constructor
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceDeviceSlotRunTimePreset()
Visual C++
public:
PhaserDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceDeviceSlotRunTimePreset = function();

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


PhaserDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset Methods
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The PhaserDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


PhaserDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset Properties
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The PhaserDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Ceilling |
Depth |
Feedback |
Floor |
LFORate |
Phase |
Stages |
type |

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Ceilling Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Ceilling Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ceilling As PhaserDeviceCeillingRunTimePreset
C#
public PhaserDeviceCeillingRunTimePreset Ceilling { get; set; }
Visual C++
public:
property PhaserDeviceCeillingRunTimePreset^ Ceilling {
    PhaserDeviceCeillingRunTimePreset^ get ();
    void set (PhaserDeviceCeillingRunTimePreset^ value);
}
JavaScript
function get_ceilling();
function set_ceilling(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Depth Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Depth Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Depth As PhaserDeviceDepthRunTimePreset
C#
public PhaserDeviceDepthRunTimePreset Depth { get; set; }
Visual C++
public:
property PhaserDeviceDepthRunTimePreset^ Depth {
    PhaserDeviceDepthRunTimePreset^ get ();
    void set (PhaserDeviceDepthRunTimePreset^ value);
}
JavaScript
function get_depth();
function set_depth(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Feedback Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Feedback Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Feedback As PhaserDeviceFeedbackRunTimePreset
C#
public PhaserDeviceFeedbackRunTimePreset Feedback { get; set; }
Visual C++
public:
property PhaserDeviceFeedbackRunTimePreset^ Feedback {
    PhaserDeviceFeedbackRunTimePreset^ get ();
    void set (PhaserDeviceFeedbackRunTimePreset^ value);
}
JavaScript
function get_feedback();
function set_feedback(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Floor Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Floor Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Floor As PhaserDeviceFloorRunTimePreset
C#
public PhaserDeviceFloorRunTimePreset Floor { get; set; }
Visual C++
public:
property PhaserDeviceFloorRunTimePreset^ Floor {
    PhaserDeviceFloorRunTimePreset^ get ();
    void set (PhaserDeviceFloorRunTimePreset^ value);
}
JavaScript
function get_floor();
function set_floor(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


LFORate Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.LFORate Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LFORate As PhaserDeviceLFORateRunTimePreset
C#
public PhaserDeviceLFORateRunTimePreset LFORate { get; set; }
Visual C++
public:
property PhaserDeviceLFORateRunTimePreset^ LFORate {
    PhaserDeviceLFORateRunTimePreset^ get ();
    void set (PhaserDeviceLFORateRunTimePreset^ value);
}
JavaScript
function get_lfoRate();
function set_lfoRate(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Phase Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Phase Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As PhaserDevicePhaseRunTimePreset
C#
public PhaserDevicePhaseRunTimePreset Phase { get; set; }
Visual C++
public:
property PhaserDevicePhaseRunTimePreset^ Phase {
    PhaserDevicePhaseRunTimePreset^ get ();
    void set (PhaserDevicePhaseRunTimePreset^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


Stages Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.Stages Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Stages As PhaserDeviceStagesRunTimePreset
C#
public PhaserDeviceStagesRunTimePreset Stages { get; set; }
Visual C++
public:
property PhaserDeviceStagesRunTimePreset^ Stages {
    PhaserDeviceStagesRunTimePreset^ get ();
    void set (PhaserDeviceStagesRunTimePreset^ value);
}
JavaScript
function get_stages();
function set_stages(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
PhaserDeviceDeviceSlotRunTimePreset..::.type Property
PhaserDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PhaserDeviceDeviceSlotRunTimePreset Class


PhaserDeviceFeedback Class

[image]

.NET Framework Class Library
PhaserDeviceFeedback Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceFeedback
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceFeedback
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceFeedback
JavaScript
NRenoiseTools.PhaserDeviceFeedback = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceFeedback');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceFeedback

See Also

PhaserDeviceFeedback Members


PhaserDeviceFeedback Members

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedback Members
PhaserDeviceFeedback Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceFeedback type exposes the following members.

Constructors

Name | Description
PhaserDeviceFeedback |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceFeedback Class


PhaserDeviceFeedback Constructor

[image]

.NET Framework Class Library
PhaserDeviceFeedback Constructor
PhaserDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceFeedback()
Visual C++
public:
PhaserDeviceFeedback()
JavaScript
NRenoiseTools.PhaserDeviceFeedback = function();

See Also

PhaserDeviceFeedback Class


PhaserDeviceFeedback Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedback Methods
PhaserDeviceFeedback Class See Also Send Feedback

The PhaserDeviceFeedback type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceFeedback Class


PhaserDeviceFeedback Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedback Properties
PhaserDeviceFeedback Class See Also Send Feedback

The PhaserDeviceFeedback type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceFeedback Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceFeedback..::.MidiMappings Property
PhaserDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceFeedback Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceFeedback..::.Value Property
PhaserDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceFeedback Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceFeedback..::.Visualization Property
PhaserDeviceFeedback Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceFeedbackVisualization
C#
public PhaserDeviceFeedbackVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceFeedbackVisualization Visualization {
    PhaserDeviceFeedbackVisualization get ();
    void set (PhaserDeviceFeedbackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceFeedback Class


PhaserDeviceFeedbackRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceFeedbackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceFeedbackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceFeedbackRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceFeedbackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceFeedbackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceFeedbackRunTimePreset

See Also

PhaserDeviceFeedbackRunTimePreset Members


PhaserDeviceFeedbackRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset Members
PhaserDeviceFeedbackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceFeedbackRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceFeedbackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceFeedbackRunTimePreset Class


PhaserDeviceFeedbackRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset Constructor
PhaserDeviceFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceFeedbackRunTimePreset()
Visual C++
public:
PhaserDeviceFeedbackRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceFeedbackRunTimePreset = function();

See Also

PhaserDeviceFeedbackRunTimePreset Class


PhaserDeviceFeedbackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset Methods
PhaserDeviceFeedbackRunTimePreset Class See Also Send Feedback

The PhaserDeviceFeedbackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceFeedbackRunTimePreset Class


PhaserDeviceFeedbackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset Properties
PhaserDeviceFeedbackRunTimePreset Class See Also Send Feedback

The PhaserDeviceFeedbackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceFeedbackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceFeedbackRunTimePreset..::.Value Property
PhaserDeviceFeedbackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceFeedbackRunTimePreset Class


PhaserDeviceFeedbackVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceFeedbackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceFeedbackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceFeedbackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceFeedbackVisualization
JavaScript
NRenoiseTools.PhaserDeviceFeedbackVisualization = function();
NRenoiseTools.PhaserDeviceFeedbackVisualization.createEnum('NRenoiseTools.PhaserDeviceFeedbackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDeviceFloor Class

[image]

.NET Framework Class Library
PhaserDeviceFloor Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceFloor
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceFloor
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceFloor
JavaScript
NRenoiseTools.PhaserDeviceFloor = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceFloor');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceFloor

See Also

PhaserDeviceFloor Members


PhaserDeviceFloor Members

[image] [image]

.NET Framework Class Library
PhaserDeviceFloor Members
PhaserDeviceFloor Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceFloor type exposes the following members.

Constructors

Name | Description
PhaserDeviceFloor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceFloor Class


PhaserDeviceFloor Constructor

[image]

.NET Framework Class Library
PhaserDeviceFloor Constructor
PhaserDeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceFloor()
Visual C++
public:
PhaserDeviceFloor()
JavaScript
NRenoiseTools.PhaserDeviceFloor = function();

See Also

PhaserDeviceFloor Class


PhaserDeviceFloor Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceFloor Methods
PhaserDeviceFloor Class See Also Send Feedback

The PhaserDeviceFloor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceFloor Class


PhaserDeviceFloor Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceFloor Properties
PhaserDeviceFloor Class See Also Send Feedback

The PhaserDeviceFloor type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceFloor Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceFloor..::.MidiMappings Property
PhaserDeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceFloor Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceFloor..::.Value Property
PhaserDeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceFloor Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceFloor..::.Visualization Property
PhaserDeviceFloor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceFloorVisualization
C#
public PhaserDeviceFloorVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceFloorVisualization Visualization {
    PhaserDeviceFloorVisualization get ();
    void set (PhaserDeviceFloorVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceFloor Class


PhaserDeviceFloorRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceFloorRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceFloorRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceFloorRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceFloorRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceFloorRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceFloorRunTimePreset

See Also

PhaserDeviceFloorRunTimePreset Members


PhaserDeviceFloorRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset Members
PhaserDeviceFloorRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceFloorRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceFloorRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceFloorRunTimePreset Class


PhaserDeviceFloorRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset Constructor
PhaserDeviceFloorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceFloorRunTimePreset()
Visual C++
public:
PhaserDeviceFloorRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceFloorRunTimePreset = function();

See Also

PhaserDeviceFloorRunTimePreset Class


PhaserDeviceFloorRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset Methods
PhaserDeviceFloorRunTimePreset Class See Also Send Feedback

The PhaserDeviceFloorRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceFloorRunTimePreset Class


PhaserDeviceFloorRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset Properties
PhaserDeviceFloorRunTimePreset Class See Also Send Feedback

The PhaserDeviceFloorRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceFloorRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceFloorRunTimePreset..::.Value Property
PhaserDeviceFloorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceFloorRunTimePreset Class


PhaserDeviceFloorVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceFloorVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceFloorVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceFloorVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceFloorVisualization
JavaScript
NRenoiseTools.PhaserDeviceFloorVisualization = function();
NRenoiseTools.PhaserDeviceFloorVisualization.createEnum('NRenoiseTools.PhaserDeviceFloorVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDeviceLFORate Class

[image]

.NET Framework Class Library
PhaserDeviceLFORate Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceLFORate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceLFORate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceLFORate
JavaScript
NRenoiseTools.PhaserDeviceLFORate = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceLFORate');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceLFORate

See Also

PhaserDeviceLFORate Members


PhaserDeviceLFORate Members

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORate Members
PhaserDeviceLFORate Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceLFORate type exposes the following members.

Constructors

Name | Description
PhaserDeviceLFORate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceLFORate Class


PhaserDeviceLFORate Constructor

[image]

.NET Framework Class Library
PhaserDeviceLFORate Constructor
PhaserDeviceLFORate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceLFORate()
Visual C++
public:
PhaserDeviceLFORate()
JavaScript
NRenoiseTools.PhaserDeviceLFORate = function();

See Also

PhaserDeviceLFORate Class


PhaserDeviceLFORate Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORate Methods
PhaserDeviceLFORate Class See Also Send Feedback

The PhaserDeviceLFORate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceLFORate Class


PhaserDeviceLFORate Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORate Properties
PhaserDeviceLFORate Class See Also Send Feedback

The PhaserDeviceLFORate type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceLFORate Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceLFORate..::.MidiMappings Property
PhaserDeviceLFORate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceLFORate Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceLFORate..::.Value Property
PhaserDeviceLFORate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceLFORate Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceLFORate..::.Visualization Property
PhaserDeviceLFORate Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceLFORateVisualization
C#
public PhaserDeviceLFORateVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceLFORateVisualization Visualization {
    PhaserDeviceLFORateVisualization get ();
    void set (PhaserDeviceLFORateVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceLFORate Class


PhaserDeviceLFORateRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceLFORateRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceLFORateRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceLFORateRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceLFORateRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceLFORateRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceLFORateRunTimePreset

See Also

PhaserDeviceLFORateRunTimePreset Members


PhaserDeviceLFORateRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset Members
PhaserDeviceLFORateRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceLFORateRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceLFORateRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceLFORateRunTimePreset Class


PhaserDeviceLFORateRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset Constructor
PhaserDeviceLFORateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceLFORateRunTimePreset()
Visual C++
public:
PhaserDeviceLFORateRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceLFORateRunTimePreset = function();

See Also

PhaserDeviceLFORateRunTimePreset Class


PhaserDeviceLFORateRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset Methods
PhaserDeviceLFORateRunTimePreset Class See Also Send Feedback

The PhaserDeviceLFORateRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceLFORateRunTimePreset Class


PhaserDeviceLFORateRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset Properties
PhaserDeviceLFORateRunTimePreset Class See Also Send Feedback

The PhaserDeviceLFORateRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceLFORateRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceLFORateRunTimePreset..::.Value Property
PhaserDeviceLFORateRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceLFORateRunTimePreset Class


PhaserDeviceLFORateVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceLFORateVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceLFORateVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceLFORateVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceLFORateVisualization
JavaScript
NRenoiseTools.PhaserDeviceLFORateVisualization = function();
NRenoiseTools.PhaserDeviceLFORateVisualization.createEnum('NRenoiseTools.PhaserDeviceLFORateVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDevicePhase Class

[image]

.NET Framework Class Library
PhaserDevicePhase Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDevicePhase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDevicePhase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDevicePhase
JavaScript
NRenoiseTools.PhaserDevicePhase = function();

Type.createClass(
    'NRenoiseTools.PhaserDevicePhase');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDevicePhase

See Also

PhaserDevicePhase Members


PhaserDevicePhase Members

[image] [image]

.NET Framework Class Library
PhaserDevicePhase Members
PhaserDevicePhase Class Constructors Methods Properties See Also Send Feedback

The PhaserDevicePhase type exposes the following members.

Constructors

Name | Description
PhaserDevicePhase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDevicePhase Class


PhaserDevicePhase Constructor

[image]

.NET Framework Class Library
PhaserDevicePhase Constructor
PhaserDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDevicePhase()
Visual C++
public:
PhaserDevicePhase()
JavaScript
NRenoiseTools.PhaserDevicePhase = function();

See Also

PhaserDevicePhase Class


PhaserDevicePhase Methods

[image] [image]

.NET Framework Class Library
PhaserDevicePhase Methods
PhaserDevicePhase Class See Also Send Feedback

The PhaserDevicePhase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDevicePhase Class


PhaserDevicePhase Properties

[image] [image]

.NET Framework Class Library
PhaserDevicePhase Properties
PhaserDevicePhase Class See Also Send Feedback

The PhaserDevicePhase type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDevicePhase Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDevicePhase..::.MidiMappings Property
PhaserDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDevicePhase Class


Value Property

[image]

.NET Framework Class Library
PhaserDevicePhase..::.Value Property
PhaserDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDevicePhase Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDevicePhase..::.Visualization Property
PhaserDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDevicePhaseVisualization
C#
public PhaserDevicePhaseVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDevicePhaseVisualization Visualization {
    PhaserDevicePhaseVisualization get ();
    void set (PhaserDevicePhaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDevicePhase Class


PhaserDevicePhaseRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDevicePhaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDevicePhaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDevicePhaseRunTimePreset
JavaScript
NRenoiseTools.PhaserDevicePhaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDevicePhaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDevicePhaseRunTimePreset

See Also

PhaserDevicePhaseRunTimePreset Members


PhaserDevicePhaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset Members
PhaserDevicePhaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDevicePhaseRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDevicePhaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDevicePhaseRunTimePreset Class


PhaserDevicePhaseRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset Constructor
PhaserDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDevicePhaseRunTimePreset()
Visual C++
public:
PhaserDevicePhaseRunTimePreset()
JavaScript
NRenoiseTools.PhaserDevicePhaseRunTimePreset = function();

See Also

PhaserDevicePhaseRunTimePreset Class


PhaserDevicePhaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset Methods
PhaserDevicePhaseRunTimePreset Class See Also Send Feedback

The PhaserDevicePhaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDevicePhaseRunTimePreset Class


PhaserDevicePhaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset Properties
PhaserDevicePhaseRunTimePreset Class See Also Send Feedback

The PhaserDevicePhaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDevicePhaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDevicePhaseRunTimePreset..::.Value Property
PhaserDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDevicePhaseRunTimePreset Class


PhaserDevicePhaseVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDevicePhaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDevicePhaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDevicePhaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDevicePhaseVisualization
JavaScript
NRenoiseTools.PhaserDevicePhaseVisualization = function();
NRenoiseTools.PhaserDevicePhaseVisualization.createEnum('NRenoiseTools.PhaserDevicePhaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PhaserDeviceRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceRunTimePreset

See Also

PhaserDeviceRunTimePreset Members


PhaserDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceRunTimePreset Members
PhaserDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

PhaserDeviceRunTimePreset Class


PhaserDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceRunTimePreset Constructor
PhaserDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceRunTimePreset()
Visual C++
public:
PhaserDeviceRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceRunTimePreset = function();

See Also

PhaserDeviceRunTimePreset Class


PhaserDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceRunTimePreset Methods
PhaserDeviceRunTimePreset Class See Also Send Feedback

The PhaserDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceRunTimePreset Class


PhaserDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceRunTimePreset Properties
PhaserDeviceRunTimePreset Class See Also Send Feedback

The PhaserDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

PhaserDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
PhaserDeviceRunTimePreset..::.DeviceSlot Property
PhaserDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As PhaserDeviceDeviceSlotRunTimePreset
C#
public PhaserDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property PhaserDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    PhaserDeviceDeviceSlotRunTimePreset^ get ();
    void set (PhaserDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

PhaserDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
PhaserDeviceRunTimePreset..::.type Property
PhaserDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PhaserDeviceRunTimePreset Class


PhaserDeviceStages Class

[image]

.NET Framework Class Library
PhaserDeviceStages Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceStages
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceStages
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceStages
JavaScript
NRenoiseTools.PhaserDeviceStages = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceStages');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceStages

See Also

PhaserDeviceStages Members


PhaserDeviceStages Members

[image] [image]

.NET Framework Class Library
PhaserDeviceStages Members
PhaserDeviceStages Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceStages type exposes the following members.

Constructors

Name | Description
PhaserDeviceStages |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceStages Class


PhaserDeviceStages Constructor

[image]

.NET Framework Class Library
PhaserDeviceStages Constructor
PhaserDeviceStages Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceStages()
Visual C++
public:
PhaserDeviceStages()
JavaScript
NRenoiseTools.PhaserDeviceStages = function();

See Also

PhaserDeviceStages Class


PhaserDeviceStages Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceStages Methods
PhaserDeviceStages Class See Also Send Feedback

The PhaserDeviceStages type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceStages Class


PhaserDeviceStages Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceStages Properties
PhaserDeviceStages Class See Also Send Feedback

The PhaserDeviceStages type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

PhaserDeviceStages Class


MidiMappings Property

[image]

.NET Framework Class Library
PhaserDeviceStages..::.MidiMappings Property
PhaserDeviceStages Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

PhaserDeviceStages Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceStages..::.Value Property
PhaserDeviceStages Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceStages Class


Visualization Property

[image]

.NET Framework Class Library
PhaserDeviceStages..::.Visualization Property
PhaserDeviceStages Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As PhaserDeviceStagesVisualization
C#
public PhaserDeviceStagesVisualization Visualization { get; set; }
Visual C++
public:
property PhaserDeviceStagesVisualization Visualization {
    PhaserDeviceStagesVisualization get ();
    void set (PhaserDeviceStagesVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

PhaserDeviceStages Class


PhaserDeviceStagesRunTimePreset Class

[image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PhaserDeviceStagesRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PhaserDeviceStagesRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PhaserDeviceStagesRunTimePreset
JavaScript
NRenoiseTools.PhaserDeviceStagesRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PhaserDeviceStagesRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PhaserDeviceStagesRunTimePreset

See Also

PhaserDeviceStagesRunTimePreset Members


PhaserDeviceStagesRunTimePreset Members

[image] [image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset Members
PhaserDeviceStagesRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PhaserDeviceStagesRunTimePreset type exposes the following members.

Constructors

Name | Description
PhaserDeviceStagesRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

PhaserDeviceStagesRunTimePreset Class


PhaserDeviceStagesRunTimePreset Constructor

[image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset Constructor
PhaserDeviceStagesRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PhaserDeviceStagesRunTimePreset()
Visual C++
public:
PhaserDeviceStagesRunTimePreset()
JavaScript
NRenoiseTools.PhaserDeviceStagesRunTimePreset = function();

See Also

PhaserDeviceStagesRunTimePreset Class


PhaserDeviceStagesRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset Methods
PhaserDeviceStagesRunTimePreset Class See Also Send Feedback

The PhaserDeviceStagesRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaserDeviceStagesRunTimePreset Class


PhaserDeviceStagesRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset Properties
PhaserDeviceStagesRunTimePreset Class See Also Send Feedback

The PhaserDeviceStagesRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

PhaserDeviceStagesRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
PhaserDeviceStagesRunTimePreset..::.Value Property
PhaserDeviceStagesRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

PhaserDeviceStagesRunTimePreset Class


PhaserDeviceStagesVisualization Enumeration

[image]

.NET Framework Class Library
PhaserDeviceStagesVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PhaserDeviceStagesVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PhaserDeviceStagesVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PhaserDeviceStagesVisualization
JavaScript
NRenoiseTools.PhaserDeviceStagesVisualization = function();
NRenoiseTools.PhaserDeviceStagesVisualization.createEnum('NRenoiseTools.PhaserDeviceStagesVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Pitch Class

[image]

.NET Framework Class Library
Pitch Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Pitch
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Pitch
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Pitch
JavaScript
NRenoiseTools.Pitch = function();

Type.createClass(
    'NRenoiseTools.Pitch');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Pitch

See Also

Pitch Members


Pitch Members

[image] [image]

.NET Framework Class Library
Pitch Members
Pitch Class Constructors Methods Properties See Also Send Feedback

The Pitch type exposes the following members.

Constructors

Name | Description
Pitch |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

Pitch Class


Pitch Constructor

[image]

.NET Framework Class Library
Pitch Constructor
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Pitch()
Visual C++
public:
Pitch()
JavaScript
NRenoiseTools.Pitch = function();

See Also

Pitch Class


Pitch Methods

[image] [image]

.NET Framework Class Library
Pitch Methods
Pitch Class See Also Send Feedback

The Pitch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pitch Class


Pitch Properties

[image] [image]

.NET Framework Class Library
Pitch Properties
Pitch Class See Also Send Feedback

The Pitch type exposes the following members.

Properties

Name | Description
Decay |
InterpolationMode |
IsActive |
Lfo1 |
Lfo2 |
LoopEnd |
LoopMode |
LoopStart |
Nodes |
SustainIsActive |
SustainPos |

See Also

Pitch Class


Decay Property

[image]

.NET Framework Class Library
Pitch..::.Decay Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Decay As Integer
C#
public int Decay { get; set; }
Visual C++
public:
property int Decay {
    int get ();
    void set (int value);
}
JavaScript
function get_decay();
function set_decay(value);

Remarks

See Also

Pitch Class


InterpolationMode Property

[image]

.NET Framework Class Library
Pitch..::.InterpolationMode Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As PitchInterpolationMode
C#
public PitchInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property PitchInterpolationMode InterpolationMode {
    PitchInterpolationMode get ();
    void set (PitchInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

Pitch Class


IsActive Property

[image]

.NET Framework Class Library
Pitch..::.IsActive Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Pitch Class


Lfo1 Property

[image]

.NET Framework Class Library
Pitch..::.Lfo1 Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo1 As Lfo
C#
public Lfo Lfo1 { get; set; }
Visual C++
public:
property Lfo^ Lfo1 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo1();
function set_lfo1(value);

Remarks

See Also

Pitch Class


Lfo2 Property

[image]

.NET Framework Class Library
Pitch..::.Lfo2 Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lfo2 As Lfo
C#
public Lfo Lfo2 { get; set; }
Visual C++
public:
property Lfo^ Lfo2 {
    Lfo^ get ();
    void set (Lfo^ value);
}
JavaScript
function get_lfo2();
function set_lfo2(value);

Remarks

See Also

Pitch Class


LoopEnd Property

[image]

.NET Framework Class Library
Pitch..::.LoopEnd Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As Integer
C#
public int LoopEnd { get; set; }
Visual C++
public:
property int LoopEnd {
    int get ();
    void set (int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

Pitch Class


LoopMode Property

[image]

.NET Framework Class Library
Pitch..::.LoopMode Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As PitchLoopMode
C#
public PitchLoopMode LoopMode { get; set; }
Visual C++
public:
property PitchLoopMode LoopMode {
    PitchLoopMode get ();
    void set (PitchLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

Pitch Class


LoopStart Property

[image]

.NET Framework Class Library
Pitch..::.LoopStart Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As Integer
C#
public int LoopStart { get; set; }
Visual C++
public:
property int LoopStart {
    int get ();
    void set (int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

Pitch Class


Nodes Property

[image]

.NET Framework Class Library
Pitch..::.Nodes Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Nodes As PitchNodes
C#
public PitchNodes Nodes { get; set; }
Visual C++
public:
property PitchNodes^ Nodes {
    PitchNodes^ get ();
    void set (PitchNodes^ value);
}
JavaScript
function get_nodes();
function set_nodes(value);

Remarks

See Also

Pitch Class


SustainIsActive Property

[image]

.NET Framework Class Library
Pitch..::.SustainIsActive Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainIsActive As Boolean
C#
public bool SustainIsActive { get; set; }
Visual C++
public:
property bool SustainIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sustainIsActive();
function set_sustainIsActive(value);

Remarks

See Also

Pitch Class


SustainPos Property

[image]

.NET Framework Class Library
Pitch..::.SustainPos Property
Pitch Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SustainPos As Integer
C#
public int SustainPos { get; set; }
Visual C++
public:
property int SustainPos {
    int get ();
    void set (int value);
}
JavaScript
function get_sustainPos();
function set_sustainPos(value);

Remarks

See Also

Pitch Class


PitchInterpolationMode Enumeration

[image]

.NET Framework Class Library
PitchInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PitchInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PitchInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PitchInterpolationMode
JavaScript
NRenoiseTools.PitchInterpolationMode = function();
NRenoiseTools.PitchInterpolationMode.createEnum('NRenoiseTools.PitchInterpolationMode', false);

Members

Member name | Description
Linear |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PitchLoopMode Enumeration

[image]

.NET Framework Class Library
PitchLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PitchLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PitchLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PitchLoopMode
JavaScript
NRenoiseTools.PitchLoopMode = function();
NRenoiseTools.PitchLoopMode.createEnum('NRenoiseTools.PitchLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PitchNodes Class

[image]

.NET Framework Class Library
PitchNodes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PitchNodes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PitchNodes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PitchNodes
JavaScript
NRenoiseTools.PitchNodes = function();

Type.createClass(
    'NRenoiseTools.PitchNodes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PitchNodes

See Also

PitchNodes Members


PitchNodes Members

[image] [image]

.NET Framework Class Library
PitchNodes Members
PitchNodes Class Constructors Methods Properties See Also Send Feedback

The PitchNodes type exposes the following members.

Constructors

Name | Description
PitchNodes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

PitchNodes Class


PitchNodes Constructor

[image]

.NET Framework Class Library
PitchNodes Constructor
PitchNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PitchNodes()
Visual C++
public:
PitchNodes()
JavaScript
NRenoiseTools.PitchNodes = function();

See Also

PitchNodes Class


PitchNodes Methods

[image] [image]

.NET Framework Class Library
PitchNodes Methods
PitchNodes Class See Also Send Feedback

The PitchNodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PitchNodes Class


PitchNodes Properties

[image] [image]

.NET Framework Class Library
PitchNodes Properties
PitchNodes Class See Also Send Feedback

The PitchNodes type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

PitchNodes Class


Length Property

[image]

.NET Framework Class Library
PitchNodes..::.Length Property
PitchNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

PitchNodes Class


PlayMode Property

[image]

.NET Framework Class Library
PitchNodes..::.PlayMode Property
PitchNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As PitchNodesPlayMode
C#
public PitchNodesPlayMode PlayMode { get; set; }
Visual C++
public:
property PitchNodesPlayMode PlayMode {
    PitchNodesPlayMode get ();
    void set (PitchNodesPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

PitchNodes Class


Points Property

[image]

.NET Framework Class Library
PitchNodes..::.Points Property
PitchNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

PitchNodes Class


ValueQuantum Property

[image]

.NET Framework Class Library
PitchNodes..::.ValueQuantum Property
PitchNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

PitchNodes Class


PitchNodesPlayMode Enumeration

[image]

.NET Framework Class Library
PitchNodesPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PitchNodesPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PitchNodesPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PitchNodesPlayMode
JavaScript
NRenoiseTools.PitchNodesPlayMode = function();
NRenoiseTools.PitchNodesPlayMode.createEnum('NRenoiseTools.PitchNodesPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PluginDevice Class

[image]

.NET Framework Class Library
PluginDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PluginDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PluginDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PluginDevice
JavaScript
NRenoiseTools.PluginDevice = function();

Type.createClass(
    'NRenoiseTools.PluginDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PluginDevice

See Also

PluginDevice Members


PluginDevice Members

[image] [image]

.NET Framework Class Library
PluginDevice Members
PluginDevice Class Constructors Methods Properties See Also Send Feedback

The PluginDevice type exposes the following members.

Constructors

Name | Description
PluginDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveProgram |
IsActive |
IsSelected |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

PluginDevice Class


PluginDevice Constructor

[image]

.NET Framework Class Library
PluginDevice Constructor
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PluginDevice()
Visual C++
public:
PluginDevice()
JavaScript
NRenoiseTools.PluginDevice = function();

See Also

PluginDevice Class


PluginDevice Methods

[image] [image]

.NET Framework Class Library
PluginDevice Methods
PluginDevice Class See Also Send Feedback

The PluginDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginDevice Class


PluginDevice Properties

[image] [image]

.NET Framework Class Library
PluginDevice Properties
PluginDevice Class See Also Send Feedback

The PluginDevice type exposes the following members.

Properties

Name | Description
ActiveProgram |
IsActive |
IsSelected |
ParameterChunk |
ParameterChunkType |
Parameters |
PluginDisplayName |
PluginEditorWindowPosition |
PluginIdentifier |
PluginShortDisplayName |
PluginType |
PluginTypeSpecified |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

PluginDevice Class


ActiveProgram Property

[image]

.NET Framework Class Library
PluginDevice..::.ActiveProgram Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ActiveProgram As Integer
C#
public int ActiveProgram { get; set; }
Visual C++
public:
property int ActiveProgram {
    int get ();
    void set (int value);
}
JavaScript
function get_activeProgram();
function set_activeProgram(value);

Remarks

See Also

PluginDevice Class


IsActive Property

[image]

.NET Framework Class Library
PluginDevice..::.IsActive Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

PluginDevice Class


IsSelected Property

[image]

.NET Framework Class Library
PluginDevice..::.IsSelected Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

PluginDevice Class


ParameterChunk Property

[image]

.NET Framework Class Library
PluginDevice..::.ParameterChunk Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunk As String
C#
public string ParameterChunk { get; set; }
Visual C++
public:
property String^ ParameterChunk {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameterChunk();
function set_parameterChunk(value);

Remarks

See Also

PluginDevice Class


ParameterChunkType Property

[image]

.NET Framework Class Library
PluginDevice..::.ParameterChunkType Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterChunkType As PluginDeviceParameterChunkType
C#
public PluginDeviceParameterChunkType ParameterChunkType { get; set; }
Visual C++
public:
property PluginDeviceParameterChunkType ParameterChunkType {
    PluginDeviceParameterChunkType get ();
    void set (PluginDeviceParameterChunkType value);
}
JavaScript
function get_parameterChunkType();
function set_parameterChunkType(value);

Remarks

See Also

PluginDevice Class


Parameters Property

[image]

.NET Framework Class Library
PluginDevice..::.Parameters Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As Parameter()
C#
public Parameter[] Parameters { get; set; }
Visual C++
public:
property array<Parameter^>^ Parameters {
    array<Parameter^>^ get ();
    void set (array<Parameter^>^ value);
}
JavaScript
function get_parameters();
function set_parameters(value);

Remarks

See Also

PluginDevice Class


PluginDisplayName Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginDisplayName Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginDisplayName As String
C#
public string PluginDisplayName { get; set; }
Visual C++
public:
property String^ PluginDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginDisplayName();
function set_pluginDisplayName(value);

Remarks

See Also

PluginDevice Class


PluginEditorWindowPosition Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginEditorWindowPosition Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginEditorWindowPosition As String
C#
public string PluginEditorWindowPosition { get; set; }
Visual C++
public:
property String^ PluginEditorWindowPosition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginEditorWindowPosition();
function set_pluginEditorWindowPosition(value);

Remarks

See Also

PluginDevice Class


PluginIdentifier Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginIdentifier Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginIdentifier As String
C#
public string PluginIdentifier { get; set; }
Visual C++
public:
property String^ PluginIdentifier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginIdentifier();
function set_pluginIdentifier(value);

Remarks

See Also

PluginDevice Class


PluginShortDisplayName Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginShortDisplayName Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginShortDisplayName As String
C#
public string PluginShortDisplayName { get; set; }
Visual C++
public:
property String^ PluginShortDisplayName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pluginShortDisplayName();
function set_pluginShortDisplayName(value);

Remarks

See Also

PluginDevice Class


PluginType Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginType Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginType As PluginDevicePluginType
C#
public PluginDevicePluginType PluginType { get; set; }
Visual C++
public:
property PluginDevicePluginType PluginType {
    PluginDevicePluginType get ();
    void set (PluginDevicePluginType value);
}
JavaScript
function get_pluginType();
function set_pluginType(value);

Remarks

See Also

PluginDevice Class


PluginTypeSpecified Property

[image]

.NET Framework Class Library
PluginDevice..::.PluginTypeSpecified Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginTypeSpecified As Boolean
C#
public bool PluginTypeSpecified { get; set; }
Visual C++
public:
property bool PluginTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pluginTypeSpecified();
function set_pluginTypeSpecified(value);

Remarks

See Also

PluginDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
PluginDevice..::.RunTimePresetA Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As PluginDeviceRunTimePreset
C#
public PluginDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property PluginDeviceRunTimePreset^ RunTimePresetA {
    PluginDeviceRunTimePreset^ get ();
    void set (PluginDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

PluginDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
PluginDevice..::.RunTimePresetB Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As PluginDeviceRunTimePreset
C#
public PluginDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property PluginDeviceRunTimePreset^ RunTimePresetB {
    PluginDeviceRunTimePreset^ get ();
    void set (PluginDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

PluginDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
PluginDevice..::.SelectedPresetIsModified Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

PluginDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
PluginDevice..::.SelectedPresetName Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

PluginDevice Class


type Property

[image]

.NET Framework Class Library
PluginDevice..::.type Property
PluginDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PluginDevice Class


PluginDeviceParameterChunkType Enumeration

[image]

.NET Framework Class Library
PluginDeviceParameterChunkType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PluginDeviceParameterChunkType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PluginDeviceParameterChunkType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PluginDeviceParameterChunkType
JavaScript
NRenoiseTools.PluginDeviceParameterChunkType = function();
NRenoiseTools.PluginDeviceParameterChunkType.createEnum('NRenoiseTools.PluginDeviceParameterChunkType', false);

Members

Member name | Description
Chunk |
ParameterBag |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PluginDevicePluginType Enumeration

[image]

.NET Framework Class Library
PluginDevicePluginType Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration PluginDevicePluginType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum PluginDevicePluginType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class PluginDevicePluginType
JavaScript
NRenoiseTools.PluginDevicePluginType = function();
NRenoiseTools.PluginDevicePluginType.createEnum('NRenoiseTools.PluginDevicePluginType', false);

Members

Member name | Description
AU |
VST |
LADSAP |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


PluginDeviceRunTimePreset Class

[image]

.NET Framework Class Library
PluginDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PluginDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PluginDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PluginDeviceRunTimePreset
JavaScript
NRenoiseTools.PluginDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.PluginDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PluginDeviceRunTimePreset

See Also

PluginDeviceRunTimePreset Members


PluginDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
PluginDeviceRunTimePreset Members
PluginDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The PluginDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
PluginDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

PluginDeviceRunTimePreset Class


PluginDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
PluginDeviceRunTimePreset Constructor
PluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PluginDeviceRunTimePreset()
Visual C++
public:
PluginDeviceRunTimePreset()
JavaScript
NRenoiseTools.PluginDeviceRunTimePreset = function();

See Also

PluginDeviceRunTimePreset Class


PluginDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
PluginDeviceRunTimePreset Methods
PluginDeviceRunTimePreset Class See Also Send Feedback

The PluginDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginDeviceRunTimePreset Class


PluginDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
PluginDeviceRunTimePreset Properties
PluginDeviceRunTimePreset Class See Also Send Feedback

The PluginDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

PluginDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
PluginDeviceRunTimePreset..::.DeviceSlot Property
PluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As DeviceSlotRunTimePreset
C#
public DeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property DeviceSlotRunTimePreset^ DeviceSlot {
    DeviceSlotRunTimePreset^ get ();
    void set (DeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

PluginDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
PluginDeviceRunTimePreset..::.type Property
PluginDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PluginDeviceRunTimePreset Class


PluginProperties Class

[image]

.NET Framework Class Library
PluginProperties Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class PluginProperties
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class PluginProperties
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class PluginProperties
JavaScript
NRenoiseTools.PluginProperties = function();

Type.createClass(
    'NRenoiseTools.PluginProperties');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.PluginProperties

See Also

PluginProperties Members


PluginProperties Members

[image] [image]

.NET Framework Class Library
PluginProperties Members
PluginProperties Class Constructors Methods Properties See Also Send Feedback

The PluginProperties type exposes the following members.

Constructors

Name | Description
PluginProperties |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AliasFxIndices |
AliasInstrumentIndex |
AutoSuspend |
BaseNote |
Channel |
OutputRoutings |
PluginDevice |
Volume |

See Also

PluginProperties Class


PluginProperties Constructor

[image]

.NET Framework Class Library
PluginProperties Constructor
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PluginProperties()
Visual C++
public:
PluginProperties()
JavaScript
NRenoiseTools.PluginProperties = function();

See Also

PluginProperties Class


PluginProperties Methods

[image] [image]

.NET Framework Class Library
PluginProperties Methods
PluginProperties Class See Also Send Feedback

The PluginProperties type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginProperties Class


PluginProperties Properties

[image] [image]

.NET Framework Class Library
PluginProperties Properties
PluginProperties Class See Also Send Feedback

The PluginProperties type exposes the following members.

Properties

Name | Description
AliasFxIndices |
AliasInstrumentIndex |
AutoSuspend |
BaseNote |
Channel |
OutputRoutings |
PluginDevice |
Volume |

See Also

PluginProperties Class


AliasFxIndices Property

[image]

.NET Framework Class Library
PluginProperties..::.AliasFxIndices Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AliasFxIndices As String
C#
public string AliasFxIndices { get; set; }
Visual C++
public:
property String^ AliasFxIndices {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_aliasFxIndices();
function set_aliasFxIndices(value);

Remarks

See Also

PluginProperties Class


AliasInstrumentIndex Property

[image]

.NET Framework Class Library
PluginProperties..::.AliasInstrumentIndex Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AliasInstrumentIndex As Integer
C#
public int AliasInstrumentIndex { get; set; }
Visual C++
public:
property int AliasInstrumentIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_aliasInstrumentIndex();
function set_aliasInstrumentIndex(value);

Remarks

See Also

PluginProperties Class


AutoSuspend Property

[image]

.NET Framework Class Library
PluginProperties..::.AutoSuspend Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoSuspend As Boolean
C#
public bool AutoSuspend { get; set; }
Visual C++
public:
property bool AutoSuspend {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoSuspend();
function set_autoSuspend(value);

Remarks

See Also

PluginProperties Class


BaseNote Property

[image]

.NET Framework Class Library
PluginProperties..::.BaseNote Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseNote As Integer
C#
public int BaseNote { get; set; }
Visual C++
public:
property int BaseNote {
    int get ();
    void set (int value);
}
JavaScript
function get_baseNote();
function set_baseNote(value);

Remarks

See Also

PluginProperties Class


Channel Property

[image]

.NET Framework Class Library
PluginProperties..::.Channel Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Channel As SByte
C#
public sbyte Channel { get; set; }
Visual C++
public:
property signed char Channel {
    signed char get ();
    void set (signed char value);
}
JavaScript
function get_channel();
function set_channel(value);

Remarks

See Also

PluginProperties Class


OutputRoutings Property

[image]

.NET Framework Class Library
PluginProperties..::.OutputRoutings Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputRoutings As OutputRouting()
C#
public OutputRouting[] OutputRoutings { get; set; }
Visual C++
public:
property array<OutputRouting^>^ OutputRoutings {
    array<OutputRouting^>^ get ();
    void set (array<OutputRouting^>^ value);
}
JavaScript
function get_outputRoutings();
function set_outputRoutings(value);

Remarks

See Also

PluginProperties Class


PluginDevice Property

[image]

.NET Framework Class Library
PluginProperties..::.PluginDevice Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PluginDevice As PluginDevice
C#
public PluginDevice PluginDevice { get; set; }
Visual C++
public:
property PluginDevice^ PluginDevice {
    PluginDevice^ get ();
    void set (PluginDevice^ value);
}
JavaScript
function get_pluginDevice();
function set_pluginDevice(value);

Remarks

See Also

PluginProperties Class


Volume Property

[image]

.NET Framework Class Library
PluginProperties..::.Volume Property
PluginProperties Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As Single
C#
public float Volume { get; set; }
Visual C++
public:
property float Volume {
    float get ();
    void set (float value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

PluginProperties Class


RecordManager Class

[image]

.NET Framework Class Library
RecordManager Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RecordManager
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RecordManager
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RecordManager
JavaScript
NRenoiseTools.RecordManager = function();

Type.createClass(
    'NRenoiseTools.RecordManager');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RecordManager

See Also

RecordManager Members


RecordManager Members

[image] [image]

.NET Framework Class Library
RecordManager Members
RecordManager Class Constructors Methods Properties See Also Send Feedback

The RecordManager type exposes the following members.

Constructors

Name | Description
RecordManager |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LinkedTrackIndex |

See Also

RecordManager Class


RecordManager Constructor

[image]

.NET Framework Class Library
RecordManager Constructor
RecordManager Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RecordManager()
Visual C++
public:
RecordManager()
JavaScript
NRenoiseTools.RecordManager = function();

See Also

RecordManager Class


RecordManager Methods

[image] [image]

.NET Framework Class Library
RecordManager Methods
RecordManager Class See Also Send Feedback

The RecordManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecordManager Class


RecordManager Properties

[image] [image]

.NET Framework Class Library
RecordManager Properties
RecordManager Class See Also Send Feedback

The RecordManager type exposes the following members.

Properties

Name | Description
LinkedTrackIndex |

See Also

RecordManager Class


LinkedTrackIndex Property

[image]

.NET Framework Class Library
RecordManager..::.LinkedTrackIndex Property
RecordManager Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LinkedTrackIndex As Integer
C#
public int LinkedTrackIndex { get; set; }
Visual C++
public:
property int LinkedTrackIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_linkedTrackIndex();
function set_linkedTrackIndex(value);

Remarks

See Also

RecordManager Class


RenoiseDeviceChain Class

[image]

.NET Framework Class Library
RenoiseDeviceChain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RenoiseDeviceChain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RenoiseDeviceChain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RenoiseDeviceChain
JavaScript
NRenoiseTools.RenoiseDeviceChain = function();

Type.createClass(
    'NRenoiseTools.RenoiseDeviceChain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RenoiseDeviceChain

See Also

RenoiseDeviceChain Members


RenoiseDeviceChain Members

[image] [image]

.NET Framework Class Library
RenoiseDeviceChain Members
RenoiseDeviceChain Class Constructors Methods Properties See Also Send Feedback

The RenoiseDeviceChain type exposes the following members.

Constructors

Name | Description
RenoiseDeviceChain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Devices |
doc_version |

See Also

RenoiseDeviceChain Class


RenoiseDeviceChain Constructor

[image]

.NET Framework Class Library
RenoiseDeviceChain Constructor
RenoiseDeviceChain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RenoiseDeviceChain()
Visual C++
public:
RenoiseDeviceChain()
JavaScript
NRenoiseTools.RenoiseDeviceChain = function();

See Also

RenoiseDeviceChain Class


RenoiseDeviceChain Methods

[image] [image]

.NET Framework Class Library
RenoiseDeviceChain Methods
RenoiseDeviceChain Class See Also Send Feedback

The RenoiseDeviceChain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenoiseDeviceChain Class


RenoiseDeviceChain Properties

[image] [image]

.NET Framework Class Library
RenoiseDeviceChain Properties
RenoiseDeviceChain Class See Also Send Feedback

The RenoiseDeviceChain type exposes the following members.

Properties

Name | Description
Devices |
doc_version |

See Also

RenoiseDeviceChain Class


Devices Property

[image]

.NET Framework Class Library
RenoiseDeviceChain..::.Devices Property
RenoiseDeviceChain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Devices As RenoiseDeviceChainDevices
C#
public RenoiseDeviceChainDevices Devices { get; set; }
Visual C++
public:
property RenoiseDeviceChainDevices^ Devices {
    RenoiseDeviceChainDevices^ get ();
    void set (RenoiseDeviceChainDevices^ value);
}
JavaScript
function get_devices();
function set_devices(value);

Remarks

See Also

RenoiseDeviceChain Class


doc_version Property

[image]

.NET Framework Class Library
RenoiseDeviceChain..::.doc_version Property
RenoiseDeviceChain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property doc_version As Integer
C#
public int doc_version { get; set; }
Visual C++
public:
property int doc_version {
    int get ();
    void set (int value);
}
JavaScript
function get_doc_version();
function set_doc_version(value);

Remarks

See Also

RenoiseDeviceChain Class


RenoiseDeviceChainDevices Class

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RenoiseDeviceChainDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RenoiseDeviceChainDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RenoiseDeviceChainDevices
JavaScript
NRenoiseTools.RenoiseDeviceChainDevices = function();

Type.createClass(
    'NRenoiseTools.RenoiseDeviceChainDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RenoiseDeviceChainDevices

See Also

RenoiseDeviceChainDevices Members


RenoiseDeviceChainDevices Members

[image] [image]

.NET Framework Class Library
RenoiseDeviceChainDevices Members
RenoiseDeviceChainDevices Class Constructors Methods Properties See Also Send Feedback

The RenoiseDeviceChainDevices type exposes the following members.

Constructors

Name | Description
RenoiseDeviceChainDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
LineInDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

RenoiseDeviceChainDevices Class


RenoiseDeviceChainDevices Constructor

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices Constructor
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RenoiseDeviceChainDevices()
Visual C++
public:
RenoiseDeviceChainDevices()
JavaScript
NRenoiseTools.RenoiseDeviceChainDevices = function();

See Also

RenoiseDeviceChainDevices Class


RenoiseDeviceChainDevices Methods

[image] [image]

.NET Framework Class Library
RenoiseDeviceChainDevices Methods
RenoiseDeviceChainDevices Class See Also Send Feedback

The RenoiseDeviceChainDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenoiseDeviceChainDevices Class


RenoiseDeviceChainDevices Properties

[image] [image]

.NET Framework Class Library
RenoiseDeviceChainDevices Properties
RenoiseDeviceChainDevices Class See Also Send Feedback

The RenoiseDeviceChainDevices type exposes the following members.

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
LineInDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

RenoiseDeviceChainDevices Class


AudioPluginDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.AudioPluginDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AudioPluginDevice As AudioPluginDevice()
C#
public AudioPluginDevice[] AudioPluginDevice { get; set; }
Visual C++
public:
property array<AudioPluginDevice^>^ AudioPluginDevice {
    array<AudioPluginDevice^>^ get ();
    void set (array<AudioPluginDevice^>^ value);
}
JavaScript
function get_audioPluginDevice();
function set_audioPluginDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


BusCompressorDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.BusCompressorDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BusCompressorDevice As BusCompressorDevice()
C#
public BusCompressorDevice[] BusCompressorDevice { get; set; }
Visual C++
public:
property array<BusCompressorDevice^>^ BusCompressorDevice {
    array<BusCompressorDevice^>^ get ();
    void set (array<BusCompressorDevice^>^ value);
}
JavaScript
function get_busCompressorDevice();
function set_busCompressorDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


ChorusDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.ChorusDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ChorusDevice As ChorusDevice()
C#
public ChorusDevice[] ChorusDevice { get; set; }
Visual C++
public:
property array<ChorusDevice^>^ ChorusDevice {
    array<ChorusDevice^>^ get ();
    void set (array<ChorusDevice^>^ value);
}
JavaScript
function get_chorusDevice();
function set_chorusDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


CompressorDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.CompressorDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressorDevice As CompressorDevice()
C#
public CompressorDevice[] CompressorDevice { get; set; }
Visual C++
public:
property array<CompressorDevice^>^ CompressorDevice {
    array<CompressorDevice^>^ get ();
    void set (array<CompressorDevice^>^ value);
}
JavaScript
function get_compressorDevice();
function set_compressorDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


DcOffsetDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.DcOffsetDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DcOffsetDevice As DcOffsetDevice()
C#
public DcOffsetDevice[] DcOffsetDevice { get; set; }
Visual C++
public:
property array<DcOffsetDevice^>^ DcOffsetDevice {
    array<DcOffsetDevice^>^ get ();
    void set (array<DcOffsetDevice^>^ value);
}
JavaScript
function get_dcOffsetDevice();
function set_dcOffsetDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


DelayDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.DelayDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayDevice As DelayDevice()
C#
public DelayDevice[] DelayDevice { get; set; }
Visual C++
public:
property array<DelayDevice^>^ DelayDevice {
    array<DelayDevice^>^ get ();
    void set (array<DelayDevice^>^ value);
}
JavaScript
function get_delayDevice();
function set_delayDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Distortion2Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Distortion2Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Distortion2Device As Distortion2DeviceDistortionDevice()
C#
public Distortion2DeviceDistortionDevice[] Distortion2Device { get; set; }
Visual C++
public:
property array<Distortion2DeviceDistortionDevice^>^ Distortion2Device {
    array<Distortion2DeviceDistortionDevice^>^ get ();
    void set (array<Distortion2DeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortion2Device();
function set_distortion2Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


DistortionDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.DistortionDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DistortionDevice As DistortionDeviceDistortionDevice()
C#
public DistortionDeviceDistortionDevice[] DistortionDevice { get; set; }
Visual C++
public:
property array<DistortionDeviceDistortionDevice^>^ DistortionDevice {
    array<DistortionDeviceDistortionDevice^>^ get ();
    void set (array<DistortionDeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortionDevice();
function set_distortionDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Eq10Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Eq10Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq10Device As Eq10DeviceEqDevice()
C#
public Eq10DeviceEqDevice[] Eq10Device { get; set; }
Visual C++
public:
property array<Eq10DeviceEqDevice^>^ Eq10Device {
    array<Eq10DeviceEqDevice^>^ get ();
    void set (array<Eq10DeviceEqDevice^>^ value);
}
JavaScript
function get_eq10Device();
function set_eq10Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Eq5Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Eq5Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq5Device As Eq5DeviceEqDevice()
C#
public Eq5DeviceEqDevice[] Eq5Device { get; set; }
Visual C++
public:
property array<Eq5DeviceEqDevice^>^ Eq5Device {
    array<Eq5DeviceEqDevice^>^ get ();
    void set (array<Eq5DeviceEqDevice^>^ value);
}
JavaScript
function get_eq5Device();
function set_eq5Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Filter1Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Filter1Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter1Device As Filter1DeviceFilterDevice()
C#
public Filter1DeviceFilterDevice[] Filter1Device { get; set; }
Visual C++
public:
property array<Filter1DeviceFilterDevice^>^ Filter1Device {
    array<Filter1DeviceFilterDevice^>^ get ();
    void set (array<Filter1DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter1Device();
function set_filter1Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Filter2Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Filter2Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter2Device As Filter2DeviceFilterDevice()
C#
public Filter2DeviceFilterDevice[] Filter2Device { get; set; }
Visual C++
public:
property array<Filter2DeviceFilterDevice^>^ Filter2Device {
    array<Filter2DeviceFilterDevice^>^ get ();
    void set (array<Filter2DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter2Device();
function set_filter2Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Filter3Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Filter3Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter3Device As Filter3DeviceFilterDevice()
C#
public Filter3DeviceFilterDevice[] Filter3Device { get; set; }
Visual C++
public:
property array<Filter3DeviceFilterDevice^>^ Filter3Device {
    array<Filter3DeviceFilterDevice^>^ get ();
    void set (array<Filter3DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter3Device();
function set_filter3Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


FilterDistortionDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.FilterDistortionDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDistortionDevice As FilterDistortionDevice()
C#
public FilterDistortionDevice[] FilterDistortionDevice { get; set; }
Visual C++
public:
property array<FilterDistortionDevice^>^ FilterDistortionDevice {
    array<FilterDistortionDevice^>^ get ();
    void set (array<FilterDistortionDevice^>^ value);
}
JavaScript
function get_filterDistortionDevice();
function set_filterDistortionDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


FlangerDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.FlangerDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FlangerDevice As FlangerDevice()
C#
public FlangerDevice[] FlangerDevice { get; set; }
Visual C++
public:
property array<FlangerDevice^>^ FlangerDevice {
    array<FlangerDevice^>^ get ();
    void set (array<FlangerDevice^>^ value);
}
JavaScript
function get_flangerDevice();
function set_flangerDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


GainerDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.GainerDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GainerDevice As GainerDevice()
C#
public GainerDevice[] GainerDevice { get; set; }
Visual C++
public:
property array<GainerDevice^>^ GainerDevice {
    array<GainerDevice^>^ get ();
    void set (array<GainerDevice^>^ value);
}
JavaScript
function get_gainerDevice();
function set_gainerDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Gate2Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Gate2Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gate2Device As Gate2DeviceGateDevice()
C#
public Gate2DeviceGateDevice[] Gate2Device { get; set; }
Visual C++
public:
property array<Gate2DeviceGateDevice^>^ Gate2Device {
    array<Gate2DeviceGateDevice^>^ get ();
    void set (array<Gate2DeviceGateDevice^>^ value);
}
JavaScript
function get_gate2Device();
function set_gate2Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


GateDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.GateDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateDevice As GateDeviceGateDevice()
C#
public GateDeviceGateDevice[] GateDevice { get; set; }
Visual C++
public:
property array<GateDeviceGateDevice^>^ GateDevice {
    array<GateDeviceGateDevice^>^ get ();
    void set (array<GateDeviceGateDevice^>^ value);
}
JavaScript
function get_gateDevice();
function set_gateDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


InstrumentAutomationDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.InstrumentAutomationDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InstrumentAutomationDevice As InstrumentAutomationDevice()
C#
public InstrumentAutomationDevice[] InstrumentAutomationDevice { get; set; }
Visual C++
public:
property array<InstrumentAutomationDevice^>^ InstrumentAutomationDevice {
    array<InstrumentAutomationDevice^>^ get ();
    void set (array<InstrumentAutomationDevice^>^ value);
}
JavaScript
function get_instrumentAutomationDevice();
function set_instrumentAutomationDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


LfoDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.LfoDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDevice As LfoDevice()
C#
public LfoDevice[] LfoDevice { get; set; }
Visual C++
public:
property array<LfoDevice^>^ LfoDevice {
    array<LfoDevice^>^ get ();
    void set (array<LfoDevice^>^ value);
}
JavaScript
function get_lfoDevice();
function set_lfoDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


LineInDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.LineInDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LineInDevice As LineInDevice()
C#
public LineInDevice[] LineInDevice { get; set; }
Visual C++
public:
property array<LineInDevice^>^ LineInDevice {
    array<LineInDevice^>^ get ();
    void set (array<LineInDevice^>^ value);
}
JavaScript
function get_lineInDevice();
function set_lineInDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Lofi2Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Lofi2Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lofi2Device As Lofi2DeviceLofiDevice()
C#
public Lofi2DeviceLofiDevice[] Lofi2Device { get; set; }
Visual C++
public:
property array<Lofi2DeviceLofiDevice^>^ Lofi2Device {
    array<Lofi2DeviceLofiDevice^>^ get ();
    void set (array<Lofi2DeviceLofiDevice^>^ value);
}
JavaScript
function get_lofi2Device();
function set_lofi2Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


LofiDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.LofiDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LofiDevice As LofiDeviceLofiDevice()
C#
public LofiDeviceLofiDevice[] LofiDevice { get; set; }
Visual C++
public:
property array<LofiDeviceLofiDevice^>^ LofiDevice {
    array<LofiDeviceLofiDevice^>^ get ();
    void set (array<LofiDeviceLofiDevice^>^ value);
}
JavaScript
function get_lofiDevice();
function set_lofiDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


MaximizerDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.MaximizerDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximizerDevice As MaximizerDevice()
C#
public MaximizerDevice[] MaximizerDevice { get; set; }
Visual C++
public:
property array<MaximizerDevice^>^ MaximizerDevice {
    array<MaximizerDevice^>^ get ();
    void set (array<MaximizerDevice^>^ value);
}
JavaScript
function get_maximizerDevice();
function set_maximizerDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


MidiCCDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.MidiCCDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiCCDevice As MidiCCDevice()
C#
public MidiCCDevice[] MidiCCDevice { get; set; }
Visual C++
public:
property array<MidiCCDevice^>^ MidiCCDevice {
    array<MidiCCDevice^>^ get ();
    void set (array<MidiCCDevice^>^ value);
}
JavaScript
function get_midiCCDevice();
function set_midiCCDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


MixerEqDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.MixerEqDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MixerEqDevice As MixerEqDevice()
C#
public MixerEqDevice[] MixerEqDevice { get; set; }
Visual C++
public:
property array<MixerEqDevice^>^ MixerEqDevice {
    array<MixerEqDevice^>^ get ();
    void set (array<MixerEqDevice^>^ value);
}
JavaScript
function get_mixerEqDevice();
function set_mixerEqDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


PdcTestDelayDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.PdcTestDelayDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PdcTestDelayDevice As PdcTestDelayDevice()
C#
public PdcTestDelayDevice[] PdcTestDelayDevice { get; set; }
Visual C++
public:
property array<PdcTestDelayDevice^>^ PdcTestDelayDevice {
    array<PdcTestDelayDevice^>^ get ();
    void set (array<PdcTestDelayDevice^>^ value);
}
JavaScript
function get_pdcTestDelayDevice();
function set_pdcTestDelayDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


PhaserDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.PhaserDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PhaserDevice As PhaserDevice()
C#
public PhaserDevice[] PhaserDevice { get; set; }
Visual C++
public:
property array<PhaserDevice^>^ PhaserDevice {
    array<PhaserDevice^>^ get ();
    void set (array<PhaserDevice^>^ value);
}
JavaScript
function get_phaserDevice();
function set_phaserDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Reverb2Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Reverb2Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb2Device As Reverb2DeviceReverbDevice()
C#
public Reverb2DeviceReverbDevice[] Reverb2Device { get; set; }
Visual C++
public:
property array<Reverb2DeviceReverbDevice^>^ Reverb2Device {
    array<Reverb2DeviceReverbDevice^>^ get ();
    void set (array<Reverb2DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb2Device();
function set_reverb2Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


Reverb3Device Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.Reverb3Device Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb3Device As Reverb3DeviceReverbDevice()
C#
public Reverb3DeviceReverbDevice[] Reverb3Device { get; set; }
Visual C++
public:
property array<Reverb3DeviceReverbDevice^>^ Reverb3Device {
    array<Reverb3DeviceReverbDevice^>^ get ();
    void set (array<Reverb3DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb3Device();
function set_reverb3Device(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


ReverbDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.ReverbDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbDevice As ReverbDeviceReverbDevice()
C#
public ReverbDeviceReverbDevice[] ReverbDevice { get; set; }
Visual C++
public:
property array<ReverbDeviceReverbDevice^>^ ReverbDevice {
    array<ReverbDeviceReverbDevice^>^ get ();
    void set (array<ReverbDeviceReverbDevice^>^ value);
}
JavaScript
function get_reverbDevice();
function set_reverbDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


RingModDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.RingModDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RingModDevice As RingModDevice()
C#
public RingModDevice[] RingModDevice { get; set; }
Visual C++
public:
property array<RingModDevice^>^ RingModDevice {
    array<RingModDevice^>^ get ();
    void set (array<RingModDevice^>^ value);
}
JavaScript
function get_ringModDevice();
function set_ringModDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


SendDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.SendDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SendDevice As SendDevice()
C#
public SendDevice[] SendDevice { get; set; }
Visual C++
public:
property array<SendDevice^>^ SendDevice {
    array<SendDevice^>^ get ();
    void set (array<SendDevice^>^ value);
}
JavaScript
function get_sendDevice();
function set_sendDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


ShaperDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.ShaperDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShaperDevice As ShaperDevice()
C#
public ShaperDevice[] ShaperDevice { get; set; }
Visual C++
public:
property array<ShaperDevice^>^ ShaperDevice {
    array<ShaperDevice^>^ get ();
    void set (array<ShaperDevice^>^ value);
}
JavaScript
function get_shaperDevice();
function set_shaperDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


StereoExpanderDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.StereoExpanderDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoExpanderDevice As StereoExpanderDevice()
C#
public StereoExpanderDevice[] StereoExpanderDevice { get; set; }
Visual C++
public:
property array<StereoExpanderDevice^>^ StereoExpanderDevice {
    array<StereoExpanderDevice^>^ get ();
    void set (array<StereoExpanderDevice^>^ value);
}
JavaScript
function get_stereoExpanderDevice();
function set_stereoExpanderDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


VelocityDevice Property

[image]

.NET Framework Class Library
RenoiseDeviceChainDevices..::.VelocityDevice Property
RenoiseDeviceChainDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityDevice As VelocityDevice()
C#
public VelocityDevice[] VelocityDevice { get; set; }
Visual C++
public:
property array<VelocityDevice^>^ VelocityDevice {
    array<VelocityDevice^>^ get ();
    void set (array<VelocityDevice^>^ value);
}
JavaScript
function get_velocityDevice();
function set_velocityDevice(value);

Remarks

See Also

RenoiseDeviceChainDevices Class


RenoiseInstrument Class

[image]

.NET Framework Class Library
RenoiseInstrument Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RenoiseInstrument _
    Inherits Instrument
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RenoiseInstrument : Instrument
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RenoiseInstrument : public Instrument
JavaScript
NRenoiseTools.RenoiseInstrument = function();

Type.createClass(
    'NRenoiseTools.RenoiseInstrument',
    NRenoiseTools.Instrument);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Instrument
NRenoiseTools..::.RenoiseInstrument

See Also

RenoiseInstrument Members


RenoiseInstrument Members

[image] [image]

.NET Framework Class Library
RenoiseInstrument Members
RenoiseInstrument Class Constructors Methods Properties See Also Send Feedback

The RenoiseInstrument type exposes the following members.

Constructors

Name | Description
RenoiseInstrument |

Methods

Name | Description
Copy | Copies this instrument to another instrument. (Inherited from Instrument.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CopyIntoNewInstrumentNameCounter | (Inherited from Instrument.)
CopyIntoNewSampleNameCounter | (Inherited from Instrument.)
doc_version |
Envelopes | (Inherited from Instrument.)
FileName | Gets or sets the name of the file used to store the RenoiseInstrument. This property is set when loading song from a file Load(String). (Inherited from Instrument.)
MidiProperties | (Inherited from Instrument.)
Name | (Inherited from Instrument.)
PluginProperties | (Inherited from Instrument.)
Samples | (Inherited from Instrument.)
SplitMap | (Inherited from Instrument.)

See Also

RenoiseInstrument Class


RenoiseInstrument Constructor

[image]

.NET Framework Class Library
RenoiseInstrument Constructor
RenoiseInstrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RenoiseInstrument()
Visual C++
public:
RenoiseInstrument()
JavaScript
NRenoiseTools.RenoiseInstrument = function();

See Also

RenoiseInstrument Class


RenoiseInstrument Methods

[image] [image]

.NET Framework Class Library
RenoiseInstrument Methods
RenoiseInstrument Class See Also Send Feedback

The RenoiseInstrument type exposes the following members.

Methods

Name | Description
Copy | Copies this instrument to another instrument. (Inherited from Instrument.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenoiseInstrument Class


Load Method

[image] [image]

.NET Framework Class Library
RenoiseInstrument..::.Load Method
RenoiseInstrument Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads a xrni Renoise instrument from a specified stream. (Inherited from Instrument.)
Load(String) | Loads a xrni Renoise instrument from a specified file name. (Inherited from Instrument.)

See Also

RenoiseInstrument Class
RenoiseInstrument Members


Save Method

[image] [image]

.NET Framework Class Library
RenoiseInstrument..::.Save Method
RenoiseInstrument Class See Also Send Feedback

Overload List

Name | Description
Save()()() | Writes this xrni Renoise instrument to the default filename file. (Inherited from Instrument.)
Save(Stream) | Writes this xrni Renoise instrument from a specified output stream. (Inherited from Instrument.)
Save(String) | Writes this xrni Renoise instrument to a specified output file. (Inherited from Instrument.)

See Also

RenoiseInstrument Class
RenoiseInstrument Members


RenoiseInstrument Properties

[image] [image]

.NET Framework Class Library
RenoiseInstrument Properties
RenoiseInstrument Class See Also Send Feedback

The RenoiseInstrument type exposes the following members.

Properties

Name | Description
CopyIntoNewInstrumentNameCounter | (Inherited from Instrument.)
CopyIntoNewSampleNameCounter | (Inherited from Instrument.)
doc_version |
Envelopes | (Inherited from Instrument.)
FileName | Gets or sets the name of the file used to store the RenoiseInstrument. This property is set when loading song from a file Load(String). (Inherited from Instrument.)
MidiProperties | (Inherited from Instrument.)
Name | (Inherited from Instrument.)
PluginProperties | (Inherited from Instrument.)
Samples | (Inherited from Instrument.)
SplitMap | (Inherited from Instrument.)

See Also

RenoiseInstrument Class


doc_version Property

[image]

.NET Framework Class Library
RenoiseInstrument..::.doc_version Property
RenoiseInstrument Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property doc_version As Integer
C#
public int doc_version { get; set; }
Visual C++
public:
property int doc_version {
    int get ();
    void set (int value);
}
JavaScript
function get_doc_version();
function set_doc_version(value);

Remarks

See Also

RenoiseInstrument Class


RenoiseSong Class

[image]

.NET Framework Class Library
RenoiseSong Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RenoiseSong _
    Inherits Song
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RenoiseSong : Song
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RenoiseSong : public Song
JavaScript
NRenoiseTools.RenoiseSong = function();

Type.createClass(
    'NRenoiseTools.RenoiseSong',
    NRenoiseTools.Song);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongBase
NRenoiseTools..::.Song
NRenoiseTools..::.RenoiseSong

See Also

RenoiseSong Members


RenoiseSong Members

[image] [image]

.NET Framework Class Library
RenoiseSong Members
RenoiseSong Class Constructors Methods Properties See Also Send Feedback

The RenoiseSong type exposes the following members.

Constructors

Name | Description
RenoiseSong |

Methods

Name | Description
Copy | Copies this song to another song. (Inherited from Song.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
doc_version |
FileName | Gets or sets the name of the file used to store the RenoiseSong. This property is set when loading song from a file Load(String). (Inherited from Song.)
GlobalSongData | (Inherited from SongBase.)
Instruments | (Inherited from SongBase.)
PatternPool | (Inherited from SongBase.)
PatternSequence | (Inherited from SongBase.)
RecordManager | (Inherited from SongBase.)
SelectedInstrumentIndex | (Inherited from SongBase.)
SelectedSampleIndex | (Inherited from SongBase.)
SelectedTrackIndex | (Inherited from SongBase.)
Tracks | (Inherited from SongBase.)

See Also

RenoiseSong Class


RenoiseSong Constructor

[image]

.NET Framework Class Library
RenoiseSong Constructor
RenoiseSong Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RenoiseSong()
Visual C++
public:
RenoiseSong()
JavaScript
NRenoiseTools.RenoiseSong = function();

See Also

RenoiseSong Class


RenoiseSong Methods

[image] [image]

.NET Framework Class Library
RenoiseSong Methods
RenoiseSong Class See Also Send Feedback

The RenoiseSong type exposes the following members.

Methods

Name | Description
Copy | Copies this song to another song. (Inherited from Song.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenoiseSong Class


Load Method

[image] [image]

.NET Framework Class Library
RenoiseSong..::.Load Method
RenoiseSong Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads a xrns Renoise song from a specified stream. (Inherited from Song.)
Load(String) | Loads a xrns Renoise song from a specified file name. (Inherited from Song.)

See Also

RenoiseSong Class
RenoiseSong Members


Save Method

[image] [image]

.NET Framework Class Library
RenoiseSong..::.Save Method
RenoiseSong Class See Also Send Feedback

Overload List

Name | Description
Save()()() | Writes this xrns Renoise song to a specified output file. (Inherited from Song.)
Save(Stream) | Writes this xrns Renoise song from a specified output stream. (Inherited from Song.)
Save(String) | Writes this xrns Renoise song to a specified output file. (Inherited from Song.)

See Also

RenoiseSong Class
RenoiseSong Members


RenoiseSong Properties

[image] [image]

.NET Framework Class Library
RenoiseSong Properties
RenoiseSong Class See Also Send Feedback

The RenoiseSong type exposes the following members.

Properties

Name | Description
doc_version |
FileName | Gets or sets the name of the file used to store the RenoiseSong. This property is set when loading song from a file Load(String). (Inherited from Song.)
GlobalSongData | (Inherited from SongBase.)
Instruments | (Inherited from SongBase.)
PatternPool | (Inherited from SongBase.)
PatternSequence | (Inherited from SongBase.)
RecordManager | (Inherited from SongBase.)
SelectedInstrumentIndex | (Inherited from SongBase.)
SelectedSampleIndex | (Inherited from SongBase.)
SelectedTrackIndex | (Inherited from SongBase.)
Tracks | (Inherited from SongBase.)

See Also

RenoiseSong Class


doc_version Property

[image]

.NET Framework Class Library
RenoiseSong..::.doc_version Property
RenoiseSong Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property doc_version As Integer
C#
public int doc_version { get; set; }
Visual C++
public:
property int doc_version {
    int get ();
    void set (int value);
}
JavaScript
function get_doc_version();
function set_doc_version(value);

Remarks

See Also

RenoiseSong Class


ResonanceNodes Class

[image]

.NET Framework Class Library
ResonanceNodes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ResonanceNodes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ResonanceNodes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ResonanceNodes
JavaScript
NRenoiseTools.ResonanceNodes = function();

Type.createClass(
    'NRenoiseTools.ResonanceNodes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ResonanceNodes

See Also

ResonanceNodes Members


ResonanceNodes Members

[image] [image]

.NET Framework Class Library
ResonanceNodes Members
ResonanceNodes Class Constructors Methods Properties See Also Send Feedback

The ResonanceNodes type exposes the following members.

Constructors

Name | Description
ResonanceNodes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

ResonanceNodes Class


ResonanceNodes Constructor

[image]

.NET Framework Class Library
ResonanceNodes Constructor
ResonanceNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ResonanceNodes()
Visual C++
public:
ResonanceNodes()
JavaScript
NRenoiseTools.ResonanceNodes = function();

See Also

ResonanceNodes Class


ResonanceNodes Methods

[image] [image]

.NET Framework Class Library
ResonanceNodes Methods
ResonanceNodes Class See Also Send Feedback

The ResonanceNodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResonanceNodes Class


ResonanceNodes Properties

[image] [image]

.NET Framework Class Library
ResonanceNodes Properties
ResonanceNodes Class See Also Send Feedback

The ResonanceNodes type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

ResonanceNodes Class


Length Property

[image]

.NET Framework Class Library
ResonanceNodes..::.Length Property
ResonanceNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

ResonanceNodes Class


PlayMode Property

[image]

.NET Framework Class Library
ResonanceNodes..::.PlayMode Property
ResonanceNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As ResonanceNodesPlayMode
C#
public ResonanceNodesPlayMode PlayMode { get; set; }
Visual C++
public:
property ResonanceNodesPlayMode PlayMode {
    ResonanceNodesPlayMode get ();
    void set (ResonanceNodesPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

ResonanceNodes Class


Points Property

[image]

.NET Framework Class Library
ResonanceNodes..::.Points Property
ResonanceNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

ResonanceNodes Class


ValueQuantum Property

[image]

.NET Framework Class Library
ResonanceNodes..::.ValueQuantum Property
ResonanceNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

ResonanceNodes Class


ResonanceNodesPlayMode Enumeration

[image]

.NET Framework Class Library
ResonanceNodesPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ResonanceNodesPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ResonanceNodesPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ResonanceNodesPlayMode
JavaScript
NRenoiseTools.ResonanceNodesPlayMode = function();
NRenoiseTools.ResonanceNodesPlayMode.createEnum('NRenoiseTools.ResonanceNodesPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb2DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceDeviceSlotRunTimePreset

See Also

Reverb2DeviceDeviceSlotRunTimePreset Members


Reverb2DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset Members
Reverb2DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DryMix |
LPFilter |
PreDelay |
QualitySetup |
ReverbTime |
Send |
type |

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


Reverb2DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset Constructor
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Reverb2DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceDeviceSlotRunTimePreset = function();

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


Reverb2DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset Methods
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Reverb2DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


Reverb2DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset Properties
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Reverb2DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
DryMix |
LPFilter |
PreDelay |
QualitySetup |
ReverbTime |
Send |
type |

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


DryMix Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.DryMix Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As Reverb2DeviceDryMixRunTimePreset
C#
public Reverb2DeviceDryMixRunTimePreset DryMix { get; set; }
Visual C++
public:
property Reverb2DeviceDryMixRunTimePreset^ DryMix {
    Reverb2DeviceDryMixRunTimePreset^ get ();
    void set (Reverb2DeviceDryMixRunTimePreset^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


LPFilter Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.LPFilter Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPFilter As Reverb2DeviceLPFilterRunTimePreset
C#
public Reverb2DeviceLPFilterRunTimePreset LPFilter { get; set; }
Visual C++
public:
property Reverb2DeviceLPFilterRunTimePreset^ LPFilter {
    Reverb2DeviceLPFilterRunTimePreset^ get ();
    void set (Reverb2DeviceLPFilterRunTimePreset^ value);
}
JavaScript
function get_lpFilter();
function set_lpFilter(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


PreDelay Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.PreDelay Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PreDelay As Reverb2DevicePreDelayRunTimePreset
C#
public Reverb2DevicePreDelayRunTimePreset PreDelay { get; set; }
Visual C++
public:
property Reverb2DevicePreDelayRunTimePreset^ PreDelay {
    Reverb2DevicePreDelayRunTimePreset^ get ();
    void set (Reverb2DevicePreDelayRunTimePreset^ value);
}
JavaScript
function get_preDelay();
function set_preDelay(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


QualitySetup Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.QualitySetup Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property QualitySetup As Integer
C#
public int QualitySetup { get; set; }
Visual C++
public:
property int QualitySetup {
    int get ();
    void set (int value);
}
JavaScript
function get_qualitySetup();
function set_qualitySetup(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


ReverbTime Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.ReverbTime Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbTime As Reverb2DeviceReverbTimeRunTimePreset
C#
public Reverb2DeviceReverbTimeRunTimePreset ReverbTime { get; set; }
Visual C++
public:
property Reverb2DeviceReverbTimeRunTimePreset^ ReverbTime {
    Reverb2DeviceReverbTimeRunTimePreset^ get ();
    void set (Reverb2DeviceReverbTimeRunTimePreset^ value);
}
JavaScript
function get_reverbTime();
function set_reverbTime(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


Send Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.Send Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Send As Reverb2DeviceSendRunTimePreset
C#
public Reverb2DeviceSendRunTimePreset Send { get; set; }
Visual C++
public:
property Reverb2DeviceSendRunTimePreset^ Send {
    Reverb2DeviceSendRunTimePreset^ get ();
    void set (Reverb2DeviceSendRunTimePreset^ value);
}
JavaScript
function get_send();
function set_send(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Reverb2DeviceDeviceSlotRunTimePreset..::.type Property
Reverb2DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb2DeviceDeviceSlotRunTimePreset Class


Reverb2DeviceDryMix Class

[image]

.NET Framework Class Library
Reverb2DeviceDryMix Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceDryMix
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceDryMix
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceDryMix
JavaScript
NRenoiseTools.Reverb2DeviceDryMix = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceDryMix');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceDryMix

See Also

Reverb2DeviceDryMix Members


Reverb2DeviceDryMix Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMix Members
Reverb2DeviceDryMix Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceDryMix type exposes the following members.

Constructors

Name | Description
Reverb2DeviceDryMix |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceDryMix Class


Reverb2DeviceDryMix Constructor

[image]

.NET Framework Class Library
Reverb2DeviceDryMix Constructor
Reverb2DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceDryMix()
Visual C++
public:
Reverb2DeviceDryMix()
JavaScript
NRenoiseTools.Reverb2DeviceDryMix = function();

See Also

Reverb2DeviceDryMix Class


Reverb2DeviceDryMix Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMix Methods
Reverb2DeviceDryMix Class See Also Send Feedback

The Reverb2DeviceDryMix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceDryMix Class


Reverb2DeviceDryMix Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMix Properties
Reverb2DeviceDryMix Class See Also Send Feedback

The Reverb2DeviceDryMix type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceDryMix Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb2DeviceDryMix..::.MidiMappings Property
Reverb2DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb2DeviceDryMix Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceDryMix..::.Value Property
Reverb2DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceDryMix Class


Visualization Property

[image]

.NET Framework Class Library
Reverb2DeviceDryMix..::.Visualization Property
Reverb2DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb2DeviceDryMixVisualization
C#
public Reverb2DeviceDryMixVisualization Visualization { get; set; }
Visual C++
public:
property Reverb2DeviceDryMixVisualization Visualization {
    Reverb2DeviceDryMixVisualization get ();
    void set (Reverb2DeviceDryMixVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb2DeviceDryMix Class


Reverb2DeviceDryMixRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceDryMixRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceDryMixRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceDryMixRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceDryMixRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceDryMixRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceDryMixRunTimePreset

See Also

Reverb2DeviceDryMixRunTimePreset Members


Reverb2DeviceDryMixRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset Members
Reverb2DeviceDryMixRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceDryMixRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceDryMixRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb2DeviceDryMixRunTimePreset Class


Reverb2DeviceDryMixRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset Constructor
Reverb2DeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceDryMixRunTimePreset()
Visual C++
public:
Reverb2DeviceDryMixRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceDryMixRunTimePreset = function();

See Also

Reverb2DeviceDryMixRunTimePreset Class


Reverb2DeviceDryMixRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset Methods
Reverb2DeviceDryMixRunTimePreset Class See Also Send Feedback

The Reverb2DeviceDryMixRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceDryMixRunTimePreset Class


Reverb2DeviceDryMixRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset Properties
Reverb2DeviceDryMixRunTimePreset Class See Also Send Feedback

The Reverb2DeviceDryMixRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb2DeviceDryMixRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceDryMixRunTimePreset..::.Value Property
Reverb2DeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceDryMixRunTimePreset Class


Reverb2DeviceDryMixVisualization Enumeration

[image]

.NET Framework Class Library
Reverb2DeviceDryMixVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb2DeviceDryMixVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb2DeviceDryMixVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb2DeviceDryMixVisualization
JavaScript
NRenoiseTools.Reverb2DeviceDryMixVisualization = function();
NRenoiseTools.Reverb2DeviceDryMixVisualization.createEnum('NRenoiseTools.Reverb2DeviceDryMixVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb2DeviceLPFilter Class

[image]

.NET Framework Class Library
Reverb2DeviceLPFilter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceLPFilter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceLPFilter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceLPFilter
JavaScript
NRenoiseTools.Reverb2DeviceLPFilter = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceLPFilter');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceLPFilter

See Also

Reverb2DeviceLPFilter Members


Reverb2DeviceLPFilter Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilter Members
Reverb2DeviceLPFilter Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceLPFilter type exposes the following members.

Constructors

Name | Description
Reverb2DeviceLPFilter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceLPFilter Class


Reverb2DeviceLPFilter Constructor

[image]

.NET Framework Class Library
Reverb2DeviceLPFilter Constructor
Reverb2DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceLPFilter()
Visual C++
public:
Reverb2DeviceLPFilter()
JavaScript
NRenoiseTools.Reverb2DeviceLPFilter = function();

See Also

Reverb2DeviceLPFilter Class


Reverb2DeviceLPFilter Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilter Methods
Reverb2DeviceLPFilter Class See Also Send Feedback

The Reverb2DeviceLPFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceLPFilter Class


Reverb2DeviceLPFilter Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilter Properties
Reverb2DeviceLPFilter Class See Also Send Feedback

The Reverb2DeviceLPFilter type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceLPFilter Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb2DeviceLPFilter..::.MidiMappings Property
Reverb2DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb2DeviceLPFilter Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceLPFilter..::.Value Property
Reverb2DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceLPFilter Class


Visualization Property

[image]

.NET Framework Class Library
Reverb2DeviceLPFilter..::.Visualization Property
Reverb2DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb2DeviceLPFilterVisualization
C#
public Reverb2DeviceLPFilterVisualization Visualization { get; set; }
Visual C++
public:
property Reverb2DeviceLPFilterVisualization Visualization {
    Reverb2DeviceLPFilterVisualization get ();
    void set (Reverb2DeviceLPFilterVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb2DeviceLPFilter Class


Reverb2DeviceLPFilterRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceLPFilterRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceLPFilterRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceLPFilterRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceLPFilterRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceLPFilterRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceLPFilterRunTimePreset

See Also

Reverb2DeviceLPFilterRunTimePreset Members


Reverb2DeviceLPFilterRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset Members
Reverb2DeviceLPFilterRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceLPFilterRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceLPFilterRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb2DeviceLPFilterRunTimePreset Class


Reverb2DeviceLPFilterRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset Constructor
Reverb2DeviceLPFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceLPFilterRunTimePreset()
Visual C++
public:
Reverb2DeviceLPFilterRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceLPFilterRunTimePreset = function();

See Also

Reverb2DeviceLPFilterRunTimePreset Class


Reverb2DeviceLPFilterRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset Methods
Reverb2DeviceLPFilterRunTimePreset Class See Also Send Feedback

The Reverb2DeviceLPFilterRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceLPFilterRunTimePreset Class


Reverb2DeviceLPFilterRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset Properties
Reverb2DeviceLPFilterRunTimePreset Class See Also Send Feedback

The Reverb2DeviceLPFilterRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb2DeviceLPFilterRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceLPFilterRunTimePreset..::.Value Property
Reverb2DeviceLPFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceLPFilterRunTimePreset Class


Reverb2DeviceLPFilterVisualization Enumeration

[image]

.NET Framework Class Library
Reverb2DeviceLPFilterVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb2DeviceLPFilterVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb2DeviceLPFilterVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb2DeviceLPFilterVisualization
JavaScript
NRenoiseTools.Reverb2DeviceLPFilterVisualization = function();
NRenoiseTools.Reverb2DeviceLPFilterVisualization.createEnum('NRenoiseTools.Reverb2DeviceLPFilterVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb2DevicePreDelay Class

[image]

.NET Framework Class Library
Reverb2DevicePreDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DevicePreDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DevicePreDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DevicePreDelay
JavaScript
NRenoiseTools.Reverb2DevicePreDelay = function();

Type.createClass(
    'NRenoiseTools.Reverb2DevicePreDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DevicePreDelay

See Also

Reverb2DevicePreDelay Members


Reverb2DevicePreDelay Members

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelay Members
Reverb2DevicePreDelay Class Constructors Methods Properties See Also Send Feedback

The Reverb2DevicePreDelay type exposes the following members.

Constructors

Name | Description
Reverb2DevicePreDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DevicePreDelay Class


Reverb2DevicePreDelay Constructor

[image]

.NET Framework Class Library
Reverb2DevicePreDelay Constructor
Reverb2DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DevicePreDelay()
Visual C++
public:
Reverb2DevicePreDelay()
JavaScript
NRenoiseTools.Reverb2DevicePreDelay = function();

See Also

Reverb2DevicePreDelay Class


Reverb2DevicePreDelay Methods

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelay Methods
Reverb2DevicePreDelay Class See Also Send Feedback

The Reverb2DevicePreDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DevicePreDelay Class


Reverb2DevicePreDelay Properties

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelay Properties
Reverb2DevicePreDelay Class See Also Send Feedback

The Reverb2DevicePreDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DevicePreDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb2DevicePreDelay..::.MidiMappings Property
Reverb2DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb2DevicePreDelay Class


Value Property

[image]

.NET Framework Class Library
Reverb2DevicePreDelay..::.Value Property
Reverb2DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DevicePreDelay Class


Visualization Property

[image]

.NET Framework Class Library
Reverb2DevicePreDelay..::.Visualization Property
Reverb2DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb2DevicePreDelayVisualization
C#
public Reverb2DevicePreDelayVisualization Visualization { get; set; }
Visual C++
public:
property Reverb2DevicePreDelayVisualization Visualization {
    Reverb2DevicePreDelayVisualization get ();
    void set (Reverb2DevicePreDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb2DevicePreDelay Class


Reverb2DevicePreDelayRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DevicePreDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DevicePreDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DevicePreDelayRunTimePreset
JavaScript
NRenoiseTools.Reverb2DevicePreDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DevicePreDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DevicePreDelayRunTimePreset

See Also

Reverb2DevicePreDelayRunTimePreset Members


Reverb2DevicePreDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset Members
Reverb2DevicePreDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DevicePreDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DevicePreDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb2DevicePreDelayRunTimePreset Class


Reverb2DevicePreDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset Constructor
Reverb2DevicePreDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DevicePreDelayRunTimePreset()
Visual C++
public:
Reverb2DevicePreDelayRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DevicePreDelayRunTimePreset = function();

See Also

Reverb2DevicePreDelayRunTimePreset Class


Reverb2DevicePreDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset Methods
Reverb2DevicePreDelayRunTimePreset Class See Also Send Feedback

The Reverb2DevicePreDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DevicePreDelayRunTimePreset Class


Reverb2DevicePreDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset Properties
Reverb2DevicePreDelayRunTimePreset Class See Also Send Feedback

The Reverb2DevicePreDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb2DevicePreDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb2DevicePreDelayRunTimePreset..::.Value Property
Reverb2DevicePreDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DevicePreDelayRunTimePreset Class


Reverb2DevicePreDelayVisualization Enumeration

[image]

.NET Framework Class Library
Reverb2DevicePreDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb2DevicePreDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb2DevicePreDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb2DevicePreDelayVisualization
JavaScript
NRenoiseTools.Reverb2DevicePreDelayVisualization = function();
NRenoiseTools.Reverb2DevicePreDelayVisualization.createEnum('NRenoiseTools.Reverb2DevicePreDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb2DeviceReverbDevice Class

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceReverbDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceReverbDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceReverbDevice
JavaScript
NRenoiseTools.Reverb2DeviceReverbDevice = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceReverbDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceReverbDevice

See Also

Reverb2DeviceReverbDevice Members


Reverb2DeviceReverbDevice Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbDevice Members
Reverb2DeviceReverbDevice Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceReverbDevice type exposes the following members.

Constructors

Name | Description
Reverb2DeviceReverbDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DryMix |
IsActive |
IsSelected |
LPFilter |
PreDelay |
QualitySetup |
ReverbTime |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Send |
type |

See Also

Reverb2DeviceReverbDevice Class


Reverb2DeviceReverbDevice Constructor

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice Constructor
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceReverbDevice()
Visual C++
public:
Reverb2DeviceReverbDevice()
JavaScript
NRenoiseTools.Reverb2DeviceReverbDevice = function();

See Also

Reverb2DeviceReverbDevice Class


Reverb2DeviceReverbDevice Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbDevice Methods
Reverb2DeviceReverbDevice Class See Also Send Feedback

The Reverb2DeviceReverbDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceReverbDevice Class


Reverb2DeviceReverbDevice Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbDevice Properties
Reverb2DeviceReverbDevice Class See Also Send Feedback

The Reverb2DeviceReverbDevice type exposes the following members.

Properties

Name | Description
DryMix |
IsActive |
IsSelected |
LPFilter |
PreDelay |
QualitySetup |
ReverbTime |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Send |
type |

See Also

Reverb2DeviceReverbDevice Class


DryMix Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.DryMix Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As Reverb2DeviceDryMix
C#
public Reverb2DeviceDryMix DryMix { get; set; }
Visual C++
public:
property Reverb2DeviceDryMix^ DryMix {
    Reverb2DeviceDryMix^ get ();
    void set (Reverb2DeviceDryMix^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


IsActive Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.IsActive Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.IsSelected Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


LPFilter Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.LPFilter Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPFilter As Reverb2DeviceLPFilter
C#
public Reverb2DeviceLPFilter LPFilter { get; set; }
Visual C++
public:
property Reverb2DeviceLPFilter^ LPFilter {
    Reverb2DeviceLPFilter^ get ();
    void set (Reverb2DeviceLPFilter^ value);
}
JavaScript
function get_lpFilter();
function set_lpFilter(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


PreDelay Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.PreDelay Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PreDelay As Reverb2DevicePreDelay
C#
public Reverb2DevicePreDelay PreDelay { get; set; }
Visual C++
public:
property Reverb2DevicePreDelay^ PreDelay {
    Reverb2DevicePreDelay^ get ();
    void set (Reverb2DevicePreDelay^ value);
}
JavaScript
function get_preDelay();
function set_preDelay(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


QualitySetup Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.QualitySetup Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property QualitySetup As Integer
C#
public int QualitySetup { get; set; }
Visual C++
public:
property int QualitySetup {
    int get ();
    void set (int value);
}
JavaScript
function get_qualitySetup();
function set_qualitySetup(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


ReverbTime Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.ReverbTime Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbTime As Reverb2DeviceReverbTime
C#
public Reverb2DeviceReverbTime ReverbTime { get; set; }
Visual C++
public:
property Reverb2DeviceReverbTime^ ReverbTime {
    Reverb2DeviceReverbTime^ get ();
    void set (Reverb2DeviceReverbTime^ value);
}
JavaScript
function get_reverbTime();
function set_reverbTime(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.RunTimePresetA Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Reverb2DeviceRunTimePreset
C#
public Reverb2DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Reverb2DeviceRunTimePreset^ RunTimePresetA {
    Reverb2DeviceRunTimePreset^ get ();
    void set (Reverb2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.RunTimePresetB Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Reverb2DeviceRunTimePreset
C#
public Reverb2DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Reverb2DeviceRunTimePreset^ RunTimePresetB {
    Reverb2DeviceRunTimePreset^ get ();
    void set (Reverb2DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.SelectedPresetIsModified Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.SelectedPresetName Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


Send Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.Send Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Send As Reverb2DeviceSend
C#
public Reverb2DeviceSend Send { get; set; }
Visual C++
public:
property Reverb2DeviceSend^ Send {
    Reverb2DeviceSend^ get ();
    void set (Reverb2DeviceSend^ value);
}
JavaScript
function get_send();
function set_send(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


type Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbDevice..::.type Property
Reverb2DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb2DeviceReverbDevice Class


Reverb2DeviceReverbTime Class

[image]

.NET Framework Class Library
Reverb2DeviceReverbTime Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceReverbTime
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceReverbTime
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceReverbTime
JavaScript
NRenoiseTools.Reverb2DeviceReverbTime = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceReverbTime');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceReverbTime

See Also

Reverb2DeviceReverbTime Members


Reverb2DeviceReverbTime Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTime Members
Reverb2DeviceReverbTime Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceReverbTime type exposes the following members.

Constructors

Name | Description
Reverb2DeviceReverbTime |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceReverbTime Class


Reverb2DeviceReverbTime Constructor

[image]

.NET Framework Class Library
Reverb2DeviceReverbTime Constructor
Reverb2DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceReverbTime()
Visual C++
public:
Reverb2DeviceReverbTime()
JavaScript
NRenoiseTools.Reverb2DeviceReverbTime = function();

See Also

Reverb2DeviceReverbTime Class


Reverb2DeviceReverbTime Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTime Methods
Reverb2DeviceReverbTime Class See Also Send Feedback

The Reverb2DeviceReverbTime type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceReverbTime Class


Reverb2DeviceReverbTime Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTime Properties
Reverb2DeviceReverbTime Class See Also Send Feedback

The Reverb2DeviceReverbTime type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceReverbTime Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbTime..::.MidiMappings Property
Reverb2DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb2DeviceReverbTime Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbTime..::.Value Property
Reverb2DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceReverbTime Class


Visualization Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbTime..::.Visualization Property
Reverb2DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb2DeviceReverbTimeVisualization
C#
public Reverb2DeviceReverbTimeVisualization Visualization { get; set; }
Visual C++
public:
property Reverb2DeviceReverbTimeVisualization Visualization {
    Reverb2DeviceReverbTimeVisualization get ();
    void set (Reverb2DeviceReverbTimeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb2DeviceReverbTime Class


Reverb2DeviceReverbTimeRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceReverbTimeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceReverbTimeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceReverbTimeRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceReverbTimeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceReverbTimeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceReverbTimeRunTimePreset

See Also

Reverb2DeviceReverbTimeRunTimePreset Members


Reverb2DeviceReverbTimeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset Members
Reverb2DeviceReverbTimeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceReverbTimeRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceReverbTimeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb2DeviceReverbTimeRunTimePreset Class


Reverb2DeviceReverbTimeRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset Constructor
Reverb2DeviceReverbTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceReverbTimeRunTimePreset()
Visual C++
public:
Reverb2DeviceReverbTimeRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceReverbTimeRunTimePreset = function();

See Also

Reverb2DeviceReverbTimeRunTimePreset Class


Reverb2DeviceReverbTimeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset Methods
Reverb2DeviceReverbTimeRunTimePreset Class See Also Send Feedback

The Reverb2DeviceReverbTimeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceReverbTimeRunTimePreset Class


Reverb2DeviceReverbTimeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset Properties
Reverb2DeviceReverbTimeRunTimePreset Class See Also Send Feedback

The Reverb2DeviceReverbTimeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb2DeviceReverbTimeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceReverbTimeRunTimePreset..::.Value Property
Reverb2DeviceReverbTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceReverbTimeRunTimePreset Class


Reverb2DeviceReverbTimeVisualization Enumeration

[image]

.NET Framework Class Library
Reverb2DeviceReverbTimeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb2DeviceReverbTimeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb2DeviceReverbTimeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb2DeviceReverbTimeVisualization
JavaScript
NRenoiseTools.Reverb2DeviceReverbTimeVisualization = function();
NRenoiseTools.Reverb2DeviceReverbTimeVisualization.createEnum('NRenoiseTools.Reverb2DeviceReverbTimeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb2DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceRunTimePreset

See Also

Reverb2DeviceRunTimePreset Members


Reverb2DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset Members
Reverb2DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Reverb2DeviceRunTimePreset Class


Reverb2DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset Constructor
Reverb2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceRunTimePreset()
Visual C++
public:
Reverb2DeviceRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceRunTimePreset = function();

See Also

Reverb2DeviceRunTimePreset Class


Reverb2DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset Methods
Reverb2DeviceRunTimePreset Class See Also Send Feedback

The Reverb2DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceRunTimePreset Class


Reverb2DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset Properties
Reverb2DeviceRunTimePreset Class See Also Send Feedback

The Reverb2DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Reverb2DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset..::.DeviceSlot Property
Reverb2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Reverb2DeviceDeviceSlotRunTimePreset
C#
public Reverb2DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Reverb2DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Reverb2DeviceDeviceSlotRunTimePreset^ get ();
    void set (Reverb2DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Reverb2DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Reverb2DeviceRunTimePreset..::.type Property
Reverb2DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb2DeviceRunTimePreset Class


Reverb2DeviceSend Class

[image]

.NET Framework Class Library
Reverb2DeviceSend Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceSend
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceSend
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceSend
JavaScript
NRenoiseTools.Reverb2DeviceSend = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceSend');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceSend

See Also

Reverb2DeviceSend Members


Reverb2DeviceSend Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceSend Members
Reverb2DeviceSend Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceSend type exposes the following members.

Constructors

Name | Description
Reverb2DeviceSend |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceSend Class


Reverb2DeviceSend Constructor

[image]

.NET Framework Class Library
Reverb2DeviceSend Constructor
Reverb2DeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceSend()
Visual C++
public:
Reverb2DeviceSend()
JavaScript
NRenoiseTools.Reverb2DeviceSend = function();

See Also

Reverb2DeviceSend Class


Reverb2DeviceSend Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceSend Methods
Reverb2DeviceSend Class See Also Send Feedback

The Reverb2DeviceSend type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceSend Class


Reverb2DeviceSend Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceSend Properties
Reverb2DeviceSend Class See Also Send Feedback

The Reverb2DeviceSend type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb2DeviceSend Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb2DeviceSend..::.MidiMappings Property
Reverb2DeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb2DeviceSend Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceSend..::.Value Property
Reverb2DeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceSend Class


Visualization Property

[image]

.NET Framework Class Library
Reverb2DeviceSend..::.Visualization Property
Reverb2DeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb2DeviceSendVisualization
C#
public Reverb2DeviceSendVisualization Visualization { get; set; }
Visual C++
public:
property Reverb2DeviceSendVisualization Visualization {
    Reverb2DeviceSendVisualization get ();
    void set (Reverb2DeviceSendVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb2DeviceSend Class


Reverb2DeviceSendRunTimePreset Class

[image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb2DeviceSendRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb2DeviceSendRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb2DeviceSendRunTimePreset
JavaScript
NRenoiseTools.Reverb2DeviceSendRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb2DeviceSendRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb2DeviceSendRunTimePreset

See Also

Reverb2DeviceSendRunTimePreset Members


Reverb2DeviceSendRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset Members
Reverb2DeviceSendRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb2DeviceSendRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb2DeviceSendRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb2DeviceSendRunTimePreset Class


Reverb2DeviceSendRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset Constructor
Reverb2DeviceSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb2DeviceSendRunTimePreset()
Visual C++
public:
Reverb2DeviceSendRunTimePreset()
JavaScript
NRenoiseTools.Reverb2DeviceSendRunTimePreset = function();

See Also

Reverb2DeviceSendRunTimePreset Class


Reverb2DeviceSendRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset Methods
Reverb2DeviceSendRunTimePreset Class See Also Send Feedback

The Reverb2DeviceSendRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb2DeviceSendRunTimePreset Class


Reverb2DeviceSendRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset Properties
Reverb2DeviceSendRunTimePreset Class See Also Send Feedback

The Reverb2DeviceSendRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb2DeviceSendRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb2DeviceSendRunTimePreset..::.Value Property
Reverb2DeviceSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb2DeviceSendRunTimePreset Class


Reverb2DeviceSendVisualization Enumeration

[image]

.NET Framework Class Library
Reverb2DeviceSendVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb2DeviceSendVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb2DeviceSendVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb2DeviceSendVisualization
JavaScript
NRenoiseTools.Reverb2DeviceSendVisualization = function();
NRenoiseTools.Reverb2DeviceSendVisualization.createEnum('NRenoiseTools.Reverb2DeviceSendVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceColor Class

[image]

.NET Framework Class Library
Reverb3DeviceColor Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceColor
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceColor
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceColor
JavaScript
NRenoiseTools.Reverb3DeviceColor = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceColor');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceColor

See Also

Reverb3DeviceColor Members


Reverb3DeviceColor Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceColor Members
Reverb3DeviceColor Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceColor type exposes the following members.

Constructors

Name | Description
Reverb3DeviceColor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceColor Class


Reverb3DeviceColor Constructor

[image]

.NET Framework Class Library
Reverb3DeviceColor Constructor
Reverb3DeviceColor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceColor()
Visual C++
public:
Reverb3DeviceColor()
JavaScript
NRenoiseTools.Reverb3DeviceColor = function();

See Also

Reverb3DeviceColor Class


Reverb3DeviceColor Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceColor Methods
Reverb3DeviceColor Class See Also Send Feedback

The Reverb3DeviceColor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceColor Class


Reverb3DeviceColor Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceColor Properties
Reverb3DeviceColor Class See Also Send Feedback

The Reverb3DeviceColor type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceColor Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceColor..::.MidiMappings Property
Reverb3DeviceColor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceColor Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceColor..::.Value Property
Reverb3DeviceColor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceColor Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceColor..::.Visualization Property
Reverb3DeviceColor Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceColorVisualization
C#
public Reverb3DeviceColorVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceColorVisualization Visualization {
    Reverb3DeviceColorVisualization get ();
    void set (Reverb3DeviceColorVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceColor Class


Reverb3DeviceColorRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceColorRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceColorRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceColorRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceColorRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceColorRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceColorRunTimePreset

See Also

Reverb3DeviceColorRunTimePreset Members


Reverb3DeviceColorRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset Members
Reverb3DeviceColorRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceColorRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceColorRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceColorRunTimePreset Class


Reverb3DeviceColorRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset Constructor
Reverb3DeviceColorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceColorRunTimePreset()
Visual C++
public:
Reverb3DeviceColorRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceColorRunTimePreset = function();

See Also

Reverb3DeviceColorRunTimePreset Class


Reverb3DeviceColorRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset Methods
Reverb3DeviceColorRunTimePreset Class See Also Send Feedback

The Reverb3DeviceColorRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceColorRunTimePreset Class


Reverb3DeviceColorRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset Properties
Reverb3DeviceColorRunTimePreset Class See Also Send Feedback

The Reverb3DeviceColorRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceColorRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceColorRunTimePreset..::.Value Property
Reverb3DeviceColorRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceColorRunTimePreset Class


Reverb3DeviceColorVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceColorVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceColorVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceColorVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceColorVisualization
JavaScript
NRenoiseTools.Reverb3DeviceColorVisualization = function();
NRenoiseTools.Reverb3DeviceColorVisualization.createEnum('NRenoiseTools.Reverb3DeviceColorVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceDeviceSlotRunTimePreset

See Also

Reverb3DeviceDeviceSlotRunTimePreset Members


Reverb3DeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset Members
Reverb3DeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color |
DryMix |
LPFilter |
LPGain |
Pan |
PreDelay |
ReverbTime |
type |
WetMix |
Width |

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Reverb3DeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset Constructor
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceDeviceSlotRunTimePreset()
Visual C++
public:
Reverb3DeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceDeviceSlotRunTimePreset = function();

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Reverb3DeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset Methods
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Reverb3DeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Reverb3DeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset Properties
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The Reverb3DeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Color |
DryMix |
LPFilter |
LPGain |
Pan |
PreDelay |
ReverbTime |
type |
WetMix |
Width |

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Color Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.Color Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Color As Reverb3DeviceColorRunTimePreset
C#
public Reverb3DeviceColorRunTimePreset Color { get; set; }
Visual C++
public:
property Reverb3DeviceColorRunTimePreset^ Color {
    Reverb3DeviceColorRunTimePreset^ get ();
    void set (Reverb3DeviceColorRunTimePreset^ value);
}
JavaScript
function get_color();
function set_color(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


DryMix Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.DryMix Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As Reverb3DeviceDryMixRunTimePreset
C#
public Reverb3DeviceDryMixRunTimePreset DryMix { get; set; }
Visual C++
public:
property Reverb3DeviceDryMixRunTimePreset^ DryMix {
    Reverb3DeviceDryMixRunTimePreset^ get ();
    void set (Reverb3DeviceDryMixRunTimePreset^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


LPFilter Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.LPFilter Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPFilter As Reverb3DeviceLPFilterRunTimePreset
C#
public Reverb3DeviceLPFilterRunTimePreset LPFilter { get; set; }
Visual C++
public:
property Reverb3DeviceLPFilterRunTimePreset^ LPFilter {
    Reverb3DeviceLPFilterRunTimePreset^ get ();
    void set (Reverb3DeviceLPFilterRunTimePreset^ value);
}
JavaScript
function get_lpFilter();
function set_lpFilter(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


LPGain Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.LPGain Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPGain As Reverb3DeviceLPGainRunTimePreset
C#
public Reverb3DeviceLPGainRunTimePreset LPGain { get; set; }
Visual C++
public:
property Reverb3DeviceLPGainRunTimePreset^ LPGain {
    Reverb3DeviceLPGainRunTimePreset^ get ();
    void set (Reverb3DeviceLPGainRunTimePreset^ value);
}
JavaScript
function get_lpGain();
function set_lpGain(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Pan Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.Pan Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Pan As Reverb3DevicePanRunTimePreset
C#
public Reverb3DevicePanRunTimePreset Pan { get; set; }
Visual C++
public:
property Reverb3DevicePanRunTimePreset^ Pan {
    Reverb3DevicePanRunTimePreset^ get ();
    void set (Reverb3DevicePanRunTimePreset^ value);
}
JavaScript
function get_pan();
function set_pan(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


PreDelay Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.PreDelay Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PreDelay As Reverb3DevicePreDelayRunTimePreset
C#
public Reverb3DevicePreDelayRunTimePreset PreDelay { get; set; }
Visual C++
public:
property Reverb3DevicePreDelayRunTimePreset^ PreDelay {
    Reverb3DevicePreDelayRunTimePreset^ get ();
    void set (Reverb3DevicePreDelayRunTimePreset^ value);
}
JavaScript
function get_preDelay();
function set_preDelay(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


ReverbTime Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.ReverbTime Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbTime As Reverb3DeviceReverbTimeRunTimePreset
C#
public Reverb3DeviceReverbTimeRunTimePreset ReverbTime { get; set; }
Visual C++
public:
property Reverb3DeviceReverbTimeRunTimePreset^ ReverbTime {
    Reverb3DeviceReverbTimeRunTimePreset^ get ();
    void set (Reverb3DeviceReverbTimeRunTimePreset^ value);
}
JavaScript
function get_reverbTime();
function set_reverbTime(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.type Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


WetMix Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.WetMix Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetMix As Reverb3DeviceWetMixRunTimePreset
C#
public Reverb3DeviceWetMixRunTimePreset WetMix { get; set; }
Visual C++
public:
property Reverb3DeviceWetMixRunTimePreset^ WetMix {
    Reverb3DeviceWetMixRunTimePreset^ get ();
    void set (Reverb3DeviceWetMixRunTimePreset^ value);
}
JavaScript
function get_wetMix();
function set_wetMix(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Width Property

[image]

.NET Framework Class Library
Reverb3DeviceDeviceSlotRunTimePreset..::.Width Property
Reverb3DeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Reverb3DeviceWidthRunTimePreset
C#
public Reverb3DeviceWidthRunTimePreset Width { get; set; }
Visual C++
public:
property Reverb3DeviceWidthRunTimePreset^ Width {
    Reverb3DeviceWidthRunTimePreset^ get ();
    void set (Reverb3DeviceWidthRunTimePreset^ value);
}
JavaScript
function get_width();
function set_width(value);

Remarks

See Also

Reverb3DeviceDeviceSlotRunTimePreset Class


Reverb3DeviceDryMix Class

[image]

.NET Framework Class Library
Reverb3DeviceDryMix Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceDryMix
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceDryMix
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceDryMix
JavaScript
NRenoiseTools.Reverb3DeviceDryMix = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceDryMix');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceDryMix

See Also

Reverb3DeviceDryMix Members


Reverb3DeviceDryMix Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMix Members
Reverb3DeviceDryMix Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceDryMix type exposes the following members.

Constructors

Name | Description
Reverb3DeviceDryMix |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceDryMix Class


Reverb3DeviceDryMix Constructor

[image]

.NET Framework Class Library
Reverb3DeviceDryMix Constructor
Reverb3DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceDryMix()
Visual C++
public:
Reverb3DeviceDryMix()
JavaScript
NRenoiseTools.Reverb3DeviceDryMix = function();

See Also

Reverb3DeviceDryMix Class


Reverb3DeviceDryMix Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMix Methods
Reverb3DeviceDryMix Class See Also Send Feedback

The Reverb3DeviceDryMix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceDryMix Class


Reverb3DeviceDryMix Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMix Properties
Reverb3DeviceDryMix Class See Also Send Feedback

The Reverb3DeviceDryMix type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceDryMix Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceDryMix..::.MidiMappings Property
Reverb3DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceDryMix Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceDryMix..::.Value Property
Reverb3DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceDryMix Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceDryMix..::.Visualization Property
Reverb3DeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceDryMixVisualization
C#
public Reverb3DeviceDryMixVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceDryMixVisualization Visualization {
    Reverb3DeviceDryMixVisualization get ();
    void set (Reverb3DeviceDryMixVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceDryMix Class


Reverb3DeviceDryMixRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceDryMixRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceDryMixRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceDryMixRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceDryMixRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceDryMixRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceDryMixRunTimePreset

See Also

Reverb3DeviceDryMixRunTimePreset Members


Reverb3DeviceDryMixRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset Members
Reverb3DeviceDryMixRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceDryMixRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceDryMixRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceDryMixRunTimePreset Class


Reverb3DeviceDryMixRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset Constructor
Reverb3DeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceDryMixRunTimePreset()
Visual C++
public:
Reverb3DeviceDryMixRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceDryMixRunTimePreset = function();

See Also

Reverb3DeviceDryMixRunTimePreset Class


Reverb3DeviceDryMixRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset Methods
Reverb3DeviceDryMixRunTimePreset Class See Also Send Feedback

The Reverb3DeviceDryMixRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceDryMixRunTimePreset Class


Reverb3DeviceDryMixRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset Properties
Reverb3DeviceDryMixRunTimePreset Class See Also Send Feedback

The Reverb3DeviceDryMixRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceDryMixRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceDryMixRunTimePreset..::.Value Property
Reverb3DeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceDryMixRunTimePreset Class


Reverb3DeviceDryMixVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceDryMixVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceDryMixVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceDryMixVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceDryMixVisualization
JavaScript
NRenoiseTools.Reverb3DeviceDryMixVisualization = function();
NRenoiseTools.Reverb3DeviceDryMixVisualization.createEnum('NRenoiseTools.Reverb3DeviceDryMixVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceLPFilter Class

[image]

.NET Framework Class Library
Reverb3DeviceLPFilter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceLPFilter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceLPFilter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceLPFilter
JavaScript
NRenoiseTools.Reverb3DeviceLPFilter = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceLPFilter');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceLPFilter

See Also

Reverb3DeviceLPFilter Members


Reverb3DeviceLPFilter Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilter Members
Reverb3DeviceLPFilter Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceLPFilter type exposes the following members.

Constructors

Name | Description
Reverb3DeviceLPFilter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceLPFilter Class


Reverb3DeviceLPFilter Constructor

[image]

.NET Framework Class Library
Reverb3DeviceLPFilter Constructor
Reverb3DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceLPFilter()
Visual C++
public:
Reverb3DeviceLPFilter()
JavaScript
NRenoiseTools.Reverb3DeviceLPFilter = function();

See Also

Reverb3DeviceLPFilter Class


Reverb3DeviceLPFilter Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilter Methods
Reverb3DeviceLPFilter Class See Also Send Feedback

The Reverb3DeviceLPFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceLPFilter Class


Reverb3DeviceLPFilter Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilter Properties
Reverb3DeviceLPFilter Class See Also Send Feedback

The Reverb3DeviceLPFilter type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceLPFilter Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceLPFilter..::.MidiMappings Property
Reverb3DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceLPFilter Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceLPFilter..::.Value Property
Reverb3DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceLPFilter Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceLPFilter..::.Visualization Property
Reverb3DeviceLPFilter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceLPFilterVisualization
C#
public Reverb3DeviceLPFilterVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceLPFilterVisualization Visualization {
    Reverb3DeviceLPFilterVisualization get ();
    void set (Reverb3DeviceLPFilterVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceLPFilter Class


Reverb3DeviceLPFilterRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceLPFilterRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceLPFilterRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceLPFilterRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceLPFilterRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceLPFilterRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceLPFilterRunTimePreset

See Also

Reverb3DeviceLPFilterRunTimePreset Members


Reverb3DeviceLPFilterRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset Members
Reverb3DeviceLPFilterRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceLPFilterRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceLPFilterRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceLPFilterRunTimePreset Class


Reverb3DeviceLPFilterRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset Constructor
Reverb3DeviceLPFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceLPFilterRunTimePreset()
Visual C++
public:
Reverb3DeviceLPFilterRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceLPFilterRunTimePreset = function();

See Also

Reverb3DeviceLPFilterRunTimePreset Class


Reverb3DeviceLPFilterRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset Methods
Reverb3DeviceLPFilterRunTimePreset Class See Also Send Feedback

The Reverb3DeviceLPFilterRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceLPFilterRunTimePreset Class


Reverb3DeviceLPFilterRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset Properties
Reverb3DeviceLPFilterRunTimePreset Class See Also Send Feedback

The Reverb3DeviceLPFilterRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceLPFilterRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceLPFilterRunTimePreset..::.Value Property
Reverb3DeviceLPFilterRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceLPFilterRunTimePreset Class


Reverb3DeviceLPFilterVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceLPFilterVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceLPFilterVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceLPFilterVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceLPFilterVisualization
JavaScript
NRenoiseTools.Reverb3DeviceLPFilterVisualization = function();
NRenoiseTools.Reverb3DeviceLPFilterVisualization.createEnum('NRenoiseTools.Reverb3DeviceLPFilterVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceLPGain Class

[image]

.NET Framework Class Library
Reverb3DeviceLPGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceLPGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceLPGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceLPGain
JavaScript
NRenoiseTools.Reverb3DeviceLPGain = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceLPGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceLPGain

See Also

Reverb3DeviceLPGain Members


Reverb3DeviceLPGain Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGain Members
Reverb3DeviceLPGain Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceLPGain type exposes the following members.

Constructors

Name | Description
Reverb3DeviceLPGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceLPGain Class


Reverb3DeviceLPGain Constructor

[image]

.NET Framework Class Library
Reverb3DeviceLPGain Constructor
Reverb3DeviceLPGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceLPGain()
Visual C++
public:
Reverb3DeviceLPGain()
JavaScript
NRenoiseTools.Reverb3DeviceLPGain = function();

See Also

Reverb3DeviceLPGain Class


Reverb3DeviceLPGain Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGain Methods
Reverb3DeviceLPGain Class See Also Send Feedback

The Reverb3DeviceLPGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceLPGain Class


Reverb3DeviceLPGain Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGain Properties
Reverb3DeviceLPGain Class See Also Send Feedback

The Reverb3DeviceLPGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceLPGain Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceLPGain..::.MidiMappings Property
Reverb3DeviceLPGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceLPGain Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceLPGain..::.Value Property
Reverb3DeviceLPGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceLPGain Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceLPGain..::.Visualization Property
Reverb3DeviceLPGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceLPGainVisualization
C#
public Reverb3DeviceLPGainVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceLPGainVisualization Visualization {
    Reverb3DeviceLPGainVisualization get ();
    void set (Reverb3DeviceLPGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceLPGain Class


Reverb3DeviceLPGainRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceLPGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceLPGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceLPGainRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceLPGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceLPGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceLPGainRunTimePreset

See Also

Reverb3DeviceLPGainRunTimePreset Members


Reverb3DeviceLPGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset Members
Reverb3DeviceLPGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceLPGainRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceLPGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceLPGainRunTimePreset Class


Reverb3DeviceLPGainRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset Constructor
Reverb3DeviceLPGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceLPGainRunTimePreset()
Visual C++
public:
Reverb3DeviceLPGainRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceLPGainRunTimePreset = function();

See Also

Reverb3DeviceLPGainRunTimePreset Class


Reverb3DeviceLPGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset Methods
Reverb3DeviceLPGainRunTimePreset Class See Also Send Feedback

The Reverb3DeviceLPGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceLPGainRunTimePreset Class


Reverb3DeviceLPGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset Properties
Reverb3DeviceLPGainRunTimePreset Class See Also Send Feedback

The Reverb3DeviceLPGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceLPGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceLPGainRunTimePreset..::.Value Property
Reverb3DeviceLPGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceLPGainRunTimePreset Class


Reverb3DeviceLPGainVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceLPGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceLPGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceLPGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceLPGainVisualization
JavaScript
NRenoiseTools.Reverb3DeviceLPGainVisualization = function();
NRenoiseTools.Reverb3DeviceLPGainVisualization.createEnum('NRenoiseTools.Reverb3DeviceLPGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DevicePan Class

[image]

.NET Framework Class Library
Reverb3DevicePan Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DevicePan
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DevicePan
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DevicePan
JavaScript
NRenoiseTools.Reverb3DevicePan = function();

Type.createClass(
    'NRenoiseTools.Reverb3DevicePan');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DevicePan

See Also

Reverb3DevicePan Members


Reverb3DevicePan Members

[image] [image]

.NET Framework Class Library
Reverb3DevicePan Members
Reverb3DevicePan Class Constructors Methods Properties See Also Send Feedback

The Reverb3DevicePan type exposes the following members.

Constructors

Name | Description
Reverb3DevicePan |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DevicePan Class


Reverb3DevicePan Constructor

[image]

.NET Framework Class Library
Reverb3DevicePan Constructor
Reverb3DevicePan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DevicePan()
Visual C++
public:
Reverb3DevicePan()
JavaScript
NRenoiseTools.Reverb3DevicePan = function();

See Also

Reverb3DevicePan Class


Reverb3DevicePan Methods

[image] [image]

.NET Framework Class Library
Reverb3DevicePan Methods
Reverb3DevicePan Class See Also Send Feedback

The Reverb3DevicePan type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DevicePan Class


Reverb3DevicePan Properties

[image] [image]

.NET Framework Class Library
Reverb3DevicePan Properties
Reverb3DevicePan Class See Also Send Feedback

The Reverb3DevicePan type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DevicePan Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DevicePan..::.MidiMappings Property
Reverb3DevicePan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DevicePan Class


Value Property

[image]

.NET Framework Class Library
Reverb3DevicePan..::.Value Property
Reverb3DevicePan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DevicePan Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DevicePan..::.Visualization Property
Reverb3DevicePan Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DevicePanVisualization
C#
public Reverb3DevicePanVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DevicePanVisualization Visualization {
    Reverb3DevicePanVisualization get ();
    void set (Reverb3DevicePanVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DevicePan Class


Reverb3DevicePanRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DevicePanRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DevicePanRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DevicePanRunTimePreset
JavaScript
NRenoiseTools.Reverb3DevicePanRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DevicePanRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DevicePanRunTimePreset

See Also

Reverb3DevicePanRunTimePreset Members


Reverb3DevicePanRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset Members
Reverb3DevicePanRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DevicePanRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DevicePanRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DevicePanRunTimePreset Class


Reverb3DevicePanRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset Constructor
Reverb3DevicePanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DevicePanRunTimePreset()
Visual C++
public:
Reverb3DevicePanRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DevicePanRunTimePreset = function();

See Also

Reverb3DevicePanRunTimePreset Class


Reverb3DevicePanRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset Methods
Reverb3DevicePanRunTimePreset Class See Also Send Feedback

The Reverb3DevicePanRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DevicePanRunTimePreset Class


Reverb3DevicePanRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset Properties
Reverb3DevicePanRunTimePreset Class See Also Send Feedback

The Reverb3DevicePanRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DevicePanRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DevicePanRunTimePreset..::.Value Property
Reverb3DevicePanRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DevicePanRunTimePreset Class


Reverb3DevicePanVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DevicePanVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DevicePanVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DevicePanVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DevicePanVisualization
JavaScript
NRenoiseTools.Reverb3DevicePanVisualization = function();
NRenoiseTools.Reverb3DevicePanVisualization.createEnum('NRenoiseTools.Reverb3DevicePanVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DevicePreDelay Class

[image]

.NET Framework Class Library
Reverb3DevicePreDelay Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DevicePreDelay
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DevicePreDelay
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DevicePreDelay
JavaScript
NRenoiseTools.Reverb3DevicePreDelay = function();

Type.createClass(
    'NRenoiseTools.Reverb3DevicePreDelay');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DevicePreDelay

See Also

Reverb3DevicePreDelay Members


Reverb3DevicePreDelay Members

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelay Members
Reverb3DevicePreDelay Class Constructors Methods Properties See Also Send Feedback

The Reverb3DevicePreDelay type exposes the following members.

Constructors

Name | Description
Reverb3DevicePreDelay |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DevicePreDelay Class


Reverb3DevicePreDelay Constructor

[image]

.NET Framework Class Library
Reverb3DevicePreDelay Constructor
Reverb3DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DevicePreDelay()
Visual C++
public:
Reverb3DevicePreDelay()
JavaScript
NRenoiseTools.Reverb3DevicePreDelay = function();

See Also

Reverb3DevicePreDelay Class


Reverb3DevicePreDelay Methods

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelay Methods
Reverb3DevicePreDelay Class See Also Send Feedback

The Reverb3DevicePreDelay type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DevicePreDelay Class


Reverb3DevicePreDelay Properties

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelay Properties
Reverb3DevicePreDelay Class See Also Send Feedback

The Reverb3DevicePreDelay type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DevicePreDelay Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DevicePreDelay..::.MidiMappings Property
Reverb3DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DevicePreDelay Class


Value Property

[image]

.NET Framework Class Library
Reverb3DevicePreDelay..::.Value Property
Reverb3DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DevicePreDelay Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DevicePreDelay..::.Visualization Property
Reverb3DevicePreDelay Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DevicePreDelayVisualization
C#
public Reverb3DevicePreDelayVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DevicePreDelayVisualization Visualization {
    Reverb3DevicePreDelayVisualization get ();
    void set (Reverb3DevicePreDelayVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DevicePreDelay Class


Reverb3DevicePreDelayRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DevicePreDelayRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DevicePreDelayRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DevicePreDelayRunTimePreset
JavaScript
NRenoiseTools.Reverb3DevicePreDelayRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DevicePreDelayRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DevicePreDelayRunTimePreset

See Also

Reverb3DevicePreDelayRunTimePreset Members


Reverb3DevicePreDelayRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset Members
Reverb3DevicePreDelayRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DevicePreDelayRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DevicePreDelayRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DevicePreDelayRunTimePreset Class


Reverb3DevicePreDelayRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset Constructor
Reverb3DevicePreDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DevicePreDelayRunTimePreset()
Visual C++
public:
Reverb3DevicePreDelayRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DevicePreDelayRunTimePreset = function();

See Also

Reverb3DevicePreDelayRunTimePreset Class


Reverb3DevicePreDelayRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset Methods
Reverb3DevicePreDelayRunTimePreset Class See Also Send Feedback

The Reverb3DevicePreDelayRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DevicePreDelayRunTimePreset Class


Reverb3DevicePreDelayRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset Properties
Reverb3DevicePreDelayRunTimePreset Class See Also Send Feedback

The Reverb3DevicePreDelayRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DevicePreDelayRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DevicePreDelayRunTimePreset..::.Value Property
Reverb3DevicePreDelayRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DevicePreDelayRunTimePreset Class


Reverb3DevicePreDelayVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DevicePreDelayVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DevicePreDelayVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DevicePreDelayVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DevicePreDelayVisualization
JavaScript
NRenoiseTools.Reverb3DevicePreDelayVisualization = function();
NRenoiseTools.Reverb3DevicePreDelayVisualization.createEnum('NRenoiseTools.Reverb3DevicePreDelayVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceReverbDevice Class

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceReverbDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceReverbDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceReverbDevice
JavaScript
NRenoiseTools.Reverb3DeviceReverbDevice = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceReverbDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceReverbDevice

See Also

Reverb3DeviceReverbDevice Members


Reverb3DeviceReverbDevice Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbDevice Members
Reverb3DeviceReverbDevice Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceReverbDevice type exposes the following members.

Constructors

Name | Description
Reverb3DeviceReverbDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color |
DryMix |
IsActive |
IsSelected |
LPFilter |
LPGain |
Pan |
PreDelay |
ReverbTime |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetMix |
Width |

See Also

Reverb3DeviceReverbDevice Class


Reverb3DeviceReverbDevice Constructor

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice Constructor
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceReverbDevice()
Visual C++
public:
Reverb3DeviceReverbDevice()
JavaScript
NRenoiseTools.Reverb3DeviceReverbDevice = function();

See Also

Reverb3DeviceReverbDevice Class


Reverb3DeviceReverbDevice Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbDevice Methods
Reverb3DeviceReverbDevice Class See Also Send Feedback

The Reverb3DeviceReverbDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceReverbDevice Class


Reverb3DeviceReverbDevice Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbDevice Properties
Reverb3DeviceReverbDevice Class See Also Send Feedback

The Reverb3DeviceReverbDevice type exposes the following members.

Properties

Name | Description
Color |
DryMix |
IsActive |
IsSelected |
LPFilter |
LPGain |
Pan |
PreDelay |
ReverbTime |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |
WetMix |
Width |

See Also

Reverb3DeviceReverbDevice Class


Color Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.Color Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Color As Reverb3DeviceColor
C#
public Reverb3DeviceColor Color { get; set; }
Visual C++
public:
property Reverb3DeviceColor^ Color {
    Reverb3DeviceColor^ get ();
    void set (Reverb3DeviceColor^ value);
}
JavaScript
function get_color();
function set_color(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


DryMix Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.DryMix Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As Reverb3DeviceDryMix
C#
public Reverb3DeviceDryMix DryMix { get; set; }
Visual C++
public:
property Reverb3DeviceDryMix^ DryMix {
    Reverb3DeviceDryMix^ get ();
    void set (Reverb3DeviceDryMix^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


IsActive Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.IsActive Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


IsSelected Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.IsSelected Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


LPFilter Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.LPFilter Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPFilter As Reverb3DeviceLPFilter
C#
public Reverb3DeviceLPFilter LPFilter { get; set; }
Visual C++
public:
property Reverb3DeviceLPFilter^ LPFilter {
    Reverb3DeviceLPFilter^ get ();
    void set (Reverb3DeviceLPFilter^ value);
}
JavaScript
function get_lpFilter();
function set_lpFilter(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


LPGain Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.LPGain Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LPGain As Reverb3DeviceLPGain
C#
public Reverb3DeviceLPGain LPGain { get; set; }
Visual C++
public:
property Reverb3DeviceLPGain^ LPGain {
    Reverb3DeviceLPGain^ get ();
    void set (Reverb3DeviceLPGain^ value);
}
JavaScript
function get_lpGain();
function set_lpGain(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


Pan Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.Pan Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Pan As Reverb3DevicePan
C#
public Reverb3DevicePan Pan { get; set; }
Visual C++
public:
property Reverb3DevicePan^ Pan {
    Reverb3DevicePan^ get ();
    void set (Reverb3DevicePan^ value);
}
JavaScript
function get_pan();
function set_pan(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


PreDelay Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.PreDelay Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PreDelay As Reverb3DevicePreDelay
C#
public Reverb3DevicePreDelay PreDelay { get; set; }
Visual C++
public:
property Reverb3DevicePreDelay^ PreDelay {
    Reverb3DevicePreDelay^ get ();
    void set (Reverb3DevicePreDelay^ value);
}
JavaScript
function get_preDelay();
function set_preDelay(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


ReverbTime Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.ReverbTime Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbTime As Reverb3DeviceReverbTime
C#
public Reverb3DeviceReverbTime ReverbTime { get; set; }
Visual C++
public:
property Reverb3DeviceReverbTime^ ReverbTime {
    Reverb3DeviceReverbTime^ get ();
    void set (Reverb3DeviceReverbTime^ value);
}
JavaScript
function get_reverbTime();
function set_reverbTime(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.RunTimePresetA Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As Reverb3DeviceRunTimePreset
C#
public Reverb3DeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property Reverb3DeviceRunTimePreset^ RunTimePresetA {
    Reverb3DeviceRunTimePreset^ get ();
    void set (Reverb3DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.RunTimePresetB Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As Reverb3DeviceRunTimePreset
C#
public Reverb3DeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property Reverb3DeviceRunTimePreset^ RunTimePresetB {
    Reverb3DeviceRunTimePreset^ get ();
    void set (Reverb3DeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.SelectedPresetIsModified Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.SelectedPresetName Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


type Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.type Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


WetMix Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.WetMix Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property WetMix As Reverb3DeviceWetMix
C#
public Reverb3DeviceWetMix WetMix { get; set; }
Visual C++
public:
property Reverb3DeviceWetMix^ WetMix {
    Reverb3DeviceWetMix^ get ();
    void set (Reverb3DeviceWetMix^ value);
}
JavaScript
function get_wetMix();
function set_wetMix(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


Width Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbDevice..::.Width Property
Reverb3DeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Reverb3DeviceWidth
C#
public Reverb3DeviceWidth Width { get; set; }
Visual C++
public:
property Reverb3DeviceWidth^ Width {
    Reverb3DeviceWidth^ get ();
    void set (Reverb3DeviceWidth^ value);
}
JavaScript
function get_width();
function set_width(value);

Remarks

See Also

Reverb3DeviceReverbDevice Class


Reverb3DeviceReverbTime Class

[image]

.NET Framework Class Library
Reverb3DeviceReverbTime Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceReverbTime
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceReverbTime
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceReverbTime
JavaScript
NRenoiseTools.Reverb3DeviceReverbTime = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceReverbTime');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceReverbTime

See Also

Reverb3DeviceReverbTime Members


Reverb3DeviceReverbTime Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTime Members
Reverb3DeviceReverbTime Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceReverbTime type exposes the following members.

Constructors

Name | Description
Reverb3DeviceReverbTime |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceReverbTime Class


Reverb3DeviceReverbTime Constructor

[image]

.NET Framework Class Library
Reverb3DeviceReverbTime Constructor
Reverb3DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceReverbTime()
Visual C++
public:
Reverb3DeviceReverbTime()
JavaScript
NRenoiseTools.Reverb3DeviceReverbTime = function();

See Also

Reverb3DeviceReverbTime Class


Reverb3DeviceReverbTime Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTime Methods
Reverb3DeviceReverbTime Class See Also Send Feedback

The Reverb3DeviceReverbTime type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceReverbTime Class


Reverb3DeviceReverbTime Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTime Properties
Reverb3DeviceReverbTime Class See Also Send Feedback

The Reverb3DeviceReverbTime type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceReverbTime Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbTime..::.MidiMappings Property
Reverb3DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceReverbTime Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbTime..::.Value Property
Reverb3DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceReverbTime Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbTime..::.Visualization Property
Reverb3DeviceReverbTime Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceReverbTimeVisualization
C#
public Reverb3DeviceReverbTimeVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceReverbTimeVisualization Visualization {
    Reverb3DeviceReverbTimeVisualization get ();
    void set (Reverb3DeviceReverbTimeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceReverbTime Class


Reverb3DeviceReverbTimeRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceReverbTimeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceReverbTimeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceReverbTimeRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceReverbTimeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceReverbTimeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceReverbTimeRunTimePreset

See Also

Reverb3DeviceReverbTimeRunTimePreset Members


Reverb3DeviceReverbTimeRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset Members
Reverb3DeviceReverbTimeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceReverbTimeRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceReverbTimeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceReverbTimeRunTimePreset Class


Reverb3DeviceReverbTimeRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset Constructor
Reverb3DeviceReverbTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceReverbTimeRunTimePreset()
Visual C++
public:
Reverb3DeviceReverbTimeRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceReverbTimeRunTimePreset = function();

See Also

Reverb3DeviceReverbTimeRunTimePreset Class


Reverb3DeviceReverbTimeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset Methods
Reverb3DeviceReverbTimeRunTimePreset Class See Also Send Feedback

The Reverb3DeviceReverbTimeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceReverbTimeRunTimePreset Class


Reverb3DeviceReverbTimeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset Properties
Reverb3DeviceReverbTimeRunTimePreset Class See Also Send Feedback

The Reverb3DeviceReverbTimeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceReverbTimeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceReverbTimeRunTimePreset..::.Value Property
Reverb3DeviceReverbTimeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceReverbTimeRunTimePreset Class


Reverb3DeviceReverbTimeVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceReverbTimeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceReverbTimeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceReverbTimeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceReverbTimeVisualization
JavaScript
NRenoiseTools.Reverb3DeviceReverbTimeVisualization = function();
NRenoiseTools.Reverb3DeviceReverbTimeVisualization.createEnum('NRenoiseTools.Reverb3DeviceReverbTimeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceRunTimePreset

See Also

Reverb3DeviceRunTimePreset Members


Reverb3DeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset Members
Reverb3DeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

Reverb3DeviceRunTimePreset Class


Reverb3DeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset Constructor
Reverb3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceRunTimePreset()
Visual C++
public:
Reverb3DeviceRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceRunTimePreset = function();

See Also

Reverb3DeviceRunTimePreset Class


Reverb3DeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset Methods
Reverb3DeviceRunTimePreset Class See Also Send Feedback

The Reverb3DeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceRunTimePreset Class


Reverb3DeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset Properties
Reverb3DeviceRunTimePreset Class See Also Send Feedback

The Reverb3DeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

Reverb3DeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset..::.DeviceSlot Property
Reverb3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As Reverb3DeviceDeviceSlotRunTimePreset
C#
public Reverb3DeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property Reverb3DeviceDeviceSlotRunTimePreset^ DeviceSlot {
    Reverb3DeviceDeviceSlotRunTimePreset^ get ();
    void set (Reverb3DeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

Reverb3DeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
Reverb3DeviceRunTimePreset..::.type Property
Reverb3DeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

Reverb3DeviceRunTimePreset Class


Reverb3DeviceWetMix Class

[image]

.NET Framework Class Library
Reverb3DeviceWetMix Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceWetMix
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceWetMix
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceWetMix
JavaScript
NRenoiseTools.Reverb3DeviceWetMix = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceWetMix');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceWetMix

See Also

Reverb3DeviceWetMix Members


Reverb3DeviceWetMix Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMix Members
Reverb3DeviceWetMix Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceWetMix type exposes the following members.

Constructors

Name | Description
Reverb3DeviceWetMix |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceWetMix Class


Reverb3DeviceWetMix Constructor

[image]

.NET Framework Class Library
Reverb3DeviceWetMix Constructor
Reverb3DeviceWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceWetMix()
Visual C++
public:
Reverb3DeviceWetMix()
JavaScript
NRenoiseTools.Reverb3DeviceWetMix = function();

See Also

Reverb3DeviceWetMix Class


Reverb3DeviceWetMix Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMix Methods
Reverb3DeviceWetMix Class See Also Send Feedback

The Reverb3DeviceWetMix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceWetMix Class


Reverb3DeviceWetMix Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMix Properties
Reverb3DeviceWetMix Class See Also Send Feedback

The Reverb3DeviceWetMix type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceWetMix Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceWetMix..::.MidiMappings Property
Reverb3DeviceWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceWetMix Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceWetMix..::.Value Property
Reverb3DeviceWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceWetMix Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceWetMix..::.Visualization Property
Reverb3DeviceWetMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceWetMixVisualization
C#
public Reverb3DeviceWetMixVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceWetMixVisualization Visualization {
    Reverb3DeviceWetMixVisualization get ();
    void set (Reverb3DeviceWetMixVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceWetMix Class


Reverb3DeviceWetMixRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceWetMixRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceWetMixRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceWetMixRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceWetMixRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceWetMixRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceWetMixRunTimePreset

See Also

Reverb3DeviceWetMixRunTimePreset Members


Reverb3DeviceWetMixRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset Members
Reverb3DeviceWetMixRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceWetMixRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceWetMixRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceWetMixRunTimePreset Class


Reverb3DeviceWetMixRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset Constructor
Reverb3DeviceWetMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceWetMixRunTimePreset()
Visual C++
public:
Reverb3DeviceWetMixRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceWetMixRunTimePreset = function();

See Also

Reverb3DeviceWetMixRunTimePreset Class


Reverb3DeviceWetMixRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset Methods
Reverb3DeviceWetMixRunTimePreset Class See Also Send Feedback

The Reverb3DeviceWetMixRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceWetMixRunTimePreset Class


Reverb3DeviceWetMixRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset Properties
Reverb3DeviceWetMixRunTimePreset Class See Also Send Feedback

The Reverb3DeviceWetMixRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceWetMixRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceWetMixRunTimePreset..::.Value Property
Reverb3DeviceWetMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceWetMixRunTimePreset Class


Reverb3DeviceWetMixVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceWetMixVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceWetMixVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceWetMixVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceWetMixVisualization
JavaScript
NRenoiseTools.Reverb3DeviceWetMixVisualization = function();
NRenoiseTools.Reverb3DeviceWetMixVisualization.createEnum('NRenoiseTools.Reverb3DeviceWetMixVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Reverb3DeviceWidth Class

[image]

.NET Framework Class Library
Reverb3DeviceWidth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceWidth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceWidth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceWidth
JavaScript
NRenoiseTools.Reverb3DeviceWidth = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceWidth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceWidth

See Also

Reverb3DeviceWidth Members


Reverb3DeviceWidth Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidth Members
Reverb3DeviceWidth Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceWidth type exposes the following members.

Constructors

Name | Description
Reverb3DeviceWidth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceWidth Class


Reverb3DeviceWidth Constructor

[image]

.NET Framework Class Library
Reverb3DeviceWidth Constructor
Reverb3DeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceWidth()
Visual C++
public:
Reverb3DeviceWidth()
JavaScript
NRenoiseTools.Reverb3DeviceWidth = function();

See Also

Reverb3DeviceWidth Class


Reverb3DeviceWidth Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidth Methods
Reverb3DeviceWidth Class See Also Send Feedback

The Reverb3DeviceWidth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceWidth Class


Reverb3DeviceWidth Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidth Properties
Reverb3DeviceWidth Class See Also Send Feedback

The Reverb3DeviceWidth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

Reverb3DeviceWidth Class


MidiMappings Property

[image]

.NET Framework Class Library
Reverb3DeviceWidth..::.MidiMappings Property
Reverb3DeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

Reverb3DeviceWidth Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceWidth..::.Value Property
Reverb3DeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceWidth Class


Visualization Property

[image]

.NET Framework Class Library
Reverb3DeviceWidth..::.Visualization Property
Reverb3DeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As Reverb3DeviceWidthVisualization
C#
public Reverb3DeviceWidthVisualization Visualization { get; set; }
Visual C++
public:
property Reverb3DeviceWidthVisualization Visualization {
    Reverb3DeviceWidthVisualization get ();
    void set (Reverb3DeviceWidthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

Reverb3DeviceWidth Class


Reverb3DeviceWidthRunTimePreset Class

[image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Reverb3DeviceWidthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Reverb3DeviceWidthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Reverb3DeviceWidthRunTimePreset
JavaScript
NRenoiseTools.Reverb3DeviceWidthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.Reverb3DeviceWidthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Reverb3DeviceWidthRunTimePreset

See Also

Reverb3DeviceWidthRunTimePreset Members


Reverb3DeviceWidthRunTimePreset Members

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset Members
Reverb3DeviceWidthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The Reverb3DeviceWidthRunTimePreset type exposes the following members.

Constructors

Name | Description
Reverb3DeviceWidthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

Reverb3DeviceWidthRunTimePreset Class


Reverb3DeviceWidthRunTimePreset Constructor

[image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset Constructor
Reverb3DeviceWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Reverb3DeviceWidthRunTimePreset()
Visual C++
public:
Reverb3DeviceWidthRunTimePreset()
JavaScript
NRenoiseTools.Reverb3DeviceWidthRunTimePreset = function();

See Also

Reverb3DeviceWidthRunTimePreset Class


Reverb3DeviceWidthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset Methods
Reverb3DeviceWidthRunTimePreset Class See Also Send Feedback

The Reverb3DeviceWidthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reverb3DeviceWidthRunTimePreset Class


Reverb3DeviceWidthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset Properties
Reverb3DeviceWidthRunTimePreset Class See Also Send Feedback

The Reverb3DeviceWidthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

Reverb3DeviceWidthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
Reverb3DeviceWidthRunTimePreset..::.Value Property
Reverb3DeviceWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Reverb3DeviceWidthRunTimePreset Class


Reverb3DeviceWidthVisualization Enumeration

[image]

.NET Framework Class Library
Reverb3DeviceWidthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration Reverb3DeviceWidthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum Reverb3DeviceWidthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class Reverb3DeviceWidthVisualization
JavaScript
NRenoiseTools.Reverb3DeviceWidthVisualization = function();
NRenoiseTools.Reverb3DeviceWidthVisualization.createEnum('NRenoiseTools.Reverb3DeviceWidthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ReverbDeviceDamp Class

[image]

.NET Framework Class Library
ReverbDeviceDamp Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceDamp
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceDamp
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceDamp
JavaScript
NRenoiseTools.ReverbDeviceDamp = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceDamp');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceDamp

See Also

ReverbDeviceDamp Members


ReverbDeviceDamp Members

[image] [image]

.NET Framework Class Library
ReverbDeviceDamp Members
ReverbDeviceDamp Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceDamp type exposes the following members.

Constructors

Name | Description
ReverbDeviceDamp |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceDamp Class


ReverbDeviceDamp Constructor

[image]

.NET Framework Class Library
ReverbDeviceDamp Constructor
ReverbDeviceDamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceDamp()
Visual C++
public:
ReverbDeviceDamp()
JavaScript
NRenoiseTools.ReverbDeviceDamp = function();

See Also

ReverbDeviceDamp Class


ReverbDeviceDamp Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceDamp Methods
ReverbDeviceDamp Class See Also Send Feedback

The ReverbDeviceDamp type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceDamp Class


ReverbDeviceDamp Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceDamp Properties
ReverbDeviceDamp Class See Also Send Feedback

The ReverbDeviceDamp type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceDamp Class


MidiMappings Property

[image]

.NET Framework Class Library
ReverbDeviceDamp..::.MidiMappings Property
ReverbDeviceDamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ReverbDeviceDamp Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceDamp..::.Value Property
ReverbDeviceDamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceDamp Class


Visualization Property

[image]

.NET Framework Class Library
ReverbDeviceDamp..::.Visualization Property
ReverbDeviceDamp Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ReverbDeviceDampVisualization
C#
public ReverbDeviceDampVisualization Visualization { get; set; }
Visual C++
public:
property ReverbDeviceDampVisualization Visualization {
    ReverbDeviceDampVisualization get ();
    void set (ReverbDeviceDampVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ReverbDeviceDamp Class


ReverbDeviceDampRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceDampRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceDampRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceDampRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceDampRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceDampRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceDampRunTimePreset

See Also

ReverbDeviceDampRunTimePreset Members


ReverbDeviceDampRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset Members
ReverbDeviceDampRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceDampRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceDampRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ReverbDeviceDampRunTimePreset Class


ReverbDeviceDampRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset Constructor
ReverbDeviceDampRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceDampRunTimePreset()
Visual C++
public:
ReverbDeviceDampRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceDampRunTimePreset = function();

See Also

ReverbDeviceDampRunTimePreset Class


ReverbDeviceDampRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset Methods
ReverbDeviceDampRunTimePreset Class See Also Send Feedback

The ReverbDeviceDampRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceDampRunTimePreset Class


ReverbDeviceDampRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset Properties
ReverbDeviceDampRunTimePreset Class See Also Send Feedback

The ReverbDeviceDampRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ReverbDeviceDampRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceDampRunTimePreset..::.Value Property
ReverbDeviceDampRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceDampRunTimePreset Class


ReverbDeviceDampVisualization Enumeration

[image]

.NET Framework Class Library
ReverbDeviceDampVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ReverbDeviceDampVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ReverbDeviceDampVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ReverbDeviceDampVisualization
JavaScript
NRenoiseTools.ReverbDeviceDampVisualization = function();
NRenoiseTools.ReverbDeviceDampVisualization.createEnum('NRenoiseTools.ReverbDeviceDampVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ReverbDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceDeviceSlotRunTimePreset

See Also

ReverbDeviceDeviceSlotRunTimePreset Members


ReverbDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset Members
ReverbDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Damp |
DryMix |
RoomSize |
Send |
type |
Width |

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


ReverbDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset Constructor
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceDeviceSlotRunTimePreset()
Visual C++
public:
ReverbDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceDeviceSlotRunTimePreset = function();

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


ReverbDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset Methods
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ReverbDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


ReverbDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset Properties
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ReverbDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Damp |
DryMix |
RoomSize |
Send |
type |
Width |

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


Damp Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.Damp Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Damp As ReverbDeviceDampRunTimePreset
C#
public ReverbDeviceDampRunTimePreset Damp { get; set; }
Visual C++
public:
property ReverbDeviceDampRunTimePreset^ Damp {
    ReverbDeviceDampRunTimePreset^ get ();
    void set (ReverbDeviceDampRunTimePreset^ value);
}
JavaScript
function get_damp();
function set_damp(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


DryMix Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.DryMix Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As ReverbDeviceDryMixRunTimePreset
C#
public ReverbDeviceDryMixRunTimePreset DryMix { get; set; }
Visual C++
public:
property ReverbDeviceDryMixRunTimePreset^ DryMix {
    ReverbDeviceDryMixRunTimePreset^ get ();
    void set (ReverbDeviceDryMixRunTimePreset^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


RoomSize Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.RoomSize Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RoomSize As ReverbDeviceRoomSizeRunTimePreset
C#
public ReverbDeviceRoomSizeRunTimePreset RoomSize { get; set; }
Visual C++
public:
property ReverbDeviceRoomSizeRunTimePreset^ RoomSize {
    ReverbDeviceRoomSizeRunTimePreset^ get ();
    void set (ReverbDeviceRoomSizeRunTimePreset^ value);
}
JavaScript
function get_roomSize();
function set_roomSize(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


Send Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.Send Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Send As ReverbDeviceSendRunTimePreset
C#
public ReverbDeviceSendRunTimePreset Send { get; set; }
Visual C++
public:
property ReverbDeviceSendRunTimePreset^ Send {
    ReverbDeviceSendRunTimePreset^ get ();
    void set (ReverbDeviceSendRunTimePreset^ value);
}
JavaScript
function get_send();
function set_send(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.type Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


Width Property

[image]

.NET Framework Class Library
ReverbDeviceDeviceSlotRunTimePreset..::.Width Property
ReverbDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As ReverbDeviceWidthRunTimePreset
C#
public ReverbDeviceWidthRunTimePreset Width { get; set; }
Visual C++
public:
property ReverbDeviceWidthRunTimePreset^ Width {
    ReverbDeviceWidthRunTimePreset^ get ();
    void set (ReverbDeviceWidthRunTimePreset^ value);
}
JavaScript
function get_width();
function set_width(value);

Remarks

See Also

ReverbDeviceDeviceSlotRunTimePreset Class


ReverbDeviceDryMix Class

[image]

.NET Framework Class Library
ReverbDeviceDryMix Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceDryMix
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceDryMix
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceDryMix
JavaScript
NRenoiseTools.ReverbDeviceDryMix = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceDryMix');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceDryMix

See Also

ReverbDeviceDryMix Members


ReverbDeviceDryMix Members

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMix Members
ReverbDeviceDryMix Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceDryMix type exposes the following members.

Constructors

Name | Description
ReverbDeviceDryMix |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceDryMix Class


ReverbDeviceDryMix Constructor

[image]

.NET Framework Class Library
ReverbDeviceDryMix Constructor
ReverbDeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceDryMix()
Visual C++
public:
ReverbDeviceDryMix()
JavaScript
NRenoiseTools.ReverbDeviceDryMix = function();

See Also

ReverbDeviceDryMix Class


ReverbDeviceDryMix Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMix Methods
ReverbDeviceDryMix Class See Also Send Feedback

The ReverbDeviceDryMix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceDryMix Class


ReverbDeviceDryMix Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMix Properties
ReverbDeviceDryMix Class See Also Send Feedback

The ReverbDeviceDryMix type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceDryMix Class


MidiMappings Property

[image]

.NET Framework Class Library
ReverbDeviceDryMix..::.MidiMappings Property
ReverbDeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ReverbDeviceDryMix Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceDryMix..::.Value Property
ReverbDeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceDryMix Class


Visualization Property

[image]

.NET Framework Class Library
ReverbDeviceDryMix..::.Visualization Property
ReverbDeviceDryMix Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ReverbDeviceDryMixVisualization
C#
public ReverbDeviceDryMixVisualization Visualization { get; set; }
Visual C++
public:
property ReverbDeviceDryMixVisualization Visualization {
    ReverbDeviceDryMixVisualization get ();
    void set (ReverbDeviceDryMixVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ReverbDeviceDryMix Class


ReverbDeviceDryMixRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceDryMixRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceDryMixRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceDryMixRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceDryMixRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceDryMixRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceDryMixRunTimePreset

See Also

ReverbDeviceDryMixRunTimePreset Members


ReverbDeviceDryMixRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset Members
ReverbDeviceDryMixRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceDryMixRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceDryMixRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ReverbDeviceDryMixRunTimePreset Class


ReverbDeviceDryMixRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset Constructor
ReverbDeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceDryMixRunTimePreset()
Visual C++
public:
ReverbDeviceDryMixRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceDryMixRunTimePreset = function();

See Also

ReverbDeviceDryMixRunTimePreset Class


ReverbDeviceDryMixRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset Methods
ReverbDeviceDryMixRunTimePreset Class See Also Send Feedback

The ReverbDeviceDryMixRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceDryMixRunTimePreset Class


ReverbDeviceDryMixRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset Properties
ReverbDeviceDryMixRunTimePreset Class See Also Send Feedback

The ReverbDeviceDryMixRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ReverbDeviceDryMixRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceDryMixRunTimePreset..::.Value Property
ReverbDeviceDryMixRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceDryMixRunTimePreset Class


ReverbDeviceDryMixVisualization Enumeration

[image]

.NET Framework Class Library
ReverbDeviceDryMixVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ReverbDeviceDryMixVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ReverbDeviceDryMixVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ReverbDeviceDryMixVisualization
JavaScript
NRenoiseTools.ReverbDeviceDryMixVisualization = function();
NRenoiseTools.ReverbDeviceDryMixVisualization.createEnum('NRenoiseTools.ReverbDeviceDryMixVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ReverbDeviceReverbDevice Class

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceReverbDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceReverbDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceReverbDevice
JavaScript
NRenoiseTools.ReverbDeviceReverbDevice = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceReverbDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceReverbDevice

See Also

ReverbDeviceReverbDevice Members


ReverbDeviceReverbDevice Members

[image] [image]

.NET Framework Class Library
ReverbDeviceReverbDevice Members
ReverbDeviceReverbDevice Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceReverbDevice type exposes the following members.

Constructors

Name | Description
ReverbDeviceReverbDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Damp |
DryMix |
IsActive |
IsSelected |
RoomSize |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Send |
type |
Width |

See Also

ReverbDeviceReverbDevice Class


ReverbDeviceReverbDevice Constructor

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice Constructor
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceReverbDevice()
Visual C++
public:
ReverbDeviceReverbDevice()
JavaScript
NRenoiseTools.ReverbDeviceReverbDevice = function();

See Also

ReverbDeviceReverbDevice Class


ReverbDeviceReverbDevice Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceReverbDevice Methods
ReverbDeviceReverbDevice Class See Also Send Feedback

The ReverbDeviceReverbDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceReverbDevice Class


ReverbDeviceReverbDevice Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceReverbDevice Properties
ReverbDeviceReverbDevice Class See Also Send Feedback

The ReverbDeviceReverbDevice type exposes the following members.

Properties

Name | Description
Damp |
DryMix |
IsActive |
IsSelected |
RoomSize |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Send |
type |
Width |

See Also

ReverbDeviceReverbDevice Class


Damp Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.Damp Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Damp As ReverbDeviceDamp
C#
public ReverbDeviceDamp Damp { get; set; }
Visual C++
public:
property ReverbDeviceDamp^ Damp {
    ReverbDeviceDamp^ get ();
    void set (ReverbDeviceDamp^ value);
}
JavaScript
function get_damp();
function set_damp(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


DryMix Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.DryMix Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DryMix As ReverbDeviceDryMix
C#
public ReverbDeviceDryMix DryMix { get; set; }
Visual C++
public:
property ReverbDeviceDryMix^ DryMix {
    ReverbDeviceDryMix^ get ();
    void set (ReverbDeviceDryMix^ value);
}
JavaScript
function get_dryMix();
function set_dryMix(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


IsActive Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.IsActive Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


IsSelected Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.IsSelected Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


RoomSize Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.RoomSize Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RoomSize As ReverbDeviceRoomSize
C#
public ReverbDeviceRoomSize RoomSize { get; set; }
Visual C++
public:
property ReverbDeviceRoomSize^ RoomSize {
    ReverbDeviceRoomSize^ get ();
    void set (ReverbDeviceRoomSize^ value);
}
JavaScript
function get_roomSize();
function set_roomSize(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.RunTimePresetA Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As ReverbDeviceRunTimePreset
C#
public ReverbDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property ReverbDeviceRunTimePreset^ RunTimePresetA {
    ReverbDeviceRunTimePreset^ get ();
    void set (ReverbDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.RunTimePresetB Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As ReverbDeviceRunTimePreset
C#
public ReverbDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property ReverbDeviceRunTimePreset^ RunTimePresetB {
    ReverbDeviceRunTimePreset^ get ();
    void set (ReverbDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.SelectedPresetIsModified Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.SelectedPresetName Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


Send Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.Send Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Send As ReverbDeviceSend
C#
public ReverbDeviceSend Send { get; set; }
Visual C++
public:
property ReverbDeviceSend^ Send {
    ReverbDeviceSend^ get ();
    void set (ReverbDeviceSend^ value);
}
JavaScript
function get_send();
function set_send(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


type Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.type Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


Width Property

[image]

.NET Framework Class Library
ReverbDeviceReverbDevice..::.Width Property
ReverbDeviceReverbDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As ReverbDeviceWidth
C#
public ReverbDeviceWidth Width { get; set; }
Visual C++
public:
property ReverbDeviceWidth^ Width {
    ReverbDeviceWidth^ get ();
    void set (ReverbDeviceWidth^ value);
}
JavaScript
function get_width();
function set_width(value);

Remarks

See Also

ReverbDeviceReverbDevice Class


ReverbDeviceRoomSize Class

[image]

.NET Framework Class Library
ReverbDeviceRoomSize Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceRoomSize
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceRoomSize
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceRoomSize
JavaScript
NRenoiseTools.ReverbDeviceRoomSize = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceRoomSize');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceRoomSize

See Also

ReverbDeviceRoomSize Members


ReverbDeviceRoomSize Members

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSize Members
ReverbDeviceRoomSize Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceRoomSize type exposes the following members.

Constructors

Name | Description
ReverbDeviceRoomSize |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceRoomSize Class


ReverbDeviceRoomSize Constructor

[image]

.NET Framework Class Library
ReverbDeviceRoomSize Constructor
ReverbDeviceRoomSize Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceRoomSize()
Visual C++
public:
ReverbDeviceRoomSize()
JavaScript
NRenoiseTools.ReverbDeviceRoomSize = function();

See Also

ReverbDeviceRoomSize Class


ReverbDeviceRoomSize Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSize Methods
ReverbDeviceRoomSize Class See Also Send Feedback

The ReverbDeviceRoomSize type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceRoomSize Class


ReverbDeviceRoomSize Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSize Properties
ReverbDeviceRoomSize Class See Also Send Feedback

The ReverbDeviceRoomSize type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceRoomSize Class


MidiMappings Property

[image]

.NET Framework Class Library
ReverbDeviceRoomSize..::.MidiMappings Property
ReverbDeviceRoomSize Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ReverbDeviceRoomSize Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceRoomSize..::.Value Property
ReverbDeviceRoomSize Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceRoomSize Class


Visualization Property

[image]

.NET Framework Class Library
ReverbDeviceRoomSize..::.Visualization Property
ReverbDeviceRoomSize Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ReverbDeviceRoomSizeVisualization
C#
public ReverbDeviceRoomSizeVisualization Visualization { get; set; }
Visual C++
public:
property ReverbDeviceRoomSizeVisualization Visualization {
    ReverbDeviceRoomSizeVisualization get ();
    void set (ReverbDeviceRoomSizeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ReverbDeviceRoomSize Class


ReverbDeviceRoomSizeRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceRoomSizeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceRoomSizeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceRoomSizeRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceRoomSizeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceRoomSizeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceRoomSizeRunTimePreset

See Also

ReverbDeviceRoomSizeRunTimePreset Members


ReverbDeviceRoomSizeRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset Members
ReverbDeviceRoomSizeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceRoomSizeRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceRoomSizeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ReverbDeviceRoomSizeRunTimePreset Class


ReverbDeviceRoomSizeRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset Constructor
ReverbDeviceRoomSizeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceRoomSizeRunTimePreset()
Visual C++
public:
ReverbDeviceRoomSizeRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceRoomSizeRunTimePreset = function();

See Also

ReverbDeviceRoomSizeRunTimePreset Class


ReverbDeviceRoomSizeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset Methods
ReverbDeviceRoomSizeRunTimePreset Class See Also Send Feedback

The ReverbDeviceRoomSizeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceRoomSizeRunTimePreset Class


ReverbDeviceRoomSizeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset Properties
ReverbDeviceRoomSizeRunTimePreset Class See Also Send Feedback

The ReverbDeviceRoomSizeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ReverbDeviceRoomSizeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceRoomSizeRunTimePreset..::.Value Property
ReverbDeviceRoomSizeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceRoomSizeRunTimePreset Class


ReverbDeviceRoomSizeVisualization Enumeration

[image]

.NET Framework Class Library
ReverbDeviceRoomSizeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ReverbDeviceRoomSizeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ReverbDeviceRoomSizeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ReverbDeviceRoomSizeVisualization
JavaScript
NRenoiseTools.ReverbDeviceRoomSizeVisualization = function();
NRenoiseTools.ReverbDeviceRoomSizeVisualization.createEnum('NRenoiseTools.ReverbDeviceRoomSizeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ReverbDeviceRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceRunTimePreset

See Also

ReverbDeviceRunTimePreset Members


ReverbDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceRunTimePreset Members
ReverbDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

ReverbDeviceRunTimePreset Class


ReverbDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceRunTimePreset Constructor
ReverbDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceRunTimePreset()
Visual C++
public:
ReverbDeviceRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceRunTimePreset = function();

See Also

ReverbDeviceRunTimePreset Class


ReverbDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceRunTimePreset Methods
ReverbDeviceRunTimePreset Class See Also Send Feedback

The ReverbDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceRunTimePreset Class


ReverbDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceRunTimePreset Properties
ReverbDeviceRunTimePreset Class See Also Send Feedback

The ReverbDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

ReverbDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
ReverbDeviceRunTimePreset..::.DeviceSlot Property
ReverbDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As ReverbDeviceDeviceSlotRunTimePreset
C#
public ReverbDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property ReverbDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    ReverbDeviceDeviceSlotRunTimePreset^ get ();
    void set (ReverbDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

ReverbDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ReverbDeviceRunTimePreset..::.type Property
ReverbDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ReverbDeviceRunTimePreset Class


ReverbDeviceSend Class

[image]

.NET Framework Class Library
ReverbDeviceSend Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceSend
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceSend
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceSend
JavaScript
NRenoiseTools.ReverbDeviceSend = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceSend');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceSend

See Also

ReverbDeviceSend Members


ReverbDeviceSend Members

[image] [image]

.NET Framework Class Library
ReverbDeviceSend Members
ReverbDeviceSend Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceSend type exposes the following members.

Constructors

Name | Description
ReverbDeviceSend |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceSend Class


ReverbDeviceSend Constructor

[image]

.NET Framework Class Library
ReverbDeviceSend Constructor
ReverbDeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceSend()
Visual C++
public:
ReverbDeviceSend()
JavaScript
NRenoiseTools.ReverbDeviceSend = function();

See Also

ReverbDeviceSend Class


ReverbDeviceSend Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceSend Methods
ReverbDeviceSend Class See Also Send Feedback

The ReverbDeviceSend type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceSend Class


ReverbDeviceSend Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceSend Properties
ReverbDeviceSend Class See Also Send Feedback

The ReverbDeviceSend type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceSend Class


MidiMappings Property

[image]

.NET Framework Class Library
ReverbDeviceSend..::.MidiMappings Property
ReverbDeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ReverbDeviceSend Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceSend..::.Value Property
ReverbDeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceSend Class


Visualization Property

[image]

.NET Framework Class Library
ReverbDeviceSend..::.Visualization Property
ReverbDeviceSend Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ReverbDeviceSendVisualization
C#
public ReverbDeviceSendVisualization Visualization { get; set; }
Visual C++
public:
property ReverbDeviceSendVisualization Visualization {
    ReverbDeviceSendVisualization get ();
    void set (ReverbDeviceSendVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ReverbDeviceSend Class


ReverbDeviceSendRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceSendRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceSendRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceSendRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceSendRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceSendRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceSendRunTimePreset

See Also

ReverbDeviceSendRunTimePreset Members


ReverbDeviceSendRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset Members
ReverbDeviceSendRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceSendRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceSendRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ReverbDeviceSendRunTimePreset Class


ReverbDeviceSendRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset Constructor
ReverbDeviceSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceSendRunTimePreset()
Visual C++
public:
ReverbDeviceSendRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceSendRunTimePreset = function();

See Also

ReverbDeviceSendRunTimePreset Class


ReverbDeviceSendRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset Methods
ReverbDeviceSendRunTimePreset Class See Also Send Feedback

The ReverbDeviceSendRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceSendRunTimePreset Class


ReverbDeviceSendRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset Properties
ReverbDeviceSendRunTimePreset Class See Also Send Feedback

The ReverbDeviceSendRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ReverbDeviceSendRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceSendRunTimePreset..::.Value Property
ReverbDeviceSendRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceSendRunTimePreset Class


ReverbDeviceSendVisualization Enumeration

[image]

.NET Framework Class Library
ReverbDeviceSendVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ReverbDeviceSendVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ReverbDeviceSendVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ReverbDeviceSendVisualization
JavaScript
NRenoiseTools.ReverbDeviceSendVisualization = function();
NRenoiseTools.ReverbDeviceSendVisualization.createEnum('NRenoiseTools.ReverbDeviceSendVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ReverbDeviceWidth Class

[image]

.NET Framework Class Library
ReverbDeviceWidth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceWidth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceWidth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceWidth
JavaScript
NRenoiseTools.ReverbDeviceWidth = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceWidth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceWidth

See Also

ReverbDeviceWidth Members


ReverbDeviceWidth Members

[image] [image]

.NET Framework Class Library
ReverbDeviceWidth Members
ReverbDeviceWidth Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceWidth type exposes the following members.

Constructors

Name | Description
ReverbDeviceWidth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceWidth Class


ReverbDeviceWidth Constructor

[image]

.NET Framework Class Library
ReverbDeviceWidth Constructor
ReverbDeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceWidth()
Visual C++
public:
ReverbDeviceWidth()
JavaScript
NRenoiseTools.ReverbDeviceWidth = function();

See Also

ReverbDeviceWidth Class


ReverbDeviceWidth Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceWidth Methods
ReverbDeviceWidth Class See Also Send Feedback

The ReverbDeviceWidth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceWidth Class


ReverbDeviceWidth Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceWidth Properties
ReverbDeviceWidth Class See Also Send Feedback

The ReverbDeviceWidth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ReverbDeviceWidth Class


MidiMappings Property

[image]

.NET Framework Class Library
ReverbDeviceWidth..::.MidiMappings Property
ReverbDeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ReverbDeviceWidth Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceWidth..::.Value Property
ReverbDeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceWidth Class


Visualization Property

[image]

.NET Framework Class Library
ReverbDeviceWidth..::.Visualization Property
ReverbDeviceWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ReverbDeviceWidthVisualization
C#
public ReverbDeviceWidthVisualization Visualization { get; set; }
Visual C++
public:
property ReverbDeviceWidthVisualization Visualization {
    ReverbDeviceWidthVisualization get ();
    void set (ReverbDeviceWidthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ReverbDeviceWidth Class


ReverbDeviceWidthRunTimePreset Class

[image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ReverbDeviceWidthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ReverbDeviceWidthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ReverbDeviceWidthRunTimePreset
JavaScript
NRenoiseTools.ReverbDeviceWidthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ReverbDeviceWidthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ReverbDeviceWidthRunTimePreset

See Also

ReverbDeviceWidthRunTimePreset Members


ReverbDeviceWidthRunTimePreset Members

[image] [image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset Members
ReverbDeviceWidthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ReverbDeviceWidthRunTimePreset type exposes the following members.

Constructors

Name | Description
ReverbDeviceWidthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ReverbDeviceWidthRunTimePreset Class


ReverbDeviceWidthRunTimePreset Constructor

[image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset Constructor
ReverbDeviceWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReverbDeviceWidthRunTimePreset()
Visual C++
public:
ReverbDeviceWidthRunTimePreset()
JavaScript
NRenoiseTools.ReverbDeviceWidthRunTimePreset = function();

See Also

ReverbDeviceWidthRunTimePreset Class


ReverbDeviceWidthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset Methods
ReverbDeviceWidthRunTimePreset Class See Also Send Feedback

The ReverbDeviceWidthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReverbDeviceWidthRunTimePreset Class


ReverbDeviceWidthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset Properties
ReverbDeviceWidthRunTimePreset Class See Also Send Feedback

The ReverbDeviceWidthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ReverbDeviceWidthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ReverbDeviceWidthRunTimePreset..::.Value Property
ReverbDeviceWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ReverbDeviceWidthRunTimePreset Class


ReverbDeviceWidthVisualization Enumeration

[image]

.NET Framework Class Library
ReverbDeviceWidthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ReverbDeviceWidthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ReverbDeviceWidthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ReverbDeviceWidthVisualization
JavaScript
NRenoiseTools.ReverbDeviceWidthVisualization = function();
NRenoiseTools.ReverbDeviceWidthVisualization.createEnum('NRenoiseTools.ReverbDeviceWidthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDevice Class

[image]

.NET Framework Class Library
RingModDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDevice
JavaScript
NRenoiseTools.RingModDevice = function();

Type.createClass(
    'NRenoiseTools.RingModDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDevice

See Also

RingModDevice Members


RingModDevice Members

[image] [image]

.NET Framework Class Library
RingModDevice Members
RingModDevice Class Constructors Methods Properties See Also Send Feedback

The RingModDevice type exposes the following members.

Constructors

Name | Description
RingModDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Frequency |
Inertia |
IsActive |
IsSelected |
OscillatorType |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

RingModDevice Class


RingModDevice Constructor

[image]

.NET Framework Class Library
RingModDevice Constructor
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDevice()
Visual C++
public:
RingModDevice()
JavaScript
NRenoiseTools.RingModDevice = function();

See Also

RingModDevice Class


RingModDevice Methods

[image] [image]

.NET Framework Class Library
RingModDevice Methods
RingModDevice Class See Also Send Feedback

The RingModDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDevice Class


RingModDevice Properties

[image] [image]

.NET Framework Class Library
RingModDevice Properties
RingModDevice Class See Also Send Feedback

The RingModDevice type exposes the following members.

Properties

Name | Description
Amount |
Frequency |
Inertia |
IsActive |
IsSelected |
OscillatorType |
Phase |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
type |

See Also

RingModDevice Class


Amount Property

[image]

.NET Framework Class Library
RingModDevice..::.Amount Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As RingModDeviceAmount
C#
public RingModDeviceAmount Amount { get; set; }
Visual C++
public:
property RingModDeviceAmount^ Amount {
    RingModDeviceAmount^ get ();
    void set (RingModDeviceAmount^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

RingModDevice Class


Frequency Property

[image]

.NET Framework Class Library
RingModDevice..::.Frequency Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As RingModDeviceFrequency
C#
public RingModDeviceFrequency Frequency { get; set; }
Visual C++
public:
property RingModDeviceFrequency^ Frequency {
    RingModDeviceFrequency^ get ();
    void set (RingModDeviceFrequency^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

RingModDevice Class


Inertia Property

[image]

.NET Framework Class Library
RingModDevice..::.Inertia Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As RingModDeviceInertia
C#
public RingModDeviceInertia Inertia { get; set; }
Visual C++
public:
property RingModDeviceInertia^ Inertia {
    RingModDeviceInertia^ get ();
    void set (RingModDeviceInertia^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

RingModDevice Class


IsActive Property

[image]

.NET Framework Class Library
RingModDevice..::.IsActive Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

RingModDevice Class


IsSelected Property

[image]

.NET Framework Class Library
RingModDevice..::.IsSelected Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

RingModDevice Class


OscillatorType Property

[image]

.NET Framework Class Library
RingModDevice..::.OscillatorType Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property OscillatorType As RingModDeviceOscillatorType
C#
public RingModDeviceOscillatorType OscillatorType { get; set; }
Visual C++
public:
property RingModDeviceOscillatorType^ OscillatorType {
    RingModDeviceOscillatorType^ get ();
    void set (RingModDeviceOscillatorType^ value);
}
JavaScript
function get_oscillatorType();
function set_oscillatorType(value);

Remarks

See Also

RingModDevice Class


Phase Property

[image]

.NET Framework Class Library
RingModDevice..::.Phase Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As RingModDevicePhase
C#
public RingModDevicePhase Phase { get; set; }
Visual C++
public:
property RingModDevicePhase^ Phase {
    RingModDevicePhase^ get ();
    void set (RingModDevicePhase^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

RingModDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
RingModDevice..::.RunTimePresetA Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As RingModDeviceRunTimePreset
C#
public RingModDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property RingModDeviceRunTimePreset^ RunTimePresetA {
    RingModDeviceRunTimePreset^ get ();
    void set (RingModDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

RingModDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
RingModDevice..::.RunTimePresetB Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As RingModDeviceRunTimePreset
C#
public RingModDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property RingModDeviceRunTimePreset^ RunTimePresetB {
    RingModDeviceRunTimePreset^ get ();
    void set (RingModDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

RingModDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
RingModDevice..::.SelectedPresetIsModified Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

RingModDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
RingModDevice..::.SelectedPresetName Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

RingModDevice Class


type Property

[image]

.NET Framework Class Library
RingModDevice..::.type Property
RingModDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

RingModDevice Class


RingModDeviceAmount Class

[image]

.NET Framework Class Library
RingModDeviceAmount Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceAmount
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceAmount
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceAmount
JavaScript
NRenoiseTools.RingModDeviceAmount = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceAmount');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceAmount

See Also

RingModDeviceAmount Members


RingModDeviceAmount Members

[image] [image]

.NET Framework Class Library
RingModDeviceAmount Members
RingModDeviceAmount Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceAmount type exposes the following members.

Constructors

Name | Description
RingModDeviceAmount |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceAmount Class


RingModDeviceAmount Constructor

[image]

.NET Framework Class Library
RingModDeviceAmount Constructor
RingModDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceAmount()
Visual C++
public:
RingModDeviceAmount()
JavaScript
NRenoiseTools.RingModDeviceAmount = function();

See Also

RingModDeviceAmount Class


RingModDeviceAmount Methods

[image] [image]

.NET Framework Class Library
RingModDeviceAmount Methods
RingModDeviceAmount Class See Also Send Feedback

The RingModDeviceAmount type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceAmount Class


RingModDeviceAmount Properties

[image] [image]

.NET Framework Class Library
RingModDeviceAmount Properties
RingModDeviceAmount Class See Also Send Feedback

The RingModDeviceAmount type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceAmount Class


MidiMappings Property

[image]

.NET Framework Class Library
RingModDeviceAmount..::.MidiMappings Property
RingModDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

RingModDeviceAmount Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceAmount..::.Value Property
RingModDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceAmount Class


Visualization Property

[image]

.NET Framework Class Library
RingModDeviceAmount..::.Visualization Property
RingModDeviceAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As RingModDeviceAmountVisualization
C#
public RingModDeviceAmountVisualization Visualization { get; set; }
Visual C++
public:
property RingModDeviceAmountVisualization Visualization {
    RingModDeviceAmountVisualization get ();
    void set (RingModDeviceAmountVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

RingModDeviceAmount Class


RingModDeviceAmountRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceAmountRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceAmountRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceAmountRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceAmountRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceAmountRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceAmountRunTimePreset

See Also

RingModDeviceAmountRunTimePreset Members


RingModDeviceAmountRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset Members
RingModDeviceAmountRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceAmountRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceAmountRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

RingModDeviceAmountRunTimePreset Class


RingModDeviceAmountRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset Constructor
RingModDeviceAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceAmountRunTimePreset()
Visual C++
public:
RingModDeviceAmountRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceAmountRunTimePreset = function();

See Also

RingModDeviceAmountRunTimePreset Class


RingModDeviceAmountRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset Methods
RingModDeviceAmountRunTimePreset Class See Also Send Feedback

The RingModDeviceAmountRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceAmountRunTimePreset Class


RingModDeviceAmountRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset Properties
RingModDeviceAmountRunTimePreset Class See Also Send Feedback

The RingModDeviceAmountRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

RingModDeviceAmountRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceAmountRunTimePreset..::.Value Property
RingModDeviceAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceAmountRunTimePreset Class


RingModDeviceAmountVisualization Enumeration

[image]

.NET Framework Class Library
RingModDeviceAmountVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration RingModDeviceAmountVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum RingModDeviceAmountVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class RingModDeviceAmountVisualization
JavaScript
NRenoiseTools.RingModDeviceAmountVisualization = function();
NRenoiseTools.RingModDeviceAmountVisualization.createEnum('NRenoiseTools.RingModDeviceAmountVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceDeviceSlotRunTimePreset

See Also

RingModDeviceDeviceSlotRunTimePreset Members


RingModDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset Members
RingModDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Frequency |
Inertia |
OscillatorType |
Phase |
type |

See Also

RingModDeviceDeviceSlotRunTimePreset Class


RingModDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset Constructor
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceDeviceSlotRunTimePreset()
Visual C++
public:
RingModDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceDeviceSlotRunTimePreset = function();

See Also

RingModDeviceDeviceSlotRunTimePreset Class


RingModDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset Methods
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The RingModDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceDeviceSlotRunTimePreset Class


RingModDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset Properties
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The RingModDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Amount |
Frequency |
Inertia |
OscillatorType |
Phase |
type |

See Also

RingModDeviceDeviceSlotRunTimePreset Class


Amount Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.Amount Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As RingModDeviceAmountRunTimePreset
C#
public RingModDeviceAmountRunTimePreset Amount { get; set; }
Visual C++
public:
property RingModDeviceAmountRunTimePreset^ Amount {
    RingModDeviceAmountRunTimePreset^ get ();
    void set (RingModDeviceAmountRunTimePreset^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


Frequency Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.Frequency Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As RingModDeviceFrequencyRunTimePreset
C#
public RingModDeviceFrequencyRunTimePreset Frequency { get; set; }
Visual C++
public:
property RingModDeviceFrequencyRunTimePreset^ Frequency {
    RingModDeviceFrequencyRunTimePreset^ get ();
    void set (RingModDeviceFrequencyRunTimePreset^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


Inertia Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.Inertia Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Inertia As RingModDeviceInertiaRunTimePreset
C#
public RingModDeviceInertiaRunTimePreset Inertia { get; set; }
Visual C++
public:
property RingModDeviceInertiaRunTimePreset^ Inertia {
    RingModDeviceInertiaRunTimePreset^ get ();
    void set (RingModDeviceInertiaRunTimePreset^ value);
}
JavaScript
function get_inertia();
function set_inertia(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


OscillatorType Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.OscillatorType Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property OscillatorType As RingModDeviceOscillatorTypeRunTimePreset
C#
public RingModDeviceOscillatorTypeRunTimePreset OscillatorType { get; set; }
Visual C++
public:
property RingModDeviceOscillatorTypeRunTimePreset^ OscillatorType {
    RingModDeviceOscillatorTypeRunTimePreset^ get ();
    void set (RingModDeviceOscillatorTypeRunTimePreset^ value);
}
JavaScript
function get_oscillatorType();
function set_oscillatorType(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


Phase Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.Phase Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Phase As RingModDevicePhaseRunTimePreset
C#
public RingModDevicePhaseRunTimePreset Phase { get; set; }
Visual C++
public:
property RingModDevicePhaseRunTimePreset^ Phase {
    RingModDevicePhaseRunTimePreset^ get ();
    void set (RingModDevicePhaseRunTimePreset^ value);
}
JavaScript
function get_phase();
function set_phase(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
RingModDeviceDeviceSlotRunTimePreset..::.type Property
RingModDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

RingModDeviceDeviceSlotRunTimePreset Class


RingModDeviceFrequency Class

[image]

.NET Framework Class Library
RingModDeviceFrequency Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceFrequency
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceFrequency
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceFrequency
JavaScript
NRenoiseTools.RingModDeviceFrequency = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceFrequency');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceFrequency

See Also

RingModDeviceFrequency Members


RingModDeviceFrequency Members

[image] [image]

.NET Framework Class Library
RingModDeviceFrequency Members
RingModDeviceFrequency Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceFrequency type exposes the following members.

Constructors

Name | Description
RingModDeviceFrequency |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceFrequency Class


RingModDeviceFrequency Constructor

[image]

.NET Framework Class Library
RingModDeviceFrequency Constructor
RingModDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceFrequency()
Visual C++
public:
RingModDeviceFrequency()
JavaScript
NRenoiseTools.RingModDeviceFrequency = function();

See Also

RingModDeviceFrequency Class


RingModDeviceFrequency Methods

[image] [image]

.NET Framework Class Library
RingModDeviceFrequency Methods
RingModDeviceFrequency Class See Also Send Feedback

The RingModDeviceFrequency type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceFrequency Class


RingModDeviceFrequency Properties

[image] [image]

.NET Framework Class Library
RingModDeviceFrequency Properties
RingModDeviceFrequency Class See Also Send Feedback

The RingModDeviceFrequency type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceFrequency Class


MidiMappings Property

[image]

.NET Framework Class Library
RingModDeviceFrequency..::.MidiMappings Property
RingModDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

RingModDeviceFrequency Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceFrequency..::.Value Property
RingModDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceFrequency Class


Visualization Property

[image]

.NET Framework Class Library
RingModDeviceFrequency..::.Visualization Property
RingModDeviceFrequency Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As RingModDeviceFrequencyVisualization
C#
public RingModDeviceFrequencyVisualization Visualization { get; set; }
Visual C++
public:
property RingModDeviceFrequencyVisualization Visualization {
    RingModDeviceFrequencyVisualization get ();
    void set (RingModDeviceFrequencyVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

RingModDeviceFrequency Class


RingModDeviceFrequencyRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceFrequencyRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceFrequencyRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceFrequencyRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceFrequencyRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceFrequencyRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceFrequencyRunTimePreset

See Also

RingModDeviceFrequencyRunTimePreset Members


RingModDeviceFrequencyRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset Members
RingModDeviceFrequencyRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceFrequencyRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceFrequencyRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

RingModDeviceFrequencyRunTimePreset Class


RingModDeviceFrequencyRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset Constructor
RingModDeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceFrequencyRunTimePreset()
Visual C++
public:
RingModDeviceFrequencyRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceFrequencyRunTimePreset = function();

See Also

RingModDeviceFrequencyRunTimePreset Class


RingModDeviceFrequencyRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset Methods
RingModDeviceFrequencyRunTimePreset Class See Also Send Feedback

The RingModDeviceFrequencyRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceFrequencyRunTimePreset Class


RingModDeviceFrequencyRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset Properties
RingModDeviceFrequencyRunTimePreset Class See Also Send Feedback

The RingModDeviceFrequencyRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

RingModDeviceFrequencyRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceFrequencyRunTimePreset..::.Value Property
RingModDeviceFrequencyRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceFrequencyRunTimePreset Class


RingModDeviceFrequencyVisualization Enumeration

[image]

.NET Framework Class Library
RingModDeviceFrequencyVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration RingModDeviceFrequencyVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum RingModDeviceFrequencyVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class RingModDeviceFrequencyVisualization
JavaScript
NRenoiseTools.RingModDeviceFrequencyVisualization = function();
NRenoiseTools.RingModDeviceFrequencyVisualization.createEnum('NRenoiseTools.RingModDeviceFrequencyVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDeviceInertia Class

[image]

.NET Framework Class Library
RingModDeviceInertia Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceInertia
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceInertia
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceInertia
JavaScript
NRenoiseTools.RingModDeviceInertia = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceInertia');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceInertia

See Also

RingModDeviceInertia Members


RingModDeviceInertia Members

[image] [image]

.NET Framework Class Library
RingModDeviceInertia Members
RingModDeviceInertia Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceInertia type exposes the following members.

Constructors

Name | Description
RingModDeviceInertia |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceInertia Class


RingModDeviceInertia Constructor

[image]

.NET Framework Class Library
RingModDeviceInertia Constructor
RingModDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceInertia()
Visual C++
public:
RingModDeviceInertia()
JavaScript
NRenoiseTools.RingModDeviceInertia = function();

See Also

RingModDeviceInertia Class


RingModDeviceInertia Methods

[image] [image]

.NET Framework Class Library
RingModDeviceInertia Methods
RingModDeviceInertia Class See Also Send Feedback

The RingModDeviceInertia type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceInertia Class


RingModDeviceInertia Properties

[image] [image]

.NET Framework Class Library
RingModDeviceInertia Properties
RingModDeviceInertia Class See Also Send Feedback

The RingModDeviceInertia type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceInertia Class


MidiMappings Property

[image]

.NET Framework Class Library
RingModDeviceInertia..::.MidiMappings Property
RingModDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

RingModDeviceInertia Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceInertia..::.Value Property
RingModDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceInertia Class


Visualization Property

[image]

.NET Framework Class Library
RingModDeviceInertia..::.Visualization Property
RingModDeviceInertia Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As RingModDeviceInertiaVisualization
C#
public RingModDeviceInertiaVisualization Visualization { get; set; }
Visual C++
public:
property RingModDeviceInertiaVisualization Visualization {
    RingModDeviceInertiaVisualization get ();
    void set (RingModDeviceInertiaVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

RingModDeviceInertia Class


RingModDeviceInertiaRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceInertiaRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceInertiaRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceInertiaRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceInertiaRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceInertiaRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceInertiaRunTimePreset

See Also

RingModDeviceInertiaRunTimePreset Members


RingModDeviceInertiaRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset Members
RingModDeviceInertiaRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceInertiaRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceInertiaRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

RingModDeviceInertiaRunTimePreset Class


RingModDeviceInertiaRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset Constructor
RingModDeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceInertiaRunTimePreset()
Visual C++
public:
RingModDeviceInertiaRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceInertiaRunTimePreset = function();

See Also

RingModDeviceInertiaRunTimePreset Class


RingModDeviceInertiaRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset Methods
RingModDeviceInertiaRunTimePreset Class See Also Send Feedback

The RingModDeviceInertiaRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceInertiaRunTimePreset Class


RingModDeviceInertiaRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset Properties
RingModDeviceInertiaRunTimePreset Class See Also Send Feedback

The RingModDeviceInertiaRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

RingModDeviceInertiaRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceInertiaRunTimePreset..::.Value Property
RingModDeviceInertiaRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceInertiaRunTimePreset Class


RingModDeviceInertiaVisualization Enumeration

[image]

.NET Framework Class Library
RingModDeviceInertiaVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration RingModDeviceInertiaVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum RingModDeviceInertiaVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class RingModDeviceInertiaVisualization
JavaScript
NRenoiseTools.RingModDeviceInertiaVisualization = function();
NRenoiseTools.RingModDeviceInertiaVisualization.createEnum('NRenoiseTools.RingModDeviceInertiaVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDeviceOscillatorType Class

[image]

.NET Framework Class Library
RingModDeviceOscillatorType Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceOscillatorType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceOscillatorType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceOscillatorType
JavaScript
NRenoiseTools.RingModDeviceOscillatorType = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceOscillatorType');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceOscillatorType

See Also

RingModDeviceOscillatorType Members


RingModDeviceOscillatorType Members

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorType Members
RingModDeviceOscillatorType Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceOscillatorType type exposes the following members.

Constructors

Name | Description
RingModDeviceOscillatorType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceOscillatorType Class


RingModDeviceOscillatorType Constructor

[image]

.NET Framework Class Library
RingModDeviceOscillatorType Constructor
RingModDeviceOscillatorType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceOscillatorType()
Visual C++
public:
RingModDeviceOscillatorType()
JavaScript
NRenoiseTools.RingModDeviceOscillatorType = function();

See Also

RingModDeviceOscillatorType Class


RingModDeviceOscillatorType Methods

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorType Methods
RingModDeviceOscillatorType Class See Also Send Feedback

The RingModDeviceOscillatorType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceOscillatorType Class


RingModDeviceOscillatorType Properties

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorType Properties
RingModDeviceOscillatorType Class See Also Send Feedback

The RingModDeviceOscillatorType type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDeviceOscillatorType Class


MidiMappings Property

[image]

.NET Framework Class Library
RingModDeviceOscillatorType..::.MidiMappings Property
RingModDeviceOscillatorType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

RingModDeviceOscillatorType Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceOscillatorType..::.Value Property
RingModDeviceOscillatorType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceOscillatorType Class


Visualization Property

[image]

.NET Framework Class Library
RingModDeviceOscillatorType..::.Visualization Property
RingModDeviceOscillatorType Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As RingModDeviceOscillatorTypeVisualization
C#
public RingModDeviceOscillatorTypeVisualization Visualization { get; set; }
Visual C++
public:
property RingModDeviceOscillatorTypeVisualization Visualization {
    RingModDeviceOscillatorTypeVisualization get ();
    void set (RingModDeviceOscillatorTypeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

RingModDeviceOscillatorType Class


RingModDeviceOscillatorTypeRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceOscillatorTypeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceOscillatorTypeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceOscillatorTypeRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceOscillatorTypeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceOscillatorTypeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceOscillatorTypeRunTimePreset

See Also

RingModDeviceOscillatorTypeRunTimePreset Members


RingModDeviceOscillatorTypeRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset Members
RingModDeviceOscillatorTypeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceOscillatorTypeRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceOscillatorTypeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

RingModDeviceOscillatorTypeRunTimePreset Class


RingModDeviceOscillatorTypeRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset Constructor
RingModDeviceOscillatorTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceOscillatorTypeRunTimePreset()
Visual C++
public:
RingModDeviceOscillatorTypeRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceOscillatorTypeRunTimePreset = function();

See Also

RingModDeviceOscillatorTypeRunTimePreset Class


RingModDeviceOscillatorTypeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset Methods
RingModDeviceOscillatorTypeRunTimePreset Class See Also Send Feedback

The RingModDeviceOscillatorTypeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceOscillatorTypeRunTimePreset Class


RingModDeviceOscillatorTypeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset Properties
RingModDeviceOscillatorTypeRunTimePreset Class See Also Send Feedback

The RingModDeviceOscillatorTypeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

RingModDeviceOscillatorTypeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
RingModDeviceOscillatorTypeRunTimePreset..::.Value Property
RingModDeviceOscillatorTypeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDeviceOscillatorTypeRunTimePreset Class


RingModDeviceOscillatorTypeVisualization Enumeration

[image]

.NET Framework Class Library
RingModDeviceOscillatorTypeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration RingModDeviceOscillatorTypeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum RingModDeviceOscillatorTypeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class RingModDeviceOscillatorTypeVisualization
JavaScript
NRenoiseTools.RingModDeviceOscillatorTypeVisualization = function();
NRenoiseTools.RingModDeviceOscillatorTypeVisualization.createEnum('NRenoiseTools.RingModDeviceOscillatorTypeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDevicePhase Class

[image]

.NET Framework Class Library
RingModDevicePhase Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDevicePhase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDevicePhase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDevicePhase
JavaScript
NRenoiseTools.RingModDevicePhase = function();

Type.createClass(
    'NRenoiseTools.RingModDevicePhase');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDevicePhase

See Also

RingModDevicePhase Members


RingModDevicePhase Members

[image] [image]

.NET Framework Class Library
RingModDevicePhase Members
RingModDevicePhase Class Constructors Methods Properties See Also Send Feedback

The RingModDevicePhase type exposes the following members.

Constructors

Name | Description
RingModDevicePhase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDevicePhase Class


RingModDevicePhase Constructor

[image]

.NET Framework Class Library
RingModDevicePhase Constructor
RingModDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDevicePhase()
Visual C++
public:
RingModDevicePhase()
JavaScript
NRenoiseTools.RingModDevicePhase = function();

See Also

RingModDevicePhase Class


RingModDevicePhase Methods

[image] [image]

.NET Framework Class Library
RingModDevicePhase Methods
RingModDevicePhase Class See Also Send Feedback

The RingModDevicePhase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDevicePhase Class


RingModDevicePhase Properties

[image] [image]

.NET Framework Class Library
RingModDevicePhase Properties
RingModDevicePhase Class See Also Send Feedback

The RingModDevicePhase type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

RingModDevicePhase Class


MidiMappings Property

[image]

.NET Framework Class Library
RingModDevicePhase..::.MidiMappings Property
RingModDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

RingModDevicePhase Class


Value Property

[image]

.NET Framework Class Library
RingModDevicePhase..::.Value Property
RingModDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDevicePhase Class


Visualization Property

[image]

.NET Framework Class Library
RingModDevicePhase..::.Visualization Property
RingModDevicePhase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As RingModDevicePhaseVisualization
C#
public RingModDevicePhaseVisualization Visualization { get; set; }
Visual C++
public:
property RingModDevicePhaseVisualization Visualization {
    RingModDevicePhaseVisualization get ();
    void set (RingModDevicePhaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

RingModDevicePhase Class


RingModDevicePhaseRunTimePreset Class

[image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDevicePhaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDevicePhaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDevicePhaseRunTimePreset
JavaScript
NRenoiseTools.RingModDevicePhaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDevicePhaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDevicePhaseRunTimePreset

See Also

RingModDevicePhaseRunTimePreset Members


RingModDevicePhaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset Members
RingModDevicePhaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDevicePhaseRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDevicePhaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

RingModDevicePhaseRunTimePreset Class


RingModDevicePhaseRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset Constructor
RingModDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDevicePhaseRunTimePreset()
Visual C++
public:
RingModDevicePhaseRunTimePreset()
JavaScript
NRenoiseTools.RingModDevicePhaseRunTimePreset = function();

See Also

RingModDevicePhaseRunTimePreset Class


RingModDevicePhaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset Methods
RingModDevicePhaseRunTimePreset Class See Also Send Feedback

The RingModDevicePhaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDevicePhaseRunTimePreset Class


RingModDevicePhaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset Properties
RingModDevicePhaseRunTimePreset Class See Also Send Feedback

The RingModDevicePhaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

RingModDevicePhaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
RingModDevicePhaseRunTimePreset..::.Value Property
RingModDevicePhaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RingModDevicePhaseRunTimePreset Class


RingModDevicePhaseVisualization Enumeration

[image]

.NET Framework Class Library
RingModDevicePhaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration RingModDevicePhaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum RingModDevicePhaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class RingModDevicePhaseVisualization
JavaScript
NRenoiseTools.RingModDevicePhaseVisualization = function();
NRenoiseTools.RingModDevicePhaseVisualization.createEnum('NRenoiseTools.RingModDevicePhaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


RingModDeviceRunTimePreset Class

[image]

.NET Framework Class Library
RingModDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class RingModDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class RingModDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class RingModDeviceRunTimePreset
JavaScript
NRenoiseTools.RingModDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.RingModDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.RingModDeviceRunTimePreset

See Also

RingModDeviceRunTimePreset Members


RingModDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
RingModDeviceRunTimePreset Members
RingModDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The RingModDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
RingModDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

RingModDeviceRunTimePreset Class


RingModDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
RingModDeviceRunTimePreset Constructor
RingModDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RingModDeviceRunTimePreset()
Visual C++
public:
RingModDeviceRunTimePreset()
JavaScript
NRenoiseTools.RingModDeviceRunTimePreset = function();

See Also

RingModDeviceRunTimePreset Class


RingModDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
RingModDeviceRunTimePreset Methods
RingModDeviceRunTimePreset Class See Also Send Feedback

The RingModDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingModDeviceRunTimePreset Class


RingModDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
RingModDeviceRunTimePreset Properties
RingModDeviceRunTimePreset Class See Also Send Feedback

The RingModDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

RingModDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
RingModDeviceRunTimePreset..::.DeviceSlot Property
RingModDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As RingModDeviceDeviceSlotRunTimePreset
C#
public RingModDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property RingModDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    RingModDeviceDeviceSlotRunTimePreset^ get ();
    void set (RingModDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

RingModDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
RingModDeviceRunTimePreset..::.type Property
RingModDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

RingModDeviceRunTimePreset Class


Sample Class

[image]

.NET Framework Class Library
Sample Class
Members See Also Send Feedback

Sample class. This class to create and manipulate Renoise Song.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Sample
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Sample
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Sample
JavaScript
NRenoiseTools.Sample = function();

Type.createClass(
    'NRenoiseTools.Sample');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Sample

See Also

Sample Members


Sample Members

[image] [image]

.NET Framework Class Library
Sample Members
Sample Class Constructors Methods Properties See Also Send Feedback

The Sample type exposes the following members.

Constructors

Name | Description
Sample |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseNote |
BeatSyncIsActive |
BeatSyncLines |
Buffer | Gets or sets the sample buffer.
FileModificationDate |
FileModificationDateSpecified |
FileModificationDayTime |
FileModificationDayTimeSpecified |
FileName |
Finetune |
InterpolationMode |
LoopEnd |
LoopMode |
LoopStart |
Name |
NewNoteAction |
Panning |
Volume |

See Also

Sample Class


Sample Constructor

[image]

.NET Framework Class Library
Sample Constructor
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Sample()
Visual C++
public:
Sample()
JavaScript
NRenoiseTools.Sample = function();

See Also

Sample Class


Sample Methods

[image] [image]

.NET Framework Class Library
Sample Methods
Sample Class See Also Send Feedback

The Sample type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sample Class


Sample Properties

[image] [image]

.NET Framework Class Library
Sample Properties
Sample Class See Also Send Feedback

The Sample type exposes the following members.

Properties

Name | Description
BaseNote |
BeatSyncIsActive |
BeatSyncLines |
Buffer | Gets or sets the sample buffer.
FileModificationDate |
FileModificationDateSpecified |
FileModificationDayTime |
FileModificationDayTimeSpecified |
FileName |
Finetune |
InterpolationMode |
LoopEnd |
LoopMode |
LoopStart |
Name |
NewNoteAction |
Panning |
Volume |

See Also

Sample Class


BaseNote Property

[image]

.NET Framework Class Library
Sample..::.BaseNote Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseNote As SByte
C#
public sbyte BaseNote { get; set; }
Visual C++
public:
property signed char BaseNote {
    signed char get ();
    void set (signed char value);
}
JavaScript
function get_baseNote();
function set_baseNote(value);

Remarks

See Also

Sample Class


BeatSyncIsActive Property

[image]

.NET Framework Class Library
Sample..::.BeatSyncIsActive Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BeatSyncIsActive As Boolean
C#
public bool BeatSyncIsActive { get; set; }
Visual C++
public:
property bool BeatSyncIsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_beatSyncIsActive();
function set_beatSyncIsActive(value);

Remarks

See Also

Sample Class


BeatSyncLines Property

[image]

.NET Framework Class Library
Sample..::.BeatSyncLines Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BeatSyncLines As Short
C#
public short BeatSyncLines { get; set; }
Visual C++
public:
property short BeatSyncLines {
    short get ();
    void set (short value);
}
JavaScript
function get_beatSyncLines();
function set_beatSyncLines(value);

Remarks

See Also

Sample Class


Buffer Property

[image]

.NET Framework Class Library
Sample..::.Buffer Property
Sample Class See Also Send Feedback

Gets or sets the sample buffer.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Buffer As Byte()
C#
public byte[] Buffer { get; set; }
Visual C++
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
JavaScript
function get_buffer();
function set_buffer(value);

Field Value

The sample buffer.

See Also

Sample Class


FileModificationDate Property

[image]

.NET Framework Class Library
Sample..::.FileModificationDate Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileModificationDate As DateTime
C#
public DateTime FileModificationDate { get; set; }
Visual C++
public:
property DateTime FileModificationDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_fileModificationDate();
function set_fileModificationDate(value);

Remarks

See Also

Sample Class


FileModificationDateSpecified Property

[image]

.NET Framework Class Library
Sample..::.FileModificationDateSpecified Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileModificationDateSpecified As Boolean
C#
public bool FileModificationDateSpecified { get; set; }
Visual C++
public:
property bool FileModificationDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fileModificationDateSpecified();
function set_fileModificationDateSpecified(value);

Remarks

See Also

Sample Class


FileModificationDayTime Property

[image]

.NET Framework Class Library
Sample..::.FileModificationDayTime Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileModificationDayTime As DateTime
C#
public DateTime FileModificationDayTime { get; set; }
Visual C++
public:
property DateTime FileModificationDayTime {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_fileModificationDayTime();
function set_fileModificationDayTime(value);

Remarks

See Also

Sample Class


FileModificationDayTimeSpecified Property

[image]

.NET Framework Class Library
Sample..::.FileModificationDayTimeSpecified Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileModificationDayTimeSpecified As Boolean
C#
public bool FileModificationDayTimeSpecified { get; set; }
Visual C++
public:
property bool FileModificationDayTimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fileModificationDayTimeSpecified();
function set_fileModificationDayTimeSpecified(value);

Remarks

See Also

Sample Class


FileName Property

[image]

.NET Framework Class Library
Sample..::.FileName Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

Remarks

See Also

Sample Class


Finetune Property

[image]

.NET Framework Class Library
Sample..::.Finetune Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Finetune As SByte
C#
public sbyte Finetune { get; set; }
Visual C++
public:
property signed char Finetune {
    signed char get ();
    void set (signed char value);
}
JavaScript
function get_finetune();
function set_finetune(value);

Remarks

See Also

Sample Class


InterpolationMode Property

[image]

.NET Framework Class Library
Sample..::.InterpolationMode Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As SampleInterpolationMode
C#
public SampleInterpolationMode InterpolationMode { get; set; }
Visual C++
public:
property SampleInterpolationMode InterpolationMode {
    SampleInterpolationMode get ();
    void set (SampleInterpolationMode value);
}
JavaScript
function get_interpolationMode();
function set_interpolationMode(value);

Remarks

See Also

Sample Class


LoopEnd Property

[image]

.NET Framework Class Library
Sample..::.LoopEnd Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopEnd As UInteger
C#
public uint LoopEnd { get; set; }
Visual C++
public:
property unsigned int LoopEnd {
    unsigned int get ();
    void set (unsigned int value);
}
JavaScript
function get_loopEnd();
function set_loopEnd(value);

Remarks

See Also

Sample Class


LoopMode Property

[image]

.NET Framework Class Library
Sample..::.LoopMode Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopMode As SampleLoopMode
C#
public SampleLoopMode LoopMode { get; set; }
Visual C++
public:
property SampleLoopMode LoopMode {
    SampleLoopMode get ();
    void set (SampleLoopMode value);
}
JavaScript
function get_loopMode();
function set_loopMode(value);

Remarks

See Also

Sample Class


LoopStart Property

[image]

.NET Framework Class Library
Sample..::.LoopStart Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LoopStart As UInteger
C#
public uint LoopStart { get; set; }
Visual C++
public:
property unsigned int LoopStart {
    unsigned int get ();
    void set (unsigned int value);
}
JavaScript
function get_loopStart();
function set_loopStart(value);

Remarks

See Also

Sample Class


Name Property

[image]

.NET Framework Class Library
Sample..::.Name Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

Sample Class


NewNoteAction Property

[image]

.NET Framework Class Library
Sample..::.NewNoteAction Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NewNoteAction As SampleNewNoteAction
C#
public SampleNewNoteAction NewNoteAction { get; set; }
Visual C++
public:
property SampleNewNoteAction NewNoteAction {
    SampleNewNoteAction get ();
    void set (SampleNewNoteAction value);
}
JavaScript
function get_newNoteAction();
function set_newNoteAction(value);

Remarks

See Also

Sample Class


Panning Property

[image]

.NET Framework Class Library
Sample..::.Panning Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As Single
C#
public float Panning { get; set; }
Visual C++
public:
property float Panning {
    float get ();
    void set (float value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

Sample Class


Volume Property

[image]

.NET Framework Class Library
Sample..::.Volume Property
Sample Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As Single
C#
public float Volume { get; set; }
Visual C++
public:
property float Volume {
    float get ();
    void set (float value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

Sample Class


SampleInterpolationMode Enumeration

[image]

.NET Framework Class Library
SampleInterpolationMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SampleInterpolationMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SampleInterpolationMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SampleInterpolationMode
JavaScript
NRenoiseTools.SampleInterpolationMode = function();
NRenoiseTools.SampleInterpolationMode.createEnum('NRenoiseTools.SampleInterpolationMode', false);

Members

Member name | Description
None |
Linear |
Cubic |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SampleLoopMode Enumeration

[image]

.NET Framework Class Library
SampleLoopMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SampleLoopMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SampleLoopMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SampleLoopMode
JavaScript
NRenoiseTools.SampleLoopMode = function();
NRenoiseTools.SampleLoopMode.createEnum('NRenoiseTools.SampleLoopMode', false);

Members

Member name | Description
Off |
Forward |
Backward |
PingPong |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SampleNewNoteAction Enumeration

[image]

.NET Framework Class Library
SampleNewNoteAction Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SampleNewNoteAction
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SampleNewNoteAction
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SampleNewNoteAction
JavaScript
NRenoiseTools.SampleNewNoteAction = function();
NRenoiseTools.SampleNewNoteAction.createEnum('NRenoiseTools.SampleNewNoteAction', false);

Members

Member name | Description
Cut |
NoteOff |
None |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SendDevice Class

[image]

.NET Framework Class Library
SendDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDevice
JavaScript
NRenoiseTools.SendDevice = function();

Type.createClass(
    'NRenoiseTools.SendDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDevice

See Also

SendDevice Members


SendDevice Members

[image] [image]

.NET Framework Class Library
SendDevice Members
SendDevice Class Constructors Methods Properties See Also Send Feedback

The SendDevice type exposes the following members.

Constructors

Name | Description
SendDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestSendTrack |
IsActive |
IsSelected |
MuteSource |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SendAmount |
type |

See Also

SendDevice Class


SendDevice Constructor

[image]

.NET Framework Class Library
SendDevice Constructor
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDevice()
Visual C++
public:
SendDevice()
JavaScript
NRenoiseTools.SendDevice = function();

See Also

SendDevice Class


SendDevice Methods

[image] [image]

.NET Framework Class Library
SendDevice Methods
SendDevice Class See Also Send Feedback

The SendDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDevice Class


SendDevice Properties

[image] [image]

.NET Framework Class Library
SendDevice Properties
SendDevice Class See Also Send Feedback

The SendDevice type exposes the following members.

Properties

Name | Description
DestSendTrack |
IsActive |
IsSelected |
MuteSource |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SendAmount |
type |

See Also

SendDevice Class


DestSendTrack Property

[image]

.NET Framework Class Library
SendDevice..::.DestSendTrack Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestSendTrack As SendDeviceDestSendTrack
C#
public SendDeviceDestSendTrack DestSendTrack { get; set; }
Visual C++
public:
property SendDeviceDestSendTrack^ DestSendTrack {
    SendDeviceDestSendTrack^ get ();
    void set (SendDeviceDestSendTrack^ value);
}
JavaScript
function get_destSendTrack();
function set_destSendTrack(value);

Remarks

See Also

SendDevice Class


IsActive Property

[image]

.NET Framework Class Library
SendDevice..::.IsActive Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

SendDevice Class


IsSelected Property

[image]

.NET Framework Class Library
SendDevice..::.IsSelected Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

SendDevice Class


MuteSource Property

[image]

.NET Framework Class Library
SendDevice..::.MuteSource Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MuteSource As Boolean
C#
public bool MuteSource { get; set; }
Visual C++
public:
property bool MuteSource {
    bool get ();
    void set (bool value);
}
JavaScript
function get_muteSource();
function set_muteSource(value);

Remarks

See Also

SendDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
SendDevice..::.RunTimePresetA Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As SendDeviceRunTimePreset
C#
public SendDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property SendDeviceRunTimePreset^ RunTimePresetA {
    SendDeviceRunTimePreset^ get ();
    void set (SendDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

SendDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
SendDevice..::.RunTimePresetB Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As SendDeviceRunTimePreset
C#
public SendDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property SendDeviceRunTimePreset^ RunTimePresetB {
    SendDeviceRunTimePreset^ get ();
    void set (SendDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

SendDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
SendDevice..::.SelectedPresetIsModified Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

SendDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
SendDevice..::.SelectedPresetName Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

SendDevice Class


SendAmount Property

[image]

.NET Framework Class Library
SendDevice..::.SendAmount Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SendAmount As SendDeviceSendAmount
C#
public SendDeviceSendAmount SendAmount { get; set; }
Visual C++
public:
property SendDeviceSendAmount^ SendAmount {
    SendDeviceSendAmount^ get ();
    void set (SendDeviceSendAmount^ value);
}
JavaScript
function get_sendAmount();
function set_sendAmount(value);

Remarks

See Also

SendDevice Class


type Property

[image]

.NET Framework Class Library
SendDevice..::.type Property
SendDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SendDevice Class


SendDeviceDestSendTrack Class

[image]

.NET Framework Class Library
SendDeviceDestSendTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceDestSendTrack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceDestSendTrack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceDestSendTrack
JavaScript
NRenoiseTools.SendDeviceDestSendTrack = function();

Type.createClass(
    'NRenoiseTools.SendDeviceDestSendTrack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceDestSendTrack

See Also

SendDeviceDestSendTrack Members


SendDeviceDestSendTrack Members

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrack Members
SendDeviceDestSendTrack Class Constructors Methods Properties See Also Send Feedback

The SendDeviceDestSendTrack type exposes the following members.

Constructors

Name | Description
SendDeviceDestSendTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SendDeviceDestSendTrack Class


SendDeviceDestSendTrack Constructor

[image]

.NET Framework Class Library
SendDeviceDestSendTrack Constructor
SendDeviceDestSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceDestSendTrack()
Visual C++
public:
SendDeviceDestSendTrack()
JavaScript
NRenoiseTools.SendDeviceDestSendTrack = function();

See Also

SendDeviceDestSendTrack Class


SendDeviceDestSendTrack Methods

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrack Methods
SendDeviceDestSendTrack Class See Also Send Feedback

The SendDeviceDestSendTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceDestSendTrack Class


SendDeviceDestSendTrack Properties

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrack Properties
SendDeviceDestSendTrack Class See Also Send Feedback

The SendDeviceDestSendTrack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SendDeviceDestSendTrack Class


MidiMappings Property

[image]

.NET Framework Class Library
SendDeviceDestSendTrack..::.MidiMappings Property
SendDeviceDestSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SendDeviceDestSendTrack Class


Value Property

[image]

.NET Framework Class Library
SendDeviceDestSendTrack..::.Value Property
SendDeviceDestSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SendDeviceDestSendTrack Class


Visualization Property

[image]

.NET Framework Class Library
SendDeviceDestSendTrack..::.Visualization Property
SendDeviceDestSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SendDeviceDestSendTrackVisualization
C#
public SendDeviceDestSendTrackVisualization Visualization { get; set; }
Visual C++
public:
property SendDeviceDestSendTrackVisualization Visualization {
    SendDeviceDestSendTrackVisualization get ();
    void set (SendDeviceDestSendTrackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SendDeviceDestSendTrack Class


SendDeviceDestSendTrackRunTimePreset Class

[image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceDestSendTrackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceDestSendTrackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceDestSendTrackRunTimePreset
JavaScript
NRenoiseTools.SendDeviceDestSendTrackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SendDeviceDestSendTrackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceDestSendTrackRunTimePreset

See Also

SendDeviceDestSendTrackRunTimePreset Members


SendDeviceDestSendTrackRunTimePreset Members

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset Members
SendDeviceDestSendTrackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SendDeviceDestSendTrackRunTimePreset type exposes the following members.

Constructors

Name | Description
SendDeviceDestSendTrackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SendDeviceDestSendTrackRunTimePreset Class


SendDeviceDestSendTrackRunTimePreset Constructor

[image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset Constructor
SendDeviceDestSendTrackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceDestSendTrackRunTimePreset()
Visual C++
public:
SendDeviceDestSendTrackRunTimePreset()
JavaScript
NRenoiseTools.SendDeviceDestSendTrackRunTimePreset = function();

See Also

SendDeviceDestSendTrackRunTimePreset Class


SendDeviceDestSendTrackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset Methods
SendDeviceDestSendTrackRunTimePreset Class See Also Send Feedback

The SendDeviceDestSendTrackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceDestSendTrackRunTimePreset Class


SendDeviceDestSendTrackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset Properties
SendDeviceDestSendTrackRunTimePreset Class See Also Send Feedback

The SendDeviceDestSendTrackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SendDeviceDestSendTrackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SendDeviceDestSendTrackRunTimePreset..::.Value Property
SendDeviceDestSendTrackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SendDeviceDestSendTrackRunTimePreset Class


SendDeviceDestSendTrackVisualization Enumeration

[image]

.NET Framework Class Library
SendDeviceDestSendTrackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SendDeviceDestSendTrackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SendDeviceDestSendTrackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SendDeviceDestSendTrackVisualization
JavaScript
NRenoiseTools.SendDeviceDestSendTrackVisualization = function();
NRenoiseTools.SendDeviceDestSendTrackVisualization.createEnum('NRenoiseTools.SendDeviceDestSendTrackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SendDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.SendDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SendDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceDeviceSlotRunTimePreset

See Also

SendDeviceDeviceSlotRunTimePreset Members


SendDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset Members
SendDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SendDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
SendDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestSendTrack |
MuteSource |
SendAmount |
type |

See Also

SendDeviceDeviceSlotRunTimePreset Class


SendDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset Constructor
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceDeviceSlotRunTimePreset()
Visual C++
public:
SendDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.SendDeviceDeviceSlotRunTimePreset = function();

See Also

SendDeviceDeviceSlotRunTimePreset Class


SendDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset Methods
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SendDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceDeviceSlotRunTimePreset Class


SendDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset Properties
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SendDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
DestSendTrack |
MuteSource |
SendAmount |
type |

See Also

SendDeviceDeviceSlotRunTimePreset Class


DestSendTrack Property

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset..::.DestSendTrack Property
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestSendTrack As SendDeviceDestSendTrackRunTimePreset
C#
public SendDeviceDestSendTrackRunTimePreset DestSendTrack { get; set; }
Visual C++
public:
property SendDeviceDestSendTrackRunTimePreset^ DestSendTrack {
    SendDeviceDestSendTrackRunTimePreset^ get ();
    void set (SendDeviceDestSendTrackRunTimePreset^ value);
}
JavaScript
function get_destSendTrack();
function set_destSendTrack(value);

Remarks

See Also

SendDeviceDeviceSlotRunTimePreset Class


MuteSource Property

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset..::.MuteSource Property
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MuteSource As Boolean
C#
public bool MuteSource { get; set; }
Visual C++
public:
property bool MuteSource {
    bool get ();
    void set (bool value);
}
JavaScript
function get_muteSource();
function set_muteSource(value);

Remarks

See Also

SendDeviceDeviceSlotRunTimePreset Class


SendAmount Property

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset..::.SendAmount Property
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SendAmount As SendDeviceSendAmountRunTimePreset
C#
public SendDeviceSendAmountRunTimePreset SendAmount { get; set; }
Visual C++
public:
property SendDeviceSendAmountRunTimePreset^ SendAmount {
    SendDeviceSendAmountRunTimePreset^ get ();
    void set (SendDeviceSendAmountRunTimePreset^ value);
}
JavaScript
function get_sendAmount();
function set_sendAmount(value);

Remarks

See Also

SendDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SendDeviceDeviceSlotRunTimePreset..::.type Property
SendDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SendDeviceDeviceSlotRunTimePreset Class


SendDeviceRunTimePreset Class

[image]

.NET Framework Class Library
SendDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceRunTimePreset
JavaScript
NRenoiseTools.SendDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SendDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceRunTimePreset

See Also

SendDeviceRunTimePreset Members


SendDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
SendDeviceRunTimePreset Members
SendDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SendDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
SendDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

SendDeviceRunTimePreset Class


SendDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
SendDeviceRunTimePreset Constructor
SendDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceRunTimePreset()
Visual C++
public:
SendDeviceRunTimePreset()
JavaScript
NRenoiseTools.SendDeviceRunTimePreset = function();

See Also

SendDeviceRunTimePreset Class


SendDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SendDeviceRunTimePreset Methods
SendDeviceRunTimePreset Class See Also Send Feedback

The SendDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceRunTimePreset Class


SendDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SendDeviceRunTimePreset Properties
SendDeviceRunTimePreset Class See Also Send Feedback

The SendDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

SendDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
SendDeviceRunTimePreset..::.DeviceSlot Property
SendDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As SendDeviceDeviceSlotRunTimePreset
C#
public SendDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property SendDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    SendDeviceDeviceSlotRunTimePreset^ get ();
    void set (SendDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

SendDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SendDeviceRunTimePreset..::.type Property
SendDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SendDeviceRunTimePreset Class


SendDeviceSendAmount Class

[image]

.NET Framework Class Library
SendDeviceSendAmount Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceSendAmount
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceSendAmount
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceSendAmount
JavaScript
NRenoiseTools.SendDeviceSendAmount = function();

Type.createClass(
    'NRenoiseTools.SendDeviceSendAmount');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceSendAmount

See Also

SendDeviceSendAmount Members


SendDeviceSendAmount Members

[image] [image]

.NET Framework Class Library
SendDeviceSendAmount Members
SendDeviceSendAmount Class Constructors Methods Properties See Also Send Feedback

The SendDeviceSendAmount type exposes the following members.

Constructors

Name | Description
SendDeviceSendAmount |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SendDeviceSendAmount Class


SendDeviceSendAmount Constructor

[image]

.NET Framework Class Library
SendDeviceSendAmount Constructor
SendDeviceSendAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceSendAmount()
Visual C++
public:
SendDeviceSendAmount()
JavaScript
NRenoiseTools.SendDeviceSendAmount = function();

See Also

SendDeviceSendAmount Class


SendDeviceSendAmount Methods

[image] [image]

.NET Framework Class Library
SendDeviceSendAmount Methods
SendDeviceSendAmount Class See Also Send Feedback

The SendDeviceSendAmount type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceSendAmount Class


SendDeviceSendAmount Properties

[image] [image]

.NET Framework Class Library
SendDeviceSendAmount Properties
SendDeviceSendAmount Class See Also Send Feedback

The SendDeviceSendAmount type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SendDeviceSendAmount Class


MidiMappings Property

[image]

.NET Framework Class Library
SendDeviceSendAmount..::.MidiMappings Property
SendDeviceSendAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SendDeviceSendAmount Class


Value Property

[image]

.NET Framework Class Library
SendDeviceSendAmount..::.Value Property
SendDeviceSendAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SendDeviceSendAmount Class


Visualization Property

[image]

.NET Framework Class Library
SendDeviceSendAmount..::.Visualization Property
SendDeviceSendAmount Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SendDeviceSendAmountVisualization
C#
public SendDeviceSendAmountVisualization Visualization { get; set; }
Visual C++
public:
property SendDeviceSendAmountVisualization Visualization {
    SendDeviceSendAmountVisualization get ();
    void set (SendDeviceSendAmountVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SendDeviceSendAmount Class


SendDeviceSendAmountRunTimePreset Class

[image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SendDeviceSendAmountRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SendDeviceSendAmountRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SendDeviceSendAmountRunTimePreset
JavaScript
NRenoiseTools.SendDeviceSendAmountRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SendDeviceSendAmountRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SendDeviceSendAmountRunTimePreset

See Also

SendDeviceSendAmountRunTimePreset Members


SendDeviceSendAmountRunTimePreset Members

[image] [image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset Members
SendDeviceSendAmountRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SendDeviceSendAmountRunTimePreset type exposes the following members.

Constructors

Name | Description
SendDeviceSendAmountRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SendDeviceSendAmountRunTimePreset Class


SendDeviceSendAmountRunTimePreset Constructor

[image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset Constructor
SendDeviceSendAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SendDeviceSendAmountRunTimePreset()
Visual C++
public:
SendDeviceSendAmountRunTimePreset()
JavaScript
NRenoiseTools.SendDeviceSendAmountRunTimePreset = function();

See Also

SendDeviceSendAmountRunTimePreset Class


SendDeviceSendAmountRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset Methods
SendDeviceSendAmountRunTimePreset Class See Also Send Feedback

The SendDeviceSendAmountRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SendDeviceSendAmountRunTimePreset Class


SendDeviceSendAmountRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset Properties
SendDeviceSendAmountRunTimePreset Class See Also Send Feedback

The SendDeviceSendAmountRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SendDeviceSendAmountRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SendDeviceSendAmountRunTimePreset..::.Value Property
SendDeviceSendAmountRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SendDeviceSendAmountRunTimePreset Class


SendDeviceSendAmountVisualization Enumeration

[image]

.NET Framework Class Library
SendDeviceSendAmountVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SendDeviceSendAmountVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SendDeviceSendAmountVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SendDeviceSendAmountVisualization
JavaScript
NRenoiseTools.SendDeviceSendAmountVisualization = function();
NRenoiseTools.SendDeviceSendAmountVisualization.createEnum('NRenoiseTools.SendDeviceSendAmountVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrack Class

[image]

.NET Framework Class Library
SequencerMasterTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrack
JavaScript
NRenoiseTools.SequencerMasterTrack = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrack

See Also

SequencerMasterTrack Members


SequencerMasterTrack Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrack Members
SequencerMasterTrack Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrack type exposes the following members.

Constructors

Name | Description
SequencerMasterTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerMasterTrack Class


SequencerMasterTrack Constructor

[image]

.NET Framework Class Library
SequencerMasterTrack Constructor
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrack()
Visual C++
public:
SequencerMasterTrack()
JavaScript
NRenoiseTools.SequencerMasterTrack = function();

See Also

SequencerMasterTrack Class


SequencerMasterTrack Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrack Methods
SequencerMasterTrack Class See Also Send Feedback

The SequencerMasterTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrack Class


SequencerMasterTrack Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrack Properties
SequencerMasterTrack Class See Also Send Feedback

The SequencerMasterTrack type exposes the following members.

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerMasterTrack Class


DelayColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.DelayColumnIsVisible Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayColumnIsVisible As Boolean
C#
public bool DelayColumnIsVisible { get; set; }
Visual C++
public:
property bool DelayColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_delayColumnIsVisible();
function set_delayColumnIsVisible(value);

Remarks

See Also

SequencerMasterTrack Class


FilterDevices Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.FilterDevices Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDevices As SequencerMasterTrackFilterDevices
C#
public SequencerMasterTrackFilterDevices FilterDevices { get; set; }
Visual C++
public:
property SequencerMasterTrackFilterDevices^ FilterDevices {
    SequencerMasterTrackFilterDevices^ get ();
    void set (SequencerMasterTrackFilterDevices^ value);
}
JavaScript
function get_filterDevices();
function set_filterDevices(value);

Remarks

See Also

SequencerMasterTrack Class


Name Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.Name Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

SequencerMasterTrack Class


NoteColumnStates Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.NoteColumnStates Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NoteColumnStates As SequencerMasterTrackNoteColumnState()
C#
public SequencerMasterTrackNoteColumnState[] NoteColumnStates { get; set; }
Visual C++
public:
property array<SequencerMasterTrackNoteColumnState>^ NoteColumnStates {
    array<SequencerMasterTrackNoteColumnState>^ get ();
    void set (array<SequencerMasterTrackNoteColumnState>^ value);
}
JavaScript
function get_noteColumnStates();
function set_noteColumnStates(value);

Remarks

See Also

SequencerMasterTrack Class


NumberOfVisibleEffectColumns Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.NumberOfVisibleEffectColumns Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleEffectColumns As Integer
C#
public int NumberOfVisibleEffectColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleEffectColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleEffectColumns();
function set_numberOfVisibleEffectColumns(value);

Remarks

See Also

SequencerMasterTrack Class


NumberOfVisibleNoteColumns Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.NumberOfVisibleNoteColumns Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleNoteColumns As Integer
C#
public int NumberOfVisibleNoteColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleNoteColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleNoteColumns();
function set_numberOfVisibleNoteColumns(value);

Remarks

See Also

SequencerMasterTrack Class


PanningColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.PanningColumnIsVisible Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PanningColumnIsVisible As Boolean
C#
public bool PanningColumnIsVisible { get; set; }
Visual C++
public:
property bool PanningColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_panningColumnIsVisible();
function set_panningColumnIsVisible(value);

Remarks

See Also

SequencerMasterTrack Class


State Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.State Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property State As SequencerMasterTrackState
C#
public SequencerMasterTrackState State { get; set; }
Visual C++
public:
property SequencerMasterTrackState State {
    SequencerMasterTrackState get ();
    void set (SequencerMasterTrackState value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

SequencerMasterTrack Class


TrackDelay Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.TrackDelay Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackDelay As Single
C#
public float TrackDelay { get; set; }
Visual C++
public:
property float TrackDelay {
    float get ();
    void set (float value);
}
JavaScript
function get_trackDelay();
function set_trackDelay(value);

Remarks

See Also

SequencerMasterTrack Class


TrackRouting Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.TrackRouting Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackRouting As Integer
C#
public int TrackRouting { get; set; }
Visual C++
public:
property int TrackRouting {
    int get ();
    void set (int value);
}
JavaScript
function get_trackRouting();
function set_trackRouting(value);

Remarks

See Also

SequencerMasterTrack Class


type Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.type Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerMasterTrack Class


VolumeColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerMasterTrack..::.VolumeColumnIsVisible Property
SequencerMasterTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VolumeColumnIsVisible As Boolean
C#
public bool VolumeColumnIsVisible { get; set; }
Visual C++
public:
property bool VolumeColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_volumeColumnIsVisible();
function set_volumeColumnIsVisible(value);

Remarks

See Also

SequencerMasterTrack Class


SequencerMasterTrackDevice Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevice
JavaScript
NRenoiseTools.SequencerMasterTrackDevice = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevice

See Also

SequencerMasterTrackDevice Members


SequencerMasterTrackDevice Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevice Members
SequencerMasterTrackDevice Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevice type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoDcCorrection |
AutoGain |
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SoftClipping |
Surround |
type |
Volume |

See Also

SequencerMasterTrackDevice Class


SequencerMasterTrackDevice Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevice Constructor
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevice()
Visual C++
public:
SequencerMasterTrackDevice()
JavaScript
NRenoiseTools.SequencerMasterTrackDevice = function();

See Also

SequencerMasterTrackDevice Class


SequencerMasterTrackDevice Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevice Methods
SequencerMasterTrackDevice Class See Also Send Feedback

The SequencerMasterTrackDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevice Class


SequencerMasterTrackDevice Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevice Properties
SequencerMasterTrackDevice Class See Also Send Feedback

The SequencerMasterTrackDevice type exposes the following members.

Properties

Name | Description
AutoDcCorrection |
AutoGain |
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SoftClipping |
Surround |
type |
Volume |

See Also

SequencerMasterTrackDevice Class


AutoDcCorrection Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.AutoDcCorrection Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoDcCorrection As Boolean
C#
public bool AutoDcCorrection { get; set; }
Visual C++
public:
property bool AutoDcCorrection {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoDcCorrection();
function set_autoDcCorrection(value);

Remarks

See Also

SequencerMasterTrackDevice Class


AutoGain Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.AutoGain Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoGain As Boolean
C#
public bool AutoGain { get; set; }
Visual C++
public:
property bool AutoGain {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoGain();
function set_autoGain(value);

Remarks

See Also

SequencerMasterTrackDevice Class


IsActive Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.IsActive Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

SequencerMasterTrackDevice Class


IsSelected Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.IsSelected Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

SequencerMasterTrackDevice Class


Panning Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.Panning Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerMasterTrackDevicePanning
C#
public SequencerMasterTrackDevicePanning Panning { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePanning^ Panning {
    SequencerMasterTrackDevicePanning^ get ();
    void set (SequencerMasterTrackDevicePanning^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerMasterTrackDevice Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.PostPanning Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerMasterTrackDevicePostPanning
C#
public SequencerMasterTrackDevicePostPanning PostPanning { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostPanning^ PostPanning {
    SequencerMasterTrackDevicePostPanning^ get ();
    void set (SequencerMasterTrackDevicePostPanning^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerMasterTrackDevice Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.PostVolume Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerMasterTrackDevicePostVolume
C#
public SequencerMasterTrackDevicePostVolume PostVolume { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostVolume^ PostVolume {
    SequencerMasterTrackDevicePostVolume^ get ();
    void set (SequencerMasterTrackDevicePostVolume^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerMasterTrackDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.RunTimePresetA Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As SequencerMasterTrackDeviceRunTimePreset
C#
public SequencerMasterTrackDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceRunTimePreset^ RunTimePresetA {
    SequencerMasterTrackDeviceRunTimePreset^ get ();
    void set (SequencerMasterTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

SequencerMasterTrackDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.RunTimePresetB Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As SequencerMasterTrackDeviceRunTimePreset
C#
public SequencerMasterTrackDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceRunTimePreset^ RunTimePresetB {
    SequencerMasterTrackDeviceRunTimePreset^ get ();
    void set (SequencerMasterTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

SequencerMasterTrackDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.SelectedPresetIsModified Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

SequencerMasterTrackDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.SelectedPresetName Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

SequencerMasterTrackDevice Class


SoftClipping Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.SoftClipping Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SoftClipping As Boolean
C#
public bool SoftClipping { get; set; }
Visual C++
public:
property bool SoftClipping {
    bool get ();
    void set (bool value);
}
JavaScript
function get_softClipping();
function set_softClipping(value);

Remarks

See Also

SequencerMasterTrackDevice Class


Surround Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.Surround Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerMasterTrackDeviceSurround
C#
public SequencerMasterTrackDeviceSurround Surround { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceSurround^ Surround {
    SequencerMasterTrackDeviceSurround^ get ();
    void set (SequencerMasterTrackDeviceSurround^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerMasterTrackDevice Class


type Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.type Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerMasterTrackDevice Class


Volume Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevice..::.Volume Property
SequencerMasterTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerMasterTrackDeviceVolume
C#
public SequencerMasterTrackDeviceVolume Volume { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceVolume^ Volume {
    SequencerMasterTrackDeviceVolume^ get ();
    void set (SequencerMasterTrackDeviceVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerMasterTrackDevice Class


SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceDeviceSlotRunTimePreset

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Members


SequencerMasterTrackDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Members
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoDcCorrection |
AutoGain |
Panning |
PostPanning |
PostVolume |
SoftClipping |
Surround |
type |
Volume |

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


SequencerMasterTrackDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Constructor
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceDeviceSlotRunTimePreset()
Visual C++
public:
SequencerMasterTrackDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceDeviceSlotRunTimePreset = function();

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


SequencerMasterTrackDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Methods
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


SequencerMasterTrackDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Properties
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
AutoDcCorrection |
AutoGain |
Panning |
PostPanning |
PostVolume |
SoftClipping |
Surround |
type |
Volume |

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


AutoDcCorrection Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.AutoDcCorrection Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoDcCorrection As Boolean
C#
public bool AutoDcCorrection { get; set; }
Visual C++
public:
property bool AutoDcCorrection {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoDcCorrection();
function set_autoDcCorrection(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


AutoGain Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.AutoGain Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoGain As Boolean
C#
public bool AutoGain { get; set; }
Visual C++
public:
property bool AutoGain {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoGain();
function set_autoGain(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


Panning Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.Panning Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerMasterTrackDevicePanningRunTimePreset
C#
public SequencerMasterTrackDevicePanningRunTimePreset Panning { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePanningRunTimePreset^ Panning {
    SequencerMasterTrackDevicePanningRunTimePreset^ get ();
    void set (SequencerMasterTrackDevicePanningRunTimePreset^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.PostPanning Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerMasterTrackDevicePostPanningRunTimePreset
C#
public SequencerMasterTrackDevicePostPanningRunTimePreset PostPanning { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostPanningRunTimePreset^ PostPanning {
    SequencerMasterTrackDevicePostPanningRunTimePreset^ get ();
    void set (SequencerMasterTrackDevicePostPanningRunTimePreset^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.PostVolume Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerMasterTrackDevicePostVolumeRunTimePreset
C#
public SequencerMasterTrackDevicePostVolumeRunTimePreset PostVolume { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostVolumeRunTimePreset^ PostVolume {
    SequencerMasterTrackDevicePostVolumeRunTimePreset^ get ();
    void set (SequencerMasterTrackDevicePostVolumeRunTimePreset^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


SoftClipping Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.SoftClipping Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SoftClipping As Boolean
C#
public bool SoftClipping { get; set; }
Visual C++
public:
property bool SoftClipping {
    bool get ();
    void set (bool value);
}
JavaScript
function get_softClipping();
function set_softClipping(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


Surround Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.Surround Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerMasterTrackDeviceSurroundRunTimePreset
C#
public SequencerMasterTrackDeviceSurroundRunTimePreset Surround { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceSurroundRunTimePreset^ Surround {
    SequencerMasterTrackDeviceSurroundRunTimePreset^ get ();
    void set (SequencerMasterTrackDeviceSurroundRunTimePreset^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.type Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


Volume Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceDeviceSlotRunTimePreset..::.Volume Property
SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerMasterTrackDeviceVolumeRunTimePreset
C#
public SequencerMasterTrackDeviceVolumeRunTimePreset Volume { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceVolumeRunTimePreset^ Volume {
    SequencerMasterTrackDeviceVolumeRunTimePreset^ get ();
    void set (SequencerMasterTrackDeviceVolumeRunTimePreset^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerMasterTrackDeviceDeviceSlotRunTimePreset Class


SequencerMasterTrackDevicePanning Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePanning
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePanning = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePanning

See Also

SequencerMasterTrackDevicePanning Members


SequencerMasterTrackDevicePanning Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning Members
SequencerMasterTrackDevicePanning Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePanning type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePanning Class


SequencerMasterTrackDevicePanning Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning Constructor
SequencerMasterTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePanning()
Visual C++
public:
SequencerMasterTrackDevicePanning()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePanning = function();

See Also

SequencerMasterTrackDevicePanning Class


SequencerMasterTrackDevicePanning Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning Methods
SequencerMasterTrackDevicePanning Class See Also Send Feedback

The SequencerMasterTrackDevicePanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePanning Class


SequencerMasterTrackDevicePanning Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning Properties
SequencerMasterTrackDevicePanning Class See Also Send Feedback

The SequencerMasterTrackDevicePanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning..::.MidiMappings Property
SequencerMasterTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerMasterTrackDevicePanning Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning..::.Value Property
SequencerMasterTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanning..::.Visualization Property
SequencerMasterTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerMasterTrackDevicePanningVisualization
C#
public SequencerMasterTrackDevicePanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePanningVisualization Visualization {
    SequencerMasterTrackDevicePanningVisualization get ();
    void set (SequencerMasterTrackDevicePanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerMasterTrackDevicePanning Class


SequencerMasterTrackDevicePanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePanningRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePanningRunTimePreset

See Also

SequencerMasterTrackDevicePanningRunTimePreset Members


SequencerMasterTrackDevicePanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset Members
SequencerMasterTrackDevicePanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePanningRunTimePreset Class


SequencerMasterTrackDevicePanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset Constructor
SequencerMasterTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePanningRunTimePreset()
Visual C++
public:
SequencerMasterTrackDevicePanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePanningRunTimePreset = function();

See Also

SequencerMasterTrackDevicePanningRunTimePreset Class


SequencerMasterTrackDevicePanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset Methods
SequencerMasterTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePanningRunTimePreset Class


SequencerMasterTrackDevicePanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset Properties
SequencerMasterTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningRunTimePreset..::.Value Property
SequencerMasterTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePanningRunTimePreset Class


SequencerMasterTrackDevicePanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackDevicePanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackDevicePanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackDevicePanningVisualization
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePanningVisualization = function();
NRenoiseTools.SequencerMasterTrackDevicePanningVisualization.createEnum('NRenoiseTools.SequencerMasterTrackDevicePanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackDevicePostPanning Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePostPanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePostPanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePostPanning
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostPanning = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePostPanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePostPanning

See Also

SequencerMasterTrackDevicePostPanning Members


SequencerMasterTrackDevicePostPanning Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning Members
SequencerMasterTrackDevicePostPanning Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePostPanning type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePostPanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePostPanning Class


SequencerMasterTrackDevicePostPanning Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning Constructor
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePostPanning()
Visual C++
public:
SequencerMasterTrackDevicePostPanning()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostPanning = function();

See Also

SequencerMasterTrackDevicePostPanning Class


SequencerMasterTrackDevicePostPanning Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning Methods
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

The SequencerMasterTrackDevicePostPanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePostPanning Class


SequencerMasterTrackDevicePostPanning Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning Properties
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

The SequencerMasterTrackDevicePostPanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePostPanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning..::.MidiMappings Property
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerMasterTrackDevicePostPanning Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning..::.Value Property
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePostPanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanning..::.Visualization Property
SequencerMasterTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerMasterTrackDevicePostPanningVisualization
C#
public SequencerMasterTrackDevicePostPanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostPanningVisualization Visualization {
    SequencerMasterTrackDevicePostPanningVisualization get ();
    void set (SequencerMasterTrackDevicePostPanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerMasterTrackDevicePostPanning Class


SequencerMasterTrackDevicePostPanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePostPanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePostPanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePostPanningRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostPanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePostPanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePostPanningRunTimePreset

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Members


SequencerMasterTrackDevicePostPanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset Members
SequencerMasterTrackDevicePostPanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePostPanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePostPanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Class


SequencerMasterTrackDevicePostPanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset Constructor
SequencerMasterTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePostPanningRunTimePreset()
Visual C++
public:
SequencerMasterTrackDevicePostPanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostPanningRunTimePreset = function();

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Class


SequencerMasterTrackDevicePostPanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset Methods
SequencerMasterTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePostPanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Class


SequencerMasterTrackDevicePostPanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset Properties
SequencerMasterTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePostPanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningRunTimePreset..::.Value Property
SequencerMasterTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePostPanningRunTimePreset Class


SequencerMasterTrackDevicePostPanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostPanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackDevicePostPanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackDevicePostPanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackDevicePostPanningVisualization
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostPanningVisualization = function();
NRenoiseTools.SequencerMasterTrackDevicePostPanningVisualization.createEnum('NRenoiseTools.SequencerMasterTrackDevicePostPanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackDevicePostVolume Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePostVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePostVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePostVolume
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePostVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePostVolume

See Also

SequencerMasterTrackDevicePostVolume Members


SequencerMasterTrackDevicePostVolume Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume Members
SequencerMasterTrackDevicePostVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePostVolume type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePostVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePostVolume Class


SequencerMasterTrackDevicePostVolume Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume Constructor
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePostVolume()
Visual C++
public:
SequencerMasterTrackDevicePostVolume()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostVolume = function();

See Also

SequencerMasterTrackDevicePostVolume Class


SequencerMasterTrackDevicePostVolume Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume Methods
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

The SequencerMasterTrackDevicePostVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePostVolume Class


SequencerMasterTrackDevicePostVolume Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume Properties
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

The SequencerMasterTrackDevicePostVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDevicePostVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume..::.MidiMappings Property
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerMasterTrackDevicePostVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume..::.Value Property
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePostVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolume..::.Visualization Property
SequencerMasterTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerMasterTrackDevicePostVolumeVisualization
C#
public SequencerMasterTrackDevicePostVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerMasterTrackDevicePostVolumeVisualization Visualization {
    SequencerMasterTrackDevicePostVolumeVisualization get ();
    void set (SequencerMasterTrackDevicePostVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerMasterTrackDevicePostVolume Class


SequencerMasterTrackDevicePostVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDevicePostVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDevicePostVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDevicePostVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDevicePostVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDevicePostVolumeRunTimePreset

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Members


SequencerMasterTrackDevicePostVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset Members
SequencerMasterTrackDevicePostVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDevicePostVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDevicePostVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Class


SequencerMasterTrackDevicePostVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset Constructor
SequencerMasterTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDevicePostVolumeRunTimePreset()
Visual C++
public:
SequencerMasterTrackDevicePostVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostVolumeRunTimePreset = function();

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Class


SequencerMasterTrackDevicePostVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset Methods
SequencerMasterTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePostVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Class


SequencerMasterTrackDevicePostVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset Properties
SequencerMasterTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDevicePostVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeRunTimePreset..::.Value Property
SequencerMasterTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDevicePostVolumeRunTimePreset Class


SequencerMasterTrackDevicePostVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackDevicePostVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackDevicePostVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackDevicePostVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackDevicePostVolumeVisualization
JavaScript
NRenoiseTools.SequencerMasterTrackDevicePostVolumeVisualization = function();
NRenoiseTools.SequencerMasterTrackDevicePostVolumeVisualization.createEnum('NRenoiseTools.SequencerMasterTrackDevicePostVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackDeviceRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceRunTimePreset

See Also

SequencerMasterTrackDeviceRunTimePreset Members


SequencerMasterTrackDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset Members
SequencerMasterTrackDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerMasterTrackDeviceRunTimePreset Class


SequencerMasterTrackDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset Constructor
SequencerMasterTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceRunTimePreset()
Visual C++
public:
SequencerMasterTrackDeviceRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceRunTimePreset = function();

See Also

SequencerMasterTrackDeviceRunTimePreset Class


SequencerMasterTrackDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset Methods
SequencerMasterTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceRunTimePreset Class


SequencerMasterTrackDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset Properties
SequencerMasterTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerMasterTrackDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset..::.DeviceSlot Property
SequencerMasterTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As SequencerMasterTrackDeviceDeviceSlotRunTimePreset
C#
public SequencerMasterTrackDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    SequencerMasterTrackDeviceDeviceSlotRunTimePreset^ get ();
    void set (SequencerMasterTrackDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

SequencerMasterTrackDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceRunTimePreset..::.type Property
SequencerMasterTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerMasterTrackDeviceRunTimePreset Class


SequencerMasterTrackDeviceSurround Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceSurround
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceSurround
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceSurround
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceSurround = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceSurround');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceSurround

See Also

SequencerMasterTrackDeviceSurround Members


SequencerMasterTrackDeviceSurround Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround Members
SequencerMasterTrackDeviceSurround Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceSurround type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceSurround |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDeviceSurround Class


SequencerMasterTrackDeviceSurround Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround Constructor
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceSurround()
Visual C++
public:
SequencerMasterTrackDeviceSurround()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceSurround = function();

See Also

SequencerMasterTrackDeviceSurround Class


SequencerMasterTrackDeviceSurround Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround Methods
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

The SequencerMasterTrackDeviceSurround type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceSurround Class


SequencerMasterTrackDeviceSurround Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround Properties
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

The SequencerMasterTrackDeviceSurround type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDeviceSurround Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround..::.MidiMappings Property
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerMasterTrackDeviceSurround Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround..::.Value Property
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDeviceSurround Class


Visualization Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurround..::.Visualization Property
SequencerMasterTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerMasterTrackDeviceSurroundVisualization
C#
public SequencerMasterTrackDeviceSurroundVisualization Visualization { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceSurroundVisualization Visualization {
    SequencerMasterTrackDeviceSurroundVisualization get ();
    void set (SequencerMasterTrackDeviceSurroundVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerMasterTrackDeviceSurround Class


SequencerMasterTrackDeviceSurroundRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceSurroundRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceSurroundRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceSurroundRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceSurroundRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceSurroundRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceSurroundRunTimePreset

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Members


SequencerMasterTrackDeviceSurroundRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset Members
SequencerMasterTrackDeviceSurroundRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceSurroundRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceSurroundRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Class


SequencerMasterTrackDeviceSurroundRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset Constructor
SequencerMasterTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceSurroundRunTimePreset()
Visual C++
public:
SequencerMasterTrackDeviceSurroundRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceSurroundRunTimePreset = function();

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Class


SequencerMasterTrackDeviceSurroundRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset Methods
SequencerMasterTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceSurroundRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Class


SequencerMasterTrackDeviceSurroundRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset Properties
SequencerMasterTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceSurroundRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundRunTimePreset..::.Value Property
SequencerMasterTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDeviceSurroundRunTimePreset Class


SequencerMasterTrackDeviceSurroundVisualization Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceSurroundVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackDeviceSurroundVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackDeviceSurroundVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackDeviceSurroundVisualization
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceSurroundVisualization = function();
NRenoiseTools.SequencerMasterTrackDeviceSurroundVisualization.createEnum('NRenoiseTools.SequencerMasterTrackDeviceSurroundVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackDeviceVolume Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceVolume
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceVolume

See Also

SequencerMasterTrackDeviceVolume Members


SequencerMasterTrackDeviceVolume Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume Members
SequencerMasterTrackDeviceVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceVolume type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDeviceVolume Class


SequencerMasterTrackDeviceVolume Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume Constructor
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceVolume()
Visual C++
public:
SequencerMasterTrackDeviceVolume()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceVolume = function();

See Also

SequencerMasterTrackDeviceVolume Class


SequencerMasterTrackDeviceVolume Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume Methods
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

The SequencerMasterTrackDeviceVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceVolume Class


SequencerMasterTrackDeviceVolume Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume Properties
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

The SequencerMasterTrackDeviceVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerMasterTrackDeviceVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume..::.MidiMappings Property
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerMasterTrackDeviceVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume..::.Value Property
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDeviceVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolume..::.Visualization Property
SequencerMasterTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerMasterTrackDeviceVolumeVisualization
C#
public SequencerMasterTrackDeviceVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerMasterTrackDeviceVolumeVisualization Visualization {
    SequencerMasterTrackDeviceVolumeVisualization get ();
    void set (SequencerMasterTrackDeviceVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerMasterTrackDeviceVolume Class


SequencerMasterTrackDeviceVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackDeviceVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackDeviceVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackDeviceVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackDeviceVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackDeviceVolumeRunTimePreset

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Members


SequencerMasterTrackDeviceVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset Members
SequencerMasterTrackDeviceVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackDeviceVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackDeviceVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Class


SequencerMasterTrackDeviceVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset Constructor
SequencerMasterTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackDeviceVolumeRunTimePreset()
Visual C++
public:
SequencerMasterTrackDeviceVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceVolumeRunTimePreset = function();

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Class


SequencerMasterTrackDeviceVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset Methods
SequencerMasterTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Class


SequencerMasterTrackDeviceVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset Properties
SequencerMasterTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerMasterTrackDeviceVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeRunTimePreset..::.Value Property
SequencerMasterTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerMasterTrackDeviceVolumeRunTimePreset Class


SequencerMasterTrackDeviceVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackDeviceVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackDeviceVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackDeviceVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackDeviceVolumeVisualization
JavaScript
NRenoiseTools.SequencerMasterTrackDeviceVolumeVisualization = function();
NRenoiseTools.SequencerMasterTrackDeviceVolumeVisualization.createEnum('NRenoiseTools.SequencerMasterTrackDeviceVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackFilterDevices Class

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackFilterDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackFilterDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackFilterDevices
JavaScript
NRenoiseTools.SequencerMasterTrackFilterDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackFilterDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackFilterDevices

See Also

SequencerMasterTrackFilterDevices Members


SequencerMasterTrackFilterDevices Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices Members
SequencerMasterTrackFilterDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackFilterDevices type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackFilterDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Devices |

See Also

SequencerMasterTrackFilterDevices Class


SequencerMasterTrackFilterDevices Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices Constructor
SequencerMasterTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackFilterDevices()
Visual C++
public:
SequencerMasterTrackFilterDevices()
JavaScript
NRenoiseTools.SequencerMasterTrackFilterDevices = function();

See Also

SequencerMasterTrackFilterDevices Class


SequencerMasterTrackFilterDevices Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices Methods
SequencerMasterTrackFilterDevices Class See Also Send Feedback

The SequencerMasterTrackFilterDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackFilterDevices Class


SequencerMasterTrackFilterDevices Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices Properties
SequencerMasterTrackFilterDevices Class See Also Send Feedback

The SequencerMasterTrackFilterDevices type exposes the following members.

Properties

Name | Description
Devices |

See Also

SequencerMasterTrackFilterDevices Class


Devices Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevices..::.Devices Property
SequencerMasterTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Devices As SequencerMasterTrackFilterDevicesDevices
C#
public SequencerMasterTrackFilterDevicesDevices Devices { get; set; }
Visual C++
public:
property SequencerMasterTrackFilterDevicesDevices^ Devices {
    SequencerMasterTrackFilterDevicesDevices^ get ();
    void set (SequencerMasterTrackFilterDevicesDevices^ value);
}
JavaScript
function get_devices();
function set_devices(value);

Remarks

See Also

SequencerMasterTrackFilterDevices Class


SequencerMasterTrackFilterDevicesDevices Class

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerMasterTrackFilterDevicesDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerMasterTrackFilterDevicesDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerMasterTrackFilterDevicesDevices
JavaScript
NRenoiseTools.SequencerMasterTrackFilterDevicesDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerMasterTrackFilterDevicesDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerMasterTrackFilterDevicesDevices

See Also

SequencerMasterTrackFilterDevicesDevices Members


SequencerMasterTrackFilterDevicesDevices Members

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices Members
SequencerMasterTrackFilterDevicesDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerMasterTrackFilterDevicesDevices type exposes the following members.

Constructors

Name | Description
SequencerMasterTrackFilterDevicesDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SequencerMasterTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerMasterTrackFilterDevicesDevices Class


SequencerMasterTrackFilterDevicesDevices Constructor

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices Constructor
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerMasterTrackFilterDevicesDevices()
Visual C++
public:
SequencerMasterTrackFilterDevicesDevices()
JavaScript
NRenoiseTools.SequencerMasterTrackFilterDevicesDevices = function();

See Also

SequencerMasterTrackFilterDevicesDevices Class


SequencerMasterTrackFilterDevicesDevices Methods

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices Methods
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerMasterTrackFilterDevicesDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerMasterTrackFilterDevicesDevices Class


SequencerMasterTrackFilterDevicesDevices Properties

[image] [image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices Properties
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerMasterTrackFilterDevicesDevices type exposes the following members.

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SequencerMasterTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerMasterTrackFilterDevicesDevices Class


AudioPluginDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.AudioPluginDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AudioPluginDevice As AudioPluginDevice()
C#
public AudioPluginDevice[] AudioPluginDevice { get; set; }
Visual C++
public:
property array<AudioPluginDevice^>^ AudioPluginDevice {
    array<AudioPluginDevice^>^ get ();
    void set (array<AudioPluginDevice^>^ value);
}
JavaScript
function get_audioPluginDevice();
function set_audioPluginDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


BusCompressorDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.BusCompressorDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BusCompressorDevice As BusCompressorDevice()
C#
public BusCompressorDevice[] BusCompressorDevice { get; set; }
Visual C++
public:
property array<BusCompressorDevice^>^ BusCompressorDevice {
    array<BusCompressorDevice^>^ get ();
    void set (array<BusCompressorDevice^>^ value);
}
JavaScript
function get_busCompressorDevice();
function set_busCompressorDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


ChorusDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.ChorusDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ChorusDevice As ChorusDevice()
C#
public ChorusDevice[] ChorusDevice { get; set; }
Visual C++
public:
property array<ChorusDevice^>^ ChorusDevice {
    array<ChorusDevice^>^ get ();
    void set (array<ChorusDevice^>^ value);
}
JavaScript
function get_chorusDevice();
function set_chorusDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


CompressorDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.CompressorDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressorDevice As CompressorDevice()
C#
public CompressorDevice[] CompressorDevice { get; set; }
Visual C++
public:
property array<CompressorDevice^>^ CompressorDevice {
    array<CompressorDevice^>^ get ();
    void set (array<CompressorDevice^>^ value);
}
JavaScript
function get_compressorDevice();
function set_compressorDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


DcOffsetDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.DcOffsetDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DcOffsetDevice As DcOffsetDevice()
C#
public DcOffsetDevice[] DcOffsetDevice { get; set; }
Visual C++
public:
property array<DcOffsetDevice^>^ DcOffsetDevice {
    array<DcOffsetDevice^>^ get ();
    void set (array<DcOffsetDevice^>^ value);
}
JavaScript
function get_dcOffsetDevice();
function set_dcOffsetDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


DelayDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.DelayDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayDevice As DelayDevice()
C#
public DelayDevice[] DelayDevice { get; set; }
Visual C++
public:
property array<DelayDevice^>^ DelayDevice {
    array<DelayDevice^>^ get ();
    void set (array<DelayDevice^>^ value);
}
JavaScript
function get_delayDevice();
function set_delayDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Distortion2Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Distortion2Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Distortion2Device As Distortion2DeviceDistortionDevice()
C#
public Distortion2DeviceDistortionDevice[] Distortion2Device { get; set; }
Visual C++
public:
property array<Distortion2DeviceDistortionDevice^>^ Distortion2Device {
    array<Distortion2DeviceDistortionDevice^>^ get ();
    void set (array<Distortion2DeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortion2Device();
function set_distortion2Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


DistortionDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.DistortionDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DistortionDevice As DistortionDeviceDistortionDevice()
C#
public DistortionDeviceDistortionDevice[] DistortionDevice { get; set; }
Visual C++
public:
property array<DistortionDeviceDistortionDevice^>^ DistortionDevice {
    array<DistortionDeviceDistortionDevice^>^ get ();
    void set (array<DistortionDeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortionDevice();
function set_distortionDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Eq10Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Eq10Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq10Device As Eq10DeviceEqDevice()
C#
public Eq10DeviceEqDevice[] Eq10Device { get; set; }
Visual C++
public:
property array<Eq10DeviceEqDevice^>^ Eq10Device {
    array<Eq10DeviceEqDevice^>^ get ();
    void set (array<Eq10DeviceEqDevice^>^ value);
}
JavaScript
function get_eq10Device();
function set_eq10Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Eq5Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Eq5Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq5Device As Eq5DeviceEqDevice()
C#
public Eq5DeviceEqDevice[] Eq5Device { get; set; }
Visual C++
public:
property array<Eq5DeviceEqDevice^>^ Eq5Device {
    array<Eq5DeviceEqDevice^>^ get ();
    void set (array<Eq5DeviceEqDevice^>^ value);
}
JavaScript
function get_eq5Device();
function set_eq5Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Filter1Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Filter1Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter1Device As Filter1DeviceFilterDevice()
C#
public Filter1DeviceFilterDevice[] Filter1Device { get; set; }
Visual C++
public:
property array<Filter1DeviceFilterDevice^>^ Filter1Device {
    array<Filter1DeviceFilterDevice^>^ get ();
    void set (array<Filter1DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter1Device();
function set_filter1Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Filter2Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Filter2Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter2Device As Filter2DeviceFilterDevice()
C#
public Filter2DeviceFilterDevice[] Filter2Device { get; set; }
Visual C++
public:
property array<Filter2DeviceFilterDevice^>^ Filter2Device {
    array<Filter2DeviceFilterDevice^>^ get ();
    void set (array<Filter2DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter2Device();
function set_filter2Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Filter3Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Filter3Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter3Device As Filter3DeviceFilterDevice()
C#
public Filter3DeviceFilterDevice[] Filter3Device { get; set; }
Visual C++
public:
property array<Filter3DeviceFilterDevice^>^ Filter3Device {
    array<Filter3DeviceFilterDevice^>^ get ();
    void set (array<Filter3DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter3Device();
function set_filter3Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


FilterDistortionDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.FilterDistortionDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDistortionDevice As FilterDistortionDevice()
C#
public FilterDistortionDevice[] FilterDistortionDevice { get; set; }
Visual C++
public:
property array<FilterDistortionDevice^>^ FilterDistortionDevice {
    array<FilterDistortionDevice^>^ get ();
    void set (array<FilterDistortionDevice^>^ value);
}
JavaScript
function get_filterDistortionDevice();
function set_filterDistortionDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


FlangerDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.FlangerDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FlangerDevice As FlangerDevice()
C#
public FlangerDevice[] FlangerDevice { get; set; }
Visual C++
public:
property array<FlangerDevice^>^ FlangerDevice {
    array<FlangerDevice^>^ get ();
    void set (array<FlangerDevice^>^ value);
}
JavaScript
function get_flangerDevice();
function set_flangerDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


GainerDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.GainerDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GainerDevice As GainerDevice()
C#
public GainerDevice[] GainerDevice { get; set; }
Visual C++
public:
property array<GainerDevice^>^ GainerDevice {
    array<GainerDevice^>^ get ();
    void set (array<GainerDevice^>^ value);
}
JavaScript
function get_gainerDevice();
function set_gainerDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Gate2Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Gate2Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gate2Device As Gate2DeviceGateDevice()
C#
public Gate2DeviceGateDevice[] Gate2Device { get; set; }
Visual C++
public:
property array<Gate2DeviceGateDevice^>^ Gate2Device {
    array<Gate2DeviceGateDevice^>^ get ();
    void set (array<Gate2DeviceGateDevice^>^ value);
}
JavaScript
function get_gate2Device();
function set_gate2Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


GateDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.GateDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateDevice As GateDeviceGateDevice()
C#
public GateDeviceGateDevice[] GateDevice { get; set; }
Visual C++
public:
property array<GateDeviceGateDevice^>^ GateDevice {
    array<GateDeviceGateDevice^>^ get ();
    void set (array<GateDeviceGateDevice^>^ value);
}
JavaScript
function get_gateDevice();
function set_gateDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


InstrumentAutomationDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.InstrumentAutomationDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InstrumentAutomationDevice As InstrumentAutomationDevice()
C#
public InstrumentAutomationDevice[] InstrumentAutomationDevice { get; set; }
Visual C++
public:
property array<InstrumentAutomationDevice^>^ InstrumentAutomationDevice {
    array<InstrumentAutomationDevice^>^ get ();
    void set (array<InstrumentAutomationDevice^>^ value);
}
JavaScript
function get_instrumentAutomationDevice();
function set_instrumentAutomationDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


LfoDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.LfoDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDevice As LfoDevice()
C#
public LfoDevice[] LfoDevice { get; set; }
Visual C++
public:
property array<LfoDevice^>^ LfoDevice {
    array<LfoDevice^>^ get ();
    void set (array<LfoDevice^>^ value);
}
JavaScript
function get_lfoDevice();
function set_lfoDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Lofi2Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Lofi2Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lofi2Device As Lofi2DeviceLofiDevice()
C#
public Lofi2DeviceLofiDevice[] Lofi2Device { get; set; }
Visual C++
public:
property array<Lofi2DeviceLofiDevice^>^ Lofi2Device {
    array<Lofi2DeviceLofiDevice^>^ get ();
    void set (array<Lofi2DeviceLofiDevice^>^ value);
}
JavaScript
function get_lofi2Device();
function set_lofi2Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


LofiDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.LofiDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LofiDevice As LofiDeviceLofiDevice()
C#
public LofiDeviceLofiDevice[] LofiDevice { get; set; }
Visual C++
public:
property array<LofiDeviceLofiDevice^>^ LofiDevice {
    array<LofiDeviceLofiDevice^>^ get ();
    void set (array<LofiDeviceLofiDevice^>^ value);
}
JavaScript
function get_lofiDevice();
function set_lofiDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


MaximizerDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.MaximizerDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximizerDevice As MaximizerDevice()
C#
public MaximizerDevice[] MaximizerDevice { get; set; }
Visual C++
public:
property array<MaximizerDevice^>^ MaximizerDevice {
    array<MaximizerDevice^>^ get ();
    void set (array<MaximizerDevice^>^ value);
}
JavaScript
function get_maximizerDevice();
function set_maximizerDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


MidiCCDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.MidiCCDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiCCDevice As MidiCCDevice()
C#
public MidiCCDevice[] MidiCCDevice { get; set; }
Visual C++
public:
property array<MidiCCDevice^>^ MidiCCDevice {
    array<MidiCCDevice^>^ get ();
    void set (array<MidiCCDevice^>^ value);
}
JavaScript
function get_midiCCDevice();
function set_midiCCDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


MixerEqDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.MixerEqDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MixerEqDevice As MixerEqDevice()
C#
public MixerEqDevice[] MixerEqDevice { get; set; }
Visual C++
public:
property array<MixerEqDevice^>^ MixerEqDevice {
    array<MixerEqDevice^>^ get ();
    void set (array<MixerEqDevice^>^ value);
}
JavaScript
function get_mixerEqDevice();
function set_mixerEqDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


PdcTestDelayDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.PdcTestDelayDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PdcTestDelayDevice As PdcTestDelayDevice()
C#
public PdcTestDelayDevice[] PdcTestDelayDevice { get; set; }
Visual C++
public:
property array<PdcTestDelayDevice^>^ PdcTestDelayDevice {
    array<PdcTestDelayDevice^>^ get ();
    void set (array<PdcTestDelayDevice^>^ value);
}
JavaScript
function get_pdcTestDelayDevice();
function set_pdcTestDelayDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


PhaserDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.PhaserDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PhaserDevice As PhaserDevice()
C#
public PhaserDevice[] PhaserDevice { get; set; }
Visual C++
public:
property array<PhaserDevice^>^ PhaserDevice {
    array<PhaserDevice^>^ get ();
    void set (array<PhaserDevice^>^ value);
}
JavaScript
function get_phaserDevice();
function set_phaserDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Reverb2Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Reverb2Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb2Device As Reverb2DeviceReverbDevice()
C#
public Reverb2DeviceReverbDevice[] Reverb2Device { get; set; }
Visual C++
public:
property array<Reverb2DeviceReverbDevice^>^ Reverb2Device {
    array<Reverb2DeviceReverbDevice^>^ get ();
    void set (array<Reverb2DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb2Device();
function set_reverb2Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


Reverb3Device Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.Reverb3Device Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb3Device As Reverb3DeviceReverbDevice()
C#
public Reverb3DeviceReverbDevice[] Reverb3Device { get; set; }
Visual C++
public:
property array<Reverb3DeviceReverbDevice^>^ Reverb3Device {
    array<Reverb3DeviceReverbDevice^>^ get ();
    void set (array<Reverb3DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb3Device();
function set_reverb3Device(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


ReverbDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.ReverbDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbDevice As ReverbDeviceReverbDevice()
C#
public ReverbDeviceReverbDevice[] ReverbDevice { get; set; }
Visual C++
public:
property array<ReverbDeviceReverbDevice^>^ ReverbDevice {
    array<ReverbDeviceReverbDevice^>^ get ();
    void set (array<ReverbDeviceReverbDevice^>^ value);
}
JavaScript
function get_reverbDevice();
function set_reverbDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


RingModDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.RingModDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RingModDevice As RingModDevice()
C#
public RingModDevice[] RingModDevice { get; set; }
Visual C++
public:
property array<RingModDevice^>^ RingModDevice {
    array<RingModDevice^>^ get ();
    void set (array<RingModDevice^>^ value);
}
JavaScript
function get_ringModDevice();
function set_ringModDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


SequencerMasterTrackDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.SequencerMasterTrackDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerMasterTrackDevice As SequencerMasterTrackDevice()
C#
public SequencerMasterTrackDevice[] SequencerMasterTrackDevice { get; set; }
Visual C++
public:
property array<SequencerMasterTrackDevice^>^ SequencerMasterTrackDevice {
    array<SequencerMasterTrackDevice^>^ get ();
    void set (array<SequencerMasterTrackDevice^>^ value);
}
JavaScript
function get_sequencerMasterTrackDevice();
function set_sequencerMasterTrackDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


ShaperDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.ShaperDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShaperDevice As ShaperDevice()
C#
public ShaperDevice[] ShaperDevice { get; set; }
Visual C++
public:
property array<ShaperDevice^>^ ShaperDevice {
    array<ShaperDevice^>^ get ();
    void set (array<ShaperDevice^>^ value);
}
JavaScript
function get_shaperDevice();
function set_shaperDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


StereoExpanderDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.StereoExpanderDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoExpanderDevice As StereoExpanderDevice()
C#
public StereoExpanderDevice[] StereoExpanderDevice { get; set; }
Visual C++
public:
property array<StereoExpanderDevice^>^ StereoExpanderDevice {
    array<StereoExpanderDevice^>^ get ();
    void set (array<StereoExpanderDevice^>^ value);
}
JavaScript
function get_stereoExpanderDevice();
function set_stereoExpanderDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


VelocityDevice Property

[image]

.NET Framework Class Library
SequencerMasterTrackFilterDevicesDevices..::.VelocityDevice Property
SequencerMasterTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityDevice As VelocityDevice()
C#
public VelocityDevice[] VelocityDevice { get; set; }
Visual C++
public:
property array<VelocityDevice^>^ VelocityDevice {
    array<VelocityDevice^>^ get ();
    void set (array<VelocityDevice^>^ value);
}
JavaScript
function get_velocityDevice();
function set_velocityDevice(value);

Remarks

See Also

SequencerMasterTrackFilterDevicesDevices Class


SequencerMasterTrackNoteColumnState Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackNoteColumnState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackNoteColumnState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackNoteColumnState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackNoteColumnState
JavaScript
NRenoiseTools.SequencerMasterTrackNoteColumnState = function();
NRenoiseTools.SequencerMasterTrackNoteColumnState.createEnum('NRenoiseTools.SequencerMasterTrackNoteColumnState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerMasterTrackState Enumeration

[image]

.NET Framework Class Library
SequencerMasterTrackState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerMasterTrackState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerMasterTrackState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerMasterTrackState
JavaScript
NRenoiseTools.SequencerMasterTrackState = function();
NRenoiseTools.SequencerMasterTrackState.createEnum('NRenoiseTools.SequencerMasterTrackState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrack Class

[image]

.NET Framework Class Library
SequencerSendTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrack
JavaScript
NRenoiseTools.SequencerSendTrack = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrack

See Also

SequencerSendTrack Members


SequencerSendTrack Members

[image] [image]

.NET Framework Class Library
SequencerSendTrack Members
SequencerSendTrack Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrack type exposes the following members.

Constructors

Name | Description
SequencerSendTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerSendTrack Class


SequencerSendTrack Constructor

[image]

.NET Framework Class Library
SequencerSendTrack Constructor
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrack()
Visual C++
public:
SequencerSendTrack()
JavaScript
NRenoiseTools.SequencerSendTrack = function();

See Also

SequencerSendTrack Class


SequencerSendTrack Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrack Methods
SequencerSendTrack Class See Also Send Feedback

The SequencerSendTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrack Class


SequencerSendTrack Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrack Properties
SequencerSendTrack Class See Also Send Feedback

The SequencerSendTrack type exposes the following members.

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerSendTrack Class


DelayColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.DelayColumnIsVisible Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayColumnIsVisible As Boolean
C#
public bool DelayColumnIsVisible { get; set; }
Visual C++
public:
property bool DelayColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_delayColumnIsVisible();
function set_delayColumnIsVisible(value);

Remarks

See Also

SequencerSendTrack Class


FilterDevices Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.FilterDevices Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDevices As SequencerSendTrackFilterDevices
C#
public SequencerSendTrackFilterDevices FilterDevices { get; set; }
Visual C++
public:
property SequencerSendTrackFilterDevices^ FilterDevices {
    SequencerSendTrackFilterDevices^ get ();
    void set (SequencerSendTrackFilterDevices^ value);
}
JavaScript
function get_filterDevices();
function set_filterDevices(value);

Remarks

See Also

SequencerSendTrack Class


Name Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.Name Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

SequencerSendTrack Class


NoteColumnStates Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.NoteColumnStates Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NoteColumnStates As SequencerSendTrackNoteColumnState()
C#
public SequencerSendTrackNoteColumnState[] NoteColumnStates { get; set; }
Visual C++
public:
property array<SequencerSendTrackNoteColumnState>^ NoteColumnStates {
    array<SequencerSendTrackNoteColumnState>^ get ();
    void set (array<SequencerSendTrackNoteColumnState>^ value);
}
JavaScript
function get_noteColumnStates();
function set_noteColumnStates(value);

Remarks

See Also

SequencerSendTrack Class


NumberOfVisibleEffectColumns Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.NumberOfVisibleEffectColumns Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleEffectColumns As Integer
C#
public int NumberOfVisibleEffectColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleEffectColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleEffectColumns();
function set_numberOfVisibleEffectColumns(value);

Remarks

See Also

SequencerSendTrack Class


NumberOfVisibleNoteColumns Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.NumberOfVisibleNoteColumns Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleNoteColumns As Integer
C#
public int NumberOfVisibleNoteColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleNoteColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleNoteColumns();
function set_numberOfVisibleNoteColumns(value);

Remarks

See Also

SequencerSendTrack Class


PanningColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.PanningColumnIsVisible Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PanningColumnIsVisible As Boolean
C#
public bool PanningColumnIsVisible { get; set; }
Visual C++
public:
property bool PanningColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_panningColumnIsVisible();
function set_panningColumnIsVisible(value);

Remarks

See Also

SequencerSendTrack Class


State Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.State Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property State As SequencerSendTrackState
C#
public SequencerSendTrackState State { get; set; }
Visual C++
public:
property SequencerSendTrackState State {
    SequencerSendTrackState get ();
    void set (SequencerSendTrackState value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

SequencerSendTrack Class


TrackDelay Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.TrackDelay Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackDelay As Single
C#
public float TrackDelay { get; set; }
Visual C++
public:
property float TrackDelay {
    float get ();
    void set (float value);
}
JavaScript
function get_trackDelay();
function set_trackDelay(value);

Remarks

See Also

SequencerSendTrack Class


TrackRouting Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.TrackRouting Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackRouting As Integer
C#
public int TrackRouting { get; set; }
Visual C++
public:
property int TrackRouting {
    int get ();
    void set (int value);
}
JavaScript
function get_trackRouting();
function set_trackRouting(value);

Remarks

See Also

SequencerSendTrack Class


type Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.type Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerSendTrack Class


VolumeColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerSendTrack..::.VolumeColumnIsVisible Property
SequencerSendTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VolumeColumnIsVisible As Boolean
C#
public bool VolumeColumnIsVisible { get; set; }
Visual C++
public:
property bool VolumeColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_volumeColumnIsVisible();
function set_volumeColumnIsVisible(value);

Remarks

See Also

SequencerSendTrack Class


SequencerSendTrackDevice Class

[image]

.NET Framework Class Library
SequencerSendTrackDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevice
JavaScript
NRenoiseTools.SequencerSendTrackDevice = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevice

See Also

SequencerSendTrackDevice Members


SequencerSendTrackDevice Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevice Members
SequencerSendTrackDevice Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevice type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Surround |
type |
Volume |

See Also

SequencerSendTrackDevice Class


SequencerSendTrackDevice Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevice Constructor
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevice()
Visual C++
public:
SequencerSendTrackDevice()
JavaScript
NRenoiseTools.SequencerSendTrackDevice = function();

See Also

SequencerSendTrackDevice Class


SequencerSendTrackDevice Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevice Methods
SequencerSendTrackDevice Class See Also Send Feedback

The SequencerSendTrackDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevice Class


SequencerSendTrackDevice Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevice Properties
SequencerSendTrackDevice Class See Also Send Feedback

The SequencerSendTrackDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Surround |
type |
Volume |

See Also

SequencerSendTrackDevice Class


IsActive Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.IsActive Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

SequencerSendTrackDevice Class


IsSelected Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.IsSelected Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

SequencerSendTrackDevice Class


Panning Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.Panning Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerSendTrackDevicePanning
C#
public SequencerSendTrackDevicePanning Panning { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePanning^ Panning {
    SequencerSendTrackDevicePanning^ get ();
    void set (SequencerSendTrackDevicePanning^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerSendTrackDevice Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.PostPanning Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerSendTrackDevicePostPanning
C#
public SequencerSendTrackDevicePostPanning PostPanning { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostPanning^ PostPanning {
    SequencerSendTrackDevicePostPanning^ get ();
    void set (SequencerSendTrackDevicePostPanning^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerSendTrackDevice Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.PostVolume Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerSendTrackDevicePostVolume
C#
public SequencerSendTrackDevicePostVolume PostVolume { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostVolume^ PostVolume {
    SequencerSendTrackDevicePostVolume^ get ();
    void set (SequencerSendTrackDevicePostVolume^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerSendTrackDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.RunTimePresetA Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As SequencerSendTrackDeviceRunTimePreset
C#
public SequencerSendTrackDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceRunTimePreset^ RunTimePresetA {
    SequencerSendTrackDeviceRunTimePreset^ get ();
    void set (SequencerSendTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

SequencerSendTrackDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.RunTimePresetB Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As SequencerSendTrackDeviceRunTimePreset
C#
public SequencerSendTrackDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceRunTimePreset^ RunTimePresetB {
    SequencerSendTrackDeviceRunTimePreset^ get ();
    void set (SequencerSendTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

SequencerSendTrackDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.SelectedPresetIsModified Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

SequencerSendTrackDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.SelectedPresetName Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

SequencerSendTrackDevice Class


Surround Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.Surround Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerSendTrackDeviceSurround
C#
public SequencerSendTrackDeviceSurround Surround { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceSurround^ Surround {
    SequencerSendTrackDeviceSurround^ get ();
    void set (SequencerSendTrackDeviceSurround^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerSendTrackDevice Class


type Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.type Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerSendTrackDevice Class


Volume Property

[image]

.NET Framework Class Library
SequencerSendTrackDevice..::.Volume Property
SequencerSendTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerSendTrackDeviceVolume
C#
public SequencerSendTrackDeviceVolume Volume { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceVolume^ Volume {
    SequencerSendTrackDeviceVolume^ get ();
    void set (SequencerSendTrackDeviceVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerSendTrackDevice Class


SequencerSendTrackDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceDeviceSlotRunTimePreset

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Members


SequencerSendTrackDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset Members
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Panning |
PostPanning |
PostVolume |
Surround |
type |
Volume |

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


SequencerSendTrackDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset Constructor
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceDeviceSlotRunTimePreset()
Visual C++
public:
SequencerSendTrackDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceDeviceSlotRunTimePreset = function();

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


SequencerSendTrackDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset Methods
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


SequencerSendTrackDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset Properties
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Panning |
PostPanning |
PostVolume |
Surround |
type |
Volume |

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


Panning Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.Panning Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerSendTrackDevicePanningRunTimePreset
C#
public SequencerSendTrackDevicePanningRunTimePreset Panning { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePanningRunTimePreset^ Panning {
    SequencerSendTrackDevicePanningRunTimePreset^ get ();
    void set (SequencerSendTrackDevicePanningRunTimePreset^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.PostPanning Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerSendTrackDevicePostPanningRunTimePreset
C#
public SequencerSendTrackDevicePostPanningRunTimePreset PostPanning { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostPanningRunTimePreset^ PostPanning {
    SequencerSendTrackDevicePostPanningRunTimePreset^ get ();
    void set (SequencerSendTrackDevicePostPanningRunTimePreset^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.PostVolume Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerSendTrackDevicePostVolumeRunTimePreset
C#
public SequencerSendTrackDevicePostVolumeRunTimePreset PostVolume { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostVolumeRunTimePreset^ PostVolume {
    SequencerSendTrackDevicePostVolumeRunTimePreset^ get ();
    void set (SequencerSendTrackDevicePostVolumeRunTimePreset^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


Surround Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.Surround Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerSendTrackDeviceSurroundRunTimePreset
C#
public SequencerSendTrackDeviceSurroundRunTimePreset Surround { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceSurroundRunTimePreset^ Surround {
    SequencerSendTrackDeviceSurroundRunTimePreset^ get ();
    void set (SequencerSendTrackDeviceSurroundRunTimePreset^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.type Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


Volume Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceDeviceSlotRunTimePreset..::.Volume Property
SequencerSendTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerSendTrackDeviceVolumeRunTimePreset
C#
public SequencerSendTrackDeviceVolumeRunTimePreset Volume { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceVolumeRunTimePreset^ Volume {
    SequencerSendTrackDeviceVolumeRunTimePreset^ get ();
    void set (SequencerSendTrackDeviceVolumeRunTimePreset^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerSendTrackDeviceDeviceSlotRunTimePreset Class


SequencerSendTrackDevicePanning Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePanning
JavaScript
NRenoiseTools.SequencerSendTrackDevicePanning = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePanning

See Also

SequencerSendTrackDevicePanning Members


SequencerSendTrackDevicePanning Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanning Members
SequencerSendTrackDevicePanning Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePanning type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePanning Class


SequencerSendTrackDevicePanning Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanning Constructor
SequencerSendTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePanning()
Visual C++
public:
SequencerSendTrackDevicePanning()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePanning = function();

See Also

SequencerSendTrackDevicePanning Class


SequencerSendTrackDevicePanning Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanning Methods
SequencerSendTrackDevicePanning Class See Also Send Feedback

The SequencerSendTrackDevicePanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePanning Class


SequencerSendTrackDevicePanning Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanning Properties
SequencerSendTrackDevicePanning Class See Also Send Feedback

The SequencerSendTrackDevicePanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanning..::.MidiMappings Property
SequencerSendTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerSendTrackDevicePanning Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanning..::.Value Property
SequencerSendTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanning..::.Visualization Property
SequencerSendTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerSendTrackDevicePanningVisualization
C#
public SequencerSendTrackDevicePanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePanningVisualization Visualization {
    SequencerSendTrackDevicePanningVisualization get ();
    void set (SequencerSendTrackDevicePanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerSendTrackDevicePanning Class


SequencerSendTrackDevicePanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePanningRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDevicePanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePanningRunTimePreset

See Also

SequencerSendTrackDevicePanningRunTimePreset Members


SequencerSendTrackDevicePanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset Members
SequencerSendTrackDevicePanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePanningRunTimePreset Class


SequencerSendTrackDevicePanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset Constructor
SequencerSendTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePanningRunTimePreset()
Visual C++
public:
SequencerSendTrackDevicePanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePanningRunTimePreset = function();

See Also

SequencerSendTrackDevicePanningRunTimePreset Class


SequencerSendTrackDevicePanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset Methods
SequencerSendTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePanningRunTimePreset Class


SequencerSendTrackDevicePanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset Properties
SequencerSendTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanningRunTimePreset..::.Value Property
SequencerSendTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePanningRunTimePreset Class


SequencerSendTrackDevicePanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackDevicePanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackDevicePanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackDevicePanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackDevicePanningVisualization
JavaScript
NRenoiseTools.SequencerSendTrackDevicePanningVisualization = function();
NRenoiseTools.SequencerSendTrackDevicePanningVisualization.createEnum('NRenoiseTools.SequencerSendTrackDevicePanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackDevicePostPanning Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePostPanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePostPanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePostPanning
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostPanning = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePostPanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePostPanning

See Also

SequencerSendTrackDevicePostPanning Members


SequencerSendTrackDevicePostPanning Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning Members
SequencerSendTrackDevicePostPanning Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePostPanning type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePostPanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePostPanning Class


SequencerSendTrackDevicePostPanning Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning Constructor
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePostPanning()
Visual C++
public:
SequencerSendTrackDevicePostPanning()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostPanning = function();

See Also

SequencerSendTrackDevicePostPanning Class


SequencerSendTrackDevicePostPanning Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning Methods
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

The SequencerSendTrackDevicePostPanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePostPanning Class


SequencerSendTrackDevicePostPanning Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning Properties
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

The SequencerSendTrackDevicePostPanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePostPanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning..::.MidiMappings Property
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerSendTrackDevicePostPanning Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning..::.Value Property
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePostPanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanning..::.Visualization Property
SequencerSendTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerSendTrackDevicePostPanningVisualization
C#
public SequencerSendTrackDevicePostPanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostPanningVisualization Visualization {
    SequencerSendTrackDevicePostPanningVisualization get ();
    void set (SequencerSendTrackDevicePostPanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerSendTrackDevicePostPanning Class


SequencerSendTrackDevicePostPanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePostPanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePostPanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePostPanningRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostPanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePostPanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePostPanningRunTimePreset

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Members


SequencerSendTrackDevicePostPanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset Members
SequencerSendTrackDevicePostPanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePostPanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePostPanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Class


SequencerSendTrackDevicePostPanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset Constructor
SequencerSendTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePostPanningRunTimePreset()
Visual C++
public:
SequencerSendTrackDevicePostPanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostPanningRunTimePreset = function();

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Class


SequencerSendTrackDevicePostPanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset Methods
SequencerSendTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePostPanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Class


SequencerSendTrackDevicePostPanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset Properties
SequencerSendTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePostPanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningRunTimePreset..::.Value Property
SequencerSendTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePostPanningRunTimePreset Class


SequencerSendTrackDevicePostPanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostPanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackDevicePostPanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackDevicePostPanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackDevicePostPanningVisualization
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostPanningVisualization = function();
NRenoiseTools.SequencerSendTrackDevicePostPanningVisualization.createEnum('NRenoiseTools.SequencerSendTrackDevicePostPanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackDevicePostVolume Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePostVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePostVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePostVolume
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePostVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePostVolume

See Also

SequencerSendTrackDevicePostVolume Members


SequencerSendTrackDevicePostVolume Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume Members
SequencerSendTrackDevicePostVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePostVolume type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePostVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePostVolume Class


SequencerSendTrackDevicePostVolume Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume Constructor
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePostVolume()
Visual C++
public:
SequencerSendTrackDevicePostVolume()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostVolume = function();

See Also

SequencerSendTrackDevicePostVolume Class


SequencerSendTrackDevicePostVolume Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume Methods
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

The SequencerSendTrackDevicePostVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePostVolume Class


SequencerSendTrackDevicePostVolume Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume Properties
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

The SequencerSendTrackDevicePostVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDevicePostVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume..::.MidiMappings Property
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerSendTrackDevicePostVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume..::.Value Property
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePostVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolume..::.Visualization Property
SequencerSendTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerSendTrackDevicePostVolumeVisualization
C#
public SequencerSendTrackDevicePostVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerSendTrackDevicePostVolumeVisualization Visualization {
    SequencerSendTrackDevicePostVolumeVisualization get ();
    void set (SequencerSendTrackDevicePostVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerSendTrackDevicePostVolume Class


SequencerSendTrackDevicePostVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDevicePostVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDevicePostVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDevicePostVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDevicePostVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDevicePostVolumeRunTimePreset

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Members


SequencerSendTrackDevicePostVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset Members
SequencerSendTrackDevicePostVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDevicePostVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDevicePostVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Class


SequencerSendTrackDevicePostVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset Constructor
SequencerSendTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDevicePostVolumeRunTimePreset()
Visual C++
public:
SequencerSendTrackDevicePostVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostVolumeRunTimePreset = function();

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Class


SequencerSendTrackDevicePostVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset Methods
SequencerSendTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePostVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Class


SequencerSendTrackDevicePostVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset Properties
SequencerSendTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDevicePostVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeRunTimePreset..::.Value Property
SequencerSendTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDevicePostVolumeRunTimePreset Class


SequencerSendTrackDevicePostVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackDevicePostVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackDevicePostVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackDevicePostVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackDevicePostVolumeVisualization
JavaScript
NRenoiseTools.SequencerSendTrackDevicePostVolumeVisualization = function();
NRenoiseTools.SequencerSendTrackDevicePostVolumeVisualization.createEnum('NRenoiseTools.SequencerSendTrackDevicePostVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackDeviceRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceRunTimePreset

See Also

SequencerSendTrackDeviceRunTimePreset Members


SequencerSendTrackDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset Members
SequencerSendTrackDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerSendTrackDeviceRunTimePreset Class


SequencerSendTrackDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset Constructor
SequencerSendTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceRunTimePreset()
Visual C++
public:
SequencerSendTrackDeviceRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceRunTimePreset = function();

See Also

SequencerSendTrackDeviceRunTimePreset Class


SequencerSendTrackDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset Methods
SequencerSendTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceRunTimePreset Class


SequencerSendTrackDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset Properties
SequencerSendTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerSendTrackDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset..::.DeviceSlot Property
SequencerSendTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As SequencerSendTrackDeviceDeviceSlotRunTimePreset
C#
public SequencerSendTrackDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    SequencerSendTrackDeviceDeviceSlotRunTimePreset^ get ();
    void set (SequencerSendTrackDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

SequencerSendTrackDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceRunTimePreset..::.type Property
SequencerSendTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerSendTrackDeviceRunTimePreset Class


SequencerSendTrackDeviceSurround Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceSurround
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceSurround
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceSurround
JavaScript
NRenoiseTools.SequencerSendTrackDeviceSurround = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceSurround');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceSurround

See Also

SequencerSendTrackDeviceSurround Members


SequencerSendTrackDeviceSurround Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround Members
SequencerSendTrackDeviceSurround Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceSurround type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceSurround |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDeviceSurround Class


SequencerSendTrackDeviceSurround Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround Constructor
SequencerSendTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceSurround()
Visual C++
public:
SequencerSendTrackDeviceSurround()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceSurround = function();

See Also

SequencerSendTrackDeviceSurround Class


SequencerSendTrackDeviceSurround Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround Methods
SequencerSendTrackDeviceSurround Class See Also Send Feedback

The SequencerSendTrackDeviceSurround type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceSurround Class


SequencerSendTrackDeviceSurround Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround Properties
SequencerSendTrackDeviceSurround Class See Also Send Feedback

The SequencerSendTrackDeviceSurround type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDeviceSurround Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround..::.MidiMappings Property
SequencerSendTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerSendTrackDeviceSurround Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround..::.Value Property
SequencerSendTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDeviceSurround Class


Visualization Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurround..::.Visualization Property
SequencerSendTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerSendTrackDeviceSurroundVisualization
C#
public SequencerSendTrackDeviceSurroundVisualization Visualization { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceSurroundVisualization Visualization {
    SequencerSendTrackDeviceSurroundVisualization get ();
    void set (SequencerSendTrackDeviceSurroundVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerSendTrackDeviceSurround Class


SequencerSendTrackDeviceSurroundRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceSurroundRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceSurroundRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceSurroundRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDeviceSurroundRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceSurroundRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceSurroundRunTimePreset

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Members


SequencerSendTrackDeviceSurroundRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset Members
SequencerSendTrackDeviceSurroundRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceSurroundRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceSurroundRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Class


SequencerSendTrackDeviceSurroundRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset Constructor
SequencerSendTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceSurroundRunTimePreset()
Visual C++
public:
SequencerSendTrackDeviceSurroundRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceSurroundRunTimePreset = function();

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Class


SequencerSendTrackDeviceSurroundRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset Methods
SequencerSendTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceSurroundRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Class


SequencerSendTrackDeviceSurroundRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset Properties
SequencerSendTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceSurroundRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundRunTimePreset..::.Value Property
SequencerSendTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDeviceSurroundRunTimePreset Class


SequencerSendTrackDeviceSurroundVisualization Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackDeviceSurroundVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackDeviceSurroundVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackDeviceSurroundVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackDeviceSurroundVisualization
JavaScript
NRenoiseTools.SequencerSendTrackDeviceSurroundVisualization = function();
NRenoiseTools.SequencerSendTrackDeviceSurroundVisualization.createEnum('NRenoiseTools.SequencerSendTrackDeviceSurroundVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackDeviceVolume Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceVolume
JavaScript
NRenoiseTools.SequencerSendTrackDeviceVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceVolume

See Also

SequencerSendTrackDeviceVolume Members


SequencerSendTrackDeviceVolume Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume Members
SequencerSendTrackDeviceVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceVolume type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDeviceVolume Class


SequencerSendTrackDeviceVolume Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume Constructor
SequencerSendTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceVolume()
Visual C++
public:
SequencerSendTrackDeviceVolume()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceVolume = function();

See Also

SequencerSendTrackDeviceVolume Class


SequencerSendTrackDeviceVolume Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume Methods
SequencerSendTrackDeviceVolume Class See Also Send Feedback

The SequencerSendTrackDeviceVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceVolume Class


SequencerSendTrackDeviceVolume Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume Properties
SequencerSendTrackDeviceVolume Class See Also Send Feedback

The SequencerSendTrackDeviceVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerSendTrackDeviceVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume..::.MidiMappings Property
SequencerSendTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerSendTrackDeviceVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume..::.Value Property
SequencerSendTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDeviceVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolume..::.Visualization Property
SequencerSendTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerSendTrackDeviceVolumeVisualization
C#
public SequencerSendTrackDeviceVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerSendTrackDeviceVolumeVisualization Visualization {
    SequencerSendTrackDeviceVolumeVisualization get ();
    void set (SequencerSendTrackDeviceVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerSendTrackDeviceVolume Class


SequencerSendTrackDeviceVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackDeviceVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackDeviceVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackDeviceVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerSendTrackDeviceVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackDeviceVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackDeviceVolumeRunTimePreset

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Members


SequencerSendTrackDeviceVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset Members
SequencerSendTrackDeviceVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackDeviceVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerSendTrackDeviceVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Class


SequencerSendTrackDeviceVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset Constructor
SequencerSendTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackDeviceVolumeRunTimePreset()
Visual C++
public:
SequencerSendTrackDeviceVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerSendTrackDeviceVolumeRunTimePreset = function();

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Class


SequencerSendTrackDeviceVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset Methods
SequencerSendTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Class


SequencerSendTrackDeviceVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset Properties
SequencerSendTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerSendTrackDeviceVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeRunTimePreset..::.Value Property
SequencerSendTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerSendTrackDeviceVolumeRunTimePreset Class


SequencerSendTrackDeviceVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackDeviceVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackDeviceVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackDeviceVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackDeviceVolumeVisualization
JavaScript
NRenoiseTools.SequencerSendTrackDeviceVolumeVisualization = function();
NRenoiseTools.SequencerSendTrackDeviceVolumeVisualization.createEnum('NRenoiseTools.SequencerSendTrackDeviceVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackFilterDevices Class

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackFilterDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackFilterDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackFilterDevices
JavaScript
NRenoiseTools.SequencerSendTrackFilterDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackFilterDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackFilterDevices

See Also

SequencerSendTrackFilterDevices Members


SequencerSendTrackFilterDevices Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevices Members
SequencerSendTrackFilterDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackFilterDevices type exposes the following members.

Constructors

Name | Description
SequencerSendTrackFilterDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Devices |

See Also

SequencerSendTrackFilterDevices Class


SequencerSendTrackFilterDevices Constructor

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevices Constructor
SequencerSendTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackFilterDevices()
Visual C++
public:
SequencerSendTrackFilterDevices()
JavaScript
NRenoiseTools.SequencerSendTrackFilterDevices = function();

See Also

SequencerSendTrackFilterDevices Class


SequencerSendTrackFilterDevices Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevices Methods
SequencerSendTrackFilterDevices Class See Also Send Feedback

The SequencerSendTrackFilterDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackFilterDevices Class


SequencerSendTrackFilterDevices Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevices Properties
SequencerSendTrackFilterDevices Class See Also Send Feedback

The SequencerSendTrackFilterDevices type exposes the following members.

Properties

Name | Description
Devices |

See Also

SequencerSendTrackFilterDevices Class


Devices Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevices..::.Devices Property
SequencerSendTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Devices As SequencerSendTrackFilterDevicesDevices
C#
public SequencerSendTrackFilterDevicesDevices Devices { get; set; }
Visual C++
public:
property SequencerSendTrackFilterDevicesDevices^ Devices {
    SequencerSendTrackFilterDevicesDevices^ get ();
    void set (SequencerSendTrackFilterDevicesDevices^ value);
}
JavaScript
function get_devices();
function set_devices(value);

Remarks

See Also

SequencerSendTrackFilterDevices Class


SequencerSendTrackFilterDevicesDevices Class

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerSendTrackFilterDevicesDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerSendTrackFilterDevicesDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerSendTrackFilterDevicesDevices
JavaScript
NRenoiseTools.SequencerSendTrackFilterDevicesDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerSendTrackFilterDevicesDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerSendTrackFilterDevicesDevices

See Also

SequencerSendTrackFilterDevicesDevices Members


SequencerSendTrackFilterDevicesDevices Members

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices Members
SequencerSendTrackFilterDevicesDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerSendTrackFilterDevicesDevices type exposes the following members.

Constructors

Name | Description
SequencerSendTrackFilterDevicesDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
SequencerSendTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerSendTrackFilterDevicesDevices Class


SequencerSendTrackFilterDevicesDevices Constructor

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices Constructor
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerSendTrackFilterDevicesDevices()
Visual C++
public:
SequencerSendTrackFilterDevicesDevices()
JavaScript
NRenoiseTools.SequencerSendTrackFilterDevicesDevices = function();

See Also

SequencerSendTrackFilterDevicesDevices Class


SequencerSendTrackFilterDevicesDevices Methods

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices Methods
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerSendTrackFilterDevicesDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerSendTrackFilterDevicesDevices Class


SequencerSendTrackFilterDevicesDevices Properties

[image] [image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices Properties
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerSendTrackFilterDevicesDevices type exposes the following members.

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
SequencerSendTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerSendTrackFilterDevicesDevices Class


AudioPluginDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.AudioPluginDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AudioPluginDevice As AudioPluginDevice()
C#
public AudioPluginDevice[] AudioPluginDevice { get; set; }
Visual C++
public:
property array<AudioPluginDevice^>^ AudioPluginDevice {
    array<AudioPluginDevice^>^ get ();
    void set (array<AudioPluginDevice^>^ value);
}
JavaScript
function get_audioPluginDevice();
function set_audioPluginDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


BusCompressorDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.BusCompressorDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BusCompressorDevice As BusCompressorDevice()
C#
public BusCompressorDevice[] BusCompressorDevice { get; set; }
Visual C++
public:
property array<BusCompressorDevice^>^ BusCompressorDevice {
    array<BusCompressorDevice^>^ get ();
    void set (array<BusCompressorDevice^>^ value);
}
JavaScript
function get_busCompressorDevice();
function set_busCompressorDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


ChorusDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.ChorusDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ChorusDevice As ChorusDevice()
C#
public ChorusDevice[] ChorusDevice { get; set; }
Visual C++
public:
property array<ChorusDevice^>^ ChorusDevice {
    array<ChorusDevice^>^ get ();
    void set (array<ChorusDevice^>^ value);
}
JavaScript
function get_chorusDevice();
function set_chorusDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


CompressorDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.CompressorDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressorDevice As CompressorDevice()
C#
public CompressorDevice[] CompressorDevice { get; set; }
Visual C++
public:
property array<CompressorDevice^>^ CompressorDevice {
    array<CompressorDevice^>^ get ();
    void set (array<CompressorDevice^>^ value);
}
JavaScript
function get_compressorDevice();
function set_compressorDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


DcOffsetDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.DcOffsetDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DcOffsetDevice As DcOffsetDevice()
C#
public DcOffsetDevice[] DcOffsetDevice { get; set; }
Visual C++
public:
property array<DcOffsetDevice^>^ DcOffsetDevice {
    array<DcOffsetDevice^>^ get ();
    void set (array<DcOffsetDevice^>^ value);
}
JavaScript
function get_dcOffsetDevice();
function set_dcOffsetDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


DelayDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.DelayDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayDevice As DelayDevice()
C#
public DelayDevice[] DelayDevice { get; set; }
Visual C++
public:
property array<DelayDevice^>^ DelayDevice {
    array<DelayDevice^>^ get ();
    void set (array<DelayDevice^>^ value);
}
JavaScript
function get_delayDevice();
function set_delayDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Distortion2Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Distortion2Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Distortion2Device As Distortion2DeviceDistortionDevice()
C#
public Distortion2DeviceDistortionDevice[] Distortion2Device { get; set; }
Visual C++
public:
property array<Distortion2DeviceDistortionDevice^>^ Distortion2Device {
    array<Distortion2DeviceDistortionDevice^>^ get ();
    void set (array<Distortion2DeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortion2Device();
function set_distortion2Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


DistortionDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.DistortionDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DistortionDevice As DistortionDeviceDistortionDevice()
C#
public DistortionDeviceDistortionDevice[] DistortionDevice { get; set; }
Visual C++
public:
property array<DistortionDeviceDistortionDevice^>^ DistortionDevice {
    array<DistortionDeviceDistortionDevice^>^ get ();
    void set (array<DistortionDeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortionDevice();
function set_distortionDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Eq10Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Eq10Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq10Device As Eq10DeviceEqDevice()
C#
public Eq10DeviceEqDevice[] Eq10Device { get; set; }
Visual C++
public:
property array<Eq10DeviceEqDevice^>^ Eq10Device {
    array<Eq10DeviceEqDevice^>^ get ();
    void set (array<Eq10DeviceEqDevice^>^ value);
}
JavaScript
function get_eq10Device();
function set_eq10Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Eq5Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Eq5Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq5Device As Eq5DeviceEqDevice()
C#
public Eq5DeviceEqDevice[] Eq5Device { get; set; }
Visual C++
public:
property array<Eq5DeviceEqDevice^>^ Eq5Device {
    array<Eq5DeviceEqDevice^>^ get ();
    void set (array<Eq5DeviceEqDevice^>^ value);
}
JavaScript
function get_eq5Device();
function set_eq5Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Filter1Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Filter1Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter1Device As Filter1DeviceFilterDevice()
C#
public Filter1DeviceFilterDevice[] Filter1Device { get; set; }
Visual C++
public:
property array<Filter1DeviceFilterDevice^>^ Filter1Device {
    array<Filter1DeviceFilterDevice^>^ get ();
    void set (array<Filter1DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter1Device();
function set_filter1Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Filter2Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Filter2Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter2Device As Filter2DeviceFilterDevice()
C#
public Filter2DeviceFilterDevice[] Filter2Device { get; set; }
Visual C++
public:
property array<Filter2DeviceFilterDevice^>^ Filter2Device {
    array<Filter2DeviceFilterDevice^>^ get ();
    void set (array<Filter2DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter2Device();
function set_filter2Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Filter3Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Filter3Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter3Device As Filter3DeviceFilterDevice()
C#
public Filter3DeviceFilterDevice[] Filter3Device { get; set; }
Visual C++
public:
property array<Filter3DeviceFilterDevice^>^ Filter3Device {
    array<Filter3DeviceFilterDevice^>^ get ();
    void set (array<Filter3DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter3Device();
function set_filter3Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


FilterDistortionDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.FilterDistortionDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDistortionDevice As FilterDistortionDevice()
C#
public FilterDistortionDevice[] FilterDistortionDevice { get; set; }
Visual C++
public:
property array<FilterDistortionDevice^>^ FilterDistortionDevice {
    array<FilterDistortionDevice^>^ get ();
    void set (array<FilterDistortionDevice^>^ value);
}
JavaScript
function get_filterDistortionDevice();
function set_filterDistortionDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


FlangerDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.FlangerDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FlangerDevice As FlangerDevice()
C#
public FlangerDevice[] FlangerDevice { get; set; }
Visual C++
public:
property array<FlangerDevice^>^ FlangerDevice {
    array<FlangerDevice^>^ get ();
    void set (array<FlangerDevice^>^ value);
}
JavaScript
function get_flangerDevice();
function set_flangerDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


GainerDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.GainerDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GainerDevice As GainerDevice()
C#
public GainerDevice[] GainerDevice { get; set; }
Visual C++
public:
property array<GainerDevice^>^ GainerDevice {
    array<GainerDevice^>^ get ();
    void set (array<GainerDevice^>^ value);
}
JavaScript
function get_gainerDevice();
function set_gainerDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Gate2Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Gate2Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gate2Device As Gate2DeviceGateDevice()
C#
public Gate2DeviceGateDevice[] Gate2Device { get; set; }
Visual C++
public:
property array<Gate2DeviceGateDevice^>^ Gate2Device {
    array<Gate2DeviceGateDevice^>^ get ();
    void set (array<Gate2DeviceGateDevice^>^ value);
}
JavaScript
function get_gate2Device();
function set_gate2Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


GateDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.GateDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateDevice As GateDeviceGateDevice()
C#
public GateDeviceGateDevice[] GateDevice { get; set; }
Visual C++
public:
property array<GateDeviceGateDevice^>^ GateDevice {
    array<GateDeviceGateDevice^>^ get ();
    void set (array<GateDeviceGateDevice^>^ value);
}
JavaScript
function get_gateDevice();
function set_gateDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


InstrumentAutomationDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.InstrumentAutomationDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InstrumentAutomationDevice As InstrumentAutomationDevice()
C#
public InstrumentAutomationDevice[] InstrumentAutomationDevice { get; set; }
Visual C++
public:
property array<InstrumentAutomationDevice^>^ InstrumentAutomationDevice {
    array<InstrumentAutomationDevice^>^ get ();
    void set (array<InstrumentAutomationDevice^>^ value);
}
JavaScript
function get_instrumentAutomationDevice();
function set_instrumentAutomationDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


LfoDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.LfoDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDevice As LfoDevice()
C#
public LfoDevice[] LfoDevice { get; set; }
Visual C++
public:
property array<LfoDevice^>^ LfoDevice {
    array<LfoDevice^>^ get ();
    void set (array<LfoDevice^>^ value);
}
JavaScript
function get_lfoDevice();
function set_lfoDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Lofi2Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Lofi2Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lofi2Device As Lofi2DeviceLofiDevice()
C#
public Lofi2DeviceLofiDevice[] Lofi2Device { get; set; }
Visual C++
public:
property array<Lofi2DeviceLofiDevice^>^ Lofi2Device {
    array<Lofi2DeviceLofiDevice^>^ get ();
    void set (array<Lofi2DeviceLofiDevice^>^ value);
}
JavaScript
function get_lofi2Device();
function set_lofi2Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


LofiDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.LofiDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LofiDevice As LofiDeviceLofiDevice()
C#
public LofiDeviceLofiDevice[] LofiDevice { get; set; }
Visual C++
public:
property array<LofiDeviceLofiDevice^>^ LofiDevice {
    array<LofiDeviceLofiDevice^>^ get ();
    void set (array<LofiDeviceLofiDevice^>^ value);
}
JavaScript
function get_lofiDevice();
function set_lofiDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


MaximizerDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.MaximizerDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximizerDevice As MaximizerDevice()
C#
public MaximizerDevice[] MaximizerDevice { get; set; }
Visual C++
public:
property array<MaximizerDevice^>^ MaximizerDevice {
    array<MaximizerDevice^>^ get ();
    void set (array<MaximizerDevice^>^ value);
}
JavaScript
function get_maximizerDevice();
function set_maximizerDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


MidiCCDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.MidiCCDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiCCDevice As MidiCCDevice()
C#
public MidiCCDevice[] MidiCCDevice { get; set; }
Visual C++
public:
property array<MidiCCDevice^>^ MidiCCDevice {
    array<MidiCCDevice^>^ get ();
    void set (array<MidiCCDevice^>^ value);
}
JavaScript
function get_midiCCDevice();
function set_midiCCDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


MixerEqDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.MixerEqDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MixerEqDevice As MixerEqDevice()
C#
public MixerEqDevice[] MixerEqDevice { get; set; }
Visual C++
public:
property array<MixerEqDevice^>^ MixerEqDevice {
    array<MixerEqDevice^>^ get ();
    void set (array<MixerEqDevice^>^ value);
}
JavaScript
function get_mixerEqDevice();
function set_mixerEqDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


PdcTestDelayDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.PdcTestDelayDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PdcTestDelayDevice As PdcTestDelayDevice()
C#
public PdcTestDelayDevice[] PdcTestDelayDevice { get; set; }
Visual C++
public:
property array<PdcTestDelayDevice^>^ PdcTestDelayDevice {
    array<PdcTestDelayDevice^>^ get ();
    void set (array<PdcTestDelayDevice^>^ value);
}
JavaScript
function get_pdcTestDelayDevice();
function set_pdcTestDelayDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


PhaserDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.PhaserDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PhaserDevice As PhaserDevice()
C#
public PhaserDevice[] PhaserDevice { get; set; }
Visual C++
public:
property array<PhaserDevice^>^ PhaserDevice {
    array<PhaserDevice^>^ get ();
    void set (array<PhaserDevice^>^ value);
}
JavaScript
function get_phaserDevice();
function set_phaserDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Reverb2Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Reverb2Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb2Device As Reverb2DeviceReverbDevice()
C#
public Reverb2DeviceReverbDevice[] Reverb2Device { get; set; }
Visual C++
public:
property array<Reverb2DeviceReverbDevice^>^ Reverb2Device {
    array<Reverb2DeviceReverbDevice^>^ get ();
    void set (array<Reverb2DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb2Device();
function set_reverb2Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


Reverb3Device Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.Reverb3Device Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb3Device As Reverb3DeviceReverbDevice()
C#
public Reverb3DeviceReverbDevice[] Reverb3Device { get; set; }
Visual C++
public:
property array<Reverb3DeviceReverbDevice^>^ Reverb3Device {
    array<Reverb3DeviceReverbDevice^>^ get ();
    void set (array<Reverb3DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb3Device();
function set_reverb3Device(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


ReverbDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.ReverbDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbDevice As ReverbDeviceReverbDevice()
C#
public ReverbDeviceReverbDevice[] ReverbDevice { get; set; }
Visual C++
public:
property array<ReverbDeviceReverbDevice^>^ ReverbDevice {
    array<ReverbDeviceReverbDevice^>^ get ();
    void set (array<ReverbDeviceReverbDevice^>^ value);
}
JavaScript
function get_reverbDevice();
function set_reverbDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


RingModDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.RingModDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RingModDevice As RingModDevice()
C#
public RingModDevice[] RingModDevice { get; set; }
Visual C++
public:
property array<RingModDevice^>^ RingModDevice {
    array<RingModDevice^>^ get ();
    void set (array<RingModDevice^>^ value);
}
JavaScript
function get_ringModDevice();
function set_ringModDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


SendDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.SendDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SendDevice As SendDevice()
C#
public SendDevice[] SendDevice { get; set; }
Visual C++
public:
property array<SendDevice^>^ SendDevice {
    array<SendDevice^>^ get ();
    void set (array<SendDevice^>^ value);
}
JavaScript
function get_sendDevice();
function set_sendDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


SequencerSendTrackDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.SequencerSendTrackDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerSendTrackDevice As SequencerSendTrackDevice()
C#
public SequencerSendTrackDevice[] SequencerSendTrackDevice { get; set; }
Visual C++
public:
property array<SequencerSendTrackDevice^>^ SequencerSendTrackDevice {
    array<SequencerSendTrackDevice^>^ get ();
    void set (array<SequencerSendTrackDevice^>^ value);
}
JavaScript
function get_sequencerSendTrackDevice();
function set_sequencerSendTrackDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


ShaperDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.ShaperDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShaperDevice As ShaperDevice()
C#
public ShaperDevice[] ShaperDevice { get; set; }
Visual C++
public:
property array<ShaperDevice^>^ ShaperDevice {
    array<ShaperDevice^>^ get ();
    void set (array<ShaperDevice^>^ value);
}
JavaScript
function get_shaperDevice();
function set_shaperDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


StereoExpanderDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.StereoExpanderDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoExpanderDevice As StereoExpanderDevice()
C#
public StereoExpanderDevice[] StereoExpanderDevice { get; set; }
Visual C++
public:
property array<StereoExpanderDevice^>^ StereoExpanderDevice {
    array<StereoExpanderDevice^>^ get ();
    void set (array<StereoExpanderDevice^>^ value);
}
JavaScript
function get_stereoExpanderDevice();
function set_stereoExpanderDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


VelocityDevice Property

[image]

.NET Framework Class Library
SequencerSendTrackFilterDevicesDevices..::.VelocityDevice Property
SequencerSendTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityDevice As VelocityDevice()
C#
public VelocityDevice[] VelocityDevice { get; set; }
Visual C++
public:
property array<VelocityDevice^>^ VelocityDevice {
    array<VelocityDevice^>^ get ();
    void set (array<VelocityDevice^>^ value);
}
JavaScript
function get_velocityDevice();
function set_velocityDevice(value);

Remarks

See Also

SequencerSendTrackFilterDevicesDevices Class


SequencerSendTrackNoteColumnState Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackNoteColumnState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackNoteColumnState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackNoteColumnState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackNoteColumnState
JavaScript
NRenoiseTools.SequencerSendTrackNoteColumnState = function();
NRenoiseTools.SequencerSendTrackNoteColumnState.createEnum('NRenoiseTools.SequencerSendTrackNoteColumnState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerSendTrackState Enumeration

[image]

.NET Framework Class Library
SequencerSendTrackState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerSendTrackState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerSendTrackState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerSendTrackState
JavaScript
NRenoiseTools.SequencerSendTrackState = function();
NRenoiseTools.SequencerSendTrackState.createEnum('NRenoiseTools.SequencerSendTrackState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrack Class

[image]

.NET Framework Class Library
SequencerTrack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrack
JavaScript
NRenoiseTools.SequencerTrack = function();

Type.createClass(
    'NRenoiseTools.SequencerTrack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrack

See Also

SequencerTrack Members


SequencerTrack Members

[image] [image]

.NET Framework Class Library
SequencerTrack Members
SequencerTrack Class Constructors Methods Properties See Also Send Feedback

The SequencerTrack type exposes the following members.

Constructors

Name | Description
SequencerTrack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerTrack Class


SequencerTrack Constructor

[image]

.NET Framework Class Library
SequencerTrack Constructor
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrack()
Visual C++
public:
SequencerTrack()
JavaScript
NRenoiseTools.SequencerTrack = function();

See Also

SequencerTrack Class


SequencerTrack Methods

[image] [image]

.NET Framework Class Library
SequencerTrack Methods
SequencerTrack Class See Also Send Feedback

The SequencerTrack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrack Class


SequencerTrack Properties

[image] [image]

.NET Framework Class Library
SequencerTrack Properties
SequencerTrack Class See Also Send Feedback

The SequencerTrack type exposes the following members.

Properties

Name | Description
DelayColumnIsVisible |
FilterDevices |
Name |
NoteColumnStates |
NumberOfVisibleEffectColumns |
NumberOfVisibleNoteColumns |
PanningColumnIsVisible |
State |
TrackDelay |
TrackRouting |
type |
VolumeColumnIsVisible |

See Also

SequencerTrack Class


DelayColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerTrack..::.DelayColumnIsVisible Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayColumnIsVisible As Boolean
C#
public bool DelayColumnIsVisible { get; set; }
Visual C++
public:
property bool DelayColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_delayColumnIsVisible();
function set_delayColumnIsVisible(value);

Remarks

See Also

SequencerTrack Class


FilterDevices Property

[image]

.NET Framework Class Library
SequencerTrack..::.FilterDevices Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDevices As SequencerTrackFilterDevices
C#
public SequencerTrackFilterDevices FilterDevices { get; set; }
Visual C++
public:
property SequencerTrackFilterDevices^ FilterDevices {
    SequencerTrackFilterDevices^ get ();
    void set (SequencerTrackFilterDevices^ value);
}
JavaScript
function get_filterDevices();
function set_filterDevices(value);

Remarks

See Also

SequencerTrack Class


Name Property

[image]

.NET Framework Class Library
SequencerTrack..::.Name Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

SequencerTrack Class


NoteColumnStates Property

[image]

.NET Framework Class Library
SequencerTrack..::.NoteColumnStates Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NoteColumnStates As SequencerTrackNoteColumnState()
C#
public SequencerTrackNoteColumnState[] NoteColumnStates { get; set; }
Visual C++
public:
property array<SequencerTrackNoteColumnState>^ NoteColumnStates {
    array<SequencerTrackNoteColumnState>^ get ();
    void set (array<SequencerTrackNoteColumnState>^ value);
}
JavaScript
function get_noteColumnStates();
function set_noteColumnStates(value);

Remarks

See Also

SequencerTrack Class


NumberOfVisibleEffectColumns Property

[image]

.NET Framework Class Library
SequencerTrack..::.NumberOfVisibleEffectColumns Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleEffectColumns As Integer
C#
public int NumberOfVisibleEffectColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleEffectColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleEffectColumns();
function set_numberOfVisibleEffectColumns(value);

Remarks

See Also

SequencerTrack Class


NumberOfVisibleNoteColumns Property

[image]

.NET Framework Class Library
SequencerTrack..::.NumberOfVisibleNoteColumns Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfVisibleNoteColumns As Integer
C#
public int NumberOfVisibleNoteColumns { get; set; }
Visual C++
public:
property int NumberOfVisibleNoteColumns {
    int get ();
    void set (int value);
}
JavaScript
function get_numberOfVisibleNoteColumns();
function set_numberOfVisibleNoteColumns(value);

Remarks

See Also

SequencerTrack Class


PanningColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerTrack..::.PanningColumnIsVisible Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PanningColumnIsVisible As Boolean
C#
public bool PanningColumnIsVisible { get; set; }
Visual C++
public:
property bool PanningColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_panningColumnIsVisible();
function set_panningColumnIsVisible(value);

Remarks

See Also

SequencerTrack Class


State Property

[image]

.NET Framework Class Library
SequencerTrack..::.State Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property State As SequencerTrackState
C#
public SequencerTrackState State { get; set; }
Visual C++
public:
property SequencerTrackState State {
    SequencerTrackState get ();
    void set (SequencerTrackState value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

SequencerTrack Class


TrackDelay Property

[image]

.NET Framework Class Library
SequencerTrack..::.TrackDelay Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackDelay As Single
C#
public float TrackDelay { get; set; }
Visual C++
public:
property float TrackDelay {
    float get ();
    void set (float value);
}
JavaScript
function get_trackDelay();
function set_trackDelay(value);

Remarks

See Also

SequencerTrack Class


TrackRouting Property

[image]

.NET Framework Class Library
SequencerTrack..::.TrackRouting Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackRouting As Integer
C#
public int TrackRouting { get; set; }
Visual C++
public:
property int TrackRouting {
    int get ();
    void set (int value);
}
JavaScript
function get_trackRouting();
function set_trackRouting(value);

Remarks

See Also

SequencerTrack Class


type Property

[image]

.NET Framework Class Library
SequencerTrack..::.type Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerTrack Class


VolumeColumnIsVisible Property

[image]

.NET Framework Class Library
SequencerTrack..::.VolumeColumnIsVisible Property
SequencerTrack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VolumeColumnIsVisible As Boolean
C#
public bool VolumeColumnIsVisible { get; set; }
Visual C++
public:
property bool VolumeColumnIsVisible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_volumeColumnIsVisible();
function set_volumeColumnIsVisible(value);

Remarks

See Also

SequencerTrack Class


SequencerTrackDevice Class

[image]

.NET Framework Class Library
SequencerTrackDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevice
JavaScript
NRenoiseTools.SequencerTrackDevice = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevice

See Also

SequencerTrackDevice Members


SequencerTrackDevice Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevice Members
SequencerTrackDevice Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevice type exposes the following members.

Constructors

Name | Description
SequencerTrackDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Surround |
type |
Volume |

See Also

SequencerTrackDevice Class


SequencerTrackDevice Constructor

[image]

.NET Framework Class Library
SequencerTrackDevice Constructor
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevice()
Visual C++
public:
SequencerTrackDevice()
JavaScript
NRenoiseTools.SequencerTrackDevice = function();

See Also

SequencerTrackDevice Class


SequencerTrackDevice Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevice Methods
SequencerTrackDevice Class See Also Send Feedback

The SequencerTrackDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevice Class


SequencerTrackDevice Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevice Properties
SequencerTrackDevice Class See Also Send Feedback

The SequencerTrackDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
Panning |
PostPanning |
PostVolume |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Surround |
type |
Volume |

See Also

SequencerTrackDevice Class


IsActive Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.IsActive Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

SequencerTrackDevice Class


IsSelected Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.IsSelected Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

SequencerTrackDevice Class


Panning Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.Panning Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerTrackDevicePanning
C#
public SequencerTrackDevicePanning Panning { get; set; }
Visual C++
public:
property SequencerTrackDevicePanning^ Panning {
    SequencerTrackDevicePanning^ get ();
    void set (SequencerTrackDevicePanning^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerTrackDevice Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.PostPanning Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerTrackDevicePostPanning
C#
public SequencerTrackDevicePostPanning PostPanning { get; set; }
Visual C++
public:
property SequencerTrackDevicePostPanning^ PostPanning {
    SequencerTrackDevicePostPanning^ get ();
    void set (SequencerTrackDevicePostPanning^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerTrackDevice Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.PostVolume Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerTrackDevicePostVolume
C#
public SequencerTrackDevicePostVolume PostVolume { get; set; }
Visual C++
public:
property SequencerTrackDevicePostVolume^ PostVolume {
    SequencerTrackDevicePostVolume^ get ();
    void set (SequencerTrackDevicePostVolume^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerTrackDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.RunTimePresetA Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As SequencerTrackDeviceRunTimePreset
C#
public SequencerTrackDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property SequencerTrackDeviceRunTimePreset^ RunTimePresetA {
    SequencerTrackDeviceRunTimePreset^ get ();
    void set (SequencerTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

SequencerTrackDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.RunTimePresetB Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As SequencerTrackDeviceRunTimePreset
C#
public SequencerTrackDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property SequencerTrackDeviceRunTimePreset^ RunTimePresetB {
    SequencerTrackDeviceRunTimePreset^ get ();
    void set (SequencerTrackDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

SequencerTrackDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.SelectedPresetIsModified Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

SequencerTrackDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.SelectedPresetName Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

SequencerTrackDevice Class


Surround Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.Surround Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerTrackDeviceSurround
C#
public SequencerTrackDeviceSurround Surround { get; set; }
Visual C++
public:
property SequencerTrackDeviceSurround^ Surround {
    SequencerTrackDeviceSurround^ get ();
    void set (SequencerTrackDeviceSurround^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerTrackDevice Class


type Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.type Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerTrackDevice Class


Volume Property

[image]

.NET Framework Class Library
SequencerTrackDevice..::.Volume Property
SequencerTrackDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerTrackDeviceVolume
C#
public SequencerTrackDeviceVolume Volume { get; set; }
Visual C++
public:
property SequencerTrackDeviceVolume^ Volume {
    SequencerTrackDeviceVolume^ get ();
    void set (SequencerTrackDeviceVolume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerTrackDevice Class


SequencerTrackDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceDeviceSlotRunTimePreset

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Members


SequencerTrackDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset Members
SequencerTrackDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Panning |
PostPanning |
PostVolume |
Surround |
type |
Volume |

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


SequencerTrackDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset Constructor
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceDeviceSlotRunTimePreset()
Visual C++
public:
SequencerTrackDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDeviceDeviceSlotRunTimePreset = function();

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


SequencerTrackDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset Methods
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


SequencerTrackDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset Properties
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Panning |
PostPanning |
PostVolume |
Surround |
type |
Volume |

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


Panning Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.Panning Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Panning As SequencerTrackDevicePanningRunTimePreset
C#
public SequencerTrackDevicePanningRunTimePreset Panning { get; set; }
Visual C++
public:
property SequencerTrackDevicePanningRunTimePreset^ Panning {
    SequencerTrackDevicePanningRunTimePreset^ get ();
    void set (SequencerTrackDevicePanningRunTimePreset^ value);
}
JavaScript
function get_panning();
function set_panning(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


PostPanning Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.PostPanning Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostPanning As SequencerTrackDevicePostPanningRunTimePreset
C#
public SequencerTrackDevicePostPanningRunTimePreset PostPanning { get; set; }
Visual C++
public:
property SequencerTrackDevicePostPanningRunTimePreset^ PostPanning {
    SequencerTrackDevicePostPanningRunTimePreset^ get ();
    void set (SequencerTrackDevicePostPanningRunTimePreset^ value);
}
JavaScript
function get_postPanning();
function set_postPanning(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


PostVolume Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.PostVolume Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PostVolume As SequencerTrackDevicePostVolumeRunTimePreset
C#
public SequencerTrackDevicePostVolumeRunTimePreset PostVolume { get; set; }
Visual C++
public:
property SequencerTrackDevicePostVolumeRunTimePreset^ PostVolume {
    SequencerTrackDevicePostVolumeRunTimePreset^ get ();
    void set (SequencerTrackDevicePostVolumeRunTimePreset^ value);
}
JavaScript
function get_postVolume();
function set_postVolume(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


Surround Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.Surround Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Surround As SequencerTrackDeviceSurroundRunTimePreset
C#
public SequencerTrackDeviceSurroundRunTimePreset Surround { get; set; }
Visual C++
public:
property SequencerTrackDeviceSurroundRunTimePreset^ Surround {
    SequencerTrackDeviceSurroundRunTimePreset^ get ();
    void set (SequencerTrackDeviceSurroundRunTimePreset^ value);
}
JavaScript
function get_surround();
function set_surround(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.type Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


Volume Property

[image]

.NET Framework Class Library
SequencerTrackDeviceDeviceSlotRunTimePreset..::.Volume Property
SequencerTrackDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As SequencerTrackDeviceVolumeRunTimePreset
C#
public SequencerTrackDeviceVolumeRunTimePreset Volume { get; set; }
Visual C++
public:
property SequencerTrackDeviceVolumeRunTimePreset^ Volume {
    SequencerTrackDeviceVolumeRunTimePreset^ get ();
    void set (SequencerTrackDeviceVolumeRunTimePreset^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

SequencerTrackDeviceDeviceSlotRunTimePreset Class


SequencerTrackDevicePanning Class

[image]

.NET Framework Class Library
SequencerTrackDevicePanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePanning
JavaScript
NRenoiseTools.SequencerTrackDevicePanning = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePanning

See Also

SequencerTrackDevicePanning Members


SequencerTrackDevicePanning Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanning Members
SequencerTrackDevicePanning Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePanning type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePanning Class


SequencerTrackDevicePanning Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePanning Constructor
SequencerTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePanning()
Visual C++
public:
SequencerTrackDevicePanning()
JavaScript
NRenoiseTools.SequencerTrackDevicePanning = function();

See Also

SequencerTrackDevicePanning Class


SequencerTrackDevicePanning Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanning Methods
SequencerTrackDevicePanning Class See Also Send Feedback

The SequencerTrackDevicePanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePanning Class


SequencerTrackDevicePanning Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanning Properties
SequencerTrackDevicePanning Class See Also Send Feedback

The SequencerTrackDevicePanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerTrackDevicePanning..::.MidiMappings Property
SequencerTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerTrackDevicePanning Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePanning..::.Value Property
SequencerTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerTrackDevicePanning..::.Visualization Property
SequencerTrackDevicePanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerTrackDevicePanningVisualization
C#
public SequencerTrackDevicePanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerTrackDevicePanningVisualization Visualization {
    SequencerTrackDevicePanningVisualization get ();
    void set (SequencerTrackDevicePanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerTrackDevicePanning Class


SequencerTrackDevicePanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePanningRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDevicePanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePanningRunTimePreset

See Also

SequencerTrackDevicePanningRunTimePreset Members


SequencerTrackDevicePanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset Members
SequencerTrackDevicePanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePanningRunTimePreset Class


SequencerTrackDevicePanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset Constructor
SequencerTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePanningRunTimePreset()
Visual C++
public:
SequencerTrackDevicePanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDevicePanningRunTimePreset = function();

See Also

SequencerTrackDevicePanningRunTimePreset Class


SequencerTrackDevicePanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset Methods
SequencerTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePanningRunTimePreset Class


SequencerTrackDevicePanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset Properties
SequencerTrackDevicePanningRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePanningRunTimePreset..::.Value Property
SequencerTrackDevicePanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePanningRunTimePreset Class


SequencerTrackDevicePanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerTrackDevicePanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackDevicePanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackDevicePanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackDevicePanningVisualization
JavaScript
NRenoiseTools.SequencerTrackDevicePanningVisualization = function();
NRenoiseTools.SequencerTrackDevicePanningVisualization.createEnum('NRenoiseTools.SequencerTrackDevicePanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackDevicePostPanning Class

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanning Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePostPanning
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePostPanning
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePostPanning
JavaScript
NRenoiseTools.SequencerTrackDevicePostPanning = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePostPanning');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePostPanning

See Also

SequencerTrackDevicePostPanning Members


SequencerTrackDevicePostPanning Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanning Members
SequencerTrackDevicePostPanning Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePostPanning type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePostPanning |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePostPanning Class


SequencerTrackDevicePostPanning Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanning Constructor
SequencerTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePostPanning()
Visual C++
public:
SequencerTrackDevicePostPanning()
JavaScript
NRenoiseTools.SequencerTrackDevicePostPanning = function();

See Also

SequencerTrackDevicePostPanning Class


SequencerTrackDevicePostPanning Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanning Methods
SequencerTrackDevicePostPanning Class See Also Send Feedback

The SequencerTrackDevicePostPanning type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePostPanning Class


SequencerTrackDevicePostPanning Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanning Properties
SequencerTrackDevicePostPanning Class See Also Send Feedback

The SequencerTrackDevicePostPanning type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePostPanning Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanning..::.MidiMappings Property
SequencerTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerTrackDevicePostPanning Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanning..::.Value Property
SequencerTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePostPanning Class


Visualization Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanning..::.Visualization Property
SequencerTrackDevicePostPanning Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerTrackDevicePostPanningVisualization
C#
public SequencerTrackDevicePostPanningVisualization Visualization { get; set; }
Visual C++
public:
property SequencerTrackDevicePostPanningVisualization Visualization {
    SequencerTrackDevicePostPanningVisualization get ();
    void set (SequencerTrackDevicePostPanningVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerTrackDevicePostPanning Class


SequencerTrackDevicePostPanningRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePostPanningRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePostPanningRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePostPanningRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDevicePostPanningRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePostPanningRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePostPanningRunTimePreset

See Also

SequencerTrackDevicePostPanningRunTimePreset Members


SequencerTrackDevicePostPanningRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset Members
SequencerTrackDevicePostPanningRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePostPanningRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePostPanningRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePostPanningRunTimePreset Class


SequencerTrackDevicePostPanningRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset Constructor
SequencerTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePostPanningRunTimePreset()
Visual C++
public:
SequencerTrackDevicePostPanningRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDevicePostPanningRunTimePreset = function();

See Also

SequencerTrackDevicePostPanningRunTimePreset Class


SequencerTrackDevicePostPanningRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset Methods
SequencerTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePostPanningRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePostPanningRunTimePreset Class


SequencerTrackDevicePostPanningRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset Properties
SequencerTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePostPanningRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePostPanningRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanningRunTimePreset..::.Value Property
SequencerTrackDevicePostPanningRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePostPanningRunTimePreset Class


SequencerTrackDevicePostPanningVisualization Enumeration

[image]

.NET Framework Class Library
SequencerTrackDevicePostPanningVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackDevicePostPanningVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackDevicePostPanningVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackDevicePostPanningVisualization
JavaScript
NRenoiseTools.SequencerTrackDevicePostPanningVisualization = function();
NRenoiseTools.SequencerTrackDevicePostPanningVisualization.createEnum('NRenoiseTools.SequencerTrackDevicePostPanningVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackDevicePostVolume Class

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePostVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePostVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePostVolume
JavaScript
NRenoiseTools.SequencerTrackDevicePostVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePostVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePostVolume

See Also

SequencerTrackDevicePostVolume Members


SequencerTrackDevicePostVolume Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolume Members
SequencerTrackDevicePostVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePostVolume type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePostVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePostVolume Class


SequencerTrackDevicePostVolume Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolume Constructor
SequencerTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePostVolume()
Visual C++
public:
SequencerTrackDevicePostVolume()
JavaScript
NRenoiseTools.SequencerTrackDevicePostVolume = function();

See Also

SequencerTrackDevicePostVolume Class


SequencerTrackDevicePostVolume Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolume Methods
SequencerTrackDevicePostVolume Class See Also Send Feedback

The SequencerTrackDevicePostVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePostVolume Class


SequencerTrackDevicePostVolume Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolume Properties
SequencerTrackDevicePostVolume Class See Also Send Feedback

The SequencerTrackDevicePostVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDevicePostVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolume..::.MidiMappings Property
SequencerTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerTrackDevicePostVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolume..::.Value Property
SequencerTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePostVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolume..::.Visualization Property
SequencerTrackDevicePostVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerTrackDevicePostVolumeVisualization
C#
public SequencerTrackDevicePostVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerTrackDevicePostVolumeVisualization Visualization {
    SequencerTrackDevicePostVolumeVisualization get ();
    void set (SequencerTrackDevicePostVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerTrackDevicePostVolume Class


SequencerTrackDevicePostVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDevicePostVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDevicePostVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDevicePostVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDevicePostVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDevicePostVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDevicePostVolumeRunTimePreset

See Also

SequencerTrackDevicePostVolumeRunTimePreset Members


SequencerTrackDevicePostVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset Members
SequencerTrackDevicePostVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDevicePostVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDevicePostVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePostVolumeRunTimePreset Class


SequencerTrackDevicePostVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset Constructor
SequencerTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDevicePostVolumeRunTimePreset()
Visual C++
public:
SequencerTrackDevicePostVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDevicePostVolumeRunTimePreset = function();

See Also

SequencerTrackDevicePostVolumeRunTimePreset Class


SequencerTrackDevicePostVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset Methods
SequencerTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePostVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDevicePostVolumeRunTimePreset Class


SequencerTrackDevicePostVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset Properties
SequencerTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

The SequencerTrackDevicePostVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerTrackDevicePostVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeRunTimePreset..::.Value Property
SequencerTrackDevicePostVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDevicePostVolumeRunTimePreset Class


SequencerTrackDevicePostVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerTrackDevicePostVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackDevicePostVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackDevicePostVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackDevicePostVolumeVisualization
JavaScript
NRenoiseTools.SequencerTrackDevicePostVolumeVisualization = function();
NRenoiseTools.SequencerTrackDevicePostVolumeVisualization.createEnum('NRenoiseTools.SequencerTrackDevicePostVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackDeviceRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceRunTimePreset

See Also

SequencerTrackDeviceRunTimePreset Members


SequencerTrackDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset Members
SequencerTrackDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerTrackDeviceRunTimePreset Class


SequencerTrackDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset Constructor
SequencerTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceRunTimePreset()
Visual C++
public:
SequencerTrackDeviceRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDeviceRunTimePreset = function();

See Also

SequencerTrackDeviceRunTimePreset Class


SequencerTrackDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset Methods
SequencerTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceRunTimePreset Class


SequencerTrackDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset Properties
SequencerTrackDeviceRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

SequencerTrackDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset..::.DeviceSlot Property
SequencerTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As SequencerTrackDeviceDeviceSlotRunTimePreset
C#
public SequencerTrackDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property SequencerTrackDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    SequencerTrackDeviceDeviceSlotRunTimePreset^ get ();
    void set (SequencerTrackDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

SequencerTrackDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
SequencerTrackDeviceRunTimePreset..::.type Property
SequencerTrackDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

SequencerTrackDeviceRunTimePreset Class


SequencerTrackDeviceSurround Class

[image]

.NET Framework Class Library
SequencerTrackDeviceSurround Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceSurround
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceSurround
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceSurround
JavaScript
NRenoiseTools.SequencerTrackDeviceSurround = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceSurround');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceSurround

See Also

SequencerTrackDeviceSurround Members


SequencerTrackDeviceSurround Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurround Members
SequencerTrackDeviceSurround Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceSurround type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceSurround |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDeviceSurround Class


SequencerTrackDeviceSurround Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceSurround Constructor
SequencerTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceSurround()
Visual C++
public:
SequencerTrackDeviceSurround()
JavaScript
NRenoiseTools.SequencerTrackDeviceSurround = function();

See Also

SequencerTrackDeviceSurround Class


SequencerTrackDeviceSurround Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurround Methods
SequencerTrackDeviceSurround Class See Also Send Feedback

The SequencerTrackDeviceSurround type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceSurround Class


SequencerTrackDeviceSurround Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurround Properties
SequencerTrackDeviceSurround Class See Also Send Feedback

The SequencerTrackDeviceSurround type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDeviceSurround Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerTrackDeviceSurround..::.MidiMappings Property
SequencerTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerTrackDeviceSurround Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDeviceSurround..::.Value Property
SequencerTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDeviceSurround Class


Visualization Property

[image]

.NET Framework Class Library
SequencerTrackDeviceSurround..::.Visualization Property
SequencerTrackDeviceSurround Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerTrackDeviceSurroundVisualization
C#
public SequencerTrackDeviceSurroundVisualization Visualization { get; set; }
Visual C++
public:
property SequencerTrackDeviceSurroundVisualization Visualization {
    SequencerTrackDeviceSurroundVisualization get ();
    void set (SequencerTrackDeviceSurroundVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerTrackDeviceSurround Class


SequencerTrackDeviceSurroundRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceSurroundRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceSurroundRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceSurroundRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDeviceSurroundRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceSurroundRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceSurroundRunTimePreset

See Also

SequencerTrackDeviceSurroundRunTimePreset Members


SequencerTrackDeviceSurroundRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset Members
SequencerTrackDeviceSurroundRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceSurroundRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceSurroundRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerTrackDeviceSurroundRunTimePreset Class


SequencerTrackDeviceSurroundRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset Constructor
SequencerTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceSurroundRunTimePreset()
Visual C++
public:
SequencerTrackDeviceSurroundRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDeviceSurroundRunTimePreset = function();

See Also

SequencerTrackDeviceSurroundRunTimePreset Class


SequencerTrackDeviceSurroundRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset Methods
SequencerTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceSurroundRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceSurroundRunTimePreset Class


SequencerTrackDeviceSurroundRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset Properties
SequencerTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceSurroundRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerTrackDeviceSurroundRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDeviceSurroundRunTimePreset..::.Value Property
SequencerTrackDeviceSurroundRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDeviceSurroundRunTimePreset Class


SequencerTrackDeviceSurroundVisualization Enumeration

[image]

.NET Framework Class Library
SequencerTrackDeviceSurroundVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackDeviceSurroundVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackDeviceSurroundVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackDeviceSurroundVisualization
JavaScript
NRenoiseTools.SequencerTrackDeviceSurroundVisualization = function();
NRenoiseTools.SequencerTrackDeviceSurroundVisualization.createEnum('NRenoiseTools.SequencerTrackDeviceSurroundVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackDeviceVolume Class

[image]

.NET Framework Class Library
SequencerTrackDeviceVolume Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceVolume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceVolume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceVolume
JavaScript
NRenoiseTools.SequencerTrackDeviceVolume = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceVolume');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceVolume

See Also

SequencerTrackDeviceVolume Members


SequencerTrackDeviceVolume Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolume Members
SequencerTrackDeviceVolume Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceVolume type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceVolume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDeviceVolume Class


SequencerTrackDeviceVolume Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceVolume Constructor
SequencerTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceVolume()
Visual C++
public:
SequencerTrackDeviceVolume()
JavaScript
NRenoiseTools.SequencerTrackDeviceVolume = function();

See Also

SequencerTrackDeviceVolume Class


SequencerTrackDeviceVolume Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolume Methods
SequencerTrackDeviceVolume Class See Also Send Feedback

The SequencerTrackDeviceVolume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceVolume Class


SequencerTrackDeviceVolume Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolume Properties
SequencerTrackDeviceVolume Class See Also Send Feedback

The SequencerTrackDeviceVolume type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

SequencerTrackDeviceVolume Class


MidiMappings Property

[image]

.NET Framework Class Library
SequencerTrackDeviceVolume..::.MidiMappings Property
SequencerTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

SequencerTrackDeviceVolume Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDeviceVolume..::.Value Property
SequencerTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDeviceVolume Class


Visualization Property

[image]

.NET Framework Class Library
SequencerTrackDeviceVolume..::.Visualization Property
SequencerTrackDeviceVolume Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As SequencerTrackDeviceVolumeVisualization
C#
public SequencerTrackDeviceVolumeVisualization Visualization { get; set; }
Visual C++
public:
property SequencerTrackDeviceVolumeVisualization Visualization {
    SequencerTrackDeviceVolumeVisualization get ();
    void set (SequencerTrackDeviceVolumeVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

SequencerTrackDeviceVolume Class


SequencerTrackDeviceVolumeRunTimePreset Class

[image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackDeviceVolumeRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackDeviceVolumeRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackDeviceVolumeRunTimePreset
JavaScript
NRenoiseTools.SequencerTrackDeviceVolumeRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackDeviceVolumeRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackDeviceVolumeRunTimePreset

See Also

SequencerTrackDeviceVolumeRunTimePreset Members


SequencerTrackDeviceVolumeRunTimePreset Members

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset Members
SequencerTrackDeviceVolumeRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackDeviceVolumeRunTimePreset type exposes the following members.

Constructors

Name | Description
SequencerTrackDeviceVolumeRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

SequencerTrackDeviceVolumeRunTimePreset Class


SequencerTrackDeviceVolumeRunTimePreset Constructor

[image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset Constructor
SequencerTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackDeviceVolumeRunTimePreset()
Visual C++
public:
SequencerTrackDeviceVolumeRunTimePreset()
JavaScript
NRenoiseTools.SequencerTrackDeviceVolumeRunTimePreset = function();

See Also

SequencerTrackDeviceVolumeRunTimePreset Class


SequencerTrackDeviceVolumeRunTimePreset Methods

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset Methods
SequencerTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceVolumeRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackDeviceVolumeRunTimePreset Class


SequencerTrackDeviceVolumeRunTimePreset Properties

[image] [image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset Properties
SequencerTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

The SequencerTrackDeviceVolumeRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

SequencerTrackDeviceVolumeRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
SequencerTrackDeviceVolumeRunTimePreset..::.Value Property
SequencerTrackDeviceVolumeRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

SequencerTrackDeviceVolumeRunTimePreset Class


SequencerTrackDeviceVolumeVisualization Enumeration

[image]

.NET Framework Class Library
SequencerTrackDeviceVolumeVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackDeviceVolumeVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackDeviceVolumeVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackDeviceVolumeVisualization
JavaScript
NRenoiseTools.SequencerTrackDeviceVolumeVisualization = function();
NRenoiseTools.SequencerTrackDeviceVolumeVisualization.createEnum('NRenoiseTools.SequencerTrackDeviceVolumeVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackFilterDevices Class

[image]

.NET Framework Class Library
SequencerTrackFilterDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackFilterDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackFilterDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackFilterDevices
JavaScript
NRenoiseTools.SequencerTrackFilterDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackFilterDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackFilterDevices

See Also

SequencerTrackFilterDevices Members


SequencerTrackFilterDevices Members

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevices Members
SequencerTrackFilterDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackFilterDevices type exposes the following members.

Constructors

Name | Description
SequencerTrackFilterDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Devices |

See Also

SequencerTrackFilterDevices Class


SequencerTrackFilterDevices Constructor

[image]

.NET Framework Class Library
SequencerTrackFilterDevices Constructor
SequencerTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackFilterDevices()
Visual C++
public:
SequencerTrackFilterDevices()
JavaScript
NRenoiseTools.SequencerTrackFilterDevices = function();

See Also

SequencerTrackFilterDevices Class


SequencerTrackFilterDevices Methods

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevices Methods
SequencerTrackFilterDevices Class See Also Send Feedback

The SequencerTrackFilterDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackFilterDevices Class


SequencerTrackFilterDevices Properties

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevices Properties
SequencerTrackFilterDevices Class See Also Send Feedback

The SequencerTrackFilterDevices type exposes the following members.

Properties

Name | Description
Devices |

See Also

SequencerTrackFilterDevices Class


Devices Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevices..::.Devices Property
SequencerTrackFilterDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Devices As SequencerTrackFilterDevicesDevices
C#
public SequencerTrackFilterDevicesDevices Devices { get; set; }
Visual C++
public:
property SequencerTrackFilterDevicesDevices^ Devices {
    SequencerTrackFilterDevicesDevices^ get ();
    void set (SequencerTrackFilterDevicesDevices^ value);
}
JavaScript
function get_devices();
function set_devices(value);

Remarks

See Also

SequencerTrackFilterDevices Class


SequencerTrackFilterDevicesDevices Class

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SequencerTrackFilterDevicesDevices
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SequencerTrackFilterDevicesDevices
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SequencerTrackFilterDevicesDevices
JavaScript
NRenoiseTools.SequencerTrackFilterDevicesDevices = function();

Type.createClass(
    'NRenoiseTools.SequencerTrackFilterDevicesDevices');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SequencerTrackFilterDevicesDevices

See Also

SequencerTrackFilterDevicesDevices Members


SequencerTrackFilterDevicesDevices Members

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices Members
SequencerTrackFilterDevicesDevices Class Constructors Methods Properties See Also Send Feedback

The SequencerTrackFilterDevicesDevices type exposes the following members.

Constructors

Name | Description
SequencerTrackFilterDevicesDevices |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
LineInDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
SequencerTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerTrackFilterDevicesDevices Class


SequencerTrackFilterDevicesDevices Constructor

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices Constructor
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SequencerTrackFilterDevicesDevices()
Visual C++
public:
SequencerTrackFilterDevicesDevices()
JavaScript
NRenoiseTools.SequencerTrackFilterDevicesDevices = function();

See Also

SequencerTrackFilterDevicesDevices Class


SequencerTrackFilterDevicesDevices Methods

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices Methods
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerTrackFilterDevicesDevices type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequencerTrackFilterDevicesDevices Class


SequencerTrackFilterDevicesDevices Properties

[image] [image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices Properties
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

The SequencerTrackFilterDevicesDevices type exposes the following members.

Properties

Name | Description
AudioPluginDevice |
BusCompressorDevice |
ChorusDevice |
CompressorDevice |
DcOffsetDevice |
DelayDevice |
Distortion2Device |
DistortionDevice |
Eq10Device |
Eq5Device |
Filter1Device |
Filter2Device |
Filter3Device |
FilterDistortionDevice |
FlangerDevice |
GainerDevice |
Gate2Device |
GateDevice |
InstrumentAutomationDevice |
LfoDevice |
LineInDevice |
Lofi2Device |
LofiDevice |
MaximizerDevice |
MidiCCDevice |
MixerEqDevice |
PdcTestDelayDevice |
PhaserDevice |
Reverb2Device |
Reverb3Device |
ReverbDevice |
RingModDevice |
SendDevice |
SequencerTrackDevice |
ShaperDevice |
StereoExpanderDevice |
VelocityDevice |

See Also

SequencerTrackFilterDevicesDevices Class


AudioPluginDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.AudioPluginDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property AudioPluginDevice As AudioPluginDevice()
C#
public AudioPluginDevice[] AudioPluginDevice { get; set; }
Visual C++
public:
property array<AudioPluginDevice^>^ AudioPluginDevice {
    array<AudioPluginDevice^>^ get ();
    void set (array<AudioPluginDevice^>^ value);
}
JavaScript
function get_audioPluginDevice();
function set_audioPluginDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


BusCompressorDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.BusCompressorDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property BusCompressorDevice As BusCompressorDevice()
C#
public BusCompressorDevice[] BusCompressorDevice { get; set; }
Visual C++
public:
property array<BusCompressorDevice^>^ BusCompressorDevice {
    array<BusCompressorDevice^>^ get ();
    void set (array<BusCompressorDevice^>^ value);
}
JavaScript
function get_busCompressorDevice();
function set_busCompressorDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


ChorusDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.ChorusDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ChorusDevice As ChorusDevice()
C#
public ChorusDevice[] ChorusDevice { get; set; }
Visual C++
public:
property array<ChorusDevice^>^ ChorusDevice {
    array<ChorusDevice^>^ get ();
    void set (array<ChorusDevice^>^ value);
}
JavaScript
function get_chorusDevice();
function set_chorusDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


CompressorDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.CompressorDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressorDevice As CompressorDevice()
C#
public CompressorDevice[] CompressorDevice { get; set; }
Visual C++
public:
property array<CompressorDevice^>^ CompressorDevice {
    array<CompressorDevice^>^ get ();
    void set (array<CompressorDevice^>^ value);
}
JavaScript
function get_compressorDevice();
function set_compressorDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


DcOffsetDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.DcOffsetDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DcOffsetDevice As DcOffsetDevice()
C#
public DcOffsetDevice[] DcOffsetDevice { get; set; }
Visual C++
public:
property array<DcOffsetDevice^>^ DcOffsetDevice {
    array<DcOffsetDevice^>^ get ();
    void set (array<DcOffsetDevice^>^ value);
}
JavaScript
function get_dcOffsetDevice();
function set_dcOffsetDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


DelayDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.DelayDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayDevice As DelayDevice()
C#
public DelayDevice[] DelayDevice { get; set; }
Visual C++
public:
property array<DelayDevice^>^ DelayDevice {
    array<DelayDevice^>^ get ();
    void set (array<DelayDevice^>^ value);
}
JavaScript
function get_delayDevice();
function set_delayDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Distortion2Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Distortion2Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Distortion2Device As Distortion2DeviceDistortionDevice()
C#
public Distortion2DeviceDistortionDevice[] Distortion2Device { get; set; }
Visual C++
public:
property array<Distortion2DeviceDistortionDevice^>^ Distortion2Device {
    array<Distortion2DeviceDistortionDevice^>^ get ();
    void set (array<Distortion2DeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortion2Device();
function set_distortion2Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


DistortionDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.DistortionDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DistortionDevice As DistortionDeviceDistortionDevice()
C#
public DistortionDeviceDistortionDevice[] DistortionDevice { get; set; }
Visual C++
public:
property array<DistortionDeviceDistortionDevice^>^ DistortionDevice {
    array<DistortionDeviceDistortionDevice^>^ get ();
    void set (array<DistortionDeviceDistortionDevice^>^ value);
}
JavaScript
function get_distortionDevice();
function set_distortionDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Eq10Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Eq10Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq10Device As Eq10DeviceEqDevice()
C#
public Eq10DeviceEqDevice[] Eq10Device { get; set; }
Visual C++
public:
property array<Eq10DeviceEqDevice^>^ Eq10Device {
    array<Eq10DeviceEqDevice^>^ get ();
    void set (array<Eq10DeviceEqDevice^>^ value);
}
JavaScript
function get_eq10Device();
function set_eq10Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Eq5Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Eq5Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Eq5Device As Eq5DeviceEqDevice()
C#
public Eq5DeviceEqDevice[] Eq5Device { get; set; }
Visual C++
public:
property array<Eq5DeviceEqDevice^>^ Eq5Device {
    array<Eq5DeviceEqDevice^>^ get ();
    void set (array<Eq5DeviceEqDevice^>^ value);
}
JavaScript
function get_eq5Device();
function set_eq5Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Filter1Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Filter1Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter1Device As Filter1DeviceFilterDevice()
C#
public Filter1DeviceFilterDevice[] Filter1Device { get; set; }
Visual C++
public:
property array<Filter1DeviceFilterDevice^>^ Filter1Device {
    array<Filter1DeviceFilterDevice^>^ get ();
    void set (array<Filter1DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter1Device();
function set_filter1Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Filter2Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Filter2Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter2Device As Filter2DeviceFilterDevice()
C#
public Filter2DeviceFilterDevice[] Filter2Device { get; set; }
Visual C++
public:
property array<Filter2DeviceFilterDevice^>^ Filter2Device {
    array<Filter2DeviceFilterDevice^>^ get ();
    void set (array<Filter2DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter2Device();
function set_filter2Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Filter3Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Filter3Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter3Device As Filter3DeviceFilterDevice()
C#
public Filter3DeviceFilterDevice[] Filter3Device { get; set; }
Visual C++
public:
property array<Filter3DeviceFilterDevice^>^ Filter3Device {
    array<Filter3DeviceFilterDevice^>^ get ();
    void set (array<Filter3DeviceFilterDevice^>^ value);
}
JavaScript
function get_filter3Device();
function set_filter3Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


FilterDistortionDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.FilterDistortionDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterDistortionDevice As FilterDistortionDevice()
C#
public FilterDistortionDevice[] FilterDistortionDevice { get; set; }
Visual C++
public:
property array<FilterDistortionDevice^>^ FilterDistortionDevice {
    array<FilterDistortionDevice^>^ get ();
    void set (array<FilterDistortionDevice^>^ value);
}
JavaScript
function get_filterDistortionDevice();
function set_filterDistortionDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


FlangerDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.FlangerDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FlangerDevice As FlangerDevice()
C#
public FlangerDevice[] FlangerDevice { get; set; }
Visual C++
public:
property array<FlangerDevice^>^ FlangerDevice {
    array<FlangerDevice^>^ get ();
    void set (array<FlangerDevice^>^ value);
}
JavaScript
function get_flangerDevice();
function set_flangerDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


GainerDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.GainerDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GainerDevice As GainerDevice()
C#
public GainerDevice[] GainerDevice { get; set; }
Visual C++
public:
property array<GainerDevice^>^ GainerDevice {
    array<GainerDevice^>^ get ();
    void set (array<GainerDevice^>^ value);
}
JavaScript
function get_gainerDevice();
function set_gainerDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Gate2Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Gate2Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gate2Device As Gate2DeviceGateDevice()
C#
public Gate2DeviceGateDevice[] Gate2Device { get; set; }
Visual C++
public:
property array<Gate2DeviceGateDevice^>^ Gate2Device {
    array<Gate2DeviceGateDevice^>^ get ();
    void set (array<Gate2DeviceGateDevice^>^ value);
}
JavaScript
function get_gate2Device();
function set_gate2Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


GateDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.GateDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GateDevice As GateDeviceGateDevice()
C#
public GateDeviceGateDevice[] GateDevice { get; set; }
Visual C++
public:
property array<GateDeviceGateDevice^>^ GateDevice {
    array<GateDeviceGateDevice^>^ get ();
    void set (array<GateDeviceGateDevice^>^ value);
}
JavaScript
function get_gateDevice();
function set_gateDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


InstrumentAutomationDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.InstrumentAutomationDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property InstrumentAutomationDevice As InstrumentAutomationDevice()
C#
public InstrumentAutomationDevice[] InstrumentAutomationDevice { get; set; }
Visual C++
public:
property array<InstrumentAutomationDevice^>^ InstrumentAutomationDevice {
    array<InstrumentAutomationDevice^>^ get ();
    void set (array<InstrumentAutomationDevice^>^ value);
}
JavaScript
function get_instrumentAutomationDevice();
function set_instrumentAutomationDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


LfoDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.LfoDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LfoDevice As LfoDevice()
C#
public LfoDevice[] LfoDevice { get; set; }
Visual C++
public:
property array<LfoDevice^>^ LfoDevice {
    array<LfoDevice^>^ get ();
    void set (array<LfoDevice^>^ value);
}
JavaScript
function get_lfoDevice();
function set_lfoDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


LineInDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.LineInDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LineInDevice As LineInDevice()
C#
public LineInDevice[] LineInDevice { get; set; }
Visual C++
public:
property array<LineInDevice^>^ LineInDevice {
    array<LineInDevice^>^ get ();
    void set (array<LineInDevice^>^ value);
}
JavaScript
function get_lineInDevice();
function set_lineInDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Lofi2Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Lofi2Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lofi2Device As Lofi2DeviceLofiDevice()
C#
public Lofi2DeviceLofiDevice[] Lofi2Device { get; set; }
Visual C++
public:
property array<Lofi2DeviceLofiDevice^>^ Lofi2Device {
    array<Lofi2DeviceLofiDevice^>^ get ();
    void set (array<Lofi2DeviceLofiDevice^>^ value);
}
JavaScript
function get_lofi2Device();
function set_lofi2Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


LofiDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.LofiDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property LofiDevice As LofiDeviceLofiDevice()
C#
public LofiDeviceLofiDevice[] LofiDevice { get; set; }
Visual C++
public:
property array<LofiDeviceLofiDevice^>^ LofiDevice {
    array<LofiDeviceLofiDevice^>^ get ();
    void set (array<LofiDeviceLofiDevice^>^ value);
}
JavaScript
function get_lofiDevice();
function set_lofiDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


MaximizerDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.MaximizerDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MaximizerDevice As MaximizerDevice()
C#
public MaximizerDevice[] MaximizerDevice { get; set; }
Visual C++
public:
property array<MaximizerDevice^>^ MaximizerDevice {
    array<MaximizerDevice^>^ get ();
    void set (array<MaximizerDevice^>^ value);
}
JavaScript
function get_maximizerDevice();
function set_maximizerDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


MidiCCDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.MidiCCDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiCCDevice As MidiCCDevice()
C#
public MidiCCDevice[] MidiCCDevice { get; set; }
Visual C++
public:
property array<MidiCCDevice^>^ MidiCCDevice {
    array<MidiCCDevice^>^ get ();
    void set (array<MidiCCDevice^>^ value);
}
JavaScript
function get_midiCCDevice();
function set_midiCCDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


MixerEqDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.MixerEqDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MixerEqDevice As MixerEqDevice()
C#
public MixerEqDevice[] MixerEqDevice { get; set; }
Visual C++
public:
property array<MixerEqDevice^>^ MixerEqDevice {
    array<MixerEqDevice^>^ get ();
    void set (array<MixerEqDevice^>^ value);
}
JavaScript
function get_mixerEqDevice();
function set_mixerEqDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


PdcTestDelayDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.PdcTestDelayDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PdcTestDelayDevice As PdcTestDelayDevice()
C#
public PdcTestDelayDevice[] PdcTestDelayDevice { get; set; }
Visual C++
public:
property array<PdcTestDelayDevice^>^ PdcTestDelayDevice {
    array<PdcTestDelayDevice^>^ get ();
    void set (array<PdcTestDelayDevice^>^ value);
}
JavaScript
function get_pdcTestDelayDevice();
function set_pdcTestDelayDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


PhaserDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.PhaserDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PhaserDevice As PhaserDevice()
C#
public PhaserDevice[] PhaserDevice { get; set; }
Visual C++
public:
property array<PhaserDevice^>^ PhaserDevice {
    array<PhaserDevice^>^ get ();
    void set (array<PhaserDevice^>^ value);
}
JavaScript
function get_phaserDevice();
function set_phaserDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Reverb2Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Reverb2Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb2Device As Reverb2DeviceReverbDevice()
C#
public Reverb2DeviceReverbDevice[] Reverb2Device { get; set; }
Visual C++
public:
property array<Reverb2DeviceReverbDevice^>^ Reverb2Device {
    array<Reverb2DeviceReverbDevice^>^ get ();
    void set (array<Reverb2DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb2Device();
function set_reverb2Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


Reverb3Device Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.Reverb3Device Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Reverb3Device As Reverb3DeviceReverbDevice()
C#
public Reverb3DeviceReverbDevice[] Reverb3Device { get; set; }
Visual C++
public:
property array<Reverb3DeviceReverbDevice^>^ Reverb3Device {
    array<Reverb3DeviceReverbDevice^>^ get ();
    void set (array<Reverb3DeviceReverbDevice^>^ value);
}
JavaScript
function get_reverb3Device();
function set_reverb3Device(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


ReverbDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.ReverbDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverbDevice As ReverbDeviceReverbDevice()
C#
public ReverbDeviceReverbDevice[] ReverbDevice { get; set; }
Visual C++
public:
property array<ReverbDeviceReverbDevice^>^ ReverbDevice {
    array<ReverbDeviceReverbDevice^>^ get ();
    void set (array<ReverbDeviceReverbDevice^>^ value);
}
JavaScript
function get_reverbDevice();
function set_reverbDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


RingModDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.RingModDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RingModDevice As RingModDevice()
C#
public RingModDevice[] RingModDevice { get; set; }
Visual C++
public:
property array<RingModDevice^>^ RingModDevice {
    array<RingModDevice^>^ get ();
    void set (array<RingModDevice^>^ value);
}
JavaScript
function get_ringModDevice();
function set_ringModDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


SendDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.SendDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SendDevice As SendDevice()
C#
public SendDevice[] SendDevice { get; set; }
Visual C++
public:
property array<SendDevice^>^ SendDevice {
    array<SendDevice^>^ get ();
    void set (array<SendDevice^>^ value);
}
JavaScript
function get_sendDevice();
function set_sendDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


SequencerTrackDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.SequencerTrackDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerTrackDevice As SequencerTrackDevice()
C#
public SequencerTrackDevice[] SequencerTrackDevice { get; set; }
Visual C++
public:
property array<SequencerTrackDevice^>^ SequencerTrackDevice {
    array<SequencerTrackDevice^>^ get ();
    void set (array<SequencerTrackDevice^>^ value);
}
JavaScript
function get_sequencerTrackDevice();
function set_sequencerTrackDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


ShaperDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.ShaperDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ShaperDevice As ShaperDevice()
C#
public ShaperDevice[] ShaperDevice { get; set; }
Visual C++
public:
property array<ShaperDevice^>^ ShaperDevice {
    array<ShaperDevice^>^ get ();
    void set (array<ShaperDevice^>^ value);
}
JavaScript
function get_shaperDevice();
function set_shaperDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


StereoExpanderDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.StereoExpanderDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoExpanderDevice As StereoExpanderDevice()
C#
public StereoExpanderDevice[] StereoExpanderDevice { get; set; }
Visual C++
public:
property array<StereoExpanderDevice^>^ StereoExpanderDevice {
    array<StereoExpanderDevice^>^ get ();
    void set (array<StereoExpanderDevice^>^ value);
}
JavaScript
function get_stereoExpanderDevice();
function set_stereoExpanderDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


VelocityDevice Property

[image]

.NET Framework Class Library
SequencerTrackFilterDevicesDevices..::.VelocityDevice Property
SequencerTrackFilterDevicesDevices Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityDevice As VelocityDevice()
C#
public VelocityDevice[] VelocityDevice { get; set; }
Visual C++
public:
property array<VelocityDevice^>^ VelocityDevice {
    array<VelocityDevice^>^ get ();
    void set (array<VelocityDevice^>^ value);
}
JavaScript
function get_velocityDevice();
function set_velocityDevice(value);

Remarks

See Also

SequencerTrackFilterDevicesDevices Class


SequencerTrackNoteColumnState Enumeration

[image]

.NET Framework Class Library
SequencerTrackNoteColumnState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackNoteColumnState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackNoteColumnState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackNoteColumnState
JavaScript
NRenoiseTools.SequencerTrackNoteColumnState = function();
NRenoiseTools.SequencerTrackNoteColumnState.createEnum('NRenoiseTools.SequencerTrackNoteColumnState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SequencerTrackState Enumeration

[image]

.NET Framework Class Library
SequencerTrackState Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration SequencerTrackState
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum SequencerTrackState
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class SequencerTrackState
JavaScript
NRenoiseTools.SequencerTrackState = function();
NRenoiseTools.SequencerTrackState.createEnum('NRenoiseTools.SequencerTrackState', false);

Members

Member name | Description
Active |
Off |
Mute |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ShaperDevice Class

[image]

.NET Framework Class Library
ShaperDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDevice
JavaScript
NRenoiseTools.ShaperDevice = function();

Type.createClass(
    'NRenoiseTools.ShaperDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDevice

See Also

ShaperDevice Members


ShaperDevice Members

[image] [image]

.NET Framework Class Library
ShaperDevice Members
ShaperDevice Class Constructors Methods Properties See Also Send Feedback

The ShaperDevice type exposes the following members.

Constructors

Name | Description
ShaperDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Gain |
IsActive |
IsSelected |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

ShaperDevice Class


ShaperDevice Constructor

[image]

.NET Framework Class Library
ShaperDevice Constructor
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDevice()
Visual C++
public:
ShaperDevice()
JavaScript
NRenoiseTools.ShaperDevice = function();

See Also

ShaperDevice Class


ShaperDevice Methods

[image] [image]

.NET Framework Class Library
ShaperDevice Methods
ShaperDevice Class See Also Send Feedback

The ShaperDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDevice Class


ShaperDevice Properties

[image] [image]

.NET Framework Class Library
ShaperDevice Properties
ShaperDevice Class See Also Send Feedback

The ShaperDevice type exposes the following members.

Properties

Name | Description
Attack |
Gain |
IsActive |
IsSelected |
Ratio |
Release |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
Threshold |
type |

See Also

ShaperDevice Class


Attack Property

[image]

.NET Framework Class Library
ShaperDevice..::.Attack Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As ShaperDeviceAttack
C#
public ShaperDeviceAttack Attack { get; set; }
Visual C++
public:
property ShaperDeviceAttack^ Attack {
    ShaperDeviceAttack^ get ();
    void set (ShaperDeviceAttack^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

ShaperDevice Class


Gain Property

[image]

.NET Framework Class Library
ShaperDevice..::.Gain Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As ShaperDeviceGain
C#
public ShaperDeviceGain Gain { get; set; }
Visual C++
public:
property ShaperDeviceGain^ Gain {
    ShaperDeviceGain^ get ();
    void set (ShaperDeviceGain^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

ShaperDevice Class


IsActive Property

[image]

.NET Framework Class Library
ShaperDevice..::.IsActive Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

ShaperDevice Class


IsSelected Property

[image]

.NET Framework Class Library
ShaperDevice..::.IsSelected Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

ShaperDevice Class


Ratio Property

[image]

.NET Framework Class Library
ShaperDevice..::.Ratio Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As ShaperDeviceRatio
C#
public ShaperDeviceRatio Ratio { get; set; }
Visual C++
public:
property ShaperDeviceRatio^ Ratio {
    ShaperDeviceRatio^ get ();
    void set (ShaperDeviceRatio^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

ShaperDevice Class


Release Property

[image]

.NET Framework Class Library
ShaperDevice..::.Release Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As ShaperDeviceRelease
C#
public ShaperDeviceRelease Release { get; set; }
Visual C++
public:
property ShaperDeviceRelease^ Release {
    ShaperDeviceRelease^ get ();
    void set (ShaperDeviceRelease^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

ShaperDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
ShaperDevice..::.RunTimePresetA Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As ShaperDeviceRunTimePreset
C#
public ShaperDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property ShaperDeviceRunTimePreset^ RunTimePresetA {
    ShaperDeviceRunTimePreset^ get ();
    void set (ShaperDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

ShaperDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
ShaperDevice..::.RunTimePresetB Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As ShaperDeviceRunTimePreset
C#
public ShaperDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property ShaperDeviceRunTimePreset^ RunTimePresetB {
    ShaperDeviceRunTimePreset^ get ();
    void set (ShaperDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

ShaperDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
ShaperDevice..::.SelectedPresetIsModified Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

ShaperDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
ShaperDevice..::.SelectedPresetName Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

ShaperDevice Class


Threshold Property

[image]

.NET Framework Class Library
ShaperDevice..::.Threshold Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As ShaperDeviceThreshold
C#
public ShaperDeviceThreshold Threshold { get; set; }
Visual C++
public:
property ShaperDeviceThreshold^ Threshold {
    ShaperDeviceThreshold^ get ();
    void set (ShaperDeviceThreshold^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

ShaperDevice Class


type Property

[image]

.NET Framework Class Library
ShaperDevice..::.type Property
ShaperDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ShaperDevice Class


ShaperDeviceAttack Class

[image]

.NET Framework Class Library
ShaperDeviceAttack Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceAttack
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceAttack
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceAttack
JavaScript
NRenoiseTools.ShaperDeviceAttack = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceAttack');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceAttack

See Also

ShaperDeviceAttack Members


ShaperDeviceAttack Members

[image] [image]

.NET Framework Class Library
ShaperDeviceAttack Members
ShaperDeviceAttack Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceAttack type exposes the following members.

Constructors

Name | Description
ShaperDeviceAttack |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceAttack Class


ShaperDeviceAttack Constructor

[image]

.NET Framework Class Library
ShaperDeviceAttack Constructor
ShaperDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceAttack()
Visual C++
public:
ShaperDeviceAttack()
JavaScript
NRenoiseTools.ShaperDeviceAttack = function();

See Also

ShaperDeviceAttack Class


ShaperDeviceAttack Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceAttack Methods
ShaperDeviceAttack Class See Also Send Feedback

The ShaperDeviceAttack type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceAttack Class


ShaperDeviceAttack Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceAttack Properties
ShaperDeviceAttack Class See Also Send Feedback

The ShaperDeviceAttack type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceAttack Class


MidiMappings Property

[image]

.NET Framework Class Library
ShaperDeviceAttack..::.MidiMappings Property
ShaperDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ShaperDeviceAttack Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceAttack..::.Value Property
ShaperDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceAttack Class


Visualization Property

[image]

.NET Framework Class Library
ShaperDeviceAttack..::.Visualization Property
ShaperDeviceAttack Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ShaperDeviceAttackVisualization
C#
public ShaperDeviceAttackVisualization Visualization { get; set; }
Visual C++
public:
property ShaperDeviceAttackVisualization Visualization {
    ShaperDeviceAttackVisualization get ();
    void set (ShaperDeviceAttackVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ShaperDeviceAttack Class


ShaperDeviceAttackRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceAttackRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceAttackRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceAttackRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceAttackRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceAttackRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceAttackRunTimePreset

See Also

ShaperDeviceAttackRunTimePreset Members


ShaperDeviceAttackRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset Members
ShaperDeviceAttackRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceAttackRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceAttackRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ShaperDeviceAttackRunTimePreset Class


ShaperDeviceAttackRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset Constructor
ShaperDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceAttackRunTimePreset()
Visual C++
public:
ShaperDeviceAttackRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceAttackRunTimePreset = function();

See Also

ShaperDeviceAttackRunTimePreset Class


ShaperDeviceAttackRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset Methods
ShaperDeviceAttackRunTimePreset Class See Also Send Feedback

The ShaperDeviceAttackRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceAttackRunTimePreset Class


ShaperDeviceAttackRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset Properties
ShaperDeviceAttackRunTimePreset Class See Also Send Feedback

The ShaperDeviceAttackRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ShaperDeviceAttackRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceAttackRunTimePreset..::.Value Property
ShaperDeviceAttackRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceAttackRunTimePreset Class


ShaperDeviceAttackVisualization Enumeration

[image]

.NET Framework Class Library
ShaperDeviceAttackVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ShaperDeviceAttackVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ShaperDeviceAttackVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ShaperDeviceAttackVisualization
JavaScript
NRenoiseTools.ShaperDeviceAttackVisualization = function();
NRenoiseTools.ShaperDeviceAttackVisualization.createEnum('NRenoiseTools.ShaperDeviceAttackVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ShaperDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceDeviceSlotRunTimePreset

See Also

ShaperDeviceDeviceSlotRunTimePreset Members


ShaperDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset Members
ShaperDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attack |
Gain |
Ratio |
Release |
Threshold |
type |

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


ShaperDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset Constructor
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceDeviceSlotRunTimePreset()
Visual C++
public:
ShaperDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceDeviceSlotRunTimePreset = function();

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


ShaperDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset Methods
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ShaperDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


ShaperDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset Properties
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The ShaperDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
Attack |
Gain |
Ratio |
Release |
Threshold |
type |

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


Attack Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.Attack Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Attack As ShaperDeviceAttackRunTimePreset
C#
public ShaperDeviceAttackRunTimePreset Attack { get; set; }
Visual C++
public:
property ShaperDeviceAttackRunTimePreset^ Attack {
    ShaperDeviceAttackRunTimePreset^ get ();
    void set (ShaperDeviceAttackRunTimePreset^ value);
}
JavaScript
function get_attack();
function set_attack(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


Gain Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.Gain Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Gain As ShaperDeviceGainRunTimePreset
C#
public ShaperDeviceGainRunTimePreset Gain { get; set; }
Visual C++
public:
property ShaperDeviceGainRunTimePreset^ Gain {
    ShaperDeviceGainRunTimePreset^ get ();
    void set (ShaperDeviceGainRunTimePreset^ value);
}
JavaScript
function get_gain();
function set_gain(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


Ratio Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.Ratio Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Ratio As ShaperDeviceRatioRunTimePreset
C#
public ShaperDeviceRatioRunTimePreset Ratio { get; set; }
Visual C++
public:
property ShaperDeviceRatioRunTimePreset^ Ratio {
    ShaperDeviceRatioRunTimePreset^ get ();
    void set (ShaperDeviceRatioRunTimePreset^ value);
}
JavaScript
function get_ratio();
function set_ratio(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


Release Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.Release Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Release As ShaperDeviceReleaseRunTimePreset
C#
public ShaperDeviceReleaseRunTimePreset Release { get; set; }
Visual C++
public:
property ShaperDeviceReleaseRunTimePreset^ Release {
    ShaperDeviceReleaseRunTimePreset^ get ();
    void set (ShaperDeviceReleaseRunTimePreset^ value);
}
JavaScript
function get_release();
function set_release(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


Threshold Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.Threshold Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Threshold As ShaperDeviceThresholdRunTimePreset
C#
public ShaperDeviceThresholdRunTimePreset Threshold { get; set; }
Visual C++
public:
property ShaperDeviceThresholdRunTimePreset^ Threshold {
    ShaperDeviceThresholdRunTimePreset^ get ();
    void set (ShaperDeviceThresholdRunTimePreset^ value);
}
JavaScript
function get_threshold();
function set_threshold(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ShaperDeviceDeviceSlotRunTimePreset..::.type Property
ShaperDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ShaperDeviceDeviceSlotRunTimePreset Class


ShaperDeviceGain Class

[image]

.NET Framework Class Library
ShaperDeviceGain Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceGain
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceGain
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceGain
JavaScript
NRenoiseTools.ShaperDeviceGain = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceGain');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceGain

See Also

ShaperDeviceGain Members


ShaperDeviceGain Members

[image] [image]

.NET Framework Class Library
ShaperDeviceGain Members
ShaperDeviceGain Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceGain type exposes the following members.

Constructors

Name | Description
ShaperDeviceGain |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceGain Class


ShaperDeviceGain Constructor

[image]

.NET Framework Class Library
ShaperDeviceGain Constructor
ShaperDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceGain()
Visual C++
public:
ShaperDeviceGain()
JavaScript
NRenoiseTools.ShaperDeviceGain = function();

See Also

ShaperDeviceGain Class


ShaperDeviceGain Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceGain Methods
ShaperDeviceGain Class See Also Send Feedback

The ShaperDeviceGain type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceGain Class


ShaperDeviceGain Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceGain Properties
ShaperDeviceGain Class See Also Send Feedback

The ShaperDeviceGain type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceGain Class


MidiMappings Property

[image]

.NET Framework Class Library
ShaperDeviceGain..::.MidiMappings Property
ShaperDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ShaperDeviceGain Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceGain..::.Value Property
ShaperDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceGain Class


Visualization Property

[image]

.NET Framework Class Library
ShaperDeviceGain..::.Visualization Property
ShaperDeviceGain Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ShaperDeviceGainVisualization
C#
public ShaperDeviceGainVisualization Visualization { get; set; }
Visual C++
public:
property ShaperDeviceGainVisualization Visualization {
    ShaperDeviceGainVisualization get ();
    void set (ShaperDeviceGainVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ShaperDeviceGain Class


ShaperDeviceGainRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceGainRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceGainRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceGainRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceGainRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceGainRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceGainRunTimePreset

See Also

ShaperDeviceGainRunTimePreset Members


ShaperDeviceGainRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset Members
ShaperDeviceGainRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceGainRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceGainRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ShaperDeviceGainRunTimePreset Class


ShaperDeviceGainRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset Constructor
ShaperDeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceGainRunTimePreset()
Visual C++
public:
ShaperDeviceGainRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceGainRunTimePreset = function();

See Also

ShaperDeviceGainRunTimePreset Class


ShaperDeviceGainRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset Methods
ShaperDeviceGainRunTimePreset Class See Also Send Feedback

The ShaperDeviceGainRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceGainRunTimePreset Class


ShaperDeviceGainRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset Properties
ShaperDeviceGainRunTimePreset Class See Also Send Feedback

The ShaperDeviceGainRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ShaperDeviceGainRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceGainRunTimePreset..::.Value Property
ShaperDeviceGainRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceGainRunTimePreset Class


ShaperDeviceGainVisualization Enumeration

[image]

.NET Framework Class Library
ShaperDeviceGainVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ShaperDeviceGainVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ShaperDeviceGainVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ShaperDeviceGainVisualization
JavaScript
NRenoiseTools.ShaperDeviceGainVisualization = function();
NRenoiseTools.ShaperDeviceGainVisualization.createEnum('NRenoiseTools.ShaperDeviceGainVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ShaperDeviceRatio Class

[image]

.NET Framework Class Library
ShaperDeviceRatio Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceRatio
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceRatio
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceRatio
JavaScript
NRenoiseTools.ShaperDeviceRatio = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceRatio');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceRatio

See Also

ShaperDeviceRatio Members


ShaperDeviceRatio Members

[image] [image]

.NET Framework Class Library
ShaperDeviceRatio Members
ShaperDeviceRatio Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceRatio type exposes the following members.

Constructors

Name | Description
ShaperDeviceRatio |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceRatio Class


ShaperDeviceRatio Constructor

[image]

.NET Framework Class Library
ShaperDeviceRatio Constructor
ShaperDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceRatio()
Visual C++
public:
ShaperDeviceRatio()
JavaScript
NRenoiseTools.ShaperDeviceRatio = function();

See Also

ShaperDeviceRatio Class


ShaperDeviceRatio Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceRatio Methods
ShaperDeviceRatio Class See Also Send Feedback

The ShaperDeviceRatio type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceRatio Class


ShaperDeviceRatio Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceRatio Properties
ShaperDeviceRatio Class See Also Send Feedback

The ShaperDeviceRatio type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceRatio Class


MidiMappings Property

[image]

.NET Framework Class Library
ShaperDeviceRatio..::.MidiMappings Property
ShaperDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ShaperDeviceRatio Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceRatio..::.Value Property
ShaperDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceRatio Class


Visualization Property

[image]

.NET Framework Class Library
ShaperDeviceRatio..::.Visualization Property
ShaperDeviceRatio Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ShaperDeviceRatioVisualization
C#
public ShaperDeviceRatioVisualization Visualization { get; set; }
Visual C++
public:
property ShaperDeviceRatioVisualization Visualization {
    ShaperDeviceRatioVisualization get ();
    void set (ShaperDeviceRatioVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ShaperDeviceRatio Class


ShaperDeviceRatioRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceRatioRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceRatioRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceRatioRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceRatioRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceRatioRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceRatioRunTimePreset

See Also

ShaperDeviceRatioRunTimePreset Members


ShaperDeviceRatioRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset Members
ShaperDeviceRatioRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceRatioRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceRatioRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ShaperDeviceRatioRunTimePreset Class


ShaperDeviceRatioRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset Constructor
ShaperDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceRatioRunTimePreset()
Visual C++
public:
ShaperDeviceRatioRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceRatioRunTimePreset = function();

See Also

ShaperDeviceRatioRunTimePreset Class


ShaperDeviceRatioRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset Methods
ShaperDeviceRatioRunTimePreset Class See Also Send Feedback

The ShaperDeviceRatioRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceRatioRunTimePreset Class


ShaperDeviceRatioRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset Properties
ShaperDeviceRatioRunTimePreset Class See Also Send Feedback

The ShaperDeviceRatioRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ShaperDeviceRatioRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceRatioRunTimePreset..::.Value Property
ShaperDeviceRatioRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceRatioRunTimePreset Class


ShaperDeviceRatioVisualization Enumeration

[image]

.NET Framework Class Library
ShaperDeviceRatioVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ShaperDeviceRatioVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ShaperDeviceRatioVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ShaperDeviceRatioVisualization
JavaScript
NRenoiseTools.ShaperDeviceRatioVisualization = function();
NRenoiseTools.ShaperDeviceRatioVisualization.createEnum('NRenoiseTools.ShaperDeviceRatioVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ShaperDeviceRelease Class

[image]

.NET Framework Class Library
ShaperDeviceRelease Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceRelease
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceRelease
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceRelease
JavaScript
NRenoiseTools.ShaperDeviceRelease = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceRelease');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceRelease

See Also

ShaperDeviceRelease Members


ShaperDeviceRelease Members

[image] [image]

.NET Framework Class Library
ShaperDeviceRelease Members
ShaperDeviceRelease Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceRelease type exposes the following members.

Constructors

Name | Description
ShaperDeviceRelease |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceRelease Class


ShaperDeviceRelease Constructor

[image]

.NET Framework Class Library
ShaperDeviceRelease Constructor
ShaperDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceRelease()
Visual C++
public:
ShaperDeviceRelease()
JavaScript
NRenoiseTools.ShaperDeviceRelease = function();

See Also

ShaperDeviceRelease Class


ShaperDeviceRelease Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceRelease Methods
ShaperDeviceRelease Class See Also Send Feedback

The ShaperDeviceRelease type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceRelease Class


ShaperDeviceRelease Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceRelease Properties
ShaperDeviceRelease Class See Also Send Feedback

The ShaperDeviceRelease type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceRelease Class


MidiMappings Property

[image]

.NET Framework Class Library
ShaperDeviceRelease..::.MidiMappings Property
ShaperDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ShaperDeviceRelease Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceRelease..::.Value Property
ShaperDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceRelease Class


Visualization Property

[image]

.NET Framework Class Library
ShaperDeviceRelease..::.Visualization Property
ShaperDeviceRelease Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ShaperDeviceReleaseVisualization
C#
public ShaperDeviceReleaseVisualization Visualization { get; set; }
Visual C++
public:
property ShaperDeviceReleaseVisualization Visualization {
    ShaperDeviceReleaseVisualization get ();
    void set (ShaperDeviceReleaseVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ShaperDeviceRelease Class


ShaperDeviceReleaseRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceReleaseRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceReleaseRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceReleaseRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceReleaseRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceReleaseRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceReleaseRunTimePreset

See Also

ShaperDeviceReleaseRunTimePreset Members


ShaperDeviceReleaseRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset Members
ShaperDeviceReleaseRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceReleaseRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceReleaseRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ShaperDeviceReleaseRunTimePreset Class


ShaperDeviceReleaseRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset Constructor
ShaperDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceReleaseRunTimePreset()
Visual C++
public:
ShaperDeviceReleaseRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceReleaseRunTimePreset = function();

See Also

ShaperDeviceReleaseRunTimePreset Class


ShaperDeviceReleaseRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset Methods
ShaperDeviceReleaseRunTimePreset Class See Also Send Feedback

The ShaperDeviceReleaseRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceReleaseRunTimePreset Class


ShaperDeviceReleaseRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset Properties
ShaperDeviceReleaseRunTimePreset Class See Also Send Feedback

The ShaperDeviceReleaseRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ShaperDeviceReleaseRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceReleaseRunTimePreset..::.Value Property
ShaperDeviceReleaseRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceReleaseRunTimePreset Class


ShaperDeviceReleaseVisualization Enumeration

[image]

.NET Framework Class Library
ShaperDeviceReleaseVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ShaperDeviceReleaseVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ShaperDeviceReleaseVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ShaperDeviceReleaseVisualization
JavaScript
NRenoiseTools.ShaperDeviceReleaseVisualization = function();
NRenoiseTools.ShaperDeviceReleaseVisualization.createEnum('NRenoiseTools.ShaperDeviceReleaseVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


ShaperDeviceRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceRunTimePreset

See Also

ShaperDeviceRunTimePreset Members


ShaperDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceRunTimePreset Members
ShaperDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

ShaperDeviceRunTimePreset Class


ShaperDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceRunTimePreset Constructor
ShaperDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceRunTimePreset()
Visual C++
public:
ShaperDeviceRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceRunTimePreset = function();

See Also

ShaperDeviceRunTimePreset Class


ShaperDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceRunTimePreset Methods
ShaperDeviceRunTimePreset Class See Also Send Feedback

The ShaperDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceRunTimePreset Class


ShaperDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceRunTimePreset Properties
ShaperDeviceRunTimePreset Class See Also Send Feedback

The ShaperDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

ShaperDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
ShaperDeviceRunTimePreset..::.DeviceSlot Property
ShaperDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As ShaperDeviceDeviceSlotRunTimePreset
C#
public ShaperDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property ShaperDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    ShaperDeviceDeviceSlotRunTimePreset^ get ();
    void set (ShaperDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

ShaperDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
ShaperDeviceRunTimePreset..::.type Property
ShaperDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

ShaperDeviceRunTimePreset Class


ShaperDeviceThreshold Class

[image]

.NET Framework Class Library
ShaperDeviceThreshold Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceThreshold
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceThreshold
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceThreshold
JavaScript
NRenoiseTools.ShaperDeviceThreshold = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceThreshold');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceThreshold

See Also

ShaperDeviceThreshold Members


ShaperDeviceThreshold Members

[image] [image]

.NET Framework Class Library
ShaperDeviceThreshold Members
ShaperDeviceThreshold Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceThreshold type exposes the following members.

Constructors

Name | Description
ShaperDeviceThreshold |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceThreshold Class


ShaperDeviceThreshold Constructor

[image]

.NET Framework Class Library
ShaperDeviceThreshold Constructor
ShaperDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceThreshold()
Visual C++
public:
ShaperDeviceThreshold()
JavaScript
NRenoiseTools.ShaperDeviceThreshold = function();

See Also

ShaperDeviceThreshold Class


ShaperDeviceThreshold Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceThreshold Methods
ShaperDeviceThreshold Class See Also Send Feedback

The ShaperDeviceThreshold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceThreshold Class


ShaperDeviceThreshold Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceThreshold Properties
ShaperDeviceThreshold Class See Also Send Feedback

The ShaperDeviceThreshold type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

ShaperDeviceThreshold Class


MidiMappings Property

[image]

.NET Framework Class Library
ShaperDeviceThreshold..::.MidiMappings Property
ShaperDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

ShaperDeviceThreshold Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceThreshold..::.Value Property
ShaperDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceThreshold Class


Visualization Property

[image]

.NET Framework Class Library
ShaperDeviceThreshold..::.Visualization Property
ShaperDeviceThreshold Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As ShaperDeviceThresholdVisualization
C#
public ShaperDeviceThresholdVisualization Visualization { get; set; }
Visual C++
public:
property ShaperDeviceThresholdVisualization Visualization {
    ShaperDeviceThresholdVisualization get ();
    void set (ShaperDeviceThresholdVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

ShaperDeviceThreshold Class


ShaperDeviceThresholdRunTimePreset Class

[image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class ShaperDeviceThresholdRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class ShaperDeviceThresholdRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class ShaperDeviceThresholdRunTimePreset
JavaScript
NRenoiseTools.ShaperDeviceThresholdRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.ShaperDeviceThresholdRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.ShaperDeviceThresholdRunTimePreset

See Also

ShaperDeviceThresholdRunTimePreset Members


ShaperDeviceThresholdRunTimePreset Members

[image] [image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset Members
ShaperDeviceThresholdRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The ShaperDeviceThresholdRunTimePreset type exposes the following members.

Constructors

Name | Description
ShaperDeviceThresholdRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

ShaperDeviceThresholdRunTimePreset Class


ShaperDeviceThresholdRunTimePreset Constructor

[image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset Constructor
ShaperDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShaperDeviceThresholdRunTimePreset()
Visual C++
public:
ShaperDeviceThresholdRunTimePreset()
JavaScript
NRenoiseTools.ShaperDeviceThresholdRunTimePreset = function();

See Also

ShaperDeviceThresholdRunTimePreset Class


ShaperDeviceThresholdRunTimePreset Methods

[image] [image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset Methods
ShaperDeviceThresholdRunTimePreset Class See Also Send Feedback

The ShaperDeviceThresholdRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShaperDeviceThresholdRunTimePreset Class


ShaperDeviceThresholdRunTimePreset Properties

[image] [image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset Properties
ShaperDeviceThresholdRunTimePreset Class See Also Send Feedback

The ShaperDeviceThresholdRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

ShaperDeviceThresholdRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
ShaperDeviceThresholdRunTimePreset..::.Value Property
ShaperDeviceThresholdRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

ShaperDeviceThresholdRunTimePreset Class


ShaperDeviceThresholdVisualization Enumeration

[image]

.NET Framework Class Library
ShaperDeviceThresholdVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration ShaperDeviceThresholdVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum ShaperDeviceThresholdVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class ShaperDeviceThresholdVisualization
JavaScript
NRenoiseTools.ShaperDeviceThresholdVisualization = function();
NRenoiseTools.ShaperDeviceThresholdVisualization.createEnum('NRenoiseTools.ShaperDeviceThresholdVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


Song Class

[image]

.NET Framework Class Library
Song Class
Members See Also Send Feedback

Main Renoise Song class. Use this class to create and manipulate Renoise Song.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class Song _
    Inherits SongBase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class Song : SongBase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Song : public SongBase
JavaScript
NRenoiseTools.Song = function();

Type.createClass(
    'NRenoiseTools.Song',
    NRenoiseTools.SongBase);

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongBase
NRenoiseTools..::.Song
NRenoiseTools..::.RenoiseSong

See Also

Song Members


Song Members

[image] [image]

.NET Framework Class Library
Song Members
Song Class Constructors Methods Properties See Also Send Feedback

The Song type exposes the following members.

Constructors

Name | Description
Song | Initializes a new instance of the Song class.

Methods

Name | Description
Copy | Copies this song to another song.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FileName | Gets or sets the name of the file used to store the RenoiseSong. This property is set when loading song from a file Load(String).
GlobalSongData | (Inherited from SongBase.)
Instruments | (Inherited from SongBase.)
PatternPool | (Inherited from SongBase.)
PatternSequence | (Inherited from SongBase.)
RecordManager | (Inherited from SongBase.)
SelectedInstrumentIndex | (Inherited from SongBase.)
SelectedSampleIndex | (Inherited from SongBase.)
SelectedTrackIndex | (Inherited from SongBase.)
Tracks | (Inherited from SongBase.)

See Also

Song Class


Song Constructor

[image]

.NET Framework Class Library
Song Constructor
Song Class See Also Send Feedback

Initializes a new instance of the Song class.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Song()
Visual C++
public:
Song()
JavaScript
NRenoiseTools.Song = function();

See Also

Song Class


Song Methods

[image] [image]

.NET Framework Class Library
Song Methods
Song Class See Also Send Feedback

The Song type exposes the following members.

Methods

Name | Description
Copy | Copies this song to another song.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Song Class


Copy Method

[image]

.NET Framework Class Library
Song..::.Copy Method
Song Class See Also Send Feedback

Copies this song to another song.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Copy ( _
    toSong As Song _
)
C#
public void Copy(
    Song toSong
)
Visual C++
public:
void Copy(
    Song^ toSong
)
JavaScript
function copy(toSong);

Parameters

toSong
Type: NRenoiseTools..::.Song
song to copy to.

See Also

Song Class


Load Method

[image] [image]

.NET Framework Class Library
Song..::.Load Method
Song Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads a xrns Renoise song from a specified stream.
Load(String) | Loads a xrns Renoise song from a specified file name.

See Also

Song Class
Song Members


Load Method (Stream)

[image]

.NET Framework Class Library
Song..::.Load Method (Stream)
Song Class See Also Send Feedback

Loads a xrns Renoise song from a specified stream.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load ( _
    xrnsInputStream As Stream _
)
C#
public void Load(
    Stream xrnsInputStream
)
Visual C++
public:
void Load(
    Stream^ xrnsInputStream
)
JavaScript
function load(xrnsInputStream);

Parameters

xrnsInputStream
Type: System.IO..::.Stream
The XRNS input stream.

See Also

Song Class
Load Overload


Load Method (String)

[image]

.NET Framework Class Library
Song..::.Load Method (String)
Song Class See Also Send Feedback

Loads a xrns Renoise song from a specified file name.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load ( _
    fileNameArg As String _
)
C#
public void Load(
    string fileNameArg
)
Visual C++
public:
void Load(
    String^ fileNameArg
)
JavaScript
function load(fileNameArg);

Parameters

fileNameArg
Type: System..::.String
Name of the xrns Renoise file.

See Also

Song Class
Load Overload


Save Method

[image] [image]

.NET Framework Class Library
Song..::.Save Method
Song Class See Also Send Feedback

Overload List

Name | Description
Save()()() | Writes this xrns Renoise song to a specified output file.
Save(Stream) | Writes this xrns Renoise song from a specified output stream.
Save(String) | Writes this xrns Renoise song to a specified output file.

See Also

Song Class
Song Members


Save Method

[image]

.NET Framework Class Library
Song..::.Save Method
Song Class See Also Send Feedback

Writes this xrns Renoise song to a specified output file.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save
C#
public void Save()
Visual C++
public:
void Save()
JavaScript
function save();

See Also

Song Class
Save Overload


Save Method (Stream)

[image]

.NET Framework Class Library
Song..::.Save Method (Stream)
Song Class See Also Send Feedback

Writes this xrns Renoise song from a specified output stream.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save ( _
    xrnsOutputStream As Stream _
)
C#
public void Save(
    Stream xrnsOutputStream
)
Visual C++
public:
void Save(
    Stream^ xrnsOutputStream
)
JavaScript
function save(xrnsOutputStream);

Parameters

xrnsOutputStream
Type: System.IO..::.Stream
The XRNS output stream.

See Also

Song Class
Save Overload


Save Method (String)

[image]

.NET Framework Class Library
Song..::.Save Method (String)
Song Class See Also Send Feedback

Writes this xrns Renoise song to a specified output file.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
C#
public void Save(
    string fileName
)
Visual C++
public:
void Save(
    String^ fileName
)
JavaScript
function save(fileName);

Parameters

fileName
Type: System..::.String
Name of the file.

See Also

Song Class
Save Overload


Song Properties

[image] [image]

.NET Framework Class Library
Song Properties
Song Class See Also Send Feedback

The Song type exposes the following members.

Properties

Name | Description
FileName | Gets or sets the name of the file used to store the RenoiseSong. This property is set when loading song from a file Load(String).
GlobalSongData | (Inherited from SongBase.)
Instruments | (Inherited from SongBase.)
PatternPool | (Inherited from SongBase.)
PatternSequence | (Inherited from SongBase.)
RecordManager | (Inherited from SongBase.)
SelectedInstrumentIndex | (Inherited from SongBase.)
SelectedSampleIndex | (Inherited from SongBase.)
SelectedTrackIndex | (Inherited from SongBase.)
Tracks | (Inherited from SongBase.)

See Also

Song Class


FileName Property

[image]

.NET Framework Class Library
Song..::.FileName Property
Song Class See Also Send Feedback

Gets or sets the name of the file used to store the RenoiseSong. This property is set when loading song from a file Load(String).

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

Field Value

The name of the file.

See Also

Song Class


SongBase Class

[image]

.NET Framework Class Library
SongBase Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public MustInherit Class SongBase
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public abstract class SongBase
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SongBase abstract
JavaScript
NRenoiseTools.SongBase = function();

Type.createClass(
    'NRenoiseTools.SongBase');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongBase
NRenoiseTools..::.Song

See Also

SongBase Members


SongBase Members

[image] [image]

.NET Framework Class Library
SongBase Members
SongBase Class Constructors Methods Properties See Also Send Feedback

The SongBase type exposes the following members.

Constructors

Name | Description
SongBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GlobalSongData |
Instruments |
PatternPool |
PatternSequence |
RecordManager |
SelectedInstrumentIndex |
SelectedSampleIndex |
SelectedTrackIndex |
Tracks |

See Also

SongBase Class


SongBase Constructor

[image]

.NET Framework Class Library
SongBase Constructor
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SongBase()
Visual C++
public:
SongBase()
JavaScript
NRenoiseTools.SongBase = function();

See Also

SongBase Class


SongBase Methods

[image] [image]

.NET Framework Class Library
SongBase Methods
SongBase Class See Also Send Feedback

The SongBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SongBase Class


SongBase Properties

[image] [image]

.NET Framework Class Library
SongBase Properties
SongBase Class See Also Send Feedback

The SongBase type exposes the following members.

Properties

Name | Description
GlobalSongData |
Instruments |
PatternPool |
PatternSequence |
RecordManager |
SelectedInstrumentIndex |
SelectedSampleIndex |
SelectedTrackIndex |
Tracks |

See Also

SongBase Class


GlobalSongData Property

[image]

.NET Framework Class Library
SongBase..::.GlobalSongData Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property GlobalSongData As GlobalSongData
C#
public GlobalSongData GlobalSongData { get; set; }
Visual C++
public:
property GlobalSongData^ GlobalSongData {
    GlobalSongData^ get ();
    void set (GlobalSongData^ value);
}
JavaScript
function get_globalSongData();
function set_globalSongData(value);

Remarks

See Also

SongBase Class


Instruments Property

[image]

.NET Framework Class Library
SongBase..::.Instruments Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Instruments As Instrument()
C#
public Instrument[] Instruments { get; set; }
Visual C++
public:
property array<Instrument^>^ Instruments {
    array<Instrument^>^ get ();
    void set (array<Instrument^>^ value);
}
JavaScript
function get_instruments();
function set_instruments(value);

Remarks

See Also

SongBase Class


PatternPool Property

[image]

.NET Framework Class Library
SongBase..::.PatternPool Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternPool As PatternPool
C#
public PatternPool PatternPool { get; set; }
Visual C++
public:
property PatternPool^ PatternPool {
    PatternPool^ get ();
    void set (PatternPool^ value);
}
JavaScript
function get_patternPool();
function set_patternPool(value);

Remarks

See Also

SongBase Class


PatternSequence Property

[image]

.NET Framework Class Library
SongBase..::.PatternSequence Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PatternSequence As PatternSequenceData
C#
public PatternSequenceData PatternSequence { get; set; }
Visual C++
public:
property PatternSequenceData^ PatternSequence {
    PatternSequenceData^ get ();
    void set (PatternSequenceData^ value);
}
JavaScript
function get_patternSequence();
function set_patternSequence(value);

Remarks

See Also

SongBase Class


RecordManager Property

[image]

.NET Framework Class Library
SongBase..::.RecordManager Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RecordManager As RecordManager
C#
public RecordManager RecordManager { get; set; }
Visual C++
public:
property RecordManager^ RecordManager {
    RecordManager^ get ();
    void set (RecordManager^ value);
}
JavaScript
function get_recordManager();
function set_recordManager(value);

Remarks

See Also

SongBase Class


SelectedInstrumentIndex Property

[image]

.NET Framework Class Library
SongBase..::.SelectedInstrumentIndex Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedInstrumentIndex As Integer
C#
public int SelectedInstrumentIndex { get; set; }
Visual C++
public:
property int SelectedInstrumentIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_selectedInstrumentIndex();
function set_selectedInstrumentIndex(value);

Remarks

See Also

SongBase Class


SelectedSampleIndex Property

[image]

.NET Framework Class Library
SongBase..::.SelectedSampleIndex Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedSampleIndex As Integer
C#
public int SelectedSampleIndex { get; set; }
Visual C++
public:
property int SelectedSampleIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_selectedSampleIndex();
function set_selectedSampleIndex(value);

Remarks

See Also

SongBase Class


SelectedTrackIndex Property

[image]

.NET Framework Class Library
SongBase..::.SelectedTrackIndex Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedTrackIndex As Integer
C#
public int SelectedTrackIndex { get; set; }
Visual C++
public:
property int SelectedTrackIndex {
    int get ();
    void set (int value);
}
JavaScript
function get_selectedTrackIndex();
function set_selectedTrackIndex(value);

Remarks

See Also

SongBase Class


Tracks Property

[image]

.NET Framework Class Library
SongBase..::.Tracks Property
SongBase Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Tracks As SongBaseTracks
C#
public SongBaseTracks Tracks { get; set; }
Visual C++
public:
property SongBaseTracks^ Tracks {
    SongBaseTracks^ get ();
    void set (SongBaseTracks^ value);
}
JavaScript
function get_tracks();
function set_tracks(value);

Remarks

See Also

SongBase Class


SongBaseTracks Class

[image]

.NET Framework Class Library
SongBaseTracks Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class SongBaseTracks
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class SongBaseTracks
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class SongBaseTracks
JavaScript
NRenoiseTools.SongBaseTracks = function();

Type.createClass(
    'NRenoiseTools.SongBaseTracks');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongBaseTracks

See Also

SongBaseTracks Members


SongBaseTracks Members

[image] [image]

.NET Framework Class Library
SongBaseTracks Members
SongBaseTracks Class Constructors Methods Properties See Also Send Feedback

The SongBaseTracks type exposes the following members.

Constructors

Name | Description
SongBaseTracks |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SequencerMasterTrack |
SequencerSendTrack |
SequencerTrack |

See Also

SongBaseTracks Class


SongBaseTracks Constructor

[image]

.NET Framework Class Library
SongBaseTracks Constructor
SongBaseTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SongBaseTracks()
Visual C++
public:
SongBaseTracks()
JavaScript
NRenoiseTools.SongBaseTracks = function();

See Also

SongBaseTracks Class


SongBaseTracks Methods

[image] [image]

.NET Framework Class Library
SongBaseTracks Methods
SongBaseTracks Class See Also Send Feedback

The SongBaseTracks type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SongBaseTracks Class


SongBaseTracks Properties

[image] [image]

.NET Framework Class Library
SongBaseTracks Properties
SongBaseTracks Class See Also Send Feedback

The SongBaseTracks type exposes the following members.

Properties

Name | Description
SequencerMasterTrack |
SequencerSendTrack |
SequencerTrack |

See Also

SongBaseTracks Class


SequencerMasterTrack Property

[image]

.NET Framework Class Library
SongBaseTracks..::.SequencerMasterTrack Property
SongBaseTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerMasterTrack As SequencerMasterTrack()
C#
public SequencerMasterTrack[] SequencerMasterTrack { get; set; }
Visual C++
public:
property array<SequencerMasterTrack^>^ SequencerMasterTrack {
    array<SequencerMasterTrack^>^ get ();
    void set (array<SequencerMasterTrack^>^ value);
}
JavaScript
function get_sequencerMasterTrack();
function set_sequencerMasterTrack(value);

Remarks

See Also

SongBaseTracks Class


SequencerSendTrack Property

[image]

.NET Framework Class Library
SongBaseTracks..::.SequencerSendTrack Property
SongBaseTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerSendTrack As SequencerSendTrack()
C#
public SequencerSendTrack[] SequencerSendTrack { get; set; }
Visual C++
public:
property array<SequencerSendTrack^>^ SequencerSendTrack {
    array<SequencerSendTrack^>^ get ();
    void set (array<SequencerSendTrack^>^ value);
}
JavaScript
function get_sequencerSendTrack();
function set_sequencerSendTrack(value);

Remarks

See Also

SongBaseTracks Class


SequencerTrack Property

[image]

.NET Framework Class Library
SongBaseTracks..::.SequencerTrack Property
SongBaseTracks Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SequencerTrack As SequencerTrack()
C#
public SequencerTrack[] SequencerTrack { get; set; }
Visual C++
public:
property array<SequencerTrack^>^ SequencerTrack {
    array<SequencerTrack^>^ get ();
    void set (array<SequencerTrack^>^ value);
}
JavaScript
function get_sequencerTrack();
function set_sequencerTrack(value);

Remarks

See Also

SongBaseTracks Class


SongIterator Class

[image]

.NET Framework Class Library
SongIterator Class
Members See Also Send Feedback

Convenient class helper to iterate on a Renoise song. Subclass this class and use Iterate with delegates to catch events.
Copy Code
            public class MyRenoiseIterator : SongIterator {
                public MyRenoiseIterator(Song song) : base(song) {}

                public void DoMyConvertion() {
                    Iterate(new RenoiseSongEvent()
                    {
                        OnNote = delegate
                        {
                            // do whatever you want to do here.
                            // Look at Pattern, Track, Line, NoteColumn properties... to get the current pattern, track, line...etc
                        },
                        OnBeginPattern = delegate { Console.WriteLine("New pattern {0}", Pattern.Name); }
                    });
                }

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class SongIterator
C#
public class SongIterator
Visual C++
public ref class SongIterator
JavaScript
NRenoiseTools.SongIterator = function();

Type.createClass(
    'NRenoiseTools.SongIterator');

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongIterator

See Also

SongIterator Members


SongIterator Members

[image] [image]

.NET Framework Class Library
SongIterator Members
SongIterator Class Constructors Methods Properties See Also Send Feedback

The SongIterator type exposes the following members.

Constructors

Name | Description
SongIterator | Initializes a new instance of the SongIterator class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Iterate | Iterates on the song using the RenoiseSongEvent callbacks.
IteratePattern | Iterates on a specific pattern using the RenoiseSongEvent callbacks.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnIndex | Gets the current index of the column.
EffectColumn | Gets the current effect column.
FirstLineIndexOfCurrentPatternInSong | Gets the first line index of current pattern in song (absolute position).
Line | Gets the current line.
LineIndexInSong | Gets the absolute line index in song (starting from the first pattern)
LineIndexInTrack | Gets the line index in the current track.
NoteColumn | Gets the current note column.
Pattern | Gets the current pattern.
PatternIndex | Gets the index of the current pattern.
PositionBeat | Gets the current position in beat.
PositionTime | Gets the current position in time (ms).
Song | Gets the song being processed.
Tempo | Gets the current tempo.
Tempos | Gets all the tempos in the song.
Track | Gets the current track.
TrackIndex | Gets the index of the current track.

See Also

SongIterator Class


SongIterator Constructor

[image]

.NET Framework Class Library
SongIterator Constructor
SongIterator Class See Also Send Feedback

Initializes a new instance of the SongIterator class.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    song As Song _
)
C#
public SongIterator(
    Song song
)
Visual C++
public:
SongIterator(
    Song^ song
)
JavaScript
NRenoiseTools.SongIterator = function(song);

Parameters

song
Type: NRenoiseTools..::.Song
The renoise song.

See Also

SongIterator Class


SongIterator Methods

[image] [image]

.NET Framework Class Library
SongIterator Methods
SongIterator Class See Also Send Feedback

The SongIterator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Iterate | Iterates on the song using the RenoiseSongEvent callbacks.
IteratePattern | Iterates on a specific pattern using the RenoiseSongEvent callbacks.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SongIterator Class


Iterate Method

[image]

.NET Framework Class Library
SongIterator..::.Iterate Method
SongIterator Class See Also Send Feedback

Iterates on the song using the RenoiseSongEvent callbacks.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub Iterate ( _
    it As SongIteratorEvent _
)
C#
public void Iterate(
    SongIteratorEvent it
)
Visual C++
public:
void Iterate(
    SongIteratorEvent it
)
JavaScript
function iterate(it);

Parameters

it
Type: NRenoiseTools..::.SongIteratorEvent
It.

See Also

SongIterator Class


IteratePattern Method

[image]

.NET Framework Class Library
SongIterator..::.IteratePattern Method
SongIterator Class See Also Send Feedback

Iterates on a specific pattern using the RenoiseSongEvent callbacks.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub IteratePattern ( _
    patternIndexArg As Integer, _
    it As SongIteratorEvent _
)
C#
public void IteratePattern(
    int patternIndexArg,
    SongIteratorEvent it
)
Visual C++
public:
void IteratePattern(
    int patternIndexArg,
    SongIteratorEvent it
)
JavaScript
function iteratePattern(patternIndexArg, it);

Parameters

patternIndexArg
Type: System..::.Int32
The pattern index arg.
it
Type: NRenoiseTools..::.SongIteratorEvent
It.

See Also

SongIterator Class


SongIterator Properties

[image] [image]

.NET Framework Class Library
SongIterator Properties
SongIterator Class See Also Send Feedback

The SongIterator type exposes the following members.

Properties

Name | Description
ColumnIndex | Gets the current index of the column.
EffectColumn | Gets the current effect column.
FirstLineIndexOfCurrentPatternInSong | Gets the first line index of current pattern in song (absolute position).
Line | Gets the current line.
LineIndexInSong | Gets the absolute line index in song (starting from the first pattern)
LineIndexInTrack | Gets the line index in the current track.
NoteColumn | Gets the current note column.
Pattern | Gets the current pattern.
PatternIndex | Gets the index of the current pattern.
PositionBeat | Gets the current position in beat.
PositionTime | Gets the current position in time (ms).
Song | Gets the song being processed.
Tempo | Gets the current tempo.
Tempos | Gets all the tempos in the song.
Track | Gets the current track.
TrackIndex | Gets the index of the current track.

See Also

SongIterator Class


ColumnIndex Property

[image]

.NET Framework Class Library
SongIterator..::.ColumnIndex Property
SongIterator Class See Also Send Feedback

Gets the current index of the column.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
C#
public int ColumnIndex { get; }
Visual C++
public:
property int ColumnIndex {
    int get ();
}
JavaScript
function get_columnIndex();

Field Value

The index of the column.

See Also

SongIterator Class


EffectColumn Property

[image]

.NET Framework Class Library
SongIterator..::.EffectColumn Property
SongIterator Class See Also Send Feedback

Gets the current effect column.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EffectColumn As EffectColumn
C#
public EffectColumn EffectColumn { get; }
Visual C++
public:
property EffectColumn^ EffectColumn {
    EffectColumn^ get ();
}
JavaScript
function get_effectColumn();

Field Value

The effect column.

See Also

SongIterator Class


FirstLineIndexOfCurrentPatternInSong Property

[image]

.NET Framework Class Library
SongIterator..::.FirstLineIndexOfCurrentPatternInSong Property
SongIterator Class See Also Send Feedback

Gets the first line index of current pattern in song (absolute position).

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FirstLineIndexOfCurrentPatternInSong As Integer
C#
public int FirstLineIndexOfCurrentPatternInSong { get; }
Visual C++
public:
property int FirstLineIndexOfCurrentPatternInSong {
    int get ();
}
JavaScript
function get_firstLineIndexOfCurrentPatternInSong();

Field Value

The first line index of current pattern in song.

See Also

SongIterator Class


Line Property

[image]

.NET Framework Class Library
SongIterator..::.Line Property
SongIterator Class See Also Send Feedback

Gets the current line.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Line As Line
C#
public Line Line { get; }
Visual C++
public:
property Line^ Line {
    Line^ get ();
}
JavaScript
function get_line();

Field Value

The line.

See Also

SongIterator Class


LineIndexInSong Property

[image]

.NET Framework Class Library
SongIterator..::.LineIndexInSong Property
SongIterator Class See Also Send Feedback

Gets the absolute line index in song (starting from the first pattern)

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineIndexInSong As Integer
C#
public int LineIndexInSong { get; }
Visual C++
public:
property int LineIndexInSong {
    int get ();
}
JavaScript
function get_lineIndexInSong();

Field Value

The line index in song.

See Also

SongIterator Class


LineIndexInTrack Property

[image]

.NET Framework Class Library
SongIterator..::.LineIndexInTrack Property
SongIterator Class See Also Send Feedback

Gets the line index in the current track.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineIndexInTrack As Integer
C#
public int LineIndexInTrack { get; }
Visual C++
public:
property int LineIndexInTrack {
    int get ();
}
JavaScript
function get_lineIndexInTrack();

Field Value

The line index in track.

See Also

SongIterator Class


NoteColumn Property

[image]

.NET Framework Class Library
SongIterator..::.NoteColumn Property
SongIterator Class See Also Send Feedback

Gets the current note column.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoteColumn As NoteColumn
C#
public NoteColumn NoteColumn { get; }
Visual C++
public:
property NoteColumn^ NoteColumn {
    NoteColumn^ get ();
}
JavaScript
function get_noteColumn();

Field Value

The note column.

See Also

SongIterator Class


Pattern Property

[image]

.NET Framework Class Library
SongIterator..::.Pattern Property
SongIterator Class See Also Send Feedback

Gets the current pattern.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pattern As Pattern
C#
public Pattern Pattern { get; }
Visual C++
public:
property Pattern^ Pattern {
    Pattern^ get ();
}
JavaScript
function get_pattern();

Field Value

The pattern.

See Also

SongIterator Class


PatternIndex Property

[image]

.NET Framework Class Library
SongIterator..::.PatternIndex Property
SongIterator Class See Also Send Feedback

Gets the index of the current pattern.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PatternIndex As Integer
C#
public int PatternIndex { get; }
Visual C++
public:
property int PatternIndex {
    int get ();
}
JavaScript
function get_patternIndex();

Field Value

The index of the pattern.

See Also

SongIterator Class


PositionBeat Property

[image]

.NET Framework Class Library
SongIterator..::.PositionBeat Property
SongIterator Class See Also Send Feedback

Gets the current position in beat.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PositionBeat As Double
C#
public double PositionBeat { get; }
Visual C++
public:
property double PositionBeat {
    double get ();
}
JavaScript
function get_positionBeat();

Field Value

The position beat.

See Also

SongIterator Class


PositionTime Property

[image]

.NET Framework Class Library
SongIterator..::.PositionTime Property
SongIterator Class See Also Send Feedback

Gets the current position in time (ms).

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PositionTime As Double
C#
public double PositionTime { get; }
Visual C++
public:
property double PositionTime {
    double get ();
}
JavaScript
function get_positionTime();

Field Value

The position time.

See Also

SongIterator Class


Song Property

[image]

.NET Framework Class Library
SongIterator..::.Song Property
SongIterator Class See Also Send Feedback

Gets the song being processed.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Song As Song
C#
public Song Song { get; }
Visual C++
public:
property Song^ Song {
    Song^ get ();
}
JavaScript
function get_song();

Field Value

The song.

See Also

SongIterator Class


Tempo Property

[image]

.NET Framework Class Library
SongIterator..::.Tempo Property
SongIterator Class See Also Send Feedback

Gets the current tempo.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tempo As SongTempoMarker
C#
public SongTempoMarker Tempo { get; }
Visual C++
public:
property SongTempoMarker^ Tempo {
    SongTempoMarker^ get ();
}
JavaScript
function get_tempo();

Field Value

The tempo.

See Also

SongIterator Class


Tempos Property

[image]

.NET Framework Class Library
SongIterator..::.Tempos Property
SongIterator Class See Also Send Feedback

Gets all the tempos in the song.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tempos As SongTempoMarker()
C#
public SongTempoMarker[] Tempos { get; }
Visual C++
public:
property array<SongTempoMarker^>^ Tempos {
    array<SongTempoMarker^>^ get ();
}
JavaScript
function get_tempos();

Field Value

The tempos.

See Also

SongIterator Class


Track Property

[image]

.NET Framework Class Library
SongIterator..::.Track Property
SongIterator Class See Also Send Feedback

Gets the current track.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Track As Track
C#
public Track Track { get; }
Visual C++
public:
property Track^ Track {
    Track^ get ();
}
JavaScript
function get_track();

Field Value

The track.

See Also

SongIterator Class


TrackIndex Property

[image]

.NET Framework Class Library
SongIterator..::.TrackIndex Property
SongIterator Class See Also Send Feedback

Gets the index of the current track.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TrackIndex As Integer
C#
public int TrackIndex { get; }
Visual C++
public:
property int TrackIndex {
    int get ();
}
JavaScript
function get_trackIndex();

Field Value

The index of the track.

See Also

SongIterator Class


SongIteratorEvent Structure

[image]

.NET Framework Class Library
SongIteratorEvent Structure
Members See Also Send Feedback

Structures used by Iterate(SongIteratorEvent) and IteratePattern(Int32, SongIteratorEvent). This structure provides callbacks through delegates.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Structure SongIteratorEvent
C#
public struct SongIteratorEvent
Visual C++
public value class SongIteratorEvent
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

SongIteratorEvent Members


SongIteratorEvent Members

[image] [image]

.NET Framework Class Library
SongIteratorEvent Members
SongIteratorEvent Structure Methods Fields See Also Send Feedback

The SongIteratorEvent type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
OnBeginLine |
OnBeginPattern |
OnBeginSong |
OnBeginTrack |
OnEffect |
OnEndLine |
OnEndPattern |
OnEndSong |
OnEndTrack |
OnNote |

See Also

SongIteratorEvent Structure


SongIteratorEvent Fields

[image] [image]

.NET Framework Class Library
SongIteratorEvent Fields
SongIteratorEvent Structure See Also Send Feedback

The SongIteratorEvent type exposes the following members.

Fields

Name | Description
OnBeginLine |
OnBeginPattern |
OnBeginSong |
OnBeginTrack |
OnEffect |
OnEndLine |
OnEndPattern |
OnEndSong |
OnEndTrack |
OnNote |

See Also

SongIteratorEvent Structure


OnBeginLine Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnBeginLine Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnBeginLine As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnBeginLine
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnBeginLine
JavaScript
onBeginLine

See Also

SongIteratorEvent Structure


OnBeginPattern Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnBeginPattern Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnBeginPattern As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnBeginPattern
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnBeginPattern
JavaScript
onBeginPattern

See Also

SongIteratorEvent Structure


OnBeginSong Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnBeginSong Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnBeginSong As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnBeginSong
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnBeginSong
JavaScript
onBeginSong

See Also

SongIteratorEvent Structure


OnBeginTrack Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnBeginTrack Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnBeginTrack As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnBeginTrack
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnBeginTrack
JavaScript
onBeginTrack

See Also

SongIteratorEvent Structure


OnEffect Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnEffect Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnEffect As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnEffect
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnEffect
JavaScript
onEffect

See Also

SongIteratorEvent Structure


OnEndLine Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnEndLine Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnEndLine As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnEndLine
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnEndLine
JavaScript
onEndLine

See Also

SongIteratorEvent Structure


OnEndPattern Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnEndPattern Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnEndPattern As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnEndPattern
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnEndPattern
JavaScript
onEndPattern

See Also

SongIteratorEvent Structure


OnEndSong Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnEndSong Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnEndSong As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnEndSong
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnEndSong
JavaScript
onEndSong

See Also

SongIteratorEvent Structure


OnEndTrack Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnEndTrack Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnEndTrack As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnEndTrack
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnEndTrack
JavaScript
onEndTrack

See Also

SongIteratorEvent Structure


OnNote Field

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnNote Field
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public OnNote As SongIteratorEvent..::.OnIteratorEvent
C#
public SongIteratorEvent..::.OnIteratorEvent OnNote
Visual C++
public:
SongIteratorEvent..::.OnIteratorEvent^ OnNote
JavaScript
onNote

See Also

SongIteratorEvent Structure


SongIteratorEvent Methods

[image] [image]

.NET Framework Class Library
SongIteratorEvent Methods
SongIteratorEvent Structure See Also Send Feedback

The SongIteratorEvent type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SongIteratorEvent Structure


SongIteratorEvent.OnIteratorEvent Delegate

[image]

.NET Framework Class Library
SongIteratorEvent..::.OnIteratorEvent Delegate
SongIteratorEvent Structure See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub OnIteratorEvent
C#
public delegate void OnIteratorEvent()
Visual C++
public delegate void OnIteratorEvent()
JavaScript
function();

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


SongTempo Class

[image]

.NET Framework Class Library
SongTempo Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class SongTempo
C#
public class SongTempo
Visual C++
public ref class SongTempo
JavaScript
NRenoiseTools.SongTempo = function();

Type.createClass(
    'NRenoiseTools.SongTempo');

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongTempo
NRenoiseTools..::.SongTempoMarker

See Also

SongTempo Members


SongTempo Members

[image] [image]

.NET Framework Class Library
SongTempo Members
SongTempo Class Constructors Methods Properties See Also Send Feedback

The SongTempo type exposes the following members.

Constructors

Name | Description
SongTempo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bpm |
Lpb |
Realbpm |
Speed |
TimePerBeat |

See Also

SongTempo Class


SongTempo Constructor

[image]

.NET Framework Class Library
SongTempo Constructor
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bpm As Single, _
    speed As Integer _
)
C#
public SongTempo(
    float bpm,
    int speed
)
Visual C++
public:
SongTempo(
    float bpm,
    int speed
)
JavaScript
NRenoiseTools.SongTempo = function(bpm, speed);

Parameters

bpm
Type: System..::.Single
speed
Type: System..::.Int32

See Also

SongTempo Class


SongTempo Methods

[image] [image]

.NET Framework Class Library
SongTempo Methods
SongTempo Class See Also Send Feedback

The SongTempo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SongTempo Class


SongTempo Properties

[image] [image]

.NET Framework Class Library
SongTempo Properties
SongTempo Class See Also Send Feedback

The SongTempo type exposes the following members.

Properties

Name | Description
Bpm |
Lpb |
Realbpm |
Speed |
TimePerBeat |

See Also

SongTempo Class


Bpm Property

[image]

.NET Framework Class Library
SongTempo..::.Bpm Property
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Bpm As Single
C#
public float Bpm { get; set; }
Visual C++
public:
property float Bpm {
    float get ();
    void set (float value);
}
JavaScript
function get_bpm();
function set_bpm(value);

See Also

SongTempo Class


Lpb Property

[image]

.NET Framework Class Library
SongTempo..::.Lpb Property
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lpb As Integer
C#
public int Lpb { get; }
Visual C++
public:
property int Lpb {
    int get ();
}
JavaScript
function get_lpb();

See Also

SongTempo Class


Realbpm Property

[image]

.NET Framework Class Library
SongTempo..::.Realbpm Property
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Realbpm As Single
C#
public float Realbpm { get; }
Visual C++
public:
property float Realbpm {
    float get ();
}
JavaScript
function get_realbpm();

See Also

SongTempo Class


Speed Property

[image]

.NET Framework Class Library
SongTempo..::.Speed Property
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Speed As Integer
C#
public int Speed { get; set; }
Visual C++
public:
property int Speed {
    int get ();
    void set (int value);
}
JavaScript
function get_speed();
function set_speed(value);

See Also

SongTempo Class


TimePerBeat Property

[image]

.NET Framework Class Library
SongTempo..::.TimePerBeat Property
SongTempo Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimePerBeat As Double
C#
public double TimePerBeat { get; }
Visual C++
public:
property double TimePerBeat {
    double get ();
}
JavaScript
function get_timePerBeat();

See Also

SongTempo Class


SongTempoMarker Class

[image]

.NET Framework Class Library
SongTempoMarker Class
Members See Also Send Feedback

Tempo marker inside the song with the absolute position (in line and time) in the song.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class SongTempoMarker _
    Inherits SongTempo
C#
public class SongTempoMarker : SongTempo
Visual C++
public ref class SongTempoMarker : public SongTempo
JavaScript
NRenoiseTools.SongTempoMarker = function();

Type.createClass(
    'NRenoiseTools.SongTempoMarker',
    NRenoiseTools.SongTempo);

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.SongTempo
NRenoiseTools..::.SongTempoMarker

See Also

SongTempoMarker Members


SongTempoMarker Members

[image] [image]

.NET Framework Class Library
SongTempoMarker Members
SongTempoMarker Class Constructors Methods Properties See Also Send Feedback

The SongTempoMarker type exposes the following members.

Constructors

Name | Description
SongTempoMarker |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBeatFromOffset |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTimeFromOffset |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeatPosition | Gets the beat position of this tempo.
Bpm | (Inherited from SongTempo.)
Lpb | (Inherited from SongTempo.)
Position | Gets the position.
Realbpm | (Inherited from SongTempo.)
Speed | (Inherited from SongTempo.)
TimePerBeat | (Inherited from SongTempo.)
TimePosition | Gets the time position in micro seconds of this tempo.

See Also

SongTempoMarker Class


SongTempoMarker Constructor

[image]

.NET Framework Class Library
SongTempoMarker Constructor
SongTempoMarker Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    bpm As Single, _
    speed As Integer, _
    positionInSong As Integer, _
    timePosition As Double, _
    beatPosition As Double _
)
C#
public SongTempoMarker(
    float bpm,
    int speed,
    int positionInSong,
    double timePosition,
    double beatPosition
)
Visual C++
public:
SongTempoMarker(
    float bpm,
    int speed,
    int positionInSong,
    double timePosition,
    double beatPosition
)
JavaScript
NRenoiseTools.SongTempoMarker = function(bpm, speed, positionInSong, timePosition, beatPosition);

Parameters

bpm
Type: System..::.Single
speed
Type: System..::.Int32
positionInSong
Type: System..::.Int32
timePosition
Type: System..::.Double
beatPosition
Type: System..::.Double

See Also

SongTempoMarker Class


SongTempoMarker Methods

[image] [image]

.NET Framework Class Library
SongTempoMarker Methods
SongTempoMarker Class See Also Send Feedback

The SongTempoMarker type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBeatFromOffset |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTimeFromOffset |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SongTempoMarker Class


GetBeatFromOffset Method

[image]

.NET Framework Class Library
SongTempoMarker..::.GetBeatFromOffset Method
SongTempoMarker Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBeatFromOffset ( _
    offset As Integer _
) As Double
C#
public double GetBeatFromOffset(
    int offset
)
Visual C++
public:
double GetBeatFromOffset(
    int offset
)
JavaScript
function getBeatFromOffset(offset);

Parameters

offset
Type: System..::.Int32

See Also

SongTempoMarker Class


GetTimeFromOffset Method

[image]

.NET Framework Class Library
SongTempoMarker..::.GetTimeFromOffset Method
SongTempoMarker Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTimeFromOffset ( _
    offset As Integer _
) As Double
C#
public double GetTimeFromOffset(
    int offset
)
Visual C++
public:
double GetTimeFromOffset(
    int offset
)
JavaScript
function getTimeFromOffset(offset);

Parameters

offset
Type: System..::.Int32

See Also

SongTempoMarker Class


SongTempoMarker Properties

[image] [image]

.NET Framework Class Library
SongTempoMarker Properties
SongTempoMarker Class See Also Send Feedback

The SongTempoMarker type exposes the following members.

Properties

Name | Description
BeatPosition | Gets the beat position of this tempo.
Bpm | (Inherited from SongTempo.)
Lpb | (Inherited from SongTempo.)
Position | Gets the position.
Realbpm | (Inherited from SongTempo.)
Speed | (Inherited from SongTempo.)
TimePerBeat | (Inherited from SongTempo.)
TimePosition | Gets the time position in micro seconds of this tempo.

See Also

SongTempoMarker Class


BeatPosition Property

[image]

.NET Framework Class Library
SongTempoMarker..::.BeatPosition Property
SongTempoMarker Class See Also Send Feedback

Gets the beat position of this tempo.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BeatPosition As Double
C#
public double BeatPosition { get; }
Visual C++
public:
property double BeatPosition {
    double get ();
}
JavaScript
function get_beatPosition();

Field Value

The beat position.

See Also

SongTempoMarker Class


Position Property

[image]

.NET Framework Class Library
SongTempoMarker..::.Position Property
SongTempoMarker Class See Also Send Feedback

Gets the position.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
C#
public int Position { get; }
Visual C++
public:
property int Position {
    int get ();
}
JavaScript
function get_position();

Field Value

The position.

See Also

SongTempoMarker Class


TimePosition Property

[image]

.NET Framework Class Library
SongTempoMarker..::.TimePosition Property
SongTempoMarker Class See Also Send Feedback

Gets the time position in micro seconds of this tempo.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimePosition As Double
C#
public double TimePosition { get; }
Visual C++
public:
property double TimePosition {
    double get ();
}
JavaScript
function get_timePosition();

Field Value

The time position.

See Also

SongTempoMarker Class


StereoExpanderDevice Class

[image]

.NET Framework Class Library
StereoExpanderDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDevice
JavaScript
NRenoiseTools.StereoExpanderDevice = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDevice

See Also

StereoExpanderDevice Members


StereoExpanderDevice Members

[image] [image]

.NET Framework Class Library
StereoExpanderDevice Members
StereoExpanderDevice Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDevice type exposes the following members.

Constructors

Name | Description
StereoExpanderDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsActive |
IsSelected |
MonoMixMode |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
StereoWidth |
SurroundWidth |
type |

See Also

StereoExpanderDevice Class


StereoExpanderDevice Constructor

[image]

.NET Framework Class Library
StereoExpanderDevice Constructor
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDevice()
Visual C++
public:
StereoExpanderDevice()
JavaScript
NRenoiseTools.StereoExpanderDevice = function();

See Also

StereoExpanderDevice Class


StereoExpanderDevice Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDevice Methods
StereoExpanderDevice Class See Also Send Feedback

The StereoExpanderDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDevice Class


StereoExpanderDevice Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDevice Properties
StereoExpanderDevice Class See Also Send Feedback

The StereoExpanderDevice type exposes the following members.

Properties

Name | Description
IsActive |
IsSelected |
MonoMixMode |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
StereoWidth |
SurroundWidth |
type |

See Also

StereoExpanderDevice Class


IsActive Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.IsActive Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

StereoExpanderDevice Class


IsSelected Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.IsSelected Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

StereoExpanderDevice Class


MonoMixMode Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.MonoMixMode Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MonoMixMode As StereoExpanderDeviceMonoMixMode
C#
public StereoExpanderDeviceMonoMixMode MonoMixMode { get; set; }
Visual C++
public:
property StereoExpanderDeviceMonoMixMode MonoMixMode {
    StereoExpanderDeviceMonoMixMode get ();
    void set (StereoExpanderDeviceMonoMixMode value);
}
JavaScript
function get_monoMixMode();
function set_monoMixMode(value);

Remarks

See Also

StereoExpanderDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.RunTimePresetA Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As StereoExpanderDeviceRunTimePreset
C#
public StereoExpanderDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property StereoExpanderDeviceRunTimePreset^ RunTimePresetA {
    StereoExpanderDeviceRunTimePreset^ get ();
    void set (StereoExpanderDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

StereoExpanderDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.RunTimePresetB Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As StereoExpanderDeviceRunTimePreset
C#
public StereoExpanderDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property StereoExpanderDeviceRunTimePreset^ RunTimePresetB {
    StereoExpanderDeviceRunTimePreset^ get ();
    void set (StereoExpanderDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

StereoExpanderDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.SelectedPresetIsModified Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

StereoExpanderDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.SelectedPresetName Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

StereoExpanderDevice Class


StereoWidth Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.StereoWidth Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoWidth As StereoExpanderDeviceStereoWidth
C#
public StereoExpanderDeviceStereoWidth StereoWidth { get; set; }
Visual C++
public:
property StereoExpanderDeviceStereoWidth^ StereoWidth {
    StereoExpanderDeviceStereoWidth^ get ();
    void set (StereoExpanderDeviceStereoWidth^ value);
}
JavaScript
function get_stereoWidth();
function set_stereoWidth(value);

Remarks

See Also

StereoExpanderDevice Class


SurroundWidth Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.SurroundWidth Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SurroundWidth As StereoExpanderDeviceSurroundWidth
C#
public StereoExpanderDeviceSurroundWidth SurroundWidth { get; set; }
Visual C++
public:
property StereoExpanderDeviceSurroundWidth^ SurroundWidth {
    StereoExpanderDeviceSurroundWidth^ get ();
    void set (StereoExpanderDeviceSurroundWidth^ value);
}
JavaScript
function get_surroundWidth();
function set_surroundWidth(value);

Remarks

See Also

StereoExpanderDevice Class


type Property

[image]

.NET Framework Class Library
StereoExpanderDevice..::.type Property
StereoExpanderDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

StereoExpanderDevice Class


StereoExpanderDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceDeviceSlotRunTimePreset

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Members


StereoExpanderDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset Members
StereoExpanderDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MonoMixMode |
StereoWidth |
SurroundWidth |
type |

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


StereoExpanderDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset Constructor
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceDeviceSlotRunTimePreset()
Visual C++
public:
StereoExpanderDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePreset = function();

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


StereoExpanderDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset Methods
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


StereoExpanderDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset Properties
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
MonoMixMode |
StereoWidth |
SurroundWidth |
type |

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


MonoMixMode Property

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset..::.MonoMixMode Property
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MonoMixMode As StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode
C#
public StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode MonoMixMode { get; set; }
Visual C++
public:
property StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode MonoMixMode {
    StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode get ();
    void set (StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode value);
}
JavaScript
function get_monoMixMode();
function set_monoMixMode(value);

Remarks

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


StereoWidth Property

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset..::.StereoWidth Property
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property StereoWidth As StereoExpanderDeviceStereoWidthRunTimePreset
C#
public StereoExpanderDeviceStereoWidthRunTimePreset StereoWidth { get; set; }
Visual C++
public:
property StereoExpanderDeviceStereoWidthRunTimePreset^ StereoWidth {
    StereoExpanderDeviceStereoWidthRunTimePreset^ get ();
    void set (StereoExpanderDeviceStereoWidthRunTimePreset^ value);
}
JavaScript
function get_stereoWidth();
function set_stereoWidth(value);

Remarks

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


SurroundWidth Property

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset..::.SurroundWidth Property
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SurroundWidth As StereoExpanderDeviceSurroundWidthRunTimePreset
C#
public StereoExpanderDeviceSurroundWidthRunTimePreset SurroundWidth { get; set; }
Visual C++
public:
property StereoExpanderDeviceSurroundWidthRunTimePreset^ SurroundWidth {
    StereoExpanderDeviceSurroundWidthRunTimePreset^ get ();
    void set (StereoExpanderDeviceSurroundWidthRunTimePreset^ value);
}
JavaScript
function get_surroundWidth();
function set_surroundWidth(value);

Remarks

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePreset..::.type Property
StereoExpanderDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

StereoExpanderDeviceDeviceSlotRunTimePreset Class


StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode Enumeration

[image]

.NET Framework Class Library
StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode
JavaScript
NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode = function();
NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode.createEnum('NRenoiseTools.StereoExpanderDeviceDeviceSlotRunTimePresetMonoMixMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


StereoExpanderDeviceMonoMixMode Enumeration

[image]

.NET Framework Class Library
StereoExpanderDeviceMonoMixMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration StereoExpanderDeviceMonoMixMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum StereoExpanderDeviceMonoMixMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class StereoExpanderDeviceMonoMixMode
JavaScript
NRenoiseTools.StereoExpanderDeviceMonoMixMode = function();
NRenoiseTools.StereoExpanderDeviceMonoMixMode.createEnum('NRenoiseTools.StereoExpanderDeviceMonoMixMode', false);

Members

Member name | Description
L |
R |
LR |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


StereoExpanderDeviceRunTimePreset Class

[image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceRunTimePreset
JavaScript
NRenoiseTools.StereoExpanderDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceRunTimePreset

See Also

StereoExpanderDeviceRunTimePreset Members


StereoExpanderDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset Members
StereoExpanderDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

StereoExpanderDeviceRunTimePreset Class


StereoExpanderDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset Constructor
StereoExpanderDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceRunTimePreset()
Visual C++
public:
StereoExpanderDeviceRunTimePreset()
JavaScript
NRenoiseTools.StereoExpanderDeviceRunTimePreset = function();

See Also

StereoExpanderDeviceRunTimePreset Class


StereoExpanderDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset Methods
StereoExpanderDeviceRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceRunTimePreset Class


StereoExpanderDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset Properties
StereoExpanderDeviceRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

StereoExpanderDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset..::.DeviceSlot Property
StereoExpanderDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As StereoExpanderDeviceDeviceSlotRunTimePreset
C#
public StereoExpanderDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property StereoExpanderDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    StereoExpanderDeviceDeviceSlotRunTimePreset^ get ();
    void set (StereoExpanderDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

StereoExpanderDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
StereoExpanderDeviceRunTimePreset..::.type Property
StereoExpanderDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

StereoExpanderDeviceRunTimePreset Class


StereoExpanderDeviceStereoWidth Class

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceStereoWidth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceStereoWidth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceStereoWidth
JavaScript
NRenoiseTools.StereoExpanderDeviceStereoWidth = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceStereoWidth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceStereoWidth

See Also

StereoExpanderDeviceStereoWidth Members


StereoExpanderDeviceStereoWidth Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth Members
StereoExpanderDeviceStereoWidth Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceStereoWidth type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceStereoWidth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

StereoExpanderDeviceStereoWidth Class


StereoExpanderDeviceStereoWidth Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth Constructor
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceStereoWidth()
Visual C++
public:
StereoExpanderDeviceStereoWidth()
JavaScript
NRenoiseTools.StereoExpanderDeviceStereoWidth = function();

See Also

StereoExpanderDeviceStereoWidth Class


StereoExpanderDeviceStereoWidth Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth Methods
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

The StereoExpanderDeviceStereoWidth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceStereoWidth Class


StereoExpanderDeviceStereoWidth Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth Properties
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

The StereoExpanderDeviceStereoWidth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

StereoExpanderDeviceStereoWidth Class


MidiMappings Property

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth..::.MidiMappings Property
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

StereoExpanderDeviceStereoWidth Class


Value Property

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth..::.Value Property
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

StereoExpanderDeviceStereoWidth Class


Visualization Property

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidth..::.Visualization Property
StereoExpanderDeviceStereoWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As StereoExpanderDeviceStereoWidthVisualization
C#
public StereoExpanderDeviceStereoWidthVisualization Visualization { get; set; }
Visual C++
public:
property StereoExpanderDeviceStereoWidthVisualization Visualization {
    StereoExpanderDeviceStereoWidthVisualization get ();
    void set (StereoExpanderDeviceStereoWidthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

StereoExpanderDeviceStereoWidth Class


StereoExpanderDeviceStereoWidthRunTimePreset Class

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceStereoWidthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceStereoWidthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceStereoWidthRunTimePreset
JavaScript
NRenoiseTools.StereoExpanderDeviceStereoWidthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceStereoWidthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceStereoWidthRunTimePreset

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Members


StereoExpanderDeviceStereoWidthRunTimePreset Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset Members
StereoExpanderDeviceStereoWidthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceStereoWidthRunTimePreset type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceStereoWidthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Class


StereoExpanderDeviceStereoWidthRunTimePreset Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset Constructor
StereoExpanderDeviceStereoWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceStereoWidthRunTimePreset()
Visual C++
public:
StereoExpanderDeviceStereoWidthRunTimePreset()
JavaScript
NRenoiseTools.StereoExpanderDeviceStereoWidthRunTimePreset = function();

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Class


StereoExpanderDeviceStereoWidthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset Methods
StereoExpanderDeviceStereoWidthRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceStereoWidthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Class


StereoExpanderDeviceStereoWidthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset Properties
StereoExpanderDeviceStereoWidthRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceStereoWidthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthRunTimePreset..::.Value Property
StereoExpanderDeviceStereoWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

StereoExpanderDeviceStereoWidthRunTimePreset Class


StereoExpanderDeviceStereoWidthVisualization Enumeration

[image]

.NET Framework Class Library
StereoExpanderDeviceStereoWidthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration StereoExpanderDeviceStereoWidthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum StereoExpanderDeviceStereoWidthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class StereoExpanderDeviceStereoWidthVisualization
JavaScript
NRenoiseTools.StereoExpanderDeviceStereoWidthVisualization = function();
NRenoiseTools.StereoExpanderDeviceStereoWidthVisualization.createEnum('NRenoiseTools.StereoExpanderDeviceStereoWidthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


StereoExpanderDeviceSurroundWidth Class

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceSurroundWidth
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceSurroundWidth
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceSurroundWidth
JavaScript
NRenoiseTools.StereoExpanderDeviceSurroundWidth = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceSurroundWidth');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceSurroundWidth

See Also

StereoExpanderDeviceSurroundWidth Members


StereoExpanderDeviceSurroundWidth Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth Members
StereoExpanderDeviceSurroundWidth Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceSurroundWidth type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceSurroundWidth |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

StereoExpanderDeviceSurroundWidth Class


StereoExpanderDeviceSurroundWidth Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth Constructor
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceSurroundWidth()
Visual C++
public:
StereoExpanderDeviceSurroundWidth()
JavaScript
NRenoiseTools.StereoExpanderDeviceSurroundWidth = function();

See Also

StereoExpanderDeviceSurroundWidth Class


StereoExpanderDeviceSurroundWidth Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth Methods
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

The StereoExpanderDeviceSurroundWidth type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceSurroundWidth Class


StereoExpanderDeviceSurroundWidth Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth Properties
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

The StereoExpanderDeviceSurroundWidth type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

StereoExpanderDeviceSurroundWidth Class


MidiMappings Property

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth..::.MidiMappings Property
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

StereoExpanderDeviceSurroundWidth Class


Value Property

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth..::.Value Property
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

StereoExpanderDeviceSurroundWidth Class


Visualization Property

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidth..::.Visualization Property
StereoExpanderDeviceSurroundWidth Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As StereoExpanderDeviceSurroundWidthVisualization
C#
public StereoExpanderDeviceSurroundWidthVisualization Visualization { get; set; }
Visual C++
public:
property StereoExpanderDeviceSurroundWidthVisualization Visualization {
    StereoExpanderDeviceSurroundWidthVisualization get ();
    void set (StereoExpanderDeviceSurroundWidthVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

StereoExpanderDeviceSurroundWidth Class


StereoExpanderDeviceSurroundWidthRunTimePreset Class

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class StereoExpanderDeviceSurroundWidthRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class StereoExpanderDeviceSurroundWidthRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class StereoExpanderDeviceSurroundWidthRunTimePreset
JavaScript
NRenoiseTools.StereoExpanderDeviceSurroundWidthRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.StereoExpanderDeviceSurroundWidthRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.StereoExpanderDeviceSurroundWidthRunTimePreset

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Members


StereoExpanderDeviceSurroundWidthRunTimePreset Members

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset Members
StereoExpanderDeviceSurroundWidthRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The StereoExpanderDeviceSurroundWidthRunTimePreset type exposes the following members.

Constructors

Name | Description
StereoExpanderDeviceSurroundWidthRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Class


StereoExpanderDeviceSurroundWidthRunTimePreset Constructor

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset Constructor
StereoExpanderDeviceSurroundWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StereoExpanderDeviceSurroundWidthRunTimePreset()
Visual C++
public:
StereoExpanderDeviceSurroundWidthRunTimePreset()
JavaScript
NRenoiseTools.StereoExpanderDeviceSurroundWidthRunTimePreset = function();

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Class


StereoExpanderDeviceSurroundWidthRunTimePreset Methods

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset Methods
StereoExpanderDeviceSurroundWidthRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceSurroundWidthRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Class


StereoExpanderDeviceSurroundWidthRunTimePreset Properties

[image] [image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset Properties
StereoExpanderDeviceSurroundWidthRunTimePreset Class See Also Send Feedback

The StereoExpanderDeviceSurroundWidthRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthRunTimePreset..::.Value Property
StereoExpanderDeviceSurroundWidthRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

StereoExpanderDeviceSurroundWidthRunTimePreset Class


StereoExpanderDeviceSurroundWidthVisualization Enumeration

[image]

.NET Framework Class Library
StereoExpanderDeviceSurroundWidthVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration StereoExpanderDeviceSurroundWidthVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum StereoExpanderDeviceSurroundWidthVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class StereoExpanderDeviceSurroundWidthVisualization
JavaScript
NRenoiseTools.StereoExpanderDeviceSurroundWidthVisualization = function();
NRenoiseTools.StereoExpanderDeviceSurroundWidthVisualization.createEnum('NRenoiseTools.StereoExpanderDeviceSurroundWidthVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


TextBoxWriter Class

[image]

.NET Framework Class Library
TextBoxWriter Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class TextBoxWriter _
    Inherits TextWriter
C#
public class TextBoxWriter : TextWriter
Visual C++
public ref class TextBoxWriter : public TextWriter
JavaScript
NRenoiseTools.TextBoxWriter = function();

Type.createClass(
    'NRenoiseTools.TextBoxWriter',
    TextWriter);

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.IO..::.TextWriter
NRenoiseTools..::.TextBoxWriter

See Also

TextBoxWriter Members


TextBoxWriter Members

[image] [image]

.NET Framework Class Library
TextBoxWriter Members
TextBoxWriter Class Constructors Methods Fields Properties See Also Send Feedback

The TextBoxWriter type exposes the following members.

Constructors

Name | Description
TextBoxWriter |

Methods

Name | Description
Close | Closes the current writer and releases any system resources associated with the writer. (Inherited from TextWriter.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.
WriteLine | Overloaded.

Fields

Name | Description
CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

Properties

Name | Description
Encoding | (Overrides TextWriter..::.Encoding.)
FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

TextBoxWriter Class


TextBoxWriter Constructor

[image]

.NET Framework Class Library
TextBoxWriter Constructor
TextBoxWriter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    textBox As TextBox _
)
C#
public TextBoxWriter(
    TextBox textBox
)
Visual C++
public:
TextBoxWriter(
    TextBox^ textBox
)
JavaScript
NRenoiseTools.TextBoxWriter = function(textBox);

Parameters

textBox
Type: System.Windows.Forms..::.TextBox

See Also

TextBoxWriter Class


TextBoxWriter Fields

[image] [image]

.NET Framework Class Library
TextBoxWriter Fields
TextBoxWriter Class See Also Send Feedback

The TextBoxWriter type exposes the following members.

Fields

Name | Description
CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

See Also

TextBoxWriter Class


TextBoxWriter Methods

[image] [image]

.NET Framework Class Library
TextBoxWriter Methods
TextBoxWriter Class See Also Send Feedback

The TextBoxWriter type exposes the following members.

Methods

Name | Description
Close | Closes the current writer and releases any system resources associated with the writer. (Inherited from TextWriter.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.
WriteLine | Overloaded.

See Also

TextBoxWriter Class


Dispose Method

[image] [image]

.NET Framework Class Library
TextBoxWriter..::.Dispose Method
TextBoxWriter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Dispose(Boolean) | Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources. (Inherited from TextWriter.)

See Also

TextBoxWriter Class
TextBoxWriter Members


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
TextBoxWriter..::.MemberwiseClone Method
TextBoxWriter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextBoxWriter Class
TextBoxWriter Members


Write Method

[image] [image]

.NET Framework Class Library
TextBoxWriter..::.Write Method
TextBoxWriter Class See Also Send Feedback

Overload List

Name | Description
Write(Char) | Writes a character to the text stream. (Inherited from TextWriter.)
Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Write(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Write(array<Char>[]()[]) | (Overrides TextWriter..::.Write(array<Char>[]()[]).)
Write(String) | (Overrides TextWriter..::.Write(String).)
Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(String, array<Object>[]()[]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Write(array<Char>[]()[], Int32, Int32) | (Overrides TextWriter..::.Write(array<Char>[]()[], Int32, Int32).)
Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)

See Also

TextBoxWriter Class
TextBoxWriter Members


Write Method (Char[])

[image]

.NET Framework Class Library
TextBoxWriter..::.Write Method (array<Char>[]()[])
TextBoxWriter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write ( _
    buffer As Char() _
)
C#
public override void Write(
    char[] buffer
)
Visual C++
public:
virtual void Write(
    array<wchar_t>^ buffer
) override
JavaScript
function write(buffer);

Parameters

buffer
Type: array< System..::.Char >[]()[]

See Also

TextBoxWriter Class
Write Overload


Write Method (String)

[image]

.NET Framework Class Library
TextBoxWriter..::.Write Method (String)
TextBoxWriter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write ( _
    value As String _
)
C#
public override void Write(
    string value
)
Visual C++
public:
virtual void Write(
    String^ value
) override
JavaScript
function write(value);

Parameters

value
Type: System..::.String

See Also

TextBoxWriter Class
Write Overload


Write Method (Char[], Int32, Int32)

[image]

.NET Framework Class Library
TextBoxWriter..::.Write Method (array<Char>[]()[], Int32, Int32)
TextBoxWriter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write ( _
    buffer As Char(), _
    index As Integer, _
    count As Integer _
)
C#
public override void Write(
    char[] buffer,
    int index,
    int count
)
Visual C++
public:
virtual void Write(
    array<wchar_t>^ buffer,
    int index,
    int count
) override
JavaScript
function write(buffer, index, count);

Parameters

buffer
Type: array< System..::.Char >[]()[]
index
Type: System..::.Int32
count
Type: System..::.Int32

See Also

TextBoxWriter Class
Write Overload


WriteLine Method

[image] [image]

.NET Framework Class Library
TextBoxWriter..::.WriteLine Method
TextBoxWriter Class See Also Send Feedback

Overload List

Name | Description
WriteLine()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(array<Char>[]()[]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(String, array<Object>[]()[]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(array<Char>[]()[], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)

See Also

TextBoxWriter Class
TextBoxWriter Members


TextBoxWriter Properties

[image] [image]

.NET Framework Class Library
TextBoxWriter Properties
TextBoxWriter Class See Also Send Feedback

The TextBoxWriter type exposes the following members.

Properties

Name | Description
Encoding | (Overrides TextWriter..::.Encoding.)
FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

TextBoxWriter Class


Encoding Property

[image]

.NET Framework Class Library
TextBoxWriter..::.Encoding Property
TextBoxWriter Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Encoding As Encoding
C#
public override Encoding Encoding { get; }
Visual C++
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}
JavaScript
function get_encoding();

See Also

TextBoxWriter Class


Track Class

[image]

.NET Framework Class Library
Track Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public MustInherit Class Track
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public abstract class Track
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class Track abstract
JavaScript
NRenoiseTools.Track = function();

Type.createClass(
    'NRenoiseTools.Track');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Track
NRenoiseTools..::.PatternMasterTrack
NRenoiseTools..::.PatternSendTrack
NRenoiseTools..::.PatternTrack

See Also

Track Members


Track Members

[image] [image]

.NET Framework Class Library
Track Members
Track Class Constructors Methods Properties See Also Send Feedback

The Track type exposes the following members.

Constructors

Name | Description
Track |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Automations |
Lines |

See Also

Track Class


Track Constructor

[image]

.NET Framework Class Library
Track Constructor
Track Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected Track()
Visual C++
protected:
Track()
JavaScript
NRenoiseTools.Track = function();

See Also

Track Class


Track Methods

[image] [image]

.NET Framework Class Library
Track Methods
Track Class See Also Send Feedback

The Track type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Track Class


Track Properties

[image] [image]

.NET Framework Class Library
Track Properties
Track Class See Also Send Feedback

The Track type exposes the following members.

Properties

Name | Description
Automations |
Lines |

See Also

Track Class


Automations Property

[image]

.NET Framework Class Library
Track..::.Automations Property
Track Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Automations As Automations
C#
public Automations Automations { get; set; }
Visual C++
public:
property Automations^ Automations {
    Automations^ get ();
    void set (Automations^ value);
}
JavaScript
function get_automations();
function set_automations(value);

Remarks

See Also

Track Class


Lines Property

[image]

.NET Framework Class Library
Track..::.Lines Property
Track Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Lines As Line()
C#
public Line[] Lines { get; set; }
Visual C++
public:
property array<Line^>^ Lines {
    array<Line^>^ get ();
    void set (array<Line^>^ value);
}
JavaScript
function get_lines();
function set_lines(value);

Remarks

See Also

Track Class


Util Class

[image]

.NET Framework Class Library
Util Class
Members See Also Send Feedback

Misc utility methods.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Class Util
C#
public class Util
Visual C++
public ref class Util
JavaScript
NRenoiseTools.Util = function();

Type.createClass(
    'NRenoiseTools.Util');

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.Util

See Also

Util Members


Util Members

[image] [image]

.NET Framework Class Library
Util Members
Util Class Constructors Methods See Also Send Feedback

The Util type exposes the following members.

Constructors

Name | Description
Util |

Methods

Name | Description
Copy<(Of <(T>)>) | Copies properties from an instance to another
DeepClone | Perform a deep clone of an object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenZip | Open a ZipFile from a Stream. If the stream is not a zip file, an ArgumentException is thrown.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Util Class


Util Constructor

[image]

.NET Framework Class Library
Util Constructor
Util Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Util()
Visual C++
public:
Util()
JavaScript
NRenoiseTools.Util = function();

See Also

Util Class


Util Methods

[image] [image]

.NET Framework Class Library
Util Methods
Util Class See Also Send Feedback

The Util type exposes the following members.

Methods

Name | Description
Copy<(Of <(T>)>) | Copies properties from an instance to another
DeepClone | Perform a deep clone of an object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenZip | Open a ZipFile from a Stream. If the stream is not a zip file, an ArgumentException is thrown.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Util Class


Copy(T) Method

[image]

.NET Framework Class Library
Util..::.Copy<(Of <(T>)>) Method
Util Class See Also Send Feedback

Copies properties from an instance to another

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Copy(Of T) ( _
    srcInstance As T, _
    dstInstance As T _
)
C#
public static void Copy<T>(
    T srcInstance,
    T dstInstance
)
Visual C++
public:
generic<typename T>
static void Copy(
    T srcInstance,
    T dstInstance
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

srcInstance
Type: T
The source instance.
dstInstance
Type: T
The destination instance.

Type Parameters

T

See Also

Util Class


DeepClone Method

[image]

.NET Framework Class Library
Util..::.DeepClone Method
Util Class See Also Send Feedback

Perform a deep clone of an object.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DeepClone ( _
    objToClone As Object _
) As Object
C#
public static Object DeepClone(
    Object objToClone
)
Visual C++
public:
static Object^ DeepClone(
    Object^ objToClone
)
JavaScript
NRenoiseTools.Util.deepClone = function(objToClone);

Parameters

objToClone
Type: System..::.Object
The obj to clone.

Return Value

the clone

See Also

Util Class


OpenZip Method

[image]

.NET Framework Class Library
Util..::.OpenZip Method
Util Class See Also Send Feedback

Open a ZipFile from a Stream. If the stream is not a zip file, an ArgumentException is thrown.

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function OpenZip ( _
    stream As Stream _
) As ZipFile
C#
public static ZipFile OpenZip(
    Stream stream
)
Visual C++
public:
static ZipFile^ OpenZip(
    Stream^ stream
)
JavaScript
NRenoiseTools.Util.openZip = function(stream);

Parameters

stream
Type: System.IO..::.Stream
The stream.

Return Value

A Zip file

Exceptions

Exception | Condition
System..::.ArgumentException | If stream is not a zip file

See Also

Util Class


VelocityDevice Class

[image]

.NET Framework Class Library
VelocityDevice Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDevice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDevice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDevice
JavaScript
NRenoiseTools.VelocityDevice = function();

Type.createClass(
    'NRenoiseTools.VelocityDevice');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDevice

See Also

VelocityDevice Members


VelocityDevice Members

[image] [image]

.NET Framework Class Library
VelocityDevice Members
VelocityDevice Class Constructors Methods Properties See Also Send Feedback

The VelocityDevice type exposes the following members.

Constructors

Name | Description
VelocityDevice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestEffect |
DestMax |
DestMin |
DestParameter |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SrcInstrument |
type |
VelocityMax |
VelocityMin |
VelocityScaling |

See Also

VelocityDevice Class


VelocityDevice Constructor

[image]

.NET Framework Class Library
VelocityDevice Constructor
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDevice()
Visual C++
public:
VelocityDevice()
JavaScript
NRenoiseTools.VelocityDevice = function();

See Also

VelocityDevice Class


VelocityDevice Methods

[image] [image]

.NET Framework Class Library
VelocityDevice Methods
VelocityDevice Class See Also Send Feedback

The VelocityDevice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDevice Class


VelocityDevice Properties

[image] [image]

.NET Framework Class Library
VelocityDevice Properties
VelocityDevice Class See Also Send Feedback

The VelocityDevice type exposes the following members.

Properties

Name | Description
DestEffect |
DestMax |
DestMin |
DestParameter |
IsActive |
IsSelected |
RunTimePresetA |
RunTimePresetB |
SelectedPresetIsModified |
SelectedPresetName |
SrcInstrument |
type |
VelocityMax |
VelocityMin |
VelocityScaling |

See Also

VelocityDevice Class


DestEffect Property

[image]

.NET Framework Class Library
VelocityDevice..::.DestEffect Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestEffect As DestEffect
C#
public DestEffect DestEffect { get; set; }
Visual C++
public:
property DestEffect^ DestEffect {
    DestEffect^ get ();
    void set (DestEffect^ value);
}
JavaScript
function get_destEffect();
function set_destEffect(value);

Remarks

See Also

VelocityDevice Class


DestMax Property

[image]

.NET Framework Class Library
VelocityDevice..::.DestMax Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestMax As VelocityDeviceDestMax
C#
public VelocityDeviceDestMax DestMax { get; set; }
Visual C++
public:
property VelocityDeviceDestMax^ DestMax {
    VelocityDeviceDestMax^ get ();
    void set (VelocityDeviceDestMax^ value);
}
JavaScript
function get_destMax();
function set_destMax(value);

Remarks

See Also

VelocityDevice Class


DestMin Property

[image]

.NET Framework Class Library
VelocityDevice..::.DestMin Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestMin As VelocityDeviceDestMin
C#
public VelocityDeviceDestMin DestMin { get; set; }
Visual C++
public:
property VelocityDeviceDestMin^ DestMin {
    VelocityDeviceDestMin^ get ();
    void set (VelocityDeviceDestMin^ value);
}
JavaScript
function get_destMin();
function set_destMin(value);

Remarks

See Also

VelocityDevice Class


DestParameter Property

[image]

.NET Framework Class Library
VelocityDevice..::.DestParameter Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestParameter As DestParameter
C#
public DestParameter DestParameter { get; set; }
Visual C++
public:
property DestParameter^ DestParameter {
    DestParameter^ get ();
    void set (DestParameter^ value);
}
JavaScript
function get_destParameter();
function set_destParameter(value);

Remarks

See Also

VelocityDevice Class


IsActive Property

[image]

.NET Framework Class Library
VelocityDevice..::.IsActive Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsActive As Boolean
C#
public bool IsActive { get; set; }
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

Remarks

See Also

VelocityDevice Class


IsSelected Property

[image]

.NET Framework Class Library
VelocityDevice..::.IsSelected Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property IsSelected As Boolean
C#
public bool IsSelected { get; set; }
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSelected();
function set_isSelected(value);

Remarks

See Also

VelocityDevice Class


RunTimePresetA Property

[image]

.NET Framework Class Library
VelocityDevice..::.RunTimePresetA Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetA As VelocityDeviceRunTimePreset
C#
public VelocityDeviceRunTimePreset RunTimePresetA { get; set; }
Visual C++
public:
property VelocityDeviceRunTimePreset^ RunTimePresetA {
    VelocityDeviceRunTimePreset^ get ();
    void set (VelocityDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetA();
function set_runTimePresetA(value);

Remarks

See Also

VelocityDevice Class


RunTimePresetB Property

[image]

.NET Framework Class Library
VelocityDevice..::.RunTimePresetB Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimePresetB As VelocityDeviceRunTimePreset
C#
public VelocityDeviceRunTimePreset RunTimePresetB { get; set; }
Visual C++
public:
property VelocityDeviceRunTimePreset^ RunTimePresetB {
    VelocityDeviceRunTimePreset^ get ();
    void set (VelocityDeviceRunTimePreset^ value);
}
JavaScript
function get_runTimePresetB();
function set_runTimePresetB(value);

Remarks

See Also

VelocityDevice Class


SelectedPresetIsModified Property

[image]

.NET Framework Class Library
VelocityDevice..::.SelectedPresetIsModified Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetIsModified As Boolean
C#
public bool SelectedPresetIsModified { get; set; }
Visual C++
public:
property bool SelectedPresetIsModified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_selectedPresetIsModified();
function set_selectedPresetIsModified(value);

Remarks

See Also

VelocityDevice Class


SelectedPresetName Property

[image]

.NET Framework Class Library
VelocityDevice..::.SelectedPresetName Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectedPresetName As String
C#
public string SelectedPresetName { get; set; }
Visual C++
public:
property String^ SelectedPresetName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedPresetName();
function set_selectedPresetName(value);

Remarks

See Also

VelocityDevice Class


SrcInstrument Property

[image]

.NET Framework Class Library
VelocityDevice..::.SrcInstrument Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SrcInstrument As Integer
C#
public int SrcInstrument { get; set; }
Visual C++
public:
property int SrcInstrument {
    int get ();
    void set (int value);
}
JavaScript
function get_srcInstrument();
function set_srcInstrument(value);

Remarks

See Also

VelocityDevice Class


type Property

[image]

.NET Framework Class Library
VelocityDevice..::.type Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

VelocityDevice Class


VelocityMax Property

[image]

.NET Framework Class Library
VelocityDevice..::.VelocityMax Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityMax As Integer
C#
public int VelocityMax { get; set; }
Visual C++
public:
property int VelocityMax {
    int get ();
    void set (int value);
}
JavaScript
function get_velocityMax();
function set_velocityMax(value);

Remarks

See Also

VelocityDevice Class


VelocityMin Property

[image]

.NET Framework Class Library
VelocityDevice..::.VelocityMin Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityMin As Integer
C#
public int VelocityMin { get; set; }
Visual C++
public:
property int VelocityMin {
    int get ();
    void set (int value);
}
JavaScript
function get_velocityMin();
function set_velocityMin(value);

Remarks

See Also

VelocityDevice Class


VelocityScaling Property

[image]

.NET Framework Class Library
VelocityDevice..::.VelocityScaling Property
VelocityDevice Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityScaling As VelocityDeviceVelocityScaling
C#
public VelocityDeviceVelocityScaling VelocityScaling { get; set; }
Visual C++
public:
property VelocityDeviceVelocityScaling VelocityScaling {
    VelocityDeviceVelocityScaling get ();
    void set (VelocityDeviceVelocityScaling value);
}
JavaScript
function get_velocityScaling();
function set_velocityScaling(value);

Remarks

See Also

VelocityDevice Class


VelocityDeviceDestMax Class

[image]

.NET Framework Class Library
VelocityDeviceDestMax Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceDestMax
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceDestMax
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceDestMax
JavaScript
NRenoiseTools.VelocityDeviceDestMax = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceDestMax');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceDestMax

See Also

VelocityDeviceDestMax Members


VelocityDeviceDestMax Members

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMax Members
VelocityDeviceDestMax Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceDestMax type exposes the following members.

Constructors

Name | Description
VelocityDeviceDestMax |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

VelocityDeviceDestMax Class


VelocityDeviceDestMax Constructor

[image]

.NET Framework Class Library
VelocityDeviceDestMax Constructor
VelocityDeviceDestMax Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceDestMax()
Visual C++
public:
VelocityDeviceDestMax()
JavaScript
NRenoiseTools.VelocityDeviceDestMax = function();

See Also

VelocityDeviceDestMax Class


VelocityDeviceDestMax Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMax Methods
VelocityDeviceDestMax Class See Also Send Feedback

The VelocityDeviceDestMax type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceDestMax Class


VelocityDeviceDestMax Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMax Properties
VelocityDeviceDestMax Class See Also Send Feedback

The VelocityDeviceDestMax type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

VelocityDeviceDestMax Class


MidiMappings Property

[image]

.NET Framework Class Library
VelocityDeviceDestMax..::.MidiMappings Property
VelocityDeviceDestMax Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

VelocityDeviceDestMax Class


Value Property

[image]

.NET Framework Class Library
VelocityDeviceDestMax..::.Value Property
VelocityDeviceDestMax Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

VelocityDeviceDestMax Class


Visualization Property

[image]

.NET Framework Class Library
VelocityDeviceDestMax..::.Visualization Property
VelocityDeviceDestMax Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As VelocityDeviceDestMaxVisualization
C#
public VelocityDeviceDestMaxVisualization Visualization { get; set; }
Visual C++
public:
property VelocityDeviceDestMaxVisualization Visualization {
    VelocityDeviceDestMaxVisualization get ();
    void set (VelocityDeviceDestMaxVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

VelocityDeviceDestMax Class


VelocityDeviceDestMaxRunTimePreset Class

[image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceDestMaxRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceDestMaxRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceDestMaxRunTimePreset
JavaScript
NRenoiseTools.VelocityDeviceDestMaxRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceDestMaxRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceDestMaxRunTimePreset

See Also

VelocityDeviceDestMaxRunTimePreset Members


VelocityDeviceDestMaxRunTimePreset Members

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset Members
VelocityDeviceDestMaxRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceDestMaxRunTimePreset type exposes the following members.

Constructors

Name | Description
VelocityDeviceDestMaxRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

VelocityDeviceDestMaxRunTimePreset Class


VelocityDeviceDestMaxRunTimePreset Constructor

[image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset Constructor
VelocityDeviceDestMaxRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceDestMaxRunTimePreset()
Visual C++
public:
VelocityDeviceDestMaxRunTimePreset()
JavaScript
NRenoiseTools.VelocityDeviceDestMaxRunTimePreset = function();

See Also

VelocityDeviceDestMaxRunTimePreset Class


VelocityDeviceDestMaxRunTimePreset Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset Methods
VelocityDeviceDestMaxRunTimePreset Class See Also Send Feedback

The VelocityDeviceDestMaxRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceDestMaxRunTimePreset Class


VelocityDeviceDestMaxRunTimePreset Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset Properties
VelocityDeviceDestMaxRunTimePreset Class See Also Send Feedback

The VelocityDeviceDestMaxRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

VelocityDeviceDestMaxRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
VelocityDeviceDestMaxRunTimePreset..::.Value Property
VelocityDeviceDestMaxRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

VelocityDeviceDestMaxRunTimePreset Class


VelocityDeviceDestMaxVisualization Enumeration

[image]

.NET Framework Class Library
VelocityDeviceDestMaxVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration VelocityDeviceDestMaxVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum VelocityDeviceDestMaxVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class VelocityDeviceDestMaxVisualization
JavaScript
NRenoiseTools.VelocityDeviceDestMaxVisualization = function();
NRenoiseTools.VelocityDeviceDestMaxVisualization.createEnum('NRenoiseTools.VelocityDeviceDestMaxVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


VelocityDeviceDestMin Class

[image]

.NET Framework Class Library
VelocityDeviceDestMin Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceDestMin
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceDestMin
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceDestMin
JavaScript
NRenoiseTools.VelocityDeviceDestMin = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceDestMin');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceDestMin

See Also

VelocityDeviceDestMin Members


VelocityDeviceDestMin Members

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMin Members
VelocityDeviceDestMin Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceDestMin type exposes the following members.

Constructors

Name | Description
VelocityDeviceDestMin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

VelocityDeviceDestMin Class


VelocityDeviceDestMin Constructor

[image]

.NET Framework Class Library
VelocityDeviceDestMin Constructor
VelocityDeviceDestMin Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceDestMin()
Visual C++
public:
VelocityDeviceDestMin()
JavaScript
NRenoiseTools.VelocityDeviceDestMin = function();

See Also

VelocityDeviceDestMin Class


VelocityDeviceDestMin Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMin Methods
VelocityDeviceDestMin Class See Also Send Feedback

The VelocityDeviceDestMin type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceDestMin Class


VelocityDeviceDestMin Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMin Properties
VelocityDeviceDestMin Class See Also Send Feedback

The VelocityDeviceDestMin type exposes the following members.

Properties

Name | Description
MidiMappings |
Value |
Visualization |

See Also

VelocityDeviceDestMin Class


MidiMappings Property

[image]

.NET Framework Class Library
VelocityDeviceDestMin..::.MidiMappings Property
VelocityDeviceDestMin Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property MidiMappings As MidiMapping()
C#
public MidiMapping[] MidiMappings { get; set; }
Visual C++
public:
property array<MidiMapping^>^ MidiMappings {
    array<MidiMapping^>^ get ();
    void set (array<MidiMapping^>^ value);
}
JavaScript
function get_midiMappings();
function set_midiMappings(value);

Remarks

See Also

VelocityDeviceDestMin Class


Value Property

[image]

.NET Framework Class Library
VelocityDeviceDestMin..::.Value Property
VelocityDeviceDestMin Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

VelocityDeviceDestMin Class


Visualization Property

[image]

.NET Framework Class Library
VelocityDeviceDestMin..::.Visualization Property
VelocityDeviceDestMin Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Visualization As VelocityDeviceDestMinVisualization
C#
public VelocityDeviceDestMinVisualization Visualization { get; set; }
Visual C++
public:
property VelocityDeviceDestMinVisualization Visualization {
    VelocityDeviceDestMinVisualization get ();
    void set (VelocityDeviceDestMinVisualization value);
}
JavaScript
function get_visualization();
function set_visualization(value);

Remarks

See Also

VelocityDeviceDestMin Class


VelocityDeviceDestMinRunTimePreset Class

[image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceDestMinRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceDestMinRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceDestMinRunTimePreset
JavaScript
NRenoiseTools.VelocityDeviceDestMinRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceDestMinRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceDestMinRunTimePreset

See Also

VelocityDeviceDestMinRunTimePreset Members


VelocityDeviceDestMinRunTimePreset Members

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset Members
VelocityDeviceDestMinRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceDestMinRunTimePreset type exposes the following members.

Constructors

Name | Description
VelocityDeviceDestMinRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value |

See Also

VelocityDeviceDestMinRunTimePreset Class


VelocityDeviceDestMinRunTimePreset Constructor

[image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset Constructor
VelocityDeviceDestMinRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceDestMinRunTimePreset()
Visual C++
public:
VelocityDeviceDestMinRunTimePreset()
JavaScript
NRenoiseTools.VelocityDeviceDestMinRunTimePreset = function();

See Also

VelocityDeviceDestMinRunTimePreset Class


VelocityDeviceDestMinRunTimePreset Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset Methods
VelocityDeviceDestMinRunTimePreset Class See Also Send Feedback

The VelocityDeviceDestMinRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceDestMinRunTimePreset Class


VelocityDeviceDestMinRunTimePreset Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset Properties
VelocityDeviceDestMinRunTimePreset Class See Also Send Feedback

The VelocityDeviceDestMinRunTimePreset type exposes the following members.

Properties

Name | Description
Value |

See Also

VelocityDeviceDestMinRunTimePreset Class


Value Property

[image]

.NET Framework Class Library
VelocityDeviceDestMinRunTimePreset..::.Value Property
VelocityDeviceDestMinRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Single
C#
public float Value { get; set; }
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

VelocityDeviceDestMinRunTimePreset Class


VelocityDeviceDestMinVisualization Enumeration

[image]

.NET Framework Class Library
VelocityDeviceDestMinVisualization Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration VelocityDeviceDestMinVisualization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum VelocityDeviceDestMinVisualization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class VelocityDeviceDestMinVisualization
JavaScript
NRenoiseTools.VelocityDeviceDestMinVisualization = function();
NRenoiseTools.VelocityDeviceDestMinVisualization.createEnum('NRenoiseTools.VelocityDeviceDestMinVisualization', false);

Members

Member name | Description
DontShow |
Deviceonly |
MixerandDevice |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


VelocityDeviceDeviceSlotRunTimePreset Class

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceDeviceSlotRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceDeviceSlotRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceDeviceSlotRunTimePreset
JavaScript
NRenoiseTools.VelocityDeviceDeviceSlotRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceDeviceSlotRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceDeviceSlotRunTimePreset

See Also

VelocityDeviceDeviceSlotRunTimePreset Members


VelocityDeviceDeviceSlotRunTimePreset Members

[image] [image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset Members
VelocityDeviceDeviceSlotRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceDeviceSlotRunTimePreset type exposes the following members.

Constructors

Name | Description
VelocityDeviceDeviceSlotRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestMax |
DestMin |
SrcInstrument |
type |
VelocityMax |
VelocityMin |
VelocityScaling |

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityDeviceDeviceSlotRunTimePreset Constructor

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset Constructor
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceDeviceSlotRunTimePreset()
Visual C++
public:
VelocityDeviceDeviceSlotRunTimePreset()
JavaScript
NRenoiseTools.VelocityDeviceDeviceSlotRunTimePreset = function();

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityDeviceDeviceSlotRunTimePreset Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset Methods
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The VelocityDeviceDeviceSlotRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityDeviceDeviceSlotRunTimePreset Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset Properties
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

The VelocityDeviceDeviceSlotRunTimePreset type exposes the following members.

Properties

Name | Description
DestMax |
DestMin |
SrcInstrument |
type |
VelocityMax |
VelocityMin |
VelocityScaling |

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


DestMax Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.DestMax Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestMax As VelocityDeviceDestMaxRunTimePreset
C#
public VelocityDeviceDestMaxRunTimePreset DestMax { get; set; }
Visual C++
public:
property VelocityDeviceDestMaxRunTimePreset^ DestMax {
    VelocityDeviceDestMaxRunTimePreset^ get ();
    void set (VelocityDeviceDestMaxRunTimePreset^ value);
}
JavaScript
function get_destMax();
function set_destMax(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


DestMin Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.DestMin Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DestMin As VelocityDeviceDestMinRunTimePreset
C#
public VelocityDeviceDestMinRunTimePreset DestMin { get; set; }
Visual C++
public:
property VelocityDeviceDestMinRunTimePreset^ DestMin {
    VelocityDeviceDestMinRunTimePreset^ get ();
    void set (VelocityDeviceDestMinRunTimePreset^ value);
}
JavaScript
function get_destMin();
function set_destMin(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


SrcInstrument Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.SrcInstrument Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property SrcInstrument As Integer
C#
public int SrcInstrument { get; set; }
Visual C++
public:
property int SrcInstrument {
    int get ();
    void set (int value);
}
JavaScript
function get_srcInstrument();
function set_srcInstrument(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


type Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.type Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityMax Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.VelocityMax Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityMax As Integer
C#
public int VelocityMax { get; set; }
Visual C++
public:
property int VelocityMax {
    int get ();
    void set (int value);
}
JavaScript
function get_velocityMax();
function set_velocityMax(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityMin Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.VelocityMin Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityMin As Integer
C#
public int VelocityMin { get; set; }
Visual C++
public:
property int VelocityMin {
    int get ();
    void set (int value);
}
JavaScript
function get_velocityMin();
function set_velocityMin(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityScaling Property

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePreset..::.VelocityScaling Property
VelocityDeviceDeviceSlotRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property VelocityScaling As VelocityDeviceDeviceSlotRunTimePresetVelocityScaling
C#
public VelocityDeviceDeviceSlotRunTimePresetVelocityScaling VelocityScaling { get; set; }
Visual C++
public:
property VelocityDeviceDeviceSlotRunTimePresetVelocityScaling VelocityScaling {
    VelocityDeviceDeviceSlotRunTimePresetVelocityScaling get ();
    void set (VelocityDeviceDeviceSlotRunTimePresetVelocityScaling value);
}
JavaScript
function get_velocityScaling();
function set_velocityScaling(value);

Remarks

See Also

VelocityDeviceDeviceSlotRunTimePreset Class


VelocityDeviceDeviceSlotRunTimePresetVelocityScaling Enumeration

[image]

.NET Framework Class Library
VelocityDeviceDeviceSlotRunTimePresetVelocityScaling Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration VelocityDeviceDeviceSlotRunTimePresetVelocityScaling
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum VelocityDeviceDeviceSlotRunTimePresetVelocityScaling
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class VelocityDeviceDeviceSlotRunTimePresetVelocityScaling
JavaScript
NRenoiseTools.VelocityDeviceDeviceSlotRunTimePresetVelocityScaling = function();
NRenoiseTools.VelocityDeviceDeviceSlotRunTimePresetVelocityScaling.createEnum('NRenoiseTools.VelocityDeviceDeviceSlotRunTimePresetVelocityScaling', false);

Members

Member name | Description
LogFast |
LogSlow |
Linear |
ExpSlow |
ExpFast |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


VelocityDeviceRunTimePreset Class

[image]

.NET Framework Class Library
VelocityDeviceRunTimePreset Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VelocityDeviceRunTimePreset
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VelocityDeviceRunTimePreset
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VelocityDeviceRunTimePreset
JavaScript
NRenoiseTools.VelocityDeviceRunTimePreset = function();

Type.createClass(
    'NRenoiseTools.VelocityDeviceRunTimePreset');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VelocityDeviceRunTimePreset

See Also

VelocityDeviceRunTimePreset Members


VelocityDeviceRunTimePreset Members

[image] [image]

.NET Framework Class Library
VelocityDeviceRunTimePreset Members
VelocityDeviceRunTimePreset Class Constructors Methods Properties See Also Send Feedback

The VelocityDeviceRunTimePreset type exposes the following members.

Constructors

Name | Description
VelocityDeviceRunTimePreset |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DeviceSlot |
type |

See Also

VelocityDeviceRunTimePreset Class


VelocityDeviceRunTimePreset Constructor

[image]

.NET Framework Class Library
VelocityDeviceRunTimePreset Constructor
VelocityDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VelocityDeviceRunTimePreset()
Visual C++
public:
VelocityDeviceRunTimePreset()
JavaScript
NRenoiseTools.VelocityDeviceRunTimePreset = function();

See Also

VelocityDeviceRunTimePreset Class


VelocityDeviceRunTimePreset Methods

[image] [image]

.NET Framework Class Library
VelocityDeviceRunTimePreset Methods
VelocityDeviceRunTimePreset Class See Also Send Feedback

The VelocityDeviceRunTimePreset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VelocityDeviceRunTimePreset Class


VelocityDeviceRunTimePreset Properties

[image] [image]

.NET Framework Class Library
VelocityDeviceRunTimePreset Properties
VelocityDeviceRunTimePreset Class See Also Send Feedback

The VelocityDeviceRunTimePreset type exposes the following members.

Properties

Name | Description
DeviceSlot |
type |

See Also

VelocityDeviceRunTimePreset Class


DeviceSlot Property

[image]

.NET Framework Class Library
VelocityDeviceRunTimePreset..::.DeviceSlot Property
VelocityDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceSlot As VelocityDeviceDeviceSlotRunTimePreset
C#
public VelocityDeviceDeviceSlotRunTimePreset DeviceSlot { get; set; }
Visual C++
public:
property VelocityDeviceDeviceSlotRunTimePreset^ DeviceSlot {
    VelocityDeviceDeviceSlotRunTimePreset^ get ();
    void set (VelocityDeviceDeviceSlotRunTimePreset^ value);
}
JavaScript
function get_deviceSlot();
function set_deviceSlot(value);

Remarks

See Also

VelocityDeviceRunTimePreset Class


type Property

[image]

.NET Framework Class Library
VelocityDeviceRunTimePreset..::.type Property
VelocityDeviceRunTimePreset Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

VelocityDeviceRunTimePreset Class


VelocityDeviceVelocityScaling Enumeration

[image]

.NET Framework Class Library
VelocityDeviceVelocityScaling Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration VelocityDeviceVelocityScaling
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum VelocityDeviceVelocityScaling
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class VelocityDeviceVelocityScaling
JavaScript
NRenoiseTools.VelocityDeviceVelocityScaling = function();
NRenoiseTools.VelocityDeviceVelocityScaling.createEnum('NRenoiseTools.VelocityDeviceVelocityScaling', false);

Members

Member name | Description
LogFast |
LogSlow |
Linear |
ExpSlow |
ExpFast |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.


VolumeNodes Class

[image]

.NET Framework Class Library
VolumeNodes Class
Members See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Class VolumeNodes
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public class VolumeNodes
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public ref class VolumeNodes
JavaScript
NRenoiseTools.VolumeNodes = function();

Type.createClass(
    'NRenoiseTools.VolumeNodes');

Remarks

Inheritance Hierarchy

System..::.Object
NRenoiseTools..::.VolumeNodes

See Also

VolumeNodes Members


VolumeNodes Members

[image] [image]

.NET Framework Class Library
VolumeNodes Members
VolumeNodes Class Constructors Methods Properties See Also Send Feedback

The VolumeNodes type exposes the following members.

Constructors

Name | Description
VolumeNodes |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

VolumeNodes Class


VolumeNodes Constructor

[image]

.NET Framework Class Library
VolumeNodes Constructor
VolumeNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VolumeNodes()
Visual C++
public:
VolumeNodes()
JavaScript
NRenoiseTools.VolumeNodes = function();

See Also

VolumeNodes Class


VolumeNodes Methods

[image] [image]

.NET Framework Class Library
VolumeNodes Methods
VolumeNodes Class See Also Send Feedback

The VolumeNodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeNodes Class


VolumeNodes Properties

[image] [image]

.NET Framework Class Library
VolumeNodes Properties
VolumeNodes Class See Also Send Feedback

The VolumeNodes type exposes the following members.

Properties

Name | Description
Length |
PlayMode |
Points |
ValueQuantum |

See Also

VolumeNodes Class


Length Property

[image]

.NET Framework Class Library
VolumeNodes..::.Length Property
VolumeNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
C#
public int Length { get; set; }
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

VolumeNodes Class


PlayMode Property

[image]

.NET Framework Class Library
VolumeNodes..::.PlayMode Property
VolumeNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property PlayMode As VolumeNodesPlayMode
C#
public VolumeNodesPlayMode PlayMode { get; set; }
Visual C++
public:
property VolumeNodesPlayMode PlayMode {
    VolumeNodesPlayMode get ();
    void set (VolumeNodesPlayMode value);
}
JavaScript
function get_playMode();
function set_playMode(value);

Remarks

See Also

VolumeNodes Class


Points Property

[image]

.NET Framework Class Library
VolumeNodes..::.Points Property
VolumeNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property Points As String()
C#
public string[] Points { get; set; }
Visual C++
public:
property array<String^>^ Points {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_points();
function set_points(value);

Remarks

See Also

VolumeNodes Class


ValueQuantum Property

[image]

.NET Framework Class Library
VolumeNodes..::.ValueQuantum Property
VolumeNodes Class See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueQuantum As Single
C#
public float ValueQuantum { get; set; }
Visual C++
public:
property float ValueQuantum {
    float get ();
    void set (float value);
}
JavaScript
function get_valueQuantum();
function set_valueQuantum(value);

Remarks

See Also

VolumeNodes Class


VolumeNodesPlayMode Enumeration

[image]

.NET Framework Class Library
VolumeNodesPlayMode Enumeration
See Also Send Feedback

Namespace: NRenoiseTools
Assembly: NRenoiseTools (in NRenoiseTools.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")> _
Public Enumeration VolumeNodesPlayMode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("XsdRenoiseParser", "1.0.1.0")]
public enum VolumeNodesPlayMode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"XsdRenoiseParser", L"1.0.1.0")]
public enum class VolumeNodesPlayMode
JavaScript
NRenoiseTools.VolumeNodesPlayMode = function();
NRenoiseTools.VolumeNodesPlayMode.createEnum('NRenoiseTools.VolumeNodesPlayMode', false);

Members

Member name | Description
Linear |
Points |
Curve |

Remarks

See Also

NRenoiseTools Namespace
Send feedback on this topic to Microsoft.