About your Norton Account

Registering your product by creating your own Norton Account lets you manage all of your Norton products in one place at www.myNortonAccount.com. From your Norton Account, you can download latest versions and reinstall your Norton products if an original is lost or damaged.

It will only take a few moments to create your Norton Account.


Managing your product registration by using a Norton Account

The Product Key for each Norton product is conveniently stored in your Norton Account and you can easily find and update your account and billing information.

Symantec products that are older than the 2006 product year do not appear in your Norton Account.


About registering your product

It is recommended that you register your Norton product now. It only takes a few minutes. While registering, you will be asked to create or sign in to your Norton Account. This is where your Product Key is stored for each product. It is also where you can find your account and billing information for your products and services.

From your Norton Account, it's easy to reinstall your Norton products, download latest versions, and buy additional Product Keys for your home or office.