Security protection features

Norton Internet Security includes a suite of security tools that help keep your computer safe from security risks.

Security protection features include:

Personal Firewall | Protects your computer from Internet attacks, port scans, and other suspicious behavior. Managing the Personal Firewall
Intrusion Prevention | Scans each piece of information that enters and exits your computer and automatically blocks any Internet attacks. About Intrusion Prevention
Security Inspector | Scans your computer for settings that can compromise security. About Security Inspector
Trust Control | Detects when your computer connects to a new network. You can then allow or block connections from all computers that are connected to that network. About Personal Firewall Trust Control options