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�
Changes in release 2.0





Fixed the folder browser so that it now correctly handles folders that are on the desktop.


Added a “Clear Folder History” command to the File menu.


The last selected folder is now moved to the top of the folder history drop-down list so that most recently used folders are always near the top.


When typing into the folder history list, the program now waits for the user to press Return before responding. This prevents annoying problems with the focus shifting while you are still typing.


The New Folder window has been improved by allowing the user to type only the folder name required under the current folder. It gives you a preview of the full folder name it will create and automatically creates the correct folder.


The program has now been confirmed to work on Windows NT 4.


Completed the online help files.


�
The List of known problems can now be found in the main help file.


�
Changes in release 2.0 (Beta 4)





Added a check box to Folder Preferences, ‘Keep the custom sort file in the same folder as the images’. If this box is checked, the custom sort-order information will be kept in the image folder in a file called Pmio custom sort.txt. This allows you to copy or rename the image folder without losing the custom sort-order.


Added a check box to the Thumbnail Wizard (on the Customise HTML Body Window) - ‘Generate links to original images’. This is usually checked, but can be unchecked to make web pages of thumbnails with no image links in them.


Added a drive icon and write-protect indication to the Preferences Window.


Changed the ‘Auto Update’ function so that the thumbnails are updated whenever something changes in the folder even if the change happened outside of PMIO. This occurs for example if files or folders are copied, moved or deleted in Windows Explorer.


The folder browser and shortcut list are now updated whenever a removable disk is inserted or removed. (Note: Some removable drives such as floppies do not notify the system of media changes, whereas others like CD drives do).


Changed the Rename Window so that the user cannot modify the file extension. Also added more error-checking for invalid input characters.


In the Thumbnail Appearance Window, you can now change the thumbnail size, spacing and sharpness by using an edit box and spinner as well as the original slider control.


Enhanced the ‘Feedback’ command by making it possible to cancel it. It also asks if you are reporting a bug, and only attaches registry information if so. Also made it so that the program still runs even if MAPI32.DLL is not available.


Moved the ‘Sequential Rename’ command from the File menu to the Image menu.


Added a new edit box to Folder Preferences which allows you to specify a list of strings separated by semicolons. Any image files whose names start with one of these strings will be ignored by the browser. The default is “tn_” which makes it ignore the Thumbnail Wizard output files. By clearing this box you can make the browser show all files including Thumbnail Wizard output files.


Added AVI support. The browser can now display thumbnails for AVI files, and the Internal Viewer can play them. Although the program cannot create thumbnails for other movies (e.g. MPEG) the Internal Viewer can still play them because it uses the standard Windows media player. Use the ‘Additional file types’ preference to enable this. Although the thumbnails won’t load, you can still open them in the Internal Viewer.


Added a new command ‘Save As Movie’ to the Image menu. You can use this to create animated files of selected thumbnail sequences (AVI format only, at the moment).


Added a ‘Save As Movie’ command to the Animation Window. This allows the animation to be saved to a file (AVI format only, at the moment).


Added a “Rewind” command to the Animation Window. This rewinds to the first frame.


Added a new option to Application Preferences where you can specify the application to use for text files. This is designed to help users who are having trouble with spaces or long filenames on some text editors. You can have PMIO use a different editor without having to change your .txt association.


�
Changes in release 2.0 (Beta 3)





Fixed a bug which caused the program to repeatedly display an error message if one of the applications in Preferences/Applications could not be found.


Added code that should disable certain file system error messages (such as when a disk drive or file is not found) on Windows NT. This does not affect Windows 95/98.


Fixed the Drive Information Window’s display for drives with a capacity of over 2GB.


Fixed the Drive Information Window’s ‘Open Folder’ button which had been accidentally broken by a change in Beta 2.


Fixed the logic that determines when thumbnails can be saved, which had been accidentally broken by a change in Beta 2.


Fixed a bug where sorting would mess up the selection state.


Improved the Batch Engine’s “Time remaining” display.


Tidied a few user-interface items and keyboard shortcuts.


�
Changes in release 2.0 (Beta 2)





Added a ‘Safe Saves’ option to the Thumbnail Wizard. When checked, this option causes the wizard to ask if you want to overwrite existing HTML files.


The Sequential Rename command is now disabled while thumbnails are loading.


The folder browsers now allow the user to select non-valid folders such as ‘Printers’, making it easier to navigate using the keyboard.


The ‘Browse For Folder’ window now shows the selected folder and disables the OK button when a non-valid folder is selected.


The Thumbnail Wizard now generates the correct image links when the HTML file and images are in different folders. 


Changed the ‘Do Not Sort’ option to ‘Custom Sort’. Everything works as before except that now the custom sort state is remembered for each folder. This information is saved in a text file which means it will survive deletion of the browse file and can also be backed-up and edited manually. The information is saved whenever the user drags thumbnails or uses the ‘Move To Top’ function.


Added a button to Folder preferences that allows the user to manually edit the custom sort list. This lets you use your default text editor to rearrange the thumbnail order and make backups of the list if you want.


Added a ‘Move To Top’ function which allows the user to quickly move the selected thumbnails to the top of the list. This automatically switches the sort mode to ‘custom’.


Added File System information to the Drive Info window.


Changed the ‘Disable floppy drives’ preference to ‘Enable floppy A’ and ‘Enable floppy B’.


Enhanced and fixed a few bugs in the Shortcut Window.


Added a ‘Feedback’ option to the Help menu. This automatically opens an email ready to be sent with attached registry information to help the bug-solving process. The user just has to type in a description of the bug and send the email.


Added a Folder Manager window. This is an advanced facility which allows the user to minimise waste space by removing unused browse files and registry entries. It also allows folder preferences to be copied to other folders or reset to ‘factory’ settings.


Added a ‘Delete Folder’ command to the main browser File menu. This is also accessible from the folder browser.


Added some keyboard shortcuts to various menus, especially on the Basket Window.


Toolbar buttons are now consistently flat throughout the program.


The Batch Engine now sorts the thumbnails before saving them.


Added a ‘Time remaining’ display to the Batch Engine.


Fixed a bug which sometimes caused a thumbnail to have the wrong aspect-ratio and therefore show a squashed image.


Fixed an Access Violation that happened if the user dragged thumbnails while an information window was being displayed for one of those thumbnails.


Fixed an Access Violation that happened if the user quickly changed folders by using the keyboard in the folder tree.


Fixed a bug which sometimes caused the program to hang if the user double-clicked on an unloaded thumbnail. This was related to multithreading and timing.


Fixed a bug that would occur if an incomplete browse file was loaded. This could happen if the program was forcibly aborted while saving, resulting in an incomplete browse file for the next run.


Fixed a bug which caused a few options to be stored in the wrong place in the registry.


Fixed a problem where the browser’s drop-down list lost the keyboard focus while the user was still typing into it.


Fixed a bug which prevented keyboard navigation in the Thumbnail Panel. You can use the arrow keys, Home/End, Page Up/Page Down to select thumbnails, in conjunction with the shift key to select a run, similar to Explorer. Pressing Return opens the selected images.


Changed the caption of the Find Similar Images window which was wrong (it read “Find Similar Thumbnails”).


Added a few more icons to the executable. You can choose from these by using Windows Explorer. Right-click on a program shortcut and choose Properties. Then click the Shortcut tab and click ‘Change Icon’.


�
Changes in release 2.0 (Beta 1)





The thumbnail pictures are now shared among different parts of the program. The program maintains a memory-cache of recently used thumbnails which increases performance when accessing thumbnails that have been used before or are currently in use. This cache can be configured in a new preferences tab, Cache. This major program change meant that I had to totally revise the browse file format. Therefore you will now find that all existing browse files are invalid and will be ignored. You may have to press ‘Update’ to ‘wake up’ a folder if nothing appears to be happening. Sorry for the inconvenience that this will undoubtedly cause. (This will not affect you if you have never used PMIO prior to version 2.0).


Previous versions of PMIO stored both the JPEG version of the thumbnail and the bitmap version in memory all the time. This used up a lot of memory when there were many large thumbnails. Now, the bitmap is dynamically created from the JPEG data whenever it is needed. This slows down thumbnail drawing but uses far less memory. There is an option in the Cache preferences to cache the bitmap data for more speed. You can use this option if you have memory to burn and want to go faster, or if you are using a slow computer.


The thumbnail panel now has a user-definable texture, and there is a new preferences page called Panel that allows you to set the texture and colour. The texture can also be set to the selected image from the browser’s Image menu.


Although previous versions of PMIO used multithreading to load thumbnails in the background, the program was not completely thread-safe. This means it was quite likely to crash at random, and probably accounts for some rare and weird behaviour that I could never figure out. This has now been corrected and the program can run many threads at the same time while sharing the same thumbnails.


Changed the save/auto-save system to be more simple. Previously it was overcomplicated and tried to be clever and only save if a time period had elapsed, etc. This turned out to be annoying (at least for me) so I got rid of it. It now allows you to save (or auto-saves) if there has been any change to the thumbnails.


The ‘Do you want to save…’ query now has a Cancel button.


The thumbnails can now be sorted even when they are not all loaded yet. If the information required for sorting is not yet available, those thumbnails go to the end of the list.


The sort options are now also available from the main menu.


The Thumbnail Wizard has been enhanced. You can now change the output folder for the HTML and thumbnail files. You can insert a formatted heading and folder-specific HTML code. The HTML body can be customised; you can specify a border size for the thumbnails, a formatted ALT parameter, and output WIDTH and HEIGHT parameters. The edit boxes have been replaced with drop-down lists that maintain a history of entries. Note that some of the items have been moved around on the wizard dialogs. Previously, the HTML file name kept reverting to ‘untitled.htm’. This was actually a bug, and has now been corrected.


�
Added an audio feedback option to General Preferences. The sounds can be configured from the Control Panel’s “Sounds” dialog in Windows.


Added a show thumbnail info when selection colour clicked option to General Preferences. This means that if you select a thumbnail and then click on the selection colour (the area around the little picture) a box will appear giving thumbnail information. To remove the box, just click on a different thumbnail or on the thumbnail panel.


The Preferences Window no longer has tabs, but uses a tree control to select the different pages. This is to allow for future enhancement without having dozens of confusing tabs.


Replaced the Windows standard scroll bars with custom-written ones. This fixes the limitation on the number of thumbnails that can be displayed. As far as I’m concerned, you can now create as many thumbnails as you like in the same folder, and it will work if you have enough memory. These new scroll bars have user-configurable arrows and they can be configured in General Preferences. In addition, the scroll bars now accept key presses when they have the keyboard focus.


The browser now scrolls as needed during thumbnail drag and drop operations.


Added a new File Name Collision window to make it easier to recover from name collisions when copying and moving files.


The standard Rename function is now available from the Basket Window.


Deleting a file from the basket now uses the ‘Confirm Deletion’ dialog (if enabled).


Added a ‘Clear’ button to the Properties window.


Added some more sorting options, average hue and average saturation.


Added a Memos sub-menu to the Image menu. The Export Memos command has been moved here, and there is now a new command, Delete All Memos.


Added support for removable volumes and shared network folders. It is very important to remember that when you change a removable volume, such as a CD-ROM, you must execute the Update command (i.e. press F5) so that the program updates its drive information. Failure to do this can cause all kinds of weird problems including but not limited to confused preferences.


Browse files can now be moved to a folder other than the folder containing the images, and therefore CD-ROMS can now be conveniently used with the program. You can specify a default folder to store browse files in, with the option to always put new browse files in that folder, or only when the volume is write-protected or on a network. This means that you can create one special folder and arrange that all browse files go into that folder, thus minimising folder clutter.


Added a new preferences tab, Disk. Here you can specify the default folder to put thumbnails in, and also specify any drives that you want to protect from being written to by the program (e.g. a CD writer). It also enables you to disable the floppy disk drive. The latter option prevents annoying ‘drive grinding’ when you Update (F5).


Added an Apply button to the preferences window and removed the Sort Now button; applying the changes does a sort anyway.


�
Added a Drive Info command to the File menu which gives information about the disk drives in the system. See below for a known problem with this.


Added a Batch Engine window which allows you to bulk-create thumbnails in the background while still using other parts of the program.


Added a Sequential Rename command to the File menu which allows you to rename the selected images with ascending numbered names.


Added a ‘Drive Info’ button to the Copy To / Move To / New Folder windows.


Added a new thumbnail label format specifier, %g, which gives the file name of an image without the extension.


Added a Folder Properties command to the File menu. This allows you to set a standard memo and a HTML memo for the folder and also displays other information about the folder. The Thumbnail Wizard uses the HTML memos when creating HTML documents.


The Copy To / Move To windows now display information about the amount of data to be transferred and also advise you if the files will fit on the destination drive, taking into account the cluster size of the destination drive.


Added a second image finder window, Find Similar Images. This allows you to search in the open browsers for thumbnails that look similar to the single currently selected thumbnail. The function uses ‘fuzzy logic’ to scan the images and compare the trends in changes from bright to dark areas. The algorithm is experimental, but gives quite good results (sometimes). I will continue to think about it and develop it for future versions. My ultimate aim is to be able to say something like ‘Find pictures of frogs’. I doubt that this will ever come to light.


The Properties window can now be shown by pressing Shift+P.


The Properties window ‘Skip’ button is now disabled when there is only one image selected.


The status line now displays the current sort method and the number of selected images, together with the total file size selected, and information about which drives have enough space to take a copy of the selected images.


The ‘New Folder’ command no longer opens the folder just created (which was actually quite annoying and totally pointless).


The size display (e.g. 1.2MB) now has three significant digits (e.g. 1.25MB). It now also displays gigabytes (GB) instead of thousands of megabytes.


Added a main menu and status bar to the basket window.


There are now four small toolbars instead of two large ones, and they can be docked at all four edges of the browser window.


Replaced the folder text box with a drop-down list that maintains a history of folders that have been recently visited. This includes folders that were navigated to by use of the folder browser, not just the drop-down list itself.


Removed the “Load Now” menu option. Unloaded thumbnails begin to load automatically when you select them.


Changed the popup menus for the thumbnail panel. Clicking on the panel (but not on a thumbnail) now gives a new menu with some useful commands, one of which is Priority. This allows you to set the priority of the thumbnail loading/saving process relative to other browsers or the Batch Engine.


�
Added functions to the internal viewer for brightness/contrast/blur/sharpen/rotate and saving.


Fixed the ‘Internal Program Error’ bug-from-hell.


Fixed very weird behaviour in the ‘Show Hidden’ command on the directory tree panel.


Fixed a bug that confused the save system when more than one browser was open for the same folder.


Fixed a long-standing bug in the Preferences window which caused the thumbnail size to be displayed incorrectly in the edit box.


Fixed a long-standing bug which caused a flickering mouse pointer under certain circumstances.


Fixed a long-standing bug in which the thumbnails would appear corrupted under certain circumstances. This was caused by the program sometimes using the wrong value for thumbnail size.


Fixed the program icon which accidentally disappeared in version 1.2


Fixed a few problems in the installer. Made the uninstaller available from the Control Panel’s “Add/Remove Programs” dialog in Windows.


Fixed a refresh problem after setting the memo in the Properties window.


Fixed some incorrect tooltips and typos.


Fixed the silly tab order of several windows.


Improved the Splash / About Box.


Improved some icons.


�
Changes in release 1.2





Added an internal image viewer.


Added Open With menus to the browser and basket windows.


Added a new Preferences Tab called ‘Applications’ which allows you to specify a list of applications that can be used to open images from the new Open With menus.


Added a ‘Show Hidden’ option to the folder browser.


Added the ability to drop files from Explorer onto the basket window.


Added a new command to the basket window, Open Browser, which lets you open a browser for the folder where each selected image is located.


Minimised browser windows now display percentage complete in task bar icons when loading thumbnails.


Added an Image Finder which allows you to quickly find images in any browser or the basket.


Fixed a bug which caused new thumbnails to be displayed with 100% quality until they had been saved and re-loaded at least once.


Fixed a bug in the HTML Wizard which caused thumbnails for non-JPEG files to be saved as JPEGs with a non-JPEG extension.


Fixed a bug in the browse file routines which ignored disk errors. Now errors are reported instead of being ignored.


Fixed a very nasty crash bug which occurred when loading very long thin pictures.


Replaced the splash screen and thumbnail size pictures. This is because I just realised that I may have inadvertently used a copyrighted image. I can now safely state that all images in the program were created by myself, using a digital camera and registered image processing software.


Made a few optimisations and fixed a few minor bugs.


Updated the help file.


�
Changes in release 1.1





The program has now been verified to work on Windows 98.


Added new thumbnail label format specifiers. %p gives the pixel size of the image, %b gives the bit-depth, and %d gives the date stamp.


Added a new option to the General Preferences tab, Label Thumbnails. This enables you to use format specifiers to make a label for each thumbnail on the thumbnail panel. This option is only useful when the thumbnails are large enough to accommodate the text.


Changed 'Size' in thumbnail display to show the more compact 52KB format instead of 52,124 for example.


Changed the browse file format. All existing browse files will automatically be recreated in the new format.


Changed status during loading to show the image number, total number of images to load, and percentage complete.


Fixed a bug where resizing the directory tree did not relay the thumbnails when it was supposed to.


Fixed a bug in the Thumbnail Wizard which appended a space to each memo line and caused problems with long lines.


Added a new option to the Thumbnail Wizard, UNIX compatible paths, which causes all filenames to be output using the ‘/’ slash instead of ‘\’. This option is on by default.


Made the annoying “cannot sort” message optional.


Changed the JPEG quality preview to use a file called quality.bmp in the PMIO directory. You can replace this if you want to use a different picture. The bitmap in this file should be about 140x128 pixels in size. Users of V1.0 can delete quality.jpg.


Fixed a very rare bug with 'error in date format'.


Made various other minor changes to the code.


�
Changes in release 1.0





This release is for Windows 95 only. This is due to a bug in the directory list view that only appears when running under NT. I will be unable to solve this bug until someone who runs NT and C++Builder can help me. I decided not to delay releasing the program any further, and make it Windows 95 only for now. Please note that although it has not been tested on Windows 98, I expect it to work on that too.


Added automatic installation and uninstallation support.


Added support for dragging a browse file onto the browser, and double-clicking a browse file to launch the program.


Fixed a rare crash bug in drag and drop over shortcuts.


Updated the help file.


�
Changes in Beta 1.11





Fixed a bug in which many things went badly wrong if the default thumbnail size was changed after creating some browse files.





Changes in Beta 1.10





Added a new function to export image memos to text files.


Added a "Set as Wallpaper" function.


Help files are now finished.





Changes in Beta 1.9





Thumbnail set and HTML page generation has now been implemented.


Made a few minor cosmetic changes in various parts of the program.





Changes in Beta 1.8





Significantly reduced the size of the browse file by saving JPEG versions of the thumbnails instead of raw image data. The thumbnail quality is controlled by the JPEG preferences.


Removed 256-colour thumbnail support. There is now no need for it as the only reason it was there in the first place was to reduce the browse file size.


Enhanced the thumbnail quality by resampling the original image rather than simply resizing it. This can be a bit slow so it is an option in the Folder preferences.





Changes in Beta 1.7





Explorer-style tree-view browser.


Changed preferences to use a tabbed property-sheet. Added a JPEG preferences page.





